长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

使用静态路由的PPPoA会话终止:使用aal5ciscoppp的xDSL到Cisco 6400 UAC

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

此配置示例启用PC连接对Cisco 677非对称数字用户线(ADSL)路由器通过Cisco 6130高级数字用户线路接入复用器(ADSLAM)连接到单个或多个Cisco通用接入集中器(UAC)。此配置使用的特定设备没有要求。例如,您能用Cisco 678替换Cisco 677。

此配置示例有对ADSL rollout是普通在Cisco 677启用的一些个功能。这些功能是网络地址转换(NAT)、端口地址转换(PAT)和动态主机配置协议(DHCP)。这些功能允许cookie截断器转出。因为所有方框有相同的配置,有rollout和文档的巨大成本减少。

您能复制和插入思科基于IOS�的节点路由处理器的代码和Node Switch Processor (NSP)到您的配置。然而, Cisco 677使用Cisco宽带操作系统(CBOS),并且您不能复制和插入此代码。您使用配置Cisco 677的命令在此配置示例方面也包括。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

硬件

  • PC或工作站

  • Cisco 677 ADSL客户端前置设备(CPE)

  • 您的本地Telco的ADSL服务

  • 与NI-2的Cisco 6130 ADSLAM, ATU-C DMT-II

  • 有1个x NRP和1个x NSP的Cisco 6400 UAC

软件

  • Cisco 6400 UAC NRP的Cisco IOS软件版本12.0.7-DC

  • Cisco 6400 UAC NSP的Cisco IOS软件版本12.0.7-DB

  • Cisco 677 ADSL路由器的CBOS版本2.3.0.012

  • Cisco 6130 ADSLAM的Cisco IOS软件版本12.0.8-DA1

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

在此部分,您可以看到本文所描述功能的配置信息。

注意: 为了找到关于用于本文的命令的其他信息,参考命令查找工具(仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/12851/6400dsl_pppoa_stat.gif

配置

配置注释

您必须配置允许测试用户连接的一个永久性虚拟连接(PVC)在Cisco 6130。当您配置在NSP的PVP并且终止NRP的时PPP会话,在Cisco 6400必须记录虚拟路径标识符/虚拟信道标识符(VPI/VCI)配置。

此配置示例显示NSP的虚拟路径。此路径允许Cisco 6400穿过从ADSLAM的信元到终结路由器,或者到另一台ATM交换机。您能设置PVP换成ATM信元公司网络或ISP,不用PPP会话的终端在中心局查找的Cisco 6400。

此配置示例允许远程用户透明访问对他们的公司网络(如果他们连接)电子邮件,共享文件/打印,企业内部网和对Web浏览的互联网,等等。没有使用企业互联网连接。

当多条PVC在Cisco 677时配置,是可能的对路由流量通过每个PVC。ADSLAM和UAC-NSP路由/换成的配置这些PVC正确目的地、ISP/ASP或者公司, PPP能终止。此配置减少流量和从而增加在公司网络的可用的带宽并且使用当前ISP帐户为了运载Web流量。

本文档使用以下配置:

PC配置
设置IP寻址,以便自动地获取IP地址。设置WINS,以便使用DHCP WINS解决方法。保证没有设置默认网关。因为DHCP不能通过此信息,设置域名可以是必要的。

Cisco 67x CPE (show run)
[[ IP Routing = Section Start ]]
IP NAT = enabled
IP Port Address = 00, 172.22.10.254
IP Default Route for Unnumbered Links = 002, 01, 0
IP Static Route Table Entries for Unnumbered Links = 172.22.32.0, 001, 255.255.2
55.0, 1, 0;
[[ CBOS = Section Start ]]
NSOS Maximum Number of VCs = 2
NSOS Root Password = <
root password
>
NSOS Enable Password = <
enable password
>
[[ PPP Device Driver = Section Start ]]
PPP Port User Name = 00, <
username for wan0-0
>
PPP Port User Password = 00, <
password for wan0-0
>
PPP Port User Name = 01, <
username for wan0-1
>
PPP Port User Password = 01, <
password for wan0-1
>
PPP Port Option = 01, IPCP,IP Address,3,Auto,Negotiation Not Required,Negotiable
,IP,0.0.0.0
[[ DHCP = Section Start ]]
DHCP Server = enabled
DHCP Server Pool IP = 00, 172.22.10.0
DHCP Server Pool Gateway = 00, 172.22.10.254
[[ ATM WAN Device Driver = Section Start ]]
ATM WAN Virtual Connection Parms = 00, 1, 32, 0
ATM WAN Virtual Connection Parms = 01, 2, 63, 0

命令发出到Cisco 67x CPE
cbos#set nat enabled
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos#set int wan0 maxvcs 2
You must use "write" and reboot for changes to take effect.

cbos#write
NVRAM written.

cbos#reboot
 Hello! Expanding CBOS image...
CBOS v2.3.5.012 - Release Software
User Access Verification
Password:<
root password
>

cbos>en
Password:<
enable password
>

cbos#set ppp wan0-0 login <username for wan0-0>
User name for wan0-0 has been set to router.

cbos#set ppp wan0-0 password <password for wan0-0>
Password for wan0-0 has been set to <password for wan0-0>

cbos#set ppp wan0-1 login <username for wan0-1>
Password for wan0-1 has been set to <username for wan0-1>

cbos#set ppp wan0-1 password <password for wan0-1>
Password for wan0-1 has been set to <password for wan0-1>

cbos#set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos#set ppp wan0-1 ipcp 0.0.0.0
PPP wan0-1 IPCP Address set to 0.0.0.0

cbos#set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos#set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0
You must use "write" then reboot for changes to take effect

cbos#set dhcp server enable
DHCP Server enabled

cbos#set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos#set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0
Size of pool 0 is automatically changed to max size 252

cbos#set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos#set password exec <root password>
Exec Password Change Successful! 

cbos#set password enable <enable password>
Enable Password Change Successful! 

cbos#set route default wan0-1
Default Route set

cbos#set route add ip 172.22.32.0 mask 255.255.255.0 gw wan0-0
Route added
cbos#set int wan0-0 close
Closing connection wan0-0

cbos#set int wan0-1 close
Closing connection wan0-1

cbos#set int wan0-0 vpi 1
Change completed.

cbos#set int wan0-0 vc1 32
Change completed.

cbos#set int wan0-1 vpi 2
Change completed.

cbos#set int wan0-1 vci 63
Change completed.

cbos#set int wan0-0 open
Opening connection wan0-0

cbos#set int wan0-1 open
Opening connection wan0-1

cbos#write
NVRAM written

cbos#reboot

61xx ADSLAM
interface ATM 1/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1 32 int atm 0/1 40 40
 pvc 2 63 int atm 0/1 50 51

6400 NSP (slot 8)
interface ATM 8/0/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvp 40 interface ATM 1/0/0 40
 atm pvp 50 interface ATM 2/0/0 50

6400 NRP (slot 1)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-0> password <password for wan0-0>
!
!
interface ATM 0/0/0.200 multipoint
 no ip directed-broadcast
 pvc 40/40 
  encapsulation aal5ciscoppp Virtual-Template 2
!
!
interface FastEthernet 0/0/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name A>
 ppp authentication pap
!
!
ip local pool <pool name A> 172.22.40.25 172.22.40.50

6400 NRP (slot 2)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-1> password <password for wan0-1>
!
!
interface ATM 0/0/0.300 multipoint
 no ip directed-broadcast
 pvc 50/51 
  encapsulation aal5ciscoppp Virtual-Template 21
!
!
interface FastEthernet 0/0/0
 ip address 172.16.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 21
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name B>
 ppp authentication pap
!
!
ip local pool <pool name B> 172.16.100.10 172.16.100.25

验证

本部分提供的信息可帮助您确认您的配置是否可正常运行。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

在Cisco 675 CPE上使用这些指令:

  • show interface wan0 — shows培训了ADSL链路的速度。

  • show interface wan0-0 —显示关于wan0-0的PPP会话信息。

  • show interface wan0-1 —显示关于wan0-1的PPP会话信息。

  • show dhcp server pool 0 —在客户端站点显示DHCP信息。

请使用此on命令Cisco 6400 UAC :

  • show atm pvc —显示正确PVC是否设立。

故障排除

本部分提供的信息可用于对配置进行故障排除。

使用在Cisco 6400 UAC的这些指令:

  • debug ppp协商—表示PPP协商调试消息。

  • debug ppp authentication —,如果客户端通过验证,显示。

  • debug ppp error -显示与PPP连接协商和运行有关的协议错误和错误统计数据。

在您尝试其中任一个调试指令前,参考关于调试指令的重要信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12851