长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

Cisco 7200 宽带聚合配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 9 日) | 反馈


目录


简介

本文如何提供数字用户线路DSL组件一般描述和在一个基本DSL实施组合的组件。在本文的配置示例显示正在使用中的最普通的DSL网络。您能作为一般参考使用这些配置设计宽带汇聚实施。然而,请勿观看这些配置作为Cookie剪切解决方案。每客户和每个需求不同的,并且有许多方式实现同样设计目标。

当在本文的配置尽可能全时地是,本文给仅重要线路。本文假设,用户有Cisco设备配置基本的了解并且省略许多基本命令行。仅请使用这些配置作为起点设计您自己的实施。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

PPPoA会话终止:xDSL到7200

网络图

本部分使用以下网络设置:

7200_bdaggreg1.gif

配置

此示例描述如何连接Cisco 677,或者其他DSL客户端前置设备(CPE),到Cisco7200通过PPP over ATM (PPPoA)。配置包括Cisco lightstream 1010 (LS1010) ATM交换机,是一个可选组件。如果直接地连接DSL Access Multiplier (DSLAM)对Cisco7200,结果是相同的。

在本例中,您在Cisco7200建立Cisco 677的PPP会话并且终止。在会话的终端以后,传统IP通过流量对网络服务提供商(NSP)或到互联网。

CPE有进行一的配置网络地址转换(NAT)/端口地址转换(PAT)。CPE也实现DHCP服务器分配IP地址对以太网站点。

本部分使用以下配置:

PPPoA的PC配置
  1. 设置IP寻址自动地获取IP地址。
  2. 设置WINS为WINS resolution使用DHCP。
  3. 保证没有设置默认网关。

注意: 如果DHCP不可能通过此信息,您需要设置域名。

PPPoA的Cisco CPE配置
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

PPPoA的Cisco DSLAM配置
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 atm pvc 1 32 interface atm0/1 1 35

思科PPPoA的LS1010配置
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

PPPoA的Cisco7200配置
aaa new-model
AAA authentication ppp default local
!
!
username password 
!
!
interface ATM 2/0.1 multipoint
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template 2
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
!
ip local pool <pool name> 172.22.40.10 172.22.40.25

RFC1483桥接:xDSL到7200

网络图

本部分使用以下网络设置:

7200_bdaggreg2.gif

配置

此示例描述如何连接Cisco 677,或者其他DSL CPE,到Cisco7200通过RFC 1483桥接封装。此配置包括思科LS1010 ATM交换机,是一个可选组件。如果直接地连接DSLAM对Cisco7200,结果是相同的。

在本例中,您在Cisco7200建立Cisco 677的桥接的会话并且终止。在对Cisco7200的会话网桥,传统IP通过流量对NSP或到互联网后。与配置的一个DHCP服务器在7200分配IP地址到客户端工作站。

此配置使用集成路由和桥接(IRB)。要缓和可扩展性和安全性问题与IRB,请考虑路由桥接封装(RBE)。

本部分使用以下配置:

RFC 1483的PC配置
  1. 设置IP寻址自动地获取IP地址。
  2. 设置WINS为WINS resolution使用DHCP。
  3. 保证没有设置默认网关。

注意: 如果DHCP不可能通过此信息,您需要设置域名。

RFC 1483的Cisco 677 CPE配置
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

RFC 1483的Cisco DSLAM配置
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Cisco RFC 1483的LS1010配置
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

RFC 1483的Cisco7200配置
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!         
!
bridge irb
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
 bridge-group 1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
 bridge-group 1!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface BVI 1
 ip address 172.22.40.9 255.255.255.0
 no ip directed-broadcast
!
!
bridge 1 protocol ieee
 bridge 1 route ip

RBE :xDSL到7200

网络图

本部分使用以下网络设置:

7200_bdaggreg2.gif

配置

RBE当前是选择的配置多数的新建的DSL安装。RBE解决桥接安全和可扩展性问题在宽带用户环境的。

与配置的一个DHCP服务器在7200分配IP地址到客户端工作站。

重要信息:当您使用Cisco IOSï ¿  ½软件版本12.1(2)T或以上时, DHCP在路由器不能运行与未编号的ATM,除了。

本部分使用以下配置:

RBE的PC配置
  1. 设置IP寻址自动地获取IP地址。
  2. 设置WINS为WINS resolution使用DHCP。
  3. 保证没有设置默认网关。

注意: 如果DHCP不可能通过此信息,您需要设置域名。

RBE的Cisco CPE配置
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

RBE的Cisco DSLAM配置
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

思科RBE的LS1010配置
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

RBE的Cisco7200配置
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!
!
interface Loopback0
 ip address 172.22.40.9 255.255.255.0
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/35 
  encapsulation aal5snap
!
!
interface ATM 2/0.2 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/36 
  encapsulation aal5snap
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!

PPPoE :xDSL到7200

网络图

本部分使用以下网络设置:

7200_bdaggreg3.gif

配置

PPP over Ethernet (PPPoE)致以从路由器的PPP会话对末端客户端。PPP和认证软件在客户端通常运行在操作系统内或独立应用程序的。CPE在桥接模式操作桥接在DSL连接的PPP会话。但是CPE不能作为在此方案的DHCP服务器。

CPE、DSLAM和ATM交换机的配置是相同的象RFC 1483桥接的配置。因为此示例显示,您能配置本地认证的Cisco7200聚合路由器。或者您能配置7200与验证、授权和统计(AAA) RADIUS验证。

本部分使用以下配置:

PPPoE的PC配置
  1. 设置IP寻址自动地获取IP地址。
  2. 设置WINS为WINS resolution使用DHCP。
  3. 保证没有设置默认网关。

注意: 如果DHCP不可能通过此信息,您需要设置域名。

注意: 终端站一定能建立对路由器的PPP连接。验证的特殊客户端软件和访问可以是必要的。

PPPoE的Cisco 677 CPE配置
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

PPPoE的Cisco DSLAM配置
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

思科PPPoE的LS1010配置
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

PPPoE的Cisco7200配置
!
username <username> password <password>
!
vpdn enable
!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1
  pppoe limit per-mac 100
  pppoe limit per-vc 100
!
ip cef
!
interface atm2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
  protocol pppoe
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
  protocol pppoe
!
interface Virtual-Template1
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
ip local pool <pool name> 172.22.32.20 172.22.32.100

L2TP :通过L2TP从xDSL到7200

网络图

本部分使用以下网络设置:

7200_bdaggreg4.gif

配置

Layer Two Tunneling Protocol (L2TP)提供方法终止从最终用户的PPP连接在一个位置和传输L2数据包对另一个位置。L2TP卸载许多从聚合设备的Ip功能并且允许更集中式的网络设计。RADIUS服务器提供AAA。

所有设备(Cisco 7200除外)的配置与RFC1483示例的配置相同。

本部分使用以下配置:

L2TP的PC配置
  1. 设置IP寻址自动地获取IP地址。
  2. 设置WINS为WINS resolution使用DHCP。
  3. 保证没有设置默认网关。

注意: 如果DHCP不可能通过此信息,您需要设置域名。

L2TP的Cisco 677 CPE配置
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

L2TP的Cisco DSLAM配置
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

思科L2TP的LS1010配置
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

L2TP的Cisco7200 LAC配置
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!  
vpdn-group 4
 request-dialin
  protocol l2tp
  domain cisco.com
 initiate-to ip 172.22.32.27 priority 1
 local name cisco-tunnel      
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template1
 ip unnumbered FastEthernet4/0
 no ip directed-broadcast
 ppp authentication pap
!
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Cisco7200 L2TP的LNS配置
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!
vpdn-group 1
 accept-dialin
  protocol any
  virtual-template 1
 terminate-from hostname cisco-tunnel
 local name tunnel-gate
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 12868