?????? : Cisco LocalDirector 400 系列

在 LocalDirector 上配置多节点负载均衡

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


Cisco 已宣布停止销售 Cisco LocalDirector。欲知更多信息,参考Localdirector 400系列销售终止公告版


目录


简介

LocalDirector在多节点负载均衡(MNLB)环境使用Cisco设备服务器体系结构(CASA)存在。在MNLB环境, LocalDirector有一个服务管理器配置。Cisco路由器有转发代理配置。服务管理器确定转发代理的负载均衡。服务管理器根据此确定从真实服务器的信息。此设置增加网络效率和可扩展性,并且添加应用程序感知的平衡。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

此配置用使用这些软件和硬件版本开发并且测试:

  • Localdirector软件版本3.1.3

  • Cisco IOS�软件版本12.0

  • LocalDirector 430

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

config_mnlb-01.gif

配置

本文档使用以下配置:

服务管理器配置(LocalDirector)
: Saved

: LocalDirector 430 Version 3.1.3 
syslog output 20.3 
no syslog console 
hostname cisco-ld 
no shutdown ethernet 0 
shutdown ethernet 1 
shutdown ethernet 2 
no shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 auto 
interface ethernet 2 auto 
interface ethernet 3 100full 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure 0 
no secure 1 
no secure 2 
no secure 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
ping-allow 3 
ip address 172.16.9.25 255.255.255.0 
route 172.16.10.0 255.255.255.0 172.16.9.5 1 
route 172.16.8.7 255.255.255.255 172.16.9.7 1 
route 172.16.8.8 255.255.255.255 172.16.9.8 1 
route 0.0.0.0 0.0.0.0 172.16.9.1 1 
no rip passive 
failover ip address 172.16.9.26 
failover 
telnet 172.16.0.0 255.255.0.0 
virtual 10.10.10.100:0:0:tcp is 
virtual 10.10.10.110:0:0:tcp is 
redirection 10.10.10.100:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
redirection 10.10.10.110:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
real 172.16.10.3:0:0:tcp is 
real 172.16.10.4:0:0:tcp is 
real 172.16.10.5:0:0:tcp is 
real 172.16.10.6:0:0:tcp is 
bind 10.10.10.100:0:0:tcp 172.16.10.3:0:0:tcp 
bind 10.10.10.100:0:0:tcp 172.16.10.5:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.4:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.6:0:0:tcp 

转发代理配置(Cisco路由器)
Building configuration... 

Current configuration: 

! 
version 12.0 
service timestamps debug uptime 
service timestamps log uptime 
service password-encryption 
! 
hostname router-a 
! 
ip subnet-zero 
no ip domain-lookup 
! 
ip cef distributed 
ip casa 172.16.8.7 224.0.1.2 
 forwarding-agent 1637 
! 
! 
process-max-time 200 
! 
interface Channel0/0 
 description RD0713 DE10 SYSF 9910 SYSJ 
 ip address 172.16.10.1 255.255.255.0 
 ip directed-broadcast 
 ip route-cache same-interface 
 no keepalive 
 claw DD10 00 172.16.10.3 TCPIP CIPTCP TCPIP TCPIP 
 claw DE10 00 172.16.10.5 TCPIP CIPTCP TCPIP TCPIP 
 claw DF10 00 172.16.10.4 TCPIP CIPTCP TCPIP TCPIP 
 claw DG20 00 172.16.10.6 TCPIP CIPTCP TCPIP TCPIP 
! 
interface Channel0/2 
 no ip address 
 no ip directed-broadcast 
 no keepalive 
 shutdown 
! 
interface FastEthernet1/0/0 
 ip address 172.16.9.7 255.255.255.0 
 no ip redirects 
 no ip directed-broadcast 
 ip route-cache flow 
 no ip route-cache distributed 
 ip igmp join-group 224.0.1.2 
 no ip mroute-cache 
 full-duplex 
 no mop enabled 
 standby use-bia 
 standby priority 105 preempt 
 standby ip 172.16.9.6 
 standby track Channel0/0 
! 
router rip 
 version 2 
 redistribute static 
 network 172.16.0.0 
! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.9.1 
no ip http server 
! 
line con 0 
line aux 0 
line vty 0 4 
! 
end

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在您发出调试指令前,参考关于调试指令的重要信息

  • debug ip casa affinities — CASA匹配度的Enable (event)调试。

  • debug ip casa packets — CASA信息包的Enable (event)调试。

  • debug ip casa wildcards — CASA通配符的Enable (event)调试。

  • show ip casa affinities —显示关于亲和的统计信息。

  • show ip casa oper —显示操作信息。

  • show ip casa stats —显示统计信息。

  • show ip casa wildcard —显示关于通配符匹配度的信息。

关于MNLB on命令LocalDirector的更多信息,参考LD的MNLB特性组:命令参考

调试输出示例

此输出是从debug ip casa affinities命令

Router# debug ip casa affinities
16:15:36:Adding fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:    flags = 0x2, appl addr = 10.10.3.2, interest = 0x5/0x100
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0
16:15:36:Adding fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:    flags = 0x2, appl addr = 0.0.0.0, interest = 0x3/0x104
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12616