网络管理 : Cisco Network Registrar

使用 Cisco Network Registrar 进行电缆调制解调器的基本安装

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

此技术说明目的将为在实验室环境的有线调制解调器网络提供一个完整设置指南。此设置可以在对客户网络的部署前首先使用。请注意一个无困难设置在实验室里不一定含义在客户网络的一个无困难设置。在受控的实验室环境,噪声可能不是问题;当在实时寿命中,它可以相当是对面时。然而,此步骤可以使用排除从思科IOSï ¿  ½软件版本、配置、硬件和无线电频率(RF)出现的问题。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

实验室拓扑结构

图1 –实验室网络设置

basic_bridged_setup_01.gif

在包括这些组件的此图表中,有有线调制解调器终端系统(CMTS) :

  • 运行Cisco IOS软件版本12.1(2)T以MC16C调制解调器卡的uBR7246

  • 运行Cisco IOS软件版本版本12.0(7)T的CM uBR904

  • 升频器

  • 分离高频的Diplex过滤器从低频率

  • Cisco网络认证(CNR)版本3.5(3)

  • 三通的分离器

  • 在这种情况下,是笔记本电脑的客户端前置设备(CPE)

注意: 在该图表中设置的RF可以使用作为一个开始的参考点;然而,一旦在客户站点,部署它这也许更改。RF评定是超出本文的范围之外;参考连接Cisco ubr7200系列路由器对适当的RF设置和评定的电缆头端

假定

  • 升频器已经安装并且适当地配置。参考设置的厂商文档。切记,如果使用GI upconverter,比有问题的NTSC的信道的中心频率应该设置这在1.75兆赫更低。

  • 有在CM后坐的适当地配置的CPE,特别地获取IP地址的通过DHCP服务器。

  • CNR使用作为DHCP和TFTP服务器,与同样IP地址:172.17.110.136。

  • 每日定时(ToD)服务器软件在NT服务器运行和CNR一样。

在本文的部分说明是需要的配置这些组件的步骤:

  • Cisco网络认证(CNR)

  • 有线数据业务接口规范(DOCSIS)配置文件

  • 有线调制解调器终端系统(CMTS)

  • 有线调制解调器

网络图

图2 –网络图用用于此技术说明和名称的IP地址

/image/gif/paws/12547/basic_bridged_setup_02.gif

Cisco Network Registrar 配置

遵从此步骤配置CNR :

  1. 启动从开始菜单的CNR。

  2. 在菜单栏,请点击Add选项添加一新的集群。

    1. 输入集群名称。

      在这种情况下, IP地址使用作为名称。

    2. 检查连接对此集群一次被添加的复选框。

    3. 单击 Ok

    图3 –集群名称或IP Address窗口在CNR

    /image/gif/paws/12547/basic_bridged_setup_03.gif

  3. 当提示对于用户名和密码时,请使用adminchangeme

    图4 –在CNR的用户名和密码窗口

    /image/gif/paws/12547/basic_bridged_setup_04.gif

  4. 单击 Ok

    是类似的图5,包含已配置的集群的名称或IP地址的窗口出现。

    图5 –在CNR的Server Manager窗口

    basic_bridged_setup_05.gif

  5. 双击DHCP@172.17.110.136,启动DHCP@172.17.110.136属性窗口。

  6. 点击Policies选项然后单击,创建一项新的策略。

    图6 –添加呼叫“电缆调制解调器”和复制属性从“默认”策略的策略

    basic_bridged_setup_06.gif

  7. 以策略的名义类型。

    在本例中,名称是电缆调制解调器

  8. 如果这是一项新的策略,请设置复制From字段默认

  9. 单击 Ok

  10. 单击编辑选项,指定DHCP选项。

    对于呼叫电缆调制解调器的策略,请添加以下选项(请参见图7)

    • 默认情况下dhcp-lease-time是活跃和集合为604800秒,是秒钟数量在一周。

    • 路由器是CMTS电缆接口的IP地址,在这种情况下10.1.1.10。请参阅配置头端(CMTS)

    • CM的时间偏移从世界协调时间(UTC的;时间偏移选项2)。CM用于这计算本地时间,为了时间戳错误日志。

    • ToD服务器的趋炎附势者IP地址,是172.17.110.136

    • packet-siaddr是TFTP server的IP地址,是172.17.110.136

    • packet-file-name是用DOCSIS CPE Configurator配置的DOCSIS配置文件(仅限注册用户)。此文件在TFTP server的TFTP启动目录应该驻留。

    Figure7 –与属性的Edit Options窗口给对有线调制解调器策略

    basic_bridged_setup_07.gif

    注意: 保证您检查Send to BOOTP clients复选框,如果有BOOTP客户端。也是高度推荐的您总是检查发送对DHCP客户端复选框。

  11. 创建另一项策略关联与在CM后的CPE,类似膝上型计算机,等等。

    在本例中,策略的名称是有线调制解调器客户端

    遵从步骤和一样使用了电缆调制解调器策略除了,这次,设置复制From字段为电缆调制解调器策略而不是为默认策略

    图8 –添加呼叫“有线调制解调器客户端的”策略和复制属性从名为“电缆调制解调器的”现有策略

    /image/gif/paws/12547/basic_bridged_setup_08.gif

  12. 单击 Ok

  13. 点击Edit选项按钮,选择有效选项。

  14. 对于CPE策略,请从除了dhcp-lease-time和路由器选项的活动列表取消所有选项。

    要执行如此,请选择属性删除在活动列表和点击Remove按钮

  15. 更改路由器选项的IP地址对192.168.1.1,是在CMTS路由器配置的备用IP地址。

    请参阅配置头端(CMTS)

    图9 –添加路由器属性的IP地址,是备用IP地址在此策略在CMTS适用的电缆接口配置

    basic_bridged_setup_09.gif

    注意: 此示例使用一个专用IP地址作为备用地址在CMTS和在电缆调制解调器客户端策略。在生产环境, (除非使用网络地址转换[NAT]), CPE设备应该使用公网IP地址,能访问互联网。

  16. 创建范围与电缆调制解调器和有线调制解调器客户端策略产生关联。

    1. 要做一个新的范围,请点击在主菜单的DHCP@172.17.110.136,然后单击Add选项

      这将给您添加一个新的范围。

    2. 输入新的范围的名称然后选择相应的策略。

      在本例中,电缆调制解调器的范围设置使用从10.1.1.20的IP地址范围到10.1.1.30。

      图10 –呼叫“电缆调制解调器的”电缆调制解调器的范围

      /image/gif/paws/12547/basic_bridged_setup_10.gif

    3. 重复有线调制解调器客户端范围的步骤16a和16b。

      在这种情况下,到192.168.1.30使用从192.168.1.20的专用IP地址范围。

      图11 – CPE设备的范围在电缆调制解调器背后呼叫“有线调制解调器客户端”

      /image/gif/paws/12547/basic_bridged_setup_11.gif

    4. 用于CPE设备的范围要求更多的配置。

      1. 一旦创建有线调制解调器客户端范围,您需要双击范围打开在表12显示的对话框。

        图12 –有线调制解调器客户端范围窗口

        /image/gif/paws/12547/basic_bridged_setup_11.gif

      2. 点击高级选项卡。,为了与主要的范围涉及附属范围。

      3. 检查做此范围一附属复选框。

      4. 一旦下拉列表显示一个空白的值,请选择适当的主要的范围。

        在本例中,电缆调制解调器范围选择。

        图13 –进行“有线调制解调器客户端”范围第二和涉及它与主要的范围

        basic_bridged_setup_12.gif

  17. 最后,您需要重新启动您的DHCP服务器,以便您的更改能发生。

    在主菜单,挑选DHCP@172.17.110.136和在顶部单击Control选项,得到在显示的对话框14上。此对话框允许您重新加载DHCP服务器。

    图14 –确认在CNR上的变化的重新加载窗口

    /image/gif/paws/12547/basic_bridged_setup_13.gif

DOCSIS 配置文件

下一步要求建立的有线网络是编辑配置文件。为了使来的有线调制解调器联机,需要通过从DHCP服务器的TFTP下载其配置文件。在本文的示例中, CNR用于提供TFTP和DHCP服务器。参考DHCP和DOCSIS配置文件电缆调制解调器的(DOCSIS 1.0)关于最低要求设置配置文件的更多信息。文件设置用基于Web的工具, DOCSIS CPE Configurator (仅限注册用户),或者独立版本的下载。在本文的CM (uBR904)部分,使用的DOCSIS配置文件呼叫platinum.cm。

注意: 一旦配置文件创建,请保证复制对TFTP server。一旦CNR的TFTP server,您必须也保证TFTP server开始:

  1. 挑选TFTP@172.17.110.136然后单击Control选项

    这启动TFTP@172.17.110.136控制对话框,服务器可以开始。

  2. 默认情况下TFTP服务器功能关闭。要自动地做TFTP server开始在启动,请开始NRCMD (CNR的命令行界面)并且发出这些命令:

    server tftp set start-on-reboot=enabled
    
    save
    

配置头端 (CMTS)

这是CMTS的(uBR7246)一个基本配置:

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Sydney
!
boot system flash ubr7200-ik1s-mz_121-2_T.bin
no logging buffered
enable password <deleted>
!
no cable qos permission create

!--- Default.

no cable qos permission update

!--- Default.

cable qos permission modems

!--- Default.

!
!
!
ip subnet-zero
no ip domain-lookup
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.139 255.255.255.224

!--- The IP address of the interface in the same LAN segment as CNR.

!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Ethernet1/4
 no ip address
 shutdown
!
interface Ethernet1/5
 no ip address
 shutdown
!
interface Ethernet1/6
 no ip address
 shutdown
!
interface Ethernet1/7
 no ip address
 shutdown
!
 interface Cable2/0
 ip address 192.168.1.1 255.255.255.0 secondary

!--- The secondary IP address is used for the CPE’s scope in CNR.

 ip address 10.1.1.10 255.255.255.0

!--- The primary IP address is used for the CM’s scope in CNR.

 no keepalive
 cable downstream annex B

!--- Default for DOCSIS-compliant cable plants. For EuroDOCSIS, use annex A.

 cable downstream modulation 64qam

!--- Default.

 cable downstream interleave-depth 32

!--- Default.

 cable downstream frequency 451250000

!--- Cosmetic except for the uBR7100. This line has no effect
!--- on Upconverter Frequency. Used as a reminder of the frequency
!--- that is used in the Unconverter.

 cable upstream 0 frequency 28000000

!--- Upstream Frequency configuration. This is chosen after a careful
!--- analysis on the noise levels of the return path.

 cable upstream 0 power-level 0
 no cable upstream 0 shutdown

!--- Enables the upstream 0 port.

 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy

!--- Modifies the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets.

 cable helper-address 172.17.110.136

!--- Specifies a destination IP address for UDP-broadcast DHCP packets.

!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
  transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 login
line vty 1 4
 password cisco
 login
!
end

配置 CM

一般,有线调制解调器不要求它的任何用户配置能来联机(除出厂默认设置外)。只有如果CM将使用作为网桥,这应用。这是自动地得到UBR有线调制解调器概述的示例,在CM来联机后:

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
clock timezone - 0
ip subnet-zero
no ip routing
!
!
interface Ethernet0
 ip address 10.1.1.25 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address negotiated
 no ip directed-broadcast
 no ip route-cache
 cable-modem downstream saved channel 453000000 20 1
 cable-modem mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.10
ip classless
no ip http server
!
!
line con 0
 transport input none
line vty 0 4
!
end

验证和故障排除

此部分描述能使用验证有线网络的正确操作的命令。

在CMTS (uBR7246)

保证电缆调制解调器联机:

Sydney# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 2    online     2290   -0.25  6   1   10.1.1.25       0050.7366.2223

如果电缆调制解调器在init被滞留(d)状态,则没有CMTS电缆接口和DHCP服务器之间的连接。

保证您能发出从CMTS的电缆接口的一扩展ping :

Sydney# ping ip

Target IP address: 172.17.110.136
Repeat count [5]: 
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 10.1.1.10
Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

如果ping不是成功的,请检查IP路由。并且,请保证运行CNR的NT服务器有正确默认网关或路由回到CMTS。您能也发出从CNR的一ping。

在CMTS能使用验证有线调制解调器和CPE连接的另一命令是show interface cable 2/0 modem 0

Sydney# show interfaces cable 2/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
2     00         host      unknown   192.168.1.20  dhcp      0010.a4e6.d04d

!--- A laptop that is obtaining an IP address.

2     00         modem     up        10.1.1.25     dhcp      0050.7366.2223

!--- The cable modem.

在CM (uBR904)

您能也检查在有线调制解调器侧的连接。发出show ip interface brief命令并且检查接口up/up

Router# show ip interface brief

Interface                  IP-Address      OK? Method Status         Protocol
Ethernet0                  10.1.1.25       YES unset  up             up
cable-modem0               10.1.1.25       YES unset  up             up

Router# show controllers cable-modem 0

BCM Cable interface 0:
CM unit 0, idb 0x2010AC, ds 0x86213E0, regaddr = 0x800000, reset_mask 0x80
station address 0050.7366.2223  default station address 0050.7366.2223
PLD VERSION: 32
MAC State is maintenance_state, Prev States = 15
MAC mcfilter 01E02F00  data mcfilter 01000000
MAC extended header ON
DS: BCM 3116 Receiver: Chip id = 2
US: BCM 3037 Transmitter: Chip id = 30AC
Tuner: status=0x00
Rx: tuner_freq 453000000, symbol_rate 5055880, local_freq 11520000
    snr_estimate 35210, ber_estimate 0, lock_threshold 26000
    QAM in lock, FEC in lock, qam_mode QAM_64
Tx: TX_freq 27984000, power_level 0x30 (24.0 dBmV), symbol_rate 8
    (1280000 sym/sec)
DHCP: TFTP server = 172.17.110.136, TOD server = 172.17.110.136
      Security server = 0.0.0.0, Timezone Offest = 0
      Config filename = platinum.cm
buffer size 1600

RX data PDU ring with 32 entries at 0x202130
   rx_head = 0x202168 (7), rx_p = 0x8621418 (7)

RX MAC message ring with 8 entries at 0x202270
  rx_head_mac = 0x2022A0 (6), rx_p_Mac = 0x86214BC (6)

TX BD ring with 8 entries at 0x2023A8, TX_count = 0
  TX_head = 0x2023C8 (4), head_txp = 0x8621548 (4)
  TX_tail = 0x2023C8 (4), tail_txp = 0x8621548 (4)

TX PD ring with 8 entries at 0x202428, TX_count = 0
  TX_head_pd = 0x202C28 (4)
  TX_tail_pd = 0x202C28 (4)

Global control and status:
  global_ctrl_status=0x00
interrupts:
  irq_pend=0x0008, irq_mask=0x00F7

您能也测试IP连通性。ping从CM的DHCP服务器:

Router# ping 172.17.110.136

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

uBR7246

Sydney# show version

Cisco Internetwork Operating System Software
IOS (tm) 7200 Software (UBR7200-IK1S-M),
     Version 12.1(2)T, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Tue 16-May-00 13:36 by ccai
Image text-base: 0x60008900, data-base: 0x613E8000
ROM: System Bootstrap,
     Version 11.1(10) [dschwart 10], RELEASE SOFTWARE (fc1)
BOOTFLASH: 7200 Software (UBR7200-BOOT-M),
     Version 12.0(10)SC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Sydney uptime is 4 days, 40 minutes
System returned to ROM by reload
System image file is "slot0:ubr7200-ik1s-mz_121-2_T.bin"
cisco uBR7223 (NPE150) processor (revision B) with 57344K/8192K bytes of memory.
Processor board ID SAB0249006T
R4700 CPU at 150Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache
3 slot midplane, Version 1.0
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
8 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
2 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.
1024K bytes of packet SRAM memory.
20480K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

uBR904

Router# show version

Cisco Internetwork Operating System Software
IOS (TM) 900 Software (UBR900-K1OY556I-M),
     Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:01 by phanguye
Image text-base: 0x08004000, database: 0x0852E888


ROM: System Bootstrap,
     Version 11.2(19980518:195057), RELEASED SOFTWARE
ROM: 900 Software (UBR900-RBOOT-M),
     Version 11.3(7)NA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 


Router uptime is 1 hour, 6 minutes
System returned to ROM by reload at 11:20:43 - Thu Oct 12 2001
System restarted at 11:21:53 - Thu Oct 12 2001
System image file is "flash:ubr900-k1oy556i-mz.120-7.T.bin"

cisco uBR900 CM (68360) processor (revision D) with 8192K bytes of memory.
Processor board ID FAA0315Q07M
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
4096K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Boot flash (Read/Write)
        

Configuration register is 0x2102

关于使用的详细说明CNR调试—,万一需要排除故障CNR问题—参考排除故障在有线网络的DHCP问题使用Cisco Network Registrar Debugs。对于客户端类配置,参考配置客户端类别


相关信息


Document ID: 12547