思科接口和模块 : 思科内容交换模块

使用 IOS SLB 配置 FTP 服务器负载均衡

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文为FTP服务器负载均衡提供一配置示例在Cisco IOS Server Load Balancing (SLB)帮助下。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Catalyst 6000系列Supervisor Cisco IOSï ¿ Â管理引擎1的½软件版本12.1(8)E有MSFC1的(c6sup11-jsv-mz.121-8a.E)

  • Microsoft Windows 2000/iis FTP服务器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

Cisco IOS SLB功能是一基于Cisco IOS的解决方案该提供服务器负载均衡。这个功能使您能够定义一个能代表真实服务器的集群的虚拟服务器,称之为一个服务器群。当客户端首次向虚拟服务器发起连接命令时,IOS SLB对该连接进行负载平衡,以选择真实的服务器。该过程取决于已配置的负载平衡算法或预报器。

当您使用IOS SLB时,您在分派模式必须配置FTP服务器负载均衡经营。在此模式,虚拟地址为FTP服务器所知。您必须配置其中每一个有环回地址的FTP服务器他们的唯一回环接口的。此步骤是必要给在FTP服务器的每计算机在组群IP地址和虚拟地址一样。正服务器为其自己的IP地址,将回应FTP服务器能然后响应直接地对有环回地址的客户端。IOS SLB重定向数据包到真实服务器在Layer2在MAC控制(MAC)层。虚拟服务器IP地址在分派模式没有被修改。所以,真实服务器必须是层2相邻与IOS SLB。否则,中间路由器不能发送到选定的真实服务器。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

/image/gif/paws/12577/config_ftpserver_lb.gif

配置

本文档使用以下配置:

  • IOS SLB FTP配置使用Catalyst 5509

IOS SLB FTP配置使用Catalyst 5509
Current configuration: 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin 
! 
redundancy 
 main-cpu 
  auto-sync standard 
ip subnet-zero 
! 

!--- FTP Serverfarm configuration.
 
ip slb serverfarm FTPFARM 
 real 10.1.1.3 
  inservice 
 !  
 real 10.1.1.4 
  inservice 
! 

!--- FTP Virtual configuration. 
!--- Important: Config Loopback address on FTP Server's with Virtual address.
 
ip slb vserver FTPSERVER 
 virtual 172.17.63.241 tcp ftp service ftp 
 serverfarm FTPFARM 
 inservice 
! 
interface GigabitEthernet1/1 
 no ip address 
 shutdown 
! 
interface GigabitEthernet1/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/1 
 description "Uplink to the Default Gateway" 
 no ip address 
 switchport 
 switchport access vlan 100 
! 
interface FastEthernet2/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/3 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/4 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/5 
 no ip address 
 shutdown 
! 
interface FastEthernet2/48 
 no ip address 
 shutdown 
! 
interface Vlan1 
 no ip address 
 shutdown 
! 

!--- Client Side Vlan. 

interface Vlan100 
 ip address 172.17.63.240 255.255.255.192 
! 

!--- FTP Server Vlan. 
!--- Important: Configure the default gateway of the FTP Server to this address.

interface Vlan200 
 ip address 10.1.1.250 255.255.255.0 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
 login 
! 
end

注意: 除IOS SLB之外,内容交换模块为Cisco Catalyst 6500系列交换机和Cisco 7600系列路由器也是可用的。此模块根据信息包Layer4提供网络设备服务器站之间的高性能的连接通过7。关于更详细的资料,参考思科内容交换模块

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • show ip slb vserver —显示虚拟服务器信息。这是显示虚拟服务器和连接数量状态的示例:

    cat#show ip slb vserver 
    
    slb vserver    protocal   virtual                 state         conns 
    ----------------------------------------------------------------------
    FTPSERVER      TCP        172.17.63.241/32:21     OPERATIONAL    4
  • show ip slb reals —显示服务器区域信息。此指令显示为负载均衡使用的预报器。此示例使用循环法(默认)。因为设备在分派模式, “什么都”没出现在NAT下。

    cat#show ip slb serverfarm 
    
    server farm     predictor       nat        reals        bind id 
    ----------------------------------------------------------------- 
    FTPFARM         ROUNDROBIN      none          2           0

故障排除

本部分提供的信息可用于对配置进行故障排除。

警告 警告: Debug输出分配在CPU进程的高优先级。所以,调试能使系统不能使用。为此,在 Cisco 技术支持人员的会话故障排除过程,只需使用 debug 命令,就能排除特定问题故障。思科建议在期限更低网络流和少量用户,您使用调试指令。调试在这些期限减少这些on命令效果系统的其他用户。

故障排除命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug ip slb {conns|reals|vserver|所有} —显示调试消息。请使用此命令为了禁用调试no表示。这是语法说明:

    语法 说明
    conn 当前显示该所有的连接的调试消息IOS SLB把柄。
    vserver 显示所有虚拟服务器的调试消息定义对IOS SLB。
    reals 显示所有真实服务器的调试消息定义对IOS SLB。
    所有 显示IOS SLB的所有调试消息。

    FTP会话包括FTP客户端和FTP服务器,即,控制和数据之间的两连接。

  • debug ip slb连接

    这是使用无源FTP的示例。在最简单的期限,这是无源FTP如何工作:

    • 最初的FTP控制连接的一连接,客户端首次到服务器:

      2d22h: SLB_CONN_DEBUG: TCP event= SYN_CLIENT,
       state= INIT -> SYNCLIENT 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
      2d22h: SLB_CONN_DEBUG: TCP event= SYNACK_SERVER,
       state= SYNCLIENT -> ESTAB 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
    • FTP数据连接的另一连接,从服务器的客户端首次:

      2d21h: SLB_CONN_DEBUG: TCP event= DATA_CLIENT,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999 
      2d21h: SLB_CONN_DEBUG: TCP event= DATA_SERVER,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999

注意在无源FTP,客户端首次控制连接和数据连接。被动模式是指服务器状态,因为服务器被动地接受两连接。在被动模式,目的地和源端口是‘短暂’端口(非常地比1023)。客户端驾驶模式,正如在每个案件客户端必须发出passive命令或者port命令,启动数据连接的设置。在每个案件中激活模式的数据连接(被动模式的服务器,客户端的)收件人必须供应他们细听此特定连接的端口号。它总是不是数据连接的端口20,在激活模式FTP。什么都在RFC不指定将使用的端口是20和21,它是规则。许多服务器使用暂时端口数据连接。

因为vserver [chars]有FTP启用, %不能启用nat的服务器

因为IOS SLB不支持在NAT模式的FTP此错误消息显示。应急方案是使用分派模式和环回在服务器。欲知更多信息,请参阅分派模式回环部分

分派模式环回

在您配置在Catalyst 6500后的FTP Serverfarm和Vserver功能,您必须配置有环回设备或接口的每个真实服务器。配置虚拟服务器的IP地址作为环回IP地址,与255.0.0.0网络屏蔽。

Route Table 
     =========================================================================== 
     Interface List 
     0x1 ........................... MS TCP Loopback interface 
     0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
     0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
     =========================================================================== 
     Active Routes: 
        Network         Destination     Netmask       Gateway   Interface Metric 
        0.0.0.0         0.0.0.0         10.1.1.250    10.1.1.3      1 
        10.1.1.0        255.255.255.0   10.1.1.3      10.1.1.3      1 
        10.1.1.3        255.255.255.255 127.0.0.1     127.0.0.1     1 
        10.255.255.255  255.255.255.255 10.1.1.3      10.1.1.3      1 
        127.0.0.0       255.0.0.0       127.0.0.1     127.0.0.1     1 
        172.17.63.241   255.255.255.255 127.0.0.1     127.0.0.1     1 
        224.0.0.0       224.0.0.0       10.1.1.3      10.1.1.3      1 
        224.0.0.0       224.0.0.0       172.17.63.241 172.17.63.241 1 
        255.255.255.255 255.255.255.255 10.1.1.3      10.1.1.3      1 
     ===========================================================================

检查表中能看到回环地址的每一排上的网络地址。为了使正确通信的服务器,您需要对众所周知的组播网络地址的一参考。这在示例的第8行,因此您需要删除额外default-route。这是一个网络地址和集群地址一样,都始于同一个数字,后面接三个零的网络。在本例中,额外的路由在第二行。

这些是众所周知的组播网络地址:

224.0.0.0      224.0.0.0    172.17.63.241      172.17.63.241       1

这是从在示例的表删除的自动安装的默认路由:

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.241          1

您必须删除额外的路由允许正常通信用SLB虚拟服务器。


相关信息


Document ID: 12577