IBM 技术 : 数据链路交换 (DLSw) 和加强版数据链路交换 (DLSW+)

基本 DLSw+ 配置

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

数据链路交换(DLSW)是使用传输IBM系统网络体系结构(SNA)和IBM NetBIOS数据流在IP网络的交换机到交换机协议。此协议不提供全部路由,反而提供在TCP/IP的交换在SNA数据链路层和封装为在互联网的传输。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景信息

DLSw+是思科的DLSW实施。除DLSw标准之外, DLSw+包括以下功能:

  • 传输选项选择,包括TCP、FST (快速顺序传输)和直接封装。

  • 通过可扩展性增强:对等组、根据要求对等体、探测器防火墙和位置了解。

  • 在本地之间的媒体转换和远程LAN和SDLC或者以太网。

什么是 DLSw 标准?

在DLSw标准的更加了不起的详细信息,参考的RFC 1795 (RFC 1434由RFC 1795使过时)。总之, RFC 1795描述交换机到交换机协议(SSP)用于在路由器之间建立DLSw连接,找出资源、向前数据、把柄流量控制和错误恢复。它也描述如何本地终止数据链路控制(DLC)连接,并且映射DLC对DLSw的连接巡回。

通过终止本地DLC连接, DLSw涉及以下问题:

  • DLC超时

  • 在广域网的DLC确认

  • 流和拥塞控制

  • 搜索数据包广播控制

  • 源路由桥接跳数限额

注意: 对RFC 1795的增强可以在RFC 2166找到。那些增强对RFC 1795寻址在DLSw的可扩展性问题和说明。RFC 2166,然而,没有过时1795并且应该与1795一道使用。

示例配置

表示的配置此处是部分配置;他们不刻画为DLSw+支持要求的配置的仅部分和IP或其他协议支持。因为DLSw+依靠TCP/IP (除了,当您使用FST或处理),假定是IP网络已经是正在运行的。

1. 对令牌环的令牌环在广域网

/image/gif/paws/12411/ringwan.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

Router B

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

在本例中,我们拾起一个虚拟环,环号2000年,容易地建立两组之间的一关系。路由信息字段(RIF),然而,终止在DLSw+路由器。您能选择每个路由器的一个不同的虚拟环号。当选择环号时,小心;您应该遵从适用于源路由桥接的同样规则。目前,思科只支持每个路由器一个虚拟环。

dlsw local-peer命令用于定义您本地路由器的自己的DLSw+ IP地址。在上述示例中,使用回环接口的IP地址,以便DLSw+不必须依靠实时物理接口是至工作。

dlsw remote-peer命令定义了远程路由器的IP地址。跟随remote-peer关键字的第0是环列表号。通常,如果充分地想要一个网状网络,请使用第0。允许网络用于环列表号控制探索帧泛滥将被分段的(请参见示例两关于环列表演示)。

2. 对令牌环的令牌环有环列表的

/image/gif/paws/12411/ringlist.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

Router B
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 1 tcp 150.150.1.1
dlsw ring-list 1 rings 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

!
interface TokenRing1
ip address 150.150.30.1 255.255.255.0
ring-speed 16
source-bridge 2 1 2000
source bridge spanning 


!--- Allows the router to forward single route explorer frames.

在本例中,环的3所有工作站能只设立有站点的不是会话环的1,但是环2,反之亦然。因为他们本地附加到路由器B.,环的1站点能与环的2站点仍然谈。

这意味着将没有从将传送到路由器A的环2的广播。使用DLSw环列表,当您要控制在广域网时的广播数据流端口列表bgroup-list语句是非常有用的。

3. 对以太网的令牌环在广域网

/image/gif/paws/12411/ringether.gif

在本例中,设备在混合媒介查找,因此我们需要位交换主机MAC地址,在启动Explorer测试数据包的辅助设备前被编码。参见了解和排除故障源-路由转换桥接

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.


在下一个示例中,以太网段的站点允许与令牌环分段的站点谈。DLSw+路由器照料从以太网格式的转换到令牌环格式。dlsw bridge-group命令用于附加以太网段到DLSw+进程正如源网桥语句附加令牌环分段对DLSw+通过虚拟环组。您不需要配置SRT/LB,除非有在路由器B的一个令牌环接口,并且站点此令牌环的和以太网之间的通信要求。参见示例6。

注意: 在路由器B的source-bridge ring-group不是需要的。

Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!

4. 对以太网的以太网在广域网

/image/gif/paws/12411/etherwan.gif

Router A
!
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!
Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec

注意: source-bridge ring-group在任一个路由器没有要求。

5. 对以太网的令牌环在同一路由器

/image/gif/paws/12411/tokenether.gif

如果需要连接在是本地对路由器的以太网和令牌环之间的站点,您必须使用SR/TLB (转换桥接)。不支持在以太网和令牌环之间的本地DLSw。

Router A

source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1

interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol ieee

对于source-bridge transparent 2000 1000 1 1命令我们有:

  • 2000年是source-bridge ring-group 2000配置的虚拟环号。

  • 1000是假的环号给对以太网域。

  • 那导致透明桥接域的1是网桥网桥号。

  • 1是您要附加到您的源路由网桥域透明网桥组的编号。

注意: 在接口的IP地址没有为SRT/LB要求。

6. SR/TLB和DLSw+

srtlb.gif

Router A
source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol dec
Router B
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.11.1  255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.

在上述示例中, DLSw和SRT/LB配置。SRT/LB只要求,当令牌环的站点需要与以太网的站点谈在同一路由器时,路由器A。如果唯一的要求是为谈的路由器A的以太网站点与路由器的B远程令牌环站,则dlsw桥接组1照料那。

7. 对SDLC over广域网的令牌环

/image/gif/paws/12411/tokensdlc.gif

Router A
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.


Router B

dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Serial 1
 no ip address
 encapsulation sdlc
 no keepalive
 clockrate 9600
 sdlc role primary

 !--- Assumes SDLC station role secondary for the controller.

 sdlc vmac 4000.9999.0100 

 
!--- Virtual MAC address given to the controller which will 
 !--- have sdlc address (01) appended to it.

 sdlc address 01          

 
!--- SDLC address, obtained from controller configuration.

 sdlc xid 01 05D20001     

 
 !--- 01 is the SDLC address and IDBLK/IDNUM should match that 
 !--- in SMN on the host.

 sdlc partner 4000.1020.1000 01 

 
 !--- 4000.1020.1000 is the MAC address of the host
 !--- and 01 is the SDLC address.
 
 sdlc dlsw 1
!

注意: DLSw电路连接在4000.9999.0101和4000.1020.1000之间。并且,上述示例假设一个PU2.0控制器。对于其他PU类型,参考DLSw SDLC故障排除指南

上述配置示例是一些常见网络方案。您能更大量执行与DLSw+,但是这些配置提供您某些基础。记住DLSw+是与互通性其他功能的增强版RSRB用是与RFC 1795和2166一致的其他路由器。


相关信息


Document ID: 12411