IBM 技术 : 数据链路交换 (DLSw) 和加强版数据链路交换 (DLSW+)

DLSw以太网冗余配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

此配置示例实现在数据链路交换(DLSW)网络的思科IOSï ¿  ½软件以太网冗余功能。并且在本文包括调试此功能的技术。以太网冗余功能在Cisco IOS软件版本12.0(5)T被添加了。

此配置示例显示如何实现用于的以太网冗余功能和命令监控连接的状况。三个方案被模拟失败发生,当调试指令运行为了显示每个路由器时行为。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/12345/8-a.gif

配置注释

  • 控制器A配置建立两个逻辑链路控制(LLC)会话用主机;它使用一个Local Service Access Point (LSAP)值0x04和0x08,分别。控制器B只尝试建立一个LLC会话,并且主机使用LSAP值0x04。

  • 对于此配置示例,当两DLSw路由器是UP时,控制器A连接到有路由器Avimimus的主机,并且控制器B连接到主机用路由器涡轮。当两路由器适当地时,是上和工作负载均衡是实现的。

  • 这是控制器和配置的MAC地址:

    • 控制器A

      smac = 0000.2222.0000 (cann), dmac = 0000.6666.0000 (cann)
      lsap = 0x04 and lsap = 0x08, dsap = 0x04 for both connections

      作为容易参考,这些是位交换值此MAC地址:

      smac = 0000.4444.0000 (non-cann), dmac = 0000.6666.0000 (non-cann)
    • 控制器B

      smac = 0000.1111.0000 (cann), dmac = 0000.7777.0000 (cann)
      lsap = 0x08, dsap = 0x04

      作为容易参考,这些是位交换值此MAC地址:

      smac = 0000.8888.0000 (non-cann), dmac = 0000.EEEE.0000 (non-can)
  • 主机有此MAC地址:

    smac = 4000.3745.0000 (non-can) 
    lsap = 0x04

    作为容易参考,这是主机的MAC地址的位交换值:

    smac = 0200.eca2.0000 (cann)
    
  • Avimimus配置是重要的DLSw路由器,并且涡轮配置是从属DLSw路由器。Avimimus分配达到此配置的一个更加低优先级的值。默认优先级是100。列出得用于的命令此处指定每个路由器的优先级值:

    • Avimimus — dlsw transparent redundancy-enable 9999.9999.9999主优先级10

    • 涡轮— dlsw transparent redundancy-enable 9999.9999.9999

    两路由器必须配置使用同一组播MAC地址通信(9999.9999.9999)。

  • Avimimus有配置的此MAC地址:

    Ethernet 0:
    smac = 0000.3333.0000 (cann), 0000.CCCC.0000 (non-cann)
  • 涡轮有配置的此MAC地址:

    Ethernet 0:
    smac = 0000.5555.0000 (cann), 0000.AAAA.0000 (non-cann)
  • Avimimus配置进行此MAC地址映射:

    local mac: 0000.6666.0000 --> remote mac: 0200.ECA2.0000 (cann)

    作为容易参考,这些是位交换值此MAC地址:

    local mac: 0000.6666.0000 --> remote mac: 4000.3745.0000 (non-can)
  • 涡轮配置进行此MAC地址映射:

    local mac: 0000.7777.0000 --> remote mac: 0200.ECA2.0000 (cann)

    作为容易参考,这些是MAC地址的位交换值:

    local mac: 0000.EEEE.0000 --> remote mac: 4000.3745.0000 (non-can)
  • 列出得命令指定MAC地址映射此处在DLSw路由器:

    • Avimimus — dlsw transparent map本地MAC 0000 6666 0000远程MAC 0200 eca2 0000邻居0000 5555 0000

    • 涡轮— dlsw transparent map本地MAC 0000 7777 0000远程MAC 0200 eca2 0000邻居0000 3333 0000

    注意: 在这些命令配置的所有MAC地址必须在规范格式。" local-mac "值代表以太网终端站指向的目的地MAC (DMAC) (0000.6666.0000和0000.7777.0000,在这种情况下)。" remote-mac "值是您尝试通过DLSw到达远程主机的标准表示法。" neighbor "值代表另一个DLSw冗余路由器的以太网接口的MAC地址。

配置

本文档使用以下配置:

重要DLSW冗余路由器
avimimus# show run
Building configuration...
!
hostname avimimus
! 
dlsw local-peer peer-id 1.1.1.1
dlsw remote-peer 0 tcp 3.3.3.1
dlsw transparent switch-support
!
!
interface Ethernet0
 mac-address 0000.3333.0000
 ip address 5.5.5.3 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 media-type 10BaseT
 standby timers 3 10
 standby priority 150 preempt
 standby mac-address 0000.3333.3333
 standby ip 5.5.5.4
 dlsw transparent redundancy-enable 9999.9999.9999 master-priority 10

!--- This is the command used to specify the priority value of Avimimus.

 dlsw transparent map local-mac 0000.6666.0000 remote-mac 0200.eca2.0000 neighbor 0000.5555.0000

!--- This is the command used to specify the MAC address mapping at the DLSw router.

!
interface Serial0
 ip address 1.1.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 4000000
!
end

辅DLSW冗余路由器
turbo# show run
Building configuration...
!
hostname turbo
!
dlsw local-peer peer-id 2.2.2.1
dlsw remote-peer 0 tcp 3.3.3.1
dlsw transparent switch-support
!
interface Ethernet0
 mac-address 0000.5555.0000
 ip address 5.5.5.1 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 standby timers 3 10
 standby priority 100
 standby mac-address 0000.3333.3333
 standby ip 5.5.5.4
dlsw transparent redundancy-enable 9999.9999.9999

!--- This is the command used to specify the priority value of Turbo.

dlsw transparent map local-mac 0000.7777.0000 remote-mac 0200.eca2.0000 neighbor 0000.3333.0000

!--- This is the command used to specify the MAC address mapping at the DLSw router.

!
interface Serial1
 ip address 2.2.2.1 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
end

令牌环DLSw路由器
limno# show run 
!
hostname limno
!
source-bridge ring-group 100
!
dlsw local-peer peer-id 3.3.3.1
dlsw remote-peer 0 tcp 2.2.2.1
dlsw remote-peer 0 tcp 1.1.1.1
!
interface TokenRing0
 ring-speed 16
 source-bridge 10 1 100
 source-bridge spanning 
!
interface Serial0
 ip address 1.1.1.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 ip address 2.2.2.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 clockrate 4000000
!
end

验证

本部分提供的信息可帮助您确认您的配置是否可正常运行。提交所有从此配置的show命令输出。有评论以帮助您的命令输出找出重要部分。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

此部分被划分成这些小节:

show dlsw circuits 和 show llc 命令输出

在此部分,提交show dlsw circuits and show llc命令输出。

重要DLSW冗余路由器
avimimus# show dlsw circuits
Index     local addr(lsap)   remote addr(dsap)  state     uptime
738197594 0000.4444.0000(04) 4000.3745.0000(04) CONNECTED 3d02h
335544411 0000.4444.0000(08) 4000.3745.0000(04) CONNECTED 3d02h
Total number of circuits connected: 2 

DLSw电路建立在终端站MAC (0000.4444.0000)和主机MAC之间。终端站实际上不指向4000.3745.0000,但是路由器进行在dlsw transparent map命令指定的MAC地址映射。

重要DLSW冗余路由器
avimimus# show llc brief
LLC2 Connections: total of 3 connections
Et0 NORMAL 0000.aaaa.0000 0000.cccc.0000 94 94
Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 04
Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 08

第一个LLC会话建立在使用SAP值0x94的DLSw以太网冗余路由器之间。DLSw路由器的MAC地址在非规范格式出现。欲知更多信息,参考本文show dlsw transparent命令输出部分

当终端设备连通与在路由器时,配置的MAC地址另外两LLC会话参考。即0000.6666.0000是在终端站配置的DMAC地址。所有LLC会话看上去起源于接口Ethernet 0 (Et0);然而,之后列出的MAC地址在非规范格式显示。作为容易参考列出他们此方式对show dlsw命令,显示在非规范格式的所有MAC地址。

重要DLSW冗余路由器
avimimus# show llc 
LLC2 Connections: total of 3 connections
Ethernet0 DTE: 0000.aaaa.0000 0000.cccc.0000 94 94 state NORMAL
V(S)=5, V(R)=7, Last N(R)=5, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 9480/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 04 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 8920/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 08 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 9100/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200

辅DLSW冗余路由器
turbo# show dlsw circuits
Index      local addr(lsap)   remote addr(dsap)  state     uptime
2634022913 0000.8888.0000(08) 4000.3745.0000(04) CONNECTED 4d00h
Total number of circuits connected: 1


turbo# show llc brief
LLC2 Connections: total of 2 connections
Et0 NORMAL 0000.cccc.0000 0000.aaaa.0000 94 94
Et0 NORMAL 0000.8888.0000 0000.eeee.0000 04 08


turbo# show llc
LLC2 Connections: total of 2 connections
Ethernet0 DTE: 0000.cccc.0000 0000.aaaa.0000 94 94 state NORMAL
V(S)=7, V(R)=5, Last N(R)=7, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 7480/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.8888.0000 0000.eeee.0000 04 08 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 2410/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200

show dlsw transparent 命令输出

在此部分,提交show dlsw transparent命令输出。

重要DLSW冗余路由器
avimimus# show dlsw transparent neighbor
Interface Ethernet0
0000.cccc.0000 SELF Master
0000.aaaa.0000 Rcvd Master-Accepted VALID

show dlsw transparent neighbor命令显示透明桥接域的DLSw邻居。列出的所有MAC地址在非规范格式显示。然而,当您配置邻接路由器(用dlsw transparent map命令)时,请使用规范格式。路由器Avimimus有最低优先级和,因此是主路由器。

重要DLSW冗余路由器
avimimus# show dlsw transparent cache

Interface Ethernet0
Circuit Cache

local addr(lsap)   remote addr(dsap)  state    Owner
0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
0000.8888.0000(08) 4000.3745.0000(04) NEGATIVE 0000.aaaa.0000
Total number of circuits in the Cache: 3

show dlsw transparent cache命令显示广播域的主电路缓存。此路由器知道在第二个路由器被建立的连接;这对应与条目标记用NEGATIVE状态

重要DLSW冗余路由器
avimimus# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE MAC     BACKUP
---------      ----------     ------
0000.6666.0000 4000.3745.0000 0000.aaaa.0000 STATIC
0000.eeee.0000 4000.3745.0000 0000.aaaa.0000 DYNAMIC(Passive)

在上一个输出中,路由器知道在第二个路由器在其配置方面指定的转换(请参阅条目被标记的静态)并且条目(条目明显动态)配置。本地MAC地址是必须在结束时是被使用的站点作为DMAC的MAC地址。

路由器然后进行转换对出现在远端MAC列下的MAC地址。远程MAC必须匹配DLSw提供连接远程目的地的真正MAC。

第二个条目在被动状态,因此意味着第二个路由器运行并且提供其自己的转换。一旦失败, Avimimus接收该责任。

辅DLSW冗余路由器
turbo# show dlsw transparent neighbor 

Interface Ethernet0
0000.aaaa.0000 SELF      Slave
0000.cccc.0000 Connected MASTER.



turbo# show dlsw transparent cache 

Interface Ethernet0
Circuit Cache 

local addr(lsap)   remote addr(dsap)     state    Owner
0000.8888.0000(08) 4000.3745.0000(04)    POSITIVE SELF
Total number of circuits in the Cache: 1


turbo# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE Mac     BACKUP
---------      ----------     ------
0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Passive)

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

此部分提交所有从此配置的debug命令的输出。评论包括以命令输出帮助您找出重要部分。

注意: 在发出调试指令前,参考关于调试指令的重要信息

此部分被划分成这些小节:

主路由器模拟故障期间的 debug dlsw transparent 命令输出

此部分提交在主路由器的模拟故障期间,生成的debug dlsw transparent命令输出。

  • debug dlsw transparent master —显示与主从事件涉及的调试消息。

  • debug dlsw transparent circuits —显示调试消息涉及到透明桥接域的主电路缓存。

  • debug dlsw transparent address-map —显示与本地路由器作为一邻接对等体的备份在本地路由器的MAC地址映射和所有映射涉及的调试消息。

重要DLSW冗余路由器
avimimus# show debug
DLSw:
DLSw Ethernet Redundancy - Master debugging is on
DLSw Ethernet Redundancy - Circuits debugging is on
DLSw Ethernet Redundancy - Address Map debugging is on

Mar 5 18:07:10.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:30.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:40.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:50.039: DLSW-ER: Sending MP Frame
Mar 5 18:08:00.047: DLSW-ER: Sending MP Frame
Mar 5 18:08:10.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:20.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:30.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:40.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:50.051: DLSW-ER: Sending MP Frame

重要DLSW冗余路由器发送Master Present (MP)帧每10秒。

这里,当以太网接口被关闭时,失败介绍:

重要DLSW冗余路由器
avimimus# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
avimimus(config)# interface ethernet0
avimimus(config-if)# shut


Mar 5 18:09:00.951: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Init
Mar 5 18:09:02.951: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down
Mar 5 18:09:02.951: DLSW-ER:dm_action_b: LLC2 session dead freeing neighbor 0000.aaaa.0000
Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:09:02.971: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:02.979: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:03.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
 state to down

这是从辅路由器采取的调试在失败期间:

辅DLSW冗余路由器
turbo#
Mar 5 18:09:10.251: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Standby -> Active
Mar 5 18:09:10.583: DLSW-ER:dm_action_r: LLC2 session dead to neighbor 0000.cccc.0000 
Mar 5 18:09:10.587: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:09:10.591: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:09:10.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:10.595: DLSW-ER:dm_action_u: Freeing current master 0000.cccc.0000
Mar 5 18:09:10.599: DLSW-ER:dm_action_u: Changing state to Master
Mar 5 18:09:20.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:30.595: DLSW-ER: Sending MP Frame

在上一个语法,涡轮变为主路由器并且接收在Avimimus路由器配置的转换。

这是在涡轮的调试,当通过Avimimus reattempt连接对主机的连接的终端站:

辅DLSW冗余路由器
turbo#
Mar 5 18:09:40.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:40.927: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.939: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.995: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.995: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:40.999: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4

在上一个语法,您看到涡轮完成由Avimimus以前拥有)的需要的转换(设置从控制器A.的第一LLC会话。此会话使用LSAP 0x04和RSAP 0x04。

辅DLSW冗余路由器
Mar 5 18:09:41.963: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.975: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.979: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:41.983: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8

在上一个语法,您看到涡轮完成由Avimimus以前拥有)的需要的转换(设置从控制器A.的第二LLC会话。此会话使用LSAP 0x08和RSAP 0x04。

辅DLSW冗余路由器
Mar 5 18:09:41.991: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.995: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:41.999: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4

第一个DLSw电路由UGotIt说明建立了,指示。

辅DLSW冗余路由器
Mar 5 18:09:42.003: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:09:42.971: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:42.975: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:42.983: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8

第二个DLSw电路完成。

辅DLSW冗余路由器
Mar 5 18:09:42.987: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:09:50.595: DLSW-ER: Sending MP Frame

这是表明的所有DLSw命令涡轮接管了Avimimus,并且电路全部通过涡轮连接:

辅DLSW冗余路由器
turbo# show dlsw transparent cache
Interface Ethernet0
Circuit Cache
local addr(lsap)   remote addr(dsap)  state    Owner
0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
0000.8888.0000(08) 4000.3745.0000(04) POSITIVE SELF
Total number of circuits in the Cache: 3

turbo# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE Mac     BACKUP
---------      ----------     ------
0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Active)

在上一个语法,您能看到第二个转换的状况当前是DYNAMIC(Active),表明Avimimus必须发生故障。

辅DLSW冗余路由器
turbo# show dlsw circuits
Index       local addr(lsap)    remote addr(dsap)   state     uptime
4009754676  0000.4444.0000(04) 4000.3745.0000(04) CONNECTED  00:01:05
1610612789  0000.4444.0000(08) 4000.3745.0000(04) CONNECTED  00:01:04
2634022913  0000.8888.0000(08) 4000.3745.0000(04) CONNECTED  4d01h
Total number of circuits connected: 3

主路由器恢复期间的 debug dlsw transparent 命令输出

此部分提交在主路由器的恢复期间,生成的debug dlsw transparent命令输出。

重要DLSW冗余路由器
avimimus# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
avimimus(config)# interface ethernet0
avimimus(config-if)# no shut

Mar 5 18:12:00.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:03.127: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Mar 5 18:12:03.595: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Listen -> Active
Mar 5 18:12:04.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
 state to up
Mar 5 18:12:10.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:10.599: DLSW-ER: New neighbor: master 0000.cccc.0000, neighbor 0000.aaaa.0000
Mar 5 18:12:10.599: DLSW-ER:dm_action_a: Rcvd MP with worse priority from 0000.aaaa.0000
Mar 5 18:12:10.607: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.aaaa.0000
Mar 5 18:12:10.607: DLSW-ER: Sending MC to 0000.aaaa.0000
Mar 5 18:12:10.615: DLSW-ER:dm_action_d: Received MA from neighbor 0000.aaaa.0000 

在上一个语法, Avimimus接收从涡轮的Master Accept (MA)消息,确认Avimimus当前是新的主控。

这里,两路由器交换他们配置的映射的BACKMEUP_REQ。必须由ACK跟随每请求。

辅DLSW冗余路由器
Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.6666.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:10.615: DLSW-ER: Sending DN to 0000.aaaa.0000
Mar 5 18:12:10.623: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for map entry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.623: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:10.651: DLSW-ER:dm_action_f: Rcvd CO from 0000.aaaa.0000
Mar 5 18:12:10.667: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.667: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:19.731: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.735: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:20.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:20.647: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.aaaa.0000 for mapentry 0000.6666.0000 
 --> 4000.3745.0000
Mar 5 18:12:20.647: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:12:30.087: DLSW-ER: Sending MP Frame

这是从涡轮采取的调试,当主路由器Avimimus过来时:

辅DLSW冗余路由器
turbo#
Mar 5 18:12:00.595: DLSW-ER: Sending MP Frame
Mar 5 18:12:03.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Speak
Mar 5 18:12:10.087: DLSW-ER: New neighbor: master 0000.aaaa.0000, neighbor 0000.cccc.0000
Mar 5 18:12:10.091: DLSW-ER:dm_action_o: Rcvd MP with better priority: 0000.cccc.0000
Mar 5 18:12:10.595: DLSW-ER: Sending MP Frame
Mar 5 18:12:10.611: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.cccc.0000
Mar 5 18:12:10.611: DLSW-ER: Sending MA to 0000.cccc.0000

涡轮确认从Avimimus的消息,涡轮然后变为从。

辅DLSW冗余路由器
Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)
Mar 5 18:12:10.623: DLSW-ER:dm_action_c: Rcvd MC with better priority from 0000.cccc.0000
Mar 5 18:12:10.627: DLSW-ER:dm_action_c: Changing state: Master to Slave

涡轮变为辅路由器。

辅DLSW冗余路由器
Mar 5 18:12:10.627: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.cccc.0000 for mapentry 0000.6666.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.635: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(4) 4000.3745.0000(4)) with 
 lmac 0000.6666.0000
Mar 5 18:12:10.643: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(8) 4000.3745.0000(4)) with 
 lmac 0000.6666.0000

在上一个语法,涡轮中断必须由Avimimus拥有的DLSw电路。(必须扯下电路,当主控恢复。)在涡轮接收从Avimimus后的BACKMEUP_REQ此终端发生。

辅DLSW冗余路由器
Mar 5 18:12:10.643: DLSW-ER: dm_action_n: Rcvd DN frame from 0000.cccc.0000
Mar 5 18:12:10.647: DLSW-ER:Sending CO frame # 0 to 0000.cccc.0000
Mar 5 18:12:10.651: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.655: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:12:10.659: DLSW-ER:dm_action_s: LLC2 session up to neighbor 0000.cccc.0000
Mar 5 18:12:10.659: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)
Mar 5 18:12:10.671: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.675: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:12:13.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Speak -> Standby
Mar 5 18:12:19.723: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.727: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.731: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:19.735: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:20.643: DLSW-ER: Sending BACKMEUP_ACK 0000.6666.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)

turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
2634022913  0000.8888.0000(08)   4000.3745.0000(04) CONNECTED  4d01h
Total number of circuits connected: 1

在此处语法被提交发生的调试,当终端站设法重建连接。Avimimus是备份担当主路由器。

重要DLSW冗余路由器
avimimus#
Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.079: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.079: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:40.079: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:40.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:41.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:41.075: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:41.075: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:41.075: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:41.079: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:41.079: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:12:42.075: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:42.075: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000


avimimus# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  00:00:08
4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  00:00:08
Total number of circuits connected: 2

建立辅路由器 DLSw 电路期间的 debug dlsw transparent 命令输出

此部分提交生成,当辅路由器尝试启动DLSw电路时的debug dlsw transparent命令输出。

在从获得许可接受电路前,检查从和主控之间的通信是有用的。

当现有DLSw电路在辅路由器时,被清除方案被模拟。

辅DLSW冗余路由器
turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
2634022913  0000.8888.0000(08)  4000.3745.0000(04) CONNECTED   4d02h
Total number of circuits connected: 1


turbo# clear dlsw circuits 2634022913
turbo#
Mar 5 20:02:37.426: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:02:37.430: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.8888.0000:8 

涡轮通知主路由器清除其仅删除电路的缓存条目。

辅DLSW冗余路由器
Mar 5 20:03:07.398: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:07.462: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:07.466: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:07.470: DLSW-ER:IW -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8

涡轮收到从终端设备的一个流入请求连接对终端主机。在20:03:07.470,涡轮通知此请求的主路由器。

辅DLSW冗余路由器
Mar 5 20:03:07.474: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.458: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:08.462: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.474: DLSW-ER:dm_action_k: Rcvd UG for 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.478: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.eeee.0000

涡轮从其主控获得UG,并且电路启动。

辅DLSW冗余路由器
turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
385876023   0000.8888.0000(08)  4000.3745.0000(04) CONNECTED  00:00:33
Total number of circuits connected: 1

这是数据被采取在主路由器,在从尝试启动电路时候。

重要DLSW冗余路由器
avimimus# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  01:49:13
4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  01:49:13
Total number of circuits connected: 2


avimimus# show dlsw transparent cache
Interface Ethernet0
Circuit Cache

local addr(lsap)        remote addr(dsap)     state     Owner
0000.4444.0000(04)     4000.3745.0000(04)   POSITIVE    SELF
0000.4444.0000(08)     4000.3745.0000(04)   POSITIVE    SELF
0000.8888.0000(08)     4000.3745.0000(04)   NEGATIVE    0000.aaaa.0000
Total number of circuits in the Cache: 3

Mar 5 20:02:37.433: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:02:41.409: DLSW-ER: Sending MP Frame
Mar 5 20:02:51.409: DLSW-ER: Sending MP Frame
Mar 5 20:03:01.417: DLSW-ER: Sending MP Frame
Mar 5 20:03:07.473: DLSW-ER:dm_action_j: Rcvd IW <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.473: DLSW-ER:UG -> 0000.aaaa.0000: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:11.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:21.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:31.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:41.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:51.421: DLSW-ER: Sending MP Frame
avimimus#un all


相关信息


Document ID: 12345