IBM 技术 : 数据链路交换 (DLSw) 和加强版数据链路交换 (DLSW+)

数据链路交换加强版

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

数据链路交换(DLSW)是支持逻辑链路控制(LLC)传输在WAN的IBM实现的标准。DLSw是远程源路由桥接(RSRB)一更加精心制作的表并且是特定至于什么或不能桥接。DLSw要求路由器传输一有效LLC2会话或NetBIOS会话。

Cisco路由器实现RFC 1795 (DSLw标准)和2166 (DLSw版本2)。并且, DLSw比其他方法实现广播控制的更多功能并且传输在广域网间的较少信息。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

一般命令

此部分包括重要DLSw命令、命令配置的DLSw和命令排除故障的DLSw。

source-bridge ring-group

在配置DLSw的第一步是添加source-bridge ring-group命令。这连接令牌环接口执行的源路由桥接(SRB)。

任务 命令
定义振铃组。 source-bridge ring-group ring-group [virtual-mac-address]

注意: 当执行在只有以太网接口的路由器的DLSw,那里是没有需要设置环组

定义本地对等体识别

下一选项卡是定义本地对等体识别。这是在同一个方框的一个IP地址。这基本上开始在路由器的DLSw。

任务 命令
定义DLSw+本地对等体。 dlsw local-peer [peer-id ip-address] [group group] [border] [cost cost] [lf size] [keepalive seconds] [passive] [promiscuous] [biu-segment]

在配置DLSw的基本选项是设立local peer-id ip-address。这些是命令参数的说明:

  • 边界—这些命令一起发出创建网络的边界对端。

  • 开销—,当有多条路径到同一个位置时,此命令发出。此命令告诉路由器如何首先到达这些远程站点使用最低开销路径。

  • lf —此命令确定此对等体能处理的最大的帧大小。帧大小可以是:

    • 516-516字节最大帧大小

    • 1470-1470字节最大帧大小

    • 1500-1500字节最大帧大小

    • 2052-2052字节最大帧大小

    • 4472-4472字节最大帧大小

    • 8144-8144字节最大帧大小

    • 11407-11407字节最大帧大小

    • 11454-11454字节最大帧大小

    • 17800-17800字节最大帧大小

  • Keepalive —此命令定义了间隔介于中间的keepalive数据包。间隔能范围自0到1200秒。当配置按需拨号路由(DDR)的时, DLSw它通常设置到0。

  • 被动—此命令配置路由器不启动从路由器的一对等体启动。

  • 混乱—此命令意味着路由器接受从请求对等体启动的所有远端对等体的连接。此命令是有用的在有许多对等体的大站点,因为您不必须定义核心路由器的所有远端对等体。

  • biu分段—此命令是允许DLSw控制分段大小高在系统网络结构DLSw的一个选项(SNA)层。此命令启用终端站相信他们能发送大量数据。

定义远端对等体

在定义本地对等体以后,您定义了远端对等体。您能定义对等体的三种类型:TCP,快速顺序传输(FST),和处理高层次链接控制(HDLC)和帧中继。这些是发出的命令的说明定义远端对等体:

任务 命令
在帧中继的直接封装 dlsw远程对等项list-number帧中继接口序列号dlci-number [backup-peer ip-address] [bytes-netbios-out bytes-list-name] [cost cost] [dest-mac mac-address] [dmac-output-list access-list-number] [host-netbios-out host-list-name] [keepalive seconds] [lf size] [linger minutes] [lsap-output-list list] [pass-thru]
在HDLC的直接封装 dlsw remote-peer list-number interface serial number [backup-peer ip-address] [bytes-netbios-out bytes-list-name] [cost cost] [dest-mac mac-address] [dmac-output-list access-list-number] [host-netbios-out host-list-name] [keepalive seconds] [lf size] [linger minutes] [lsap-output-list list] [pass-thru]
FST dlsw远程对等项list-number fst IP地址[backup-peer ip-address] [bytes-netbios-out bytes-list-name] [cost cost] [dest-mac mac-address] [dmac-output-list access-list-number] [host-netbios-out host-list-name] [keepalive seconds] [lf size] [linger minutes] [lsap-output-list list] [pass-thru]
TCP dlsw remote-peer list-number tcp ip-address [backup-peer ip-address] [bytes-netbios-out bytes-list-name] [cost cost] [dest-mac mac-address] [dmac-output-list access-list-number] [dynamic] [host-netbios-out host-list-name] [inactivity minutes] [keepalive seconds] [lf size] [linger minutes] [lsap-output-list list] [no-llc minutes] [priority] [tcp-queue-max size] [超时seconds][v2-single-tcp]

这些是options命令的说明:

  • 备份对等—此option命令定义了备份此对等体的对等体,在第一对等体出故障情况下。

  • 开销—此option命令定义了开销此对等体。使用此命令,当有多条路径对目的地时,并且,当您需要一个支持首选的方案时。

  • 目的mac动态no-llc非活动—这些options命令在本文的备份/代价对等体部分讨论。

  • dmac-output-list —此option命令发出定义告诉路由器的访问列表哪些远程目的地MAC地址您允许或者拒绝,探测器数据流。

  • host-netbios-out —此option命令发出运用NetBIOS主机过滤器名称。

  • Keepalive —此option命令以在Keepalive之间的秒钟发出确定间隔。它使用主要DDR设置。

  • lf —此option命令指定为对等体允许的最大的大小。

  • 徘徊—此option命令指定时间路由器打开变得激活的备份对等(由于主要的失败),在主链路再后变得激活。

  • 优先级—此option命令创建DLSw流量的优先级的多个对等项。

  • tcp-queue-max —此option命令更改默认值为200 TCP队列的。

  • 超时—此option命令是TCP在切断连接前等待确认秒钟的数量。

  • V2-single-tcpM —此option命令设计用于网络地址转换(NAT)环境。每对等体认为它有高IP地址防止每对等体切断其中一TCP连接。

用于DLSw的计时器

这些是用于DLSw的计时器的说明:

参数 说明
icannotreach-block-time 不可得到的资源缓存寿命,在期间搜索该资源阻塞。有效范围是1到86400秒。默认是0 (禁用)
netbios-cache-timeout NetBIOS名称位置缓存寿命两的本地和远程可连接性缓存。有效范围是1到86400秒。默认是16分钟。
netbios-explorer-timeout 时间长度IOS�软件在标记资源不可达的前等待探测器响应(LAN和广域网)。有效范围是1到86400秒。默认是6秒。
netbios-retry-interval NetBIOS Explorer重试间隔(仅LAN)。有效范围是1到86400秒。默认是1秒。
netbios-verify-interval 在缓存条目的创建的之间间隔,并且,当条目被标记作为过时。如果搜索请求为长时间未用的缓存条目进来,处理的验证查询发送保证仍然存在。有效范围是1到86400秒。默认是4分钟。
sna-cache-timeout SNA MAC服务接入点的时间长度(SAP)位置缓存条目存在,在丢弃前(本地和远程)。有效范围是1到86400秒。默认是16分钟。
sna-explorer-timeout 时间长度IOS软件在标记资源不可达的前等待探测器响应(LAN和广域网)。有效范围是1到86400秒。默认时间为 3 分钟。
sna-retry-interval 在SNA Explorer重试次数(LAN)之间的间隔。有效范围是1到86400秒。默认是30秒。
sna-verify-interval 在缓存条目的创建的之间间隔,并且,当条目被标记作为过时。如果搜索请求为长时间未用的缓存条目进来,处理的验证查询发送保证仍然存在。有效范围是1到86400秒。默认是4分钟。
explorer-wait-time 以秒钟计时,路由器等待所有Explorer在确定前使用的哪回来对等体。

这些参数是非常有用的。例如,您能更改间隔以秒钟路由器发送Explorer。这帮助通过增加他们之间的时间减少在网络的浏览器数量。并且,您能更改路由器计时缓存条目的值。

另外的DLSw命令

这些是其他重要DLSw命令:

  • DLSw allroute SNA/netbios —此命令发出更改DLSw行为,以便所有路由Explorer使用而不是单个路由探测器。

  • dlsw桥接组—此命令发出附加透明地与DLSw的桥接域。当配置NetBIOS与以太网时,它广泛使用。

  • dlsw explorerq-depth —此命令设置DLSw探测队列的值。此命令在explorer-queue命令正常的源网桥以后发出,但是指需要处理的所有CANUREACH (CUR)帧。此命令是重要,因为包括从以太网的数据包,即使在source-bridge explorerq-depth命令没有包括。关于此命令的更多信息参考的了解和故障排除源路由桥接

显示命令

当排除故障DLSw时,在此部分和输出描述的显示命令是有用的。

show dlsw peer

此命令提供关于对等体的信息。每个远端对等体配置显示此处,包括数量已发送和收到的信息包。

Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 5.5.5.1         CONNECT          2         2  conf      0    0   0 00:00:06

这些是可能的状态:

  • 连接—此状态意味着DLSw对等体是正在运行的。

  • 断开此状态意味着对等体下来或没有连接。

  • CAP_EXG —此状态意味着DLSw在与远端对等体的功能开关。

  • WAIT_RD —此状态是在开始的最后一步对等体。此对等体等待远端对等体打开读的端口。当对等体开始和发出debug dlsw peer命令时,参考本文的Debugging部分关于的更多信息。

  • WAN_BUSY —此状态意味着TCP出局的队列满,并且数据包不可能传送。

show dlsw peer命令也显示丢包数量,数量在特定对等体间的电路, TCP队列和正常运行。丢弃计数器增加对于这些原因:

  • 广域网接口不上升为直接对等体。

  • DLSw设法发送数据包,在对等体完全连接前(等待的TCP事件或功能事件)。全双工的出局TCP队列。

  • FST序号计数不匹配。

  • 不能获得缓冲区减慢交换机FST数据包。

  • 高端的CiscoBus控制器失败;不能移动从接收缓冲区的数据包传送缓冲区或者反之亦然。

  • FST数据包目的IP地址不匹配本地对等体ID。

  • 广域网接口不为FST对等体。

  • 没有配置的SRB路由缓存命令。

  • Madge环缓冲区是全双工在低端系统:提供LAN的广域网太快速。

show dlsw capabilities

DLSw: Capabilities for peer 5.5.5.1(2065)
  vendor id (OUI)         : '00C' (cisco)
  version number          : 1
  release number          : 0
  init pacing window      : 20
  unsupported saps        : none
  num of tcp sessions     : 1
  loop prevent support    : no
  icanreach mac-exclusive : no
  icanreach netbios-excl. : no
  reachable mac addresses : none
  reachable netbios names : none
  cisco version number    : 1
  peer group number       : 0
  border peer capable     : no
  peer cost               : 3
  biu-segment configured  : no
  local-ack configured    : yes
  priority configured     : no
  version string          :
Cisco Internetwork Operating System Software
IOS (tm) 4500 Software (C4500-J-M), Version 10.3(13), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1996 by cisco Systems, Inc.

show dlsw reachability

DLSw MAC address reachability cache list
Mac Addr        status     Loc.    peer/port            rif
0800.5a0a.c51d  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a49.1e38  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a95.3a13  FOUND      REMOTE  5.5.5.1(2065)
 
DLSw NetBIOS Name reachability cache list
NetBIOS Name    status     Loc.    peer/port            rif
PIN-PIN         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
QUENEPA         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
WIN95           FOUND      REMOTE  5.5.5.1(2065)

Status字段是多数重要部分show dlsw reach命令。这些是可能的状态:

  • 找到—路由器查找设备。

  • 搜索—路由器搜索资源。

  • NOT_FOUND —负高速缓冲存储打开,并且站点未响应对查询。

  • 不确定—站点配置,但是DLSw未验证它。

  • 验证—正在验证的缓存信息,因为缓存去过时或者用户配置验证。

show dlsw circuit

Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:32; Rx CW:20, Granted:32
        RIF = 06B0.0021.00F0

当发出show dlsw circuit命令时,请注意流量控制。流量控制存在一个每电路基本类型。这是发生的通信,当两DLSw对等体分配电路可能的转移时窗口。此值根据电路尝试移动的流量总量增加或减少。值能根据网云的拥塞更改。

show dlsw circuit命令自IOS 11.1是广泛。命令当前允许您查看在服务接入点(SAP)值或MAC值的DLSw电路,简化查找电路,当排除故障时。以下是输出示例:

ibu-7206#sh dlsw cir
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
ibu-7206#sh dls cir det ?
  <0-4294967295>  Circuit ID for a specific remote circuit
  mac-address     Display all remote circuits using a specific MAC
  sap-value       Display all remote circuits using a specific SAP
  <cr>
 
ibu-7206#show dlsw circuit detail mac 4000.0000.0001
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:29; Rx CW:20, Granted:29
        RIF = 06B0.0021.00F0
241-00  4000.0000.0001(04)  4001.68ff.0000(04) CONNECTED
        Port:To0          peer 5.5.7.1(2065)
        Flow-Control-Tx CW:20, Permitted:27; Rx CW:20, Granted:27
        RIF = 0630.00F1.0010
s5e#sh cls
DLU user: DLSWDLU
      SSap:0x63       type:  llc0   class:0
        DTE:0800.5a95.3a13 0800.5a0a.c51d F0 F0
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
 
        DTE:4000.0000.0001 4001.68ff.0000 04 04
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
TokenRing0 DTE: 4000.0000.0001 4001.68ff.0000 04 04 state NORMAL
   V(S)=23, V(R)=23, Last N(R)=22, Local window=7, Remote Window=127
   akmax=3, n2=8, Next timer in 1240
   xid-retry timer      0/0       ack timer    1240/1000
   p timer              0/1000    idle timer  10224/10000
   rej timer            0/3200    busy timer      0/9600
   akdelay timer        0/100     txQ count       0/200

排除故障

默认情况下, DLSw终止LLC会话在路由器(local-ack)。另外,因为它终止路由信息字段(RIF),有要考虑的其他设计问题。最普通的DLSw问题在此部分描述。

环路

记住的多数重要事情之一关于DLSw是RIF终端。因为在网络的主要环路可能容易地创建,这是问题。此图表展示一条环路:

/image/gif/paws/12249/dlsw_1.gif

在这种情况下,因为DLSw终止RIF,数据包无限地四处走动。这是因为,在CUR帧从对等时候发送,接收的对等体创建一台新的Explorer (没有RIF)并且发送它。Explorer的步骤描述:

  1. 3174在环11发送Explorer到达主机。

  2. 两个SF1和网桥复制帧。

  3. SF1创建CUR帧对LA1 (其对等体)告诉LA1 3174要到达主机。

  4. SF2收到数据包并且做同一件事。

  5. 现在LA1和LA2创建Explorer并且发送它到环。

  6. LA1和LA2接收创建的Explorer。

  7. 现在有难题,因为每侧相信3174本地附加。

  8. 每个路由器有3174,本地和远程。

  9. 现在他们发送ICANREACH帧对SF1和SF2,分别,创建从主机的一答复往3174。

  10. SF1和SF2在令牌环放置探测器响应,并且其中每一个学习主机MAC地址本地和远程可及的。

  11. 无限地循环的Explorer的有效Dlsw reachability防火墙。然而,用未编号的信息(UI)帧,这能循环,然后驱动CPU和线路利用率至100%。

如果这发生,请验证在路由器的虚拟环正确地是相同的网云的在每一侧,显示在此图表:

/image/gif/paws/12249/dlsw_2.gif

此网云在每一侧的路由器有确切同样虚拟环号。这保证一个路由器发送通过环已经通过的Explorer,路由器然后丢弃它。当LA1生成SF1时接收的CUR帧的一台Explorer, LA2下降它,因为Explorer通过环1.已经通过。在此方案中,重要的是路由器有配置的一不同的网桥,如果数据包走向同一环,是网络的LA侧事例。

在同一个方案的以太网版本中,您必须禁用对等体。示例在此图表中显示:

dlsw_3.gif

由于在以太网的一数据包没有RIF,路由器不能确定广播,创建由在LAN的另一个路由器,是否是从另一个路由器或从始发站。使用SNA,数据包本地产生或远程。由于从令牌环环境的Explorer实际上有两个源及目的地MAC地址,他们是在以太网的没有一广播,然而定向帧到从别的一个站点。

什么在之前的图表中发生在这些步骤解释:

  1. Explorer从3174派遣到主机。

  2. 此Explorer由SF1和SF2接受。

  3. SF1和SF2其中每一个生成CUR对另一侧LA1和LA2。

  4. 这些生成主机回应的Explorer;因为它是单个路由探测器,响应给与一台所有路由探测器。

  5. LA1和LA2创建CUR帧对SF1和SF2,创建3174的数据包。

  6. SF1听到来自以太网的主机的MAC地址和当前相信主机在本地LAN查找。但是在缓存SF1,主机ID从远端对等体响应。

  7. 这强制路由器有主机本地和远程,因此意味着DLSw是残破的。

备份/代价对等体

在对等体失去情况下,备份对等添加容错到DLSw。这在核心环境通常设置,以便,当核心路由器出故障时,另一个路由器能接受失败路由器。配置和图表在此部分说明一个备份对等设置。

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   cost 2 promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   cost 4 promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

/image/gif/paws/12249/dlsw_8.gif

记住的第一件事关于DLSw开销对等体是两对等体是活跃的。路由器只保养一备份对等。如果请徘徊配置,它能当时有两。这是什么在之前的图表中发生:

  1. D3a接收Explorer并且通过发送CUR帧开始进程对每个远端对等体。

  2. D3B和D3C接收CUR帧。其中每一生成Explorer到主机,回复回到D3B和D3C。

  3. D3B和D3C回应回到与Icanreach的D3A。

  4. D3A发送对终端站的探测器响应。

  5. 远端站启动DLSw电路,有SNA的NetBIOS的交换标识(XID)和设置异步平衡模式扩展(SABME)的。

  6. D3A选择在可接通性内的更低成本。

有在多久可以定义告诉路由器等待所有Explorer回来到D3A的D3A的一个计时器。这避免问题以能发生的开销,当路由器用回来到它的第一台Explorer时。发出DLSw计时器Explorer-wait-time <seconds>命令设置此计时器。

另外,当执行的边界对端, DLSw只发送一CUR帧给最便宜的对等体。它跟,当执行的开销,不用边界对端不同运行。

备份对等有点不同地经营。您指定是备份为指定的对等体的对等体的备份对等。这意味着有备份语句的对等体是备份对等。

指定徘徊选项,以便,当主对等体再时变得可操作,电路不能立即切断。因为您不要使用有故障对等体,这是有用的,如果主对等体上上下下变化。

这展示备份对等的配置:

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1 backup-peer 1.1.14.1 linger 5
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

对等体通过发出show dlsw peer命令断开:

d3a#sh dls peer
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 1.1.14.1        CONNECT        464      1286  conf      0    0   0 03:17:02
 TCP 1.1.12.1        DISCONN          0         0  conf      0    0   -        -

边界对端

因为他们解决广播控制问题在网络的边界对端是一个重要DLSw功能。此示例说明边界对端如何配置,并且什么发生,当会话出来:

/image/gif/paws/12249/dlsw_6.gif

D3E
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3e
!
!
dlsw local-peer peer-id 1.1.11.1 group 1
   border promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
!
interface Loopback0
 ip address 1.1.11.1 255.255.255.0
!
interface Serial0
 ip address 1.1.3.1 255.255.255.0
!
interface Serial1
 ip address 1.1.2.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 ip address 10.17.1.189 255.255.255.0
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3C
Current configuration:
!
version 11.1

service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
dlsw local-peer peer-id 1.1.12.1 group 2
   border promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 no fair-queue
 clockrate 500000
!
interface Serial1
 ip address 1.1.3.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 no ip address
 shutdown
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3F
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3f
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.10.1 group 1
   promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.10.1 255.255.255.0
!
interface Serial0
 ip address 1.1.2.1 255.255.255.0
 no fair-queue
!!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1 group 2
   promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.2 255.255.255.0
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

配置边界对端第一部分是创建混杂对等体。尝试的混杂对等体接受从所有DLSw路由器的连接打开一对等体用此路由器。例如,在之前的图表中,您希望D3A打开有D3F的一对等体。如果没有任何边界对端,您需要设置网络的静态对等体。这工作良好,但是,当您有数百站点时,并且您使用静态对等体,当路由器需要远程时查找站点,路由器必须发送CUR帧对每对等体。这能导致很多开销。

另一方面,当您使用边界对端时,该远程路由器只需要发送一请求对边界对端。此请求通过组然后被传播,并且远程路由器打开一对等体以另一个远程路由器启动电路和建立连接。此进程在此图表中解释:

/image/gif/paws/12249/dlsw_7.gif

  1. 当D3A接收Explorer时,发送广播对D3C。D3C是D3A附加的边界对端。

  2. 当D3C接收CUR帧时,在组中发送CUR帧给所有对等体。D3C在另一组中也发送测试帧对配置如此执行的所有本地接口,并且发送CUR帧给边界对端。

  3. D3E接收从D3C的CUR在另一组中。然后D3E通过发送CUR执行同样对组和所有本地接口的所有对等体。

  4. D3F接收CUR帧并且发送测试轮询对本地接口。如果D3F有指向另一个路由器的一对等体,不能响应该CUR帧到另一个路由器。

  5. 当D3F收到终端站的时一回复,返回ICANREACH帧对D3E。

  6. D3E发送它对D3C,转发它对D3A。D3A发送对设备的测试响应。

  7. 当终端站开始时一个DLSw电路,有SNA的NetBIOS的XID和SABME的, D3A首次与D3F的一对等连接并且启动会话。

这是从两D3C和D3A的调试在此进程中:

d3a#
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 40
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 40 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 0
DLSw: sending bcast to BP peer 1.1.12.1(2065)

进入路由器的测试帧被看到。然后,路由器产生CUR帧对D3C。D3C活动显示此输出:

DLSw: Pak from peer 1.1.13.1(2065) with op DLX_MEMBER_TO_BP
DLSw: recv_member_to_border() from peer 1.1.13.1(2065)
DLSw: passing pak to core originally from 1.1.13.1 in group 2
%DLSWC-3-RECVSSP: SSP OP = 3( CUR  ) -explorer from peer 1.1.13.1(2065)
DLSw: Pak from peer 1.1.11.1(2065) with op DLX_RELAY_RSP
DLSW: relaying pak to member 1.1.13.1 in group 2

当D3C收到从D3A时的数据包,转发数据包对核心。以后,您看到从中继回到D3A的远端对等体的答复。然后D3A开始连接(根据要求对等体)与在此调试的远端对等体D3F :

DLSw: Pak from peer 1.1.12.1(2065) with op DLX_RELAY_RSP
DLSW: creating a peer-on-demand for 1.1.10.1
DLSw: passing pak to core originally from 1.1.10.1 in group 1
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 1.1.10.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44
DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 4
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: action_a() attempting to connect peer 1.1.10.1(2065)
DLSw: action_a(): Write pipe opened for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state DISCONN, new state WAIT_RD
DLSw: passive open 1.1.10.1(11003) -> 2065
DLSw: action_c(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state WAIT_RD, new state CAP_EXG
DLSw: CapExId Msg sent to peer 1.1.10.1(2065)
DLSw: Recv CapExId Msg from peer 1.1.10.1(2065)
DLSw: Pos CapExResp sent to peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 1.1.10.1(2065)
DLSw: action_f(): for peer 1.1.10.1(2065)
DLSw: closing read pipe tcp connection for peer 1.1.10.1(2065)
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: START-FSM (1474380): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 106
DLSw: END-FSM (1474380): state:DISCONNECTED->LOCAL_RESOLVE

在路由器收到从边界对端后的中继的数据包,打开一对等体根据要求有远端对等体D3F的(1.1.10.1),并且启动电路。

调试

在所有DLSw网络的第一步启动对等体。没有对等体,没有数据交换。大多什么的详细信息发生在DLSw对等体之间在RFC 1795解释。

注意: 如果与非Cisco设备谈通过DLSw,请使用DLSw。然而,在Cisco路由器之间,使用DLSw+。

此输出是从发出debug dlsw对等体和启动对等体在两个Cisco路由器之间:

DLSw: passive open 5.5.5.1(11010) -> 2065
DLSw: action_b(): opening write pipe for peer 5.5.5.1(2065)
DLSw: peer 5.5.5.1(2065), old state DISCONN, new state CAP_EXG
DLSw: CapExId Msg sent to peer 5.5.5.1(2065)
DLSw: Recv CapExId Msg from peer 5.5.5.1(2065)
DLSw: Pos CapExResp sent to peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
shSw: peer 5.5.5.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 5.5.5.1(2065)
DLSw: action_f(): for peer 5.5.5.1(2065)
DLSw: closing read pipe tcp connection for peer 5.5.5.1(2065)

此输出显示开始对等体和打开一TCP会话用另一个路由器的路由器。然后它开始对Exchange功能。在功能以后正向交换,对等体连接。与RSRB对比, DLSw不迁移对等体向一个闭合状态,当没有活动时,例如流量。他们总是保持已连接。如果对等体被断开,请发出debug dlsw对等体确定他们为什么没有能力在开端上。

当排除故障会话启动时,请发出debug dlsw核心观察会话故障和验证,如果电路出来。

这是一个3174通信控制器的流对主机通过DLSw+ :

/image/gif/paws/12249/dlsw_4.gif

debug dlsw输出显示会话的流正确地启动:

ibu-7206#debug dlsw
DLSw reachability debugging is on at event level for all protocol traffic
DLSw peer debugging is on
DLSw local circuit debugging is on
DLSw core message debugging is on
DLSw core state debugging is on
DLSw core flow control debugging is on
DLSw core xid debugging is on
ibu-7206#
DLSW Received-ctlQ : CLSI Msg : UDATA_STN.Ind   dlen: 208
CSM: Received CLSI Msg : UDATA_STN.Ind   dlen: 208 from TokenRing3/0
CSM:   smac 8800.5a49.1e38, dmac c000.0000.0080, ssap F0, dsap F0
CSM: Received frame type NETBIOS DATAGRAM from 0800.5a49.1e38, To3/0
DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
DLSw: Keepalive Request sent to peer 5.5.5.1(2065))
DLSw: Keepalive Response from peer 5.5.5.1(2065)
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 41
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 41 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 0

注意测试帧来自LAN (本地)从站点c001.68ff.0001到MAC地址4000.0000.0001。其中每一。Ind表明数据包自LAN进来。当路由器发送数据包对LAN时,您看到.RSP

DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 5.5.5.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44

现在您能看到广播发送对远端对等体和初始信元速率(ICR)答复上一步。这意味着远程路由器识别站点如可及的。TEST_STN.Rsp是发送对站点的路由器测试响应。

DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 4

在站点收到测试响应后,发送第一个XID。您能注意此与IS_STN.Ind。现在路由器必须临时地保持此帧,直到清除在两DLSw路由器之间的两三详细信息。

DLSw: new_ckt_from_clsi(): TokenRing3/0 4001.68ff.0001:4->4000.0000.0001:4
DLSw: START-FSM (1622182940): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 108
DLSw: END-FSM (1622182940): state:DISCONNECTED->LOCAL_RESOLVE
 
DLSW Received-ctlQ : CLSI Msg : REQ_OPNSTN.Cfm CLS_OK dlen: 108
DLSw: START-FSM (1622182940): event:DLC-ReqOpnStn.Cnf state:LOCAL_RESOLVE
DLSw: core: dlsw_action_b()
CORE: Setting lf size to 30
%DLSWC-3-SENDSSP: SSP OP = 3(CUR)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:LOCAL_RESOLVE->CKT_START
 
%DLSWC-3-RECVSSP: SSP OP = 4(ICR)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCI 0 - s:0 so:0 r:0 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-ICR state:CKT_START
DLSw: core: dlsw_action_e()
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  ACK   - s:20 so:1 r:20 ro:1
%DLSWC-3-SENDSSP: SSP OP = 5(ACK)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_START->CKT_ESTABLISHED

您能注意DLSw内部流动在两对等体之间。这些数据包为每会话启动是正常。第一阶段是搬到从断开状态CKT_ESTABLISHED状态。两路由器传输电路的CUR帧。这呼叫您能够进入电路设置吗? (CURCS)。当启动CURCS帧时的对等体接收ICRCS帧,发送确认并且迁移向电路已建状态。现在,两DLSw路由器为XID处理准备好。

DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
DLSw: 1622182940 sent FCA on  XID
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

路由器在发送对站点的测试响应以后接收XID。它一会儿保存此XID,然后传送它给在电路间的对等体。这意味着您发送到/从对等体的数据包有电路ID的被标记对他们。这样, DLSw了解在两个站点之间的活动。切记DLSw终止逻辑链路控制,类型2 (LLC2),网云的每侧的会话。

%DLSWC-3-RECVSSP: SSP OP = 7(XID)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCA on  XID   - s:20 so:0 r:20 ro:0
DLSw: START-FSM (1622182940): event:WAN-XID state:CKT_ESTABLISHED
DLSw: core: dlsw_action_g()
DISP Sent : CLSI Msg : ID.Rsp   dlen: 12
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED
 
DLSW Received-ctlQ : CLSI Msg : ID.Ind   dlen: 39
DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

您首先注意以前被发送对第一个XID的一答复。在ID.Rsp,您看到XID发送到站点,站点响应与ID.Ind。发送给DLSw对等体的这是另一个XID。

%DLSWC-3-RECVSSP: SSP OP = 8(CONQ)  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-CONQ state:CKT_ESTABLISHED

这部分表示我们,在另一侧的站点响应与SABME (CONQ)对XID。XID协商终止,并且路由器准备启动会话。

DLSw: core: dlsw_action_i()
DISP Sent : CLSI Msg : CONNECT.Req   dlen: 16

其次,路由器发送SABME到CONNECT.Req的站点。

DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CONTACT_PENDING
 
DLSW Received-ctlQ : CLSI Msg : CONNECT.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Connect.Cnf state:CONTACT_PENDING
DLSw: core: dlsw_action_j()
%DLSWC-3-SENDSSP: SSP OP = 9( CONR )  to peer 5.5.5.1(2065) success
DISP Sent : CLSI Msg : FLOW.Req   dlen: 0
DLSw: END-FSM (1622182940): state:CONTACT_PENDING->CONNECTED

然后您接收从站点的未编号确认,在CONNECT.Cfm消息显示。这发送给远端对等体通过CONR。然后相对速率(RR)进程开始与FLOW.Req。

%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:20 so:0 r:19 ro:0
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 34
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED
 
DLSw: 1622182940 decr s - s:19 so:0 r:19 ro:0
DLSW Received-disp : CLSI Msg : DATA.Ind   dlen: 35
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  INFO  - s:19 so:0 r:39 ro:1
%DLSWC-3-SENDSSP: SSP OP = 10(INFO)  to peer 5.5.5.1(2065) success
%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:19 so:0 r:38 ro:1
DLSw: 1622182940 recv FCA on  INFO  - s:19 so:0 r:38 ro:0
DLSw: 1622182940 recv FCI 0 - s:19 so:0 r:38 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 28
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED

DATA.Req表明路由器传送信息帧。Data.Ind表明路由器接收信息帧。您能使用此信息确定在DLSw路由器间的数据包流。

DLSW Received-ctlQ : CLSI Msg : DISCONNECT.Ind   dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Disc.Ind state:CONNECTED

这部分包含Disconnect.Ind。。Ind指示进来自LAN的一数据包。在这种情况下,站点发送断开,造成路由器开始切断电路。

DLSw: core: dlsw_action_n()
%DLSWC-3-SENDSSP: SSP OP = 14( HLTQ )  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CONNECTED->DISC_PENDING
 
%DLSWC-3-RECVSSP: SSP OP = 15( HLTR )  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-HLTR state:DISC_PENDING

在路由器接收断开后,发送HALT给远端对等体并且等待答复。是左的所有是发送UA对站点和关闭电路,在与DISCONNECT.Rsp的以下调试显示:

DLSw: core: dlsw_action_q()
DISP Sent : CLSI Msg : DISCONNECT.Rsp   dlen: 4
DISP Sent : CLSI Msg : CLOSE_STN.Req   dlen: 4
DLSw: END-FSM (1622182940): state:DISC_PENDING->CLOSE_PEND
 
DLSW Received-ctlQ : CLSI Msg : CLOSE_STN.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-CloseStn.Cnf state:CLOSE_PEND
DLSw: core: dlsw_action_y()
DLSw: 1622182940 to dead queue
DLSw: END-FSM (1622182940): state:CLOSE_PEND->DISCONNECTED

最后事DLSw在无效队列实行是放置电路。从那里,整理指示器并且为一个新的电路准备。

NetBIOS 会话

DLSw不同处理NetBIOS会话,但是调试是非常类似的。

/image/gif/paws/12249/dlsw_5.gif

注意: 切记XIDs不为NetBIOS站流,并且DLSw路由器交换NetBIOS名称查询系统交换处理器(SSP)帧和NetBIOS名称识别。这是主要区别。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12249