语音 : H.323

具有多点PVC和优先级基于帧中继的VoIP

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文与星型网拓扑讨论流量整形和优先级VoIP的在帧中继网络。集线器的配置是这样有两永久虚电路(PVC),一个每个远程辐射点的,并且数据和语音在同样PVC发送。请注意在本文和分段讨论的优先级适用不仅对此方案,而且于您可以有与语音和数据的一个PVC和别的与仅数据的方案。数据PVC需要是流量成形正语音和数据PVC。这归结于事实,当单个物理管道共享,在这种情况下在集线器,串行延迟时影响所有数据。

在下面的拓扑里,纽约代表集线器中央路由器。Raleigh和San Jose代表远程路由器连接对集线器通过帧中继网络。有连接到纽约路由器的两PVC。在这种情况下,纽约不应该发送超过对Raleigh的64 Kbps和同样,它不应该发送超过192 Kbps到San Jose,因为这超出配置的承诺信息速率(CIR)在帧中继映射类别。

在本文显示的拓扑里,有VoIP配置的路由器直接地连接对帧中继网云。除Cisco AS5300外,在一些拓扑方面,然而,支持语音的路由器任何地方在网络能存在。关于此的更多信息,参考提供的注意。语音路由器可以通过对连接对广域网的其他路由器的LAN连通性连接。这是重要注释,因为,如果您的语音路由器没有直接地连接对帧中继服务,所有WAN连接配置命令配置在连接对广域网的那些路由器和不在语音路由器。

注意: 有高速串行接口的Cisco AS5300路由器没有设计支持对广域网的数据连接。您需要使用您的思科AS5300作为半成品LAN路由器以主要功能处理语音呼叫。您需要专用路由器作为对广域网的直接连接。

先决条件

要求

在您尝试此配置前,请保证您满足这些前提条件:

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 三个Cisco 3640路由器用Cisco IOSï ¿  ½软件版本12.3(5) Enterprise Plus

  • 四个模拟电话连接对spoke的局外交换站(FXS)端口

  • 一个PBX连接对在中心路由器的一个T1控制器

spoke可以也是Cisco2600或1750平台。集线器可以是Cisco2600或3600平台一旦数字语音,但是它可以也是Cisco 1750平台,如果仅模拟语音存在集线器。所有流量整形和配置适用于其他平台。

注意: 虽然本文没有限制对特定软件,使用的某些命令这里不是可用的与所有Cisco IOS软件版本。例如, IP镜像支持frame-relay fragment命令用IP Plus,但是不。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置流量整形和优先级基于帧中继的VoIP的

当您运行基于帧中继的VoIP时,重要的是在帧发送的流量保持在是小于或等于帧中继CIR的级别。路由器不发送超出CIR,当配置与帧中继流量整形(FRTS)如显示的流量。如果比CIR配置路由器运作以速度极大,您可以遇到语音质量问题,并且语音质量没有保证,当您运行在保证CIR上时的PVC。

注意: 如果帧中继信息包接收与后向显式拥塞通知(BECN)位集,配置自适应整形使路由器节流在传输速率下到指定值是可能的。您建议然而,该流量速率不是超出帧中继服务的CIR,当语音数据包传送时。当实时语音数据包在间网络时,被发送这是为了保证适当的质量和交付。CIR被超出的配置为不运载语音流量的数据PVC只推荐。

注意: 并且,在您能配置您的路由器使用VoIP前,这是最佳,如果在Cisco IOS软件方面了解服务质量(QoS)功能。要得知更多QoS功能,参考队列,流量整形和过滤分段语音的

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文使用此图中的网络设置:

/image/gif/paws/12162/voip_fr_mp_1.gif

配置

本文档使用以下配置:

纽约中心路由器
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname newyork
!
logging buffered 50000 debugging
enable secret < password > [Choose a strong password with 
at least one capital letter, one number, and one special character.]
!
controller T1 2/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1-4 type e&m-wink-start
!
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay traffic-shaping

!--- This CLI command enables traffic shaping for both PVCs.

!
interface Serial2/0.1 point-to-point
description Connection to Raleigh PVC
ip address 172.16.120.2 255.255.255.0
  frame-relay interface-dlci 100
  class class-raleigh
!
interface Serial2/0.2 point-to-point
description Connection to San Jose PVC
ip address 172.16.130.2 255.255.255.0
frame-relay interface-dlci 200
  class class-sanjose
!
ip classless
!
map-class frame-relay class-raleigh
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80

!--- Recommended fragment size for 10ms delay when carrying voice
!--- traffic based on the configured CIR 64000.
!--- based on the configured CIR 64000

 frame-relay ip rtp priority 16384 16383 48

!--- Two calls with g729, no CRTP, at 24 kbps/each.

 !
map-class frame-relay class-sanjose
 frame-relay cir 192000
 frame-relay bc 1920
 frame-relay be 0
 frame-relay mincir 192000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 240

!--- This is the recommended fragment size for 10ms delay when carrying voice traffic
!--- based on the configured CIR 192000.

frame-relay ip rtp priority 16384 16383 48 

!--- Two calls with G729, no Compressed Real Time Protocol (cRTP), at 24kbpseach.

!
!
voice-port 2/0:1
!
dial-peer cor custom
!
dial-peer voice 100 pots

!--- Calls to the Public Switched Telephone Network (PSTN).

 destination-pattern 212.......
prefix 212
port 2/0:1
!
dial-peer voice 200 pots

!--- Calls to the corporate network-four digit extension forwarded.

destination-pattern 567....
 port 2/0:1
!
dial-peer voice 110 voip

!--- Calls to Raleigh.

destination-pattern 919392....
session target ipv4:172.16.120.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
dial-peer voice 210 voip    
!--- Calls to San Jose.

destination-pattern 408527....
session target ipv4:172.16.130.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end  

ip qos dscp命令在IOS version12.2(2)T介绍替换ip precedence (dial-peer)命令

frame-relay ip rtp priority命令预留属于用户数据报协议范围的一套的一个严格优先级队列实时协议(RTP)数据包流(UDP)目的地端口。

注意: 由于frame-relay ip rtp priority命令制定在其他流量的绝对优先级,请小心请使用此命令。在拥塞情形下,如果流量超出配置带宽,然后所有超额流量丢弃。

Cisco 3640 Raleigh
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname raleigh3640a
!

logging buffered 50000 debugging
enable secret < password > [Choose a strong password with at 
least one capital letter, one number, and one special character.]
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
dial-peer voice 1 pots
 destination-pattern 9193924100
port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 2126789001
  ip qos dscp cs5 media
 dtmf-relay h245-alphanumeric
 session target ipv4: 172.16.120.2 
!

interface Loopback0
 ip address 172.16.125.1 255.255.255.255
 no ip directed-broadcast
!

interface Serial2/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial2/0.1 point-to-point
description Connection to New York
 ip address 172.16.120.1 255.255.255.0

 frame-relay interface-dlci 100
  class fr_class_voip  
!
!
ip classless
no ip http server
!
!
map-class frame-relay fr_class_voip
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment  80


!--- The recommended fragment size for 10ms delay when carrying voice traffic.


!--- based on the configured CIR 64000.


  frame-relay ip rtp priority 16384 16383 48
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end

验证

此部分提供您能使用确认您的配置工作的信息。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show frame-relay fragment —显示关于在Cisco路由器发生的帧中继分段存储的信息。

  • show traffic-shape queue —显示关于元素的信息排队在级虚拟电路的数据链路连接标识符(DLCI)。此命令用于验证在帧中继的IP RTP优先级运算。当链路发生拥塞时,语音流以零权重表示。这表明语音流使用优先级队列。参考提供的输出示例:。

  • show frame-relay PVC [dlci-] —显示信息例如流量整形参数、分段值和丢弃的数据包。参考输出示例:提供了得此处并且欲知详情参考对帧中继的配置与故障排除的全面的指南

newyork#show frame-relay fragment

interface   dlci   frag-type   frag-size   in-frag   out-frag   dropped-frag
 
Serial1/0.1 100    end-to-end    80          16        20           0 

Serial1/0.2 200    end-to-end    240         12        10           0 

newyork#show traffic-shape  serial 2/0.1
Interface Se2/0.1

     Access    Target   Byte   Sustain   Excess   Interval    Increment    Adapt
VC   List      Rate     Limit  bits/int  bits/int (ms)        (bytes)      Active

100            64000    80     640       0         10          80          -
  
newyork#show traffic-shape queue
Traffic queued in shaping queue on Serial2/0.1 dlci 100
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 16 kilobits/sec

Traffic queued in shaping queue on Serial2/0.2 dlci 200
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
    Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 144 kilobits/sec

newyork#show frame-relay pvc 100

PVC Statistics for interface Serial2/0 (Frame Relay DCE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0.1

input pkts 1078          output pkts 1078         in bytes 157792
out bytes 172284         dropped pkts 0           in pkts dropped 0
out pkts dropped 0                out bytes dropped 0
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
out BECN pkts 0          in DE pkts 0             out DE pkts 0
out bcast pkts 28        out bcast bytes 8498
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:27:48, last time pvc status changed 00:27:48
Queueing strategy: weighted fair
Current fair queue configuration:
	Discard     Dynamic      Reserved
	threshold   queue count  queue count
		64          16           0
Output queue size 0/max total 600/drops 0
fragment type end-to-end        fragment size 80
cir 64000     bc   640       be 0         limit 80     interval 10
mincir 64000     byte increment 80    BECN response no  IF_CONG no
frags 2707      bytes 172284    frags delayed 2707      bytes delayed 172284
shaping inactive
traffic shaping drops 0
ip rtp priority parameters 16384 32767 48000

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除步骤

这是故障排除信息和说明与此配置有关:

  1. 排除故障为语音和QoS实现的帧中继并且保证其正确操作。

  2. 如所需要继续对语音呼叫故障故障排除。

    注意: 更多详细的故障排除信息,参考与QoS (分段、流量整形, LLQ /IP RTP优先级)的基于帧中继的VoIP

故障排除命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug priority —,如果丢弃在此队列,发生显示优先级排队(PQ)事件并且显示。有关详细信息,请参阅优先级排队中的输出丢包故障排除

  • debug frame-relay fragment - 显示与帧中继分段相关的事件或错误消息。此命令只启用在所选接口的PVC级别。

    newyork#debug priority 
    Priority output queueing debugging is on
    newyork#ping 172.16.120.1
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 172.16.120.1, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms 
    newyork# 
    *Mar  1 05:11:24.746: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.754: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.810: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.818: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.874: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.882: PQ: Serial2/0 output (Pk size/Q 13/0) 
    
    newyork#debug frame-relay fragment interface serial 2/0 100
    This may severely impact network performance.
    You are advised to enable no logging console debug. Continue?[confirm]
    Frame Relay fragment/packet debugging is on
    Displaying fragments/packets on interface Serial2/0 dlci 100 only
    
    *Mar  1 20:58:32.838: Serial1/0.1(o): dlci 100, tx-seq-num 3645, 
    B bit set, frag_hdr 03 B1 9C 3D
    *Mar  1 20:58:32.846: Serial1/0.1(o): dlci 100, tx-seq-num 3646, 
    E bit set, frag_hdr 03 B1 5C 3E
    *Mar  1 20:58:32.890: Serial1/0.1(i): dlci 100, rx-seq-num 17, 
    exp_seq-num 17,B bit set,
    	 frag_hdr 03 B1 80 11
    *Mar  1 20:58:32.894: Serial1/0.1(i): dlci 100, rx-seq-num 18, 
    exp_seq-num 18,E bit set,
    	 frag_hdr 03 B1 40 12

相关信息


Document ID: 12162