Video : Cisco uBR900 系列电缆接入路由器

Cisco电缆调制解调器上的cable-modem dhcp-proxy nat

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文解释如何使用cable-modem dhcp-proxy nat命令。此命令主要功能将配置一个网络地址转换(NAT)地址池用Intrernet供应商的DHCP服务器供应的IP地址。

欲知更多信息,在电缆IOS CMTS的参考的cable-modem dhcp-proxy发出命令

警告 警告: 注意Cisco Bug ID CSCdt32356 (仅限注册用户),在思科IOS�软件版本系列12.2修复及以后。动态NAT使用cable-modem dhcp-proxy nat pool-name cable interface命令不正确地作用。IP地址或子网掩码和默认网关没有正确地分配,如果根本。在命令被输入后,分配到NAT池的地址不响应对地址解析服务(ARP)。Ip nat pool创建是从的有线调制解调器范围,而不是客户端前置设备(CPE)范围,因此它在NAT池放置一个不能路由的IP地址。注意此问题发生在几电缆调制解调器的Cisco IOS软件版本,特别是12.1(5)T。推荐您使用在uBR924的Cisco IOS软件版本系列12.2并且使用版本12.2T, 12.3, uBR905、ubr925和CVA调制解调器的及以后系列。其他信息,参考Cisco Bug ID CSCdt32356 (仅限注册用户)。

注意: 并且请注意这些考虑事项:

  1. 由于uBR904平台不支持Cisco IOS软件版本12.1(1)T,配置cable-modem dhcp-proxy命令在此平台是不可能的。

  2. 要启用在uBR924的dhcp-proxy功能,通常推荐您使用Cisco IOS软件版本12.2(6j)。

  3. 对于CVA122,命令描述作为nat的cable dhcp-proxy。此命令是相同的象cable-modem dhcp-proxy nat命令在uBR900系列电缆调制解调器。

    从CVA122,此输出能被看到:

    Router(config)# interface cable 0
    
    Router(config-if)# cable?
    
    cable-modem

先决条件

要求

本文档的读者应掌握以下这些主题的相关知识:

  • 网络地址转换基本的了解,并且为什么使用

  • 有线电缆数据服务接口规范(DOCSIS) 1.0协议

  • Cisco IOS软件命令行界面

使用的组件

此表显示支持每个Cisco电缆调制解调器平台的此命令的Cisco IOS软件版本:

发布介绍cable-modem dhcp-proxy命令 平台
12.1(1)T uBR924
12.1(3)XL uBR905
12.2(2)XA ubr925
12.1(5)XU1 CVA122

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

动态NAT与静态NAT

使用动态NAT,转换在NAT转换表里不存在,直到路由器收到要求转换的流量。动态转换有一个超时周期,在后他们从转换表清除。使用静态NAT,然而,转换在NAT转换表里存在,当您配置静态NAT命令,并且他们在转换表里依然是,直到您删除静态NAT命令或命令。

确定的简便的方法您有动态NAT在您的有线调制解调器配置是通过搜索此in命令有线调制解调器的配置:

ip nat inside source list 100 interface cable-modem0 overload

通过指向NAT来源访问列表,您动态建立NAT转换表。cable-modem dhcp-proxy nat命令使用此动态NAT功能。

配置使用cable-modem dhcp-proxy nat命令

当曾经cable-modem dhcp-proxy nat命令时,用于NAT池的地址从有线电视运营商的DHCP服务器自动地分配。

当曾经此选项时,请包括这些NAT配置命令:

  • ip nat inside接口—请使用配置以太网接口作为“里面”接口。

  • ip nat outside接口—请使用配置电缆接口作为“外部”接口。

  • 超载—,因为cable-modem dhcp-proxy nat命令创建的NAT池只包含一个IP地址,请指定此选项用ip nat global configuration命令。

在配置路由器以后用cable-modem dhcp-proxy nat命令,请重新启动路由器。在DOCSIS提供的流程中,路由器发送DHCP客户端请求获取电缆接口的一个IP地址。使用以太网接口的MAC地址,路由器然后发送代理DHCP请求对DHCP服务器。DHCP服务器回复用第二个IP地址路由器分配到只指向一个地址的一个动态地已配置的NAT池的一动态地已配置的回环接口。

请参阅在本文的配置输出关于自动地被添加到配置的信息,在DHCP处理后。

要配置NAT,以便动态地创建池,请发出这些on命令您的路由器。切记,为了配置NAT,您的路由器必须在路由模式。

Router# config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)# interface ethernet 0

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!--- Assign an IP address to interface Ethernet 0.

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# ip nat inside

!--- Enable NAT inside for the Ethernet interface.

Router(config-if)# exit

Router(config)#

Router(config)# interface cable 0

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# no cable compliant bridge

!--- Remove bridging so that you can configure for routing.

Router(config-if)# ip nat outside

!--- Enable NAT outside for the cable interface.

Router(config-if)# cable-modem dhcp-proxy nat TEST_POOL

!--- Define dhcp-proxy nat for the TEST_POOL pool.

Router(config-if)# exit

Router(config)#

Router(config)# ip routing

!--- Enable routing.

Router(config)# ip nat inside source list 1 pool TEST_POOL overload

!--- Configure dynamic NAT.

Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

!--- Define interesting traffic for NAT.

配置如下所示:

router# show run

Building configuration...
Current configuration : 953 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
!
ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

router#

粗体命令是您输入的那个;其他是默认。注意NAT池这时未创建。有线调制解调器需要重新加载,或者电缆接口需要通过发出no shut命令跟随的关闭命令重置。

router# reload

Proceed with reload? [confirm]
133.CABLEMODEM.CISCO: 00:06:16: %SYS-5-RELOAD: Reload requested
System Bootstrap, Version 12.0(6r)T3, RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by Cisco Systems, Inc.
UBR924 platform with 16384 Kbytes of main memory
program load complete, entry point: 0x80010000, size: 0x398070
Self decompressing the image : #################################
################################################################
################################################################
################################################################
################################################################
################################################################
########################################################## [OK]

!--- Output suppressed.

Press RETURN to get started!

注意: 配置输出中,自动地被添加到配置的信息,在DHCP处理后注释与注释。

在本文中, uBR7114和uBR924使用作为示例。在他们安装的Cisco IOS软件版本分别为12.1(5)EC1和12.1(3a)T4。下张图显示使用的连接和IP地址。

图 1:用于配置的图表使用cable dhcp-proxy nat命令

/image/gif/paws/12176/cable_dhcp_proxy1.gif

uBR924 — NAT地址池的配置用服务提供商的DHCP服务器供应的IP地址
router# show run

Building configuration...
Current configuration : 1273 bytes
!
! Last configuration change at 13:12:52 - Tue Feb 29 2000
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
clock timezone - -8
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
!
interface Loopback0
 ip address 111.111.111.8 255.255.255.255

!--- Lookback interface added automatically by DHCP configuration.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream saved channel 525000000 37 1
!
ip nat pool TEST_POOL 111.111.111.8 111.111.111.8 netmask 255.255.255.0

!--- NAT pool added automatically by DHCP configuration.

ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

配置验证

此部分描述如何使用show命令输出验证有线调制解调器的配置。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

发出show arp命令显示条目在ARP表里。

router# show arp

Protocol  Address         Age (min) Hardware Addr   Type   Interface
Internet  111.111.111.111      56   0002.b9ff.8c1c  ARPA   cable-modem0
Internet  10.4.1.1             59   0002.b9ff.8c1c  ARPA   cable-modem0

!--- IP address of the interface cable 1/0
!--- of the cable modem termination system (CMTS).

Internet  192.168.1.1           -   0030.1976.771a  ARPA   Ethernet0
Internet  192.168.1.5          34   00a0.243c.eff5  ARPA   Ethernet0

!--- IP address of the PC behind the cable modem.

Internet  10.4.1.114            -   0030.1976.771b  ARPA   cable-modem0

PC在有线调制解调器背后有静态配置的IP地址192.168.1.5。是非常容易,然而,做动态地分配IP地址到其LAN主机的有线调制解调器DHCP服务器;请使用此配置:

ip dhcp excluded-address 192.168.1.1 
ip dhcp pool pool name


   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1

要测试NAT工作,请发出一ping命令从在有线调制解调器后连接的PC设法到达电缆接口。

如果查看NAT转换表,您能看到成功的转换。

router# show ip nat translations

Pro  Inside global      Inside local       Outside local    Outside global
icmp 111.111.111.8:512  192.168.1.5:512    10.4.1.114:512   10.4.1.114:512

欲知更多信息,在电缆IOS CMTS的参考的cable-modem dhcp-proxy发出命令

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12176