广域网 : T1/E1 & T3/E3

用多链路接口捆绑 NxE1 链路

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

在本文的配置示例显示您如何能通过多链路接口捆绑NxE1链路(有或没有成帧的G.704)。多链路接口在分布式多链路点对点协议的(PPP) Cisco IOS�软件版本12.0(3)T介绍在Cisco 7500路由器多用途接口处理器-基于T1或E1接口(请参阅本文相关信息部分)。多链路接口为非VIP基于T1/E1 (和其他广域网)接口支持从Cisco IOS软件版本12.0(4)T。

先决条件

要求

因为多链路PPP增加CPU负载,您建议对:

  1. 在您添加多链路接口或添加E1链路到多链路接口前,请验证当前平均的CPU负载。

  2. 请使用在Cisco 7500基于VIP的平台的分布式多链路PPP若情况许可。欲了解更详细的信息参考Cisco IOS软件版本12.0(3)T新特性文档在分布式多链路PPP限制和前提条件(请参阅本文相关信息部分)。

  3. 禁用多链路PPP分段若情况许可。

注意: 这增加在多链路捆绑的延迟。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 运行Cisco IOS软件版本12.1(11a)的思科7505路由器配备有VIP2-50和PA-MC-8E1。

  • 运行Cisco IOS软件版本12.1(11)的思科7206路由器配备有PA-MC-8E1。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景理论

多链路PPP,标准化在RFC 1990,类似于负载均衡技术因为发送在个别链路间的数据包在循环方式。然而,多链路PPP添加三个重要功能。

  • 因为多链路PPP工作在链路层,做一个NxT1/E1套件出现作为一个逻辑链接到在路由器的上层协议。所以,仅一个网络地址需要为整个NxT1/E1套件配置。

  • 多链路PPP记录早到的信息包顺序和缓冲信息包。多链路PPP保留在整个NxT1/E1套件间的packet命令与此能力。

  • 您能使信息包分段拆分大数据包到在链路间单个传送的更加小的信息包碎片。在许多情况下,分段能增加NxT1/E1链路的效率。

多链路PPP也提供重要的链路可管理性。如果个别链路发生故障,多链路PPP能自动地检测失败和从套件删除该链路。只要套件的一条链路工作,代表套件的逻辑接口是UP。使用使用保活信号,多链路PPP能检测,当一条发生故障的链路以前恢复时然后再插入链路到套件。另外,您能添加更多链路到套件,当您配置他们作为套件的成员时,当更多带宽是需要的时。在网络层的重新配置,例如新的编址,不是需要的。当您考虑使用高级路由器服务时,这也是重要因素。例如,您能一次配置一个特定服务质量套件的整体上而不是在套件的每条链路。

增加的功能的折衷方案是多链路PPP比负载均衡解决方案要求更加了不起的CPU处理。数据包重拨,碎片重组和多链路PPP协议增加CPU负载。

配置

本部分提供了用于配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可查找有关本文档所用命令的其他信息。

网络图

本文档使用此网络设置。

/image/gif/paws/11044/ppp_11044.gif

配置

本文档使用以下配置。

与G.704成帧的E1链路

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
username bob password 0 mlppp 

!--- This is an optional Challenge Handshake Authentication Protocol 
!--- (CHAP) secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

! 
no ip domain-lookup 
! 
! 
controller E1 1/0/0 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.
 
! 
controller E1 1/0/1 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/2 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/3 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/4 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/5 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/6 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/7 
�channel-group 0 timeslots 1-31 


!--- You must assign all timeslots to one channel-group.

! 
interface Multilink1 
�ip address 10.10.10.1 255.255.255.0 
�no cdp enable 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This command is optional to reduce CPU load. 

�multilink-group 1 
! 
interface Serial1/0/0:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable first-in, first-out (FIFO)  
!--- queueing on the Serial interface.  

ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/1:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/2:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 
 
encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/3:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/4:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/5:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/6:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/7:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Ethernet1/1/0 
�ip address 10.10.20.1 255.255.255.0 
�no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
username diana password 0 mlppp 

!--- An optional CHAP secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
! 
! 
controller E1 3/0 
�clock source internal 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/1 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.
 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/2 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/3 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/4 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/5 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/6 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/7 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
! 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.2 255.255.255.0 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This command is optional to reduce CPU load.
 
�multilink-group 1 
! 
interface FastEthernet0/0 
�ip address 10.10.30.1 255.255.255.0 
�no ip route-cache 
�no ip mroute-cache 
�half-duplex 
�no cdp enable 
! 
interface Serial3/0:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/1:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/2:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/3:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/4:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/5:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/6:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/7:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
ip classless 
ip route 10.10.20.0. 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

没有G.704成帧的E1链路

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

no ip domain-lookup 
! 
! 
controller E1 0/1/0 
�channel-group 0 unframed 
! 
controller E1 0/1/1 
�channel-group 0 unframed 
! 
controller E1 0/1/2 
�channel-group 0 unframed 
! 
controller E1 0/1/3 
�channel-group 0 unframed 
! 
controller E1 0/1/4 
�channel-group 0 unframed 
! 
controller E1 0/1/5 
�channel-group 0 unframed 
! 
controller E1 0/1/6 
�channel-group 0 unframed 
! 
controller E1 0/1/7 
�channel-group 0 unframed 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.1 255.255.255.0 
�no cdp enable 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This is an optional command to reduce CPU load. 

�multilink-group 1 
! 
interface Serial0/1/0:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/1:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/2:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/3:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/4:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/5:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/6:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/7:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Ethernet1/1/0 
�ip address 10.10.20.1 255.255.255.0 
�no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 

! 
controller E1 3/0 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/1 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/2 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/3 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/4 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/5 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/6 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/7 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
! 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.2 255.255.255.0 
�ppp multilink 
�no ppp multilink fragmentation 

�!--- This is an optional command to reduce CPU load. 

�multilink-group 1 
! 
interface FastEthernet0/0 
�ip address 10.10.30.1 255.255.255.0 
�no ip route-cache 
�no ip mroute-cache 
�half-duplex 
�no cdp enable 
! 
interface Serial3/0:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/1:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/2:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/3:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/4:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/5:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/6:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/7:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
ip classless 
ip route 10.10.20.0 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

验证

此部分提供您能使用适当地确认您的配置worke的信息。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show ppp multilink —与所有多链路捆绑成员一起显示所有多链路捆绑。

  • show interfaces multilink —显示多链路捆绑的状态。

  • show interfaces serial —显示每个多链路捆绑成员状况。

  • show controllers e1 —显示每条E1链路状况。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除步骤

此步骤与两配置是相关的。

  1. 验证多链路接口的状况用show interface multilink命令

    • 如果多链路接口发生故障,则请验证所有多链路捆绑成员状况用show ppp multilink命令

    • 如果多链路线路通信协议发生故障,则请验证网络控制协议(NCP)和多链路PPP (MLP)消息用debug ppp协商debug ppp multilink events命令。

  2. 如果多链路成员是非激活的,请验证Serial interfaces的状况用show interface serial命令

    • 如果Serial interfaces发生故障,请验证对应的E1链路的状况用show controller e1命令

    • 如果串行线路协议发生故障,请验证链路控制协议(LCP)和CHAP消息用debug ppp协商debug ppp authentication命令。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • show ppp multilink —与所有多链路捆绑成员一起显示所有多链路捆绑。

  • show interfaces multilink —显示多链路捆绑的状态。

  • show interfaces serial —显示每个多链路捆绑成员状况。

  • show controllers e1 —显示每条E1链路状况。

  • debug ppp协商—表示所有LCP和NCP协商消息。

  • debug ppp authentication — (可选)表示所有CHAP认证消息。

  • debug ppp multilink events —显示所有MLP套件事件。

此输出显示在Cisco 7505的故障排除命令第一配置示例的。

全部八条E1链路是活跃的:

diana#show ppp multilink 

Multilink1, bundle name is bob 
� Bundle up for 00:05:35 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 3/255 load 
� 0x1226 received sequence, 0x1226 sent sequence 
� Member links: 8 active, 0 inactive (max not set, min not set) 
��� Serial1/0/0:0, since 00:05:35, no frags rcvd 
��� Serial1/0/1:0, since 00:05:35, no frags rcvd 
��� Serial1/0/2:0, since 00:05:35, no frags rcvd 
��� Serial1/0/3:0, since 00:05:35, no frags rcvd 
��� Serial1/0/4:0, since 00:05:35, no frags rcvd 
��� Serial1/0/5:0, since 00:05:35, no frags rcvd 
��� Serial1/0/6:0, since 00:05:35, no frags rcvd 
��� Serial1/0/7:0, since 00:05:35, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 3/255, rxload 3/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:06:39 
� Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 241000 bits/sec, 28 packets/sec 
� 5 minute output rate 241000 bits/sec, 28 packets/sec 
���� 6525 packets input, 9810620 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 6526 packets output, 9796112 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions � 

在此输出中,在Cisco 7206的E1控制器3/0禁用,造成在Cisco 7505的E1控制器1/0/0和序列1/0/0:0断开:

diana# 
*Nov 23 12:52:54.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to down 
*Nov 23 12:52:56.171: %LINK-3-UPDOWN: 
Interface Serial1/0/0:0, changed state to down 
*Nov 23 12:52:57.171: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to down 

diana#show ppp multilink
Multilink1, bundle name is bob 
� Bundle up for 00:06:52 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 1/255 load 
� 0x269C received sequence, 0x269B sent sequence 
� Member links: 7 active, 1 inactive (max not set, min not set) 
��� Serial1/0/1:0, since 00:06:52, no frags rcvd 
��� Serial1/0/2:0, since 00:06:52, no frags rcvd 
��� Serial1/0/3:0, since 00:06:52, no frags rcvd 
��� Serial1/0/4:0, since 00:06:52, no frags rcvd 
��� Serial1/0/5:0, since 00:06:52, no frags rcvd 
��� Serial1/0/6:0, since 00:06:52, no frags rcvd 
��� Serial1/0/7:0, since 00:06:52, no frags rcvd 
��� Serial1/0/0:0 (inactive) 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 13888 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 6/255, rxload 6/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:07:47 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 367000 bits/sec, 40 packets/sec 
� 5 minute output rate 367000 bits/sec, 40 packets/sec 
���� 10899 packets input, 16389116 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 10901 packets output, 16367362 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is down, line protocol is down 
� Hardware is Multichannel E1 
� MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
���� reliability 255/255, txload 41/255, rxload 41/255 
� Encapsulation PPP, crc 16, Data non-inverted 
� Keepalive set (10 sec) 
� LCP Closed, multilink Closed 
� Closed: CDPCP 
� Last input 00:00:15, output 00:00:17, output hang never 
� Last clearing of "show interface" counters 00:07:42 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 323000 bits/sec, 35 packets/sec 
� 5 minute output rate 324000 bits/sec, 35 packets/sec 
���� 9811 packets input, 14623345 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 9809 packets output, 14680161 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 1 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 2 carrier transitions alarm present 
� Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
� Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is down. 
� Applique type is Channelized E1 - balanced 
� Transmitter is sending remote alarm. 
� Receiver is getting AIS. 
� Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
� International Bit: 1, National Bits: 11111 
� Data in current interval (465 seconds elapsed): 
���� 1 Line Code Violations, 1 Path Code Violations 
���� 0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
���� 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 19 Unavail Secs 
... 

diana#debug ppp negotiation 
�PPP protocol negotiation debugging is on 

diana#debug ppp authentication 
PPP authentication debugging is on 

diana#debug ppp multilink events 
Multilink events debugging is on 

在此输出中,在Cisco 7206的E1控制器3/0再启用。

diana# 
*Nov 23 12:53:40.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to up 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: I CONFREQ [Closed] id 34 len 26 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: Lower layer not up, Fast Starting 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Treating connection as a dedicated line 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Phase is ESTABLISHING, Active Open 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFREQ [Closed] id 2 len 27 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFACK [REQsent] id 34 len 26 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: I CONFACK [ACKsent] id 2 len 27 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: State is Open 
*Nov 23 12:53:42.079: Se1/0/0:0 PPP: Phase is AUTHENTICATING, by both 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O CHALLENGE id 2 len 26 from "diana" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: I CHALLENGE id 4 len 25 from "bob" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O RESPONSE id 4 len 26 from "diana" 
*Nov 23 12:53:42.079: %LINK-3-UPDOWN: Interface Serial1/0/0:0, changed state to up 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I RESPONSE id 2 len 25 from "bob" 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I SUCCESS id 4 len 4 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: O SUCCESS id 2 len 4 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Request add link to bundle 
*Nov 23 12:53:42.087: Se1/0/0:0 PPP: Phase is VIRTUALIZED 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Adding link to bundle 
*Nov 23 12:53:42.087: Mu1 MLP: Added link Se1/0/0:0 to bundle bob 
*Nov 23 12:53:43.087: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to up 

diana#show ppp multilink
Multilink1, bundle name is bob 
� Bundle up for 00:07:46 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 7/255 load 
� 0x35BF received sequence, 0x35BE sent sequence 
� Member links: 8 active, 0 inactive (max not set, min not set) 
��� Serial1/0/1:0, since 00:07:46, no frags rcvd 
��� Serial1/0/2:0, since 00:07:46, no frags rcvd 
��� Serial1/0/3:0, since 00:07:46, no frags rcvd 
��� Serial1/0/4:0, since 00:07:46, no frags rcvd 
��� Serial1/0/5:0, since 00:07:46, no frags rcvd 
��� Serial1/0/6:0, since 00:07:46, no frags rcvd 
��� Serial1/0/7:0, since 00:07:46, no frags rcvd 
��� Serial1/0/0:0, since 00:00:13, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 7/255, rxload 7/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:08:32 
� Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 443000 bits/sec, 49 packets/sec 
� 5 minute output rate 443000 bits/sec, 49 packets/sec 
���� 14098 packets input, 21200412 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 14099 packets output, 21170758 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is up, line protocol is up 
� Hardware is Multichannel E1 
� MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
���� reliability 255/255, txload 32/255, rxload 32/255 
� Encapsulation PPP, crc 16, Data non-inverted 
� Keepalive set (10 sec) 
� LCP Open, multilink Open 
� Last input 00:00:02, output 00:00:02, output hang never 
� Last clearing of "show interface" counters 00:08:39 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 253000 bits/sec, 24 packets/sec 
� 5 minute output rate 254000 bits/sec, 24 packets/sec 
���� 9821 packets input, 14623552 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 9819 packets output, 14680370 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 1 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 3 carrier transitions no alarm present 
� Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
� Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is up. 
� Applique type is Channelized E1 - balanced 
� No alarms detected. 
� Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
� International Bit: 1, National Bits: 11111 
� Data in current interval (519 seconds elapsed): 
���� 1 Line Code Violations, 1 Path Code Violations 
���� 0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
���� 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 37 Unavail Secs 
... 

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 11044