多协议标签交换 (MPLS) : 基于 ATM 的多协议标签交换 (MPLS over ATM)

MPLS VPN over ATM :在用户侧使用OSPF (没有Area 0)

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文提供多协议标签交换(MPLS) VPN over ATM的配置示例,当开放最短路径优先(OSPF)是存在用户侧时,不用area 0。

虚拟专用网络(VPN)功能,当使用与MPLS,允许几个站点透明地通过服务提供商的网络互联。一个服务提供商网络可以支持多个不同的 IP VPN。其中每一个 VPN 均向其用户显示为与所有其他网络分离的专用网络。在一个 VPN 内,每个站点都可以向该 VPN 的其他任何站点发送 IP 数据包。

先决条件

要求

每个 VPN 均与一个或多个 VPN 路由或转发实例 (VRF) 相关联。VRF包括IP路由表、一派生的思科快速转发(CEF)、表和使用此转发表的一套接口。

路由器针对每个 VRF 维护一个单独的路由和 CEF 表。使用此,信息不可能VPN的外部发送,但是相同子网可以用于几个VPN,不用重复IP地址问题。

使用边界网关协议(BGP)的路由器分配与BGP扩展属性的VPN路由工艺路线信息。

欲知关于更新传播的更多信息通过VPN,参考这些URL :

硬件与软件版本

这些字母代表使用的不同种类的路由器和交换机:

  • P :供应商核心路由器

  • PE :供应商边缘路由器

  • CE :用户边缘路由器

  • C :客户路由器

我们开发并且测试了与这些软件和硬件版本的配置:

  • PE路由器

    • 软件:Cisco IOS 软件版本12.1(3)T。MPLS VPN功能在版本12.0(5)T出现。OSPF作为PE-CE路由协议在版本12.0(7)T出现。

    • Hardware:Cisco 3660或7206路由器。关于其他硬件详细信息您能使用,参考ATM指南的设计的MPLS

  • CE路由器:请使用能交换与其PE路由器的路由信息的所有路由器。

  • P路由器和切换:MPLS VPN集成功能仅驻留在MPLS网络边缘,因此请使用所有支持MPLS的交换机。在配置示例中, MPLS网云被组成8540 MSR和LightStream1010。如果使用LightStream1010,我们建议您使用软件版本WA4.8d或更加高。您在ATM核心网络能也使用其他ATM交换机,例如Cisco BPX 8650或MGX8850。

规则

此图表显示使用这些规则的典型配置:

/image/gif/paws/10472/mpls_ospf4.gif

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

OSPF背景信息

传统上,精心组建的OSPF网络包括骨干区域(area 0)和一定数量的区域连接对此骨干网到区域边界路由器(ABR)。

使用VPN的一MPLS骨干网与在客户站点的OSPF,您在OSPF模型的层级能引入第三级。此第三级呼叫MPLS VPN超级骨干网。

在简单情况下, MPLS VPN超级骨干网与传统区域0骨干网一起。这意味着没有在客户网络的area 0 backbone,因为MPLS VPN超级骨干网扮演角色和area 0 backbone一样。如下图所示:

/image/gif/paws/10472/mpls_ospf1.gif

此图表说明此信息:

  • 服务商边缘路由器是ABR和自治系统边界路由器(ASBR)路由器。

  • 用户边缘(CE)路由器是简单OSPF路由器。

  • VPN信息通过从观点扫描器的BGP扩展属性传输到其他观点扫描器和被再注入OSPF区域作为汇总网络(类型3) Link State Advertisement (LSA)。

MPLS VPN超级骨干网也使客户使用在他们的站点的多个区域0骨干网。只要连接到MPLS VPN超级骨干网,每个站点能有一分开的area 0。结果是相同的如同分区区域0骨干网。如下图所示:

/image/gif/paws/10472/mpls_ospf2.gif

在这种情况下,这些事发生:

  • PE路由器是ABR和ASBR路由器。

  • CE路由器是ABR路由器。

  • 包含VPN信息的LSA传输与从观点扫描器的BGP扩展属性到其他观点扫描器。总之网络(类型3) LSA,信息传输在观点扫描器和CES之间。

此配置示例根据表示的第一个设置。您能找到在MPLS VPN over ATM使用第二设置的配置示例:使用在用户侧的OSPF (与Area 0)

OSPF信息传输与包括一识别OSPF网络)的BGP扩展群属性(。每个VPN必须有其自己的OSPF程序。为了指定此,您能使用此命令:

router ospf <process ID> vrf <VPN routing/forwarding instance name>

配置过程

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/10472/mpls_ospf3.gif

Cisco IOS文档(MPLS虚拟专用网络)也描述此配置程序。

配置程序第I部分

确保IP CEF启用。如果使用一个Cisco 7500路由器,您必须保证ip cef distributed启用。在观点扫描器,一旦MPLS设置,请执行这些任务:

  1. 创建用ip vrf <VPN routing/forwarding instance name>命令连接的每个VPN的一个VRF。当您执行此:

    • 指定用于该 VPN 的正确路由区分符。这用于扩大IP地址,以便您能识别属于的VPN。

      rd <VPN route distinguisher>
      
    • 设置BGP扩展属性的导入和出口属性。这些用于过滤导入和出口进程。

      route-target [export|import|both] <target VPN extended community> 
      
      
  2. 配置各自的接口的转发细节用此命令:

    ip vrf forwarding <table name>
    

    在您执行此后,请切记设置IP地址。

  3. 从属在您使用,您必须当前执行一个或很多这些的PE-CE路由协议:

    • 配置静态路由:

      ip route vrf vrf-name prefix mask [next-hop-address]
                                        [interface {interface-number}] 
      
      
    • 配置RIP用此命令:

      address-family ipv4 vrf <VPN routing/forwarding instance name>
      

      一旦完成了这部分,请输入正常RIP配置命令。

      注意: 这只适用于当前VRF的转发接口。

      注意: 您必须重新分配正确BGP到RIP。当您执行此时,也请切记指定使用的量度。

    • 宣称BGP邻居信息。

    • 配置OSPF用新ios命令:

      router ospf <process ID> vrf <VPN routing/forwarding instance name>
      

      注意: 这只适用于当前VRF的转发接口。

      注意: 您必须重新分配正确BGP到OSPF。当您执行此时,也请切记指定使用的量度。

      注意: 一旦归因于OSPF程序VRF,此进程编号总是使用此特定VRF。即使您在命令行不指定它,这也将应用。

配置程序第II部分

配置在PE路由器之间的BGP。有几个方式配置BGP,例如使用路由反射器或联盟方法。使用的方法这里–直接邻居配置–最简单和最不可扩展。

  1. 声明不同的邻居。

  2. 进入每个VPN的address-family ipv4 vrf <VPN routing/forwarding instance name>现在此PE路由器。执行一个或很多这些步骤,如所需要:

    • 重新分配静态路由信息。

    • 重新分配RIP路由信息。

    • 重新分配OSPF路由信息。

    • 激活BGP邻居用CE路由器。

  3. 输入地址家族vpnv4模式,并且执行这些任务:

    • 激活邻居。

    • 指定必须使用扩展团体。这是强制性的。

配置

注意: 输出的仅相关部分包括此处。

Alcazaba
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!         
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.10 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 150.150.0.1 255.255.255.0
 no ip mroute-cache
!
interface ATM4/0
 no ip address
 no ip mroute-cache
 atm sonet stm-1
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 150.150.0.0 0.0.0.255 area 1
 network 222.0.0.0 0.0.0.255 area 1
!
router bgp 1
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Kozel
!
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.30 255.255.255.255
!         
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 69.69.0.1 255.255.255.252
 no ip mroute-cache
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 tag-switching
 ip address 11.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 11.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 69.69.0.0 0.0.0.255 area 3
 network 222.0.0.0 0.0.0.255 area 3
!
router bgp 1
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.11 remote-as 1
 neighbor 223.0.0.11 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.11 activate
 neighbor 223.0.0.11 send-community extended
 exit-address-family
!

迅速
!
interface Loopback0
 ip address 222.0.0.1 255.255.255.255
!
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!         
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 7.7.7.7 0.0.0.0 area 1
 network 150.150.0.0 0.0.0.255 area 1
 network 222.0.0.1 0.0.0.0 area 1
!

Pivrnec
!
interface Loopback0
 ip address 222.0.0.3 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 69.69.0.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 3
 network 69.69.0.0 0.0.0.255 area 3
 network 222.0.0.3 0.0.0.0 area 3
!

验证

显示命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • show ip route vrf <VPN路由或转发实例name>

  • show ip bgp vpnv4 vrf <VPN路由或转发实例name> <A.B.C.D>

  • show ip ospf <process ID number>

  • show ip ospf <process ID number>接口

  • show ip ospf <process ID number>数据库

  • show tag-switching forwarding-table vrf <VPN路由或转发实例name>

此命令显示特定的VPN VRF在PE路由器:

Alcazaba#show ip route vrf vpn1
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
B       69.69.0.0 [200/0] via 223.0.0.21, 00:19:39
     222.0.0.0/32 is subnetted, 4 subnets
B       222.0.0.30 [200/0] via 223.0.0.21, 00:19:39
C       222.0.0.10 is directly connected, Loopback1
B       222.0.0.3 [200/11] via 223.0.0.21, 00:20:39
O       222.0.0.1 [110/11] via 150.150.0.2, 00:20:59, Ethernet1/1
     6.0.0.0/32 is subnetted, 1 subnets
B       6.6.6.6 [200/11] via 223.0.0.21, 00:20:39
     7.0.0.0/32 is subnetted, 1 subnets
O       7.7.7.7 [110/11] via 150.150.0.2, 00:21:00, Ethernet1/1
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.0.0 is directly connected, Ethernet1/1

您能也显示一特定的VRF BGP信息用show ip bgp vpnv4 vrf命令。从内部BGP (IBGP)的PE-PE结果是由i.表示的。

Alcazaba#show ip bgp vpnv4 vrf vpn1
BGP table version is 21, local router ID is 223.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:101 (default for vrf vpn1)
*>i6.6.6.6/32       223.0.0.21              11    100      0 ?
*> 7.7.7.7/32       150.150.0.2             11         32768 ?
*>i69.69.0.0/30     223.0.0.21               0    100      0 ?
*> 150.150.0.0/24   0.0.0.0                  0         32768 ?
*> 222.0.0.1/32     150.150.0.2             11         32768 ?
*>i222.0.0.3/32     223.0.0.21              11    100      0 ?
*> 222.0.0.10/32    0.0.0.0                  0         32768 ?
*>i222.0.0.30/32    223.0.0.21               0    100      0 ?

您能检查条目的详细信息。为了显示此,路由辨别器是"1:101."

Alcazaba#show ip bgp vpnv4 vrf vpn1 6.6.6.6
BGP routing table entry for 1:101:6.6.6.6/32, version 28
Paths: (1 available, best #1, table vpn1)
  Not advertised to any peer
  Local
    223.0.0.21 (metric 4) from 223.0.0.21 (223.0.0.21)
      Origin incomplete, metric 11, localpref 100, valid, internal, best
      Extended Community: RT:1:101 OSPF RT:3:2:0

Alcazaba#show ip bgp vpnv4 vrf vpn1 7.7.7.7
BGP routing table entry for 1:101:7.7.7.7/32, version 20
Paths: (1 available, best #1, table vpn1)
  Advertised to non peer-group peers:
  223.0.0.21 
  Local
    150.150.0.2 from 0.0.0.0 (223.0.0.3)
      Origin incomplete, metric 11, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:1:101 OSPF RT:1:2:0

show ip route命令在CE路由器是验证路由表的主要方法:

rapid#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
O IA    69.69.0.0 [110/11] via 150.150.0.1, 00:20:25, FastEthernet0/1
     222.0.0.0/32 is subnetted, 4 subnets
O IA    222.0.0.30 [110/11] via 150.150.0.1, 00:20:25, FastEthernet0/1
O       222.0.0.10 [110/11] via 150.150.0.1, 00:21:46, FastEthernet0/1
O IA    222.0.0.3 [110/21] via 150.150.0.1, 00:21:25, FastEthernet0/1
C       222.0.0.1 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
O IA    6.6.6.6 [110/21] via 150.150.0.1, 00:21:25, FastEthernet0/1
     7.0.0.0/24 is subnetted, 1 subnets
C       7.7.7.0 is directly connected, Loopback2
     10.0.0.0/22 is subnetted, 1 subnets
C       10.200.8.0 is directly connected, FastEthernet0/0
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.0.0 is directly connected, FastEthernet0/1
S    158.0.0.0/8 is directly connected, Null0

OSPF 特有的命令

您能使用所有show ip ospf命令。当您执行此时,请切记指示进程ID。我们在用斜体字印刷的文本标记了下面输出的多数重要部分。

OSPF LSA类型9, 10和11 (亦称不透明的LSA)用于设计流量。

PE路由器的命令

Alcazaba#show ip ospf 2
 Routing Process "ospf 2" with ID 222.0.0.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Connected to MPLS VPN super backbone
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    bgp 1, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area 1
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 7. Checksum Sum 0x420BE 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Alcazaba#show ip ospf 2 interface
Loopback1 is up, line protocol is up 
  Internet Address 222.0.0.10/32, Area 1 
  Process ID 2, Router ID 222.0.0.10, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Ethernet1/1 is up, line protocol is up 
  Internet Address 150.150.0.1/24, Area 1 
  Process ID 2, Router ID 222.0.0.10, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:07
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 3
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

Alcazaba#show ip ospf 2 database
 
            OSPF Router with ID (222.0.0.10) (Process ID 2)
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1364        0x80000013 0x7369   3
222.0.0.10      222.0.0.10      1363        0x80000002 0xFEFE   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      1363        0x80000001 0xEC6D  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      1328        0x80000001 0x4967  
69.69.0.0       222.0.0.10      1268        0x80000001 0x2427  
222.0.0.3       222.0.0.10      1328        0x80000001 0xEEF7  
222.0.0.30      222.0.0.10      1268        0x80000001 0x7B5A  

CE路由器的命令

rapid#show ip ospf interface
FastEthernet0/1 is up, line protocol is up 
  Internet Address 150.150.0.2/24, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.10  (Designated Router)
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up 
  Internet Address 222.0.0.1/32, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Loopback2 is up, line protocol is up 
  Internet Address 7.7.7.7/24, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host

rapid#show ip ospf database
 
       OSPF Router with ID (222.0.0.1) (Process ID 1)
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1350        0x80000013 0x7369   3
222.0.0.10      222.0.0.10      1350        0x80000002 0xFEFE   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      1351        0x80000001 0xEC6D  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      1316        0x80000001 0x4967  
69.69.0.0       222.0.0.10      1256        0x80000001 0x2427  
222.0.0.3       222.0.0.10      1316        0x80000001 0xEEF7  
222.0.0.30      222.0.0.10      1256        0x80000001 0x7B5A  

Alcazaba#show tag-switching forwarding-table vrf vpn1
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
24     Aggregate   222.0.0.10/32[V]  0                                  
25     Aggregate   150.150.0.0/24[V] 0                                  
27     Untagged    7.7.7.7/32[V]     1710       Et1/1      150.150.0.2  
28     Untagged    222.0.0.1/32[V]   0          Et1/1      150.150.0.2

MPLS 标签

您能检查用于特定路由的标签栈:

Alcazaba#show tag-switching forwarding-table vrf vpn1 6.6.6.6 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
None   2/41        6.6.6.6/32        0          AT4/0.1    point2point  
        MAC/Encaps=4/12, MTU=4466, Tag Stack{2/41(vcd=10) 16}
        000A8847 0000A00000010000

调试输出

这是摘自路由交换调试信息的一个部分。这显示特定路由如何导入。

Alcazaba#debug ip bgp vpnv4 import
Tag VPN import processing debugging is on
*Aug  5 05:10:09.283: vpn: Start import processing for: 1:101:222.0.0.3
*Aug  5 05:10:09.283: vpn: Import check for vpn1; flags mtch, impt
*Aug  5 05:10:09.283: vpn: Import for vpn1 permitted; import flags mtch, impt
*Aug  5 05:10:09.283: vpn: Same RD import for vpn1
*Aug  5 05:10:09.283: vpn: 1:101:222.0.0.3 (ver 29), imported as:
*Aug  5 05:10:09.283: vpn: 1:101:222.0.0.3 (ver 29)
*Aug  5 05:10:09.287: VPN: Scanning for import check is done.

测试输出

您能当前使用ping测试一切优良是:

Pivrnec#ping 7.7.7.7      
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

traceroute命令显示此输出:

Pivrnec#traceroute 7.7.7.7
 
Type escape sequence to abort.
Tracing the route to 7.7.7.7
 
  1 69.69.0.1 0 msec 0 msec 0 msec
  2 150.150.0.1 0 msec 0 msec 20 msec
  3 150.150.0.2 0 msec 0 msec * 

MLPS主机不在这里,因为他们看不到IP报头。MPLS主机只检查入站标签或接口然后转发它。

在IP存活时间(TTL)字段的操作在边缘LSR只进行。显示的跳数比实际跳数是较少。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 10472