异步传输模式 (ATM) : LAN 仿真 (LANE)

LAN 仿真示例配置

2016 年 10 月 25 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文说明如何配置LAN仿真(LANE)服务和客户端Cisco路由器的, Catalyst交换机及ATM交换机。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/10457/lane_config1.gif

在该设置:

  • Router1和Router2是运行Cisco IOSï ¿  ½软件版本12.1(4)的Cisco 4500路由器。两个作为LAN仿真客户端(LEC)。

  • LightStream1010运行Cisco IOS软件版本12.0(10)W5(18b)。它作为LAN仿真配置服务器(LECS)。

  • 以太网交换机是有一LANE刀片的一台Catalyst 5000在插槽4。此LANE刀片作为LEC和作为LANE广播及未知服务器(LES/BUS)。

  • LANE服务根据LANE设计推荐配置。

  • 两个仿真LAN (ELAN)配置:test-elan和test-elan2。

  • Router1有LEC在每个ELAN。以太网交换机有LEC在test-elan2。Router2和LightStream1010有LEC在test-elan。

  • 在以太网交换机上,虚拟LAN, VLAN2,一定对test-elan2。

  • Router1是负责执行在两ELAN之间的路由。

这是逻辑设置:

lane_config2.gif

配置

本文档使用以下配置:

注意: 与LANE是相关的配置命令的仅的部分包括。

LightStream1010

!--- Output suppressed.

atm lecs-address-default 47.0091.8100.0000.0060.705a.8f01.0060.705a.8f05.00

!

lane database test

  name test-elan server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.01
  name test-elan2 server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.02
!
interface atm2/0/0
 no ip address
 no ip directed-broadcast
 lane config auto-config-atm-address
 lane config database test
!
interface atm2/0/0.2 multipoint
 ip address 20.0.0.2 255.255.255.0
 no ip directed-broadcast
 lane client ethernet test-elan

!--- Output suppressed.

LANE数据库测验定义了LES/BUS的网络服务访问点(NSAP)地址每个ELAN的。这些地址在LightStream1010配置里指向Ethernet交换机LANE Blade :

lane-blade# show lane default

interface atm0:
LANE Client:        47.0091810000000060705A8F01.00E0B00B7030.**
LANE Server:        47.0091810000000060705A8F01.00E0B00B7031.**
LANE Bus:           47.0091810000000060705A8F01.00E0B00B7032.**
LANE Config Server: 47.0091810000000060705A8F01.00E0B00B7033.00

注意: **代表在十六进制格式的子接口字节数。

注意: 命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

一旦定义LANE数据库,使用lane config database database-name命令,请应用它在LECS的主接口。这是在LECS配置三命令的说明:

  • atm lecs-address-default NSAP地址—定义了寻址交换机通告作为是LECS NSAP对其连接的设备通过本地管理接口(ILMI)。在这种情况下,配置的地址是NSAP地址分配到LightStream1010的ATM0接口。发出show lane default命令得到此地址:

    LightStream 1010# show lane default
    
    interface ATM2/0/0:
    LANE Client:        47.0091810000000060705A8F01.0060705A8F02.**
    LANE Server:        47.0091810000000060705A8F01.0060705A8F03.**
    LANE Bus:           47.0091810000000060705A8F01.0060705A8F04.**
    LANE Config Server: 47.0091810000000060705A8F01.0060705A8F05.00
    

    注意: **代表在十六进制格式的子接口字节数。

  • 通道配置自动-设置-ATM-地址—指示LECS是否响应对呼叫建立做对其实时NSAP地址。

  • LANE配置数据库数据库名称—定义了LANE数据库LECS使用。

一旦应用以上配置对主接口, LECS是上和活跃的。

检查 LCES 状态

发出show lane config命令检查LCES状态:

LightStream 1010# show lane config

LE Config Server ATM2/0/0 config table: test
Admin: up State: operational
LECS Mastership State: active master
list of global LECS addresses (49 seconds to update):
47.0091810000000060705A8F01.0060705A8F05.00
ATM Address of this LECS: 47.0091810000000060705A8F01.0060705A8F05.00 (auto)
 vcd  rxCnt  txCnt  callingParty
  46      1      1  47.0091810000000060705A8F01.00E0B00B7031.01 LES test-elan 0 active
  62      1      1  47.0091810000000060705A8F01.00E0B00B7031.02 LES test-elan2 0 active
ATM Address of this LECS: 47.007900000000000000000000.00A03E000001.00 (well known)
cumulative total number of unrecognized packets received so far: 0
cumulative total number of config requests received so far: 608
cumulative total number of config failures so far: 601
    cause of last failure: no configuration
    culprit for the last failure: 47.009181000000FFFF705A8F01.0050E2030602.01
Router1

!--- Output suppressed.

interface ATM0

 no ip address
 pvc 0/5 qsaal
 !
 PVC 0/16 ilmi
 !
 no ATM ilmi-keepalive
!
interface ATM0.2 multipoint
 ip address 20.0.0.1 255.255.255.0
 lane client ethernet test-elan
!
interface ATM0.3 multipoint
 ip address 21.0.0.1 255.255.255.0
 lane client ethernet test-elan2
!
router rip
 network 20.0.0.0
 network 21.0.0.0

!--- Output suppressed.

检查 LEC 状态

发出这些命令检查LEC状态:

  • show lane client [interface atm number[.subinterface-number]]

    router1# show lane client interface atm 0.2
    
    LE Client ATM0.2  ELAN name: test-elan  Admin: up  State: operational
    Client ID: 2                 LEC up for 18 hours 9 minutes 42 seconds
    ELAN ID: 0
    Join Attempt: 1
    Known LE Servers: 1
    HW Address: 0060.837b.b3a2   Type: ethernet             Max Frame Size: 1516
    ATM Address: 47.0091810000000060705A8F01.0060837BB3A2.02
     VCD  rxFrames  txFrames  Type       ATM Address
       0         0         0  configure  47.0091810000000060705A8F01.0060705A8F05.00
       5         1        47  direct     47.0091810000000060705A8F01.00E0B00B7031.01
       6       145         0  distribute 47.0091810000000060705A8F01.00E0B00B7031.01
       7         0      4567  send       47.0091810000000060705A8F01.00E0B00B7032.01
       8     10221         0  forward    47.0091810000000060705A8F01.00E0B00B7032.01
  • show atm ilmi-status —验证客户端是否通过ILMI适当地注册其NSAP地址。

    router1# show atm ilmi-status
    
    Interface : ATM0 Interface Type : Private UNI (User-side)
    ILMI VCC : (0, 16) ILMI Keepalive : Disabled
    ILMI State:       UpAndNormal
    Peer IP Addr:     10.200.10.47    Peer IF Name:     ATM0/0/0
    Peer MaxVPIbits:  8               Peer MaxVCIbits:  14
    Active Prefix(s) :
    47.0091.8100.0000.0060.705a.8f01
    End-System Registered Address(s) :
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.02(Confirmed)
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.03(Confirmed)

    参考这些文档关于show atm ilmi-status命令的更多信息

Router2

!--- Output suppressed.

interface ATM1

 no ip address
 PVC 0/16 ilmi
 !
 PVC 0/5 qsaal
 !
 no ATM ilmi-keepalive
!
interface ATM1.2 multipoint
 ip address 20.0.0.3 255.255.255.0
 lane client ethernet test-elan
!
router rip
 network 20.0.0.0

!--- Output suppressed.

Ethernet交换机LANE Blade

!--- Output suppressed.

interface ATM0

 ATM preferred phy A
 atm PVC 1 0 5 qsaal
 ATM PVC 2 0 16 ilmi
 no ATM ilmi-keepalive
!
interface ATM0.1 multipoint
 lane server-bus ethernet test-elan

!--- Configuration of the Bus.

!
interface ATM0.2 multipoint
 lane server-bus ethernet test-elan2
!
interface ATM0.3 multipoint
 lane client ethernet 2 test-elan2

!--- Output suppressed.

lane server-bus ethernet elan-name命令配置此设备作为ELAN名为elan名称的LES/BUS。

注意: 可以只有每个多点子接口一服务器总线。

其它命令

当配置LANE时,这些是一些有用的命令使用。使用这些命令为了实现LANE是不必要的。

在 LECS 上

interface ATM2/0/0
  no ip address
  no ip directed-broadcast
  lane config fixed-config-atm-address
  lane config auto-config-atm-address
  lane config config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane config database test
  • LANE Config fixed-config-atm-address —表明LECS响应对呼叫建立做对众所周知的NSAP地址。众所周知的NSAP地址是47.007900000000000000000000.00A03E000001.00。

  • lane config config-atm-address NSAP —表明LECS也回答对呼叫建立做对已配置的NSAP地址47.0091.8100.0000.0060.705a.8f01.0000.0000.0001.01。

在 LES 上

interface ATM0.1 multipoint
  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane bus-atm-address 47.0091810000000060705A8F01.000000000003.01
  lane server-bus ethernet test-elan
  • Lane Config-ATM-Address NSAP —强制LES/BUS连接到与NSAP地址的LECS,而不是使用从ILMI了解的LECS地址。

  • LANE Server-ATM-Address NSAPbus-atm-address通道NSAP —允许您静态配置各自LES和BUS的NSAP地址。

参考硬编码LES/LEC/BUS/LECS的ATM地址欲知更多信息。

在 LEC 上

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0
  lane fixed-config-atm-address
  lane client ethernet test-elan

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane client ethernet test-elan
  interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane client ethernet test-elan
  • lane fixed-config-atm-address —使用众所周知的NSAP地址,强制LEC连接到LECS,而不是使用从ILMI了解的LECS NSAP地址。

  • Lane Config-ATM-Address NSAP —强制LEC连接到与NSAP地址的LECS,而不是使用从ILMI了解的LECS地址。

  • LANE Server-ATM-Address NSAP —强制LEC直接地连接到与NSAP地址的LES,无需首先连接对LECS。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 10457