多协议标签交换 (MPLS) : 基于 ATM 的多协议标签交换 (MPLS over ATM)

MPLS over ATM :VC合并

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

使用虚拟电路合并,本文提供ATM上多协议标签交换(MPLS)配置示例。

先决条件

要求

在您尝试此配置前,请保证您有ATM、MPLS和开放最短路径优先(OSPF)基本的了解。

使用的组件

请使用这些路由器之一为了实现此配置:

  • 边缘标签交换路由器(LSR) —所有ATM路由器运行Cisco IOSï ¿ Â的½软件版本12.0或以上,与MPLS以为特色。此配置使用运行Cisco IOS软件版本12.1(3)T和Cisco 7200路由器运行Cisco IOS软件版本12.0(8)S的Cisco 3600系列路由器。

  • ATM LSR —任何ATM交换机例如LightStream1010或Catalyst 85xx MSR。思科建议您使用软件版本WA4.8d或以后。LightStream1010要求特性卡单个流的排队(FC-PFQ)。

您能找到支持的平台的一更加准确的说明设计的MPLS ATM的

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

参考这些链路关于MPLS配置和规则的更多信息:

  • 使用标签转发协议(LDP)和ATM VC交换文档, VC合并设备在互联网工程任务组(IETF)多协议标签交换体系结构和MPLS标准化。您能访问从IETF MPLS需许可证的这两个文档leavingcisco.com

  • 您能找到在ATM上的MPLS文档的配置说明。

  • VC数量的Dimensioning用于MPLS网络的在设计ATM的MPLS的Dimensioning MPLS Label VC Space部分报道。

背景信息

VC合并设备允许交换机聚集与同一目的地址的多个流入流到单个流出的流里。无论哪里VC合并发生,几个流入的标签被映射到一个单个流出的标签。从去同一个目的地的不同的虚拟信道标识符(VCIs)的信元传送对与使用的同样流出的VC多点对点连接。此共享标签减少为标签交换要求的VC总数。没有VC合并,每个路径(与同一个入口路由器和同样转发等价类(FEC))消耗在每个接口的一个标签VC沿路径。VC合并通过共享不同的流的标签减少标签空间短缺与同一个目的地,即,同样FEC。

此图显示VC合并示例。在此图,路由器A和B发送流量加前缀171.69.0.0/16在路由器C。ATM交换机在中部用一定的单个出站VCI 50配置加前缀171.69.0.0/16。从路由器A的数据流和B在ATM交换机聚集并且共享同样流出的VC。来自VCI 40和VCI 70的信元在ATM交换机的Input queue缓冲,直到完整AAL5帧接收。完整的帧然后转发对在VCI 50的路由器C。

/image/gif/paws/10475/mpls_vcmerge1.gif

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此网络设置。

/image/gif/paws/10475/mpls_vcmerge2.gif

配置

在本例中, 2, 3或者4使用ATM虚通路标识符(VPIs)。但是,虚拟路径的是不必须的指定(VPs)使用MPLS。

配置IP Cisco Express Forwarding (CEF)在路由器。如果使用一个Cisco 7500路由器,您必须保证ip cef distributed命令启用。

本文档使用以下配置。

路由器 1
!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!
interface Loopback1
 ip address 100.100.1.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 100.100.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 100.100.0.0 0.0.0.255 area 10
 network 100.100.1.0 0.0.0.255 area 10
 network 223.0.0.12 0.0.0.0 area 10
!

路由器 2
!
ip cef
!
interface Loopback0
 ip address 223.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 100.100.0.1 255.255.255.0
!
interface ATM1/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
!
interface ATM1/0.1 label-switching
 ip address 10.0.0.2 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 100.100.0.0 0.0.0.255 area 10
 network 223.0.0.11 0.0.0.0 area 0
!

路由器 3
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip address 200.200.0.1 255.255.255.255
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.6 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 redistribute static
 network 10.0.0.0 0.0.0.255 area 0
 network 200.200.0.0 0.0.0.255 area 20
 network 223.0.0.21 0.0.0.0 area 0
!
ip route 158.0.0.0 255.0.0.0 Null0
!

Router4
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
 no ip directed-broadcast
! 
interface Loopback1
 ip address 150.150.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM4/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.13 255.255.255.252
 no ip directed-broadcast
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.255.255 area 30
 network 223.0.0.3 0.0.0.0 area 0
!
ip route 150.150.150.0 255.255.255.0 Null0
!

ATM交换机1
!
interface Loopback0
 ip address 223.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface ATM4/1/2
 ip address 10.0.0.1 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM4/1/3
 ip address 10.0.0.21 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.1 0.0.0.0 area 0
!

ATM交换机2
!
interface Loopback0
 ip address 223.0.0.2 255.255.255.255
 no ip directed-broadcast
!
interface ATM0/1/0
 ip address 10.0.0.14 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!         
interface ATM0/1/2
 ip address 10.0.0.5 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM0/1/3
 ip address 10.0.0.22 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.2 0.0.0.0 area 0
!

验证

本部分提供的信息可用于确认您的配置是否正常运行。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show tag-switching atm-tdp capability

  • show tag-switching atm-tdp bindings

  • show atm vc

发出show tag atm-tdp命令为了得到关于VC合并的信息。此输出,生成由show tag-switching atm-tdp capability命令,显示VC合并在这些接口启用:

ATMswitch2#show tag-switching atm-tdp capability 
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/0       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1023]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1023]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/2       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1018]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1018]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/3       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 16383]  UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 16383]  UNIDIR           -    -

您能也检查VC合并一个特定FEC –例如, 100.100.1.1/32 –如在此输出中看到:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/47 Active -> ATM0/1/3 2/52 Active
    Transit ATM0/1/0 2/47 Active -> ATM0/1/3 2/52 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/2    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/3    2    52   TVC(O) ATM0/1/2          2   47           UP
                             ATM0/1/0          2   47           UP

如果VC合并不工作(或,如果它用no tag-switching atm vc-merge命令禁用),您收到此命令输出:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/38 Active -> ATM0/1/3 2/35 Active
    Transit ATM0/1/0 2/43 Active -> ATM0/1/3 2/43 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0   2    43    TVC(I) ATM0/1/3          2   43           UP
ATM0/1/2   2    38    TVC(I) ATM0/1/3          2   35           UP
ATM0/1/3   2    35    TVC(O) ATM0/1/2          2   38           UP
ATM0/1/3   2    43    TVC(O) ATM0/1/0          2   43           UP

您能从使用许多VC,禁用VC合并功能导致系统的此输出看到。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 10475