异步传输模式 (ATM) : ATM 与帧中继互联

帧中继到 ATM 服务互工作 (FRF.8) 的端到端 PVC 管理

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

在FRF.8实施协议,宽带论坛leavingcisco.com (以前帧中继论坛)定义了相互作用或连接两份第2层协议的帧中继终点和一ATM端点通过路由器或交换机之间的通信。本文描述在FRF.8服务互通(IWF)使用路由器和交换机,连接的永久虚拟电路(PVC)管理计划并且提供配置示例。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

FRF.8 PVC 管理过程

FRF.8的部分5.2描述ATM和帧中继PVC管理计划。在ATM侧,这些步骤使用F5操作、管理和维护(OAM)信元和本地管理接口(ILMI)管理信息库(MIB)变量。ATM状态信息然后被映射到对应的帧中继状态指示由连接设备。

帧中继端使用本地管理接口(LMI)协议传达状态信息。标准的2字节帧中继报头不包括指示虚拟电路状况对终端的任何字段。LMI协议因而增添帧中继用通知终端的机制,当永久虚拟电路(PVC)添加,删除的或者更改的状态时。它也提供验证链路保持可操作的一个轮询机制。是与用于数据流的DLCI不同的它发送在数据链路连接标识符(DLCI)的LMI帧。

LMI帧的消息类型字段是八个位并且包括状态查询和状态消息。每隔几秒钟,帧中继终点(用户)发状态查询消息对网络;此消息验证链路完整性。网络回应包含请求的信息的状态消息。在状态查询以后定义的编号,帧中继终点请求一所谓的完整状态答复。网络回应包含在该链路配置的每个PVC的信息单元(IE)的状态消息。

PVC状态IE是五个字节。除报告的PVC的DLCI之外, IE包含两个重要状态位:

  • 新的位-集通过网络,当PVC在交换机被添加。网络继续设置新的位到一个在完整的状态消息,直到收到从包含接收序号相等与网络的当前发送序号的帧中继终点(用户)的一个状态查询消息。

  • 活动位-设置,当网络是满足的对目的地的一完整路径存在,并且PVC充分地是设立的端对端。

一个警告用帧中继状态机制是它不是实时进程,并且必须等待被安排的状态消息传送。有时,计时问题可能出现,如果,在PVC变得可用在网络后,两个帧中继终点收到一个完整的状态消息活动位设置到一个在不同的时刻。一个终端发送在PVC间的数据帧,在另一个终端(目的地)前接收有效状态消息。

LMI协议解决与异步状态报告类型IE的此缺点。一个异步消息包括在一更改之后的状态和状态查询发送的消息在PVC状态和没有等待消息计时器超时。执行相互作用的Cisco路由器不支持异步状态消息的步骤。

凭状态位, PVC分配在帧中继端的四个状态值之一。交换机或Cisco路由器执行IWF使用一套标准确定对VC的哪状态分配。

状态 征兆和匹配标准
已添加 帧中继网络设置完整状态报告的新的位为IWF。
删除 IWF此状态向在完整状态报告的帧中继网络报告。
非激活 IWF使用以下标准确定非激活状态:
  • 告警指示信号(AIS)或远程缺陷指示器(RDI) OAM F5信元明确地表明ATM PVC发生故障某处沿端到端路径。
  • ILMI MIB报告localDown或end2EndDown在可变atmfVccOperStatus。
IWF发送一个完整状态报告用设置的活动位到零。
激活 IWF使用以下标准确定有效状态:
  • 没有AIS OAM信元和没有RDI OAM信元从ATM网络时间间隔的如对OAM规格定义, ITU-I.610
  • ILMI MIB不报告localDown或end2EndDown在可变atmfVccOperStatus。
IWF在有效状态安置VC在帧中继端,当两个标准被满足时(如果使用两个),并且没有在ATM侧的地方IWF检测的物理报警。IWF发送一个完整状态报告活动位设置到一个为帧中继网络。

使用 Catalyst 8540 MSR 作为 IWF 交换机的示例

下面的示例显示Catalyst 8540 MSR作为IWF交换机。

网络图

拓扑出现如下:

/image/gif/paws/10440/frf8_pvc_manage1.gif

注意: ATM路由器是7500路由器使用在VIP2-50和?发器12.1(13)E的一PA-A3-OC3MM。帧中继路由器是7200路由器运行12.1(17)。ATM/FR-IWF-switch是运行12.1(12c)EY的Catalyst 8540MSR。

配置

帧中继路由器
controller E1 4/0
 channel-group 0 timeslots 1-31
!         
interface Serial4/0:0
 ip address 12.12.12.2 255.255.255.0
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay map ip 12.12.12.1 123 broadcast

ATM-FR/IWF交换机
controller E1 10/0/0
 channel-group 1  timeslots 1-31
!
interface Serial10/0/0:1
 no ip address
 encapsulation frame-relay IETF
 no arp frame-relay
 frame-relay intf-type dce
 frame-relay pvc 123 service translation  interface  ATM9/1/2 0 123 
 atm oam interface  ATM9/1/2 0 123

ATM路由器
interface ATM2/1/0.1 point-to-point
 ip address 12.12.12.1 255.255.255.0
 pvc 0/123 
  oam-pvc manage
  encapsulation aal5snap 

显示命令

ATM-router#show atm pvc 0/123
ATM2/1/0.1: VCD: 2, VPI: 0, VCI: 123
UBR, PeakRate: 149760
AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0
OAM frequency: 10 second(s), OAM retry frequency: 1 second(s), OAM retry frequen
cy: 1 second(s)
OAM up retry count: 3, OAM down retry count: 5
OAM Loopback status: OAM Received
OAM VC state: Verified
ILMI VC state: Not Managed
VC is managed by OAM.
InARP frequency: 15 minutes(s)
Transmit priority 4
InPkts: 5, OutPkts: 8, InBytes: 540, OutBytes: 624
InPRoc: 5, OutPRoc: 5
InFast: 0, OutFast: 0, InAS: 0, OutAS: 3
InPktDrops: 0, OutPktDrops: 0
CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0
OAM cells received: 124713
F5 InEndloop: 74872, F5 InSegloop: 49841, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 124756
F5 OutEndloop: 74915, F5 OutSegloop: 49841, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Status: UP

FR-router#show frame-relay pvc

PVC Statistics for interface Serial4/0:0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial4/0:0

  input pkts 8             output pkts 5            in bytes 1633      
  out bytes 520            dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 0          out bcast bytes 0         
  pvc create time 00:02:44, last time pvc status changed 00:02:44

ATM-FR/IWF-switch#show frame-relay pvc 

PVC Statistics for interface Serial10/0/0:1 (Frame Relay DCE)

              Active     Inactive      Deleted       Static
  Local          0            0            0            0
  Switched       1            0            0            0
  Unused         0            0            0            0

DLCI = 123, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial10/0/0:1

  input pkts 5             output pkts 6            in bytes 520       
  out bytes 550            dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 4151       out bcast bytes 1494481      Num Pkts Switched 0         
  pvc create time 2d21h, last time pvc status changed 2d21h

ATM-FR/IWF-switch#show atm vc interface atm 9/1/2 0 123

Interface: ATM9/1/2, Type: oc3suni 
VPI = 0  VCI = 123
Status: UP
Time-since-last-status-change: 2d21h
Connection-type: PVC 
Cast-type: point-to-point
Packet-discard-option: disabled
Usage-Parameter-Control (UPC): pass
Wrr weight: 2
Number of OAM-configured connections: 32
OAM-configuration: Seg-loopback-on End-to-end-loopback-on Ais-on Rdi-on
OAM-states:  OAM-Up
OAM-Loopback-Tx-Interval: 5
Cross-connect-interface: ATM-P10/0/0, Type: ATM-PSEUDO 
Cross-connect-VPI = 1 
Cross-connect-VCI = 155
Cross-connect-UPC: pass
Cross-connect OAM-configuration: Ais-on
Cross-connect OAM-state:  OAM-Up
OAM-Loopback-Tx-Interval: 5
Threshold Group: 3, Cells queued: 0
Rx cells: 16, Tx cells: 15
Tx Clp0:15,  Tx Clp1: 0
Rx Clp0:16,  Rx Clp1: 0
Rx Upc Violations:9, Rx cell drops:0
Rx Clp0 q full drops:0, Rx Clp1 qthresh drops:0
Rx connection-traffic-table-index: 100
Rx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
Rx pcr-clp01: 81
Rx scr-clp0 : 81
Rx mcr-clp01: none
Rx      cdvt: 1024 (from default for interface)
Rx       mbs: 50
Tx connection-traffic-table-index: 100
Tx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
Tx pcr-clp01: 81
Tx scr-clp0 : 81
Tx mcr-clp01: none
Tx      cdvt: none
Tx       mbs: 50

方案一

使用描述的配置以上,请看知道两路由器如何起反应给在网络内的失败。在此第一个方案中,我们将关闭ATM路由器ATM接口并且看到什么此失败影响在帧中继路由器PVC是。

  1. 关闭在ATM路由器的ATM子接口:

       ATM-router#config terminal
       Enter configuration commands, one per line.� End with CNTL/Z.
       ATM-router(config)#interface atm 2/1/0.1
       ATM-router(config-subif)#shut
  2. 检查PVC的状态在ATM-FR/IWF交换机的:

    ATM-FR/IWF-switch#show atm vc interface atm 9/1/2 0 123
    
    Interface: ATM9/1/2, Type: oc3suni 
    VPI = 0  VCI = 123
    Status: UP
    Time-since-last-status-change: 00:00:44
    Connection-type: PVC 
    Cast-type: point-to-point
    Packet-discard-option: disabled
    Usage-Parameter-Control (UPC): pass
    Wrr weight: 2
    Number of OAM-configured connections: 32
    OAM-configuration: Seg-loopback-on End-to-end-loopback-on Ais-on Rdi-on
    OAM-states:  OAM-Up Segment-loopback-failed End-to-end-loopback-failed
    OAM-Loopback-Tx-Interval: 5
    Cross-connect-interface: ATM-P10/0/0, Type: ATM-PSEUDO 
    Cross-connect-VPI = 1 
    Cross-connect-VCI = 155
    Cross-connect-UPC: pass
    Cross-connect OAM-configuration: Ais-on
    Cross-connect OAM-state:  OAM-Up
    OAM-Loopback-Tx-Interval: 5
    Threshold Group: 3, Cells queued: 0
    Rx cells: 1, Tx cells: 0
    Tx Clp0:0,  Tx Clp1: 0
    Rx Clp0:1,  Rx Clp1: 0
    Rx Upc Violations:0, Rx cell drops:0
    Rx Clp0 q full drops:0, Rx Clp1 qthresh drops:0
    Rx connection-traffic-table-index: 100
    Rx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
    Rx pcr-clp01: 81
    Rx scr-clp0 : 81
    Rx mcr-clp01: none
    Rx      cdvt: 1024 (from default for interface)
    Rx       mbs: 50
    Tx connection-traffic-table-index: 100
    Tx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
    Tx pcr-clp01: 81
    Tx scr-clp0 : 81
    Tx mcr-clp01: none
    Tx      cdvt: none
    Tx       mbs: 50
  3. 检查在帧中继路由器的PVC状态:

    FR-router#show frame-relay pvc
    
    PVC Statistics for interface Serial4/0:0 (Frame Relay DTE)
    
                  Active     Inactive      Deleted       Static
      Local          0            1            0            0
      Switched       0            0            0            0
      Unused         0            0            0            0
    
    DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial4/0:0
    
      input pkts 18            output pkts 5            in bytes 4320      
      out bytes 520            dropped pkts 5           in FECN pkts 0         
      in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
      in DE pkts 0             out DE pkts 0         
      out bcast pkts 0          out bcast bytes 0         
      pvc create time 00:15:21, last time pvc status changed 00:03:50

正如你在以上输出看到,在ATM侧的一失败在FR侧反射。的确, FR PVC进入非活动状态。

方案两

现在,请发现什么在ATM侧发生,当失败在FR网云内时发生。要模拟那种失败,请关闭在帧中继路由器的serial interfaces和发现ATM路由器如何起反应。

  1. 关闭在帧中继路由器的serial interfaces并且请参阅ATM路由器如何起反应:

       FR-router#config terminal
       Enter configuration commands, one per line.� End with CNTL/Z.
       FR-router(config)#int serial 4/0:0
       FR-router(config-if)#shut
  2. debug atm oam在ATM路由器启用。我们能看到,当查出失败时, ATM-FR/IWF交换机发送AIS信号对ATM路由器:

       3d12h: atm_oam_ais(ATM2/1/0): AIS signal, failure=0x6A, VC 0/123
       3d12h: atm_oam_setstate - VCD#3, VC 0/123: newstate = AIS/RDI
       3d12h: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM2/1/0.1, changed state    to down
       3d12h: atm_oam_ais_inline(ATM2/1/0): AIS signal, failure=0x6A, VC 0/123

    如果我们检查在ATM路由器的PVC状态,我们能看到PVC发生故障:

    ATM-router#show atm pvc 0/123
    ATM2/1/0.1: VCD: 3, VPI: 0, VCI: 123
    UBR, PeakRate: 149760
    AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0
    OAM frequency: 10 second(s), OAM retry frequency: 1 second(s), OAM retry frequency: 1 second(s)
    OAM up retry count: 3, OAM down retry count: 5
    OAM Loopback status: OAM Received
    OAM VC state: AIS/RDI
    ILMI VC state: Not Managed
    VC is managed by OAM.
    InARP frequency: 15 minutes(s)
    Transmit priority 4
    InPkts: 0, OutPkts: 4, InBytes: 0, OutBytes: 112
    InPRoc: 0, OutPRoc: 0
    InFast: 0, OutFast: 0, InAS: 0, OutAS: 4
    InPktDrops: 0, OutPktDrops: 0
    CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0
    OAM cells received: 304
    F5 InEndloop: 114, F5 InSegloop: 69, F5 InAIS: 121, F5 InRDI: 0
    F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
    OAM cells sent: 310
    F5 OutEndloop: 120, F5 OutSegloop: 69, F5 OutRDI: 121
    F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
    OAM cell drops: 0
    Status: DOWN, State: NOT_VERIFIED
  3. 检查在ATM-FR/IWF交换机的状态:

    ATM-FR/IWF-switch#show atm vc interface atm 9/1/2 0 123
    
    Interface: ATM9/1/2, Type: oc3suni 
    VPI = 0  VCI = 123
    Status: DOWN
    Time-since-last-status-change: 00:03:04
    Connection-type: PVC 
    Cast-type: point-to-point
    Packet-discard-option: disabled
    Usage-Parameter-Control (UPC): pass
    Wrr weight: 2
    Number of OAM-configured connections: 32
    OAM-configuration: Seg-loopback-on End-to-end-loopback-on Ais-on Rdi-on
    OAM-states:  OAM-Up
    OAM-Loopback-Tx-Interval: 5
    Cross-connect-interface: ATM-P10/0/0, Type: ATM-PSEUDO 
    Cross-connect-VPI = 1 
    Cross-connect-VCI = 155
    Cross-connect-UPC: pass
    Cross-connect OAM-configuration: Ais-on
    Cross-connect OAM-state:  OAM-Down
    OAM-Loopback-Tx-Interval: 5
    Threshold Group: 3, Cells queued: 0
    Rx cells: 3, Tx cells: 0
    Tx Clp0:0,  Tx Clp1: 0
    Rx Clp0:3,  Rx Clp1: 0
    Rx Upc Violations:0, Rx cell drops:0
    Rx Clp0 q full drops:0, Rx Clp1 qthresh drops:0
    Rx connection-traffic-table-index: 100
    Rx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
    Rx pcr-clp01: 81
    Rx scr-clp0 : 81
    Rx mcr-clp01: none
    Rx      cdvt: 1024 (from default for interface)
    Rx       mbs: 50
    Tx connection-traffic-table-index: 100
    Tx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
    Tx pcr-clp01: 81
    Tx scr-clp0 : 81
    Tx mcr-clp01: none
    Tx      cdvt: none
    Tx       mbs: 50

因此,我们能看到,由于OAM, ATM路由器将起反应给在FR网云内的一失败通过带来在对应ATM PVC下。

已知问题说明

  • CSCdu78168 (CSCdt04356重复项) :OAM管理在与FR的MSR不工作对ATM IWF

使用 Cisco 7200 路由器作为 IWF 的示例

网络图

frf8_pvc_manage2.gif

配置

3620
interface Serial1/0 
 ip address 10.10.10.1 255.255.255.0 
 encapsulation frame-relay IETF 
 frame-relay interface-dlci 50 
 frame-relay lmi-type ansi

7206
frame-relay switching 
! 
interface Serial4/3 
 no ip address 
 encapsulation frame-relay IETF 
 frame-relay interface-dlci 50 switched 
 frame-relay lmi-type ansi 
 frame-relay intf-type dce 
 clockrate 115200 
! 
interface ATM5/0 
 no ip address 
 atm clock INTERNAL 
 no atm ilmi-keepalive 
 pvc 5/50 
  vbr-nrt 100 75 
  oam-pvc manage 
  encapsulation aal5mux fr-atm-srv 
! 
connect SIVA Serial4/3 50 ATM5/0 5/50 service-interworking

7500
interface atm 4/0/0.50 multi 
 ip address 10.10.10.2 255.255.255.0 
 pvc 5/50 
  vbr-nrt 100 75 30 
  protocol ip 10.10.10.1

方案一

下列场景假设,我们配置ATM端点和ATM接口在IWF用oam-pvc manage命令。我们从ATM端点将删除PVC配置语句。当ATM PVC下来时,帧中继PVC变成非激活状态。

  1. 启用debug atm oam并且清除计数器

    1d09h: ATM OAM(ATM4/0/0.50): Timer: VCD#5 VC 5/50 Status:2 CTag:8586 Tries:0 
    1d09h: ATM OAM LOOP(ATM4/0/0.50) O: VCD#5 VC 5/50 CTag:218B 
    1d09h: ATM OAM LOOP(ATM4/0/0) I: VCD#5 VC 5/50 LoopInd:0 CTag:218B    
    1d09h: ATM OAM LOOP(ATM4/0/0) I: VCD#5 VC 5/50 LoopInd:1 CTag:4850    
    1d09h: ATM OAM LOOP(ATM4/0/0.50) O: VCD#5 VC 5/50 CTag:4850
    
  2. 删除从ATM端点的PVC用no表new-style pvc命令。

    7500#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    7500(config)#interface atm 4/0/0.50
    7500(config-subif)#no pvc 5/50
    
  3. 执行show atm vc命令并且证实VC的状态是在IWF 7200的DOWN。

    7200#show atm vc 
                  VCD /                                Peak Avg/Min Burst 
       Interface  Name  VPI   VCI   Type  Encaps   SC  Kbps Kbps    Cells   Sts 
       5/0.200    test   2    20    PVC   SNAP     UBR 149760                UP 
       5/0.100     2     3    300   PVC   SNAP     UBR 149760                UP 
       5/0         1     5    50    PVC   FRATMSRV VBR 100     75     95    DOWN
    
  4. 执行show atm pvc {vpi/vci}命令和确认OAM VC状态:不已验证。

    7200#show atm pvc 5/50 
       ATM5/0: VCD: 1, VPI: 5, VCI: 50 
       VBR-NRT, PeakRate: 100, Average Rate: 75, Burst Cells: 95 
       AAL5-FRATMSRV, etype:0x15, Flags: 0x23, VCmode: 0x0 
       OAM frequency: 10 second(s), OAM retry frequency: 1 second(s),    OAM retry frequency: 1 second(s) 
       OAM up retry count: 3, OAM down retry count: 5 
       OAM Loopback status: OAM Sent 
       OAM VC state: Not Verified 
       ILMI VC state: Not Managed 
       VC is managed by OAM. 
       InARP DISABLED 
       Transmit priority 2 
       InPkts: 0, OutPkts: 0, InBytes: 0, OutBytes: 0 
       InPRoc: 0, OutPRoc: 0, Broadcasts: 0 
       InFast: 0, OutFast: 0, InAS: 0, OutAS: 0 
       InPktDrops: 0, OutPktDrops: 0 
       CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0 
       Out CLP=1 Pkts: 0 
       OAM cells received: 19 
       F5 InEndloop: 19, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0    
       F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0 
       OAM cells sent: 82 
       F5 OutEndloop: 82, F5 OutSegloop: 0, F5 OutRDI: 0 
       F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0 
       OAM cell drops: 0 
       Status: DOWN, State: NOT_VERIFIED
    
  5. 在帧中继终点的Enable (event) debug frame-relay packet。观察状态和状态查询(StEnq)消息顺序被交换在帧中继连接的用户和网络终端之间。确认VC的状态从0x2 (激活)变成0x0 (非激活)。

    *Apr 7 01:53:18.407: Serial1/0(in): Status, myseq 69    
       *Apr 7 01:53:18.407: RT IE 1, length 1, type 0 
       *Apr 7 01:53:18.407: KA IE 3, length 2, yourseq 67, myseq 69    
       *Apr 7 01:53:18.407: PVC IE 0x7 , length 0x3 , dlci 50, status 0x2 
       
    ! -- A value of 0x2 indicates active status.
        
       *Apr 7 01:53:28.403: Serial1/0(out): StEnq, myseq 70, yourseen 67, DTE up 
       *Apr 7 01:53:28.403: datagramstart = 0x3D53954, datagramsize = 14    
       *Apr 7 01:53:28.403: FR encap = 0x00010308 
       *Apr 7 01:53:28.403: 00 75 95 01 01 01 03 02 46 43 
       *Apr 7 01:53:28.403: 
       *Apr 7 01:53:28.407: Serial1/0(in): Status, myseq 70 
       *Apr 7 01:53:28.407: RT IE 1, length 1, type 1 
       *Apr 7 01:53:28.407: KA IE 3, length 2, yourseq 68, myseq 70    
       *Apr 7 01:53:38.403: Serial1/0(out): StEnq, myseq 71, yourseen 68, DTE up 
       *Apr 7 01:53:38.403: datagramstart = 0x3D53954, datagramsize = 14    
       *Apr 7 01:53:38.403: FR encap = 0x00010308 
       *Apr 7 01:53:38.403: 00 75 95 01 01 01 03 02 47 44 
       *Apr 7 01:53:38.403: 
       *Apr 7 01:53:38.407: Serial1/0(in): Status, myseq 71 
       *Apr 7 01:53:38.407: RT IE 1, length 1, type 0 
       *Apr 7 01:53:38.407: KA IE 3, length 2, yourseq 69, myseq 71    
       *Apr 7 01:53:38.407: PVC IE 0x7 , length 0x3 , dlci 50, status 0x0 
       
    ! -- A value of 0x0 indicates inactive status. 
    
    

    Status字段的可能的值如下解释:

    • 0x0 -已添加和非激活。DLCI在交换机被编程,但是不是可用的。一个潜在原因是PVC的另一端发生故障。

    • 0x2 -已添加和活动。DLCI在交换机被编程,并且PVC是可操作的。

    • 0x3 -结合设置的有效状态(0x2)和Receiver Not Ready (RNR) (或r-bit) (0x1)。值0x03意味着交换机或一个特定队列在交换机此PVC的备份,因此帧中继接口停止传送避免丢失的帧。

    • 0x4 -删除。DLCI在交换机没有被编程,然而以前被编程了。交替地,已删除状态可以造成由在路由器被倒转的DLCI或由telco删除的PVC的帧中继网云。配置在一个帧中继终点的DLCI没有在交换机的匹配值导致VC的一个0x4状态值。

  6. 如果不能运行在生产路由器的debug frame-relay packet,请执行show frame pvc并且确认帧中继终点列出至少一个非激活本地PVC。

    3620#show frame pvc    
    PVC Statistics for interface Serial1/0 (Frame Relay DTE)    
                      Active     Inactive     Deleted     Static 
          Local         0           1            0           0      
          Switched      0           0            0           0 
          Unused        0           0            0           0    
    DLCI = 50, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial1/0    
          input pkts 0             output pkts 0            in bytes 0 
          out bytes 0              dropped pkts 0           in FECN pkts 0 
          in BECN pkts 0           out FECN pkts 0 out      BECN pkts 0 
          in DE pkts 0             out DE pkts 0 
          out bcast pkts 0         out bcast bytes 0 
          pvc create time 3d04h, last time pvc status changed 00:05:04      

方案两

下列场景假设,我们从IWF 7200删除oam-pvc manage命令。ATM VC在上状态保持和反过来保持活动在帧中继端。

  1. 删除oam-pvc manage命令在IWF 7200's ATM接口。

       7200(config)#int atm 5/0 
       7200(config-if)#pvc 5/50 
       7200(config-if-atm-vc)#no oam-pvc manage 
       7200(config-if-atm-vc)#end 
       7200#show atm vc 
       *May 31 01:20:01.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM5/0,    changed state to up 
                 VCD /                                    Peak   Avg/Min Burst 
       Interface Name   VPI   VCI   Type   Encaps   SC    Kbps   Kbps    Cells   Sts 
       5/0.100     2     3     300  PVC    SNAP      UBR  149760                  UP 
       5/0         1     5     50   PVC    FRATMSRV  VBR  100     75       95     UP
  2. 请使用PVC命令的no表删除在ATM端点的PVC。

    7500(config)#int atm 4/0/0.50 
       7500(config-subif)#no pvc 5/50 
       7500(config-subif)#end
    
  3. show atm pvc vpi/vci命令确认状态在ATM侧。

    7200-2.4#show atm pvc 5/50 
       ATM5/0: VCD: 1, VPI: 5, VCI: 50 
       VBR-NRT, PeakRate: 100, Average Rate: 75, Burst Cells: 95 
       AAL5-FRATMSRV, etype:0x15, Flags: 0x23, VCmode: 0x0 
       OAM frequency: 0 second(s), OAM retry frequency: 1 second(s),    OAM retry frequency: 1 second(s) 
       OAM up retry count: 3, OAM down retry count: 5 
       OAM Loopback status: OAM Disabled 
       OAM VC state: Not Managed 
       ILMI VC state: Not Managed 
       InARP DISABLED 
       Transmit priority 2 
       InPkts: 15, OutPkts: 19, InBytes: 1680, OutBytes: 1332 
       InPRoc: 0, OutPRoc: 0, Broadcasts: 0 
       InFast: 15, OutFast: 19, InAS: 0, OutAS: 0 
       InPktDrops: 0, OutPktDrops: 0 
       CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0 
       Out CLP=1 Pkts: 0 
       OAM cells received: 157 
       F5 InEndloop: 157, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0 
       F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0 
       OAM cells sent: 214 
       F5 OutEndloop: 214, F5 OutSegloop: 0, F5 OutRDI: 0 
       F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0 
       OAM cell drops: 0 
       Status: UP
    
  4. PVC的状态在帧中继端的也依然是活动。

     *Apr 7 02:25:08.407: Serial1/0(in): Status, myseq 5    
       *Apr 7 02:25:08.407: RT IE 1, length 1, type 0 
       *Apr 7 02:25:08.407: KA IE 3, length 2, yourseq 3 , myseq 5 
       *Apr 7 02:25:08.407: PVC IE 0x7 , length 0x3 , dlci 50, status 0x2 
       
    ! -- The Frame Relay PVC retains an active status (0x2). 
    
       *Apr 7 02:25:18.403: Serial1/0(out): StEnq, myseq 6, yourseen 3, DTE up 
       *Apr 7 02:25:18.403: datagramstart = 0x3D53094, datagramsize = 14    
       *Apr 7 02:25:18.403: FR encap = 0x00010308 
       *Apr 7 02:25:18.403: 00 75 95 01 01 00 03 02 06 03
  5. show frame pvc命令证实PVC的有效状态在帧中继终点的。

    3620#show frame pvc
    PVC Statistics for interface Serial1/0 (Frame Relay DTE)    
                   Active Inactive Deleted Static 
          Local      1      0       0        0      
          Switched   0      0       0        0 
          Unused     0      0       0        0    
    DLCI = 50, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0    
          input pkts 0        output pkts 0         in bytes 0 
          out bytes 0         dropped pkts 0        in FECN pkts 0 
          in BECN pkts 0      out FECN pkts 0 out   BECN pkts 0 
          in DE pkts 0        out DE pkts 0 
          out bcast pkts 0    out bcast bytes 0 
          pvc create time 3d04h, last time pvc status changed 00:02:45

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 10440