异步传输模式 (ATM) : IP to ATM 业务类别

Cisco 7200、3600 和 2600 路由器上的基于每 VC 类的加权公平排队 (Per-VC CBWFQ)

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

加权公平排队(WFQ)为慢速链路实现(例如序列)为每种流量类型提供公平处理。要做其工作, WFQ分类流量到根据相关的第三层和第四层信息的不同的流(IP地址, TCP端口,等等)。您不需要定义访问列表为了此能工作。使用WFQ,低带宽流量有在高带宽流量的有效优先级。高带宽流量按比例共享传输介质与分配的权值。

WFQ有以下限制:

  • 如果通信流极大增加, WFQ不能调节,因为不可扩展。

  • WFQ不是可用的在高速接口,例如ATM。

新特性,基于类的加权公平排队(CBWFQ),开发寻址WFQ的限制。不同于WFQ, CBWFQ允许您定义数据流类别。一旦类定义,参数可能然后应用。这些参数包括带宽和队列极限。

当曾经CBWFQ时,指定的重要性类变为匹配类标准的重要性每数据包。此权重来自于您分配到类的带宽。WFQ然后应用对这些类而不是应用对流。类能包括几个流。

下面每个vc CBWFQ可用性摘要在7200, 3600和2600路由器的:

  • 7200 :Cisco IOS�版本12.0(5)T, 12.0(5)XE, 12.1(1), 12.1(1)T, 12.1(1)E和以后使用PA-A3。

  • 7200与NSE :Cisco IOS版本12.1(7)E和以后。

  • 7200用NSE-1服务加速器:Cisco IOS版本12.2(4)B1。

  • 2600/3600与NM-1A-T3/E3模块技术支持LLQ/在Cisco IOS版本12.1(5)T的CBWFQ和以后。

  • 2600/3600用DS3/E3网络模块:Cisco IOS版本12.1(2)T。

注意: 思科快速转发功能,因为CBWFQ监控仅经过CEF交换的数据包,必须使用。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下硬件版本:

  • Cisco 7200、3600及2600系列路由器

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/10395/7200-1.gif

  • 1/130是在PVC和路由器A的两端分配的VPI/VCI值在7200之间的。

  • 数据流生成器连接对快速以太网接口3/0。

  • 7200运行Cisco IOS版本12.0(5)T。

  • 路由器A使用作为接收器设备测验。

  • 配置在7200被执行,但是类似的在2600/3600。

配置示例

下面必要7200的配置实现CBWFQ :

7200
    class-map ixia
      match input-interface FastEthernet3/0
    class-map loopbacks
      match access-group 102
    !
    policy-map mypol
      class ixia
       bandwidth 40000
       queue-limit 40
      class loopbacks
       bandwidth 10000
      class class-default
       fair-queue
    !
    interface ATM2/0.130 point-to-point
     ip address 14.0.0.2 255.0.0.0
     no ip directed-broadcast
     pvc 1/130
      service-policy output mypol
      vbr-nrt 100000 75000
      broadcast
      encapsulation aal5mux ip
    !
    access-list 102 permit ip host 10.0.0.1 host 11.0.0.1

下面在配置的一些一些评论:

  • 类映射分类并且分配重要性到流量。分类参数和类映射在相同地点定义。在这种情况下,一类应用对在Fast-Ethernet 3/0 (从数据流生成器的流量的所有流入的数据流)。另一类与环回(定义在7200和路由器A)之间的流量涉及。

  • 在定义分类参数以后,您能使用策略映射运用流量参数到这些分级流。在这种情况下,从数据流生成器的流“已分配”带宽40 Mbps和一队列深度40数据包。分配环回之间的流量带宽10 Mbps。

  • 队列深度是可以为特定类存储数据包的数量,在丢包发生前。默认值是(也是最大队列深度)的64。

  • 在流量参数为每类后定义,使用以下命令, CBWFQ在VC基础应用:服务策略[输入|输出] policy-map-name

  • 不匹配的流量其中一张定义的类别地图将分配在策略映射定义的默认组地图(组默认设置)。所有未分类的数据流将应用参数定义在此默认组下。在这种情况下,正常加权公平排队配置。

  • 对于此配置示例, CBWFQ在VC应用,但是在PVC捆绑可以使用。另外, CBWFQ可以关联与加权随机早期丢弃(WRED)作为丢弃机制(当队列极限被到达)时。

重要信息:

前面执行在此部分的配置任务,您必须首先创建将使用区分在VC的流量的类,然后定义了策略映射包括他们。您能配置许多类的等级策略和在路由器定义--至最多64。然而,总量已分配VC带宽(在策略映射包括的所有类)不能超出VC的可用的带宽的75百分比。

由于CBWFQ提供一最低带宽保证,除UBR和UBR+之外,您能只应用CBWFQ到与业务类别的VC。

您不能应用每个vc WFQ和CBWFQ到UBR和UBR+ VC,因为这两个服务类是不保证最小带宽的尽力而为类。当CBWFQ为VC时启用,作为服务策略的部分配置的所有类在公平排队系统安装。

如果运用服务策略对ATM VC,并且策略包括不是并行高速转发-的功能已启用,数据包将被踢到下条更低速的交换路径。执行show pxf acc summ命令并且寻找平底船的一个增加的值由于“输出功能”。

router#show pxf acc sum      
            Pkts             Dropped   RP Processed             Ignored 
           Total                 242      328395045                   0 
10 second averages: PXF complex busy:       28%  PXF read pipeline full:   0% 
PXF Statistic: 
     Packets RP -> PXF: 
         switch ip:                       0 
         switch raw:              556612940 
         qos fastsend:                    0 
         qos enqueue:                     0 
     Total:                       556612940 
Packets PXF -> RP: 
         qos pkts:                        0 
         fast pkts:               228217649 
         drops: total                   242 
           "    no route               :         242 
         punts: total             328395045 
           "    not IP                 :         597 
           "    IP options             :         676 
           "    CEF no adjacency       :      186770 
           "    CEF receive            :      265306 
           "    output feature         :   327916956 

7200 路由器上的高级 CBWFQ 配置

在运行Cisco IOS版本12.1(5)E, 12.1(5)T和以后的Cisco 7200路由器上,我们能分组映射类别形成更加复杂的类映射。另外,我们能关联逻辑操作到类映射参数(确定流量是否匹配类)。

请查看以下类映射澄清此概念:

高级CBWFQ配置
class-map match-all ixia
  description traffic from Ixia 
  match input-interface FastEthernet1/0 
class-map match-all ftp1 
  description ftp traffic initiated by the traffic generator 
  match class-map ixia 
  match class-map ftp2 
class-map match-all ftp2 
  match access-group 103 
class-map match-any test 
  match access-group 102    
  match input-interface Ethernet0/0 
! 
access-list 103 permit tcp any any eq ftp    
! 
access-list 102 permit ip host 10.1.1.1 any

在全部匹配和match-any之间的区别如下:

  • 全部匹配:如果所有相关的条件验证,流关联与类映射。

  • match-any含义:流关联与类映射,如果相关的情况ANY验证(不一定所有条件)。

我们能看到此处类映射能包括测验其他配置的等级地图。在这种情况下,如果匹配所有条件定义在类映射鸢尾属和类映射ftp2下,流关联与ftp1。

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show policy-map interface atm x/y[.z] —此命令允许您发现统计信息每个队列,例如丢包。为监控服务策略的结果是有用的创建与Cisco的模块化服务质量(QoS)命令行界面(CLI) (MQC)。关于如何解释此命令输出的更详细信息,在show policy-map interface输出中参考了解信息包计数器

            7200#show policy-map interface atm 2/0.130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0

    注意: 请参阅关于丢包的两种类型的以下说明:

    • 丢弃:从此的总丢包队列。

    • 尾部丢弃:从此的丢包排队,只有当另一个队列安排有的一流入数据包“降低” WFQ序号时,并且WFQ系统到达最大队列极限信息包的数量。

  • show policy-map interface atm x/y[.z] VC [vcd|vpi/vci] —此命令给特定VC的更多粒度。

            7200#show policy-map interface atm 2/0.130 vc 1/130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0
    

您能也使用其他命令类似show class-mapshow policy-map class获得关于映射类别的详细信息。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 10395