异步传输模式 (ATM) : IP over ATM

关于 ATM 接口桥接的常见问题

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

本文回答桥接常见问题在ATM路由器接口。

Q. 千兆交换路由器(GSR)是否支持桥接?

A. 不能。GSR运行Cisco IOS 软件版本12.0S和11.2GS,设计为互联网服务提供商社区提供稳健IP路由和增强的IP RTP优先策略服务。他们为全桥接协议不提供支持例如透明桥接或源路由桥接,亦不他们支持集成路由和桥接(IRB)。然而,您能使用桥接形式永久虚电路(BPVCs)允许ATM线卡连接到Catalyst交换机或到另一远程设备该支持桥接格式请求注释RFC 1483leavingcisco.com 仅PDU。

Q. Catalyst 6000是否FlexWan支持桥接格式RFC 1483协议数据单元(PDU) ?

A. 可以。此功能性能用您的Cisco IOS软件版本变化,确定是否软件或硬件转发路径里支持这样PVC。

Cisco IOS 12.1(13)E介绍硬件支持在Cisco 7600系列的RFC 1483桥接PDU与PA-A3 ATM端口适配器和FlexWan。思科推荐升级到此版本保证最大转发性能。在上一个版本中, RFC 1483桥接PDU极大降低Catalyst 6000的转发性能,当曾经“IRB”时和没有推荐。

如果不能升级到Cisco IOS 12.1(13)E,备选解决方案将使用OC-12 ATM模块(WS-X6101) Catalyst 6000系列严格支持第2层应用程序例如桥接格式PDU或LAN仿真(LANE)。如果不能使用OC-12接口,并且您的应用程序是数字用户线路DSL聚合,请使用运行路由的网桥封装(RBE)的一个Cisco 7200或7400系列路由器。

Cisco IOS 12.1(5a)E1介绍RFC 1483桥接PDU的支持在与PA-A3的FlexWan。在此版本中, cwan atm bridge hidden命令要求。我们推荐运行Cisco IOS 12.1(11a)E1或以上版本避免CSCdw22284和CSCdw44684。当曾经Cisco IOS 12.1(13)E或更新时, cwan atm bridge命令不是需要的。

开始与Cisco IOS 12.1(13)E或更新的软件的Cisco IOS (本地IOS)和混合模式(MSFC)支持RFC 1483桥接PDU。下表说明RFC 1483桥接PDU的一配置示例在FlexWan和PA-A3。保证您映射正确VLAN对正确PVC。此配置在FlexWan的分布式路径被执行。

RFC 1483桥接PDU 12.1(13)E1或以上的配置示例
vlan 30 
! 
interface FastEthernet7/1 
 no ip address 
 duplex full 
 speed 100 
 switchport 
 switchport access vlan 30 
! 
interface ATM9/1/0 
 no ip address  
 mtu 4096
 atm bridge-enable 
  bandwidth 2000 
  pvc 0/39  
  bridge-vlan 30 
 encapsulation aal5snap 
! 
router rip 
 network 10.0.0.0 
 network 30.0.0.0 
! 

ATM OC-12光学服务模型(OSM) Cisco 7600系列的也支持RFC 1483桥接。欲知更多信息和配置示例,请参阅配置OC-12 ATM光服务模块

Q. 为什么不在两子接口之间的Catalyst 5000/6000 ATM模块网桥在同样虚拟LAN (VLAN) ?

A. ATM模块的配置指南注释以下限制:如果两PVC在同样VLAN和ATM模块配置,从一个PVC接收的数据包没有转发对另一个PVC。原因和模块的体系结构有关。WS-X515x系列和WS-X5166使用防止模块发送数据包收到的一块单向的背板接口芯片。WS-X516x系列使用两块单向的背板接口芯片。然而,它不能发送默认情况下收到由于自动响应抑制,启用避免环路的数据包,因为在Catalyst 5000的生成树逻辑工作每端口,每VLAN而不是在个人PVC。

解决方法如下:

  • 请使用一全网状而不是一星型网ATM PVC设计。

  • 以标准的Cisco IOS Bridging使用配置的一个路由器。您在同一个网桥组中必须配置两不同的子接口允许广播和其他流量通过在两远程主机之间。

  • 请使用一个路由交换模块(RSM),路由交换机特性卡或者多层交换机特性卡(MSFC)。终止在路由器的PVC然后路由或者桥接在他们之间。

Q. Cisco路由器是否支持RFC 1438 AAl5MUX Bridged封装格式?

A. 不虚拟电路-基于多路复用要求被封装的或被传送的协议在ATM接口手工配置。思科支持与aal5mux封装的以下协议:

7500-1(config-subif)#atm pvc 1 0 200 aal5mux ? 
     apollo     Apollo Domain 
     appletalk  AppleTalk 
     decnet     DECnet 
     ip         IP 
     ipx        Novell IPX 
     vines      Banyan VINES 
     xns        Xerox Network Services

使用基于VC的多路技术,在ATM网络间被传送的网络协议由连接两个ATM站点的VC隐含地识别。即必须转入每份协议分开的VC。这不是可用的在有ATM OSM的Cisco 7600。

Q. 路由器是否通过ATM接口将传递802.1Q报头?

A. 不能。在以下拓扑里,当桥接在ATM链路时,路由器不会保留802.1Q标签。802.1Q标签删除在以太网接口。

/image/gif/paws/10405/atm_bridging_faq.gif

然而,有一个备选方式构件端到端VLAN。配置有同一套的路由器网桥组和802.1Q子接口。换句话说,两个路由器末端有网桥群组和802.1Q子接口之间的一对一映射。这不是可适用的对Cisco 7600。

端到端VLAN的路由器配置
interface FastEthernet4/0 
no ip address 
! 
interface FastEthernet4/0.100 
 encapsulation dot1Q 100 
 bridge-group 1 
! 
interface atm 5/0.100 
 bridge-group 1

另外, Cisco IOS现在支持第2层虚拟专用网络透明地运载在ATM云间的Layer2体系结构。通过多协议标签交换的任意传输是传输的Layer2数据包Cisco解决方案在互联网协议/多协议标签交换(IP/MPLS)骨干网。原子通过启用Layer2帧传输扩大IP网络的可用性在MPLS骨干网的。原子要求为在MPLS基础设施的支持的传统服务和为支持数新建的连接选项,包括第2层VPN和Layer2虚拟租用的线路。关于原子的更多信息,请参阅概述-思科在MPLS的任何传输

Cisco IOS软件版本12.0(10)ST/12.0(21)ST和12.0(22)S引入ATM原子的(在MPLS的AAL5支持)在Cisco 12000系列ATM线卡。欲知更多信息,请参阅在MPLS的MPLS AToM-ATM AAL5。Cisco IOS软件版本12.0(22)sy介绍在MPLS的ATM信元中继在7200系列和7500系列。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 10405