异步传输模式 (ATM) : 电路仿真服务 (CES)

使用自适应时钟和软PVC 的T1 非结构化 CES

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文提供配置示例T1非结构化电路仿真服务(CES)使用可适应的计时。松散组织结构服务意味着PVC使用了整个T1/E1带宽。ATM交换机不调查T1/E1,然而再生产位数据流有时钟频率的从接收端口到目标端口。能适应的计时意味着CES模块通过计算平均的接收数据速率推断适当时间为数据传输。此的主要优点是不要求网络时钟同步。对于在CES服务的更多详细说明请读电路仿真服务介绍

假定

在本文的配置示例根据以下假设:

  • 此示例使用可适应的计时模式。因为我们使用可适应的计时,您不需要网络时钟语句。然而,您可以选择配置缓冲长度防止缓冲区溢出和下溢,并且,同时,控制延迟(更加了不起的缓冲区大小含义更加巨大的延迟)。缓冲长度与最大信元延时变化(CDV)是按比例,您能用ces circuit circuit-id [cas] [cdv max-req]命令配置。默认值是2000毫秒。测量值在输出显示show ces circuit命令中

  • 在两个PBX上的成帧都是扩展超帧(ESF)。这是在LS1010的默认值,因此不需要明确地配置它。然而,我们在本例中将配置它为演示。

  • 在两个PBX的line编码是二进制的8个零替补(B8ZS)。这是在LS1010的默认值,因此不需要明确地配置它。然而,我们在本例中将配置它为演示。

  • LS1010是软PVC的激活侧;8540-MSR是被动端。

  • 在CES PAM,PBX和ATM交换机之间的距离小于110英尺。此长度是默认线路缆线长度(lbo),因此不需要明确地配置它。然而,我们在本例中将配置它为演示。

  • LS1010配备有功能卡每流排队(FC-PFQ),在上使用一个相位锁定环路(PLL)能够锁定和跟踪选择时钟源的。此高质量,锁定时钟然后对网络时钟接口提供界面规定期限。8540 MSR装备网络时钟模块(NetClkMod),提供Stratum 3时钟资源的优势。

  • 当电路被定义时,ATM Pseudo接口(ATM-Px/y/z)被创建。欲了解更详细的信息参考配置电路仿真服务的本文。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

http://www.cisco.com/c/dam/en/us/support/docs/asynchronous-transfer-mode-atm/circuit-emulation-services-ces/10428-cessample4-1.gif

配置

本文档使用如下所示的配置。

8540-MSR
8540-MSR#show running-config

Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname 8540-MSR
!
boot system flash bootflash:cat8540m-wp-mz.120-1a.W5.7.bin
logging buffered 4096 debugging
!
redundancy
 main-cpu
  no sync config startup
  sync config running
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
network-clock-select 1 system
ip subnet-zero
atm address 47.0091.8100.0000.0090.2144.8401.0090.2144.8401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
interface ATM3/0/0
 no ip address
 no ip directed-broadcast
!
interface ATM3/0/1
 no ip address no
 ip directed-broadcast
!

interface CBR3/1/0
 no ip address no 
 ip directed-broadcast
 ces aal1 clock adaptive
 ces circuit 0 circuit-name example
 ces dsx1 linecode b8zs
 ces dsx1 framing esf
 ces dsx1 lbo 0_110
!
interface ATM0
 no ip address
 no ip directed-broadcast
 atm maxvp-number 0
!
interface Ethernet0
 no ip directed-broadcast
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

请使用在软PVC的被动端的show ces address获得您需要配置软PVC的地址和VPI/VCI对(在本例中的LS1010的)激活侧。请参阅下列的示例输出:

8540-MSR#show ces address
 
CES-IWF ATM Address(es):47.0091.8100.0000.0090.2144.8401.4000.0c81.9030.10 CBR3/1/0:0 
vpi 0 vci 16
LS1010-A
ls1010#show running-config

Building configuration...

Current configuration:
!
version 11.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname ls1010
!
atm address 47.0091.8100.0000.0090.92b8.6401.0090.92b8.6401.00
atm router pnni
�no aesa embedded-number left-justified
�node 1 level 56 lowest
� redistribute atm-static
!
no ip address
!
interface CBR12/1/0
�no ip address
�ces aal1 clock adaptive
�ces circuit 0 circuit-name example
�ces dsx1 linecode b8zs
�ces dsx1 framing esf
�ces dsx1 lbo 0_110
�ces pvc 0 dest-address 47.0091.8100.0000.0090.2144.8401.4000.0c81.9030.10 
 vpi 0 vci 16
!
interface CBR12/1/1
�no ip address
!
interface CBR12/1/2
�no ip address
!
interface CBR12/1/3
�no ip address
!
interface ATM13/0/0
�no ip address
�atm maxvp-number 0
!
interface Ethernet13/0/0
ip classless
!
line con 0
line aux 0
line vty 0 4
login
!
end

请使用show ces interface命令验证Ces circuit是UP在两边。请参阅下列的示例输出:

ls1010#show ces interface cbr 12/1/0
 
Interface: CBR12/1/0 Port-type:T1-DCU
IF Status: UP Admin Status: UP
Channels in use on this port: 1-24
LineType: ESF LineCoding: B8ZS LoopConfig: NoLoop�
SignalMode: NoSignalling XmtClockSrc: network-derived
DataFormat: UnStructured AAL1 Clocking Mode: Adaptive LineLength: 0_110
LineState: NoAlarm<
Errors in the Current Interval:
PCVs 514 LCVs 2 ESs 0 SESs 1 SEFSs 0
UASs 0 CSSs 0 LESs 0 BESs 0 DMs 0
Errors in the last 24Hrs:
PCVs 2057 LCVs 10 ESs 0 SESs 4 SEFSs 0
UASs 19 CSSs 0 LESs 0 BESs 0 DMs 0
Input Counters: 1054405 cells, 49557035 bytes
Output Counters: 1054405 cells, 49557035 bytes

请使用show atm vc命令验证软PVC设立了在两ATM交换机之间。请参阅下列的示例输出:

8540-MSR#show atm vc interface ATM-P3/1/3
 
Interface�� VPI�� VCI�� Type�� X-Interface�� X-VPI�� X-VCI�� Encap Status
 
ATM-P3/1/3��� 0��� 16 SoftVC����� ATM3/0/0������ 0������ 39����������� UP
 
 
LS1010#show atm vc interface ATM-P12/1/3
 
Interface�� VPI�� VCI�� Type�� X-Interface�� X-VPI�� X-VCI�� Encap Status
 
ATM-P12/1/3�� 0��� 16 SoftVC��� ATM12/0/0������� 0����� 39������������ UP

请使用show ces circuit cbr x/y/z 0命令验证没有时钟故障和看到下溢或溢出是否增加。保证使用在8540 MSR端的此指令。请参阅下列的示例输出:

ls1010#show ces circuit cbr 12/1/0 0
 
Circuit: Name sil, Circuit-state ADMIN_UP / Interface CBR12/1/0,
Circuit_id 0, Port-Type T1, Port-State UP�
Port Clocking network-derived, aal1 Clocking Method CESIWF_AAL1_CLOCK_ADAPT
Channel in use on this port: 1-24
Channels used by this circuit: 1-24
Cell-Rate: 4107, Bit-Rate 1544000
cas OFF, cell_header 0x100 (vci = 16)
Configured CDV 2000 usecs, Measured CDV 373 usecs
De-jitter: UnderFlow 1, OverFlow 0
ErrTolerance 8, idleCircuitdetect OFF, onHookIdleCode 0x0
state: VcActive, maxQueueDepth 823, startDequeueDepth 435
Partial Fill: 47, Structured Data Transfer 0
Active SoftVC
Src: atm addr 47.0091.8100.0000.0090.92b8.6401.4000.0c86.1030.10 vpi 0, vci 16
Dst: atm addr 47.0091.8100.0000.0090.2144.8401.4000.0c81.9030.10

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 10428