异步传输模式 (ATM) : LAN 仿真 (LANE)

使用 ATM 路由模块进行 LAN 仿真

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录

相关的思科支持社区讨论

简介

本文为使用ATM路由器模块的LAN仿真(ARM)提供一配置示例。

ARM提供Catalyst 8540多业务交换机路由器(MSR)和8510 MSR在Layer2和第3层网络拓扑之间的高速网际工程。当ARM安装时,您不再需要选择第3层或ATM技术,这一点频繁地是案件伴随着企业和大城市区域应用程序。反而,您能有第3层和ATM技术在同一个多业务ATM交换机路由器机箱。

Catalyst 8510或8540 MSR配备有ARM功能提供桥接和路由从以太网到ATM和从ATM到ATM。

ARM用于Catalyst 8510的第3层交换接口模块之间的提供互通性或8540个CSR (园区网交换路由器)和用于Catalyst 8510或8540 MSR机箱和接口模块的ATM端口适配器。因此您能结合第3层和ATM端口适配器和接口模块在Catalyst 8510或8540 MSR机箱配备有ARM。得知更多的Cisco Catalyst 8540 CSR和Cisco Catalyst 8540 MSR之间的参考的主要区别在Catalyst 8500 MSR和Catalyst 8500 CSR之间的区别。

您能安装从0编号的slot的两阿姆斯到3和从9到12在Catalyst 8510或8540 MSR机箱。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

LAN仿真使用ARM介绍在Catalyst 8510 MSR在思科IOS�软件Release12.0(10)W5(18b)和在Catalyst 8540 MSR在Cisco IOS软件版本12.0(4a)W5(11a)。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

支持的功能

ARM根据思科快速转发(CEF)并且支持这些功能:

  • 开放最短路径优先(OSPF)、路由信息协议(RIP)、RIP2、增强型内部网关路由协议(EIGRP)和高级IGRP。

  • 互联网控制消息协议(ICMP)目的地不可得到重定向消息。

  • 至两同等路径的负载均衡。

  • 集成路由和桥接(IRB)。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此网络设置。有在slot 9.的一个ARM卡。

/image/gif/paws/10403/atm_arm_rt.gif

配置

本文档使用以下配置:

注意: 这些配置只显示命令与LANE相关。

Catalyst 5500 (交换机)
set vlan 3 4/5
set vlan 2 4/4

Catalyst 5500 (LANE卡)
hostname ATM
!
!
!
lane database ARM
 name elan2 server-atm-address 47.009181000000009021449C01.00E01E2EE861.02
 name elan3 server-atm-address 47.009181000000009021449C01.00E01E2EE861.03
!
interface Ethernet0
!
interface ATM0
 atm preferred phy B
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database ARM
!
interface ATM0.2 multipoint
 lane server-bus ethernet elan2
 lane client ethernet 2 elan2
!
interface ATM0.3 multipoint
 lane server-bus ethernet elan3
 lane client ethernet 3 elan3

Cisco 7000
hostname 7000a
!
interface Loopback0
 ip address 140.40.40.1 255.255.255.0
!
interface Ethernet0/3
 ip address 45.45.45.2 255.255.255.0
!
router eigrp 1
 network 45.0.0.0
 network 140.40.0.0

Cisco 7206
hostname 7206B
!
interface Loopback0
 ip address 150.50.50.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet6/0
 ip address 40.40.40.2 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 40.0.0.0
 network 150.50.0.0

Catalyst 8540 MSR
hostname C8540-MSR
!
interface Loopback0
 ip address 160.60.60.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM9/0/0
 no ip address
 no ip directed-broadcast
!
interface ATM9/0/0.2 multipoint
 ip address 40.40.40.1 255.255.255.0
 no ip directed-broadcast
 lane client ethernet elan2
!
interface ATM9/0/0.3 multipoint
 ip address 45.45.45.1 255.255.255.0
 no ip directed-broadcast
 lane client ethernet elan3
!
router eigrp 1
 network 40.0.0.0
 network 45.0.0.0
 network 160.60.0.0
 no auto-summary

显示命令

此部分提供您能使用的,用以确认您的配置正常工作的信息。

发出这些命令测试您的网络是否适当地操作:

  • ping

  • show ip route

  • show ip cef

  • show lane le-arp接口ATM卡/subcard/端口[.subinterface-number]

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

下输出示例:是输入这些on命令结果在网络图中显示的设备。此输出表示,网络在适当地运行。ping从Catalyst 8540 MSR的ATM9/0/0.3接口去思科7000路由器的Ethernet0/3接口。

C8540-MSR# ping 45.45.45.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 45.45.45.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

您能通过ping Cisco 7206的Ethernet6/0接口也测试Catalyst 8540 MSR和Cisco 7200路由器之间的连接从Catalyst 8540的。此输出示例:显示ping是成功的。

C8540-MSR# ping 40.40.40.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.40.40.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

另一个方式测试连接是通过发出show ip route命令。Catalyst 8540 MSR有一个路由对网络在Cisco 7200路由器背后由地址150.50.0.0 —了解由IGRP —并且有路由对网络在思科7000路由器背后由地址通过IGRP —了解的140.40.0.0。

C8540-MSR# show ip route

D  140.40.0.0/16 [90/130816] via 45.45.45.2, 00:34:58, ATM9/0/0.3
   172.16.0.0/24 is subnetted, 1 subnets
   160.60.0.0/24 is subnetted, 1 subnets
C  160.60.60.0 is directly connected, Loopback0
C  40.40.40.0 is directly connected, ATM9/0/0.2
D  150.50.0.0/16 [90/130816] via 40.40.40.2, 00:29:50, ATM9/0/0.2
   45.0.0.0/24 is subnetted, 1 subnets
C  45.45.45.0 is directly connected, ATM9/0/0.3

C8540-MSR# show ip cef

40.40.40.0/24       attached               ATM9/0/0.2
40.40.40.0/32       receive
40.40.40.1/32       receive
40.40.40.2/32       40.40.40.2             ATM9/0/0.2
40.40.40.255/32     receive
45.45.45.0/24       attached               ATM9/0/0.3
45.45.45.0/32       receive
45.45.45.1/32       receive
45.45.45.2/32       45.45.45.2             ATM9/0/0.3
45.45.45.255/32     receive
140.40.0.0/16       45.45.45.2             ATM9/0/0.3
150.50.0.0/16       40.40.40.2             ATM9/0/0.2
160.60.60.0/24      attached               Loopback0
160.60.60.0/32      receive
160.60.60.1/32      receive
160.60.60.255/32    receive

为在Catalyst 8540的子接口要看到LANE ARP表,请发出show lane le-arp命令

C8540-MSR# show lane le-arp interface atm 9/0/0.2

Hardware Addr   ATM Address                                  VCD  Interface
0030.7b1e.90a8  47.009181000000009021449C01.00E01E2EE860.02  878  ATM9/0/0.2

C8540-MSR# show lane le-arp interface atm 9/0/0.3

Hardware Addr   ATM Address                                  VCD  Interface
0000.0c0d.fdcb  47.009181000000009021449C01.00E01E2EE860.03  876  ATM9/0/0.3

故障排除

目前没有针对此配置的故障排除信息。

相关信息


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 10403