广域网 : 点对点协议 (PPP)

多个串行接口的背对背路由器上的多链路 PPP

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

在一些环境,捆绑串行链路作为单个聚合带宽可能是必要的。本文描述如何配置Cisco 2503接入服务器捆绑与两不同的说法的两serial interfaces :

这些配置可以用于路由器连接由有信道服务单元或数据服务单元的租用的线路或路由器(CSU/DSU)或ISDN终端适配器(TA)配置拨号。(Cisco路由器未配置拨号电话号码。)您能添加其它功能到此配置配合您的需要。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco 2503 路由器

  • Cisco IOSï ¿  ½软件版本12.2(7b)

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

相关产品

此配置可以与有两广域网serial interfaces的所有两路由器中的每一一起使用。您能使用WIC-1T、WIC-2T或者已修复广域网serial interfaces。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/10382/pppmultilink.gif

配置

此配置用在思科2500系列路由器的Cisco IOS软件版本12.2(7b)测试。相同的配置概念将适用于一个相似的路由器结构或其他Cisco IOS软件版本。

示例 1:Interface dialer

示例 2:虚拟模板

示例 1:Interface dialer

Router1 - Cisco 2503
Current configuration:
version 12.2
 
hostname Router1
!
username Router2 password 0 abc

!--- This local username and password pair is used for PPP Challenge
!--- Handshake Authentication Protocol (CHAP) authentication.

ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

!--- The loopback address is used by interface dialer 1.

!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1

 !--- Interface Serial0 is a member of rotary-group 1.
 !--- The rotary group configuration is in interface dialer 1. 

 no fair-queue
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 pulse-time 1
!
interface Dialer1

!--- This is the configuration for rotary-group 1.
!--- The dialer interface number must exactly match the rotary group number.

 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 192.168.20.1 name Router2 broadcast
 dialer load-threshold 2 either
 dialer-group 1

 !--- Apply interesting traffic definition from dialer-list 1.

 no fair-queue
 ppp authentication chap
 ppp direction callout  

 !--- This is a hidden command; see the Notes section for more information.

 ppp multilink

 !--- Allow multilink for the dialer profile.
 !--- Without this command, multilink is NOT negotiated.

!
ip classless
ip route 192.168.20.1 255.255.255.255 Dialer1
dialer-list 1 protocol ip permit

!--- The dialer-list defines the interesting traffic.

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2 - Cisco 2503
Current configuration:
version 12.2
hostname Router2
!
!
username Router1 password 0 abc
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 999
 dialer map ip 192.168.10.2 name Router1 broadcast
 dialer load-threshold 2 either
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 192.168.10.2 255.255.255.255 Dialer1
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
end

示例1笔记

ppp direction callout命令是隐藏命令使用,当路由器是混淆的至于时谁拨号谁(当已连接背对背或连接由租用的线路和CSU/DSU或者ISDN TA配置拨号)时。可能也使用ppp direction callin命令。请使用这些命令之一。

  • 对于本地路由器,请使用ppp方向拨出

  • 对于远程路由器,请使用ppp方向呼入

如果不使用此命令,路由器一会儿连接然后断开。

上述配置描述两路由器, Router1和Router2,有两serial interfaces将被捆绑作为单个聚合带宽。使用ip unnumbered loopback0,在两路由器上,接口回环配置并且集成与interface dialer。两serial interfaces为没有IP地址配置。物理接口Serial0和Serial1配置与拨号轮询组并且关联与单个逻辑接口拨号程序。

Dialer-list 1定义了关注数据流,反过来触发dialer-group 1命令在interface dialer 1启动链路。在两路由器定义的拨号映射语句映射interface dialer 1对对等`路由器IP地址,并且主机名定义在CHAP认证服务。静态路由定义路由流量对目的地。

ppp authentication chap命令启用PPP协商。dialer load-threshold命令设置该的负载触发带来第二串行线路。PPP多链路拨号轮询组命令配置,以便两serial interfaces可以一起被捆绑作为聚合带宽的一个虚拟访问接口。ppp direction callout命令确定哪侧必须在PPP协商和CHAP认证时做拨出。

验证示例1

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

Router1# show ppp multilink 
Virtual-Access1, bundle name is Router2 
  Bundle up for 00:01:05 
  Dialer interface is Dialer1 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 1/255 load 
  0x0 received sequence, 0x0 sent sequence 
  Member links: 2 (max not set, min not set) 
    Serial0, since 00:01:05, no frags rcvd 
    Serial1, since 00:01:05, no frags rcvd   

 Router2# show ppp multilink  

 Virtual-Access1, bundle name is Router1
  Bundle up for 00:03:25
  Dialer interface is Dialer1
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:03:25, no frags rcvd
    Serial0, since 00:03:25, no frags rcvd

排除故障示例1

本部分提供的信息可用于对配置进行故障排除。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

debug 命令

在Router1, debug ppp authentication命令显示CHAP成功。

May  8 17:52:19: Se1 PPP: Using configured call direction
May  8 17:52:19: Se1 PPP: Treating connection as a callout
May  8 17:52:19: Se0 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se0 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O SUCCESS id 135 len 4
May  8 17:52:19: Se1 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se1 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O SUCCESS id 135 len 4
5d05h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
May  8 17:52:19: Vi1 PPP: Using configured call direction
May  8 17:52:19: Vi1 PPP: Treating connection as a callout
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to up

在Router2, debug ppp authentication命令显示“等待的对等体…."”

5d02h: %LINK-3-UPDOWN: Interface Serial0, changed state to up
5d02h: Se0 PPP: Treating connection as a callin
5d02h: Se0 CHAP: O CHALLENGE id 132 len 28 from "Router2"
5d02h: Se0 CHAP: I CHALLENGE id 133 len 28 from "Router1"
5d02h: Se0 CHAP: Waiting for peer to authenticate first
5d02h: Se0 CHAP: I RESPONSE id 132 len 28 from "Router1"
5d02h: Se0 CHAP: O SUCCESS id 132 len 4
5d02h: Se0 CHAP: Processing saved Challenge, id 133
5d02h: Se0 CHAP: O RESPONSE id 133 len 28 from "Router2"
5d02h: Se0 CHAP: I SUCCESS id 133 len 4
5d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

示例 2:虚拟模板

Router1 - Cisco 2503
Current configuration
!
version 12.2
!
hostname Router1
!
!
username Router2 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
 
multilink virtual-template 1

!--- Applies the virtual interface template to the multilink bundle.

 
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

 !--- The loopback address is used by virtual-template 1.

 
 
interface Virtual-Template1

!--- Interface virtual-template is a logical interface that creates
!--- virtual access interfaces dynamically and applies them to 
!--- physical serial interfaces.

 ip unnumbered Loopback0

!--- Always unnumber the virtual-template to an UP interface.
!--- Do not assign a static IP.

 ppp authentication chap
 ppp multilink 

 !--- Enables multilink PPP on the virtual-template interface.

 
interface Serial0
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
!
ip classless
!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2 - Cisco 2503
Current configuration :
!
version 12.2
!
hostname Router2
!
!
username Router1 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
multilink virtual-template 1
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Virtual-Template1
 ip unnumbered Loopback0
 ppp authentication chap
 ppp multilink
!
interface Serial0
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
!
end

以上配置描述在Router1和Router2配置的虚拟模板。在本例中,两路由器用虚拟模板配置。路由器连接背对背,并且多链路会话不断开。静态路由不是需要的:主机路由在PPP协商以后安装。

请使用Cisco IOS软件版本11.3或以后使用虚拟模板PPP多链路。

virtual template命令动态地创建虚拟访问接口并且应用他们对物理serial interfaces用multilink virtual-template命令。在接口虚拟模板(例如ppp authentication chap)配置的参数为两serial interfaces应用。ppp multilink命令在interface virtual-template捆绑物理serial interfaces形成虚拟访问为了聚集带宽。

验证示例2

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

Router2# show ppp multilink
 
Virtual-Access1, bundle name is Router1

!--- Virtual Access interface used for the bundle

  Bundle up for 00:20:38
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:20:39, no frags rcvd
    Serial0, since 00:20:39, no frags rcvd

!--- Note that there are two links (Se 0 and Se1) in the bundle

这些命令可能也帮助:

  • show ip route connected —看到虚拟访问的Ip route是否安装。

  • show interface virtual-access x —检查特殊虚拟访问接口的状况。在以上示例中,虚拟访问接口编号是1。

排除故障示例2

本部分提供的信息可用于对配置进行故障排除。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

如下所示,在全局配置中配置时间戳:

service timestamps debug datetime msec
service timestamps log datetime msec

请使用这些命令排除故障:

  • debug ppp协商—看到客户端是否通过PPP协商。您能也检查哪些选项(回拨,多链路PPP [MLP],等),并且哪些协议(IP, IPX,等)协商。

  • debug ppp authentication —看到客户端是否通过验证。

  • debug vtemplate —看到使用什么虚拟模板配置。

  • debug vprofile —看到什么配置选项应用对虚拟访问接口。


相关信息


Document ID: 10382