拨号和接入 : 按需拨号路由 (DDR)

拨号技术:概述和解释

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本章介绍并且说明用于拨号网络的某些技术。您将查找配置某些的提示和解释显示命令,为验证网络的正确操作是有用的。故障排除程序是超出本文的范围之外,并且可以在题为的本文找到排除故障拨号

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

调制解调器操作

此部分说明与设置、验证和使用特别地涉及的问题调制解调器用Cisco路由器。

使用modem autoconfigure命令

如果使用Cisco互联网操作系统(Cisco IOS)版本11.1或以上,您能配置您的Cisco路由器通信与和自动地配置您的调制解调器。

使用以下步骤配置Cisco路由器自动地尝试发现什么样的调制解调器连接到线路,然后配置调制解调器:

  1. 要发现调制解调器类型附加对您的路由器,请使用modem autoconfigure discovery line configuration命令

  2. 当调制解调器顺利地发现时,使用modem autoconfigure type modem-name line configuration命令,请自动地配置调制解调器。

如果要显示路由器有条目调制解调器的列表,请使用show modemcap调制解调器名称。如果要更改从show modemcap命令返回的调制解调器值,请使用modemcap edit modem-name attribute value line configuration命令

关于使用这些命令的全部信息,参考Cisco IOS文档Dial Solutions配置指南和拨号解决方案命令参考

注意: 请勿进入在使用自动配置的modemcap项的&w。这造成NVRAM重写,在modem autoconfigure执行时候,并且毁坏调制解调器。

建立到调制解调器的反向 Telnet 会话

诊断目的,或者最初配置调制解调器,如果运行Cisco IOS版本11.0或以下,您必须建立一反向远程登录会话配置调制解调器用Cisco设备通信。只要您锁定数据终端设备(DTE)侧调制解调器速度,调制解调器用接入服务器或路由器永远将沟通以期望的速度。参考的表16-5关于锁定调制解调器速度的信息。肯定Cisco设备的速度在发出对调制解调器的命令前配置通过一反向远程登录会话。再次,参考表16-5关于配置接入服务器或路由器的速度的信息。

要配置一反向远程登录会话的调制解调器,请使用线路配置命令transport input telnet。组成循环组(在这种情况下,在端口1),输入放置这些命令的line configuration命令轮循1.在line configuration原因IOS下分配流入连接的IP监听程序在端口范围开始用以下基本编号的:

2000年 Telnet协议
3000 与轮循的Telnet协议
4000 原始TCP协议
5000 与轮循的原始TCP协议
6000 Telnet协议,二进制模式
7000 Telnet协议,与轮循的二进制模式
9000 XRemote协议
10000 与轮循的XRemote协议

要启动一反向远程登录会话到您的调制解调器,请执行以下步骤:

  1. 从您的终端,请使用IP地址是所有激活的IP地址,在Cisco设备的连接的接口的telnet ip-address 20yy命令,并且yy是调制解调器连接的线路号。

    例如,以下命令将联络您到一思科2501路由器的辅助端口有IP地址192.169.53.52的:telnet 192.169.53.52 2001。通常,如果能ping有问题的的IP地址此种类Telnet命令可以从任何地方网络发出。

    注意: 在多数Cisco路由器上,端口01是辅助端口。在Cisco接入服务器上,辅助端口是为时TTY +1。为例, 2511的辅助端口是端口17 (16个TTY端口+ 1)。总是请使用show line exec命令看到辅助端口端口号-特别在2600和3600系列,使用非连续端口编号适应变化的异步模块大小。

  2. 如果连接拒绝,可能表明没有或者监听程序在特定地址和端口,或者某人已经连接到该端口。验证连接地址和端口号。并且,请确保modem inout命令或modem dtr-active,以及传输输入全部,出现在被到达的线路的line configuration下。

    如果曾经轮循功能,请确保rotary n命令在n是循环组的编号的line configuration里也出现。要检查某人是否已经连接,请远程登录到路由器并且请使用show line命令n.寻找星号指示线路是在使用中。确保CTS高,并且DSR不是。请使用clear line n命令断开连接端口号的n.当前会话。如果连接仍然拒绝,调制解调器也许一直主张载波检测(CD)。从线路断开调制解调器,建立一反向远程登录会话,然后连接调制解调器。

  3. 在顺利地进行后Telnet连接,输入AT并且是肯定的调制解调器回复以OK。

  4. 如果调制解调器不是响应能力的,参考下表。

表调制解调器对路由器连接问题症状的16-1个下面的概述可能的原因和描述解决方案对那些问题。

表16-1 :调制解调器和路由器之间的没有连接

可能的原因 建议的行动
调制解调器控制在接入服务器或路由器没有启用
  1. 在访问服务器或路由器时使用show line执行命令。辅助端口的输出应该显示InoutRIisCD在调制解调器栏。这表明调制解调器控制在接入服务器或路由器的线路上启用。对于show line输出的说明,参考“使用调试指令”在章节15。
  2. 使用modem inout line configuration命令,配置调制解调器控制的线路。调制解调器控制在接入服务器当前启用。
示例:以下示例说明如何配置两次进入和出去的呼叫的一条线路:
line 5
modem inout

注意: 当调制解调器的连接有问题的时,肯定使用modem inout命令,而不是modem dialin命令。后一个命令允许线路仅响应呼入呼叫。呼出呼叫将拒绝,并且建立一远程登录会话以调制解调器为了配置它将是不可能的。如果要使用modem dialin命令,如此请执行,在您肯定之后调制解调器正确地作用。

调制解调器能是不正确的配置的或有挂起会话。 输入AT&FE1Q0返回它到出厂默认设置,并且确保调制解调器设置响应字符并且返回输出。调制解调器可能有挂起会话。请使用“^U”清除线路和“^Q”打开流量控制(XON)。验证奇偶校验设置。
不正确接线
  1. 检查在调制解调器和接入服务器或者路由器之间的布线。确认调制解调器通过一个卷起的RJ-45电缆和MMOD DB-25适配器连接到接入服务器上的辅助端口。此电缆配置由Cisco为RJ-45端口建议使用并且支持。(这些连接器典型地被标记“Modem.")
  2. 使用show line执行命令验证布线是正确的。请参阅show line命令输出的说明在“使用调试指令”题为的部分的在章节15。
硬件故障
  1. 验证您使用正确的接线,并且所有连接是好。
  2. 检查所有硬件损伤,包括布线(断线),适配器(松散管脚),接入服务器端口和调制解调器。
  3. 请参阅章节3, “排除故障硬件和启动问题”,关于硬件故障排除的更多信息。

使用循环组

对于一些应用程序,在一个给的路由器的调制解调器需要由用户的一组共享。Cisco Dialout Utility是此种应用程序示例。基本上,用户连接到连接他们到一个可用的调制解调器的一个端口。添加对循环组的一条异步线路,输入n是循环组编号在异步线路的配置里的轮循n。参考下面示例。

line 1 16
 modem InOut
 transport input all
 rotary 1
 speed 115200
 flowcontrol hardware

上述line configuration将允许用户连接对循环组通过输入telnet正常telnet的192.169.53.52 3001。选择包括原始TCP的端口5001, 7001 Cisco Dialout Utility用途)的二进制telnet的(和10001 Xremote连接的。

注意: 要验证Cisco Dialout Utility的配置,请双击Dialout程序图标在屏幕的右下并且按更多信息按钮。其次,请按配置Ports>按钮。确保端口在7000范围,如果曾经循环组和6000范围,如果Dialout程序瞄准单个调制解调器。您应该也启用注册PC的调制解调器。这由选择以下顺序完成:Start->Control Panel-> modems-> (请选择您的Cisco拨出调制解调器) - >Properties->Connection->Advanced… - >Record日志文件

解释Show line输出

当排除故障调制解调器到接入服务器或接入路由器连接时,从show line line-number exec命令的输出是有用的。下面从show line命令的输出。

as5200-1#show line 1
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
   1 TTY 115200/115200-    -      -    -    -      0       0     0/0       -

Line 1, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
Status: No Exit Banner
Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
Modem state: Hanging up
  modem(slot/port)=1/0, state=IDLE
  dsx1(slot/unit/channel)=NONE, status=VDEV_STATUS_UNLOCKED
Group codes:    0
Modem hardware state: CTS noDSR  noDTR RTS
Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                ^^x    none   -     -       none
Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
               00:10:00        never                        none     not set
                            Idle Session Disconnect Warning
                              never
                            Login-sequence User Response
                             00:00:30
                            Autoselect Initial Wait
                              not set
Modem type is unknown.
Session limit is not set.
Time since activation: never
Editing is enabled.
History is enabled, history size is 10.
DNS resolution in show commands is enabled
Full user help is disabled
Allowed transports are lat pad telnet rlogin udptn v120 lapb-ta.  
Preferred is l
at pad telnet rlogin udptn v120 lapb-ta.
No output characters are padded
No special data dispatching characters
as5200-1#

当连接问题发生时,重要输出在调制解调器状态和调制解调器硬件状态域出现。

注意: 调制解调器硬件状态域在为每个平台输出的show line没出现。在某些情况下,信号状态的征兆在调制解调器状态字段将显示。

表16-2显示从输出的典型的调制解调器状态和调制解调器硬件状态字符串show line命令。它也解释每状态的含义。

表16-2 :调制解调器和调制解调器硬件状态在Show line输出中

调制解调器状态 调制解调器硬件状态 含义
空闲 CTS noDSR DTR RTS (当没有呼入呼叫)时,这些是连接的适当的调制解调器状态接入服务器之间或路由器和调制解调器。其他种类输出通常指示一问题。
就绪 -- 如果调制解调器状态准备好,而不是空闲,请考虑以下:
  1. 调制解调器控制在接入服务器或路由器没有配置。配置接入服务器或路由器用modem inout line configuration命令
  2. 会话在线路存在。如果需要请使用show users exec命令并且请使用clear line privileged exec命令终止会话。
  3. DSR高。有此的两个可能的来源:
    • 布线问题。如果您的连接器使用DB-25管脚6并且没有管脚8,您必须移动从6的管脚向8或获得适当的连接器。
    • 为DCD配置的调制解调器总是高。应该重新配置调制解调器有DCD高仅一CD(1)。这通常实行同&C1调制解调器命令,但是检查您的调制解调器文档您的调制解调器的确切句法。如果您的软件不支持调制解调器控制,您必须配置调制解调器用no exec line configuration命令连接的接入服务器线路。用clear line privileged exec命令清除线路,用调制解调器起动反向Telnet会话,并且重新配置调制解调器以使DCD仅在CD上为高水平。通过输入断开结束远程登录会话并且重新配置接入服务器线路用exec line configuration命令。
准备 noCTS noDSR DTR RTS(2) noCTS字符串在以下四个原因之一的调制解调器硬件状态域出现:
  1. 调制解调器被关闭。
  2. 调制解调器没有适当地连接到接入服务器。检查从调制解调器的电缆连接到接入服务器。
  3. 不正确接线(卷起的MDCE或者平直的MDTE,但是没有移动的管脚)。推荐的布线配置在此表里给前。
  4. 调制解调器没有为硬件流控制配置。请使用no flowcontrol hardware line configuration命令禁用在接入服务器的硬件流控制。然后请通过一反向远程登录会话启用在调制解调器的硬件流控制。(请参考您的调制解调器文档并且请参阅部分“建立一反向远程登录会话到调制解调器”前在本章。)重新启用在接入服务器的硬件流控制用flowcontrol hardware line configuration命令
准备 CTS DSR DTR RTS(2) DSR字符串(而不是noDSR字符串)在的调制解调器硬件状态域出现任一个下列的原因:
  1. 不正确接线(卷起的MDCE或者平直的MDTE,但是没有移动的管脚)。推荐的布线配置在此表里给前。
  2. 调制解调器为总是高的DCD配置。重新配置调制解调器,以便DCD只是高在CD。这通常实行同&C1调制解调器命令,但是检查您的调制解调器文档您的调制解调器的确切句法。配置调制解调器用no exec line configuration命令连接的接入服务器线路。用clear line privileged exec命令清除线路,用调制解调器起动反向Telnet会话,并且重新配置调制解调器以使DCD仅在CD上为高水平。通过输入断开结束远程登录会话。重新配置接入服务器线路用exec line configuration命令。
就绪 CTS* DSR* DTR RTS(2) 如果此字符串在调制解调器硬件状态域出现,调制解调器控制在接入服务器很可能没有启用。请使用modem inout line configuration命令启用在线路的调制解调器控制。关于配置调制解调器控制的其他信息在接入服务器或路由器线路在此表里被提供前。

(1) CD =载波检测

(2) *在信号旁边指示两件事之一:信号更改在过去几秒以内或选择的调制解调器控制方法没有使用信号。

收集调制解调器性能信息

此部分说明收集的性能数据方法在接入服务器Cisco AS5x00家族找到的MICA数字调制解调器。性能数据可以用于趋势分析并且是有用的在也许遇到的故障排除性能问题。当查看编号下面提交了,请记住完美不是可能的在真实世界。可能的调制解调器呼叫成功率(CSR)是电路、客户端调制解调器用户规模和使用的套的质量的功能调制。V.34呼叫的典型CSR百分比是95%。V.90呼叫可以预计成功连接92%时间。过早的丢包可能发生10%时间。

请使用以下命令获取调制解调器工作情况全景在接入服务器的:

  • show modem

  • show modem summary

  • show modem connect-speeds

  • show modem call-stats

以下信息是有用,当排除故障单个调制解调器连接或收集数据为趋势分析时:

  • debug modem csm

  • 调制解调器呼叫记录

  • show modem op (MICA)/AT@E1 (Microcom),当连接时

  • 会话的show modem log在断开以后的利益

  • ANI (主叫方号码)

  • 每日定时

  • 客户端调制解调器硬件/固件修订版

  • 从客户端的有趣的信息(在disconnect)-ATI6以后, ATI11, AT&V, AT&V1,等等

  • 音频记录(.wav文件)从客户端调制解调器的培训尝试

在以下部分,命令进一步将解释,并且一些普通的趋势讨论。

Show modem/Show modem summary

show modem命令给单个调制解调器观点。从这些编号单个调制解调器健康可以查看。

router# show modem 
  Codes: 
  * - Modem has an active call 
  C - Call in setup 
  T - Back-to-Back test in progress 
  R - Modem is being Reset 
  p - Download request is pending and modem cannot be used for taking calls 
  D - Download in progress 
  B - Modem is marked bad and cannot be used for taking calls 
  b - Modem is either busied out or shut-down 
  d - DSP software download is required for achieving K56flex connections 
  ! - Upgrade request is pending 
                Inc calls     Out calls     Busied   Failed  No       Succ 
  Mdm  Usage    Succ   Fail   Succ   Fail   Out      Dial    Answer   Pct. 
* 1/0    17%      74      3      0      0       0        0       0     96% 
* 1/1    15%      80      4      0      0       0        1       1     95% 
* 1/2    15%      82      0      0      0       0        0       0    100% 
  1/3    21%      62      1      0      0       0        0       0     98% 
  1/4    21%      49      5      0      0       0        0       0     90% 
* 1/5    18%      65      3      0      0       0        0       0     95% 

为在路由器的所有调制解调器要看到综合指数,请使用show modem summary命令

router#show modem summary 
         Incoming calls       Outgoing calls      Busied   Failed   No    Succ 
Usage  Succ   Fail  Avail   Succ   Fail  Avail    Out      Dial     Ans   Pct. 
   0%  6297    185     64      0      0      0        0        0     0     97% 

表16-3 :show modem菲尔茨

菲尔茨 说明
进入和出去的呼叫 拨号到和在调制解调器外面的呼叫。
  • 总系统正常运行的用量百分比所有调制解调器是在使用中的。
  • Succ -顺利地连接的总呼叫量。
  • 失败-没有成功连接的总呼叫量。
  • 可用-总调制解调器可用为使用在系统。
占线的 时期总数调制解调器被采取了服务中断用modem busy命令modem shutdown命令
失败的拨号 调制解调器没有挂断尝试的总数或有无拨号音。
无应答 时期呼叫震令总数检测,但是呼叫未由调制解调器应答。
Succ Pct。 总可用的调制解调器的成功的连接百分比。

Show modem call-stats输出

compress  retrain lostCarr  rmtLink  trainup hostDrop wdogTimr inacTout 
  Mdm     #   %    #   %    #   %    #   %    #   %    #   %    #   %    #   % 
 Total    9       41      271     3277        7     2114        0        0

表16-4 :show modem call-stats菲尔茨

rmtLink 这显示错误纠正有效,并且客户端系统挂断呼叫附加对远程调制解调器。
hostDrop 显示呼叫IOS主机系统挂断这。一些常见原因包括:空闲超时、电路结算从电话公司或者一PPP LCP termreq从客户端。通过使用调制解调器呼叫记录或Aaa accounting,确定暂停的原因的最佳方法。

其他断开原因应该加起来对少于10%总计。

Show modem connect-speeds输出

router>show modem connect 33600 0 
 Mdm   26400  28000  28800  29333  30667  31200  32000  33333  33600 TotCnt 
Tot      614      0   1053      0      0   1682      0      0    822   6304 

router>show modem connect 56000 0 
 Mdm   48000  49333  50000  50666  52000  53333  54000  54666  56000 TotCnt 
Tot      178    308     68     97     86     16      0      0      0   6304 

期望发现V.34速度的分配。应该有高峰在26.4,如果T1使用随路信令(CAS)。For ISDN (PRI) T1,高峰应该在31.2。并且,请寻找一些K56flex, V.90加速。如果没有V.90连接可能有网络拓扑问题。

了解调制解调器呼叫记录(11.3AA/12.0T)命令

而不是exec命令,这是配置命令被放置在有问题的接入服务器的系统级别。当用户断开时,消息类似于以下显示:

*May 31 18:11:09.558: %CALLRECORD-3-MICA_TERSE_CALL_REC: DS0 slot/contr/chan=2/0/18,
slot/port=1/29, call_id=378, userid=cisco, ip=0.0.0.0, calling=5205554099, 
called=4085553932, std=V.90, prot=LAP-M, comp=V.42bis both,
init-rx/tx b-rate=26400/41333, finl-rx/tx brate=28800/41333, rbs=0, d-pad=6.0 dB,
retr=1, sq=4, snr=29, rx/tx chars=93501/94046, bad=5, rx/tx ec=1612/732, bad=0,
time=337, finl-state=Steady, disc(radius)=Lost Carrier/Lost Carrier,
disc(modem)=A220 Rx (line to host) data flushing - not OK/EC condition - locally 
detected/received
DISC frame -- normal LAPM termination

show modem operational-status命令

exec命令show modem operational-status表示当前(或多数最近的)参数关于调制解调器连接。

此命令的文档条目在Cisco IOS版本12.0拨号解决方案命令参考被找到。show modem operational-status仅是为MICA调制解调器。Microcom调制解调器的等效命令是调制解调器at模式/AT@E1。请使用modem at-mode <slot>/<port>命令连接到调制解调器,然后发出AT@E1命令。modem at-mode命令的完整文档可以在Cisco AS5300软件配置指南找到,并且AT@E1命令的文档在AT命令集和寄存器汇总供Microcom调制解调器模块命令参考

请使用以下步骤确定哪调制解调器用户进来在:

  1. 发出show user命令并且寻找他们连接的TTY。

  2. 请使用show line命令并且寻找调制解调器插槽/端口编号。

收集客户端性能数据

对于趋势分析,收集客户端性能数据是非常重要的。总是请设法得到以下信息:

  • 客户端硬件型号/固件版本(可达到与在客户端调制解调器的ATI3I7命令)

  • 客户端报告的断开原因(使用ATI6AT&V1)

在客户端的其他有用的资料包括PC的modemlog.txt和ppplog.txt。您必须特定配置您的PC生成这些文件。

分析性能数据

一旦收集了并且了解您的调制解调器系统的性能数据,您需要查看可能需要改进的剩余的模式和组件。

问题用特定服务器调制解调器

请使用show modemshow modem call-stats识别有异常地高速率连接时故障或坏断开速率的(MICA)所有调制解调器。如果相邻对调制解调器有问题,问题是暂停的可能/死DSP。请使用复制闪存调制解调器对受影响的HMM为了恢复。确保调制解调器运行端口件新版本。要验证所有调制解调器正确地配置,请使用configuration命令modem自动配置类型mica/microcom_server在line configuration里。要确保调制解调器自动配置,每当挂断呼叫,使用exec命令debug confmodem。为了修理是非常不正确的配置的调制解调器,您可能需要建立一反向远程登录会话。

与特定的Ds0s的问题

DS0问题是少见,但是可能的。要找出发生故障的Ds0s,请使用show controller t1 call-counters命令并且寻找与异常地高TotalCalls和异常地低TotalDuration的所有Ds0s。要瞄准怀疑Ds0s,您可以需要忙碌与configuration命令isdn服务dsl的其他Ds0s, ds0 busyout在T1的serial interfaces下。从show controller t1 call-counters的输出如下所示:

TimeSlot   Type   TotalCalls   TotalDuration 
    1       pri         873       1w6d 
    2       pri         753       2w2d 
    3       pri         4444      00:05:22 

明显地,时隙3在这种情况下是可疑的信道。

其他共同性趋势

下面Cisco TAC看到的一些更加普通的趋势。

  1. Bad电路路径

    如果有以下问题,您也许是恶化的电路路径通过公共交换电话网(PSTN) :

    • 长途呼叫有问题,但是本地不(或反之亦然)

    • 呼叫天某时有问题

    • 从特定远程交换的呼叫有问题

  2. 与长途呼叫的问题

    如果您的长途服务不正常运行或(但是本地服务优良是) :

    • 请务必数字线路连接到数字交换机,不是信道组。

    • 提示电话公司检查用于长距离的电路路径。

  3. 与呼叫的问题从呼叫区域的特定。

    如果从特定地理区域/交换的呼叫倾向于有问题,您应该从电话公司得到网络拓扑。

    如果多个模数转换要求, V.90/K56flex调制解调器连接不会是可能的,并且V.34可能某种程度降低。模数转换在为服务由非完整的数字交换机或由模拟交换机的区域要求。

ISDN操作

ISDN是指供给最终用户的一套数字服务。ISDN介入电话网的数字化,以便语音、数据、文本、图形、音乐、视频和其他参考来源资料可以提供给从单个最终用户,在现有电话配线的最终用户终端。ISDN的拥护者想象全世界网络很象现在电话网,但是与数字传输和各种各样新的服务。

ISDN是努力标准化用户服务、用户/network接口和网络和互联网网络容量。标准化用户服务尝试保证级别国际兼容性。标准化用户/network接口由第三方制造商刺激开发和销售这些接口。标准化网络和互联网网络容量帮助请通过保证达到全球连通性目标ISDN网络互相容易地通信。

ISDN应用程序在主页包括高速的镜像应用程序(例如组IV传真),其他电话线路服务电子通勤行业,高速的文件传输和视频会议。语音,当然,也isl对ISDN的普遍的申请。

家庭接入市场在另外技术中被划分。在更新的较低花费的技术例如变得的DSL和电缆可用家庭市场移动远离ISDN的区域中。企业,然而,继续使用ISDN以PRI T1/E1s的形式传送很多数据或提供v.90 dialin访问。

ISDN组件

ISDN组件包括终端、终端适配器(TA),网络终端设备、线路终接设备和交换局终端设备。ISDN终端进来两个类型。专门化ISDN终端指终端设备类型1 (TE1)。把ISDN标准日期填早的非ISDN终端,例如DTE,指终端设备类型2 (TE2)。TE1s连接对ISDN网络通过一个四线,双绞线数字链接。TE2s连接对ISDN网络通过终端适配器。ISDN TA可以是一个独立设备或一个板在TE2里面。如果TE2实现作为独立设备,连接对TA通过一个标准的物理层接口。示例包括EIA/TIA-232-C (以前RS-232-C), V.24和V.35。

在TE1和TE2设备之外,在ISDN网络的导航点是网络终端类型1 (NT1)或网络终端类型2 (NT2)设备。这些是联络配线对常规双线的本地环路的四线用户的网络终端设备。在北美, NT1是客户端前置设备(CPE)设备。在世界的多数其他地区中, NT1是载波提供的网络的一部分。NT2是一个更加复杂的设备,典型地找到在数字专用交换分机(PBX),进行Layer2和3协议功能和集中服务。NT1/2设备也存在;它是结合NT1和NT2的功能的单个设备。

一定数量的参考点在ISDN指定。这些参考点定义了功能分组例如TA和NT1之间的逻辑接口。ISDN参考点包括以下:

  • 在非ISDN设备和TA之间的R-The参考点

  • 在用户终端和NT2之间的S-The参考点

  • 在NT1和NT2设备之间的T-The参考点

  • 在NT1设备和线路终接设备之间的U-The参考点在运营商网络。U参考点是仅相关的在北美,运营商网络没有提供NT1功能

下列是示例ISDN配置。此示例显示三个设备附加对ISDN交换机在中心局。两这些设备综合服务数字网兼容,因此他们可以通过对NT2设备的一个S参考点附加。第三个设备(标准,非ISDN电话)通过对TA的R参考点附加。这些设备中的任一个可能也附有到NT1/2设备,将替换NT1和NT2。并且,虽然他们没有显示,相似的用户站附加到最右端ISDN交换机。

一个示例ISDN配置

2503B#show running-config
Building configuration...

Current configuration:
!
version 11.1
service timestamps debug datetime msec
service udp-small-servers
service tcp-small-servers
!
hostname 2503B
!
!
username 2503A password 
ip subnet-zero
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 172.16.141.11 255.255.255.192
!         
interface Serial0
 no ip address 
 shutdown 
!         
interface Serial1
 no ip address
 shutdown 
!         
interface BRI0
 description phone#5553754
 ip address 172.16.20.2 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 300
 dialer map ip 172.16.20.1 name 2503A broadcast 5553759
 dialer-group 1
 ppp authentication chap
!         
no ip classless
!         
dialer-list 1 protocol ip permit
!         
line con 0
line aux 0
line vty 0 4
!         
end       
          
2503B#

ISDN服务

ISDN基本速率接口(BRI)服务提供两条B信道和一D信道(2B+D)。BRI B信道服务操作在64 Kbps和被认为传送用户数据;BRI D-channel服务操作在16 Kbps和被认为传播控制和信令信息,在某种状况下,虽然可以支持用户数据数据传输。D信道信令协议通过3 OSI参考模型包括第一层。BRI也提供成帧控制和其他顶上,带来其总比特率to192 Kbps。BRI物理层规范是国际电信联盟电信标准化部门(ITU-T;前面国际电报电话咨询委员会[CCITT]) I.430。

ISDN基本速率接口(PRI)服务提供23条B信道和一D信道在北美和日本,产生总比特率1.544 Mbps (PRI D信道运行在64 Kbps)。在欧洲、澳大利亚和世界提供30 B的其他部分加上一64 KBPS D信道和所有接口速率的ISDN PRI 2.048 Mbps。PRI物理层规范是ITU-T I.431。

第 1 层

ISDN物理层(层1)帧格式有所不同根据是否帧出站(从终端到网络)或入站(从网络到终端)。两个物理层接口在表16-1显示。

/image/gif/paws/10202/isdnffa.gif

图16-1 :ISDN物理层帧格式

帧是长48个的位, 36个位代表数据。使用ISDN物理层帧的位如下:

  • F -提供同步。

  • L -调整平均的比特值。

  • E -使用冲突解决方法,当一被动总线的几个终端为信道角逐。

  • A -激活设备。

  • S -未分配。

  • B1、B2和D -用户数据。

多个ISDN用户设备可以物理的附加到一个电路。在此配置中,如果两个终端同时,传送冲突能发生。所以, ISDN确定链路争用的提供功能。当NT收到从TE时的一个D位,在下个E比特位置响应上一步位。TE盼望下个E位是相同的象其为时传送的D位。

终端不能传送到D信道,除非他们首先检测一个的一个特定编号(指示"no signal")与已建立的优先级相应。如果TE在是与其D位不同的响应(e)信道检测有点,必须停止立即传送。此简单技术保证仅一个终端能一次传送其D信息。在成功的D信息发射以后,终端有要求减少的其优先级检测更加连续那些在传送前。终端不能提高他们的优先级,直到在同一条线路的所有其它设备有一个机会发送D信息。电话接线比所有其他服务有高优先级,并且信令信息比nonsignaling信息有一高优先级。

Layer2

ISDN信令协议的Layer2是在D信道,亦称LAPD的链接接入程序。LAPD类似于高级数据链路控制(HDLC)和链路接入过程,平衡式(LAPB)。当LAPD简称的扩展指示,在D信道间用于保证控制和信令信息信息流和适当地接收。LAPD帧格式(请参见图16-2)非常类似于那HDLC,并且,类似HDLC, LAPD使用监督,信息和无编号帧。LAPD协议在ITU-T Q.920和ITU-T Q.921正式指定。

lapdff.gif

图16-2 :LAPD帧格式

LAPD标志和控制字段与那些是相同的HDLC。LAPD地址字段可以是长1个或2个的字节。如果第一个字节的延长的地址位设置,地址是1个字节;如果它没有设置,地址是2个字节。第一个地址字段字节包含服务接存取点识别器(SAPI),识别门户LAPD服务为第3层提供。C/R位指示帧是否包含命令或答复。终端终点标识(TEI)领域识别单个终端或多个终端。所有部分的TEI指示一广播。

第3层

两个第3层规格使用ISDN信令:ITU-T (以前CCITT) I.450 (亦称ITU-T Q.930)和ITU-T I.451 (亦称ITU-T Q.931)。同时,这些协议支持用户到用户,电路交换和信息包交换的连接。各种各样的呼叫建立、呼叫终止、信息和其他消息指定,包括设置、连接、版本、用户信息、取消、状态和断开。

这些消息是功能上相同的对X.25协议提供的那些(请参阅章节19, “排除故障X.25连接”,欲知更多信息)。图16-3,从ITU-T I.451,显示ISDN电路交换呼叫的典型的阶段。

/image/gif/paws/10202/stages.gif

图16-3 ISDN电路交换呼叫阶段

解释Show isdn status输出

要欲知什么ISDN连接的当前情况在路由器和电话公司交换机之间,请使用show isdn status命令。此命令支持的这两接口是BRI和PRI。

3620-2#show isdn status
Global ISDN Switchtype = basic-ni
ISDN BRI0/0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 88, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI = 97, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Spid Status:
        TEI 88, ces = 1, state = 5(init)
            spid1 configured, no LDN, spid1 sent, spid1 valid
            Endpoint ID Info: epsf = 0, usid = 0, tid = 1
        TEI 97, ces = 2, state = 5(init)
            spid2 configured, no LDN, spid2 sent, spid2 valid
            Endpoint ID Info: epsf = 0, usid = 1, tid = 1
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003

BRI的表16-5:- show isdn status

字段 意义
Layer 1 Status:DEACTIVATED 这指示BRI接口看不到在线路的一个信号。有此情况的五个可能的来源。
  • BRI接口被关闭。请检查配置shutdown命令在BRI接口下或者寻找从show interface命令的一个管理上下降状态的征兆。请使用配置工具并且输入未关闭在BRI接口下。输入clear interface bri命令在EXEC提示确保BRI接口重新启动。
  • 问题存在与布线。您将需要替换电缆。确保您使用一个直通RJ-45电缆。要检查电缆,请保持RJ-45电缆末端并行。如果管脚按同一顺序,电缆直通。如果管脚顺序被倒转,电缆滚动。更换电缆。
  • 路由器的ISDN BRI端口也许要求NT1设备。在ISDN中, NT1是提供客户端前置设备和中心局交换设备之间的接口的设备。如果路由器没有内部NT1,请获取并且连接NT1到BRI端口。确保BRI或终端适配器附加到NT1的S/T端口。参考制造商说明文件验证外部NT1的正确操作。
  • 线路也许不作用。联系载波确认连接的操作和验证交换机类型设置。
  • 确保路由器正确地作用。如果有有故障或发生故障的硬件,请如所需要替换。
第 2 层状态State=TEI_ASSIGNED 检查交换类型设置和SPIDS。接口专有的ISDN交换机设置将改写全局交换设置。SPID状态指示交换机是否接受SPIDS (有效或无效)。请与您的服务提供商联系验证在路由器配置的设置。要更改SPID设置,请使用isdn spidn interface configuration命令。那里n是1或2,根据有问题的信道。请使用此命令no表示删除特定的SPID。
isdn spidn spid-number [ldn] 
no isdn spidn spid-number [ldn]
语法说明:
spid-number
识别您订阅的服务的编号。此值由ISDN服务服务供应商分配并且通常是有另外的位的一个10位电话号码。
ldn
(可选)本地目录号(LDN),是一个七位数字的编号由服务提供商分配。在来话建立消息的交换机提供此信息。如果不包括对交换机的本地目录访问允许,但是另一条B信道可能不能收到呼入呼叫。要看到在交换机和路由器之间的第2层协商,请使用privileged exec命令debug isdn q921。q921调试在Debug命令参考资料描述。调试在CPU资源取决于,因此请当心,当使用他们时。

5200-1# show isdn status
Global ISDN Switchtype = primary-5ess
ISDN Serial0:23 interface
        dsl 0, interface ISDN Switchtype = primary-5ess
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask:  0x807FFFFF
    Total Allocated ISDN CCBs = 0
5200-1#

如果show isdn status命令不工作也不显示PRI,使用show isdn service命令,请尝试。确保pri-group命令在配置里出现在T1/E1控制器下在配置里。如果命令不存在,请配置控制器用pri-group命令

下列是一配置的示例一个Cisco路由器的用信道化T1/PRI控制器:

controller t1 0
framing esf
line code b8zs
pri-group timeslots 1-24

表16-6 :PRI的show isdn status

字段 意义
Layer 1 Status:DEACTIVATED 这指示PRI接口看不到T1/E1成帧在线路。设想此情况的以下可能的原因:
  • PRI接口被关闭。请检查配置shutdown命令在serial0:23接口下或寻找从show interface命令的一个管理上下降状态的征兆。请使用配置工具并且输入未关闭在有问题的接口下。输入clear controller T1/E1 n命令在EXEC提示确保PRI接口重新启动。
  • 问题存在与布线。您将需要替换电缆。确保您使用一个直通RJ-45电缆。要检查电缆,请保持RJ-45电缆末端并行。如果管脚按同一顺序,电缆直通。如果管脚顺序被倒转,电缆滚动。更换电缆。
  • 线路也许不作用。联系载波确认连接的操作和验证交换机类型设置。
  • 确保路由器正确地作用。如果有有故障或发生故障的硬件,请如所需要替换。
第 2 层状态State=TEI_ASSIGNED 检查交换类型设置。接口专有的ISDN交换机设置将改写全局交换设置。验证T1/E1配置匹配运营商交换机(T1/E1问题在章节15)讨论。要看到在交换机和路由器之间的第2层协商,请使用privileged exec命令debug isdn q921。q921调试在Debug命令参考资料描述。调试在CPU资源取决于,因此请当心,当使用他们时。
呼叫/call控制块/托塔尔在使用中Allocated ISDN呼叫控制块编号 这些编号指示多少呼叫进展中和指定支持那些呼叫资源的数量。如果已分配CCB数量高于使用的CCB数量,请考虑也许有在发布CCB的一问题。确保那里是呼入呼叫的联机CCB。

按需拨号路由:拨号接口操作

按需拨号路由(DDR)是提供WAN连接方法在经济,所需基础上,或者作为主链路或作为备份为非拨号串行链路。

拨号接口定义作为所有路由器接口能够放置或接收呼叫。此统称应该是著名的从期限拨号接口(与一大写D),是指配置的一个逻辑接口控制路由器一个或更多物理接口,并且在路由器配置里被看到,当interface dialer X.从这点转发,除非另外说明,我们在其广义的使用期限拨号程序。

拨号接口配置进来两个类似:基于拨号映射的(有时指传统DDR)和拨号配置文件。哪个方法您使用取决于您需要拨号连接的情况。基于拨号映射的DDR在IOS版本9.0首先介绍,在IOS版本11.2的拨号配置文件。

触发拨号

在其重点, DDR是路由分机, Interesting Packets路由对拨号接口,触发拨号尝试。以下部分说明在定义关注数据流涉及的概念并且说明用于DDR连接的路由。

Interesting Packets

触发的是描述数据包的此术语用于或或者将触发拨号尝试或的流量,如果拨号链路已经是活跃的,将重置在拨号接口的空闲计时器。触发的数据包将被认为:

  • 数据包必须满足定义的“permit”标准access-list

  • access-list必须由拨号列表参考或数据包必须由拨号列表全体地允许的是协议

  • 必须关联拨号器列表与拨号接口利用拨号组

数据包从未自动地认为触发的(默认情况下)。在路由器或接入服务器配置里必须明确地宣称触发数据包定义。

拨号组

在每拨号接口的配置中在路由器或接入服务器的,一定dialer-group命令。如果dialer-group命令不存在,没有触发数据包定义和接口之间的逻辑链接。命令语法:

dialer-group [group number]

组编号是特定接口属于拨号访问组的编号。此访问组用dialer-list命令定义。可接受值是在1和10.之间的非零,正整数。

接口可以关联与仅一个拨号访问组;多个拨号组分配没有允许。第二个拨号访问组分配将改写第一。拨号访问组用dialer-group命令定义。dialer-list命令连结访问列表与拨号访问组。

匹配指定的拨号程序组触发连接请求的数据包。

数据包的目的地址被评估在associated dialer-list命令指定的访问列表。如果它通过,或者呼叫被发起(如果连接已经未被建立)或空闲计时器重置(如果呼叫当前连接)。

拨号器列表

dialer-list global configuration命令用于定义DDR拨号程序列表控制正在拨号由协议,或者用协议和访问列表的组合。Interesting Packets是匹配协议级别permit或由在dialer-list命令的列表允许的那些:dialer-list dialer-group protocol protocol-name {permit|拒绝|描述|访问组}

拨号组是在其中任一dialer-group interface configuration命令识别的拨号访问组的编号。

协议名称是任一个下列的协议关键字:AppleTalk、网桥、clns、clns_es、clns_is、DECNet、decnet_router-L1、decnet_router-L2、decnet_node、ip、ipx、vines或者xns。

permit对整个协议的许可证访问。

拒绝拒绝对整个协议的访问。

列表指定访问列表比整个协议将使用定义粒度细致。

access-list-number -在任何DECNet指定的访问列表编号、Banyan VINES、IP、Novell IPX或者XNS标准或者扩展访问列表,包括Novell IPX扩展服务访问点(SAP)访问列表和桥接类型。参见表16-7关于支持的访问列表类型和编号。

访问组用于clns filter-setclns access-group命令的过滤器列表名称。

表16-7 :access-list编号由协议

访问列表类型 访问列表编号范围(十进制)
AppleTalk 600-699
Banyan VINES (标准) 1-100
Banyan VINES (被延伸) 101-200
DECNet 300-399
IP (标准) 1-99
IP (被延伸) 100-199
Novell IPX (标准) 800-899
Novell IPX (扩展) 900-999
透明桥接 200-299
XNS 500-599

访问列表

对于将在拨号连接间发送的每个网络协议,访问列表可能配置。为成本控制的目的,配置访问列表为了防止某一流量,例如路由更新,启动或保持连接通常是理想的。注意,当我们为定义触发的和无关的流量的目的时建立访问列表,我们不宣称非触发数据流不能流过拨号链路。我们表明他们不会重置空闲计时器,亦不他们独自地将启动连接。只要拨号连接是UP,非触发数据流将允许在链路间流。

例如,一路由器运行EIGRP作为其路由协议能有配置的访问列表宣称非触发的EIGRP的数据包和触发的其他IP数据流:

access-list 101 deny eigrp any any
access-list 101 permit ip any any

访问列表可以为也许流过拨号链路的所有协议配置。为所有协议切记那,默认行为在没有access-list permit语句时是否决所有流量。如果访问列表和没有dialer-list命令允许协议,则协议非触发的。在实际实践,如果没有协议的拨号器列表,那些数据包不会在链路间根本流。

示例-汇集它全部

使用到位所有元素,您能检查数据包“触发的”状态取决于的完整进程。在本例中, IP和IPX是可能流过拨号链路的协议。用户要防止广播和路由更新发起呼叫或保持链路。

!
interface async 1
 dialer-group 7
!
access-list 121 deny eigrp any any
access-list 121 deny ip any host 255.255.255.255
access-list 121 permit ip any any
access-list 903 deny -1 FFFFFFFF 0 FFFFFFFF 452
access-list 903 deny -1 FFFFFFFF 0 FFFFFFFF 453
access-list 903 deny -1 FFFFFFFF 0 FFFFFFFF 457
access-list 903 permit -1
!
dialer-list 7 protocol ip list 121
dialer-list 7 protocol ipx list 903
!

必须由access-list 121语句允许数据包,在交叉interface async 1前,为了被认为触发的。在这种情况下, EIGRP数据包拒绝,象所有其他广播包,而其他IP数据流允许。切记这不防止EIGRP数据包传输链路。只意味着这些数据包不会重置空闲计时器也不会启动拨号尝试。

同样地, access-list 903宣称IPX RIP、SAP和GNS请求非触发的,而其他IPX数据流是有趣的。没有这些拒绝语句,拨号连接不会可能下来,并且非常高额电话费将发生,因为数据包这些类型在IPX网络间经常流。

dialer-group 7配置在异步接口,我们知道拨号列表7是需要的附加触发数据流过滤器(即访问列表)到接口。一个拨号列表语句为每份协议要求(和一个可以配置),确保拨号器列表编号是相同的象在接口的拨号组组编号。

再次,请记住在为定义关注数据流配置的访问列表的拒绝语句不会防止已拒绝数据包流过链路。

使用debug dialer命令,您能看到触发拨号尝试的活动:

Dialing cause: Async1: ip (s=172.16.1.111 d=172.16.2.22)

此处我们看到与172.16.1.111源地址和172.16.2.22目的地址的IP数据流触发了在接口Async1的拨号尝试。

路由

一旦定义,必须适当地路由Interesting Packets为了能将启动的呼叫。路由进程取决于两件事:路由表条目和“”的接口路由数据包的。

接口- up/up (spoofing)

为了通过接口能将路由的对和数据包,该接口一定是up/up如在输出的show interfaces中看到

Montecito# show interfaces ethernet 0
Ethernet0 is up, line protocol is up
  Hardware is Lance, address is . . . 

什么发生在没有连接的拨号接口?如果协议不是正在运行的在接口,暗示是接口不会是UP。依靠该接口的路由从路由表和流量将被冲洗不会路由对该接口。结果是呼叫不会由接口发起。

抵抗此可能性的解决方案将允许状态up/up (spoofing)拨号接口。所有接口可以配置作为拨号接口。例如,序列或异步接口能做成拨号程序通过添加dialer in-band命令或dialer dtr到接口配置。这些线路为天生是拨号接口的接口是多余的(BRI和PRI)。show interface的输出如下所示: :

Montecito# show interfaces bri 0
BRI0 is up, line protocol is up (spoofing)
  Hardware is BRI
  Internet address is . . .

换句话说,接口“假装” up/up,以便相关的路由将仍然有效,并且,以便数据包可以路由到接口。

有拨号接口不会是up/up (spoofing)的情况。show interface输出可能显示接口作为管理上下降状态:

Montecito# show interfaces bri 0
BRI0 is administratively down, line protocol is down
  Hardware is BRI
  Internet address is . . .

管理性关闭仅仅意味着接口配置与shutdown命令。当路由器是启动在首先次时,这是所有路由器接口的默认状态。要补救此,请使用interface configuration命令未关闭

接口可能也被看到在备用模式:

Montecito# show interfaces bri 0
BRI0 is standby mode, line protocol is down
  Hardware is BRI
  Internet address is . . . 

此状态表明接口配置作为另一个接口的备份。当连接在失败的情况下时要求冗余,拨号接口可以设置作为备份。这通过添加以下命令完成到主要连接的接口:

backup interface [interface]
backup delay [enable-delay] [disable-delay]

一旦backup interface命令配置,作为备份使用的接口将被放到备用模式,到主要接口去状态down/down之时。那时,作为备份配置的拨号接口,将去等待拨号事件的一个up/up.(.spoofing)状态。

静态路由和浮动静态路由

可靠方法路由数据包到拨号接口是静态路由。这些路由手工被输入到路由器或接入服务器的配置用命令:

ip route前缀掩码{地址|interface} [distance]

前缀:目的地的Ip route前缀。

掩码:目的地的前缀掩码。

地址:能使用到达目的地网络下一跳的IP地址。

接口:使用的网络接口出站流量。

距离:(可选)管理距离。此参数用于浮动静态路由。

静态路由用于拨号链路是对远程站点的唯一的连接的情况。静态路由有管理距离值为一(1),做在动态路由更喜欢的它对同一个目的地。

另一方面,浮动静态路由-即,有预定义的管理距离的静态路由-典型地用于备份DDR方案。在这些情况下一个动态路由协议,例如RIP或EIGRP,路由在主链路间的数据包。

正常静态路由(管理距离= 1)是更可取的对EIGRP (管理距离= 90)或RIP (管理距离= 120)。静态路由造成数据包在拨号线路间路由,即使主要的上和能够通过流量。如果,然而,静态路由高于那配置与管理距离任何动态路由协议在使用中在路由器,浮动静态路由在没有“更加好的”路由时只将使用-一个与更短的管理距离。

如果备份DDR利用backup interface命令被调用,情况有些不同的。由于拨号接口在备用模式依然是,当主要的是UP时,静态路由或浮动静态路由可能配置。在主要接口是down/down之后,拨号接口不会尝试连接。

对于一给的连接,必要静态(或浮动静态)的路由数量是编址的功能在拨号接口的。在两拨号接口(一在两路由器中的每一)处共享常见网络或子网,典型地仅一静态路由要求。它指向远程LAN使用远程路由器的拨号接口的地址作为下一跳地址。

示例

示例 1:使用编号的接口,拨号是唯一的连接。一个路由是满足的。

/image/gif/paws/10202/singledialnumbered.gif

图16-4 :拨号使用编号的接口

Montecito:
ip route 192.168.10.0 255.255.255.0 172.16.20.2
Goleta: 
ip route 10.1.1.0 255.255.255.0 172.16.20.1

示例 2:使用未编号的接口,拨号是唯一的连接。这可以用一个路由配置,但是普通配置两个路由:对LAN接口的主机路由在远程路由器和对远程LAN的一个路由通过远程LAN建立接口。这执行防止第三层到第二层映射问题,能导致封装故障。

此方法也使用,如果在两个设备的拨号接口被编号,但是不在同一网络或子网。

/image/gif/paws/10202/singledialunnumbered.gif

图16-5 :拨号使用未编号的接口

Montecito:
ip route 192.168.10.0 255.255.255.0 192.168.10.1
ip route 192.168.10.1 255.255.255.255 BRI0
Goleta: 
ip route 10.1.1.0 255.255.255.0 10.1.1.1
ip route 10.1.1.1 255.255.255.255 BRI0

示例 3:使用编号的接口,拨号是备用连接。一浮动静态路由要求。

backupnumbered.gif

图16-6 :备份使用编号的接口

Montecito:
ip route 192.168.10.0 255.255.255.0 172.16.20.2 200
Goleta: 
ip route 10.1.1.0 255.255.255.0 172.16.20.1 200

示例 4:使用未编号的接口,拨号是备用连接。正如在以上的示例2,此方法也使用,如果在两个设备的拨号接口被编号,但是不在同一网络或子网。

/image/gif/paws/10202/backupunnumbered.gif

图16-7 :备份使用无编号的接口

Montecito:
ip route 192.168.10.0 255.255.255.0 192.168.10.1 200
ip route 192.168.10.1 255.255.255.255 BRI0 200
Goleta: 
ip route 10.1.1.0 255.255.255.0 10.1.1.1 200
ip route 10.1.1.1 255.255.255.255 BRI0 200

拨号图

基于拨号映射的(传统) DDR是强大和全面,但是其限制影响比例缩放和延伸性。基于拨号映射的DDR根据在单个目标文件的呼叫规格和物理接口配置之间的一个静态绑定。

然而,基于拨号映射的DDR也有许多力量。它支持帧中继、ISO CLNS、LAPB、Snapshot路由和Cisco路由器支持的所有路由协议。默认情况下,基于拨号映射的DDR支持快速交换。

当配置呼出电话的时一个接口,必须配置一dialer map为每远程目的地和为在远程目的地的每个另外被叫号码。例如,如果想要有其B信道中的每一的不同的本地目录号的多链路PPP连接,当拨号从ISDN BRI到另一ISDN BRI接口时,您需要其中每一个的一dialer map远端号码:

!
interface bri 0
 dialer map ip 172.16.20.1 name Montecito broadcast 5551234
 dialer map ip 172.16.20.1 name Montecito broadcast 5554321
!

拨号图配置的命令可以是重要。如果两个或多个dialer map命令参考同一远程地址,路由器或接入服务器按顺序将逐个试他们,直到成功设立一连接

注意: IOS能动态建立在接收呼叫的路由器的拨号图。dialer map根据认证的用户名和呼叫方的经过协商的IP地址被构件。动态拨号映射在show dialer map命令的输出中能只被看到。您在路由器或接入服务器的运行的配置不能查看他们。

命令语法

请使用以下表dialer map interface configuration命令对:

  • 配置serial interfaces或ISDN接口呼叫一或多个站点或者

  • 收到从多个站点的呼叫。

所有选项显示以命令的此第一个形式。要删除特定的拨号映射项,请使用此命令no表示

dialer map protocol next-hop-address [name hostname] [spc] [speed 56 | 64] 
[broadcast] [modem-script modem-regexp] [system-script system-regexp] 
[dial-string[:isdn-subaddress]]

请使用以下表dialer map命令对:

  • 配置serial interfaces或ISDN接口发出呼叫到多个站点,和

  • 验证从多个站点的呼叫。

    dialer map protocol next-hop-address [name hostname] [spc] [speed 56 | 64] 
    [broadcast] [dial-string[:isdn-subaddress]] 
    

请使用以下表dialer map命令配置serial interfaces或ISDN接口支持桥接。

dialer map bridge [name hostname] [spc] [broadcast] [dial-string[:isdn-subaddress]]

请使用以下表dialer map命令配置异步接口发出呼叫对:

  • 单站点要求系统脚本或没有的已分配调制解调器脚本或者

  • 多个站点单个线路的,多条线路的,或者拨号循环组的。

    dialer map protocol next-hop-address [name hostname] [broadcast]
    [modem-script modem-regexp] [system-script system-regexp] [dial-string]
    

语法说明

  • 协议关键字。请使用下列之一:AppleTalk网桥clnsDECNetipipxNovell快照vines或者xns

  • 下一条地址-用于的协议地址匹配数据包是注定的地址。此参数没有与网桥协议关键字一起使用。

  • 名称- (可选)指示本地路由器或接入服务器连通的远程系统。使用验证在呼入呼叫的远程系统。

  • 主机名- (可选)远程设备(通常主机名)的区分大小写的名称或ID。对于有ISDN接口的路由器, Hostname Field能包含主叫线路ID提供的编号(在主叫线路识别,也指CLI呼叫方ID自动数字标识(ANI)处,是可用的)。

  • spc - (可选)指定用户设备和交换之间的部分永久连接。它仅使用在德国在ISDN BRI和1TR6 ISDN交换机之间的电路和在澳大利亚在ISDN PRI和TS-014交换机之间的电路。

  • speed 56|64 - (可选)关键字和重视指示在千位每秒的线路速度使用。使用仅ISDN。默认速度是64 Kbps。

  • 广播- (可选)表明应该转发广播到此协议地址。

  • Modem-script - (可选)指示将用于连接调制解调器脚本(异步接口)。

  • modem-regexp - (调制解调器脚本将匹配的可选)常规表示(异步接口)。

  • 系统脚本- (可选)指示将用于连接系统脚本(异步接口)。

  • 系统的regexp - (系统脚本将匹配的可选)常规表示(异步接口)。

  • 拨号字符串[:isdn-subaddress] (可选)电话号码发送到拨号设备在匹配定义的访问控制列表数据包的识别有一指定的下一跳地址的(和用于ISDN多点连接的可选subaddress编号)。拨号字符串和ISDN子地址,若被采用,必须是在line命令的最后项目。

拨号原型(Dialer Profile)

注意: 在此部分术语dialer.interface参阅配置接口;不对在路由器或接入服务器的一个物理接口。

DDR的拨号配置文件实施,介绍在IOS版本11.2,根据在逻辑和物理接口配置之间的分离。拨号配置文件也允许将在一起地绑捆的逻辑和物理配置动态地在每呼叫的基础上。

当您要执行以下时,拨号配置文件方法是有利的:

  • 共享接口(ISDN,异步或者同步串行)拨打或接收呼叫

  • 逐个用户更改所有配置(除了在拨号配置文件第一阶段的封装)

  • 对许多目的地的网桥

  • 避免分开的展望期问题

拨号配置文件允许从逻辑配置将分离的物理接口的配置要求为呼叫,并且他们也允许将在一起地绑捆的逻辑和物理配置动态地在每呼叫的基础上。

拨号程序配置文件包括以下元素:

  • 拨号接口(逻辑实体)配置,包括其中每一个用于到达一个目的地子网)的一个或更多拨号字符串(

  • 定义了所有呼叫的所有特性对指定的拨号字符串的拨号映射类

  • 拨号接口将使用的物理接口的一个指定拨号池

所有呼叫去到/从同一目的地子网使用同一拨号配置文件。

拨号接口配置包括必要的所有设置到达一个特定目的地子网(和通过它到达的任何网络)。多个拨号字符串可以为同一拨号接口指定;每个拨号字符串可以关联与一个不同的拨号映射类。拨号映射类定义了所有呼叫的所有特性对指定的拨号字符串。例如,一个目的地的映射类别也许指定56 KBPS ISDN速度。一个不同的目的地的映射类别也许指定64 KBPS ISDN速度。

每拨号接口使用一个拨号池,是根据优先级被定购的物理接口池分配到每个物理接口。物理接口能属于多个拨号池,当争用被解决由优先级。ISDN BRI和PRI接口能定在B信道最低和最大的一限制所有拨号池保留的。拨号池保留的信道依然是空闲,直到流量被处理给池。

当拨号配置文件用于配置DDR时,物理接口没有除了接口属于的封装和拨号池的配置设置。

注意: 之前的段有一例外。应用必须配置的命令,在验证完成前在物理(或BRI或者PRI)接口和不在拨号配置文件。拨号配置文件不复制PPP认证命令(或LCP命令)对物理接口。

图16-8显示拨号配置文件的一典型的应用程序。路由器A有按需拨号路由的按需拨号路由的拨号接口1与子网1.1.1.0和拨号接口2与子网2.2.2.0。拨号接口的1 IP地址是其地址作为在网络1.1.1.0的一个节点。同时,该IP地址担当拨号接口使用的物理接口的IP地址1。同样地,拨号接口的2 IP地址是其地址作为在网络2.2.2.0的一个节点。

/image/gif/paws/10202/x1.gif

图16-8 :典型的拨号配置文件应用程序

拨号接口只使用一个拨号池。物理接口,然而,可以是一个或许多拨号池的成员,并且拨号池能有几个物理接口作为成员。

图16-9说明在拨号接口、拨号池和物理接口中的概念的关系。拨号接口0用途拨号池2.物理接口BRI 1属于dialer pool 2并且有特定优先级在池。物理接口BRI 2也属于dialer pool 2。由于争用根据物理接口的优先级是解决的在池的, BRI 1和BRI 2必须分配在池的不同的优先级。或许BRI 1是指定优先级100,并且BRI 2是在dialer pool 2的指定优先级50 (优先级50高于优先级100)。BRI 2有一更加高优先级在池,并且首先将发出其呼叫。

/image/gif/paws/10202/x2.gif

图16-9 :在拨号接口、拨号池和物理接口中的关系

Dialer Profile配置步骤

命令 目的
interface dialer number 创建拨号程序接口。
ip address address mask 指定拨号程序接口的 IP 地址和掩码,该拨号程序接口作为所呼叫的目标网络中的节点。
encapsulation ppp 指定 PPP 封装。
dialer remote-name username 指定远程路由器CHAP认证名称。
dialer string dial-string class class-name 指定所呼叫的远程目标以及为对此目标进行的呼叫定义特性的映射类。
拨号程序池号码 指定用于对此目标进行呼叫的拨号池。
dialer-group group-number 将拨号程序接口分配给拨号程序组。
dialer-list dialer-group protocol protocol-name {permit|拒绝|描述} 指定访问列表由列表编号或由协议和列表编号定义能触发呼叫的“触发的”数据包。

PPP操作

点对点协议(PPP)是绝对地最普通的链路层传输协议,完全被强占SLIP作为选择协议同步的拨号(和在许多情况下,非拨号)和异步串行连接的。PPP在1989年最初定义由RFC 1134,由达到高潮(自此文字)在RFC1661的一系列的RFC从那以后使过时。也有定义了协议的元素,例如RFC1990的许多RFC (PPP多链路协议), RFC2125 (PPP带宽分配协议)和许多其他。RFC一个联机信息库可以找到在:

http://www.ietf.org/rfc.htmlleavingcisco.com

或许PPP的最好的定义可以在RFC1661找到,陈述:

点对点协议(PPP)为传输在点对点链路的多协议数据包提供一个标准方法。PPP包括三个主要组件:

  1. 封装的多协议数据包一个方法。

  2. 建立,配置和测试的数据链路连接链路控制协议(LCP)。

  3. 家族网络控制协议(NCP)设立和配置的不同的网络层协议。

PPP 协商的各个阶段

PPP协商包括三个相位:链路控制协议(LCP)、验证和网络控制协议(NCP)。其中每一按顺序继续,跟随异步或ISDN连接的建立。

LCP

PPP不跟随客户端/服务器模型。所有连接对等。所以,当有呼叫方和接收方时,点对点连接的两端必须对经过协商的协议和参数达成协议。

当协商开始时,要其中每一的对等体建立PPP连接必须发送Configure请求(参见在debug ppp协商和此后指CONFREQ)。在CONFREQ包括不是链路默认的所有选项。这些经常包括最大接收单元(MRU)、异步控制字符映射(ACCM),认证协议(AuthProto)和幻数。并且被看到最大接收重建单元(MRRU)和端点分辨器(EndpointDisc),用于多链路PPP。

有对所有CONFREQ的三可能的答复:

  • 配置承认(CONFACK),如果对等体认可选项并且赞成在CONFREQ,看到的值必须发出。

  • 必须发送配置拒绝(CONFREJ),如果其中任一个在CONFREQ的选项没有被认可(例如,一些供应商特殊选项)或,如果的值任何选项在对等体的配置里明确地禁止。

  • 必须发送配置否定回答(CONFNAK),如果在CONFREQ的所有选项被认可,但是值不是可接受对对等体。

两对等体继续交换CONFREQ, CONFREJs和CONFNAKs直到中的每一发送CONFACK,直到拨号连接是残破的,或者直到其中一或两个对等体表明协商不可能完成。

验证

在LCP协商和达成以后在AuthProto的一项协议成功的完成,下一步是验证。验证,当不必须每RFC1661,是高度推荐的在所有拨号连接。在某些情况下,它是正常操作的一个需求;是的拨号配置文件典型事例。

验证的两种主要类型在PPP的是密码认证协议和质询握手验证协议(CHAP),定义由RFC1334和更新由RFC1994。

因为纯文本密码在拨号连接间,被发送PAP是简单两个,但是安全的较少。因为纯文本密码没有在拨号连接间,被发送CHAP是安全的更多。

PAP可能是必要的在任一个下列的环境中:

  • 当系统中安装了大量不支持 CHAP 的客户端应用程序时

  • 当不同供应商实施的 CHAP 互不兼容时

当讨论验证时,使用术语“请求方”和“验证器”区分设备播放的角色在连接的任一个末端是有用的,虽然任一对等体能在任何一个角色操作。“请求方”描述请求网络访问并且提供认证信息的设备;“验证器”验证认证信息的正确性,并且允许或禁止连接。当DDR连接被建立在路由器之间时,它是普通为了两对等体能操作在两个角色。

PAP

PAP是十分简单的。在LCP协商的成功的完成以后,请求方重复发送其在链路间的用户名/密码组合,直到验证器回应确认或,直到链路是残破的。验证器可能断开链路是否确定用户名/密码组合无效。

CHAP

CHAP是稍微更加复杂的。验证器发送对请求方的一挑战,然后回应值。此值计算通过使用“单向散列函数”功能混合挑战和CHAP口令。结果值被发送对验证器与一起可能是与其实际主机名不同)的请求人的Chap主机名(在响应消息

验证器读在响应消息的主机名,为预计的该主机名查寻预计密码,然后计算值在其答复发送的请求方由执行请求方执行的同一个散列函数。如果结果值配比,验证是成功的。失败应该导致断开。

AAA

一验证、授权和核算(AAA)服务,例如TACACS+或RADIUS,可能用于完成PAP或CHAP。

NCP

在成功认证以后, NCP相位开始。正如在LCP,对等体交换CONFREQ、CONFREJs、CONFNAKs和CONFACK。然而,在此相位协商,协商的和更高层协议有关- IP, IPX,桥接, CDP,等等元素。一个或很多这些协议可能协商。因为它是最常用的,并且,因为其他协议在操作同一个方式,互联网协议控制协议(IPCP),定义在RFC1332,是此讨论焦点。其他有关RFC包括,但是没有被限制对:

  • RFC1552 (IPX控制协议)

  • RFC1378 (AppleTalk控制协议)

  • RFC1638 (桥接控制协议)

  • RFC1762 (DECNet控制协议)

  • RFC1763 (Vines控制协议)

另外,在NCP期间, Cisco发现协议控制协议(CDPCP)可能协商,虽然这不普通。Cisco TAC工程师通常建议no cdp enable命令在任意拨号接口配置防止无限地保持召集的CDP数据包。

在IPCP协商的关键要素是每个对等体地址。其中每一对等体是在两可能的状态之一中;或者它有一个IP地址或不。如果对等体已经有一个地址,将发送在CONFREQ的该地址给另一对等体。如果地址是可接受对另一对等体, CONFACK将返回。如果地址不是可接受,回复将是包含对等体的CONFNAK一个地址能使用。

如果对等体没有地址,将发送与地址0.0.0.0的一CONFREQ。这告诉另一对等体分配地址,通过发送与适当地址的一CONFNAK完成。

其它选项在IPCP可能协商。编解码器域名服务器的主要的和备用地址和NetBIOS名称服务器,正如信息性RFC1877所描述。IP压缩协议(RFC1332)也普通。

预备PPP方法

预备PPP方法包括多链路PPP、多机箱PPP和虚拟配置文件。

多链路 PPP

Multilink点对点协议(MLP)功能提供在多个广域网链接的负载均衡功能。同时它在两提供多厂商互操作性,信息包分段和适当定序和负载计算入站和出站通流量。多链路PPP Cisco实施支持在RFC1717的分段和信息包顺序规格。

多链路PPP允许将被分段的。这些片段可以在多条点对点链路同时发送到同一远程地址。多条链路出来以回应您定义了的拨号负载门限值。负载可以计算在入站数据流,出站流量,或者在二者之一,当必要时为特定站点之间的流量。MLP提供按需带宽并且减少在广域网链路间的传输等待时间。

多链路PPP在配置支持按需拨号的循环组和PPP封装的以下接口类型工作(单个或多) :

  • 异步串行接口

  • BRI

  • PRI

配置

要配置在异步接口的多链路PPP,您配置异步接口支持DDR和PPP封装。您然后配置拨号接口支持PPP封装、按需带宽和多链路PPP。有时,然而,添加更多异步接口不改进性能。使用V.34调制解调器,使用默认MTU大小,多链路PPP应该支持三个异步接口。然而,数据包也许偶尔地丢弃,如果MTU小或,如果短帧大突发流量发生。

默认情况下,因为ISDN接口是拨号循环组要启用在单个ISDN BRI或PRI接口的多链路PPP,您没有要求分开定义拨号循环组。如果不使用PPP认证步骤,您的电话业务必须通过呼叫方id。

负载阈值编号要求。关于配置在单个ISDN BRI接口的多链路PPP示例,请参阅下面一个ISDN接口的多链路PPP的示例

当多链路PPP配置时,并且您希望多链路捆绑无限地连接,请使用拨号程序空闲Timeout命令设置一个非常高空闲计时器。dialer-load threshold 1命令不保持多链路捆绑无限地连接的,并且dialer-load threshold 2命令不保持多链路捆绑两条链路无限地连接n链路。

要启用在多个ISDN BRI或PRI接口的多链路PPP,您设置拨号程序轮循接口并且为多链路PPP配置它。您分开然后配置BRI并且添加他们其中每一到同一循环组。请参阅下面多个ISDN接口的多链路PPP的示例

在一个ISDN接口的多链路PPP的示例

以下示例启用在BRI接口0的多链路PPP。当一个BRI配置时,拨号程序循环组配置没有要求默认情况下(ISDN接口是循环组)。

interface bri 0
ip address 171.1.1.7 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 30
 dialer load-threshold 40 either
 dialer map ip 172.16.20.2 name Goleta 5551212
 dialer-group 1
 ppp authentication pap
 ppp multilink

在多个ISDN接口的多链路PPP的示例

以下示例配置多个ISDN BRI属于多链路PPP的同一拨号循环组。请使用ISDN BRI的dialer rotary-group命令分配其中每一给必须匹配拨号接口的该拨号循环组(第0的编号在这种情况下)。

interface BRI0
 no ip address
 encapsulation ppp
 dialer rotary-group 0
!
interface BRI1
 no ip address
 encapsulation ppp
 dialer rotary-group 0
!
interface Dialer0
 ip address 172.16.20.1 255.255.255.0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 500
 dialer map ip 172.16.20.2 name Goleta broadcast 5551212
 dialer load-threshold 30 either
 dialer-group 1
 ppp authentication chap
 ppp multilink

多机箱多链路PPP

多链路PPP提供拆分和重组信息包的功能给在逻辑管道间的单个终端系统(也呼叫套件)形成由多条链路。多链路PPP提供按需带宽并且减少在广域网链路间的传输等待时间。

多机箱多链路PPP (MMP),另一方面,为链路提供其他功能在用不同的远程地址的多个路由器终止。MMP能也处理两模拟和数字流量。

此功能供有拨入用户大群,单个接入服务器不能提供足够的拨入端口的情况使用。MMP允许公司提供一个拨号号码给其用户和应用同一解决方案到模拟和数字呼叫。此功能允许网络服务提供商,例如,分配ISDN轮循号到在几路由器间的几个ISDN PRI。

对于MMP命令的完整说明此中被参考的,参考Cisco拨号解决方案命令参考。找出在本章出现,使用命令参考主索引或搜索联机其他命令的文档。

支持MMP在Cisco 7500、4500及2500系列平台和同步串行、异步串行、ISDN BRI、ISDN PRI和拨号接口。

MMP不要求电话公司交换机的重新配置。

配置

路由器或接入服务器配置属于对等体的组,呼叫堆栈组。堆栈组的所有组员是对等体;堆栈组不需要一个永久性lead路由器。所有堆栈组成员能应答来自一个接入号码的呼叫,通常是ISDN PRI搜索组。呼叫能自远程用户设备进来,例如路由器、调制解调器、ISDN终端适配器或者PC卡。

一旦连接用堆栈组的一名组员建立,该成员拥有呼叫。如果第二次呼叫自同一个客户端进来,并且一个不同的路由器应答呼叫,路由器设立一个通道并且转发属于呼叫的所有信息包拥有呼叫的路由器。建立一个通道和转发呼叫进程通过它对拥有呼叫的路由器有时呼叫设想PPP链路对呼叫主控

如果更多强大的路由器是可用的,它可以配置作为堆栈组的组员,并且其他堆栈组成员能建立通道和转发所有呼叫到它。在这种情况下,其他堆栈组成员回答呼叫,并且对强大的转发流量卸载路由器。

注意: 在堆栈组成员之间的高延时广域网线路能使堆栈组操作效率低。

MMP呼叫处理,投标和Layer2转发操作在堆栈组中如下进行。它在表16-10也显示。

  1. 当第一个呼叫进来到堆栈组时,路由器A应答。

  2. 在投标,因为已经有呼叫,路由器A赢取。路由器A变为该会话的呼叫控制者用远程设备。路由器A也许也呼叫对主绑定接口的主机

  3. 当发起呼叫时的远程设备需要更多带宽,做第二多链路PPP呼叫给组。

  4. 当第二次呼叫进来时,路由器D回答它并且通知堆栈组。因为已经处理会话用该远程设备,路由器A赢取投标。

  5. 路由器D设立一个通道到路由器A并且转递原始PPP数据到路由器A。

  6. 路由器A重新召集和重新排序数据包。

  7. 如果更多呼叫进来到路由器D,并且他们也属于路由器A,在A和D之间的通道扩大处理已添加流量。路由器D不设立一个另外的通道对A。

  8. 如果更多呼叫进来和由其他路由器回答,该路由器也设立一个通道对A并且转递原始PPP数据。

  9. 被重新召集的数据在公司网络通过,好象安排全部通过一条物理链路来。

/image/gif/paws/10202/x3.gif

图16-10 :典型的多机箱多链路PPP方案

与上一个图对比,图16-11以卸载路由器为特色。属于堆栈组答案呼叫,设立通道,并且传送呼叫到Cisco 4700路由器赢取投标的接入服务器和是所有呼叫的呼叫控制者。Cisco 4700重新召集和重新排序进来通过堆栈组的所有数据包。

x4.gif

图16-11 :多机箱多链路PPP用一个卸载路由器作为堆栈组成员

注意: 您能创建使用另外接入服务器、交换和路由器平台的堆栈组。然而,不应该与ISDN一起通用接入服务器例如Cisco AS5200。应该用接入服务器只执行这例如4x00平台。由于从中心局的呼叫分配用一个任意方式,此组合可能导致传送对一数字专用接入服务器的模拟呼叫,不能处理呼叫。

在路由器的一组的MMP支持要求每个路由器配置支持以下:

  • 多链路 PPP

  • 堆栈组竞标协议(SGBP)

  • 克隆接口配置使用的虚拟模板支持MMP

虚拟配置文件

虚拟配置文件是能创建并且动态地配置虚拟访问接口的一唯一点对点协议(PPP)应用程序,当拨入呼叫接收时和动态地切断接口,当呼叫结束时。虚拟配置文件与直接的PPP和与多链路PPP (MLP)一起使用。

虚拟配置文件虚拟访问接口的配置信息能来自自虚拟模板接口,或者在验证、授权和统计(AAA)服务器或者两个存储的用户专有配置。

虚拟配置文件使用的user-specific aaa配置是接口配置和在LCP协商中下载。另一个功能,呼叫每位用户配置,也使用从AAA服务器得的配置信息。然而,每位用户配置使用在NCP协商中(例如访问列表和路由过滤器)下载的网络配置

两个规则由虚拟配置文件虚拟模板接口和AAA配置管理虚拟访问接口配置:

  • 每个虚拟访问应用能有,至多的一个模板克隆的。然而,它能有克隆的多个AAA配置(虚拟配置文件AAA信息和AAA每用户配置,也许反过来包括多个协议的配置)。

  • 当虚拟配置文件由虚拟模板时配置,其模板比其他虚拟模板有高优先级。

请参阅下面“与其他Cisco拨号特性”部分的互通性关于取决于在线状态或缺乏由MLP或另一个虚拟访问功能克隆虚拟模板接口可能的配置顺序的说明。

此功能在支持MLP的所有Cisco IOS平台运行。

对于在此部分提及的命令的完整说明,参考“虚拟配置文件发出命令”在拨号解决方案命令参考的章节在Cisco IOS文档集。要找出在本章出现其他命令的文档,您能使用命令参考主索引或搜索联机。

背景信息

在您开始配置它前,此部分引见关于虚拟配置文件的背景信息帮助您了解此应用程序。

限制

我们建议未编号的地址用于虚拟模板接口保证相同的网络地址在虚拟访问接口没有创建。

先决条件

使用用户专有的AAA接口配置信息与虚拟配置文件要求为AAA将配置的路由器并且要求AAA服务器有特定用户接口配置AV对。相关AV对(在RADIUS服务器)开始如下:

cisco-avpair = "lcp:interface-config=...",

跟随等号的信息(=)可能是所有Cisco IOS接口配置命令。例如,线路也许下列:

cisco-avpair = "lcp:interface-config=ip address 200.200.200.200 
255.255.255.0",

使用与虚拟配置文件的一个虚拟模板接口要求为虚拟配置文件特别地将定义的虚拟模板。

与其他Cisco拨号特性的互通性

虚拟配置文件与Cisco DDR、多链路PPP (MLP)和拨号程序兼容例如ISDN。

物理接口DDR配置

当其他虚拟访问接口应用程序没有配置时,虚拟配置文件与物理接口充分地兼容在以下DDR配置状态:

  • 拨号配置文件为接口配置。拨号配置文件使用而不是虚拟配置文件配置。

  • DDR在接口没有配置。虚拟配置文件改写当前配置。

  • 传统DDR在接口配置。虚拟配置文件改写当前配置。

注意: 如果使用拨号接口(包括任何ISDN拨号程序),其配置在物理接口使用而不是虚拟配置文件配置。

对虚拟访问接口配置的多链路PPP作用

如表16-8所显示,虚拟访问接口的确切的配置取决于以下三个要素:

  • 虚拟配置文件是否配置由虚拟模板,由AAA,由两个,或者由两者都不。这些状态显示作为“仅VP VT”, “仅VP AAA”, “VP VT和VP AAA”,和“没有VP”,分别,在表里。

  • 出现或缺乏拨号接口。

  • 在线状态或无MPL。列标签“MLP”是暂时代替支持MLP和克隆从虚拟模板接口的所有虚拟访问功能。

在表16-8, “多链路VT”意味着虚拟模板接口被克隆,如果一个人为MLP或使用MLP的虚拟访问功能定义。

表16-8 :虚拟配置文件配置克隆顺序

虚拟配置文件配置 MLP没有拨号程序 MLP拨号程序 没有MLP没有拨号程序 没有MLP拨号程序
仅VP VT VP VT VP VT VP VT VP VT
仅VP AAA (多链路VT) VP AAA (多链路VT) VP AAA VP AAA VP AAA
VP VT和VP AAA VP VT VP AAA VP VT VP AAA VP VT VP AAA VP VT VP AAA
没有VP (多链路VT) 拨号程序 虚拟访问接口没有创建。 虚拟访问接口没有创建。

项目定货在表的所有信元的是重要。那里VP VT显示如上VP AAA,意味着虚拟配置文件虚拟模板在接口首先被克隆,用户的AAA接口配置然后应用对它。用户专有的AAA接口配置添加到配置并且改写所有相冲突的物理接口或虚拟模板配置命令。

与使用虚拟模板的其它特性的互通性

虚拟配置文件与克隆虚拟模板接口的虚拟访问应用也兼容。每个虚拟访问应用能有,至多的一个模板克隆的,但是能从多个AAA配置克隆。

虚拟配置文件和其他虚拟模板应用程序之间的交互作用如下:

  • 如果虚拟配置文件启用,并且虚拟模板为它定义,使用虚拟配置文件虚拟模板。

  • 如果虚拟配置文件由单独AAA配置(虚拟模板没有为虚拟配置文件定义),另一个虚拟访问应用的(例如VPDN虚拟模板)可以被克隆在虚拟访问接口上。

  • 虚拟模板,若有,被克隆对在虚拟配置文件AAA配置或AAA每用户配置前的一个虚拟访问接口。AAA每用户配置,若被采用,是应用的为时。

术语

以下新建的或不常见期限用于本章:

AV对:在AAA服务器的一个配置参数;AAA服务器发送到路由器的一部分的用户配置,以回应使用物精确的授权请求。路由器解释每个AV对作为Cisco IOS路由器配置命令并且运用AV对按顺序。在本章,期限AV对是指在RADIUS服务器的一个接口配置参数。

虚拟配置文件的一个接口配置AV对能采取一表例如此:

cisco-avpair = "lcp:interface-config=ip address 1.1.1.1 255.255.255.255.0",

克隆:创建和配置虚拟访问接口通过应用从一个特定虚拟模板的配置命令。虚拟模板是通用的用户信息和与路由器有关的信息的来源。克隆结果是配置的与所有in命令模板。

虚拟访问接口:动态地创建并且临时地存在一个唯一虚拟接口的实例。虚拟访问接口可以由不同的应用程序不同地创建和配置,例如虚拟配置文件和虚拟专用拨号网络。

虚拟模板接口:通用接口配置某些用户的或有些目的,加上与路由器有关的信息。这采取Cisco IOS接口命令列表的表应用到虚拟接口当必要时。

虚拟配置文件:动态地创建,当某些用户用户调用和动态地被切断,当呼叫断开一个唯一虚拟访问接口的实例。一个特定用户的虚拟配置文件可以由虚拟模板接口配置,在AAA服务器存储的特定用户接口配置或者一个虚拟模板接口和特定用户接口配置从AAA。

虚拟访问接口的配置开始与虚拟模板接口(若有),跟随由用户专有配置的申请对特定用户的拨入会话(若有)。

有注解的PPP协商示例

在本例中, ping启动ISDN链路在路由器MontecitoGoleta之间。注意,而没有在本例中的时间戳,通常推荐您使用全局配置命令service timestamps debug datetime msec

/image/gif/paws/10202/bri-num.gif

图16-12 :路由器-ISDN-路由器

这些调试从Montecito采取;然而,在Goleta的调试将查找同样。

注意: 您的调试在一个不同的格式可能出现。此输出是更旧的Ppp调试输出格式,在IOS版本介绍的修改前11.2(8)。请参阅章节17关于Ppp调试示例在更新的IOS版本的。

Montecito#show debugging
 
  PPP:
 
    PPP authentication debugging is on
 
    PPP protocol negotiation debugging is on
 
A
 Montecito#ping 172.16.20.2
 
    
  Type escape sequence to abort.
 
  Sending 5, 100-byte ICMP Echoes to 172.16.20.2, timeout is 2 seconds:
 
    
B
 %LINK-3-UPDOWN: Interface BRI0: B-Channel 1, changed state to up
 
C
 ppp: sending CONFREQ, type = 3 (CI_AUTHTYPE), value = C223/5
 
C
 ppp: sending CONFREQ, type = 5 (CI_MAGICNUMBER), value = 29EBD1A7
 
D
 PPP BRI0: B-Channel 1: received config for type = 0x3 (AUTHTYPE)
value = 0xC223 digest = 0x5 acked
 
D
 PPP BRI0: B-Channel 1: received config for type = 0x5 (MAGICNUMBER)
value = 0x28FC9083 acked
 
E
 PPP BRI0: B-Channel 1: state = ACKsent fsm_rconfack(0xC021): rcvd id 0x65
 
F
 ppp: config ACK received, type = 3 (CI_AUTHTYPE), value = C223
 
F
 ppp: config ACK received, type = 5 (CI_MAGICNUMBER), value = 29EBD1A7
 
G
 PPP BRI0: B-Channel 1: Send CHAP challenge id=1 to remote
 
H
 PPP BRI0: B-Channel 1: CHAP challenge from Goleta
 
J
 PPP BRI0: B-Channel 1: CHAP response id=1 received from Goleta
 
K
 PPP BRI0: B-Channel 1: Send CHAP success id=1 to remote
 
L
 PPP BRI0: B-Channel 1: remote passed CHAP authentication.
 
M
 PPP BRI0: B-Channel 1: Passed CHAP authentication with remote.
 
N
 ipcp: sending CONFREQ, type = 3 (CI_ADDRESS), Address = 172.16.20.1
 
P
 ppp BRI0: B-Channel 1: Negotiate IP address: her address 172.16.20.2 (ACK)
 
Q
 ppp: ipcp_reqci: returning CONFACK.
 
R
 PPP BRI0: B-Channel 1: state = ACKsent fsm_rconfack(0x8021): rcvd id 0x25
 
S
 ipcp: config ACK received, type = 3 (CI_ADDRESS), Address = 172.16.20.1
 
T
 BRI0: install route to 172.16.20.2
 
U
 %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0: B-Channel 1,
changed state to up
 

A -流量生成为了启动拨号尝试。

B -连接被建立(用于此示例没的ISDN调试)。

开始LCP :

C - Montecito发送LCP配置请求AUTHTYPE的和MAGICNUMBER的。

D - Goleta发送其CONFREQ。如果MAGICNUMBER的值是相同的作为Montecito发送的值,有强可能性线路循环。

E -这表明Montecito发送了确认对Goleta's CONFREQs

F - Montecito接收从Goleta的CONFACK。

开始认证阶段:

G, H - MontecitoGoleta挑战验证的。

J - Goleta应付挑战。

K, L - Goleta顺利地通过验证。

M -消息从GoletaMontecito :成功的验证。

NCP协商开始:

N, P -每个路由器发送其在CONFREQ的配置的IP地址。

问, R - Montecito发送CONFACK对Goleta's CONFREQ

S - ?反之亦然。

T, U -路由从Montecito安装到Goleta,并且在接口的协议更改对“”,表明NCP协商顺利地完成。

在呼叫Cisco系统TAC小组前

呼叫Cisco系统技术支持中心(TAC)之前,保证您通读了本章,并执行完了您的系统问题的建议措施。

另外,执行以下操作,并记录结果,以便我们能够更好地为您提供帮助:

对于所有问题,请收集show running-configshow version输出。保证service timestamps debug datetime msec命令在配置里。

对于DDR问题,请收集以下:

如果ISDN是包含的,请收集:

  • show isdn status

  • debug isdn q931

  • debug isdn events

如果调制解调器是包含的,请收集:

  • show lines

  • show line [x]

  • show modem (如果集成调制解调器是包含的)

  • show modem version (如果集成调制解调器是包含的)

  • debug modem

  • debug modem csm (如果集成调制解调器是包含的)

  • debug chat (如果DDR方案)

如果T1或PRI是包含的,请收集:

  • show controller t1

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 10202