广域网 : 帧中继

使用浮动静态路由为广域网链路配置ISDN备份

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

通过使用浮动静态路由和按需拨号的(DDR)路由,此配置示例显示您如何备份与综合业务数字网络(ISDN)的一条帧中继链路。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

此配置使用下面软件和硬件版本开发并且被测试。

  • Cisco 2503 路由器

  • Cisco IOSï ¿  ½软件版本12.2(7b)在两路由器运行

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景理论

如果发生故障,广域网链路一个实施目标是提供方式备份链路。ISDN频繁地提供此备份。思科提供能达到同一个功能的备份策略,但是用不同的方式。如果路由信息在帧中继链路间通过,浮动静态路由能启动备份链路帧中继链路是否停止通过信息。

注意: 使用浮动静态路由,此示例显示帧中继的一个备份。然而,您能也使用此方法备份所有广域网链路。

其他解决方案能使用备份接口(请参阅配置备份接口关于子接口)或Dialer Watch。如果使用backup interface命令方法,点对点子接口是有利的,因为主要或多点接口能在UP/UP状态依然是,即使永久虚拟连接(PVC)下来与帧中继匹配。

关于配置DDR备份的更多信息,参考配置和故障排除DDR备份文件。您能也参考本文评估备份接口、浮动静态路由和Dialer Watch DDR备份的关于多种DDR备份方法的更多信息。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要寻找关于用于本文的命令的其他信息,请使用IOS的命令查找工具。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/10214/fr_isdn_backup.gif

配置

本文档使用如下所示的配置。

此配置是在2500系列路由器的测试的使用Cisco IOS软件版本12.2(7b)。相同的配置概念将适用于一个相似的路由器结构或其他Cisco IOS版本。

Router1 (思科2503路由器)
Current configuration:

version 12.2
!
hostname Router1
!

!--- This username password pair is used for 
!--- PPP CHAP authentication

username Router2 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0

!--- Primary Link.
!--- The bandwidth is adjusted to allow for rapid backup of the link.


!--- This adjusts the EIGRP Hello interval and 
!--- Hold time for rapid convergence.
!--- The bandwidth command does not actually change the bandwidth of the link,
!--- it only adjusts the routing protocol bandwidth parameter.

 bandwidth 2048
 ip address 172.16.2.1 255.255.255.128
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0

! -- Backup link.

 ip address 172.16.3.1 255.255.255.0

! -- The backup link is in a different subnet.
! -- The BRI interface on the peer should also be in this subnet.

 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer map ip 172.16.3.2 name Router2 broadcast 5552000

! -- Dialer map for the peer. Note the IP address and name.
! -- The name must match the authenticated username of the peer.

 dialer load-threshold 5 either
 dialer-group 1

! -- Apply interesting traffic definition.
! -- Interesting traffic definition is defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink
!
router eigrp 100

!--- This example uses eigrp. 
!--- You can use any routing protocol instead.

 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.4.0 255.255.255.0 172.16.3.2 200

!--- The floating static route is defined.
!--- Note the administrative distance of the route is 200.
!--- Hence it is only used when all other routes for 172.16.4.0/24 
!--- are lost. Note that the next hop for the floating static route 
!--- matches the dialer map ip. If the nexthop is not the same as 
!--- in the dialer map then the router will no dial.

!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any

!--- EIGRP routing packets are denied in the dialer-list.


!--- This prevents eigrp packets from keeping the link up.
!--- Adjust the interesting traffic depending on your traffic definitions.

!
dialer-list 1 protocol ip list 100

!---  Interesting traffic defintion. Use access-list 100.
!---  The interesting traffic is applied to BRI interface 
!--- using dialer-group 1. 

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

浮动静态为Router1配置。浮动静态路由有已分配管理距离200。相同子网的一个路由在帧中继链路也将了解通过增强的内部网关路由选择协议(EIGRP),强调浮动路由的另外或冗余本质。EIGRP获知的路由在路由表里将安装由于其更短的管理距离90,与那静态路由比较200。在帧中继链路失败情形下, EIGRP路由从路由表将消失,浮动静态路由安装。在ISDN连接间将发送的所有关注数据流启动线路。当连接在帧中继时恢复,再了解路由通过EIGRP。此路由再次替换静态路由和直接数据流在帧中继电路。

路由协议流量被标记作为非触发的在拨号器列表,以便不造成ISDN专线连接或依然是已连接。然而,一次链路是UP, EIGRP数据包能流过链路,并且两路由器能交换路由信息。广播关键字在拨号映射语句包括允许路由协议流量段落在ISDN链路的。如果不希望EIGRP交换路由信息,即使ISDN链路是UP,请勿包括广播关键字在拨号映射语句。

dialer load-threshold命令设置将触发在第二条B信道将放置的并发呼叫的负载。多链路点对点协议(PPP)配置(PPP多链路),以便两个ISDN B信道可以一起被捆绑作为聚合带宽的一个虚拟访问接口。

在当前配置中,仅Router1配置发出呼叫。Router2从Router1的接收呼叫。如果希望两边启动链路,请添加dialer mapdialer load-threshold命令到Router2的配置。

Router2 (思科2503路由器)
Current configuration:

version 12.2
!
!
hostname Router2
!
username Router1 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 bandwidth 2048
 ip address 172.16.2.2 255.255.255.128
 encapsulation frame-relay
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
 clockrate 64000
!
interface BRI0
 ip address 172.16.3.2 255.255.255.0

! -- IP address of backup interface.
! -- This router accepts the call. Note the IP address matches both the 
! -- dialer map floating static router nexthop on the peer.

 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink

!--- The missing dialer map command disables 
!--- this router from making the call.

!
router eigrp 100
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1 200
!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
line con 0
line aux 0
line vty 0 4
!
end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

路由表更改

注意: 确定请显示命令支持Output Interpreter Tool,允许您查看show命令输出分析;

从Router1观察下面路由表。注意浮动静态路由替换EIGRP学到的路由,在Router2变得不可得到在帧中继链路后。

当帧中继链路是UP时,如下所示Router1路由表。

Router1#show ip route      
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
            inter area      
            * - candidate default, U - per-user static route, o - ODR 
            P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
      [D 172.16.4.0/2490/1787392] via 172.16.2.2, 00:06:56, Serial0
     
!---  EIGRP learned route over Frame Relay link 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

当在帧中继链路的连接丢失时, Router1在其路由表里安装浮动静态路由如下所示。

Router1#show ip route 
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
     S 172.16.4.0/24 [200/0] via 172.16.3.2 
     
!--- Floating static route. Administrative distance is 200 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

对网络172.16.4.0/24的所有关注数据流当前启动ISDN连接。例如,从Router1,对172.16.4.1的一ping启动ISDN链路如下所示。

注意: 如果使路由协议触发的,则日常流量自动地启动链路。此的下侧可能是链路将无限地依然是,造成高长途费用。

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms 
Router1# 
3d22h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
3d22h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up 
3d22h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552000 Router2 
Router1# 

因为ISDN专线是UP, EIGRP当前开始在ISDN连接的exchaging的路由信息。这造成Router1安装EIGRP路由到其路由表,指向下个跳越172.16.3.2。

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

Gateway of last resort is not set 

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks 
D      172.16.4.0/24 [90/40537600] via 172.16.3.2, 00:00:17, BRI0

!--- EIGRP route learnt over the ISDN link 

C      172.16.3.2/32 is directly connected, BRI0 
C      172.16.1.0/24 is directly connected, Ethernet0 
C      172.16.2.0/25 is directly connected, Serial0 
C      172.16.3.0/24 is directly connected, BRI0 
Router1# 

关注数据流是将发起ISDN呼叫的流量和由dialer-list命令定义。在上述配置中,拨号列表指向允许除了EIGRP数据包的所有IP信息包的访问列表编号100。这意味着,所有IP信息包,除了EIGRP数据包,能启动ISDN连接。一旦联系被建立,所有流量,包括EIGRP流量,允许在链路间去。但是,如果关注数据流不流过ISDN链路处于拨号空闲计时器的,链路将减少,并且EIGRP路由不会被交换。这时,浮动静态路由在Router1路由表里再将安装。

故障排除

关于排除故障的信息浮动静态路由参考配置和故障排除DDR备份文件。本文讨论常见的症状例如:

  • 当主链路断开时,备份链路没有拨号。

  • 备份链路拨号,但是不连接对另一侧。

  • 备份链路,当主链路恢复时,没有撤销。

  • 备份链路不稳定的(例如,摆动),当主要接口发生故障时。

参考的帧中继特定故障排除配置配置帧中继备份

以下命令可帮助排除故障备份链路。:

在尝试以上任何一个调试指令前,请参阅关于调试指令的重要信息

调试输出

路由协议流量(EIGRP)被标记作为非触发的由dialer list命令,因此它不会启动链路也保持它。然而,当链路是活跃的,路由更新将被交换。如果正确流量能启动链路, debug dialer packet命令能验证。输出如下所示。

Router1#debug dialer packets 
Dial on demand packets debugging is on 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: cdp, 273 bytes, outgoing uninteresting (no list matched) 

关注数据流(互联网控制消息协议(ICMP)响应在这种情况下)将重置空闲计时器并且保持链路作为下面。如果空闲计时器超时,无关的流量通过,但是不会保持链路。

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/51/80 ms 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping) 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 

虽则,因为联系由触发的ICMP流量,已经建立标记作为非触发的, EIGRP数据包流过ISDN链路。


相关信息


Document ID: 10214