拨号和接入 : 按需拨号路由 (DDR)

拨号程序配置文件的配置与故障排除

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档提供了对 Dialer Profiles 进行配置和故障排除的提示。

先决条件

要求

本文档的读者应具备以下方面的知识:

  • 传统 DDR(Dialer Maps 和拨号程序循环组)

  • PPP 质询握手身份验证协议 (CHAP) 和口令身份验证协议 (PAP)

  • 主叫方 ID (CLID) 和 Dialed Number Identification Service (DNIS)

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • 拨号配置文件在Cisco IOS�软件版本11.2首先介绍。

  • 本文档中的说明适用于 Cisco IOS 软件版本 12.0(7)T 及更高版本。本文档不讨论以前 Cisco IOS 软件版本中的拨号程序配置文件行为。

  • 由于对 Dialer Profiles 进行了更改,我们建议您运行 Cisco IOS 软件版本 12.1 或更高版本。Dialer Profiles 可用于任何具有 ISDN 接口的 Cisco 路由器。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

使用 Software Advisor 工具仅限注册用户)可验证您运行的 Cisco IOS 软件版本是否支持此功能。

提示: 在 Software Advisor 工具中,搜索名为 Dynamic Multiple Encapsulation for Dial-in over ISDN 的功能。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

传统按需拨号路由 (DDR) 虽然可在许多情况下使用,但在您要通过为不同用户定义不同特性来区分用户的情况下会存在限制。使用传统 DDR 无法实现这种区分。Dialer Profiles 被设计为一个新的 DDR 模型,允许在路由器上配置用户特定配置文件;配置文件确定了特定用户的特性,并且配置文件会动态绑定到物理接口(例如,异步或基本速率接口 - BRI)以用于传入或传出 DDR 呼叫。Dialer Profiles 支持将点对点协议 (PPP)、高级数据链路控制 (HDLC)、帧中继或 X.25 封装用于入站或出站拨号。PPP 封装是推荐的方法,本文档会重点介绍 PPP。

拨号程序配置文件对您是否合适?

请回答以下问题以确定 Dialer Profiles 是否为您的配置的最佳之选。应将答案为“不关心”的任何问题解释为回答为“否”。您应将以下问题的答案应用于下面显示的流程图以确定要使用的最佳方法。

  1. 是否存在用户特定要求?换句话说,是否需要在用户之间以不同方式应用功能(例如,压缩、空闲超时、第 3 层编址或任何其他服务或功能)?

  2. 是否会连接到 200 个以上的站点(无论呼叫方向任何)?

    注意: 200 个站点是一个任意数目,超过该数目时,网络扩展会成为重要问题。

  3. 是否存在出站拨号要求?

请使用下面的流程图来获取最佳 DDR 实现方法。

DDR 解决方案比较流程图

/image/gif/paws/10219/23-4.gif

有关传统 DDR 的详细信息,请参阅按需拨号路由配置上的“Cisco IOS 拨号技术配置指南”一章。

有关 Virtual Profiles (VP) 的详细信息,请参阅虚拟模板、配置文件和网络上的“Cisco IOS 拨号技术配置指南”一章。

有关大规模拨出 (LSDO) 的详细信息,请参阅配置大规模拨出上的“Cisco IOS 拨号技术配置指南”一章。

拨号配置文件与传统 DDR 相比的优点

  • 与传统 DDR 不同,拨号程序配置文件是点对点接口。这个事实减轻了第 3 层到第 2 层映射要求以及管理多个映射的附加复杂性。

  • 使用不同的第 3 层网络地址配置物理接口的不同成员。

  • Dialer Profiles 允许物理接口根据传入或传出呼叫要求而呈现不同特性。

  • 允许备份接口在主接口运行时是非专用的并且可用。

  • 控制进入和离开 DDR 接口的最小或最大连接数目。

  • 可以为 ISDN 接口的每个 B 信道设置不同的 DDR 参数。

示例情况

使用 Dialer Profiles 的常见情况包括:

  • 路由器需要连接到多个站点,并且对等体位于不同子网上。

  • 物理接口必须用于正常 DDR 并向广域网链路提供备份

  • 需要为特定连接保留某些 B 信道

  • 对等体运行不同的封装(例如,HDLC 和 PPP)。

    注意: 此功能需要 Cisco IOS 软件版本 12.0(7)T 或更高版本

  • 某些连接可能需要多个信道,而其他连接只需要单个信道

  • 每个连接需要不同的空闲超时值。

  • 每个连接需要不同的相关流量定义

  • 对等体的 IP 地址未知

  • ISDN B 信道(在 PRI 中)需要不同的配置

请注意,上面所述的大多数情况是适合使用 Dialer Profiles 的每用户相关问题。请记住,上面的列表并不包括可以使用 Dialer Profiles 的所有情况。

限制条件

Dialer Profiles 具有已知限制。例如:

  • 除非启用了基于 CLID 的绑定(需要 Cisco IOS 软件版本 12.0(7)T 或更高版本),否则必须在物理接口和拨号程序接口上启用 PPP 认证和多链路。

  • 每个拨号程序接口都使用一个接口描述块 (IDB),此块是用于管理接口的内部结构。允许有限数目的 IDB(取决于 Cisco IOS 软件版本和平台);这意味着 Dialer Profiles 不能针对大型 DDR 应用程序进行扩展。有关各种平台的 IDB 限制的详细信息,请参阅 Cisco IOS 平台的最大接口子接口数目:IDB 限制

  • 在拨号程序配置文件中,没有用于配置共享相同特性的一组用户的通用拨号程序配置文件(甚至默认配置文件)的方法。每个用户必须具有自己的配置文件。

    提示: 将 Virtual Profiles 与 Dialer Profiles 结合使用。Virtual Profiles 可以提供出色的“默认配置文件”。

  • 对于传入连接,如果不先应答呼叫并产生费用,就无法限制对配置文件的传入呼叫量。

拨号程序配置文件组件

拨号程序配置文件包括以下元素:

  • 拨号程序接口 - 一个逻辑实体,用于定义用户特定拨号程序配置文件。所有用户特定配置设置都位于拨号程序接口配置下;例如,第 3 层协议地址、相关流量、超时。请注意,此拨号程序接口与用作带有传统 DDR 的循环组的拨号程序接口完全不同。为进行此讨论,应将拨号程序配置文件和拨号程序接口视为同义词。

  • 拨号程序池 - 每个拨号程序接口都是一个拨号程序池的成员;池是包含一个或多个物理接口的组。池中可具有各种接口(异步、ISDN、串行)的任意组合。特定物理接口的出站拨号争用是使用 dialer pool-member priority 命令来解决的。

  • 物理接口 - 接口(如 BRI 和异步)配置为一个或多个池的成员,并且至少针对接口所属的拨号程序池的封装参数和标识而进行配置。除非启用了基于主叫方 ID (CLID) 的绑定,否则还必须在物理接口上配置 PPP 认证和多链路 PPP(如果适用)。

下图描述了 Dialer Profiles 的这些不同元素间的示例交互。

/image/gif/paws/10219/23-1.gif

了解使用拨号程序配置文件时的Dialer Profiles

下面,我们将详细说明按每个呼叫将 Dialer Profiles 动态绑定到物理接口的概念。

特定对等体的配置信息包含在拨号程序配置文件中。在通过物理端口将该特定对等体拨入或拨出之后,路由器必须将远程拨号程序配置文件绑定到物理接口。由于路由器上可能配置了多个 Dialer Profiles,因此必须正确选择要为任何给定呼叫(传入或传出)绑定的配置文件。在讨论涉及拨出或拨入的这一主题时,我们提供了一个分步过程,然后是一个流程图。请在使用分步过程时参考该流程图。

拨出

此方案非常类似于拨号程序循环组的操作;物理接口具有特定连接的拨号程序配置文件的特性。绑定过程如下所示:

  1. 传入数据包到达路由器;路由表查找会通过一个拨号程序接口指示其目标地址。

  2. Cisco IOS 软件会注意到该拨号程序接口是一个拨号程序配置文件。如果不存在此配置文件的现有连接,则会标识该拨号程序接口所关联的池。

  3. 如果存在现有连接,则将数据包排队到该物理接口,并且如果流量是“相关的”,则会重置空闲计时器。

  4. 如果不存在现有连接,则会按照 dialer-list 检查流量,以确定它是否是相关的。如果不是相关的,则会丢弃数据包。如果它是相关流量,则继续执行步骤 5。

  5. 如果不存在现有连接,则 Cisco IOS 软件会搜索属于具有最高拨号程序池优先级的拨号程序接口的物理接口。这是将用于拨号的接口。此接口绑定到拨号程序接口,从而使物理接口采用拨号程序接口的配置。

  6. Cisco IOS 软件拨打拨号程序配置文件的电话号码,此时会执行正常的 DDR 步骤。

  7. 如果对等体的身份验证名称与传出拨号程序配置文件中的 dialer remote-name 不匹配,则呼叫断开。

拨出流程图

23-2.gif

无论拨号程序池是由 ISDN 接口、异步接口还是两者混合组成,此顺序都相同。

来自配置文件的出站呼叫数目可使用最小和最大阈值进行管理(使用 dialer pool-member pool_number max-link number min-link number 命令)。最小阈值用作保留系统,而最大阈值可防止配置文件的过度使用。一旦达到阈值,就不允许在该配置文件上进行更多传出呼叫。

拨入

传入呼叫的拨号程序配置文件绑定更加复杂,因为传入接口可能是多个池的成员,并且这些池可与多个 Dialer Profiles 关联。如果无法进行动态绑定,则呼叫就会断开。绑定过程如下所示:

注意: 此过程按执行顺序显示,并且在找到第一个匹配时,呼叫会绑定到拨号程序接口。

  1. 如果物理接口仅是一个池的成员,并且仅有一个拨号程序配置文件与此拨号池关联,则将物理接口绑定到此拨号程序配置文件。

    注意: 仅当单个已配置拨号程序配置文件不具有 dialer callerdialer called 时,才会执行此步骤。如果配置了任一命令,则仅当存在成功匹配时才执行此绑定。

  2. 尝试从在拨号程序接口中使用 dialer caller 命令的呼叫来匹配主叫方 ID (CLID);仅检查与物理接口是其成员的池相关联的配置文件。如果找到匹配,则将物理接口绑定到匹配的拨号程序配置文件。如果此检查因任何原因而失败,请继续执行下一步以进一步尝试绑定。有关 dialer caller 的详细信息,请参阅文档使用主叫方 ID 的 ISDN 认证和回叫。如果电话公司未提供 CLID,或未在拨号程序配置文件中配置 dialer caller,则会跳过此步骤。

  3. 尝试使用由电话公司在传入呼叫 Q.931 设置消息中提供的 DNIS 及 ISDN 子地址信息进行绑定。将按照每个拨号程序配置文件中的 dialer called 命令来检查此传入呼叫 DNIS 和子地址信息。如果找到匹配,则绑定成功;否则,它会移动到下一个条件。

    注意: 仅当传入呼叫 Q.931 设置消息中存在 ISDN 子地址信息,并且在拨号程序配置文件中正确配置了 dialer called 命令时,才允许进行 DNIS 绑定。ISDN 子地址主要在欧洲和澳大利亚使用,在北美地区不常用。

  4. 如果物理接口是针对 PPP 认证配置的,请应答呼叫并对远程对等体进行身份验证。请使用经过身份验证的名称来标识配置了相同名称的拨号程序配置文件(使用 dialer remote-name 命令)。仅检查与物理接口是其成员的池相关联的配置文件。如果找到匹配,则将物理接口绑定到匹配的拨号程序接口。如果此检查因任何原因而失败,则绑定尝试算法失败,呼叫断开。

/image/gif/paws/10219/23-3a.gif

请注意,绑定并不表示成功连接。它仅表示物理接口现在具有要使用的配置。然而,呼叫仍可能因其他原因(例如,IP 控制协议 (IPCP) 失败)而断开。

一旦绑定成功,并且设备通过身份验证,路由器就会检查 dialer remote-name 是否与对等体经过身份验证用户名相匹配。如果名称不匹配,则呼叫断开。

只能使用主叫方 ID 或 DNIS 来绑定同步 ISDN 呼叫。目前还没有做出任何尝试来使用提供的 CLID/DNIS,在调节解调器呼叫是偶然通过 ISDN BRI 或 PRI 连接来提供的情况下对调节解调器呼叫进行绑定。

来自配置文件的入站呼叫的数目可使用最大阈值来管理(dialer pool-member 命令中的 max-link 选项)。最大阈值可防止配置文件的过度使用。路由器对呼叫进行应答,以确定呼叫针对哪个配置文件以及是否达到了配置文件最大连接限制。如果达到最大值,则呼叫断开。

拨号程序配置文件配置任务汇总

若要配置 Dialer Profiles,请执行以下任务:

  1. 配置一个或多个拨号程序接口。特定于目标的所有配置设置都位于拨号程序接口配置中。

    步骤 命令 目的
    1. interface dialer number 创建拨号程序接口。
    2. ip address ip_address subnet_maskip unnumbered interfaceip address negotiated 指定拨号程序接口的 IP 地址和掩码,该拨号程序接口作为所呼叫的目标网络中的节点。您还可以不对连接至路由器上另一个 Up/Up 接口的接口进行编号,或者可以在 IPCP 协商过程中获取地址
    3. encapsulation ppp 指定 PPP 封装。
    4. (可选)ppp authentication chap|pap [callin] 指定 PPP 认证方法。仅当不执行基于 CLID 或 DNIS 的绑定时才需要此命令。有关详细信息,请参阅拨入部分。
    5. dialer caller number 配置对等体的主叫方 ID (CLID)(用于绑定)。确保电话公司在传入呼叫 SETUP 消息中提供 CLID。
    6. (可选)dialer called DNIS:subaddress 指定可以用于绑定的 DNIS 和子地址信息。此信息主要在欧洲和澳大利亚使用。

    注意: 配置 DNIS 和子地址;否则,对此配置文件进行的每个 DNIS 绑定尝试都会失败。

    7. dialer remote-name username 指定远程路由器身份验证名称。如果未正确指定用户名,则呼叫将会断开。
    8. dialer string dial-string class class-name 指定所呼叫的远程目标以及为对此目标进行的呼叫定义特性的映射类。映射类是可选的。仅当路由器进行出站呼叫时,才需要此命令。
    9. dialer pool pool-number 指定用于对此目标进行呼叫的拨号池。
    10. dialer-group group-number 将拨号程序接口分配给拨号程序组。这会将相关流量定义应用于该接口。
    11. dialer-list group-number protocol protocol-name{permit|拒绝|list} access-list-number 通过列表编号或协议和列表编号指定访问列表(在全局配置模式下),以定义可以触发呼叫的“相关”数据包。group-number 必须与步骤 9 中的编号相同

  2. (可选)配置映射类以根据每个呼叫目标,为不同类型的呼叫指定不同特性。有关详细信息,请参阅配置 map-class dialer 命令部分。

  3. 配置物理接口。

    步骤 命令 说明
    1. interface interface_type number 配置 Dialer Profiles 的物理接口参数。
    2. (可选)encapsulation ppp 指定 PPP 封装作为默认设置。您还可以配置 x25、帧中继、HDLC 等。虽然物理接口使用 PPP 封装,但在 B 信道上运行的实际封装由绑定到此接口的拨号程序配置文件上配置的封装确定。
    3. (可选)ppp authentication chap|pap [callin] 指定 PPP 认证方法。仅当不执行基于 CLID 或 DNIS 的绑定时才需要此命令。有关详细信息,请参阅拨入部分。
    4. (可选)ppp multilink 允许此物理接口上存在 PPP 多链路。仅当不执行基于 CLID 或 DNIS 的绑定时才需要此命令。有关详细信息,请参阅拨入部分。
    5. dialer pool-member pool-number 将物理接口分配给拨号程序池。此池编号应与前一个表中步骤 9 中配置的编号相同。

    注意: 如果不是所有通过此物理接口进行的传入连接都使用 CLID 或 DNIS 进行绑定,则必须 在该物理接口上配置 encapsulation pppppp authenticationppp multilink(如果适用)。

  4. 配置 CHAP 或 PAP 认证的用户名和口令。有关配置 PAP 的详细信息,请参阅 PPP 口令身份验证协议 (PAP) 的配置和故障排除。有关 CHAP 信息,请参阅了解和配置 PPP CHAP 认证

  5. 通过将拨号程序接口作为下一跳来配置静态路由。

配置示例

/image/gif/paws/10219/dialer2.gif

在上图中:

  • 拨号程序接口 Dialer1 使用拨号程序池 10

  • 拨号程序接口 Dialer2 使用拨号程序池 20

  • 拨号程序接口 Dialer3 使用拨号程序池 30

  • BRI 0、BRI 1、BRI 2 属于拨号程序池 10

  • BRI 1、BRI 2 属于拨号程序池 20

  • BRI 2 属于拨号程序池 30

如果接口 Dialer1 需要建立 DDR 连接,则它会使用拨号程序池 10 中的一个 BRI。在本例中,来自 BRI 0、BRI 1 或 BRI 2 的 B 信道将用于呼叫。

如果拨号程序接口 Dialer2 需要进行 DDR 连接,则它会使用拨号程序池 20(通过分机 BRI 1 或 BRI 2)。

若要在拨号程序池内避免争用,可以对拨号程序池的物理接口设置优先级。

配置拨号程序接口

下面的示例配置演示了这些拨号程序接口配置任务:

interface Dialer1 
 ip address 1.1.1.1 255.255.255.0

 ! -- IP Address.  
 ! -- For simplicity keep this address in the same network as the peer.


 ! -- If needed, you can unnumber this to another interface instead.

 encapsulation ppp
 dialer remote-name Smalluser

 ! -- Authenticated remote name of the peer. 


 ! -- Verify that this name exactly matches the authenticated name of the remote.

 dialer string 5554540

 ! -- Number for outbound call. For inbound calls this is not needed.


 ! -- Multiple dial strings can be specified for the same dialer interface.

 dialer caller 5554540

 ! -- CLID information used for binding. 

 dialer pool 10

 !-- Member of dialer pool 10.


 !-- The dialer interface can only be a member of 1 pool(the reverse is not true).

 dialer-group 1

 ! -- Interesting traffic is defined by dialer-list 1.

!
interface Dialer2
 ip address 2.2.2.2 255.255.255.0
 encapsulation ppp
 dialer remote-name Mediumuser

 !-- Note that the remote-name is different from the other profiles.


 !-- Do not configure two dialer profiles with the same remote-name.

 dialer string 5554541
 dialer caller 5554541
 dialer load-threshold 50 either

 ! -- Load threshold (50/255=20%) for multilink ppp.

 dialer pool 20
 dialer-group 2
 ppp multilink

 ! -- Dialer 2 can perform Multilink PPP.

!
interface Dialer3
 ip address 3.3.3.3 255.255.255.0
 encapsulation ppp
 dialer remote-name Poweruser
 dialer string 5554542 class Eng

 !--- Dial 5554542 and use the map-class named "Eng" (defined below).

 dialer caller 5554542
 dialer hold-queue 10
 dialer load-threshold 80

 ! -- Load threshold (80/255=32%) for multilink ppp.

 dialer pool 30
 dialer-group 2
 ppp multilink

 ! -- Dialer 3 can perform Multilink PPP.

!
map-class dialer Eng

!--- Map-class named "Eng" that was used with the dialer string in Dialer3.

 isdn speed 56

注意: 为需要连接到的每个远程设备配置拨号程序接口。

配置拨号程序接口至少需要使用的命令:

  • 使用 dialer remote-name user-name 命令可指定远程目标。这是为身份验证传递的远程路由器名称。

  • 使用 dialer string string 命令可指定要拨打的号码(用于出站呼叫)。如有必要,您可以配置映射类。

  • 使用 dialer caller lookup 命令可指定对等体的 CLID。

  • 使用 dialer pool number 可将拨号程序接口绑定到拨号程序池。请注意,拨号程序接口只能与一个拨号程序池关联,但拨号程序池可与许多拨号程序接口关联。

  • dialer-group group-number 命令用于引用定义“相关”流量的拨号程序列表。

注意: dialer-list dialer-group protocol protocol-name{permit|拒绝|list access-list-number} 命令指定协议或访问列表编号,此协议或访问列表编号定义用于触发呼叫的“相关”数据包。

配置 map-class dialer 命令

您可以使用 map-class dialer class-name 命令来指定映射类并进入映射类配置模式。下表显示了各个选项:

命令 说明
dialer isdn [speed <56>]|[[no-spc] 指定 ISDN 线路速度 56Kbps。

注意: 64 Kbps 为默认设置。速度参数仅与 56 Kbps 线路速度结合使用;64 不是有效选项。

注意: 请与电话公司联系以确定这是否必要。

dialer idle-timeout number 指定进行呼叫时所使用的空闲计时器值。默认时间为 120 秒钟。

注意: 您还可以在拨号程序接口中配置空闲超时。

dialer fast-idle number 指定进行呼叫时所使用的快速空闲计时器值。存在物理接口拥塞时使用此命令。默认时间为 20 秒钟。
dialer wait-for-carrier-time number 指定进行呼叫时所使用的载波时间值。

注意: 上面显示的某些拨号程序命令可直接在拨号程序接口或映射类下进行配置。相同命令可以多次出现(可具有不同参数)。优先级顺序是从最高到最低:

  • 映射类参数

  • 接口参数

配置物理接口

使用 dialer pool-member number 命令可将物理接口分配给拨号程序池。您可通过使用此接口配置命令指定多个拨号程序池编号而将接口分配给多个拨号程序池。

使用此命令的 priority 可在拨号程序池内设置接口优先级。

interface BRI0
   no ip address
   encapsulation ppp
  
 ! -- Specify that the default encapsulation for this interface is ppp.
   ! -- Although BRI0 employs ppp encapsulation, the actual encapsulation
   ! -- running over the B-channels are determined by the one configured 
   ! -- on the dialer profile bound to this interface.

   dialer pool-member 10 priority 100

   ! -- BRI 0 is a member of pool 10.

  !
  interface BRI1
   no ip address
   encapsulation ppp
   dialer pool-member 10 priority 50
   
! -- BRI 1 is a member of pool 10.
   ! -- Note that the priority is less than BRI 0.

   dialer pool-member 20 priority 100
   
! -- BRI 1 is a member of pool 20.
   ! -- Note that the priority is higher than BRI 2.

  !  
  interface BRI2
   no ip address
   encapsulation x25
  
 ! -- Although BRI2 employs X25 encapsulation, 
   ! -- the actual encapsulation running over the B-channels 
   ! -- are determined by the one configured on the dialer profile
   ! -- bound to this interface.

   dialer pool-member 10 priority 10

   ! -- BRI 1 is a member of pool 10.
   ! -- Note that the priority is less than BRI 0 and BRI 1.

   dialer pool-member 20 priority 50

   ! -- BRI 2 is a member of pool 20.
   ! -- Note that the priority is lower than BRI 1.

   dialer pool-member 30
   ...
   ...
   ...

注意: 如果无法执行基于 CLID 或 DNIS 的绑定,则必须在物理接口下配置命令 encapsulation pppppp authentication chap|pap [callin]ppp multilink(如果适用)。

dialer pool-member 可选命令参数包括:

参数 说明
号码 设置拨号程序池编号。此编号是 1 到 255 之间的十进制值。
priority number 设置拨号程序池内物理接口的优先级。首先为拨出选择具有优先级编号的接口。此编号是 1 到 255 之间的十进制值。较大值表示更高的优先级。仅当物理接口上存在出站呼叫争用时,才需要此命令。
min-link number 为此拨号程序池保留的接口上的 ISDN B 信道。这是 1 到 255 之间的一个数字。可将其用作简单信道保留系统。
max-link number 设置为此拨号程序池保留的接口上 ISDN B 信道的最大数目。这是 1 到 255 之间的一个数字。

拨号程序配置文件示例配置

有关使用 Dialer Profiles 的全面示例配置,请参阅使用 Dialer Profiles 配置 ISDN DDR

有关非 PPP 配置示例,请参阅以下文档:

调整和可选命令

有关调整和可选命令的详细信息,请参阅文档使用 Dialer Profiles 命令的对等 DDR

验证拨号配置文件操作

show interface dialer1 命令显示有关传入和传入呼叫的信息:

Router# show interfaces dialer1
Dialer1 is up, line protocol is up (spoofing)

! -- The dialer interface is up/up(spoofing).
! -- Dialer interface is always up(spoofing) so that the route 
! -- to the dialer interface remains in the routing table.
! -- Refer to the Note below.

  Hardware is Unknown
  Internet address is 1.1.1.1/24

  ! -- IP address for the dialer interface.

  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation PPP, loopback not set

  ! -- Encapsulation on the dialer interface.

  DTR is pulsed for 1 seconds on reset
  Interface is bound to BRI0:1

  ! -- This dialer is bound to 1 B-channel. 

  Last input 00:00:38, output never, output hang never
  Last clearing of "show interface" counters 00:05:36
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     38 packets input, 4659 bytes
     34 packets output, 9952 bytes
Bound to:
BRI0:1 is up, line protocol is up


! -- B-channel to which Dialer1 is bound to.

  Hardware is BRI
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation PPP, loopback not set, keepalive not set
  Interface is bound to Dialer1 (Encapsulation PPP)

  ! -- Encapsulation applied by the dialer profile.

  LCP Open, multilink Open
  Last input 00:00:39, output 00:00:11, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: FIFO
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     78 packets input, 9317 bytes, 0 no buffer
     Received 65 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     93 packets output, 9864 bytes, 0 underruns
     0 output errors, 0 collisions, 7 interface resets
     0 output buffer failures, 0 output buffers swapped out
     4 carrier transitions

注意: 拨号程序接口始终至少处于 up/up 模式(欺骗)。“欺骗”一词是指线路实际未启动,但拨号程序强制线路表现为“启动”,这样上层协议就会继续按预期方式运行。欺骗是为了允许 DDR 工作而添加一种状态。接口为了响应路由给它的数据包而“按需拨号”。但是,由于数据包不会路由到“关闭”的接口,因此接口必须假装为已启动(欺骗),以便即使接口未连接,数据包也会路由到该接口。欺骗是按需拨号接口上的正常状态。

拨号程序配置文件故障排除

症状 debug 命令 解决方法
拨号从不发生 debug dialer 确认相关流量、路由配置、拨号程序电话号码和拨号程序池设置。
呼入呼叫连接不正确 debug dialer 确认三个绑定步骤之一是否将成功。
呼叫过早被断开,或者呼叫从不断开 debug dialer packet 确认相关数据包配置

与传统 DDR 一样,调试拨号程序配置文件问题的最适当的命令为 debug dialer。如果呼叫成功,则调试所显示的内容不会多于已记录的消息。如果失败,则具有一些可能是失败原因的问题。

拨号从不发生

开启 debug dialer 并生成发送到对等体的相关流量。路由器应尝试拨号。以下是示例输出:

maui-soho-01#ping 10.1.1.1

     Type escape sequence to abort.
     Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

     *Mar 1 00:24:47.242: BR0 DDR: rotor dialout [priority]
     *Mar 1 00:24:47.250: BR0 DDR: Dialing cause ip (s=192.168.1.1, d=10.1.1.1)
     *Mar 1 00:24:47.250: BR0 DDR: Attempting to dial 5551111

检查 debug dialer 是否生成任何调试输出。如果根本没有 debug dialer 输出,或者绑定失败,则很可能是因为所发送的 IP 数据包未路由到拨号程序接口。遵循以下程序。有关绑定的详细信息,请参阅本文档的拨出部分。

对出站呼叫绑定问题进行故障排除

请按下面的步骤对出站呼叫绑定问题进行故障排除。

  1. 如果拨号程序配置文件没有与拨号程序池关联,则 debug dialer 将针对出站呼叫显示以下内容:

    *Mar 1 07:20:45.676: Di15: Cannot place call, no dialer pool set

    解决方案:在拨号程序接口上配置 dialer pool 命令。

  2. 如果物理接口没有与任何池关联,则呼叫路由器上的调试消息将与没有任何其他物理接口时相同,从而触发快速空闲计时器

    *Mar 1 11:54:14.937: Di15: No free dialer - starting fast idle timer

    解决方案:在物理接口上配置 dialer pool-member 命令以将其关联到拨号程序池

对出站呼叫路由问题进行故障排除

验证了拨号程序池配置正确之后:

  1. 验证在拨号程序接口上配置了 IP。在接口上应具有一个 IP 地址或 ip unnumbered type number(其中 type number 是路由器在其上分配有 IP 地址的另一个接口)或 ip address negotiated

  2. 检查是否配置了命令 ip routing。当使用 show running-config 命令查看配置时,您不应看到已配置命令 no ip routing

  3. 确保存在指向拨号程序接口的静态路由。下面的示例是具有下一跳 Dialer 1 的 172.22.53.0/24 的静态路由:

    maui-soho-01(config)#ip route 172.22.53.0 255.255.255.0 dialer 1
    
  4. 验证拨号程序接口不处于关闭状态。使用 show interface dialer interface 命令验证接口处于 up/up 状态,或检查拨号程序接口配置下是否存在 no shutdown

存在调试输出,但是没有“Attempting to Dial”消息

在这种情况下,可能具有路由到该接口的 IP 数据包,但是路由器出于某种原因而将其丢弃且没有启动呼叫。查看 debug dialer 输出以确定没有进行呼叫尝试的原因。下面是 debug dialer 所指示的一些问题及其可能原因:

示例 1

*Mar  1 00:07:22.255: Di1 DDR: ip (s=10.1.0.1, d=192.168.201.1), 
       100 bytes, outgoing uninteresting (no dialer-group defined).

拨号程序接口上未配置任何拨号程序组。如以下示例所示,添加拨号程序组:

 interface Dialer1
       dialer-group 1

示例 2

*Mar  1 00:08:24.919: Di1 DDR: ip (s=10.1.0.1, d=192.168.201.1), 
       100 bytes, outgoing uninteresting (dialer-list 1 not defined).

拨号程序接口上有一个拨号程序组语句,但引用的拨号程序列表不存在。如以下示例所示,配置拨号程序列表:

dialer-list group-number protocol ip permit

注意: 组编号的值应与 dialer-group group-number 中配置的编号相同。在此示例中,请配置 dialer-list 1

示例 3

*Mar  1 00:25:32.551: Di1 DDR: ip (s=10.1.0.1, d=192.168.201.1), 
       100 bytes, outgoing interesting (ip PERMIT)
     *Mar  1 00:25:32.555: Di1 DDR: No free dialer - starting fast idle timer.

在这种情况下,会将传出数据包视为足够相关以启动该链路,但是没有可用于进行呼叫的物理接口。确保在物理接口中配置了 dialer pool-member number,并在拨号程序接口中配置了 dialer pool number示例:

interface BRI0
      dialer pool-member 1
     !
     interface Dialer1
      dialer pool 1

此外,还要验证物理接口未处于关闭状态。在物理接口上使用 no shutdown 命令。

示例 4

*Mar  1 00:37:24.235: Di1 DDR: ip (s=10.1.0.1, d=192.168.201.1), 
       100 bytes, outgoing interesting (ip PERMIT)
     *Mar  1 00:37:24.239: Di1 DDR: Cannot place call, no dialer string set.

在这种情况下,不在拨号程序接口上配置 dialer string dial-string。路由器要进行呼叫,但是不知道要呼叫的号码。定义拨号程序字符串:

interface Dialer1
      dialer string 8134

呼入呼叫连接不正确

使用拨号程序配置文件的呼叫可能会因将物理接口与该呼叫的拨号程序接口绑定时出现问题而失败。请验证路由器满足上面的拨入部分中所述的绑定条件之一。遵循以下步骤:

  1. 如果拨号程序配置文件没有与拨号程序池关联,则 debug dialer 将针对入站呼叫显示以下内容:

    *Mar 1 11:51:24.873: BRI0:1: 
    Authenticated host HQ-NAS with no matching dialer profile

    解决方案:在拨号程序接口上配置 dialer pool 命令。

  2. 请记住,可进行四次绑定尝试。假设我们有多个拨号程序配置文件,CLID 和 DNIS 绑定尝试失败,并且未配置 PPP 认证(预先排除第四次测试的可能性)。在被叫路由器上将生成以下 debug dialer 消息。

    *Mar 1 11:59:36.521: ISDN BR0:1: Incoming call rejected, unbindable

    解决方案:在物理接口上配置 ppp authentication chap|pap [callin]

  3. 如果在物理接口上启用了 PPP 认证,则将继续进行第四次绑定尝试。路由器将使用经过身份验证的用户名来尝试绑定到拨号程序池中的拨号程序接口之一。如果该尝试失败,则会在被叫路由器上看到以下调试:

    *Mar 1 12:03:32.227: BRI0:1: 
    Authenticated host HQ-NAS with no matching dialer profile

    解决方案:在拨号程序接口上配置 dialer remote-name 命令。指定的名称必须与远程路由器为进行身份验证而提供的用户名精确匹配。在此示例中,经过身份验证的用户名为 HQ-NAS。

呼叫过早被断开,或者呼叫从不断开

如果呼叫意外断开或从不断开,请检查拨号程序空闲超时和相关流量定义。您能使用debug dialer packet命令发现特定信息包是否是有趣。例如:

Apr 26 01:57:24.483: Di1 DDR: ip (s=192.168.1.1, d=224.0.0.5), 64 bytes,
  outgoing uninteresting (list 101)
Apr 26 01:57:26.225: Di1 DDR: ip (s=192.168.1.1, d=10.1.1.1), 100 bytes,
  outgoing interesting (list 101)

在上面的示例中,Open Shortest Path First (OSPF) hello 对于访问列表 101 不相关,而第二个数据包对于访问列表 101 相关。

  1. 在拨号程序接口配置中调整拨号程序空闲超时。默认是 120 秒,但您可能希望根据自己的需求增大或降低该值。

  2. 更改相关流量定义(已通过 dialer-list 命令配置)。如果呼叫过早被断开,则您可能希望更加松散地定义相关流量。如果呼叫从不断开,请将您的相关流量定义更改为限制性更强。例如,您可以将路由协议流量定义为不相关。以下是相关流量定义的示例:

    access-list 101 remark Interesting traffic for dialer-list 1
    access-list 101 deny ospf any any
    
    !--- Mark OSPF as uninteresting. This will prevent OSPF hellos
    !--- from keeping the link up.
    
    access-list 101 deny udp any any eq ntp
    
    !--- Define ntp traffic as NOT interesting.
    !--- This will prevent periodic ntp traffic from keeping the
    !--- link up indefinitely.
    
    access-list 101 permit ip any any
    
    !--- All other IP traffic is interesting. Change this depending on your
    !--- traffic needs.
    
    dialer-list 1 protocol ip list 101

有关详细信息,请参阅文档拨号技术:概述和解释

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 10219