拨号和接入 : 异步连接

在路由器与 Windows PC 之间配置 MS 回呼

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

回拨的Microsoft实施与RFC 1570不是兼容的leavingcisco.com然而,由于Microsoft拨号网络客户端的大市场份额, Cisco实现Microsoft回叫(MSCB)控制协议到Cisco IOSï ¿  ½软件版本11.3(2)T和以上。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 配置网络接入服务器(NAS)接受从客户端的模拟呼叫。回拨是调制解调器拨入其它功能。所以,请验证此方面是否正确地作用。这可帮助您排除故障。

  • T1/E1电路一定有能力在拨出上。与您的电话公司(Telco)联系验证此。

使用的组件

本文档中的信息根据Cisco IOS软件版本11.3(2)T及以上版本版本。

此方案在有Windows拨号网络的PC测试了。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景理论

回拨执行在这中命令:

  1. PC用户(客户端)连接到Cisco接入服务器。

  2. 回叫过程在点对点协议(PPP)链路控制协议(LCP)相位协商。

  3. PPP认证进行。

  4. Cisco IOS软件验证此用户或线路的回拨规则并且断开回拨的呼叫方。

  5. Cisco接入服务器拨通客户端。

有MSCB的四种类型:

  1. 没有回拨。

  2. 用户指定回叫编号。

  3. 服务器指定的(预先配置的)回拨号码。

  4. 预先配置的回拨号码列表。

默认配置是没有回拨(选项1)。选项2或3可以配置:

  • 本地(如果没有使用AAA服务器)。

  • 在TACACS+或RADIUS用户配置文件(如果使用AAA)。

如果选项2配置,提示用户输入他的回拨号码。如果选项3配置,提示符只提供一选择,是管理员定义的编号。

思科只实现MSCB而不是回拨客户端功能的回拨服务器功能。这意味着Cisco路由器可以仅使用作为MSCB服务器和不作为MSCB客户端。另外,在客户端要求验证将执行的MSCB Cisco实施。

配置

本部分提供有关如何配置本文档所述功能的信息。

配置汇总

要启用MSCB,您必须启用ppp callback accept命令在接收接口下(例如,异步组)。另外,因为验证要求,您必须特权密码认证协议(PAP)或质询握手验证协议(CHAP)验证:

ppp authentication chap pap

两聊天脚本自动地创建。这些是摘机回拨聊天脚本:

chat-script offhook "" "ATH1" OK
chat-script callback ABORT ERROR ABORT BUSY "" 
"ATZ" OK "ATDT \T" TIMEOUT60 CONNECT \c

聊天脚本自动地也应用到线路在使用中:

line 1 24
  script modem-off-hook offhook
  script callback callback

用户必须授权呼叫回到。您能本地配置此在NAS或在外部AAA服务器(RADIUS或TACACS+),根据用户名和密码信息存储的地方。

这是呼叫回到在5551212的用户的一个本地配置:

username callmeback callback-dialstring 5551212 password cisco

此本地配置是可适用的对允许指定他们自己的回拨号码的用户:

username callmeback callback-dialstring "" password cisco

网络图

本文档使用以下网络设置:

/image/gif/paws/9554/async_ppp.gif

配置

本文档使用以下配置:

  • isdn2-2 (AS5200路由器)

isdn2-2 (AS5200路由器)
Current configuration:
!
version 11.3
service timestamps debug datetime msec
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname isdn2-2
!
aaa new-model
aaa authentication login default none
aaa authentication login use-local local
aaa authentication ppp default local
aaa authorization network local

!--- Runs authorization for network-related service requests (Example: PPP).
!--- For an AAA server implementation, replace "local" with TACACS+ or RADIUS in
!--- these statements.

enable secret 5 <deleted>
!
username callmeback callback-dialstring "" password 7 <deleted>

!--- This is for mobile users. The client specifies the callback number.
!--- If a RADIUS server is used, this information can be offloaded to the server.

ip domain-name cisco.com
isdn switch-type primary-5ess
chat-script offhook "" "ATH1" OK
chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

!--- The chat script "callback" is used for the callback connection.

clock timezone PST -8
clock summer-time PDT recurring
!
!
controller T1 0

!--- Active T1 Primary Rate Interface (PRI).

 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 shutdown 
!
interface Ethernet0
 ip address 172.16.25.52 255.255.255.240
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
interface Serial0:23

!--- D-channel for T1 0.

 ip unnumbered Ethernet0
 encapsulation ppp
 dialer-group 1
 isdn incoming-voice modem

!--- Allows incoming ISDN voice calls to be switched to the onboard modems.

 peer default ip address pool default
!
interface Group-Async1
  ip unnumbered Ethernet0
  ip tcp header-compression passive
  encapsulation ppp
  async mode interactive
  peer default ip address pool default
  no cdp enable
  ppp max-bad-auth 3
  ppp callback accept

!--- Allows the group-async to accept a callback request to a remote host.

  ppp authentication chap

!--- CHAP, PAP, or both must be enabled for callback.

   group-range 1 12
!
router eigrp 202
  network 172.16.0.0
  distance 90 172.16.25.49 0.0.0.0
  no auto-summary
!
ip local pool default 172.16.25.59 172.16.25.62

!--- Default IP address pool for dial-in clients.

ip default-gateway 172.16.25.49

ip classless
dialer-list 1 protocol ip permit
!
line con 0
line 1 6
  autoselect during-login
  autoselect ppp
  script modem-off-hook offhook
  script callback callback

!--- Specifies a chat script to issue AT commands to the modem during a callback attempt.
!--- The chat-scripts "offhook" and "callback" were configured earlier.

  login authentication use-local
  modem InOut
  transport input all
line 7 12

!--- These modems are busied out and not used.

  autoselect during-login
  autoselect ppp
  login authentication use-local
  modem InOut
  modem busyout
  transport input all
line aux 0
  exec-timeout 0 0
  line vty 0 4
  password 7 <deleted>
!
end

Windows 客户端配置

Windows 95 及 98 客户端配置

对于Windows 95及98 PCs,没有回拨的特殊客户端配置。接入服务器处理连接的回叫功能。Windows 95或98 PC显示“等待的回拨”消息表明回拨进展中。

Windows NT 及 2000 客户端配置

配置这些平台请求回拨。完成这些步骤配置他们:

  1. 选择Start > Programs > Accessories >通信>网络和拨号连接

  2. 从菜单选择先进>拨号首选

  3. 图1所显示,点击Callback选项访问回叫功能菜单

  4. 配置您的回叫选项当必要时:

    • 为了不使用回叫功能,请点击No Callback按钮

    • 将被提示该做什么,当服务器提示回拨时,请单击要求我在正在拨号期间,当服务器提示按钮时。

    • 自动地接受回拨提供,总是请单击呼叫我回到在编号在按钮之下,并且选择设备从列表使用。

    • 要更换回拨电话号码,请选择设备并且点击编辑按钮。如图1所显示,输入编号在电话号码字段中,然后点击OK键在Call Me Back At对话框内。

  5. 点击电话号码字段中,并且输入在Call Me Back At对话框的编号(显示在图1)上。完成后,单击确定

  6. 当你完成的时候,请点击OK键在拨号首选对话框内。

    图1 –访问回叫功能

    async_ppp2.gif

    /image/gif/paws/9554/async_ppp3.gif

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show isdn active —显示关于当前流入和流出的ISDN呼叫的信息。请使用此命令验证回拨是否顺利地完成。如果回拨是成功的, show isdn active显示呼叫如流出的在回拨服务器。

  • show users —显示关于有效线路的信息在路由器。如果Cisco IOS软件的版本支持,您还可以使用 show caller 命令。

  • show dialer —显示为按需拨号路由(DDR)配置的接口的一般诊断信息。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

关于调试指令的更多信息,请参阅Cisco IOS版本12.0 Debug命令参考资料

  • debug aaa authentication —显示关于AAA认证的信息。

  • debug aaa authorization —显示关于AAA授权的信息。

  • 当路由器使用一个调制解调器和一个对话脚本呼叫在终端线路时的上一步debug callback —显示回拨事件。

  • debug modem —使您观察在接入服务器的调制解调器线路活动。

  • debug ppp [数据包|协商|错误|验证] —显示关于流量的信息并且在实现PPP的互联网络里交换。

    • 数据包—显示发送和接收的PPP数据包。(此命令显示低级数据包转储信息。)

    • 当PPP选项协商时,协商—显示在PPP启动期间传送的PPP数据包。

    • 错误—显示协议错误和错误统计信息关联与PPP连接协商和操作。

    • 验证—显示认证协议消息,包括CHAP和PAP交换。

  • debug chat —显示发生在接入服务器和其内部调制解调器之间的握手,当调制解调器被指示拨号时。聊天脚本是定义了在数据终端设备(DTE)和数据通信设备(DCE)设备之间的握手的一组期望发送的字符串对。

  • debug isdn q931 —显示ISDN Q.931 (D信道)呼叫建立及拆线消息和调试。在此方案中,调制解调器呼叫被传送作为在公共交换电话网(PSTN)的一项语音承载服务。

  • debug modem csm —使您排除故障在路由器的呼叫交换模块(CSM)问题用内部数字调制解调器。使用该指令,您能跟踪呼入和呼出的呼叫交换排序的完成情况。

isdn2-2#show debug
   General OS:
   Modem control/process activation debugging is on
   AAA Authentication debugging is on
   AAA Authorization debugging is on
   PPP:
   PPP protocol negotiation debugging is on
   ISDN:
   ISDN Q931 packets debugging is on
   Chat Scripts:
   Chat scripts activity debugging is on
   Modem Management:
   Modem Management Call Switching Module debugging is on
   isdn2-2#

   !--- This is the initial call from the client.

   *Mar 1 01:24:48.643: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x36
   *Mar 1 01:24:48.647: Bearer Capability i = 0x9090A2
   *Mar 1 01:24:48.651: Channel ID i = 0xA98393
   *Mar 1 01:24:48.651: Called Party Number i = 0xC1, '4084327528'
   *Mar 1 01:24:48.663: ISDN Se0:23: Incoming call id = 0xA
   *Mar 1 01:24:48.671: EVENT_FROM_ISDN::dchan_idb=0x7F8EE0, call_id=0xA, ces=0x1
   bchan=0x12, event=0x1, cause=0x0
   *Mar 1 01:24:48.671: VDEV_ALLOCATE: slot 0 and port 3 is allocated.
   *Mar 1 01:24:48.675: EVENT_FROM_ISDN:(000A): DEV_INCALL at slot 0 and port  3
   *Mar 1 01:24:48.675: CSM_PROC_IDLE: CSM_EVENT_ISDN_CALL at slot 0, port 3
   *Mar 1 01:24:48.679: Fast Ringing On at modem slot 0, port 3
   *Mar 1 01:24:48.699: ISDN Se0:23: TX -> CALL_PROC pd = 8 callref = 0x8036
   *Mar 1 01:24:48.703: Channel ID i = 0xA98393
   *Mar 1 01:24:48.735: ISDN Se0:23: TX -> ALERTING pd = 8 callref = 0x8036
   *Mar 1 01:24:49.699: Fast Ringing Off at modem slot 0, port 3
   *Mar 1 01:24:49.699: CSM_PROC_IC1_RING: CSM_EVENT_MODEM_OFFHOOK at slot 0,
   port 3
   *Mar 1 01:24:49.711: ISDN Se0:23: TX -> CONNECT pd = 8 callref = 0x8036
   *Mar 1 01:24:49.783: ISDN Se0:23: RX <- CONNECT_ACK pd = 8 callref = 0x36
   *Mar 1 01:24:49.799: EVENT_FROM_ISDN::dchan_idb=0x7F8EE0, call_id=0xA, ces=0x1
   bchan=0x12, event=0x4, cause=0x0
   *Mar 1 01:24:49.799: EVENT_FROM_ISDN:(000A): DEV_CONNECTED at slot 0 and
   port 3
   *Mar 1 01:24:49.803: CSM_PROC_IC4_WAIT_FOR_CARRIER:CSM_EVENT_ISDN_CONNECTED at
    slot 0, port 3

   !--- Modem has established carrier.

   *Mar 1 01:25:11.123: TTY4: DSR came up
   *Mar 1 01:25:11.127: tty4: Modem: IDLE->READY
   *Mar 1 01:25:11.131: TTY4: EXEC creation
   *Mar 1 01:25:11.135: AAA/AUTHEN: create_user (0x7B009C) user='' ruser=''
   port='tty4' rem_addr='async/4084327528' authen_type=ASCII service=LOGIN priv=1
   *Mar 1 01:25:11.139: AAA/AUTHEN/START (3134998138): port='tty4'
   list='use-local' action=LOGIN service=LOGIN
   *Mar 1 01:25:11.143: AAA/AUTHEN/START (3134998138): found list use-local
   *Mar 1 01:25:11.143: AAA/AUTHEN/START (3134998138): Method=LOCAL
   
   !--- Local AAA.

   *Mar 1 01:25:11.147: AAA/AUTHEN (3134998138): status = GETUSER
   *Mar 1 01:25:13.951: TTY4: Autoselect(2) sample 7E
   *Mar 1 01:25:13.955: TTY4: Autoselect(2) sample 7EFF
   *Mar 1 01:25:13.959: TTY4: Autoselect(2) sample 7EFF7D
   *Mar 1 01:25:13.959: TTY4: Autoselect(2) sample 7EFF7D23
   *Mar 1 01:25:13.963: TTY4 Autoselect cmd: ppp negotiate
   *Mar 1 01:25:13.967: AAA/AUTHEN/ABORT: (3134998138) because Autoselected.
   *Mar 1 01:25:13.967: AAA/AUTHEN: free_user (0x7B009C) user='' ruser=''
   port='tty4' rem_addr='async/4084327528' authen_type=ASCII service=LOGIN priv=1
   *Mar 1 01:25:13.975: TTY4: EXEC creation

   !--- PPP has been autoselected and begins negotiation.

   %LINK-3-UPDOWN: Interface Async4, changed state to up
   *Mar 1 01:25:16.611: As4 PPP: Treating connection as a dedicated line
   *Mar 1 01:25:16.611: As4 PPP: Phase is ESTABLISHING, Active Open

   !--- LCP negotiation begins.

   *Mar 1 01:25:16.615: As4 LCP: O CONFREQ [Closed] id 3 len 25
   *Mar 1 01:25:16.619: As4 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 01:25:16.623: As4 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 01:25:16.623: As4 LCP: MagicNumber 0x608D04A3 (0x0506608D04A3)
   *Mar 1 01:25:16.627: As4 LCP: PFC (0x0702)
   *Mar 1 01:25:16.627: As4 LCP: ACFC (0x0802)
   *Mar 1 01:25:16.751: As4 LCP: I CONFACK [REQsent] id 3 len 25
   *Mar 1 01:25:16.755: As4 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 01:25:16.755: As4 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 01:25:16.759: As4 LCP: MagicNumber 0x608D04A3 (0x0506608D04A3)
   *Mar 1 01:25:16.763: As4 LCP: PFC (0x0702)
   *Mar 1 01:25:16.763: As4 LCP: ACFC (0x0802)
   *Mar 1 01:25:17.003: As4 LCP: I CONFREQ [ACKrcvd] id 3 len 23

   !--- Incoming CONFREQ.
 
   *Mar 1 01:25:17.003: As4 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 01:25:17.007: As4 LCP: MagicNumber 0x004A4A09 (0x0506004A4A09)
   *Mar 1 01:25:17.007: As4 LCP: PFC (0x0702)
   *Mar 1 01:25:17.011: As4 LCP: ACFC (0x0802)
   *Mar 1 01:25:17.011: As4 LCP: Callback 6 (0x0D0306)

   !--- Peer requests MS Callback (Option 6).
   !--- A PPP callback request uses Option 0.

   *Mar 1 01:25:17.015: As4 LCP: O CONFACK [ACKrcvd] id 3 len 23
   *Mar 1 01:25:17.015: As4 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 01:25:17.019: As4 LCP: MagicNumber 0x004A4A09 (0x0506004A4A09)
   *Mar 1 01:25:17.023: As4 LCP: PFC (0x0702)
   *Mar 1 01:25:17.023: As4 LCP: ACFC (0x0802)
   *Mar 1 01:25:17.023: As4 LCP: Callback 6 (0x0D0306)

   !--- NAS CONFACKS all LCP parameters. 
   !--- If the NAS refuses Callback (completely or just MS Callback), LCP may fail.

   *Mar 1 01:25:17.027: As4 LCP: State is Open
  
  !--- Authentication begins.

   *Mar 1 01:25:20.095: As4 PPP: Phase is AUTHENTICATING, by this end
   *Mar 1 01:25:20.099: As4 CHAP: O CHALLENGE id 4 len 28 from "isdn2-2"
   *Mar 1 01:25:20.187: As4 CHAP: I RESPONSE id 4 len 26 from "callmeback"
   *Mar 1 01:25:20.191: AAA/AUTHEN: create_user (0x7ADEAC) user='callmeback'
   ruser='' port='Async4' rem_addr='async/4084327528' authen_type=CHAP
   service=PPP priv=1
   *Mar 1 01:25:20.195: AAA/AUTHEN/START (44582883): port='Async4' list=''
   action=LOGIN service=PPP
   *Mar 1 01:25:20.199: AAA/AUTHEN/START (44582883): using "default" list
   *Mar 1 01:25:20.199: AAA/AUTHEN/START (44582883): Method=LOCAL
   
   !--- Authentication passes.

  *Mar 1 01:25:20.203: AAA/AUTHEN (44582883): status = PASS

   !--- Check authorization for LCP.
   !--- With local AAA, this should pass.
   !--- For server-based AAA, this must be explicitly configured on the server.

   *Mar 1 01:25:20.207: AAA/AUTHOR/LCP As4: Authorize LCP
   *Mar 1 01:25:20.207: AAA/AUTHOR/LCP: Async4: (3405067782): user='callmeback'
   *Mar 1 01:25:20.211: AAA/AUTHOR/LCP: Async4: (3405067782): send AV service=ppp
   *Mar 1 01:25:20.211: AAA/AUTHOR/LCP: Async4: (3405067782): send AV
   protocol=lcp
   *Mar 1 01:25:20.215: AAA/AUTHOR/LCP: Async4 (3405067782): Method=LOCAL
   *Mar 1 01:25:20.219: AAA/AUTHOR (3405067782): Post authorization status =
   PASS_ADD
   *Mar 1 01:25:20.223: AAA/AUTHOR/LCP As4: Processing AV service=ppp
   *Mar 1 01:25:20.223: AAA/AUTHOR/LCP As4: Processing AV protocol=lcp
   *Mar 1 01:25:20.227: AAA/AUTHOR/LCP As4: Processing AV service=ppp
   *Mar 1 01:25:20.227: AAA/AUTHOR/LCP As4: Processing AV protocol=lcp

   !--- Callback-dialstring is null, so user is allowed to specify
   !--- their own callback number.

  *Mar 1 01:25:20.227: AAA/AUTHOR/LCP As4: Processing AV callback-dialstring=

   !--- Authentication ACK is returned to client.

  *Mar 1 01:25:20.235: As4 CHAP: O SUCCESS id 4 len 4

   !--- Callback negotiation proceeds. Because callback-dialstring
   !--- is null, MCB debug says "Callback Number - Client ANY".

  *Mar 1 01:25:20.239: As4 MCB: User callmeback Callback Number - Client ANY

   !--- The callback number of the client is requested. Client receives a dialog
   !--- box that prompts the user to type in the callback number. 
   !--- Request is sent every two seconds. If the user is slow to type a response,
   !--- the call remains in this phase for a long time.
   
   *Mar 1 01:25:20.243: Async4 PPP: O MCB Request(1) id 20 len 9
   *Mar 1 01:25:20.243: Async4 MCB: O 1 14 0 9 2 5 0 1 0 
   *Mar 1 01:25:20.247: As4 MCB: O Request Id 20 Callback Type Client-Num delay  0
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Async4, changed state to up
   *Mar 1 01:25:22.459: As4 MCB: Timeout in state WAIT_RESPONSE
   *Mar 1 01:25:22.463: Async4 PPP: O MCB Request(1) id 21 len 9
   *Mar 1 01:25:22.463: Async4 MCB: O 1 15 0 9 2 5 0 1 0 
   *Mar 1 01:25:22.467: As4 MCB: O Request Id 21 Callback Type Client-Num delay  0
   *Mar 1 01:25:24.499: As4 MCB: Timeout in state WAIT_RESPONSE
   *Mar 1 01:25:24.503: Async4 PPP: O MCB Request(1) id 22 len 9
   *Mar 1 01:25:24.503: Async4 MCB: O 1 16 0 9 2 5 0 1 0 
   *Mar 1 01:25:24.507: As4 MCB: O Request Id 22 Callback Type Client-Num delay  0
   *Mar 1 01:25:26.543: As4 MCB: Timeout in state WAIT_RESPONSE
   *Mar 1 01:25:26.547: Async4 PPP: O MCB Request(1) id 23 len 9
   *Mar 1 01:25:26.547: Async4 MCB: O 1 17 0 9 2 5 0 1 0 
   *Mar 1 01:25:26.551: As4 MCB: O Request Id 23 Callback Type Client-Num delay  0
   *Mar 1 01:25:28.583: As4 MCB: Timeout in state WAIT_RESPONSE
   *Mar 1 01:25:28.587: Async4 PPP: O MCB Request(1) id 24 len 9
   *Mar 1 01:25:28.587: Async4 MCB: O 1 18 0 9 2 5 0 1 0 
   *Mar 1 01:25:28.591: As4 MCB: O Request Id 24 Callback Type Client-Num delay  0

   !--- Client returned the callback number. Notice that the response 
   !--- is for the initial request id 20.

   *Mar 1 01:25:29.763: Async4 PPP: I MCB Response(2) id 20 len 17
   *Mar 1 01:25:29.767: Async4 MCB: I 2 14 0 11 2 D F 1 35 32 37 2D 39 36 35 31 0 
   *Mar 1 01:25:29.767: As4 MCB: Received response

   !--- Response is ignored because the id is 20. There have 
   !--- been a few timeouts and id 24 (the last one sent) is expected.

   *Mar 1 01:25:29.771: As4 MCB: Resp ignored. ID Expected 24, got id 20
   *Mar 1 01:25:30.623: As4 MCB: Timeout in state WAIT_RESPONSE

   !--- Send out new request (id 25).

   *Mar 1 01:25:30.627: Async4 PPP: O MCB Request(1) id 25 len 9
   *Mar 1 01:25:30.627: Async4 MCB: O 1 19 0 9 2 5 0 1 0 
   *Mar 1 01:25:30.631: As4 MCB: O Request Id 25 Callback Type Client-Num delay  0

   !--- Client has cached user response, and so the callback number is 
   !--- returned right away.

   *Mar 1 01:25:30.715: Async4 PPP: I MCB Response(2) id 25 len 17
   *Mar 1 01:25:30.719: Async4 MCB: I 2 19 0 11 2 D F 1 35 32 37
   2D 39 36 35 31 0 
   *Mar 1 01:25:30.723: As4 MCB: Received response

   !--- Received client callback number is 527-9651.

   *Mar 1 01:25:30.723: As4 MCB: Response CBK-Client-Num 2 13 15, addr
   1-527-9651

   !--- Callback number acknowledged.

   *Mar 1 01:25:30.727: Async4 PPP: O MCB Ack(3) id 26 len 17
   *Mar 1 01:25:30.731: Async4 MCB: O 3 1A 0 11 2 D F 1 35 32 37
   2D 39 36 35 31 0 
   *Mar 1 01:25:30.731: As4 MCB: O Ack Id 26 Callback Type Client-Num delay 15
   *Mar 1 01:25:30.735: As4 MCB: Negotiated MCB with peer

   !--- Client hangs up and begins to wait for callback.
   !--- This is indicated by an Incoming (I) TERMREQ.

   *Mar 1 01:25:30.815: As4 LCP: I TERMREQ [Open] id 5 len 4
   *Mar 1 01:25:30.815: As4 LCP: O TERMACK [Open] id 5 len 4
   *Mar 1 01:25:30.819: As4 MCB: Peer terminating the link
   *Mar 1 01:25:30.819: As4 PPP: Phase is TERMINATING
   *Mar 1 01:25:30.819: As4 MCB: Link terminated by peer, Callback Needed

   !--- Initiate callback to client; sleeps for ten seconds.

   *Mar 1 01:25:30.823: As4 MCB: Initiate Callback for callmeback at 527-9651 
    using Async
   *Mar 1 01:25:30.827: As4 MCB: Async-callback in progress

   !--- Drop modem and B-channel for initial call from client.

   *Mar 1 01:25:31.499: CSM_PROC_IC5_OC6_CONNECTED: CSM_EVENT_MODEM_ONHOOK at
   slot 0, port 3
   *Mar 1 01:25:31.503: VDEV_DEALLOCATE: slot 0 and port 3 is deallocated
   *Mar 1 01:25:31.503: ISDN Se0:23: Event: Hangup call to call id 0xA 
   %ISDN-6-DISCONNECT: Interface Serial0:18 disconnected from unknown , call
   lasted 41 seconds

   !--- Call is completely disconnected.

   *Mar 1 01:25:31.523: ISDN Se0:23: TX -> DISCONNECT pd = 8 callref = 0x8036
   *Mar 1 01:25:31.523: Cause i = 0x8090 - Normal call clearing 
   *Mar 1 01:25:31.583: ISDN Se0:23: RX <- RELEASE pd = 8 callref = 0x36
   *Mar 1 01:25:31.655: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8036
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Async4, changed state to down
   *Mar 1 01:25:31.851: TTY4: Async Int reset: Dropping DTR
   *Mar 1 01:25:33.695: As4 LCP: TIMEout: Time = 0x4E521C State = TERMsent
   *Mar 1 01:25:33.699: As4 LCP: State is Closed
   *Mar 1 01:25:33.699: As4 PPP: Phase is DOWN
   *Mar 1 01:25:33.703: As4 PPP: Phase is ESTABLISHING, Passive Open
   *Mar 1 01:25:33.707: As4 LCP: State is Listen
   %LINK-5-CHANGED: Interface Async4, changed state to reset
   *Mar 1 01:25:33.879: As4 LCP: State is Closed
   *Mar 1 01:25:33.879: As4 PPP: Phase is DOWN
   *Mar 1 01:25:33.883: As4 IPCP: Remove route to 172.16.25.61
   %LINK-3-UPDOWN: Interface Async4, changed state to down
   *Mar 1 01:25:38.887: As4 LCP: State is Closed
   *Mar 1 01:25:38.887: As4 PPP: Phase is DOWN

   !--- Cleanup from previous call is finished.

  *Mar 1 01:25:40.863: CHAT4: Matched chat script offhook to string offhook
  *Mar 1 01:25:40.867: CHAT4: Asserting DTR

   !--- Modem goes offhook.

   *Mar 1 01:25:40.867: CHAT4: Chat script offhook started
   *Mar 1 01:25:40.871: CHAT4: Sending string: ATH1
   *Mar 1 01:25:40.871: CHAT4: Expecting string: OK
   *Mar 1 01:25:40.911: CSM_PROC_IDLE: CSM_EVENT_MODEM_OFFHOOK at slot 0, port  3
   *Mar 1 01:25:40.963: CHAT4: Completed match for expect: OK
   *Mar 1 01:25:40.967: CHAT4: Chat script offhook finished, status = Success

   !--- Chat script "offhook" was successfully completed.
 
   *Mar 1 01:25:40.967: CHAT4: Matched chat script callback to string callback

   !--- Chat script "callback" is initated.

   *Mar 1 01:25:40.971: CHAT4: Asserting DTR
   *Mar 1 01:25:40.975: CHAT4: Chat script callback started

   !--- Reset modem to known state.

   *Mar 1 01:25:40.975: CHAT4: Sending string: ATZ
   *Mar 1 01:25:40.979: CSM_PROC_OC1_REQUEST_DIGIT: CSM_EVENT_MODEM_ONHOOK at
   slot 0, port 3
   *Mar 1 01:25:40.983: VDEV_DEALLOCATE: slot 0 and port 3 is deallocated
   *Mar 1 01:25:40.979: CHAT4: Expecting string: OK
   *Mar 1 01:25:42.123: CHAT4: Completed match for expect: OK

   !--- Dial the callback number of the client.

   *Mar 1 01:25:42.127: CHAT4: Sending string: ATDT \T<527-9651>
   *Mar 1 01:25:42.131: CHAT4: Expecting string: CONNECT
   *Mar 1 01:25:43.199: CSM_PROC_IDLE: CSM_EVENT_MODEM_OFFHOOK at slot 0, port  3

   !--- Modem/ISDN needs to collect the digits from IOS before it makes the call.

   *Mar 1 01:25:43.327: DSX1_MAIL_FROM_NEAT: DC_READY_RSP: mid = 5, slot = 2,
   unit = 1
   *Mar 1 01:25:43.331: CSM_PROC_OC1_REQUEST_DIGIT:
   CSM_EVENT_DIGIT_COLLECT_READY at slot 0, port 3
   *Mar 1 01:25:43.331: CSM_PROC_OC1_REQUEST_DIGIT:
   CSM_EVENT_ADDR_INFO_COLLECTED at slot 0, port 3
   *Mar 1 01:25:44.327: DSX1_MAIL_FROM_NEAT: DC_FIRST_DIGIT_RSP: mid = 5,
   slot = 2, unit = 1
   *Mar 1 01:25:44.331: CSM_PROC_OC2_COLLECT_1ST_DIGIT:
   CSM_EVENT_GET_1ST_DIGIT at slot 0, port 3
   *Mar 1 01:25:47.331: DSX1_MAIL_FROM_NEAT: DC_ALL_DIGIT_RSP: mid = 5, slot
   = 2, unit = 1
   *Mar 1 01:25:47.331: CSM_PROC_OC3_COLLECT_ALL_DIGIT:
   CSM_EVENT_GET_ALL_DIGITS at slot 0, port 3
   *Mar 1 01:25:47.335: CSM_PROC_OC3_COLLECT_ALL_DIGIT: called party num:
      (5279651) at slot 0, port 3

   !--- Digits have been collected; ISDN call is made.

   *Mar 1 01:25:47.339: process_pri_call making a voice_call.
   *Mar 1 01:25:47.351: ISDN Se0:23: TX -> SETUP pd = 8 callref = 0x0005
   *Mar 1 01:25:47.355: Bearer Capability i = 0x8090A2

   !--- Bearer cap indicates call is an analog call.

   *Mar 1 01:25:47.355: Channel ID i = 0xE1808397
   *Mar 1 01:25:47.359: Called Party Number i = 0xA1, '5279651'
   *Mar 1 01:25:47.431: ISDN Se0:23: RX <- CALL_PROC pd = 8 callref = 0x8005
   *Mar 1 01:25:47.435: Channel ID i = 0xA98397
   *Mar 1 01:25:47.451: EVENT_FROM_ISDN::dchan_idb=0x7F8EE0, call_id=0xA005,
   ces=0x1 bchan=0x16, event=0x3, cause=0x0
   *Mar 1 01:25:47.451: EVENT_FROM_ISDN:(A005): DEV_CALL_PROC at slot 0 and port 3 
   *Mar 1 01:25:47.455: CSM_PROC_OC4_DIALING: 
    CSM_EVENT_ISDN_BCHAN_ASSIGNED at slot 0, port 3
   *Mar 1 01:25:48.147: ISDN Se0:23: RX <- ALERTING pd = 8 callref = 0x8005
   *Mar 1 01:25:48.151: Progress Ind i = 0x8388 - In-band info or
   appropriate now available 
   *Mar 1 01:25:50.835: ISDN Se0:23: RX <- CONNECT pd = 8 callref = 0x8005
   *Mar 1 01:25:50.851: EVENT_FROM_ISDN::dchan_idb=0x7F8EE0, call_id=0xA005,
   ces=0x1 bchan=0x16, event=0x4, cause=0x
   *Mar 1 01:25:50.855: EVENT_FROM_ISDN:(A005): DEV_CONNECTED at slot 0 and port 3
   *Mar 1 01:25:50.859: CSM_PROC_OC5_WAIT_FOR_CARRIER: 
    CSM_EVENT_ISDN_CONNECTED at slot 0, port 3 
   
   !--- ISDN call is connected.

   *Mar 1 01:25:50.867: ISDN Se0:23: TX -> CONNECT_ACK pd = 8 callref = 0x0005
   *Mar 1 01:25:53.735: AAA/AUTHEN: free_user (0x7ADEAC) user='callmeback'
   ruser='' port='Async4' rem_addr='async/4084327528' authen_type=CHAP
   service=PPP priv=1

   !--- Modems have established carrier.

   *Mar 1 01:26:13.487: CHAT4: Completed match for expect: CONNECT
   *Mar 1 01:26:13.491: CHAT4: Sending string: \c
   *Mar 1 01:26:13.491: CHAT4: Chat script callback finished, status = Success
   *Mar 1 01:26:15.415: TTY4: DSR came up
   *Mar 1 01:26:15.419: tty4: Modem: IDLE->READY
   *Mar 1 01:26:15.439: TTY4: EXEC creation
   *Mar 1 01:26:15.443: AAA/AUTHEN: create_user (0x7ADEA4) user='' ruser=''
   port='tty4' rem_addr='async/5279651' authen_type=ASCII service=LOGIN priv=1
   *Mar 1 01:26:15.447: AAA/AUTHEN/START (2043462211): port='tty4'
   list='use-local' action=LOGIN service=LOGIN
   *Mar 1 01:26:15.451: AAA/AUTHEN/START (2043462211): found list use-local
   *Mar 1 01:26:15.451: AAA/AUTHEN/START (2043462211): Method=LOCAL
   *Mar 1 01:26:15.455: AAA/AUTHEN (2043462211): status = GETUSER
   
   !--- PPP negotiation begins again.

   *Mar 1 01:26:16.631: TTY4: Autoselect(2) sample 7E
   %LINK-3-UPDOWN: Interface Async4, changed state to up
   *Mar 1 01:26:18.663: As4 PPP: Treating connection as a dedicated line
   *Mar 1 01:26:18.663: As4 PPP: Phase is ESTABLISHING, Active Open
   *Mar 1 01:26:18.667: As4 LCP: O CONFREQ [Closed] id 5 len 25
   *Mar 1 01:26:18.671: As4 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 01:26:18.675: As4 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 01:26:18.675: As4 LCP: MagicNumber 0x608DF70C (0x0506608DF70C)
   *Mar 1 01:26:18.679: As4 LCP: PFC (0x0702)
   *Mar 1 01:26:18.679: As4 LCP: ACFC (0x0802)
   *Mar 1 01:26:18.779: As4 LCP: I CONFACK [REQsent] id 5 len 25
   *Mar 1 01:26:18.783: As4 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 01:26:18.787: As4 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 01:26:18.787: As4 LCP: MagicNumber 0x608DF70C (0x0506608DF70C)
   *Mar 1 01:26:18.791: As4 LCP: PFC (0x0702)
   *Mar 1 01:26:18.791: As4 LCP: ACFC (0x0802)
   *Mar 1 01:26:19.707: As4 LCP: I CONFREQ [ACKrcvd] id 3 len 20
   *Mar 1 01:26:19.711: As4 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 01:26:19.711: As4 LCP: MagicNumber 0x004B3EF5 (0x0506004B3EF5)
   *Mar 1 01:26:19.715: As4 LCP: PFC (0x0702)
   *Mar 1 01:26:19.715: As4 LCP: ACFC (0x0802)
   *Mar 1 01:26:19.719: As4 LCP: O CONFACK [ACKrcvd] id 3 len 20
   *Mar 1 01:26:19.723: As4 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 01:26:19.723: As4 LCP: MagicNumber 0x004B3EF5 (0x0506004B3EF5)
   *Mar 1 01:26:19.727: As4 LCP: PFC (0x0702)
   *Mar 1 01:26:19.727: As4 LCP: ACFC (0x0802)
   *Mar 1 01:26:19.731: As4 LCP: State is Open

   !--- Reauthenticate the user.

   *Mar 1 01:26:22.779: As4 PPP: Phase is AUTHENTICATING, by this end
   *Mar 1 01:26:22.783: As4 CHAP: O CHALLENGE id 6 len 28 from "isdn2-2"
   *Mar 1 01:26:22.887: As4 CHAP: I RESPONSE id 6 len 26 from "callmeback"
   *Mar 1 01:26:22.895: AAA/AUTHEN: create_user (0x8F1DAC) user='callmeback'
   ruser='' port='Async4' rem_addr='async/5279651' authen_type=CHAP
   service=PPP priv=1
   *Mar 1 01:26:22.899: AAA/AUTHEN/START (2174906802): port='Async4' list=''
   action=LOGIN service=PPP
   *Mar 1 01:26:22.899: AAA/AUTHEN/START (2174906802): using "default"    list
   *Mar 1 01:26:22.903: AAA/AUTHEN/START (2174906802): Method=LOCAL
   *Mar 1 01:26:22.903: AAA/AUTHEN (2174906802): status = PASS
   *Mar 1 01:26:22.907: AAA/AUTHOR/LCP As4: Authorize LCP
   *Mar 1 01:26:22.911: AAA/AUTHOR/LCP: Async4: (3262137315): user='callmeback'
   *Mar 1 01:26:22.911: AAA/AUTHOR/LCP: Async4: (3262137315): send AV service=ppp
   *Mar 1 01:26:22.915: AAA/AUTHOR/LCP: Async4: (3262137315): send AV
   protocol=lcp
   *Mar 1 01:26:22.915: AAA/AUTHOR/LCP: Async4 (3262137315): Method=LOCAL
   *Mar 1 01:26:22.923: AAA/AUTHOR (3262137315): 
    Post authorization status =PASS_ADD
   *Mar 1 01:26:22.927: AAA/AUTHOR/LCP As4: Processing AV service=ppp
   *Mar 1 01:26:22.927: AAA/AUTHOR/LCP As4: Processing AV protocol=lcp
   *Mar 1 01:26:22.931: AAA/AUTHOR/LCP As4: Processing AV service=ppp
   *Mar 1 01:26:22.931: AAA/AUTHOR/LCP As4: Processing AV protocol=lcp
   *Mar 1 01:26:22.931: AAA/AUTHOR/LCP As4: Processing AV callback-dialstring=
   *Mar 1 01:26:22.939: As4 CHAP: O SUCCESS id 6 len 4
   *Mar 1 01:26:22.943: As4 PPP: Phase is UP
   *Mar 1 01:26:22.947: AAA/AUTHOR/FSM As4: (0): Can we start IPCP?
   *Mar 1 01:26:22.947: AAA/AUTHOR/FSM: Async4: (345798021): user='callmeback'
   *Mar 1 01:26:22.951: AAA/AUTHOR/FSM: Async4: (345798021): send AV service=ppp
   *Mar 1 01:26:22.951: AAA/AUTHOR/FSM: Async4: (345798021): send AV protocol=ip
   *Mar 1 01:26:22.955: AAA/AUTHOR/FSM: Async4 (345798021): Method=LOCAL
   *Mar 1 01:26:22.955: AAA/AUTHOR (345798021): 
    Post authorization status = PASS_REPL
   
   !--- Negotiate IPCP.

   *Mar 1 01:26:22.959: AAA/AUTHOR/FSM As4: We can start IPCP
   *Mar 1 01:26:22.963: As4 IPCP: O CONFREQ [Closed] id 1 len 16
   *Mar 1 01:26:22.967: As4 IPCP: CompressType VJ 15 slots (0x0206002D0F00)
   *Mar 1 01:26:22.967: As4 IPCP: Address 172.16.25.52 (0x0306AC101934)
   *Mar 1 01:26:23.019: As4 IPCP: I CONFREQ [REQsent] id 1 len 40
   *Mar 1 01:26:23.023: As4 IPCP: CompressType VJ 15 slots CompressSlotID
   (0x0206002D0F01)
   *Mar 1 01:26:23.027: As4 IPCP: Address 0.0.0.0 (0x030600000000)
   *Mar 1 01:26:23.027: As4 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)
   *Mar 1 01:26:23.031: As4 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)
   *Mar 1 01:26:23.035: As4 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)
   *Mar 1 01:26:23.035: As4 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)
   *Mar 1 01:26:23.039: AAA/AUTHOR/IPCP As4: Start. Her address 0.0.0.0, we
   want 0.0.0.0
   *Mar 1 01:26:23.039: AAA/AUTHOR/IPCP As4: Processing AV service=ppp
   *Mar 1 01:26:23.043: AAA/AUTHOR/IPCP As4: Processing AV protocol=ip
   *Mar 1 01:26:23.043: AAA/AUTHOR/IPCP As4: Authorization succeeded
   *Mar 1 01:26:23.047: AAA/AUTHOR/IPCP As4: Done. Her address 0.0.0.0, we
   want 0.0.0.0
   *Mar 1 01:26:23.047: As4 IPCP: Using pool 'default'
   *Mar 1 01:26:23.051: As4 IPCP: Pool returned 172.16.25.60
   *Mar 1 01:26:23.051: As4 IPCP: O CONFREJ [REQsent] id 1 len 28
   *Mar 1 01:26:23.055: As4 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)
   *Mar 1 01:26:23.059: As4 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)
   *Mar 1 01:26:23.059: As4 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)
   *Mar 1 01:26:23.063: As4 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)
   *Mar 1 01:26:23.067: As4 IPCP: I CONFACK [REQsent] id 1 len 16
   *Mar 1 01:26:23.067: As4 IPCP: CompressType VJ 15 slots (0x0206002D0F00)
   *Mar 1 01:26:23.071: As4 IPCP: Address 172.16.25.52 (0x0306AC101934)
   *Mar 1 01:26:23.139: As4 IPCP: I CONFREQ [ACKrcvd] id 2 len 16
   *Mar 1 01:26:23.139: As4 IPCP: CompressType VJ 15 slots CompressSlotID
   (0x0206002D0F01)
   *Mar 1 01:26:23.143: As4 IPCP: Address 0.0.0.0 (0x030600000000)
   *Mar 1 01:26:23.147: AAA/AUTHOR/IPCP As4: Start. Her address 0.0.0.0, we
   want 172.16.25.60
   *Mar 1 01:26:23.147: AAA/AUTHOR/IPCP As4: Processing AV service=ppp
   *Mar 1 01:26:23.151: AAA/AUTHOR/IPCP As4: Processing AV protocol=ip
   *Mar 1 01:26:23.151: AAA/AUTHOR/IPCP As4: Authorization succeeded
   *Mar 1 01:26:23.151: AAA/AUTHOR/IPCP As4: Done. Her address 0.0.0.0, we
   want 172.16.25.60
   *Mar 1 01:26:23.155: As4 IPCP: O CONFNAK [ACKrcvd] id 2 len 10
   *Mar 1 01:26:23.159: As4 IPCP: Address 172.16.25.60 (0x0306AC10193C)
   *Mar 1 01:26:23.255: As4 IPCP: I CONFREQ [ACKrcvd] id 3 len 16
   *Mar 1 01:26:23.259: As4 IPCP: CompressType VJ 15 slots CompressSlotID
   (0x0206002D0F01)
   *Mar 1 01:26:23.263: As4 IPCP: Address 172.16.25.60 (0x0306AC10193C)
   *Mar 1 01:26:23.263: AAA/AUTHOR/IPCP As4: Start. Her address
   172.16.25.60, we want 172.16.25.60
   *Mar 1 01:26:23.267: AAA/AUTHOR/IPCP: Async4: (3819567164): user='callmeback'
   *Mar 1 01:26:23.271: AAA/AUTHOR/IPCP: Async4: (3819567164): send AV
   service=ppp
   *Mar 1 01:26:23.271: AAA/AUTHOR/IPCP: Async4: (3819567164): send AV
   protocol=ip
   *Mar 1 01:26:23.275: AAA/AUTHOR/IPCP: Async4: (3819567164): send AV
   addr*172.16.25.60
   *Mar 1 01:26:23.275: AAA/AUTHOR/IPCP: Async4 (3819567164): Method=LOCAL
   *Mar 1 01:26:23.279: AAA/AUTHOR (3819567164): Post authorization status =
   PASS_REPL
   *Mar 1 01:26:23.283: AAA/AUTHOR/IPCP As4: Reject 172.16.25.60, using
   172.16.25.60
   *Mar 1 01:26:23.287: AAA/AUTHOR/IPCP As4: Processing AV service=ppp
   *Mar 1 01:26:23.291: AAA/AUTHOR/IPCP As4: Processing AV protocol=ip
   *Mar 1 01:26:23.291: AAA/AUTHOR/IPCP As4: Processing AV addr*172.16.25.60
   *Mar 1 01:26:23.295: AAA/AUTHOR/IPCP As4: Authorization succeeded
   *Mar 1 01:26:23.295: AAA/AUTHOR/IPCP As4: Done. Her address 172.16.25.60,
   we want 172.16.25.60
   *Mar 1 01:26:23.299: As4 IPCP: O CONFACK [ACKrcvd] id 3 len 16
   *Mar 1 01:26:23.303: As4 IPCP: CompressType VJ 15 slots CompressSlotID
   (0x0206002D0F01)
   *Mar 1 01:26:23.303: As4 IPCP: Address 172.16.25.60 (0x0306AC10193C)
   *Mar 1 01:26:23.307: As4 IPCP: State is Open
   *Mar 1 01:26:23.323: As4 IPCP: Install route to 172.16.25.60
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Async4, changed state to up
   
   !--- Client is connected.


相关信息


Document ID: 9554