拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

用四条 T1 配置 NFAS

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

ISDN Non-Facility Associated Signaling (NFAS)允许单个D信道控制多个主速率接口(PRI)。当主要NFAS D信道出故障时,您能配置备份D信道。当您配置ISDN PRI的时信道化T1控制器,您只需要配置NFAS主要的D信道;其配置被分配到相关的NFAS组的所有成员。

通过使用对控制多个PRI的单个D信道,在每个接口的一个额外的信道是自由运载数据流。主要的D-信令信道的所有硬件故障导致对备份D信道的一个立即切换,无需当前断开联网的用户。

注意: 如果配置备份D信道,只有23条B信道在备份T1控制器可以使用,因为在备份的D信道不可用。所以,不主要的和备份仅的那些T1能有可用24条的B信道。在此配置中, T1控制器4/0主要的并且有23条可用的B信道,并且T1控制器4/1是备份并且有23条可用的B信道。T1控制器5/0和5/1每有24条可用的B信道。

先决条件

要求

前提对于NFAS如下:

  • NFAS用信道化T1控制器仅支持,并且,结果,必须为在实现NFAS前的ISDN PRI也配置T1控制器。关于配置ISDN的更多信息,参考ISDN支持页。

  • 为NFAS配置的路由器必须连接到4ess, dms250, dms100或者National ISDN交换机类型。

    注意: primary-5ess类型交换机不支持NFAS。参见您的服务提供商或Telco确定NFAS是否可以为您的T1线路配置。

  • 在您的Telco的ISDN交换机必须配置NFAS。

  • 您一定使用Cisco IOSï ¿  ½软件版本11.3T或以上。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 以下配置用运行Cisco IOS软件版本12.0(5)的Cisco 7507路由器测试。

  • 此配置在同一组内说明如何设置四个NFAS成员。主要NFAS接口是T1 4/0,并且备份是T1 4/1。T1控制器5/0和5/1有24条B信道可用对他们

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

NFAS 术语

常用的NFAS期限如下:

  • NFAS -允许单个D信道对控制多个PRI的ISDN服务。使用对控制多个PRI的单个D信道允许在每个接口的一条B信道运载其他流量。

  • 24个B信道接口- PRI信道组配置有NFAS D信道;所有24个信道是B信道。此特定的T1在主要控制器使用配置的D信道发信号。

  • NFAS group-a分组(接口的组)受单个D信道的控制PRI信道。信道组能包括在多个T1控制器的所有ISDN信道。

    注意: NFAS可以用成员配置用在路由器的不同的slot (例如, NFAS成员没有限制到在同一个slot或模块)。并且,在单个机箱内,支持五NFAS组。在使用处从多个供应商的T1,他们由供应商经常分组。

  • NFAS成员- PRI在NFAS组中。例如,如果T1控制器1/0, 1/1和2/0在一NFAS组中,配置NFAS组也许包括serial interfaces 1/0:23, 1/1:23和2/0:23。要显示所有NFAS的成员请分组,请使用show isdn nfas group privileged exec命令。

需要的命令

注意: 正常ISDN PRI配置命令在本文没出现。请参阅相关信息部分关于配置ISDN PRI的更多信息。

pri-group timeslots 1-24 nfas_d功能nfas_interface int_number nfas_group group_number

此控制器配置命令在组内分配T1控制器到NFAS组并且选定其功能。指定以下值作为适当:

  • 功能-时隙将执行的功能24,二者之一主要的,备份或者无。每NFAS组必须有一主要的。路由器不要求备份,然而多数NFAS实施有备份D信道。请与电话公司联系您的确定您是否应该配置您的NFAS组的备份D信道。控制器的其余可以配置与无,选定第24个时隙作为B信道。

    注意: 正确地配置主要的和备份D信道如指定由您的Telco。与NFAS配置的一个常见错误不正确地是T1主要的,并且是备份的desginating。

  • int_number -分配由服务提供商和用于的值独特识别PRI。从0的值可能的范围到在路由器的最高的T1联机,减一个。例如,如果路由器有10 T1 NFAS接口编号能排列在0和9.之间。必须分配0个接口到主要的D信道和1个接口对备份D信道。

    注意: 在某些情况下NFAS设置不使用备份D信道的地方,请勿使用关键字nfas_interface 1,为备份D信道保留。配置仅nfas_interface 0, 2, 3, 4等等。

    注意: 当配置广泛NFAS组时,必须分配0个接口到每主要的D信道和1个接口对每备份D信道,假设他们是在一不同的nfas_group。

  • group_number -组标识符唯一在路由器。广泛NFAS组在路由器能存在。每组必须用主要和备用控制器配置。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/9584/quadt1_nfas.gif

配置

本文档使用以下配置:

Cisco 7507
! 
! 
Last configuration change at 13:07:00 cst Mon Jan 31 2000 
!
version 12.0 
no service pad 
service timestamps debug uptime 
service timestamps log datetime localtime show-timezone 
no service password-encryption 
! 
hostname Router 
! 
enable secret 
! 
ip subnet-zero 
no ip domain-lookup 
ip host west 172.22.173.21
isdn switch-type primary-dms100 

!--- Switchtype must be configured. 
!--- Contact your Telco for more information.
!--- Primary T1 controller.

controller T1 4/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1 

!--- Primary D channel, nfas interface 0 and member of group 1.

controller T1 4/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1 


!--- Backup D channel, nfas interface 1 and member of group 1. 


controller T1 5/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 2 and member of group 1.


controller T1 5/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 3 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 3 and member of group 1.

process-max-time 200 
! 
interface FastEthernet1/0/0   
 ip address 10.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 full-duplex 
! 
interface FastEthernet1/1/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 shutdown 

!--- D channel for primary controller.
!--- Note: Other D channels in the group are not seen.
!--- All configuration changes made to the primary D channel propagate 
to all the NFAS group members.


interface Serial4/0:23 
 description primary d channel 
 no ip address 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool-member 1 
 isdn switch-type primary-dms100 
 isdn tei-negotiation first-call 
 ppp authentication chap 
 ppp multilink 
! 
interface Dialer0 
 ip address 192.168.10.1 255.255.255.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer remote-name C3620-EA-BCO 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap 
 ppp multilink 
!
router eigrp 200 
 redistribute static 
 network 10.0.0.0 
 network 192.168.10.0 

! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.1.2 
! 
dialer-list 1 protocol ip permit 
! 
line con 0 
 transport input none 
line aux 0 
 password
   login
  modem InOut
  stopbits 1
 line vty 0 4
  exec-timeout 60 0
  password 
 login 
! 
end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show isdn status -确保路由器用ISDN交换机适当地通信。在输出中,验证第1层状态是否为活跃状态,是否第2层状态=MULTIPLE_FRAME_ESTABLISHED出现。

  • show isdn nfas group privileged exec命令显示指定的NFAS组或所有NFAS组的成员。

  • show isdn service -显示每个ISDN信道状态和服务状况的Privileged exec命令。D信道指示如保留。如果单个信道是占线的或有故障,此命令可以用于验证。

  • show controller t1 -显示控制器状态特定到控制器硬件。它也显示信息排除故障物理层和数据链路层问题。在正常操作,输出应该表明控制器上,并且没有报警。

注意: 确保作为主要的被选定的T1连接由Telco和在您的路由器配置方面连接对正确端口。常见错误有错误的T1线路(电缆)连接对在您的路由器的主要的T1端口。

show 输出示例

以下从路由器的一些show命令输出配置与NFAS。

下面是 show isdn status 命令输出的示例:

Router#show isdn status 
Global ISDN Switchtype = primary-dms100 
ISDN Serial4/0:23 interface
         dsl 0, interface ISDN Switchtype = primary-dms100 : 
Primary D channel of nfas group 1
     Layer 1 Status:
         ACTIVE

!--- Primary D channel is active

    Layer 2 Status: 
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED 

!--- Layer 2 is established correctly

    Layer 3 Status: 
        23 Active Layer 3 Call(s) 
    Activated dsl 0 CCBs = 23 
        CCB:callid=0xA0B, sapi=0x0, ces=0x0, B-chan=1 
        CCB:callid=0xA0C, sapi=0x0, ces=0x0, B-chan=3 
        CCB:callid=0xA0D, sapi=0x0, ces=0x0, B-chan=4 
        CCB:callid=0xA0E, sapi=0x0, ces=0x0, B-chan=2 
        CCB:callid=0xA0F, sapi=0x0, ces=0x0, B-chan=5 
        CCB:callid=0xA10, sapi=0x0, ces=0x0, B-chan=6 
        CCB:callid=0xA11, sapi=0x0, ces=0x0, B-chan=7 
        CCB:callid=0xA12, sapi=0x0, ces=0x0, B-chan=8 
        CCB:callid=0xA13, sapi=0x0, ces=0x0, B-chan=9 
        CCB:callid=0xA14, sapi=0x0, ces=0x0, B-chan=10 
        CCB:callid=0xA15, sapi=0x0, ces=0x0, B-chan=11 
        CCB:callid=0xA16, sapi=0x0, ces=0x0, B-chan=12 
        CCB:callid=0xA17, sapi=0x0, ces=0x0, B-chan=13 
        CCB:callid=0xA18, sapi=0x0, ces=0x0, B-chan=14 
        CCB:callid=0xA1B, sapi=0x0, ces=0x0, B-chan=15 
        CCB:callid=0xA1C, sapi=0x0, ces=0x0, B-chan=16 
        CCB:callid=0xA1D, sapi=0x0, ces=0x0, B-chan=17 
        CCB:callid=0xA1E, sapi=0x0, ces=0x0, B-chan=18 
        CCB:callid=0xA1F, sapi=0x0, ces=0x0, B-chan=19 
        CCB:callid=0xA20, sapi=0x0, ces=0x0, B-chan=20 
        CCB:callid=0xA21, sapi=0x0, ces=0x0, B-chan=21 
        CCB:callid=0xA22, sapi=0x0, ces=0x0, B-chan=22 
        CCB:callid=0xA23, sapi=0x0, ces=0x0, B-chan=23 
    The Free Channel Mask:  0x80000000 
ISDN Serial4/1:23 interface
         dsl 1, interface ISDN Switchtype = primary-dms100 :
 Backup D channel of nfas group 1
     Layer 1 Status:
         DEACTIVATED
     Layer 2 Status:
         TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED 
    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 1 CCBs = 0 
    The Free Channel Mask:  0x7E7FFB 
ISDN Serial5/0:23 interface
         dsl 2, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1
     Layer 1 & 2 Status Not Applicable
 
!--- NFAS member: D channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 2 CCBs = 0 
    The Free Channel Mask:  0x0 
ISDN Serial5/1:23 interface
         dsl 3, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1 
    Layer 1 & 2 Status Not Applicable

!--- NFAS member-channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 3 CCBs = 0 
    The Free Channel Mask:  0x80000000 
    Total Allocated ISDN CCBs = 23

注意: 输出的show isdn status只显示信息关于主要的和备用控制器的D信道。并且,仅主要的D信道(Serial4/0:23)显示设立的激活和多个帧。备份D信道状态(Serial4/1:23)出现作为DEACTIVATED和TEI_ASSIGNED。

第1层的show isdn status T1的5/0和5/1输出和Layer2被选定不可适用,因为第24个信道(Serial5/0:23和序列5/1:23)使用作为B信道。

这是show isdn nfas group命令输出:

Router#show isdn nfas group 1 
ISDN NFAS GROUP 1 ENTRIES:The primary D is Serial4/0:23.    
The backup D is Serial4/1:23.    
The NFAS member is Serial5/0:23.    
The NFAS member is Serial5/1:23. 
There are 4 total nfas members.    
There are 68 total available B channels. 
The primary D-channel is DSL 0 in state IN SERVICE. 
The backup D-channel is DSL 1 in state OUT OF SERVICE. 
The current active layer 2 DSL is 0.

注意: show isdn nfas group输出显示组的组员。输出显示控制器4/0主要的,并且4/1是备份。控制器5/0和5/1是组的组员并且有24条B信道可用对他们。

输出也显示NFAS成员和可用的信道数量总数。它显示主要的D信道在使用中,当备份是服务中断时。

这是一show isdn service命令输出的示例:

Router# show isdn service 
PRI Channel Statistics:
 ISDN Se4/0:23, Channel [1-24]
      Configured Isdn Interface (dsl) 0
      Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3
      Service State (0=Inservice 1=Maint 2=Outofservice)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
 ISDN Se4/1:23, Channel [1-24]
     Configured Isdn Interface (dsl) 1
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
     2 2 0 2 2 2 2 2 2 2 2 2 2 2 2 0 0 2 2 2 2 2 0 3  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 2 2 0 0 0 0 0 0 0  
ISDN Se5/0:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 2 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
ISDN Se5/1:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 3 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
Router#

show isdn service输出显示主要的D信道和附属在状态3,对应于保留。其他成员的D信道在状态2,指示他们忙碌和在使用中作为B信道。信道状态0表明信道是可用的为使用。

注意: 在许多设备(通常接入服务器)中D信道的服务状态是2,表明信道是服务中断。这是表面问题,并且不应该影响您的连接。确定D信道是否如前所述实际上是作用的使用show isdn status命令

对于没有被选定作为主要的或备份的控制器(5/0和5/1),请保证第24个信道在空闲或忙碌状态。它不应该在保留状态。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出调试指令前,参考关于调试指令的重要信息

  • debug isdn q931 -表示呼叫建立并且切断ISDN网络连接(层3)。

  • debug isdn q921 -表示数据链路层消息(在D信道的层2)在路由器和ISDN交换机之间。如果show isdn status命令不显示第1层和第2层,请使用此debug。

如果控制器关闭

当属于NFAS组的控制器关闭时,什么发生?关闭的控制器将清除在那的所有激活的呼叫,并且之一以下将应用:

  • 如果关闭的控制器主要的,并且备份没有配置,所有激活的呼叫总体上分组被清除。

  • 如果关闭的控制器主要的,活动(IN服务) D信道在主要的,并且备份配置,对备用控制器的活动D信道交换机。

  • 如果关闭的控制器主要的,并且活动(IN服务) D信道在备份,活动D信道在备用控制器坚持。

  • 如果关闭的控制器是备份,并且活动D信道在备份,活动D信道变成主要控制器。

注意: 在主要的和备用控制器之间的活动D信道过渡发生,只有当链路之一发生故障时,并且没有,当链路出来时。


相关信息


Document ID: 9584