网络应用服务 : 思科 500 系列高速缓存引擎

排除WCCP的反向透明缓存故障

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

当用于实现反向透明缓存时,本文描述如何排除故障WEB缓存通信协议(WCCP)。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 在本地模式配置的Catalyst 6500用Supervisor 1和MSFC1

  • Cisco IOSï ¿  ½软件版本12.1(8a)EX (c6sup11-jsv-mz.121-8a.EX.bin)

  • 与版本2.51的Cache Engine 550

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的信息,请参阅 Cisco 技术提示规则

配置

tshoot_wccp_9251.gif

当您安装Cache Engine时,思科建议您配置必要仅的命令实现WCCP。您能添加其它特性,例如验证到路由器和客户端重定向列表,以后。

在Cache Engine,您必须指定路由器的IP地址,并且您要使用WCCP的版本。


wccp router-list 1 192.168.15.1    
   wccp reverse-proxy router-list-num 1    
   wccp version 2

一旦WCCP IP地址和版本配置,您也许发现警告在路由器应该激活的消息服务99为了实现反向透明缓存。服务99是反向透明缓存的WCCP服务标识符。正常透明缓存的标识符是词“web-cache”在Cisco IOS。为了启动在路由器的服务99 (反向透明缓存)和为了指定重定向将执行的端口,请添加这些in命令全局配置模式:


ip wccp 99
interface Vlan200 
    ip address 10.10.10.120 255.255.255.0 
    ip wccp 99 redirect out 

当您配置反向透明缓存时,管理WCCP服务99的路由器拦截请求指向对Web服务器。ip wccp 99 redirect out命令在您在他们的路径要截断客户端HTTP数据包到您的Web服务器的接口应用。一般,这是Web服务器VLAN。这通常不是Cache Engine安装的VLAN。

一旦WCCP是活跃的,路由器在有配置的WCCP重定向的所有端口侦听。要发信号其在线状态, Cache Engine不断地发送此处WCCP我是数据包对IP地址在路由器列表配置。

路由器和缓存之间的一WCCP连接形成。为了查看连接信息,发出show ip wccp命令

因为乘缓存引擎,看到路由器标识符是路由器的IP地址。此标识符不一定是重定向的数据流用于的路由器接口到达缓存。在本例中的路由器标识符是192.168.15.1。

Router#show ip wccp 
   Global WCCP information: 
       Router information: 
           Router Identifier:                  192.168.15.1 
           Protocol Version:                   2.0
    Service Identifier: 99 
           Number of Cache Engines:            1 
           Number of routers:                  1 
           Total Packets Redirected:           0 
           Redirect access-list:               -none- 
           Total Packets Denied Redirect:      0 
           Total Packets Unassigned:           0 
           Group access-list:                  -none- 
           Total Messages Denied to Group:     0 
           Total Authentication failures:      0

关于缓存的show ip wccp 99 detail命令提供详细信息。

Router#show ip wccp 99 detail 
   WCCP Cache-Engine information: 
           IP Address:               192.168.15.2 
           Protocol Version:         2.0 
           State:                    Usable 
           Redirection:              GRE 
           Initial Hash Info:        FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                                     FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF    
           Assigned Hash Info:       FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                                     FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF    
           Hash Allotment:           256 (100.00%) 
           Packets Redirected:       0 
           Connect Time:             00:00:39

Redirection字段代表使用的方法重定向从路由器的数据包到Cache Engine。此方法是通用路由封装(GRE)或Layer2。使用GRE,数据包在GRE数据包被封装。使用Layer2,数据包是发送的直通到缓存,但是Cache Engine和交换机或者路由器必须是Layer2相邻为Layer2重定向。

在十六进制代表的哈希分配最初的哈希资讯台分配的哈希资讯台字段是的哈希桶数量分配到此缓存。所有可能的来源互联网地址分开成64个相等大小的范围,每个范围一个桶,并且每个缓存分配从一定数量的这些桶源地址范围的流量。此数量由WCCP动态地管理根据缓存的负载和负荷衡量。如果只安排一个缓存安装,此缓存也许分配所有桶。

当路由器启动重定向数据包到Cache Engine时,在Total Packets Redirected字段的编号增加。

Total Packets Unassigned字段是未重定向数据包的数量,因为他们未分配到任何缓存。在本例中,当缓存删除时,数据包数量是5.数据包也许是未分配在缓存初始发现期间或一个小间隔的。

Router#show ip wccp 
   Global WCCP information: 
       Router information: 
           Router Identifier:                      192.168.15.1 
           Protocol Version:                       2.0
    Service Identifier: 99 
           Number of Cache Engines:                1 
           Number of routers:                      1 
           Total Packets Redirected:               28 
           Redirect access-list:                   -none- 
           Total Packets Denied Redirect:          0 
           Total Packets Unassigned:               5 
           Group access-list:                      -none- 
           Total Messages Denied to Group:         0 
           Total Authentication failures:          0

如果缓存不由路由器获得,调试WCCP活动也许是有用的。每当路由器接收此处我是从缓存的数据包,回答与我看到您数据包,并且这在调试报告。可用的调试指令是debug ip wccp eventsdebug ip wccp packets

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

此输出提供正常WCCP调试消息示例:

Router#debug ip wccp event 
   WCCP events debugging is on 
  Router#debug ip wccp packet 
   WCCP packet info debugging is on 
   Router# 
   2d18h: WCCP-EVNT:S00: Built new router view: 0 routers,   
          0 usable web caches, change # 00000001 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to
          192.168.15.2 w/ rcv_id 00000001 
   2d18h: WCCP-EVNT:S00: Redirect_Assignment packet from
          192.168.15.2 fails source check 
   2d18h: %WCCP-5-SERVICEFOUND: Service web-cache
          acquired on Web Cache 192.168.15.2 
   2d18h: WCCP-PKT:S00: Received valid Here_I_Am packet
          from 192.168.15.2 w/rcv_id 00000001 
   2d18h: WCCP-EVNT:S00: Built new router view: 1
          routers, 1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000002 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000002 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000003 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000003 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000004 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000005 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000006 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000006

为了增加调试级别,您也许要跟踪IP数据包流量为了证实路由器是否收到从Cache Engine的数据包。为了避免超载在生产环境的一个路由器和为了显示仅关注数据流,您能使用ACL仅限制调试到有缓存的IP地址作为来源的数据包。示例ACL是access-list 130 permit ip主机192.168.15.2主机192.168.15.1

Router#debug ip wccp event 
   WCCP events debugging is on 
  Router#debug ip wccp packet 
   WCCP packet info debugging is on 
  Router#debug ip packet 130 
   IP packet debugging is on for access list 130    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 0000001B 
   2d19h: datagramsize=174, IP 18390: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001C 
   2d19h: datagramsize=174, IP 18392: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001D 
   2d19h: datagramsize=174, IP 18394: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001E 
   2d19h: datagramsize=378, IP 18398: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 364, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 0000001E 
   2d19h: datagramsize=174, IP 18402: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001F 
   2d19h: datagramsize=174, IP 18404: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000020 
   2d19h: datagramsize=174, IP 18406: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000021 
   2d19h: datagramsize=378, IP 18410: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 364, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 00000021 
   2d19h: datagramsize=174, IP 18414: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000022 
   2d19h: datagramsize=174, IP 18416: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3

在缓存没有由路由器情况下看到,并且WCCP活动没有被看到,请检查基本连通性。设法ping从路由器或路由器的缓存从缓存。如果ping工作,错误也许在配置里存在。

如果缓存获取,但是数据包没有重定向,请验证路由器收到流量,并且流量转发对ip wccp 99 redirect out命令应用的接口。切记拦截并且重定向的流量是仅流量被处理对TCP端口80。

如果流量仍然没有重定向,并且Web内容是从服务器的以后的直通,请验证缓存正确地通过关于怎样的说明拦截。您必须有关于WCCP的一些背景信息为了完成此操作。

WCCP识别两种不同的服务类型:标准动态。路由器隐含地知道标准服务。即,因为已经知道如此,执行路由器不需要被通知使用端口80。正常透明缓存(web-cache -标准服务0)是标准服务。

在(中包括透明缓存)的所有其他案件,路由器被通知拦截的哪个端口。此信息在通过在这里我数据包。

您能发出debug ip packet dump命令为了检查数据包。请使用Cache Engine创建的调试仅发送的数据包ACL。

Router#debug ip packet 130 dump 
   2d19h: datagramsize=174, IP 19576: s=192.168.15.2 (Vlan300), d=192.168.15.1 
      (Vlan300), totlen 160, fragment 0, fo 0, 
   rcvd 3 
   072C5120:                       0004 9B294800            ...)H. 

!--- Start IP header.
 
   072C5130: 00500F0D 25360800 450000A0 4C780000  .P..%6..E.. Lx..    
   072C5140: 3F118F81 C0A80F02 C0A80F01 08000800  ?...@(..@(......    
   072C5150: 008CF09E 0000000A 0200007C 00000004  ..p........|.... 

!--- Start WCCP header.

   072C5160: 00000000 00010018 0163E606 00000515  .........cf.....    
   072C5170: 00500000 00000000 00000000 00000000  .P.............. 

!--- Port to intercept (0x50=80).

   072C5180: 0003002C C0A80F02 00000000 FFFFFFFF  ...,@(.......... 

!--- Hash allotment (FFFF...).

   072C5190: FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF  ................ 
   072C51A0: FFFFFFFF FFFFFFFF FFFF0000 00000000  ................ 
   072C51B0: 00050018 00000002 00000001 C0A80F01  ............@(..    
   072C51C0: 0000000C 00000001 C0A80F02 00080008  ........@(......    
   072C51D0: 00010004 00000001 30                 ........0

用此命令,您能确定端口是否通告,不用需要查看整个请求注释(RFC)。如果端口没有通告,问题在缓存的配置里是很可能。

参考的WEB缓存通信协议V2.0leavingcisco.com 欲知更多信息。

如果缓存获取,并且数据包重定向,但是您的互联网客户端不能浏览您的服务器,请证实缓存是否有连接到互联网和到您的服务器。从缓存ping到在互联网的多种IP地址和对你的一些内部服务器。如果ping完全合格的域(URL)而不是IP地址,请务必您指定DNS服务器在缓存配置里使用。

如果是不确定的缓存是否处理请求,您能调试HTTP活动在缓存。为了调试HTTP活动在缓存,您必须限制流量避免超载缓存。在路由器上,请在您能使用作为设备您的测验的互联网里创建与一个客户端源IP地址的ACL并且请使用选项redirect-list global命令ip WCCP 99

Router(config)#access-list 50 permit 172.17.241.126
Router(config)#ip wccp 99 redirect-list 50

一旦创建并且应用ACL,请完成这些步骤:

  1. 在有debug http all all命令(Cisco缓存引擎版本2.x)或调试http的全部缓存激活HTTP调试(Cisco缓存引擎版本3和ACNS版本4, 5)。

  2. 激活终端的监控(请发出term mon命令)。

  3. 设法浏览你的一个从您在ACL配置的客户端的服务器。

这是输出的示例:

irq0#conf tcework_readfirstdata() Start the recv: 0xb820800 len 4096 timeout    
   0x3a98 ms ctx 0xb87d800 
   cework_recvurl() Start the request: 0xb20c800 0xb20c838 0xb20c8e0 
   Http Request headers received from client:    
   GET / HTTP/1.1 
   Host: 10.10.10.152 
   User-Agent: Links (0.92; Linux 2.2.16-22 i686) 
   Accept: */* 
   Accept-Charset: us-ascii, ISO-8859-1, ISO-8859-2, ISO-8859-4, ISO-8895-5,    
      ISO-8859-13, windows-1250, windws-1251, windows-1257, cp437, cp850, cp852,
       cp866, x-cp866-u, x-mac-ce, x-kam-cs, x-koi8-r, x-koi8-u, utf8 
   Connection: Keep-Alive

Protocol dispatch: mode=1 proto=2 
   ValidateCode() Begin: pRequest=0xb20c800 
   Proxy: CACHE_MISS: HealProcessUserRequest 
   cework_teefile() 0xb20c800: Try to connect to server: CheckProxyServerOut():    
      Outgoing proxy is not enable: 0xb20c800 (F) 
   GetServerSocket(): Forwarding to server: pHost = 10.10.10.152, Port = 80    
   HttpServerConnectCallBack : Connect call back socket = 267982944, error    = 0 
   Http request headers sent to server:    

   GET / HTTP/1.1 
   Host: 10.10.10.152 
   User-Agent: Links (0.92; Linux 2.2.16-22 i686) 
   Accept: */* 
   Accept-Charset: us-ascii, ISO-8859-1, ISO-8859-2, ISO-8859-4, ISO-8895-5,    
      ISO-8859-13, windows-1250, windws-1251, windows-1257, cp437, cp850, cp852, 
      cp866, x-cp866-u, x-mac-ce, x-kam-cs, x-koi8-r, x-koi8-u, utf8 
   Connection: keep-alive 
   Via: 1.1 irq0 
   X-Forwarded-For: 172.17.241.126

cework_sendrequest: lBytesRemote = 386, nLength = 386 (0xb20c800)    
   ReadResCharRecvCallback():  lBytesRemote = 1818, nLength = 1432 0xb20c800)    
   IsResponseCacheable() OBJECTSIZE_IS_UNLIMITED, lContentLength = 3194    
   cework_processresponse() : 0xb20c800 is cacheable 
   Http response headers received from server:    
   HTTP/1.1 200 OK 
   Date: Tue, 20 Nov 2001 10:46:14 GMT 
   Server: Apache/1.3.12 (Unix)  (Red Hat/Linux) mod_ssl/2.6.6 OpenSSL/0.9.5a 
      mod_perl/1.24 
   Last-Modified: Fri, 12 Oct 2001 12:55:23 GMT 
   ETag: "5e23-c7a-3bc6e83b" 
   Accept-Ranges: bytes 
   Content-Length: 3194 
   Keep-Alive: timeout=15, max=100 
   Connection: Keep-Alive 
   Content-Type: text/html

GetUpdateCode(): GET request from client, GET request to server. 
   GetUpdateCode(): nRequestType = -1 
   SetTChain() 0xb20c800: CACHE_OBJECT_CLIENT_OBJECT sendobj_and_cache    
   Http response headers sent to client:    
   HTTP/1.1 200 OK 
   Date: Tue, 20 Nov 2001 10:46:14 GMT 
   Server: Apache/1.3.12 (Unix)  (Red Hat/Linux) mod_ssl/2.6.6 OpenSSL/0.9.5a    
      mod_perl/1.24 
   Last-Modified: Fri, 12 Oct 2001 12:55:23 GMT 
   ETag: "5e23-c7a-3bc6e83b" 
   Content-Length: 3194 
   Keep-Alive: timeout=15, max=100 
   Content-Type: text/html 
   Connection: keep-alive

cework_tee_sendheaders() 0xb20c800: sent 323 bytes to client 
   cework_tee_send_zbuf() 0xb20c800: Send 1087 bytes to client (1087)    
   UseContentLength(): Valid Content-Length (T) 
   cework_tee_recv_zbuf() 0xb20c800: Register to recv 2107 bytes timeout 120 sec 
   HttpServerRecvCallBack(): Recv Call Back socket 267982944, err 0, length  2107 
   HttpServerRecvCallBack(): lBytesRemote = 3925, nLength = 2107 (186697728)    
   cework_tee_send_zbuf() 0xb20c800: Send 2107 bytes to client (2107)    
   UseContentLength(): Valid Content-Length (T) 
   cework_setstats(): lBytesLocal = 0, lBytesRemote = 3925 (0xb20c800)    
   cework_readfirstdata() Start the recv: 0xb84a080 len 4096 timeout 0x3a98    
      ms ctx 0xb87d800 
   cework_cleanup_final() End the request: 0xb20c800 0xb20c838 0xb20c8e0

您在调试也许查找的相关信息用黑体字表示。

这些是网页页处理的不同的相位:

  1. 从客户端接收的HTTP请求报头。

  2. HTTP请求报头发送对服务器。

  3. 从服务器接收的HTTP响应报头。

  4. HTTP响应报头发送对客户端。

如果您浏览的网页包含多个对象,此事件顺序多个实例存在。请使用最简单的可能的请求减少debug输出。

在Catalyst 6500或Cisco 7600路由器上,功能管理器处理在Cisco IOS配置的所有功能为了提供故障排除一块已添加层。当第3层功能在这些设备时配置,定义了如何的信息处理了收到的帧通过对交换机或路由器(功能管理器)的Layer2控制功能。对于WCCP,此控制信息定义了IOS和WCCP截断什么数据包并且被导向到透明缓存。

show fm features命令显示在Cisco IOS启用的功能。您能使用此命令为了证实拦截的端口是否由Cache Engine正确地通告。

Router#show fm features 
   Redundancy Status: stand-alone 
   Interface: Vlan200 IP is enabled 
     hw[EGRESS] = 1, hw[INGRESS] = 1 
     hw_force_default[EGRESS] = 0, hw_force_default[INGRESS] = 0    
     mcast = 0 
     priority = 2 
     reflexive = 0 
     vacc_map : 
     outbound label: 5 
           merge_err: 0 
           protocol: ip 
             feature #: 1    
             feature id: FM_IP_WCCP    
             Service ID: 99    
             Service Type: 1

The following are the used labels 
     label 5: 
           swidb: Vlan200 
           Vlous:

The following are the features configured 
     IP WCCP: service_id = 99, service_type = 1, state = ACTIVE 
           outbound users: 
             user_idb: Vlan200    
           WC list: 
             address: 192.168.15.2    
           Service    ports: 
             ports[0]:    80

The following is the ip ACLs port expansion information 
     FM_EXP knob configured: yes

FM mode for WCCP: GRE (flowmask: destination-only)

FM redirect index base: 0x7E00

The following are internal statistics 
     Number of pending tcam inserts: 0 
     Number of merge queue elements: 0

show fm int vlan 200命令显示确切的内容三重内容可编址存储器。

Router#show fm int vlan 200 
 Interface: Vlan200 IP is enabled 
  hw[EGRESS] = 1, hw[INGRESS] = 1 
  hw_force_default[EGRESS] = 0, hw_force_default[INGRESS] = 0    
  mcast = 0 
  priority = 2 
  reflexive = 0 
  vacc_map : 
  outbound label: 5 
   merge_err: 0 
   protocol: ip 
    feature #: 1    
    feature id: FM_IP_WCCP    
    Service ID: 99    
    Service Type: 1    
     (only for IP_PROT) DestAddr SrcAddr          Dpt   Spt  L4OP TOS Est  prot  Rslt 
     vmr IP value #1:   0.0.0.0  192.168.15.2     0     0    0    0   0    6     permit 
     vmr IP mask  #1:   0.0.0.0  255.255.255.255  0     0    0    0   0    FF 
     vmr IP value #2:   0.0.0.0  0.0.0.0          80    0    0    0   0    6     bridge 
     vmr IP mask  #2:   0.0.0.0  0.0.0.0          FFFF  0    0    0   0    FF 
     vmr IP value #3:   0.0.0.0  0.0.0.0          0     0    0    0   0    0     permit 
     vmr IP mask  #3:   0.0.0.0  0.0.0.0          0     0    0    0   0    0

vmr IP值# 1 :线路定义了在来自Cache Engine的帧的拦截旁路。没有此,有重定向环路。vmr IP值# 2 :线路定义了有端口80作为他们的目的地所有数据包的拦截。如果端口80在第二行没有显示,但是WCCP是活跃的,并且缓存由路由器是可用的,则在缓存配置里也许有一问题。收集转储在这里我数据包为了确定端口是否由缓存发送。

如果无法解决问题,在您排除故障后,问题向Cisco技术支持中心(TAC)报告

这是您必须提供给Cisco TAC的一些基本信息。从路由器,请收集此信息:

  • 输出show tech命令。如果有与show tech输出的大小的,困难show running-config的输出和show version输出命令可以被替代。

  • 输出show ip wccp命令

  • 输出show ip wccp web-cache detail命令

  • 如果看起来似乎与通信的一问题路由器和Web缓存之间,请提供从debug ip wccp eventsdebug ip wccp packets命令的输出,当问题发生时。

在Cache Engine (仅Cisco Cache引擎),请收集输出show tech命令

当您与TAC联系时,请完成这些步骤:

  1. 提供问题的一清楚说明。您应该包括对回答这些问题:

    • 什么是症状?

    • 它是否一直或偶尔地发生?

    • 在配置上的一个变化以后问题开始?

    • 使用思科或第三方缓存?

  2. 提供拓扑的一清楚说明。如果那将做它更多结算,请包括图表。

  3. 提供您认为是有用的在解决问题的其他信息。

这是配置示例的输出:

*********************************** Router Configuration *****************************
Router#show running 
   Building configuration...
Current configuration : 4231 bytes 
   ! 
   version 12.1 
   service timestamps debug uptime 
   service timestamps log uptime 
   no service password-encryption 
   ! 
   hostname Router 
   ! 
   boot buffersize 126968 
   boot bootldr bootflash:c6msfc-boot-mz.120-7.XE1    
   ! 
   redundancy 
    main-cpu 
     auto-sync standard 
   ip subnet-zero 
   ip wccp 99 
   ! 
   ! 
   ! 
   interface FastEthernet3/1 
    no ip address 
    switchport 
    switchport access vlan 100 
    switchport mode access 
   ! 
   interface FastEthernet3/2 
    no ip address 
    switchport 
    switchport access vlan 200 
    switchport mode access 
   ! 
   interface FastEthernet3/3 
    no ip address 
    switchport 
    switchport access vlan 300 
    switchport mode access 
   ! 
   interface FastEthernet3/4 
    no ip address 
   ! 
! 
   interface Vlan100 
    ip address 172.17.241.97 255.255.255.0    
   ! 
   interface Vlan200 
    ip address 10.10.10.120 255.255.255.0    
    ip wccp 99 redirect out 
   ! 
   interface Vlan300 
    ip address 192.168.15.1 255.255.255.0    
   ! 
   ip classless 
   ip route 0.0.0.0 0.0.0.0 172.17.241.1    
   no ip http server 
   ! 
   access-list 30 permit 192.168.15.2 
   ! 
   ! 
   line con 0 
    exec-timeout 0 0 
   line vty 0 4 
    login 
    transport input lat pad mop telnet rlogin udptn    nasi 
   ! 
   end
*********************************** Cache Configuration ******************************
Cache#show running
Building configuration... 
   Current configuration: 
   ! 
   ! 
   logging disk /local/syslog.txt debug 
   ! 
   user add admin uid 0  capability admin-access    
   ! 
   ! 
   ! 
   hostname Cache 
   ! 
   interface ethernet 0 
    ip address 192.168.15.2 255.255.255.0    
    ip broadcast-address 192.168.15.255    
    exit 
   ! 
   interface ethernet 1 
    exit 
   ! 
   ip default-gateway 192.168.15.1 
   ip name-server 172.17.247.195 
   ip domain-name cisco.com 
   ip route 0.0.0.0 0.0.0.0 192.168.15.1    
   cron file /local/etc/crontab 
   ! 
   wccp router-list 1 192.168.15.1 
   wccp reverse-proxy router-list-num 1 
   wccp version 2 
   ! 
   authentication login local enable 
   authentication configuration local enable    
   rule no-cache url-regex .*cgi-bin.* 
   rule no-cache url-regex .*aw-cgi.* 
   ! 
   ! 
   end

相关信息


Document ID: 9251