局域网交换 : 802.1Q

配置示例:Catalyst 2900XL/3500XL/2950 与 CatOS 交换机之间的 ISL/802.1q 中继

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 10 月 20 日) | 反馈


目录


简介

本文为交换机间链路协议(ISL)提供建立中继在思科Catalyst 5500和Catalyst 3500xl交换机之间的配置示例和IEEE 802.1Q。当您发出命令,本文显示每命令结果。您在本文的方案能使用这些交换机中的任一得到同样结果:

  • 运行Catalyst OS的Catalyst 4500/4000及6500/6000系列交换机(CatOS)

  • 其他成员Catalyst 5500/5000系列

  • Catalyst层2固定配置交换机中的任一

    Catalyst层2固定配置交换机包括2900/3500XL, 2940, 2950/2955和2970。

在您进一步继续进行本文前,参考的VLAN中继协议支持

先决条件

要求

本文档没有任何特定的要求。

使用的组件

要创建在本文的示例,这些交换机清除配置用于实验室环境:

  • 运行Cisco IOSï ¿  ½软件版本12.0(5)WC7的Catalyst 3524xl交换机

  • 运行CatOS 6.4(2)软件的Catalyst 5500交换机

本文档中的配置在隔离的实验室环境中实施。保证您了解所有配置或on命令潜在影响您的网络。在所有设备的配置用clear config all命令清除了在Catalyst 5500交换机和write erase命令在Catalyst 3524xl交换机保证默认配置。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景理论

中继是一种在两个设备之间点到点链路上传输来自若干 VLAN 的流量的方式。您能实施以太网中继的二种方式是:

  • ISL,思科专有协议

  • IEEE 802.1Q标准

本文创建运载从两VLAN的流量在Catalyst 3500和Catalyst 5500交换机之间的单条链路间的中继。如何在2个VLAN 之间选路由不属于本文讨论范围。

重要说明

Catalyst 2940/2950/2955/2970交换机

仅Catalyst 2940及2950/2955系列交换机支持802.1q中继。这些交换机不支持ISL中继。

Catalyst 2970系列交换机支持ISL和802.1q中继。

Catalyst 2900xl/3500XL交换机

Catalyst 2900XL/3500XL 交换机目前不支持动态中继协议 (DTP)。请使用非协商选项switchport trunk命令在中继链路的另一侧。使用非协商选项防止DTP帧收据XL交换机不能处理的对等体。

注意: 在4-MB DRAM Catalyst 2900XL交换机上,只有中继支持用这些有中继能力的模块:

  • WS-X2914-XL-V

  • WS-X2922-XL-V

  • WS-X2924-XL-V

  • WS-X2931-XL

  • WS-X2932-XL

参见此表关于支持中继的当前交换机模型列表:

交换机型号 最低Cisco IOS软件版本必要为ISL中继 最低Cisco IOS软件版本必要为802.1q中继 当前Cisco IOS软件版本必要为建立中继(ISL/802.1Q)
WS-C2916M-XL (4-MB交换机) Cisco IOS软件版本11.2(8)sa4,企业版 Cisco IOS软件版本11.2(8)sa5,原始版本 Cisco IOS软件版本11.2(8.6)SA6,原始版本
WS-C2912-XL WS-C2924-XL WS-C2924C-XL WS-C2924M-XL WS-C2912MF-XL Cisco IOS软件版本11.2(8)sa4,企业版 Cisco IOS软件版本11.2(8)sa5,原始版本 Cisco IOS软件版本12.0(5)wc(1)或以上版本
WS-C2924M-XL-DC Cisco IOS 软件版本 12.0(5)XU Cisco IOS 软件版本 12.0(5)XU Cisco IOS软件版本12.0(5)wc(1)或以上版本
WS-C3508G-XL WS-C3512-XL WS-C3524-XL Cisco IOS软件版本11.2(8)sa4,企业版 Cisco IOS软件版本11.2(8)sa5,原始版本 Cisco IOS软件版本12.0(5)wc(1)或以上版本
WS-C3548-XL Cisco IOS软件版本12.0(5)XP,企业版 Cisco IOS软件版本12.0(5)XP,企业版 Cisco IOS软件版本12.0(5)wc(1)或以上版本
WS-C3524-PWR-XL WS-C3524-PWR-XL Cisco IOS 软件版本 12.0(5)XU Cisco IOS 软件版本 12.0(5)XU Cisco IOS软件版本12.0(5)wc(1)或以上版本
WS-C2940-8TF-S WS-C2940-8TT-S ISL的没有支持 Cisco IOS 软件版本 12.1(13)AY Cisco IOS软件版本12.1(13)AY或以上为802.1Q ISL的没有支持
WS-C2950-12 WS-C2950-24 WS-C2950C-24 WS-C2950T-24 WS-C2955T-12 WS-C2955C-12 WS-C2955S-12 ISL的没有支持 Cisco IOS软件版本12.0(5)WC(1) 802.1Q的Cisco IOS软件版本12.0(5)wc(1)或以上版本ISL的没有支持
WS-C2970G-24T-E Cisco IOS 软件版本 12.1(11)AX Cisco IOS 软件版本 12.1(11)AX Cisco IOS 软件版本 12.1(11)AX 或更高版本

注意: 在此表里,仅WS-C2916M-XL是4-MB DRAM交换机。在列表的其他交换机是8-MB DRAM交换机。为了确定您的交换机是否有4 MB或8 MB DRAM,请发出user-level show version命令。使用命令行界面,欲知更多信息,参考如何确定交换机内存容量使用升级在Catalyst 2900XL和3500XL交换机的软件的命令行界面部分

Catalyst 4500/4000, 5500/5000和6500/6000交换机

  • Catalyst 4500/4000系列,包括Catalyst 2948g及Catalyst 2980g,仅支持802.1q中继。系列不支持ISL中继。

  • Catalyst 6500/6000系列交换机的所有以太网端口支持802.1Q或ISL封装。

  • Catalyst 5500/5000支持Trunk的端口支持仅ISL封装或者支持ISL或802.1Q。此支持方案取决于模块。发出show port capabilities命令确定支持。命令输出明确地陈述中继容量。示例如下:

    cat5509 show port capabilities 3
    Model                    WS-X5234
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    
    !--- This port supports both 802.1Q and ISL.
    
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4 
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),tx-(1q4t)
    CoS rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
  • 确保整个中继链路范围内的中继模式匹配。如果配置链路的一端作为ISL中继线,请配置链路的另一侧作为ISL。同样地,如果配置链路的一端作为802.1Q,请配置链路的另一侧作为802.1Q。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/8758/43a.gif

配置

本文档使用以下交换机配置:

本文适用于此配置交换机:

  • Set vlan在交换机的中继协议(VTP)模式。

  • 添加第二个VLAN, VLAN 2,在交换机。

    注意: 您添加那些VLAN的端口。

  • 与使用的将中继ISL或802.1Q在互联交换机的快速以太网链路。

    这允许中继运载所有VLAN的流量。

  • 启用在端口的生成树Portfast,工作站有连接。

    根据拓扑,您启用在端口3/2和3/3的生成树Portfast Catalyst 5500的和端口FastEthernet0/2和FastEthernet0/3的在Catalyst 3524xl交换机。

此步骤提供必要的命令配置中继。每个步骤包括Cisco IOS软件和CatOS命令。根据命令您的选择使用在交换机运行的软件。

  1. 配置在两交换机的VTP。

    在本例中,您配置VTP模式如透明。您能也配置交换机作为客户端或服务器。欲知更多信息,参考创建和维护VLAN

    • Cisco IOS 软件

      IOSSwitch#vlan database
      3524xl(vlan)#vtp transparent
      Setting device to VTP TRANSPARENT mode.
    • CatOS

      CatOSSwitch> (enable) set vtp mode transparent
      VTP domain modified
  2. 创建其他VLAN。

    您必须完成在两交换机的此步骤,如果VTP模式透明,正如在示例。否则,您只需要定义在VTP服务器交换机的其他VLAN。

    • Cisco IOS 软件

      IOSSwitch(vlan)#vlan 2
      VLAN 2 added:
      Name: VLAN0002
      IOSSwitch(vlan)#exit
      APPLY completed.
      Exiting....
    • CatOS

      CatOSSwitch(enable) set vlan 2
      VTP advertisements transmitting temporarily stopped,
      and will resume after the command finishes.
      Vlan 2 configuration successful
  3. 分配一些端口到VLAN,并且如果需要,同时,启用在那些端口的Portfast。

    • Cisco IOS 软件

      IOSSwitch(config)#interface fastethernet 0/2
      IOSSwitch(config-if)#switchport access vlan 2
      IOSSwitch(config-if)#spanning-tree portfast
      %Warning: portfast enabled on FastEthernet0/2.
      
      !--- Usually, you need to enable PortFast on ports that connect 
      !--- to a single host. When you have enabled PortFast,  
      !--- hubs, concentrators, switches, and bridges that connect to this 
      !--- interface can cause temporary spanning tree loops.
      !--- Use PortFast with CAUTION.
      
      IOSSwitch(config-if)#exit
      
    • CatOS

      CatOSSwitch> (enable) set vlan 2 3/2
      Vlan 2 configuration successful
      VLAN 2 modified.
      VLAN 1 modified.
      VLAN Mod/Ports
      ---- -----------------------
      2     3/2 
      CatOSSwitch> (enable) set spantree portfast 3/2 enable
      
  4. 在端口的将中继。

    • Cisco IOS 软件

      IOSSwitch(config)#interface fastethernet 0/1
      IOSSwitch(config-if)#switchport mode trunk
      
    • CatOS

      省略CatOS交换机的此步骤。在步骤,当中继,并且,同时,您定义了封装, 5,您选定端口。

  5. 输入中继封装作为ISL或802.1Q (dot1q)。

    • Cisco IOS 软件

      IOSSwitch(config-if)#switchport trunk encapsulation isl
      
      OR
      
      IOSSwitch(config-if)#switchport trunk encapsulation dot1q
      

      注意: 一旦2940/2950交换机,请勿使用这些switchport命令。仅Catalyst 2940/2950交换机支持802.1Q封装。当您在接口的将中继用switchport mode trunk命令,您自动地配置802.1Q封装。

    • CatOS

      CatOSSwitch> (enable) set trunk 3/1 nonegotiate isl
      Port(s) 3/1 trunk mode set to nonegotiate.
      Port(s) 3/1 trunk type set to Isl.
      
      !--- This switch connects to a 2900XL. 
      !--- Therefore, you must use the nonegotiate option. 
      
      CatOSSwitch> (enable)

      或者

      
      !--- If you want to configure 802.1Q trunking instead,
      !--- issue this command:
      
      CatOSSwitch>(enable) set trunk 3/1 nonegotiate dot1q
      

    有中继模式的几个选项,例如:在,自动,理想,自动和nonegotiate。关于其中每一的更多信息,参考您配置的交换产品的适当的CatOS软件配置页。

    一旦802.1Q,请确保本地VLAN在链路间配比。默认情况下,本地VLAN是您在端口配置的1或VLAN。除VLAN1之外,如果您的网络要求本地VLAN是,您能更改本地VLAN。如果更改默认本地VLAN,您必须更改在链路的另一侧的本地VLAN。为了更改本地VLAN,请发出这些命令之一:

    • Cisco IOS 软件

      switchport trunk native vlan vlan-ID
      
      
    • CatOS

      set vlan vlan-ID module/port
      
      

      注意: 在此命令的模块/端口是中继端口。

注意: 此输出表示on命令问题3524XL交换机。用蓝色注释斜体字解释某些命令和步骤:

Catalyst 3524XL
3524xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3524xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface fastethernet0/1
switchport mode trunk
!

!--- If you have configured 802.1Q, 
!--- you instead see this output 
!--- under interface fastethernet0/1:
!--- interface fastethernet0/1
!--- switchport trunk encapsulation dot1q
!--- switchport mode trunk


!
interface fastethernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface fastethernet0/3
spanning-tree portfast
!
interface fastethernet0/4
!

!--- Output suppressed.
!
interface VLAN1
ip address 10.10.10.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
password mysecret
login
line vty 5 15
login
!
end

注意: 此输出表示on命令问题5500交换机。用蓝色注释斜体字解释某些命令和步骤:

Catalyst 5500
cat5509> (enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
........

..................

..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
!
set enablepass $2$FNl3$8MSzcpVMg1H2aWfll13aZ.
!
#system
set system name  cat5509
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp mode transparent
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 2 
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state 
 active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state 
 active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state 
 active mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
#ip
set interface sc0 1 10.10.10.3/255.255.255.0 10.10.10.255
!
!
# default port status is enable
!
!
#module 1 : 4-port 10/100BaseTX Supervisor
!
#module 2 : 3-port 1000BaseX Ethernet
!
#module 3 : 24-port 10/100BaseTX Ethernet
set vlan 2  3/2
set trunk 3/1 nonegotiate isl 1-1005

!--- If you have configured 802.1Q trunk, 
!--- this line displays as:
!--- set trunk 3/1 nonegotiate dot1q 1-1005


set spantree portfast 3/2-3 enable
!
#module 4 empty
!
#module 5 empty
!
#module 6 : 24-port 10BaseF Ethernet
!
#module 7 empty
!
#module 8 : 24-port 10/100BaseTX Ethernet
!
#module 9 empty
end
cat5509> (enable)

验证

显示命令

此部分提供您能使用来确认您的配置适当地运作的信息。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

在 Catalyst 2900XL/3500XL/2950 交换机上:

  • show interfaces {快速以太网|千兆以太网}模块/端口switchport

  • show vlan

  • show vtp status

在 Catalyst 5000 交换机上:

  • show port capabilities module/port

  • show port module/port

  • show trunk module/port

  • show vtp domain

show 命令输出示例

Catalyst 3500XL 交换机

  • show interfaces {快速以太网|千兆以太网}模块/端口switchport

    请使用此命令检查端口的管理和运行状态。并且,请使用此命令确保,本地VLAN配比在中继的两边。当端口在802.1q中继模式时,本地VLAN处理未标签的数据流。参考的创建和维护VLAN关于在本地VLAN的详细信息。

    3524xl#show interfaces fastethernet 0/1 switchport 
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No

    注意: 802.1q中继, show interfaces {快速以太网的输出|千兆以太网}模块/端口switchport命令更改这样:

    3524xl#show interfaces fastethernet 0/1 switchport 
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No
  • show vlan

    请使用此命令验证接口或者端口,属于正确VLAN。在本例中,仅接口Fa0/2属于VLAN 2。接口的其余是VLAN成员1 :

    3524xl#show vlan 
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    VLAN0002                         active    Fa0/2
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    
    
    !--- Output suppressed.
    
    
  • show vtp status

    请使用此命令检查在交换机的VTP配置。在本例中, VTP模式透明。正确的 VTP 模式取决于网络拓扑结构。关于在VTP的详细信息,参考创建和维护VLAN

    3524xl#show vtp status
    VTP Version                     : 2
    Configuration Revision          : 0
    Maximum VLANs supported locally : 254
    Number of existing VLANs        : 6
    VTP Operating Mode              : Transparent
    VTP Domain Name                 : 
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x74 0x79 0xD3 0x08 0xC0 0x82 0x68 0x63 
    Configuration last modified by 10.10.10.2 at 3-1-93 00:05:30

CatOS 交换机

  • show port capabilities module/port

    请使用此命令检查端口是否有能力在中继上:

    cat5509 show port capabilities 3/1
    Model                    WS-X5234
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4 
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),TX(1q4t)
    COs rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
  • show port module/port

    cat5509> (enable) show port 3/1
    
    Port  Name               Status     Vlan       Level  Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ------ ----- ------------
     3/1                     connected  trunk      normal a-full a-100 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status
    ----- ------------- --------------
     3/1  none          none          
    
    
    Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
    ----- -------- --------- ------------- -------- -------- -------- -------
     3/1  disabled  shutdown             0        0        1 disabled      12
    
    Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
    ----- -------- ----------------- -------- ----------------- ------------------
     3/1         0                 -        -                 -        -         -
    
    !--- Output suppressed.
    
    
  • show trunk module/port

    请使用此命令验证中继状态和配置。

    cat5509> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  isl            trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     3/1      1-2
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
    

    注意: 对于802.1q中继,此命令输出这样更改:

    cat5509> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     3/1      1-2
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
    
  • show vtp domain

    cat5509> (enable) show vtp domain
    DomainName                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           Transparent -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    6          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    10.10.10.3      disabled disabled 2-1000

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 8758