宽带电缆 : 电缆调制解调器终端系统 (CMTS)

如何使用 Cisco CMTS CLI 下载 IOS 配置文件到 Cisco 电缆调制解调器上

2016 年 10 月 25 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

思科IOSï ¿  ½软件配置文件是包含将发送的配置对路由器的文本文件。一旦Cisco电缆调制解调器,典型地发送的配置包含访问列表、主机名、SNMP团体字符串、与默认桥接配置有所不同的密码或者路由配置。要发送Cisco IOS配置文件嵌入文件在电缆调制解调器在他们的初始化进程的TFTP部分使用的有线电缆数据服务接口规范(DOCSIS)配置文件是必要的。

有两种方式下载Cisco IOS配置文件到Cisco电缆调制解调器。

第一个,是普通方法,是使用DOCSIS CPE Configurator工具。请参阅Cisco DOCSIS CPE配置器(仅限注册用户)。本文建立DOCSIS 1.0配置文件使用Cisco DOCSIS配置器(仅限注册用户)包含关于怎样的详细说明执行此。

同一任务可以是实现的第二个方式是通过使用在有线调制解调器终端系统(CMTS)的Cisco IOS的命令行界面(CLI)。

本文详细解释第二个方式下载IOS配置文件到Cisco电缆调制解调器,不用使用DOCSIS配置器工具需要。对于此我们使用允许作为DHCP、ToD和TFTP服务器将配置的Cisco CMTS一体化配置的增强版,以及配置在CMTS的一个DOCSIS配置文件。

当我们要发送配置文件到电缆调制解调器使用CLI配置DOCSIS配置文件时,我们需要添加呼叫DHCP厂商详细信息选项,亦称选项的DHCP选项43。

配置电缆调制解调器主要优点此方式是一切可以从思科的CMTS执行,并且其他服务器(类似DHCP、TFTP或者ToD)和软件(类似DOCSIS CPE Configurator工具)没有要求顺利地发送Cisco IOS配置到Cisco电缆调制解调器和获得他们可操作与定制配置。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

读者应该有基本的了解:

  • DOCSIS协议

  • 在UBR系列路由器的Cisco IOS命令行界面(CLI)

  • UNIX

  • 动态主机配置协议 (DHCP)

使用的组件

请参阅部分配置所有在一设置包括下面的DHCP选项43

供应商特定信息(选项 43)DHCP 选项

选项43是客户端和服务器用于的DHCP选项交换卖方细节信息。

此选项在不同数据可能由不同的子选项类型代表的“类型长度值”样式典型地被格式化。"值"字段的含义在结束时是定义的设备的制造商。图1给选项43的图形表示。

类型 长度 类型 长度
T1 n d1 d2 ......... T2 n D1 D2 ........

图1 -数据的类型长度值结构在选项43内发送。

要下载Cisco IOS配置文件到Cisco电缆调制解调器,我们使用两子选项,即厂商ID厂商详细信息选项(VSIF)

厂商ID子选项有类型8。三字节组织独一无二的标识符(OUI)供应商的通常是有线调制解调器的MAC地址的前三个字节。此值通常表示作为十六进制数。此字段应该是00:00:0C (在十六进制) Cisco系统设备的。下面的图2给厂商ID子选项的十六进制数。

类型 长度
08 03 00:00:0C

图2 -子选项厂商ID (按十六进制值)

使用的第二子选项是厂商详细信息域(VSIF)。此子选项有类型128,并且包含由有线调制解调器的制造商定义的所有任意值。Cisco电缆调制解调器使用此字段识别应该下载的Cisco IOS配置文件名(若有)到路由器。

任意Cisco IOS命令可能在此字段也指定。此字段在点分的十进制通常代表。打点的十进位记数法是字母的十进制表示法根据每个字母有十进制值的ASCII。“小点”用于在十进制表示法之间使更加容易了解。

在本文中我们将显示如何下载呼叫ios.cf的Cisco IOS配置文件此文件名称从ASCII转换到点分的十进制。

要了解什么在ASCII之间的转换和点分的十进制, unix命令人ascii可以使用如下所示。此命令给几份转换表。我们需要寻找十进制-字符表。

sj-cse-494% man ascii
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)

 	 Decimal - Character

     |  0 NUL|  1 SOH|  2 STX|  3 ETX|  4 EOT|  5 ENQ|  6 ACK|  7 BEL|
     |  8 BS |  9 HT | 10 NL | 11 VT | 12 NP | 13 CR | 14 SO | 15 SI |
     | 16 DLE| 17 DC1| 18 DC2| 19 DC3| 20 DC4| 21 NAK| 22 SYN| 23 ETB|
     | 24 CAN| 25 EM | 26 SUB| 27 ESC| 28 FS | 29 GS | 30 RS | 31 US |
     | 32 SP | 33  ! | 34  " | 35  # | 36  $ | 37  % | 38  & | 39  ' |
     | 40  ( | 41  ) | 42  * | 43  + | 44  , | 45  - | 46  . | 47  / |
     | 48  0 | 49  1 | 50  2 | 51  3 | 52  4 | 53  5 | 54  6 | 55  7 |
     | 56  8 | 57  9 | 58  : | 59  ; | 60  < | 61  = | 62  > | 63  ? |
     | 64  @ | 65  A | 66  B | 67  C | 68  D | 69  E | 70  F | 71  G |
     | 72  H | 73  I | 74  J | 75  K | 76  L | 77  M | 78  N | 79  O |
     | 80  P | 81  Q | 82  R | 83  S | 84  T | 85  U | 86  V | 87  W |
     | 88  X | 89  Y | 90  Z | 91  [ | 92  \ | 93  ] | 94  ^ | 95  _ |
     | 96  ` | 97  a | 98  b | 99  c |100  d |101  e |102  f |103  g |
     |104  h |105  i |106  j |107  k |108  l |109  m |110  n |111  o |
     |112  p |113  q |114  r |115  s |116  t |117  u |118  v |119  w |
     |120  x |121  y |122  z |123  { |124  | |125  } |126  ~ |127 DEL|

所以, ios.cf的点分十进制表示法在图下面显示的105.111.115.46.99.102as 3.上。

o s .。 c f
105 111 115 46 99 192

图3 -文件名ios.cf的点分十进制表示法。

因为VSIF是类型长度值格式,名为ios.cf的Cisco IOS配置文件的完整点分十进制表示法128.6.105.111.115.46.99.192。正如你看到的128.6在表3.加了到ios.cfshown的点分十进制表示法记住"128"是类型,并且"6"是长度。

128.6.105.111.115.46.99.192是在DOCSIS CPE Configurator Tool V3.2的Vendor Info选项的VSIF字段输入的值如下面的图4所显示。

iosconfig_option43.jpg

图4 -从DOCSIS CPE Configurator工具的供应商信息字段。

然而,当执行在Cisco IOS的此功能使用DHCP选项43,按十六进制值应该表示类型长度值(TLV)时信息。本文着重此十六进制表达式。

要欲知ASCII字符的十六进制表示法,我们能使用unix命令:

echo -n "ios.cf" | od -t x1 | cut -s -d' ' -f2- | tr ' ' ':'

sj-cse-494% echo -n "ios.cf" | OD -t x1 | cut -s -d' ' -f2- | tr ' ' ':'
69:6f:73:2e:63:66

或者,您能也使用了上一个unix命令人ASCII并且查找“十六进制字符”表。

sj-cse-494% man ASCII
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)


     Hexadecimal - Character

     | 00 NUL| 01 SOH| 02 STX| 03 ETX| 04 EOT| 05 ENQ| 06 ACK| 07 BEL|
     | 08 BS | 09 HT | 0A NL | 0B VT | 0C NP | 0D CR | 0E SO | 0F SI |
     | 10 DLE| 11 DC1| 12 DC2| 13 DC3| 14 DC4| 15 NAK| 16 SYN| 17 ETB|
     | 18 CAN| 19 EM | 1A SUB| 1B ESC| 1C FS | 1D GS | 1E RS | 1F US |
     | 20 SP | 21  ! | 22  " | 23  # | 24  $ | 25  % | 26  & | 27  ' |
     | 28  ( | 29  ) | 2A  * | 2B  + | 2C  , | 2D  - | 2E  . | 2F  / |
     | 30  0 | 31  1 | 32  2 | 33  3 | 34  4 | 35  5 | 36  6 | 37  7 |
     | 38  8 | 39  9 | 3A  : | 3B  ; | 3C  < | 3D  = | 3E  > | 3F  ? |
     | 40  @ | 41  A | 42  B | 43  C | 44  D | 45  E | 46  F | 47  G |
     | 48  H | 49  I | 4A  J | 4B  K | 4C  L | 4D  M | 4E  N | 4F  O |
     | 50  P | 51  Q | 52  R | 53  S | 54  T | 55  U | 56  V | 57  W |
     | 58  X | 59  Y | 5A  Z | 5B  [ | 5C  \ | 5D  ] | 5E  ^ | 5F  _ |
     | 60  ` | 61  a | 62  b | 63  c | 64  d | 65  e | 66  f | 67  g |
     | 68  h | 69  i | 6A  j | 6B  k | 6C  l | 6D  m | 6E  n | 6F  o |
     | 70  p | 71  q | 72  r | 73  s | 74  t | 75  u | 76  v | 77  w |
     | 78  x | 79  y | 7A  z | 7B  { | 7C  | | 7D  } | 7E  ~ | 7F DEL|

下面的图5汇总厂商详细信息域(VSIF)的点分的十进制以及十六进制表示法。

类型 长度
点分的十进制 128 6 105.111.115.46.99.102
十六进制 80 06 69:6F:73:2E:63:66

图5 -在点分的十进制和十六进制子选项VSIF。

包括 DHCP 选项 43 的一体化配置

此配置使用下面软件和硬件版本开发并且被测试。

  • 运行12.2(2)XF的Cisco UBR10012

  • 运行12.2(2)XA的Cisco CVA120

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果在真实网络工作,请保证您了解所有Cisco IOS命令潜在影响使用它以前。

第一步 - 用正确的选项 43 字符串创建 DOCSIS 配置文件

在配置选项43的第一步将认识厂商ID的必要的十六进制值和DHCP选项43的VSIF子选项的必要的十六进制值。

下面的表汇总在Vendor Specific Information部分详细讨论的这些值。

厂商ID子选项 VSIF子选项
TLV 类型 长度 类型 长度
十六进制 08 03 00:00:0C 80 06 69:6F:73:2E:63:66
含义 厂商ID类型 厂商ID长度 思科的ID VSIF类型 VSIF长度 (文件名) ios.cf

图 6

一旦我们知道哪个值我们将输入,我们需要使用思科的CMTS的CLI生成为DOCSIS配置文件需要的所有属性,包括DHCP选项43。

创建我们需要输入global命令电缆config-file DOCSIS文件名的DOCSIS配置文件。以下表示名为platinum.cm的创建platinum.cm所有设置下面解释。

Note: 
!--- Comments are in blue.


cable config-file platinum.cm  
  
!---  Name of the DOCSIS config file is platinum.cm

  service-class 1 priority 2  
  
!---  The Upstream Channel priority is 2

  service-class 1 max-upstream 128 
  
!---  The Maximum upstream value is 128Kbps

  service-class 1 guaranteed-upstream 10
  
!---  The Guaranteed Upstream is 10 Kbps

  service-class 1 max-downstream 10000 
  
!---  The Maximum Downstream is 10Mbps

  service-class 1 max-burst 1600
  
!---  The Maximum Upstream Transmit burst is 1600 bytes

  cpe max 10 
  
!---  The Maximum number of CPE's is 10

  timestamp
  
!---  Enable timestamp generation

  option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66  
  
!---  Using option 43 to send the IOS Configuration file named "ios.cf" 
  !---  to cable modems.

警告 警告: cable config-file命令在Cisco IOS版本12.2(1)XF1的Cisco IOS版本12.1(2)EC1介绍uBR7200和ubr7100的和ubr10k的。

注意: 肯定您正确地输入了TLV数据,当曾经六角形的选项时。不正确地输入的数据会造成CM重置,脱机或者暂停,需要重新通电才能继续。

第二步 - 创建 DHCP 服务器配置的 DHCP 池

一旦我们创建DOCSIS配置文件platinum.cm,我们需要配置CMTS是DHCP服务器,并且配置为DHCP的特点需要的选项。请参阅在CMTS的Cisco IOS动态主机配置协议(DHCP)服务,解释其中每一的含义命令我们使用DHCP池的创建。此处我们将汇总配置并且给予简要描述。

DHCP池的配置是:

ip dhcp pool surf
  
!---  name of the dhcp pool. This scope is for the cable modems attached 
  !---  to interface cable 5/0/0

  network 10.1.4.0 255.255.255.0
  
!---  pool of addresses for scope from interface c5/0/0

  bootfile platinum.cm
  
!---  DOCSIS config file name associated with this pool

  next-server 10.1.4.1
  
!---  IP address of TFTP server which sends bootfile

  default-router 10.1.4.1
  
!---  default gateway for cable modems, necessary to get DOCSIS files

  option 7 ip 10.1.4.1
  
!---  Log Server DHCP option

  option 4 ip 10.1.4.1
  
!---  ToD server IP address

  option 2 hex ffff.8f80
  
!---  Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

  lease 7 0 10
  
!---  lease 7 days 0 hours 10 minutes

  ! 

第三步 - 配置 CMTS 作为 TFTP 服务器

第三步将配置CMTS是TFTP server。执行您将需要的此:

  1. 请使用tftp-server命令

  2. 告诉TFTP server文件ios.cf哪里查找

您能达到此与tftp-server disk0:ios.cf alias ios.cf命令注意此命令在disk0放置文件ios.cf。

tftp-server server

!--- enable the cmts to act as a tftp server

tftp-server disk0:ios.cf alias ios.cf

!--- get the IOS config file called ios.cf that is pre-downloaded to disk0
!--- this IOS  config file was built with a text editor and tftp to disk0  


要放置ios.cf文件在您的闪存或disk0 (科uBR10012)您必须TFTP使用文本文件编辑器,创建的文件。要执行此第一请确保您能ping Cisco IOS配置查找的TFTP server。

其次,应该输入global命令copy tftp <device>放置文件在CMTS里面。通常闪存使用uBR7200或ubr7100或者ubr10k,然而,此示例显示如何使用disk0科uBR10012。

schooner#copy tftp disk0
Address or name of remote host []? 172.16.30.2
Source filename []? ios.cf
Destination filename [ios.cf]? 

Accessing tftp://172.16.30.2/ios.cf...
Loading ios.cf from 172.16.30.2 (via FastEthernet0/0/0): !
[OK - 173/4096 bytes]

173 bytes copied in 0.152 secs

要确保, IOS配置文件在CMTS存储请运行dir命令

schooner#dir
Directory of disk0:/
    3  -rw-    11606084   Sep 17 2001 13:31:38  ubr10k-k8p6-mz.122-2.XF.bin
 2839  -rw-         173   Oct 01 2001 23:29:44  ios.cf
47890432 bytes total (36274176 bytes free)

要查看什么命令在ios.cf文件配置more命令<filename>可以用于CMTS如下:

schooner#more ios.cf
hostname SUCCEED
service linenumber
enable password cisco
interface ethernet 0
load 30
no shut
interface cable 0
load 30
no shut
line vty 0 4
password cisco
end

第四步 - 配置 CMTS 作为 ToD 服务器

要配置在思科的CMTS只两global命令的ToD请是需要的service udp-small-servers max-servers no-limit并且缚住时间服务器。配置看似类似:

service udp-small-servers max-servers no-limit

!---  supports a large number of modems / hosts attaching quickly

cable timeserver

!---  permits cable modems to obtain Time of Day (ToD) from uBR10012


CMTS 的配置

下面找到科uBR10012的完整的配置。所有in命令粗体是相关命令对本文目的。

Schooner#show run
Building configuration...

Current configuration : 3522 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname schooner
!
logging rate-limit console all 10 except critical
enable secret 5 $1$cM7F$ryXH7z/Ly6QCnD2LQ.gZs/
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver
!
cable config-file platinum.cm
 service-class 1 priority 2
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp
 option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66
!
redundancy
 main-cpu
  auto-sync standard
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
card 1/0 1oc12pos-1
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 5/0 2cable-mc28
card 7/0 2cable-mc28
ip subnet-zero
no ip domain-lookup
!
ip dhcp pool surf
   network 10.1.4.0 255.255.255.0
   bootfile platinum.cm
   next-server 10.1.4.1 
   default-router 10.1.4.1 
   option 7 ip 10.1.4.1 
   option 4 ip 10.1.4.1 
   option 2 hex ffff.8f80
   lease 7 0 10
!
interface FastEthernet0/0/0
 ip address 172.16.30.50 255.255.255.192
!
interface POS1/0/0
 no ip address
 crc 32   
 pos report all
 POs flag j0 1
!
interface GigabitEthernet2/0/0
 no ip address
 negotiation auto
!
interface Cable5/0/0
 ip address 10.1.4.1 255.255.255.0
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 frequency 40000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
no ip http server
!
no cdp run
snmp-server community public RO
snmp-server community private RW
snmp-server trap-source Cable5/0/0
snmp-server packetsize 2048
snmp-server enable traps cable
snmp-server host 172.16.30.8 public  cable snmp
snmp-server manager
tftp-server server
tftp-server ios.cf alias ios.cf
!
alias exec scm show cable modem
!
line con 0
line aux 0
line vty 0 4
!
end

schooner#

其他CMTS供应商可能没有能力设置所有这些片段使用仅他们的CMTS命令,而在Cisco IOS可以完成完全。

要做电缆调制解调器采取在Cisco IOS配置文件指定的命令呼叫ios.cf,它是必要重新启动有问题的电缆调制解调器。通过使用命令clearcable调制解调器< IP地址/MAC地址>重置,这可以从执行从CMTS的CLI

Schooner#clear cable modem 10.1.4.4 reset

警告 警告: 如果有一个大型网络并且要发送不同的数据图表到所有电缆调制解调器在您的工厂中,推荐在相位内如此执行。这在彼此将最小化千位影响尝试的电缆调制解调器跨步,当尝试同时时获得联机。

检查配置

要验证配置,请清除有线调制解调器用clear cable modem命令。当有线调制解调器回来联机时,远程登录到它查看在配置。

Schooner#show cable modem 
MAC Address    IP Address      I/F       MAC         Prim RxPwr Timing Num  BPI
                                         State       Sid  (db)  Offset CPEs Enbld
0004.27ca.0e9b 10.1.4.6        C5/0/0/U0 online      1  *0.00   2820   0    no 
0090.9600.703d 10.1.4.2        C5/0/0/U0 online      2   -0.75  2816   0    no 
0003.e38f.f9b5 10.1.4.3        C5/0/0/U0 online      3  *0.00   2822   0    no 
0001.64ff.e4b5 10.1.4.4        C5/0/0/U0 online      4  *0.00   2812   0    no

!--- CVA120
 
0020.4086.2704 10.1.4.5        C5/0/0/U0 online      5   -0.50  2808   0    no 
0020.4086.3324 10.1.4.7        C5/0/0/U0 online      6   -0.50  2808   0    no 
0020.4079.feb4 10.1.4.8        C5/0/0/U0 online      7   0.00   2805   0    no 
0020.4085.d06a 10.1.4.9        C5/0/0/U0 online      8   -0.50  2807   0    no 

在本例中的公告ios.cf文件发出命令电缆调制解调器有SUCCEED主机名和的确这是被看到的文件名,当我们远程登录到有线调制解调器时。

Schooner#telnet 10.1.4.4
Trying 10.1.4.4 ... Open

SUCCEED line 1 


User Access Verification

Password: 
SUCCEED>en
Password: 
SUCCEED#

验证Cisco IOS配置文件顺利地下载对有线调制解调器使用show version命令。下面的输出显示关于ios.cf文件的信息在粗体。

SUCCEED#show  version
Cisco Internetwork Operating System Software 
IOS (tm) 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
TAC:Home:SW:IOS:Specials for info
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Wed 27-Jun-01 02:02 by hwcheng
Image text-base: 0x800100A0, data-base: 0x80782844
ROM: System Bootstrap, Version 12.0(20001010:025045) [spaulsen-blue-3105 3108], DEVELOPMENT SOFTWARE
ROM: 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

SUCCEED uptime is 3 days, 3 hours, 21 minutes
System returned to ROM by reload at 05:52:09 - Sat Jan 1 2000
System restarted at 05:58:30 - Sat Oct 6 2001
System image file is "flash:cva120-k8v4y5-mz.122-2.XA.bin"
Host configuration file is "tftp://10.1.4.1/ios.cf"

cisco CVA122 CM (MPC850) processor (revision 3.r) with 32256K/1024K bytes of memory.
Processor board ID SAD043708GK
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
1 Universal Serial Bus (USB) interface(s)
8192K bytes of processor board System flash (Read/Write)
7296K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2

CVA120的配置如下所示。注意in命令粗体对应于在ios.cf文件的线路。

SUCCEED#show run
Building configuration...

Current configuration : 1429 bytes
!
! Last configuration change at 11:22:22 - Tue Oct 9 2001
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service linenumber
service internal
!
hostname SUCCEED
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
enable password cisco
!
clock timezone - -8
ip subnet-zero
no ip routing
no ip finger
!
interface Ethernet0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address docsis
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream mode annex-b
 cable-modem Mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface USB0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 arp timeout 0
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip classless
no ip http server
no ip http cable-monitor
!
snmp-server packetsize 4096
snmp-server chassis-id 
snmp-server manager
!
voice-port 0
 input gain -2
!
voice-port 1
 input gain -2
!
mgcp modem passthrough voaal2 mode 
no mgcp timer receive-rtcp
!
mgcp profile default
!
line con 0
 transport input none
line vty 0 4
 password cisco
 login
!
end

重要提示

看来option命令电缆的config-file是残破的,因为一个人可能期待下面命令给有效配置。

option 43 instance 8 hex 00:00:0c
option 43 instance 128 ASCII ios.cf

当这些命令接受时,它不生成正确Cisco IOS配置文件。这不是bug!此处问题是术语instance如何解释作为“子选项”,未曾应该是。

当您有多个实例多种供应商的时,选项43 “实例的”实施多次只允许同一个选项的重复,和!示例如下:

option 43 instance 1 hex 08:03:00:00:0C:80:07:69:6F:73:2E:63:66:67

!--- Config file cisco CM

option 43 instance 2 hex 08:03:11:22:33:80:07:69:6F:73:2E:63:66:67

!--- Some option for other CM

注意11:22:33是从虚构组织的随机的厂商ID。与实时厂商ID的所有匹配是纯巧合。

因为术语instance预计反射TLV子选项字段,并且您的确有TLV子选项字段,您将必须输入在十六进制的整个字符串。


相关信息


Document ID: 8323