语音 : H.323

带有高带宽租用线路 PPP 和 LLQ 的 VoIP

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文为两个Cisco 3640路由器提供配置示例。配置使路由器与与PPP的VoIP联络在有低延迟排队(LLQ)的高带宽租用的线路。关于LLQ的更多信息,参考本文带有服务质量控制的VoIP-over-PPP (LLQ /IP RTP优先级、LFI, cRTP)

注意: 当本文讨论高带宽根据VoIP和QoS时,高带宽是在768 Kbps上的任何带宽。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOSï ¿  ½软件版本12.2(19a) IP Plus或其他Cisco IOS软件版本12.2, 12.2T, 12.3或者12.3T

  • 有48个闪存至少DRAM和16 Mb的两个Cisco 3640路由器

  • 两个Cisco NM-2V Voice/Fax接口卡Slot网络模块加上两个VIC-2FXS接口卡

  • 两serial interfaces

    在本例中,两serial interfaces是NM-1E2Ws,与一个WIC-1T广域网接口卡中的每一个。

  • 附件的模拟电话对语音呼叫的局外交换站(FXS)端口

注意: NM-1E2W、NM-1E1R2W和NM-2E2W网络模块没有足够的性能电源支持WIC-2T。缺乏支持归结于硬件限制。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

如果必要的时间发送一1500字节数据包在电线上比10毫秒极大,您需要分段的信息包。本文呈现一配置,不用分段。配置是为1500字节数据包的传输延迟少于10毫秒是的1544千比特链路。

注意: 有时在哪些您把一专用,全T1信道连接,分段功能可以是多余的。但是,您仍然需要QoS机制。在这种情况下请使用LLQ。如果必要的时间发送一1500字节数据包在电线上少于10毫秒是,您不需要分段的信息包。全T1信道提供足够的带宽允许语音数据包赶快输入和留下队列问题。

注意: 如果启用在路由器的分段,有时间的排队机制100百分比的启动。如果配置LLQ,值您配置的限制优先级队列的流量。当您未启用分段时,路由器只运用QoS策略一旦拥塞。

并且,一旦比768 Kbps极大的线路速率,压缩实时传输协议(cRTP)可以是多余的。参考本文带有服务质量控制的VoIP-over-PPP [LLQ/IP RTP Priority, LFI, cRTP]。因为cRTP压缩IP RTP报头,使用cRTP帮助保存带宽。在本文的配置部分, cRTP的启动是多余的。T1允许足够的带宽语音数据包放出,不用压缩,在电线上,不用问题。

警告 警告: 如果决定使用cRTP,请注意cRTP使用CPU资源。cRTP能使有语音流量一大量负担的路由器负担过度。

注意: 在此配置中,两路由器在一条租用的线路连接背对背。但是,在多数拓扑方面,有语音启动的路由器能任何地方存在。通常,语音路由器连接LAN连通性到连接对广域网的其他路由器。如果您的语音路由器不通过在一条租用的线路的PPP连接,您需要配置在连接对广域网的那些路由器的所有WAN连接配置命令;您不配置on命令语音路由器,在本文的配置显示。

注意: 此配置能为Cisco 1700, 2600, 3600和3700系列路由器工作。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/8128/voip_ppp_highbw_rtp_prio-1.gif

配置

本文档使用以下配置:

San Jose
SanJose3640A# show run
Building configuration...

Current configuration : 1425 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SanJose3640A
!
logging buffered 50000 debugging
!
ip subnet-zero
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
!
!
!
!
!
class-map match-all voice-signaling
 match access-group 103
class-map match-all voice-traffic
 match access-group 102
!
!
policy-map voice-policy
 class voice-traffic
  priority 51


!--- These are two uncompressed G729 VoIP calls at 24 kpbs each
!--- that have voice activity detection (VAD) disablement. You also need 
!--- to consider the Layer 2 (L2) overhead.


 class voice-signaling
  bandwidth 16


!--- This assigns a queue for voice signaling traffic that ensures 8 kbps.
!--- Note: This action is optional and has nothing to do with good voice
!--- quality. This queue assignment is a way to secure signaling.


 class class-default
  fair-queue

!--- The class-default class classifies traffic that does
!--- not fall into one of the class definitions. The fair-queue command 
!--- associates the default class weighted fair queuing (WFQ).



!
!
!
interface Ethernet1/0
 ip address 10.89.251.158 255.255.255.192
 half-duplex
!
interface Serial1/0
 bandwidth 1544
 ip address 192.168.1.1 255.255.255.0
 service-policy output voice-policy
 encapsulation ppp
 load-interval 30
 clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.89.251.129
no ip http server
!
access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 voip
 incoming called-number .
 destination-pattern 2...
 session target ipv4:192.168.1.2
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 2 pots
 destination-pattern 1001
 port 3/0/0
!
dial-peer voice 3 pots
 destination-pattern 1002
 port 3/0/1
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

SanJose3640A#

SanJose3640A#
SanJose3640A# show version
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3640-IS-M), Version 12.2(19a), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Mon 29-Sep-03 23:45 by pwade
Image text-base: 0x60008930, data-base: 0x61134000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

SanJose3640A uptime is 5 minutes
System returned to ROM by reload
System image file is "flash:c3640-is-mz.122-19a.bin"

cisco 3640 (R4700) processor (revision 0x00) with 126976K/4096K bytes of memory.
Processor board ID 15636516
R4700 CPU at 100Mhz, Implementation 33, Rev 1.0
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
1 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
DRAM configuration is 64 bits wide with parity disabled.
125K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)
16384K bytes of processor board PCMCIA Slot1 flash (Read/Write)

Configuration register is 0x2102

SanJose3640A#

Raleigh
Raleigh3640A# show run
Building configuration...

Current configuration : 1406 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Raleigh3640A
!
logging buffered 50000 debugging
!
ip subnet-zero
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
!
!
!
!
!
class-map match-all voice-signaling
 match access-group 103
class-map match-all voice-traffic
 match access-group 102
!
!
policy-map voice-policy
 class voice-traffic
  priority 51

!--- These are two uncompressed G729 VoIP calls at 24 kpbs each
!--- that have VAD disablement. You also need to consider 
!--- the L2 overhead.


 class voice-signaling
  bandwidth 16


!--- This assigns a queue for voice signaling traffic that ensures 8 kbps.
!--- Note: This action is optional and has nothing to do with good voice
!--- quality. This queue assignment is a way to secure signaling.


 class class-default
  fair-queue

!--- The class-default class classifies traffic that does
!--- not fall into one of the class definitions. The fair-queue command
!--- associates the default class WFQ.


!
!
!
interface Ethernet1/0
 ip address 10.89.251.159 255.255.255.192
 half-duplex
!
interface Serial1/0
 bandwidth 1544
 ip address 192.168.1.2 255.255.255.0
 service-policy output voice-policy
 encapsulation ppp
 load-interval 30
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.89.251.129
no ip http server
!
access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 voip
 incoming called-number .
 destination-pattern 1...
 session target ipv4:192.168.1.1
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 2 pots
 destination-pattern 2001
 port 3/0/0
!
dial-peer voice 3 pots
 destination-pattern 2002
 port 3/0/1
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

Raleigh3640A#
Raleigh3640A#
Raleigh3640A# show version
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3640-IS-M), Version 12.2(19a), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Mon 29-Sep-03 23:45 by pwade
Image text-base: 0x60008930, data-base: 0x61134000

ROM: System Bootstrap, Version 12.1(17r) [cmong 17r], RELEASE SOFTWARE (fc1)

Raleigh3640A uptime is 6 minutes
System returned to ROM by reload
System image file is "flash:c3640-is-mz.122-19a.bin"

cisco 3640-A (R4700) processor (revision 0x00) with 94208K/4096K bytes of memory.
Processor board ID 29851759
R4700 CPU at 100Mhz, Implementation 33, Rev 1.0
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
1 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
DRAM configuration is 64 bits wide with parity disabled.
123K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)
16384K bytes of processor board PCMCIA Slot0 flash (Read/Write)

Configuration register is 0x2102

Raleigh3640A#

验证

在您输入这些配置到您的路由器后,请验证他们正确地运作。此处命令和各自输出展示配置的成功实施。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show interface serial 1/0 —允许您检查您的serial interfaces状况。

  • show call active voice brief —在呼叫期间,允许您查看呼叫信息。

  • show call active voice —在呼叫期间,允许您查看呼叫信息。

  • show policy-map interface —允许您验证接口使用的QoS策略。

  • show access-list 102 —允许您由语音类的访问列表验证数据包选择。发出命令每第二次,在一些秒钟并且验证后有在数据包计数的一增加。发出clear access-list counters 102命令,如果需要。

  • show voice call summary —允许您验证呼叫的状况。如果呼叫有连接,命令显示您。

  • show voice port summary —允许您验证语音端口的状态。命令显示语音端口如挂机或摘机。

  • show voice dsp —允许您验证数字信号处理器(DSP)的状态和每呼叫使用的编码器译码器(编码)。

San Jose 路由器验证

在您进行验证前,请检查接口保证您有必要的连接发出呼叫。发出show interface serial 1/0命令检查您的serial interfaces状况。使用在本文的配置,请务必您的序列和多链路接口在线路通信协议UP状态。并且请务必您看到此:

  • 开放的LCP,开放的多链路指示PPP连接的建立。

  • 打开:IPCP, CDPCP —告诉您IP数据流发送通过PPP链路是可能的。

  • 排队策略加权公平—对应于服务策略输出命令行界面(CLI)在serial interfaces下。策略是为优先安排在数据的语音的LLQ的配置。

SanJose3640A# show interface serial 1/0
Serial1/0 is up, line protocol is up
Hardware is QUICC Serial
Internet address is 192.168.1.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:27, output 00:00:02, output hang never
Last clearing of "show interface" counters 00:00:05
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 1091 kilobits/sec
30 second input rate 0 bits/sec, 0 packets/sec
30 second output rate 0 bits/sec, 0 packets/sec
1 packets input, 16 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
1 packets output, 16 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

SanJose3640A#

此输出显示路由器。ï ¿  ½之间的成功的连接,如果看不到线路通信协议是UP,验证在DCE接口的时钟频率。一些serial interfaces doï ¿  ½不是支持高速,例如NM-8A/S。并且,请验证在两边的参数配比和,最重要,封装配比。

show call active voice brief命令的输出此处显示两成功的呼叫。一呼叫是从Raleigh路由器到San Jose路由器,并且其他是从San Jose到Raleigh。此列表解释出现黑体字的输出:

  • 答案1001激活—表示San Jose是呼叫产生的路由器。

  • 远3/0/0 —表示这是电话呼叫段。

  • 产生2001年激活—表示在Raleigh侧的一个电话收到呼叫。

  • IP 192.168.1.2 —表示这是IP呼叫段。

  • 答案2002年激活—表示Raleigh是呼叫发送的路由器。

  • IP 192.168.1.2 —表示这是IP呼叫段。

  • 产生1002激活—表示在San Jose侧的一个电话收到呼叫。

  • 远3/0/1 —表示这是电话呼叫段。

SanJose3640A# show call active voice brief
<ID>: <start>hs.<index> +<connect> pid:<peer_id> <dir> <addr> <state>
dur hh:mm:ss tx:<packets>/<bytes> rx:<packets>/<bytes>
IP <ip>:<udp> rtt:<time>ms pl:<play>/<gap>ms lost:<lost>/<early>/<late>
delay:<last>/<min>/<max>ms <codec>
MODEMPASS <method> buf:<fills>/<drains> loss <overall%> <multipkt>/<corrected>
last <buf event time>s dur:<Min>/<Max>s
FR <protocol> [int dlci cid] vad:<y/n> dtmf:<y/n> seq:<y/n>
<codec> (payload size)
ATM <protocol> [int vpi/vci cid] vad:<y/n> dtmf:<y/n> seq:<y/n>
<codec> (payload size)
Tele <int>: tx:<tot>/<v>/<fax>ms <codec> noise:<l> acom:<l> i/o:<l>/<l> dBm
Proxy <ip>:<audio udp>,<video udp>,<tcp0>,<tcp1>,<tcp2>,<tcp3> endpt: <type>/<manf>
bw: <req>/<act> codec: <audio>/<video>
tx: <audio pkts>/<audio bytes>,<video pkts>/<video bytes>,<t120 pkts>/<t120 bytes>
rx: <audio pkts>/<audio bytes>,<video pkts>/<video bytes>,<t120 pkts>/<t120 bytes>


Total call-legs: 4
11E8 : 115599hs.1 +318 pid:2 Answer 1001 active
dur 00:00:29 tx:1545/30900 rx:1544/30880
Tele 3/0/0:20: tx:30890/30890/0ms g729r8 noise:0 acom:2 i/0:-35/-44 dBm

11E8 : 115823hs.1 +94 pid:1 Originate 2001 active
dur 00:00:31 tx:1556/31120 rx:1602/32040
IP 192.168.1.2:17360 rtt:4ms pl:25590/0ms lost:0/1/0 delay:69/69/70ms g729r8

11F0 : 116855hs.1 +156 pid:1 Answer 2002 active
dur 00:00:20 tx:1087/21740 rx:1009/20180
IP 192.168.1.2:16772 rtt:2ms pl:17270/0ms lost:0/0/0 delay:69/69/70ms g729r8

11F0 : 116855hs.2 +156 pid:3 Originate 1002 active
dur 00:00:20 tx:1009/20180 rx:1087/21740
Tele 3/0/1 (23): tx:21740/21740/0ms g729r8 noise:0 acom:5 i/0:-40/-40 dBm

Total call-legs: 4

SanJose3640A#

show call active voice命令的此输出提供关于激活的呼叫的更多细节:

SanJose3640A# show call active voice
Total call-legs: 4

GENERIC:
SetupTime=115599 ms
Index=1
PeerAddress=1001
PeerSubAddress=
PeerId=2
PeerIfIndex=9
LogicalIfIndex=4
ConnectTime=115917
CallDuration=00:05:05
CallState=4
CallOrigin=2
ChargedUnits=0
InfoType=2
TransmitPackets=15338
TransmitBytes=306760
ReceivePackets=15337
ReceiveBytes=306740
TELE:
ConnectionId=[0x38D3783F 0x14F111CC 0x801CFDB1 0x2D0CC4A5]
IncomingConnectionId=[0x38D3783F 0x14F111CC 0x801CFDB1 0x2D0CC4A5]
TxDuration=306740 ms
VoiceTxDuration=306740 ms
FaxTxDuration=0 ms
CoderTypeRate=g729r8
NoiseLevel=0
ACOMLevel=5
OutSignalLevel=-43
InSignalLevel=-36
InfoActivity=2
ERLLevel=5
SessionTarget=
ImgPages=0
GENERIC:
SetupTime=115823 ms
Index=1
PeerAddress=2001
PeerSubAddress=
PeerId=1
PeerIfIndex=8
LogicalIfIndex=0
ConnectTime=115917
CallDuration=00:05:07
CallState=4
CallOrigin=1
ChargedUnits=0
InfoType=2
TransmitPackets=15357
TransmitBytes=307140
ReceivePackets=15403
ReceiveBytes=308060
VOIP:
ConnectionId[0x38D3783F 0x14F111CC 0x801CFDB1 0x2D0CC4A5]
IncomingConnectionId[0x38D3783F 0x14F111CC 0x801CFDB1 0x2D0CC4A5]
RemoteIPAddress=192.168.1.2
RemoteUDPPort=17360
RemoteSignallingIPAddress=192.168.1.2
RemoteSignallingPort=1720
RemoteMediaIPAddress=192.168.1.2
RemoteMediaPort=17360
RoundTripDelay=1 ms
SelectedQoS=best-effort
tx_DtmfRelay=h245-alphanumeric
FastConnect=TRUE

Separate H245 Connection=FALSE

H245 Tunneling=TRUE

SessionProtocol=cisco
SessionTarget=ipv4:192.168.1.2
OnTimeRvPlayout=300810
GapFillWithSilence=0 ms
GapFillWithPrediction=0 ms
GapFillWithInterpolation=0 ms
GapFillWithRedundancy=0 ms
HiWaterPlayoutDelay=70 ms
LoWaterPlayoutDelay=69 ms
ReceiveDelay=69 ms
LostPackets=0
EarlyPackets=2
LatePackets=0
VAD = disabled
CoderTypeRate=g729r8
CodecBytes=20
GENERIC:
SetupTime=116855 ms
Index=1
PeerAddress=2002
PeerSubAddress=
PeerId=1
PeerIfIndex=8
LogicalIfIndex=0
ConnectTime=117011
CallDuration=00:04:56
CallState=4
CallOrigin=2
ChargedUnits=0
InfoType=2
TransmitPackets=14915
TransmitBytes=298300
ReceivePackets=14837
ReceiveBytes=296740
VOIP:
ConnectionId[0x6C135AD4 0x14F311CC 0x8024CE4C 0xAA60AB15]
IncomingConnectionId[0x6C135AD4 0x14F311CC 0x8024CE4C 0xAA60AB15]
RemoteIPAddress=192.168.1.2
RemoteUDPPort=16772
RemoteSignallingIPAddress=192.168.1.2
RemoteSignallingPort=11004
RemoteMediaIPAddress=192.168.1.2
RemoteMediaPort=16772
RoundTripDelay=7 ms
SelectedQoS=best-effort
tx_DtmfRelay=h245-alphanumeric
FastConnect=TRUE

Separate H245 Connection=FALSE

H245 Tunneling=TRUE

SessionProtocol=cisco
SessionTarget=
OnTimeRvPlayout=295580
GapFillWithSilence=0 ms
GapFillWithPrediction=0 ms
GapFillWithInterpolation=0 ms
GapFillWithRedundancy=0 ms
HiWaterPlayoutDelay=70 ms
LoWaterPlayoutDelay=69 ms
ReceiveDelay=69 ms
LostPackets=0
EarlyPackets=0
LatePackets=0
VAD = disabled
CoderTypeRate=g729r8
CodecBytes=20
GENERIC:
SetupTime=116855 ms
Index=2
PeerAddress=1002
PeerSubAddress=
PeerId=3
PeerIfIndex=10
LogicalIfIndex=5
ConnectTime=117011
CallDuration=00:04:59
CallState=4
CallOrigin=1
ChargedUnits=0
InfoType=2
TransmitPackets=14952
TransmitBytes=299040
ReceivePackets=15030
ReceiveBytes=300600
TELE:
ConnectionId=[0x6C135AD4 0x14F311CC 0x8024CE4C 0xAA60AB15]
IncomingConnectionId=[0x6C135AD4 0x14F311CC 0x8024CE4C 0xAA60AB15]
TxDuration=300600 ms
VoiceTxDuration=300600 ms
FaxTxDuration=0 ms
CoderTypeRate=g729r8
NoiseLevel=0
ACOMLevel=5
OutSignalLevel=-40
InSignalLevel=-41
InfoActivity=2
ERLLevel=5
SessionTarget=
ImgPages=0Total call-legs: 4

SanJose3640A#$
  

Other shows:

show policy-map interface命令的输出包括此黑体语句:

  • 30秒提供的速率51000位/秒—显示带宽两呼叫要求, 51 kpbs。

SanJose3640A# show policy-map interface
Serial1/0

Service-policy output: voice-policy

Class-map: voice-traffic (match-all)
99403 packets, 6401420 bytes
30 second offered rate 51000 bps, drop rate 0 bps
Match: access-group 102
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 51 (kbps) Burst 1275 (Bytes)
(pkts matched/bytes matched) 407/65676
(total drops/bytes drops) 0/0

Class-map: voice-signaling (match-all)
158 packets, 12926 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: access-group 103
Queueing
Output Queue: Conversation 265
Bandwidth 16 (kbps) Max Threshold 64 (packets)
(pkts matched/bytes matched) 158/12926
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)
75 packets, 9221 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/0/0
SanJose3640A#

show access-lists 102命令的输出包括此黑体语句:

  • 100676匹配—显示RTP数据包的优先级发生,因为数据包到达访问列表102。

SanJose3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (100676 matches)
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (100930 matches)
SanJose3640A#
SanJose3640A#
SanJose3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (101076 matches)
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (101198 matches)
SanJose3640A#
SanJose3640A#
SanJose3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (101304 matches)
SanJose3640A#
SanJose3640A#


SanJose3640A#
SanJose3640A# show voice call sum
PORT CODEC VAD VTSP STATE VPM STATE
============ ======== === ==================== ======================
3/0/0 g729r8 n S_CONNECT FXSLS_CONNECT
3/0/1 g729r8 n S_CONNECT FXSLS_CONNECT
3/1/0 - - - FXOLS_ONHOOK
3/1/1 - - - FXOLS_ONHOOK

SanJose3640A#
SanJose3640A#


SanJose3640A#
SanJose3640A# show voice port sum
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
====== == ========== ===== ==== ======== ======== ==
3/0/0 -- fxs-ls up up off-hook idle y
3/0/1 -- fxs-ls up up off-hook idle y
3/1/0 -- fxo-ls up dorm idle on-hook y
3/1/1 -- fxo-ls up dorm idle on-hook y

SanJose3640A#


SanJose3640A# show voice dsp

DSP DSP DSPWARE CURR BOOT PAK TX/RX
TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABORT PACK COUNT
==== === == ======== ======= ===== ======= === == ========= == ===== ============
C542 001 01 g729r8 3.4.55 busy idle 0 0 3/0/0 NA 0 62487/61902
C542 002 01 g729r8 3.4.55 busy idle 0 0 3/0/1 NA 0 44362/44194
C542 003 01 g711ulaw 3.4.55 IDLE idle 0 0 3/1/0 NA 0 541/546
C542 004 01 g711ulaw 3.4.55 IDLE idle 0 0 3/1/1 NA 0 535/532

SanJose3640A#

Raleigh 路由器验证

Raleigh路由器的验证程序类似于San Jose路由器的步骤。

Raleigh3640A# show interface serial 1/0
Serial1/0 is up, line protocol is up
Hardware is QUICC Serial
Internet address is 192.168.1.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:15, output 00:00:00, output hang never
Last clearing of "show interface" counters 00:12:33
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 1091 kilobits/sec
30 second input rate 0 bits/sec, 0 packets/sec
30 second output rate 0 bits/sec, 0 packets/sec
167 packets input, 6849 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
169 packets output, 6907 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
11 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

Raleigh3640A#

Raleigh3640A#
Raleigh3640A#
Raleigh3640A#
Raleigh3640A# show call active voice
Total call-legs: 4

GENERIC:
SetupTime=209451 ms
Index=1
PeerAddress=1001
PeerSubAddress=
PeerId=1
PeerIfIndex=8
LogicalIfIndex=0
ConnectTime=209543
CallDuration=00:08:20
CallState=4
CallOrigin=2
ChargedUnits=0
InfoType=2
TransmitPackets=25054
TransmitBytes=501080
ReceivePackets=25008
ReceiveBytes=500160
VOIP:
ConnectionId[0x38D3783F 0x14F111CC 0x801CFDB1 0x2D0CC4A5]
IncomingConnectionId[0x38D3783F 0x14F111CC 0x801CFDB1 0x2D0CC4A5]
RemoteIPAddress=192.168.1.1
RemoteUDPPort=17210
RemoteSignallingIPAddress=192.168.1.1
RemoteSignallingPort=11006
RemoteMediaIPAddress=192.168.1.1
RemoteMediaPort=17210
RoundTripDelay=3 ms
SelectedQoS=best-effort
tx_DtmfRelay=h245-alphanumeric
FastConnect=TRUE

Separate H245 Connection=FALSE

H245 Tunneling=TRUE

SessionProtocol=cisco
SessionTarget=
OnTimeRvPlayout=497610
GapFillWithSilence=0 ms
GapFillWithPrediction=0 ms
GapFillWithInterpolation=0 ms
GapFillWithRedundancy=0 ms
HiWaterPlayoutDelay=70 ms
LoWaterPlayoutDelay=69 ms
ReceiveDelay=69 ms
LostPackets=0
EarlyPackets=1
LatePackets=0
VAD = disabled
CoderTypeRate=g729r8
CodecBytes=20
GENERIC:
SetupTime=209451 ms
Index=2
PeerAddress=2001
PeerSubAddress=
PeerId=2
PeerIfIndex=9
LogicalIfIndex=4
ConnectTime=209543
CallDuration=00:08:21
CallState=4
CallOrigin=1
ChargedUnits=0
InfoType=2
TransmitPackets=25074
TransmitBytes=501480
ReceivePackets=25120
ReceiveBytes=502400
TELE:
ConnectionId=[0x38D3783F 0x14F111CC 0x801CFDB1 0x2D0CC4A5]
IncomingConnectionId=[0x38D3783F 0x14F111CC 0x801CFDB1 0x2D0CC4A5]
TxDuration=502410 ms
VoiceTxDuration=502410 ms
FaxTxDuration=0 ms
CoderTypeRate=g729r8
NoiseLevel=0
ACOMLevel=1
OutSignalLevel=-41
InSignalLevel=-37
InfoActivity=2
ERLLevel=1
SessionTarget=
ImgPages=0
GENERIC:
SetupTime=210097 ms
Index=1
PeerAddress=2002
PeerSubAddress=
PeerId=3
PeerIfIndex=10
LogicalIfIndex=5
ConnectTime=210638
CallDuration=00:08:10
CallState=4
CallOrigin=2
ChargedUnits=0
InfoType=2
TransmitPackets=24606
TransmitBytes=492120
ReceivePackets=24605
ReceiveBytes=492100
TELE:
ConnectionId=[0x6C135AD4 0x14F311CC 0x8024CE4C 0xAA60AB15]
IncomingConnectionId=[0x6C135AD4 0x14F311CC 0x8024CE4C 0xAA60AB15]
TxDuration=492110 ms
VoiceTxDuration=492110 ms
FaxTxDuration=0 ms
CoderTypeRate=g729r8
NoiseLevel=0
ACOMLevel=0
OutSignalLevel=-46
InSignalLevel=-33
InfoActivity=2
ERLLevel=0
SessionTarget=
ImgPages=0
GENERIC:
SetupTime=210480 ms
Index=1
PeerAddress=1002
PeerSubAddress=
PeerId=1
PeerIfIndex=8
LogicalIfIndex=0
ConnectTime=210638
CallDuration=00:08:11
CallState=4
CallOrigin=1
ChargedUnits=0
InfoType=2
TransmitPackets=24587
TransmitBytes=491740
ReceivePackets=24664
ReceiveBytes=493280
VOIP:
ConnectionId[0x6C135AD4 0x14F311CC 0x8024CE4C 0xAA60AB15]
IncomingConnectionId[0x6C135AD4 0x14F311CC 0x8024CE4C 0xAA60AB15]
RemoteIPAddress=192.168.1.1
RemoteUDPPort=18884
RemoteSignallingIPAddress=192.168.1.1
RemoteSignallingPort=1720
RemoteMediaIPAddress=192.168.1.1
RemoteMediaPort=18884
RoundTripDelay=4 ms
SelectedQoS=best-effort
tx_DtmfRelay=h245-alphanumeric
FastConnect=TRUE

Separate H245 Connection=FALSE

H245 Tunneling=TRUE

SessionProtocol=cisco
SessionTarget=ipv4:192.168.1.1
OnTimeRvPlayout=487570
GapFillWithSilence=0 ms
GapFillWithPrediction=0 ms
GapFillWithInterpolation=0 ms
GapFillWithRedundancy=0 ms
HiWaterPlayoutDelay=70 ms
LoWaterPlayoutDelay=69 ms
ReceiveDelay=69 ms
LostPackets=0
EarlyPackets=1
LatePackets=0
VAD = disabled
CoderTypeRate=g729r8
CodecBytes=20Total call-legs: 4

Raleigh3640A#
Raleigh3640A#

Raleigh3640A# show policy interface
Serial1/0

Service-policy output: voice-policy

Class-map: voice-traffic (match-all)
113186 packets, 7289624 bytes
30 second offered rate 51000 bps, drop rate 0 bps
Match: access-group 102
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 51 (kbps) Burst 1275 (Bytes)
(pkts matched/bytes matched) 471/75864
(total drops/bytes drops) 0/0

Class-map: voice-signaling (match-all)
162 packets, 13339 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: access-group 103
Queueing
Output Queue: Conversation 265
Bandwidth 16 (kbps) Max Threshold 64 (packets)
(pkts matched/bytes matched) 162/13339
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)
194 packets, 16761 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/0/0
Raleigh3640A#


Raleigh3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (113963 matches)
Raleigh3640A#
Raleigh3640A#
Raleigh3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (114093 matches)
Raleigh3640A#
Raleigh3640A#
Raleigh3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (114188 matches)
Raleigh3640A#
Raleigh3640A#
Raleigh3640A# show access-lists 102
Extended IP access list 102
permit udp any any range 16384 32767 (114404 matches)
Raleigh3640A#
Raleigh3640A#


Raleigh3640A#
Raleigh3640A# show voice call sum
PORT CODEC VAD VTSP STATE VPM STATE
============ ======== === ==================== ======================
3/0/0 g729r8 n S_CONNECT FXSLS_CONNECT
3/0/1 g729r8 n S_CONNECT FXSLS_CONNECT
3/1/0 - - - FXOLS_ONHOOK
3/1/1 - - - FXOLS_ONHOOK

Raleigh3640A#


Raleigh3640A# show voice port sum
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
====== == ========== ===== ==== ======== ======== ==
3/0/0 -- fxs-ls up up off-hook idle y
3/0/1 -- fxs-ls up up off-hook idle y
3/1/0 -- fxo-ls up dorm idle on-hook y
3/1/1 -- fxo-ls up dorm idle on-hook y

Raleigh3640A#

Raleigh3640A#
Raleigh3640A# show voice dsp

DSP DSP DSPWARE CURR BOOT PAK TX/RX
TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABORT PACK COUNT
==== === == ======== ======= ===== ======= === == ========= == ===== ============
C542 001 01 g729r8 3.4.55 busy idle 0 0 3/0/0 NA 0 69615/68771
C542 002 01 g729r8 3.4.55 busy idle 0 0 3/0/1 NA 0 51511/51520
C542 003 01 g711ulaw 3.4.55 IDLE idle 0 0 3/1/0 NA 0 541/546
C542 004 01 g711ulaw 3.4.55 IDLE idle 0 0 3/1/1 NA 0 535/532

Raleigh3640A#

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 debug 命令的重要信息

  • debug voip ccapi inout —通过呼叫控制应用编程接口(API)跟踪执行路径。

  • 调试在所有虚拟语音端口模块(VPM)区域的debug vpm全Enable (event)。

  • show log —显示从关闭调试的输出。

因为Raleigh和San Jose侧是非常类似的在配置和设置方面,本文显示debug voip ccapi inoutdebug vpm all命令只有San Jose路由器的。

如果呼叫建立是问题,请发出调试指令该此部分列表。比较与此处信息的输出。您能使用软件,例如比较它或在比较,比较两个文本文件和查找差异之外。此处输出起一参考作用对于成功的呼叫。

首先,请确定在呼叫期间,什么在路由器发生。发出debug voip ccapi inoutdebug vpm all命令。从问题的输出show debug命令,和出现此处,显示启动debug vpm all命令在San Jose路由器。您能确定启动debug vpm all命令,因为输出显示四个启用的调试指令,除debug voip ccapi inout命令以外。当您发出debug vpm all命令时,这四命令有自动启动。

警告 警告: 您必须禁用这些调试指令,在您生成您需要的输出后。禁用与问题的调试指令undebug all命令。如果留下调试启动,您能遇到路由器性能问题。与启动的调试指令浪费CPU资源。

SanJose3640A# show debug
voip:
voip ccAPI function enter/exit debugging is on
Voice Port Module session debugging is on
Voice Port Module DSP message debugging is on
Voice Port Module error debugging is on
Voice Port Module signaling debugging is on
Voice Port Module voaal2 debugging is on
Voice Port Module trunk conditioning is on
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#! Call from 1001 to 2001
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#
*Mar 1 00:05:07.675: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0xC timestamp=33146 
 systime=30767
*Mar 1 00:05:07.679: htsp_process_event: [3/0/0, FXSLS_ONHOOK, E_DSP_SIG_
 1100] fxsls_onhook_offhook htsp_setup_ind
*Mar 1 00:05:07.679: [3/0/0] get_local_station_id calling num= calling name= calling 
 time=00/00 00:00
*Mar 1 00:05:07.679: cc_api_call_setup_ind (vdbPtr=0x6217C270, callInfo={called=,called_
 oct3=0x81,calling=,calling_oct3=0x0,calling_oct3a=0x0,calling_xlated=false,
 subscriber_type_str=RegularLine,fdest=0,peer_tag=2, prog_ind=3,callingIE_present 0},
 callID=0x61DAB4F4)
*Mar 1 00:05:07.679: cc_api_call_setup_ind calling number is null, answer addr dest 
 pattern  1001 e164_ans_addr 0 e164_dest_pattern 1
*Mar 1 00:05:07.679: cc_api_call_setup_ind valid dest pattern, copying 1001 to calling 
 number
*Mar 1 00:05:07.679: cc_api_call_setup_ind type 3 , prot 0
*Mar 1 00:05:07.683: cc_process_call_setup_ind (event=0x62107860)
*Mar 1 00:05:07.683: >>>>CCAPI handed cid 5 with tag 2 to app "DEFAULT"
*Mar 1 00:05:07.683: sess_appl: ev(24=CC_EV_CALL_SETUP_IND), cid(5), disp(0)
*Mar 1 00:05:07.683: sess_appl: ev(SSA_EV_CALL_SETUP_IND), cid(5), disp(0)
*Mar 1 00:05:07.683: ssaCallSetupInd
*Mar 1 00:05:07.683: ccCallSetContext (callID=0x5, context=0x620005E8)
*Mar 1 00:05:07.683: ssaCallSetupInd cid(5), st(SSA_CS_MAPPING),oldst(0), 
 ev(24)ev->e.evCallSetupInd.nCallInfo.finalDestFlag = 0
*Mar 1 00:05:07.683: ccCallSetupAck (callID=0x5)
*Mar 1 00:05:07.683: ccCallReportDigits (callID=0x5, enable=0x1)
*Mar 1 00:05:07.683: cc_api_call_report_digits_done (vdbPtr=0x6217C270, callID=0x5, 
 disp=0)
*Mar 1 00:05:07.683: sess_appl: ev(53=CC_EV_CALL_REPORT_DIGITS_DONE), cid(5), disp(0)
*Mar 1 00:05:07.683: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_CALL_REPORT_DIGITS_DONE)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:07.683: ssaReportDigitsDone cid(5) peer list: (empty)
*Mar 1 00:05:07.683: ssaReportDigitsDone callid=5 Enable succeeded
*Mar 1 00:05:07.687: ccGenerateTone (callID=0x5 tone=8)
*Mar 1 00:05:07.687: dsp_digit_collect_on: [3/0/0] packet_len=20 channel_id=128 packet_id=
 35 min_inter_delay=240 max_inter_delay=9760 mim_make_time=10 max_make_time=100 
 min_brake_time=10 max_brake_time=100
*Mar 1 00:05:07.687: dsp_soutput: [3/0/0]
*Mar 1 00:05:07.687: dsp_digit_collect_on: [3/0/0] packet_len=20 channel_id=128 packet_id=
 35 min_inter_delay=240 max_inter_delay=9760 mim_make_time=10 max_make_time=100 
 min_brake_time=10 max_brake_time=100
*Mar 1 00:05:07.687: dsp_soutput: [3/0/0]
*Mar 1 00:05:07.687: htsp_process_event: [3/0/0, FXSLS_WAIT_SETUP_ACK, E_HTSP_SETUP_ACK]
*Mar 1 00:05:09.455: cc_api_call_digit_begin (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, 
 srcCallId=0x5, digit=2, digit_begin_flags=0x1, rtp_timestamp=0xEB32A6E0
 rtp_expiration=0x0, dest_mask=0x1)
*Mar 1 00:05:09.455: sess_appl: ev(10=CC_EV_CALL_DIGIT_BEGIN), cid(5), disp(0)
*Mar 1 00:05:09.455: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_DIGIT_BEGIN)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:09.455: ssaIgnore cid(5), st(SSA_CS_MAPPING),oldst(0), ev(10)
*Mar 1 00:05:09.515: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, 
 srcCallId=0x5,digit=2,duration=95,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x1), 
 digit_tone_mode=0
*Mar 1 00:05:09.515: sess_appl: ev(9=CC_EV_CALL_DIGIT_END), cid(5), disp(0)
*Mar 1 00:05:09.515: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_CALL_DIGIT)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:09.515: ssaDigit
*Mar 1 00:05:09.515: ssaDigit, 0. sct->digit , sct->digit len 0, usrDigit 2, 
 digit_tone_mode=0
*Mar 1 00:05:09.515: ssaDigit,1. callinfo.called , digit 2, callinfo.calling 1001, 
 xrulecallingtag 0, xrulecalledtag 0
*Mar 1 00:05:09.515: ssaDigit, 7. callinfo.calling 1001, sct->digit 2, result 1
*Mar 1 00:05:09.635: cc_api_call_digit_begin (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, 
 srcCallId=0x5, digit=0, digit_begin_flags=0x1, rtp_timestamp=0xEB32A6E0
 rtp_expiration=0x0, dest_mask=0x1)
*Mar 1 00:05:09.635: sess_appl: ev(10=CC_EV_CALL_DIGIT_BEGIN), cid(5), disp(0)
*Mar 1 00:05:09.635: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_DIGIT_BEGIN)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:09.635: ssaIgnore cid(5), st(SSA_CS_MAPPING),oldst(0), ev(10)
*Mar 1 00:05:09.695: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, 
 srcCallId=0x5,digit=0,duration=95,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x1), 
 digit_tone_mode=0
*Mar 1 00:05:09.695: sess_appl: ev(9=CC_EV_CALL_DIGIT_END), cid(5), disp(0)
*Mar 1 00:05:09.695: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_CALL_DIGIT)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:09.695: ssaDigit
*Mar 1 00:05:09.695: ssaDigit, 0. sct->digit 2, sct->digit len 1, usrDigit 0, 
 digit_tone_mode=0
*Mar 1 00:05:09.695: ssaDigit,1. callinfo.called , digit 20, callinfo.calling 1001, 
 xrulecallingtag 0, xrulecalledtag 0
*Mar 1 00:05:09.695: ssaDigit, 7. callinfo.calling 1001, sct->digit 20, result 1
*Mar 1 00:05:09.815: cc_api_call_digit_begin (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, 
 srcCallId=0x5, digit=0, digit_begin_flags=0x1, rtp_timestamp=0xEB32A6E0
 rtp_expiration=0x0, dest_mask=0x1)
*Mar 1 00:05:09.815: sess_appl: ev(10=CC_EV_CALL_DIGIT_BEGIN), cid(5), disp(0)
*Mar 1 00:05:09.815: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_DIGIT_BEGIN)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:09.815: ssaIgnore cid(5), st(SSA_CS_MAPPING),oldst(0), ev(10)
*Mar 1 00:05:09.875: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, 
 srcCallId=0x5,digit=0,duration=95,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x1), 
 digit_tone_mode=0
*Mar 1 00:05:09.875: sess_appl: ev(9=CC_EV_CALL_DIGIT_END), cid(5), disp(0)
*Mar 1 00:05:09.875: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_CALL_DIGIT)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:09.875: ssaDigit
*Mar 1 00:05:09.875: ssaDigit, 0. sct->digit 20, sct->digit len 2, usrDigit 0, 
 digit_tone_mode=0
*Mar 1 00:05:09.875: ssaDigit,1. callinfo.called , digit 200, callinfo.calling 1001, 
 xrulecallingtag 0, xrulecalledtag 0
*Mar 1 00:05:09.875: ssaDigit, 7. callinfo.calling 1001, sct->digit 200, result 1
*Mar 1 00:05:09.995: cc_api_call_digit_begin (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, 
 srcCallId=0x5, digit=1, digit_begin_flags=0x1, rtp_timestamp=0xEB32A6E0
 rtp_expiration=0x0, dest_mask=0x1)
*Mar 1 00:05:09.995: sess_appl: ev(10=CC_EV_CALL_DIGIT_BEGIN), cid(5), disp(0)
*Mar 1 00:05:09.995: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_DIGIT_BEGIN)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:09.995: ssaIgnore cid(5), st(SSA_CS_MAPPING),oldst(0), ev(10)
*Mar 1 00:05:10.055: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, 
 srcCallId=0x5,digit=1,duration=95,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x1), 
 digit_tone_mode=0
*Mar 1 00:05:10.055: sess_appl: ev(9=CC_EV_CALL_DIGIT_END), cid(5), disp(0)
*Mar 1 00:05:10.055: cid(5)st(SSA_CS_MAPPING)ev(SSA_EV_CALL_DIGIT)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:10.055: ssaDigit
*Mar 1 00:05:10.055: ssaDigit, 0. sct->digit 200, sct->digit len 3, usrDigit 1, 
 digit_tone_mode=0
*Mar 1 00:05:10.055: ssaDigit,1. callinfo.called , digit 2001, callinfo.calling 1001, 
 xrulecallingtag 0, xrulecalledtag 0
*Mar 1 00:05:10.055: ssaDigit, 7. callinfo.calling 1001, sct->digit 2001, result 0
*Mar 1 00:05:10.055: ccCallReportDigits (callID=0x5, enable=0x0)
*Mar 1 00:05:10.055: cc_api_call_report_digits_done (vdbPtr=0x6217C270, callID=0x5, 
 disp=0)
*Mar 1 00:05:10.055: ssaSetupPeer cid(5) peer list: tag(1) called number (2001)
*Mar 1 00:05:10.055: ssaSetupPeer cid(5), destPat(2001), matched(1), prefix(), 
 peer(622FB888), peer->encapType (2)
*Mar 1 00:05:10.055: ccCallProceeding (callID=0x5, prog_ind=0x0)
*Mar 1 00:05:10.059: ccCallSetupRequest (Inbound call = 0x5, outbound peer =1, dest=, 
 params=0x621129C8 mode=0, *callID=0x6
 2112D38, prog_ind = 3) callingIE_present 0
*Mar 1 00:05:10.059: ccCallSetupRequest numbering_type 0x81
*Mar 1 00:05:10.059: ccCallSetupRequest encapType 2 clid_restrict_disable 1 null_orig_clg 
 1 clid_transparent 0 callingNumber 1001
*Mar 1 00:05:10.059: dest pattern 2..., called 2001, digit_strip 0
*Mar 1 00:05:10.059: callingNumber=1001, calledNumber=2001, redirectNumber= display_info= 
 calling_oct3a=0
*Mar 1 00:05:10.059: accountNumber=, finalDestFlag=0,
guid=3f30.bbbe.14ef.11cc.8008.fdb1.2d0c.c4a5
*Mar 1 00:05:10.059: peer_tag=1
*Mar 1 00:05:10.059: ccIFCallSetupRequestPrivate: (vdbPtr=0x620BCAF0, dest=, 
 callParams={called=2001,called_oct3=0x81, calling=1001,calling_oct3=0x0, calling_xlated=
 false, subscriber_type_str=RegularLine, fdest=0, voice_peer_tag=1},mode=0x0) vdbP
 tr type = 1
*Mar 1 00:05:10.059: ccIFCallSetupRequestPrivate: (vdbPtr=0x620BCAF0, dest=, callParams=
 {called=2001, called_oct3 0x81, calling=1001,calling_oct3 0x0, calling_xlated=false, 
 fdest=0, voice_peer_tag=1}, mode=0x0, xltrc=-5)
*Mar 1 00:05:10.059: ccSaveDialpeerTag (callID=0x5, dialpeer_tag=0x1)
*Mar 1 00:05:10.059: ccCallSetContext (callID=0x6, context=0x61DAD8A0)
*Mar 1 00:05:10.059: sess_appl: ev(53=CC_EV_CALL_REPORT_DIGITS_DONE), cid(5), disp(0)
*Mar 1 00:05:10.059: cid(5)st(SSA_CS_CALL_SETTING)ev(SSA_EV_CALL_REPORT_DIGITS_DONE)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:10.059: -cid2(6)st2(SSA_CS_CALL_SETTING)oldst2(SSA_CS_MAPPING)
*Mar 1 00:05:10.059: ssaReportDigitsDone cid(5) peer list: (empty)
*Mar 1 00:05:10.059: ssaReportDigitsDone callid=5 Reporting disabled.
*Mar 1 00:05:10.063: dsp_digit_collect_off: [3/0/0] packet_len=8 channel_id=128 packet_id=
 36
*Mar 1 00:05:10.063: dsp_soutput: [3/0/0]
*Mar 1 00:05:10.063: htsp_process_event: [3/0/0, FXSLS_OFFHOOK, E_HTSP_PROCEEDING]
*Mar 1 00:05:10.095: cc_api_call_proceeding(vdbPtr=0x620BCAF0, callID=0x6,
 prog_ind=0x0)
*Mar 1 00:05:10.099: sess_appl: ev(21=CC_EV_CALL_PROCEEDING), cid(6), disp(0)
*Mar 1 00:05:10.099: cid(6)st(SSA_CS_CALL_SETTING)ev(SSA_EV_CALL_PROCEEDING)
 oldst(SSA_CS_MAPPING)cfid(-1)csize(0)in(0)fDest(0)
*Mar 1 00:05:10.099: -cid2(5)st2(SSA_CS_CALL_SETTING)oldst2(SSA_CS_CALL_SETTING)
*Mar 1 00:05:10.099: ssaCallProc
*Mar 1 00:05:10.099: ccGetDialpeerTag (callID=0x5)
*Mar 1 00:05:10.099: ssaIgnore cid(6), st(SSA_CS_CALL_SETTING),oldst(1), ev(21)
*Mar 1 00:05:10.103: cc_api_call_cut_progress(vdbPtr=0x620BCAF0, callID=0x6, prog_ind=0x8, 
 sig_ind=0x1)
*Mar 1 00:05:10.103: sess_appl: ev(22=CC_EV_CALL_PROGRESS), cid(6), disp(0)
*Mar 1 00:05:10.107: cid(6)st(SSA_CS_CALL_SETTING)ev(SSA_EV_CALL_PROGRESS)
 oldst(SSA_CS_CALL_SETTING)cfid(-1)csize(0)in(0)fDest(0)
*Mar 1 00:05:10.107: -cid2(5)st2(SSA_CS_CALL_SETTING)oldst2(SSA_CS_CALL_SETTING)
*Mar 1 00:05:10.107: ssaCutProgress
*Mar 1 00:05:10.107: ccGetDialpeerTag (callID=0x5)
*Mar 1 00:05:10.107: ccCallCutProgress (callID=0x5, prog_ind=0x8, sig_ind=0x1)
*Mar 1 00:05:10.107: ccConferenceCreate (confID=0x6211310C, callID1=0x5, 
 callID2=0x6, tag=0x0)
*Mar 1 00:05:10.107: cc_api_bridge_done (confID=0x3, srcIF=0x620BCAF0, srcCallID=0x6, 
 dstCallID=0x5, disposition=0, tag=0x0)htsp_alert_notify
*Mar 1 00:05:10.107: cc_api_bridge_done (confID=0x3, srcIF=0x6217C270, srcCallID=0x5, 
 dstCallID=0x6, disposition=0, tag=0x0)
*Mar 1 00:05:10.107: cc_api_caps_ind (dstVdbPtr=0x620BCAF0, dstCallId=0x6, srcCallId=0x5,
 caps={codec=0x2EBFB, fax_rate=0x7F, vad=0x3, modem=0x2 codec_bytes=0, signal_type=3})
*Mar 1 00:05:10.107: cc_api_caps_ind (Playout: mode 1, initial 60,min 40, max 200)
*Mar 1 00:05:10.111: cc_api_caps_ind (dstVdbPtr=0x6217C270, dstCallId=0x5, srcCallId=0x6,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2})
*Mar 1 00:05:10.111: cc_api_caps_ind (Playout: mode 1, initial 60,min 40, max 200)
*Mar 1 00:05:10.111: cc_api_caps_ack (dstVdbPtr=0x6217C270, dstCallId=0x5, srcCallId=0x6,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2, 
 seq_num_start=9062})
*Mar 1 00:05:10.111: cc_api_caps_ack (dstVdbPtr=0x620BCAF0, dstCallId=0x6, srcCallId=0x5,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2, 
 seq_num_start=9062})
*Mar 1 00:05:10.111: cc_api_voice_mode_event , callID=0x5
*Mar 1 00:05:10.111: Call Pointer =620005E8
*Mar 1 00:05:10.115: cc_api_caps_ind (dstVdbPtr=0x6217C270, dstCallId=0x5, srcCallId=0x6,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2})
*Mar 1 00:05:10.115: cc_api_caps_ind (Playout: mode 1, initial 60,min 40, max 200)
*Mar 1 00:05:10.115: cc_api_caps_ack (dstVdbPtr=0x6217C270, dstCallId=0x5, srcCallId=0x6,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2, 
 seq_num_start=9062})
*Mar 1 00:05:10.123: cc_api_caps_ack (dstVdbPtr=0x620BCAF0, dstCallId=0x6, srcCallId=0x5,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2, 
 seq_num_start=9062})
*Mar 1 00:05:10.123: cc_api_voice_mode_event , callID=0x5
*Mar 1 00:05:10.123: Call Pointer =620005E8
*Mar 1 00:05:10.123: htsp_process_event: [3/0/0, FXSLS_OFFHOOK, E_HTSP_VOICE_CUT_THROUGH]
*Mar 1 00:05:10.123: htsp_process_event: [3/0/0, FXSLS_OFFHOOK, E_HTSP_VOICE_CUT_THROUGH]
*Mar 1 00:05:10.123: sess_appl: ev(29=CC_EV_CONF_CREATE_DONE), cid(5), disp(0)
*Mar 1 00:05:10.123: cid(5)st(SSA_CS_CONFERENCING_PROGRESS)ev(SSA_EV_CONF_CREATE_DONE)
 oldst(SSA_CS_CALL_SETTING)cfid(3)csize(0)in(1)fDest(0)
*Mar 1 00:05:10.127: -cid2(6)st2(SSA_CS_CONFERENCING_PROGRESS)oldst2(SSA_CS_CALL_SETTING)
*Mar 1 00:05:10.127: ssaConfCreateDoneAlert
*Mar 1 00:05:10.127: sess_appl: ev(51=CC_EV_VOICE_MODE_DONE), cid(5), disp(0)
*Mar 1 00:05:10.127: cid(5)st(SSA_CS_CONFERENCED_ALERT)ev(SSA_EV_VOICE_MODE_DONE)
 oldst(SSA_CS_CONFERENCING_PROGRESS)cfid(3)csize(0)in(1)fDest(0)
*Mar 1 00:05:10.127: -cid2(6)st2(SSA_CS_CONFERENCED_ALERT)oldst2(SSA_CS_CALL_SETTING)
*Mar 1 00:05:10.127: ssaIgnore cid(5), st(SSA_CS_CONFERENCED_ALERT),oldst(4), ev(51)
*Mar 1 00:05:10.127: sess_appl: ev(51=CC_EV_VOICE_MODE_DONE), cid(5), disp(2)
*Mar 1 00:05:10.127: cid(5)st(SSA_CS_CONFERENCED_ALERT)ev(SSA_EV_VOICE_MODE_DONE)
 oldst(SSA_CS_CONFERENCED_ALERT)cfid(3)csize(0)in(1)fDest(0)
*Mar 1 00:05:10.127: -cid2(6)st2(SSA_CS_CONFERENCED_ALERT)oldst2(SSA_CS_CALL_SETTING)
*Mar 1 00:05:10.127: ssaIgnore cid(5), st(SSA_CS_CONFERENCED_ALERT),oldst(4), ev(51)
*Mar 1 00:05:10.127: cc_process_notify_bridge_done (event=0x6210BDB8)
*Mar 1 00:05:10.131: cc_api_caps_ind (dstVdbPtr=0x6217C270, dstCallId=0x5, srcCallId=0x6,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2})
*Mar 1 00:05:10.131: cc_api_caps_ind (Playout: mode 1, initial 60,min 40, max 200)
*Mar 1 00:05:10.131: cc_api_caps_ack (dstVdbPtr=0x6217C270, dstCallId=0x5, srcCallId=0x6,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2, 
 seq_num_start=9063})
*Mar 1 00:05:10.131: cc_api_caps_ind (dstVdbPtr=0x6217C270, dstCallId=0x5, srcCallId=0x6,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2})
*Mar 1 00:05:10.131: cc_api_caps_ind (Playout: mode 1, initial 60,min 40, max 200)
*Mar 1 00:05:10.131: cc_api_caps_ack (dstVdbPtr=0x6217C270, dstCallId=0x5, srcCallId=0x6,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2, 
 seq_num_start=9063})
*Mar 1 00:05:10.135: cc_api_caps_ack (dstVdbPtr=0x620BCAF0, dstCallId=0x6, srcCallId=0x5,
 caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, signal_type=2, 
 seq_num_start=9063})
*Mar 1 00:05:10.135: cc_api_voice_mode_event , callID=0x5
*Mar 1 00:05:10.135: Call Pointer =620005E8
*Mar 1 00:05:10.135: cc_api_caps_ack (dstVdbPtr=0x620BCAF0, dstCallId=0x6, 
 srcCallId=0x5, caps={codec=0x4, fax_rate=0x2, vad=0x1, modem=0x0 codec_bytes=20, 
 signal_type=2, seq_num_start=9063})
*Mar 1 00:05:10.135: cc_api_voice_mode_event , callID=0x5
*Mar 1 00:05:10.135: Call Pointer =620005E8
*Mar 1 00:05:10.135: htsp_process_event: [3/0/0, FXSLS_OFFHOOK, E_HTSP_VOICE_CUT_THROUGH]
*Mar 1 00:05:10.135: htsp_process_event: [3/0/0, FXSLS_OFFHOOK, E_HTSP_VOICE_CUT_THROUGH]
*Mar 1 00:05:10.135: sess_appl: ev(51=CC_EV_VOICE_MODE_DONE), cid(5), disp(0)
*Mar 1 00:05:10.135: cid(5)st(SSA_CS_CONFERENCED_ALERT)ev(SSA_EV_VOICE_MODE_DONE)
 oldst(SSA_CS_CONFERENCED_ALERT)cfid(3)csize(0)in(1)fDest(0)
*Mar 1 00:05:10.135: -cid2(6)st2(SSA_CS_CONFERENCED_ALERT)oldst2(SSA_CS_CALL_SETTING)
*Mar 1 00:05:10.135: ssaIgnore cid(5), st(SSA_CS_CONFERENCED_ALERT),oldst(4), ev(51)
*Mar 1 00:05:10.135: sess_appl: ev(51=CC_EV_VOICE_MODE_DONE), cid(5), disp(0)
*Mar 1 00:05:10.135: cid(5)st(SSA_CS_CONFERENCED_ALERT)ev(SSA_EV_VOICE_MODE_DONE)
 oldst(SSA_CS_CONFERENCED_ALERT)cfid(3)csize(0)in(1)fDest(0)
*Mar 1 00:05:10.139: -cid2(6)st2(SSA_CS_CONFERENCED_ALERT)oldst2(SSA_CS_CALL_SETTING)
*Mar 1 00:05:10.139: ssaIgnore cid(5), st(SSA_CS_CONFERENCED_ALERT),oldst(4), ev(51)
*Mar 1 00:05:18.303: cc_api_call_connected(vdbPtr=0x620BCAF0, callID=0x6), prog_ind = 
 2cc_api_call_connected: setting callEntry->connected to TRUE

*Mar 1 00:05:18.303: sess_appl: ev(8=CC_EV_CALL_CONNECTED), cid(6), disp(0)
*Mar 1 00:05:18.303: cid(6)st(SSA_CS_CONFERENCED_ALERT)ev(SSA_EV_CALL_CONNECTED)
 oldst(SSA_CS_CALL_SETTING)cfid(3)csize(0)in(0)fDest(0)
*Mar 1 00:05:18.307: -cid2(5)st2(SSA_CS_CONFERENCED_ALERT)oldst2(SSA_CS_CONFERENCED_ALERT)
*Mar 1 00:05:18.307: ssaConnectAlert
*Mar 1 00:05:18.307: ccGetDialpeerTag (callID=0x5)
*Mar 1 00:05:18.307: ccCallConnect (callID=0x5), prog_ind = 2ccCallConnect: 
 setting callEntry->connected to TRUE

*Mar 1 00:05:18.307: ssaFlushPeerTagQueue cid(5) peer list: (empty)htsp_connect: no_
 offhook 0
*Mar 1 00:05:18.307: htsp_process_event: [3/0/0, FXSLS_OFFHOOK, E_HTSP_CONNECT]fxsls_
 offhook_connect
*Mar 1 00:05:18.307: [3/0/0] set signal state = 0x6 timestamp = 0
*Mar 1 00:05:18.307: dsp_set_sig_state: [3/0/0] packet_len=12 channel_id=128 packet_id=39 
 state=0x6 timestamp=0x0
*Mar 1 00:05:18.307: dsp_soutput: [3/0/0]
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#! call connected
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#! 1001 disconnecting the call
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#
SanJose3640A#
*Mar 1 00:05:57.019: htsp_dsp_message: SEND/RESP_SIG_STATUS: state=0x4 timestamp=16952 
 systime=35702
*Mar 1 00:05:57.019: htsp_process_event: [3/0/0, FXSLS_CONNECT, E_DSP_SIG_0100]fxsls_
 offhook_onhook, HF duration=500
*Mar 1 00:05:57.023: htsp_timer - 500 msec
*Mar 1 00:05:57.523: htsp_process_event: [3/0/0, FXSLS_CONNECT, E_HTSP_EVENT_TIMER]fxsls_
 connect_wait_release_req
*Mar 1 00:05:57.523: htsp_timer_stop
*Mar 1 00:05:57.523: cc_api_call_disconnected(vdbPtr=0x6217C270, callID=0x5, cause=0x10)
*Mar 1 00:05:57.523: sess_appl: ev(11=CC_EV_CALL_DISCONNECTED), cid(5), disp(0)
*Mar 1 00:05:57.523: cid(5)st(SSA_CS_ACTIVE)ev(SSA_EV_CALL_DISCONNECTED)
 oldst(SSA_CS_CONFERENCED_ALERT)cfid(3)csize(0)in(1)fDest(0)
*Mar 1 00:05:57.523: -cid2(6)st2(SSA_CS_ACTIVE)oldst2(SSA_CS_CONFERENCED_ALERT)
*Mar 1 00:05:57.523: ssa: Disconnected cid(5) state(5) cause(0x10)
*Mar 1 00:05:57.523: ccConferenceDestroy (confID=0x3, tag=0x0)
*Mar 1 00:05:57.523: cc_api_bridge_drop_done (confID=0x3, srcIF=0x620BCAF0, srcCallID=0x6, 
 dstCallID=0x5, disposition=0 tag=0x0)
*Mar 1 00:05:57.523: cc_api_bridge_drop_done (confID=0x3, srcIF=0x6217C270, srcCallID=0x5, 
 dstCallID=0x6, disposition=0 tag=0x0)
*Mar 1 00:05:57.523: sess_appl: ev(30=CC_EV_CONF_DESTROY_DONE), cid(5), disp(0)
*Mar 1 00:05:57.523: cid(5)st(SSA_CS_CONF_DESTROYING)ev(SSA_EV_CONF_DESTROY_DONE)
 oldst(SSA_CS_ACTIVE)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:57.527: -cid2(6)st2(SSA_CS_CONF_DESTROYING)oldst2(SSA_CS_CONFERENCED_ALERT)
*Mar 1 00:05:57.527: ssaConfDestroyDone
*Mar 1 00:05:57.527: ccCallDisconnect (callID=0x5, cause=0x10 tag=0x0)
*Mar 1 00:05:57.527: ccCallDisconnect: existing_cause = 0x0, new_cause = 0x10
*Mar 1 00:05:57.527: ccCallDisconnect (callID=0x6, cause=0x10 tag=0x0)
*Mar 1 00:05:57.527: ccCallDisconnect: existing_cause = 0x0, new_cause = 0x10htsp_release_
 req: cause 16, no_onhook 0
*Mar 1 00:05:57.531: htsp_process_event: [3/0/0, FXSLS_WAIT_RELEASE_REQ, 
 E_HTSP_RELEASE_REQ] fxsls_waitrls_req_rls
*Mar 1 00:05:57.531: [3/0/0] set signal state = 0x4 timestamp = 0
*Mar 1 00:05:57.531: dsp_set_sig_state: [3/0/0] packet_len=12 channel_id=128 packet_id=39 
 state=0x4 timestamp=0x0
*Mar 1 00:05:57.531: dsp_soutput: [3/0/0]htsp_report_onhook_sig
*Mar 1 00:05:57.531: cc_api_call_feature: (vdbPtr=0x6217C270, callID=0x5,
 feature_ind.type=5

*Mar 1 00:05:57.535: cc_api_call_disconnect_done(vdbPtr=0x6217C270, callID=0x5, disp=0, 
 tag=0x0)
*Mar 1 00:05:57.535: hdsprm_close_cleanup
*Mar 1 00:05:57.535: sess_appl: ev(28=CC_EV_CALL_FEATURE), cid(5), disp(0)
*Mar 1 00:05:57.535: cid(5)st(SSA_CS_DISCONNECTING)ev(SSA_EV_CALL_FEATURE)
 oldst(SSA_CS_CONF_DESTROYING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:57.535: -cid2(6)st2(SSA_CS_DISCONNECTING)oldst2(SSA_CS_CONFERENCED_ALERT)
*Mar 1 00:05:57.535: ssaIgnore cid(5), st(SSA_CS_DISCONNECTING),oldst(7), ev(28)
*Mar 1 00:05:57.539: sess_appl: ev(12=CC_EV_CALL_DISCONNECT_DONE), cid(5), disp(0)
*Mar 1 00:05:57.539: cid(5)st(SSA_CS_DISCONNECTING)ev(SSA_EV_CALL_DISCONNECT_DONE)
 oldst(SSA_CS_DISCONNECTING)cfid(-1)csize(0)in(1)fDest(0)
*Mar 1 00:05:57.539: -cid2(6)st2(SSA_CS_DISCONNECTING)oldst2(SSA_CS_CONFERENCED_ALERT)
*Mar 1 00:05:57.539: ssaDisconnectDone
*Mar 1 00:05:57.543: cc_api_icpif: expect factor = 0
*Mar 1 00:05:57.543: g113_calculate_impairment (delay=101,loss=0), Io=0 Iq=0 Idte=0 Idd=0 
 Ie=9 Itot=9
*Mar 1 00:05:57.543: cc_api_call_disconnect_done(vdbPtr=0x620BCAF0, callID=0x6, disp=0, 
 tag=0x0)
*Mar 1 00:05:57.547: sess_appl: ev(12=CC_EV_CALL_DISCONNECT_DONE), cid(6), disp(0)
*Mar 1 00:05:57.547: cid(6)st(SSA_CS_DISCONNECTING)ev(SSA_EV_CALL_DISCONNECT_DONE)
 oldst(SSA_CS_CONFERENCED_ALERT)cfid(-1)csize(1)in(0)fDest(0)
*Mar 1 00:05:57.547: ssaDisconnectDone
SanJose3640A#�

SanJose3640A#

相关信息


Document ID: 8128