广域网 : 点对点协议 (PPP)

PPP 背对背连接

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文为PPP背对背连接提供一配置示例。使用这样配置,您能验证您的连接和硬件是工作正常和某测试的均等使用IP路由。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 此配置是可适用的对所有思科IOSï ¿  ½软件版本。

  • DCE端用广域网DCE电缆连接。

  • DTE端用广域网DTE电缆连接。

关于广域网DCE或DTE电缆的更多信息,参考串行电缆文档。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

配置汇总

在此配置中, Router1使用一个V35-MT电缆(思科参考是CAB-V35MT),并且Router2使用一个V35-FC电缆(思科参考是CAB-V35FC)。这意味着Router2提供时钟。发出clock rate 64000命令使用64000位/秒时钟频率在serial0接口下。

注意: 一旦此命令配置,在配置里看起来作为clock rate 64000。两个电缆彼此当前连接。

以太网接口通过发出no keepalive命令配置。那个方式,连接他们到LAN网络为了获得他们正在运行是不必要的。使用在每个路由器的静态路由使您ping Router2以太网接口的IP地址,使用Router1 (或另一方面)以太网接口的IP地址。当然,这是有用的在测试环境。

网络图

本文根据以下配置:

/image/gif/paws/7923/ppp_backtoback.gif

配置

本文档使用以下配置:

Router1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.1.0.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.1 255.255.255.0
 encapsulation ppp
!
ip classless
ip route 10.2.0.0 255.255.255.0 10.0.0.2
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

Router2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.2.0.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.2 255.255.255.0
 encapsulation ppp
 no fair-queue
 clock rate 64000
!
ip classless
ip route 10.1.0.0 255.255.255.0 10.0.0.1
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • 发出show controllers命令检查电缆和时钟频率:

    下列是输出show controllers命令

    Router1#show controllers serial 0 | i V.35
    buffer size 1524  HD unit 0, V.35 DTE cable
    Router1#
    
  • 发出show interfaces serial 0命令检查数据包被发送并且接收(请参阅信息包输入packets output5分钟输入速率5每分钟输出生产率。关于使用的封装的信息,请参阅Encapsulation ppp

    下列是输出show interfaces serial 0命令

    Router1#show interfaces serial 0
    Serial0 is up, line protocol is up
      Hardware is HD64570
      Internet address is 10.0.0.1/24
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Open
      Open: IPCP, CDPCP
      Last input 00:00:00, output 00:00:00, output hang never
      Last clearing of "show interface" counters 00:07:53
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/5/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1158 kilobits/sec
      5 minute input rate 2000 bits/sec, 2 packets/sec
      5 minute output rate 2000 bits/sec, 2 packets/sec
         155 packets input, 55066 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         168 packets output, 60037 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
         0 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    Router1#
    
  • 使用IP地址10.2.0.1,要生成ping到10.2.0.2,您能发出ping命令

    下列是输出ping命令

    Router1#ping
    Protocol [ip]:
    Target IP address: 10.2.0.1
    Repeat count [5]:
    Datagram size [100]:
    Timeout in seconds [2]:
    Extended commands [n]: y
    Source address or interface: 10.1.0.1
    Type of service [0]:
    Set DF bit in IP header? [no]:
    Validate reply data? [no]:
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose[none]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds: Packet sent with a source address of 10.1.0.1 !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms Router1#
    

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show controllers —显示电缆和时钟频率。

  • show interfaces serial 0 —验证数据包被发送并且接收。

  • ping —用于测试设备的连接。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 7923