拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

配置使用ISDN桥接的拨号配置文件

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

使用拨号配置文件,本文为桥接在ISDN的两个不同的站点提供一配置示例使用每个站点一条B信道。

先决条件

要求

在您尝试此配置前,您需要收集从ISDN服务服务供应商的此信息:

  • ISDN交换机类型

  • ISDN服务配置文件标识符(SPID)和本地目录号(LDNs),在可适用地方。在北美, SPIDS为所有ISDN交换机类型要求除了5ESS自定义点对点。LDN是本地七位ISDN电话号码(没有区域代码)您的路由器。LDNs为DMS-100要求。

您也需要收集此网络信息:

  • 点对点协议(PPP)主机名-您必须分配PPP客户端名称到两个设备。

  • PPP认证类型-质询握手验证协议(CHAP)验证被偏好和用于此示例。

  • PPP密码-您必须分配PPP密码到所有位置。

  • IP地址信息-您必须创建IP网络设计。

  • 电话号码-两个位置ISDN电话号码。

  • 用户名和密码。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

拨号配置文件允许从逻辑配置将分离的物理接口的配置要求为呼叫。使用拨号配置文件,逻辑和物理配置动态地一定在每呼叫的基础上。

注意: 您在一个B信道和路由不能桥接在另一边信道。

配置

配置功能的此部分存在信息描述在本文。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/6429/dialprofbridge.gif

配置

路由器 1
Current configuration:
!
version 11.2
service udp-small-servers
service tcp-small-servers
!
hostname Router1
no ip routing
!
enable password foo
!
username Router2 password bar
username Router3 password bar
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.1.1.1 255.255.255.0
 media-type 10BaseT
 bridge-group 1
!
interface BRI0
 no ip address
 no ip mroute-cache
 encapsulation ppp
 no ip route-cache
 dialer pool-member 1
 ppp authentication chap
!
interface Dialer0
 no ip address
 no ip mroute-cache
 encapsulation ppp
 no ip route-cache
 dialer remote-name Router2
 dialer string 5552323
 dialer pool 1
 dialer-group 2
 no fair-queue
 no cdp enable
 ppp authentication chap
 bridge-group 1
!
interface Dialer1
 no ip address
 no ip mroute-cache
 encapsulation ppp
 no ip route-cache
 dialer remote-name Router3
 dialer string 5553434
 dialer pool 1
 dialer-group 2
 no cdp enable
 ppp authentication chap
 bridge-group 1
!
dialer-list 2 protocol bridge permit
bridge 1 protocol ieee
end

路由器 2
Current configuration:
!
version 11.2
service udp-small-servers
service tcp-small-servers
!
hostname Router2
no ip routing
!
enable password foo
!
username Router1 password bar
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.1.1.2 255.255.255.0
 no ip route-cache
 bridge-group 1
!
interface BRI0
 no ip address
 encapsulation ppp
 no ip route-cache
 dialer pool-member 1
!
interface Dialer0
 no ip address
 encapsulation ppp
 no ip route-cache
 dialer remote-name Router1
 dialer string 5551212
 dialer pool 1
 dialer-group 2
 no fair-queue
 no cdp enable
 ppp authentication chap
 bridge-group 1
!
dialer-list 2 protocol bridge permit
bridge 1 protocol ieee
!
end

路由器 3
Current configuration:
!
version 11.2
service udp-small-servers
service tcp-small-servers
!
hostname Router3
no ip routing
!
username Router1 password bar
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.1.1.3 255.255.255.0
 no ip route-cache
 bridge-group 1
!
interface BRI0
 no ip address
 encapsulation ppp
 no ip route-cache
 dialer pool-member 1
 ppp authentication chap
!
interface Dialer0
 no ip address
 encapsulation ppp
 no ip route-cache
 dialer remote-name Router1
 dialer string 5551212
 dialer pool 1
 dialer-group 2
 no cdp enable
 ppp authentication chap
 bridge-group 1
!
dialer-list 2 protocol bridge permit
bridge 1 protocol ieee
!
end

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug ppp authentication —看到客户端是否通过验证。如果使用在Cisco IOS�软件版本11.2之前的一个版本,请使用debug ppp chap命令

  • debug ppp协商—看到客户端是否通过点对点协议(PPP)协商;这是您检查地址协商的时候。

  • debug ppp error - 显示和PPP连接协商与操作相关的协议错误以及统计错误。

  • debug isdn q931 —要检查ISDN连接作为用户请拨号,为了发现什么发生与ISDN呼叫(例如,如果连接丢弃)。

  • show isdn status - 状态应为:

    layer 1 = active
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    如果第1层不是活跃的,则电线适配器或端口可能是坏或没接通。如果Layer2在TEI_Assign的状态,则路由器与交换机不对话。

  • show bridge —查看条目类在网桥转发数据库的。

  • show span —显示生成树拓扑为路由器所知。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 6429