广域网 : 点对点协议 (PPP)

接入服务器带有专用 V.120 PPP的 拨入 IP/PPP 配置

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文为接入服务器拨入IP/PPP提供一配置示例以专用的V.120 PPP

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOSï ¿  ½软件版本11.2或以上,与虚拟异步接口的V.120的。

  • Cisco IOS软件版本11.3或以上,为V.120用虚拟模板。

  • 配置的超过五条VTY线路Cisco IOS企业镜像。

请使用软件建议工具(仅限注册用户)确定哪些Cisco IOS软件特性集支持V.120功能。在工具内,请选择以下功能:V.120 Support、协议转换和虚拟模板协议转换的。如果需要其它功能,请选择他们如所需求。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

国际电信联盟电信标准化部门建议V.120,允许同步,异步或者位透明的数据可靠的传输在ISDN承载信道的。

V.120连接可以在PPP或非PPP模式。这是因为许多V.120终端适配器类似于调制解调器,并且支持一些AT命令集。非PPP模式可以用于验证V.120设置是否是正确在客户端和路由器。PPP在该链路可能然后配置。欲知更多信息,请参阅在非PPP模式部分的验证V.120

有实现V.120的两主要方法:

  • 虚拟异步接口

    使用Cisco IOS软件,您能配置异步协议功能,例如PPP和SLIP,在VTY线路。PPP和SLIP通常仅作用在异步接口,不在VTY线路。当您配置VTY线路支持异步协议功能时,您创建在VTY线路的虚拟异步接口。虚拟异步接口(亦称vty-async)创建对通过非物理接口进入路由器的支持呼叫。例如,异步字符数据流呼叫终止或者非物理接口的地产。虚拟异步接口不是可配置的用户;相反,他们动态地创建,并且被切断根据要求。

  • 虚拟模板

    使用一两步协议转换,虚拟模板实施支持PPP隧道。当V.120用户通过虚拟终端线路时拨,路由器创建虚拟访问接口。虚拟访问接口是支持在虚拟接口模板指定的异步协议配置的一个临时接口。该接口通过克隆虚拟模板接口在配置里动态地创建。当连接失败,此虚拟访问接口被释放。因为比有限的虚拟异步实施,给出更多配置选项虚拟模板更加灵活。

V.120 如何影响路由器性能

思科不建议您运行在V.120的PPP在Micamodem,因为V.120处理非常CPU密集型。Cisco AS5200不能处理许多同时激活的V.120 PPP连接。其他As5xxx路由器能处理更加同时激活的V.120 PPP连接。作为替代方案,思科推荐配置客户端ISDN终端适配器(TA)完成“同步对异步PPP转换”,以便连接进入网络接入服务器(NAS)作为正常同步PPP而不是V.120。

然而,用NextPort调制解调器,新特性被添加,卸载V.120呼叫到调制解调器数字信号信号处理器(DSP)。如果使用Cisco IOS软件版本12.2 XB (和12.2(11)T和以后),终止在NextPort DSP的V.120呼叫而不是CPU是可能的。欲知更多信息,请参阅终止在NextPort DSP的V.120塞申斯

为什么要使用 V.120 实现 PPP?

在V.120的PPP CPU密集型。所以,思科劝阻大量使用。然而您可以要运行在V.120的PPP以下原因的:

  • 附加到异步数据终端设备(DTE)的您使用终端适配器(TA),并且不能完成同步对异步PPP转换。在这种情况下,您必须使用V.120。

  • 您的TA的默认配置是V.120,没有您的互联网服务提供商,协助,并且您无法重新配置您的TA。

  • 应用程序要让PPP会话从字符格终端对话开始(例如,一特殊一次性密码挑战和答复),因此您不想要一纯同步PPP会话。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

此部分也描述vty-async的实施和虚拟模板。

注意: 这些步骤假设, NAS为基本ISDN或异步拨入访问适当地配置,并且客户端为在V.120的PPP适当地配置。

虚拟异步接口 (vty-async)

要实现vty-async,请完成这些步骤:

  1. 使用vty-async全局配置命令,创建虚拟异步接口。

  2. 配置vty-async连接的验证。请使用vty-async ppp验证{chap|pap}命令。

  3. 配置其他vty-async参数例如,保活计时器, MTU大小,报头压缩,等等,如所需求,您的设置的。参考协议转换欲知更多信息,并且虚拟异步装置发出命令

  4. 使用autodetect encapsulation v120 ppp命令,配置V.120封装自动检测。必须应用此命令到呼入呼叫的物理接口(例如, interface bri 0,接口序列1:23)。然而,如果呼叫的V.120 TA在Q.931设置的低级兼容性字段正确地发信号V.120,自动检测封装不是需要的。不幸地,许多TA不能执行此。

  5. 禁用用户名和密码提示符在VTY line configuration下。您不能通过配置登录密码执行此在VTY线路配置模式。如果使用AAA,请定义有方法无的列表然后应用它对VTY接口。例如:

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. 配置autocommand ppp default命令在VTY线路配置模式。没有登录认证和自动命令,当V.120连接进来, ppp, VTY启动PPP。这允许V.120对等体立即开始PPP协商,而不必运行脚本或者输入在终端窗口的用户名和密码。VTY不支持autoselect命令

    注意: 因为运行PPP的VTY开始,当连接被建立,您不能为管理发出在NAS的Telnet命令。避过此限制,实施transport input v120命令在用于V.120 PPP连接的VTY和实施transport input telnet命令在用于管理Telnet的那些。

虚拟模板

要实现虚拟模板,请完成这些步骤:

  1. 通过使用interface virtual-template命令,创建并且配置虚拟接口模板。正您会配置一个正常异步串行接口,请配置此虚拟接口。要执行如此,请分配虚拟接口模板激活接口的IP地址(使用ip unnumbered interface命令),并且配置编址,正您在异步接口会配置它。您能也输入压缩TCP报头或配置PPP的质询握手验证协议(CHAP)验证的in命令接口配置模式。例如:

    interface Virtual-Template1
      ip unnumbered Ethernet0
      no ip directed-broadcast
      ip tcp header-compression passive
      peer default ip address pool IPaddressPool
      ppp authentication chap
  2. 使用vty-async全局配置命令,创建虚拟异步接口。

  3. 配置虚拟终端线路根据虚拟接口模板的定义支持异步协议功能。使用vty-async virtual-template number命令在全局配置模式,您能执行此。例如:

    vty-async
    vty-async Virtual-Template 1
  4. 使用autodetect encapsulation v120 ppp命令,配置V.120封装自动检测。实施此命令对呼入呼叫的物理接口(例如, interface bri 0,接口序列1:23)。然而,如果呼叫的V.120 TA在Q.931设置的低级兼容性字段正确地发信号V.120,自动检测封装没有要求。不幸地,许多TA不能执行此。

  5. 禁用用户名和密码提示符在VTY line configuration下。请勿通过配置登录密码执行此在VTY线路配置模式。如果使用AAA,请定义有方法无的列表然后应用它对VTY接口。例如:

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. 配置autocommand ppp default命令在VTY线路配置模式。没有登录认证和自动命令,当V.120连接进来, ppp, VTY启动PPP。这将允许V.120对等体立即开始PPP协商,而不必运行脚本或输入在终端窗口的用户名和密码。注意VTY不支持autoselect命令

    注意: 因为运行PPP的VTY开始,当连接被建立,您不能为管理发出在NAS的Telnet命令。避过此限制,实施transport input v120命令在用于V.120 PPP连接的VTY和实施transport input telnet命令在用于管理Telnet的那些。

网络图

本文档使用以下网络设置:

/image/gif/paws/6306/28a.gif

配置

本文档使用以下配置:

  • Cisco AS5200 (支持拨入同步ISDN PPP不是的多链路),异步PPP和V.120 PPP的IP或PPP客户端。

此配置使用描述的虚拟异步接口(vty-async)方法以上。

V.120 (PPP)与虚拟异步接口
aaa new-model
aaa authentication login default local
aaa authentication login NOAUTH none             

!--- The aaa list NOAUTH has no authentication.
!--- This list will be applied to the vty interface.

! 
username fred password FLINTSTONE
!
ip local pool default 10.1.1.2 10.1.1.47

!--- Define local IP address pool.


vty-async                                        

!--- Configures all virtual terminal lines on a router to 
!--- support asynchronous protocol features.
!--- The vty-async parameters are required for Async V.120. 

vty-async keepalive 0       

!--- Disable PPP keepalives.

vty-async ppp authen chap pap 

!--- Async  V.120 PPP authentication methods.

!
interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
!
interface serial0:23

!--- ISDN D-channel configuration for T1 0.

  no ip address
  encapsulation ppp
  isdn incoming-voice modem

!--- Analog calls are forwarded to the internal digital modem.

  ppp authentication chap pap
  dialer rotary-group 1

!--- Member of rotary group 1. 


!--- The rotary group configuration is interface Dialer 1.

  autodetect encapsulation v120 ppp  

!--- Automatic detection of encapsulation type on the specified interface. 
!--- This interface will automatically detect whether the call is normal PPP or V.120
!--- If the calling V.120 TA correctly signals V.120 in the Q.931 
!--- SETUP low-level compatibility field, autodetect encapsulation is 
!--- not needed. Unfortunately, many TAs fail to do this.   
   
!
interface Dialer1

!--- Rotary group 1 logical interface.

  description Dialer interface for sync ISDN calls
  ip unnumbered Ethernet0
  encapsulation ppp
  peer default ip address pool
  dialer-group 1
  dialer idle-timeout 300                      
  no cdp enable
  ppp authentication chap pap 
!
interface Group-Async1
  description Interface for async modem calls
  async mode dedicated                           

!--- PPP only, no exec dial-ins (or Teminal window after dial).
 
  ip unnumbered Ethernet0
  encapsulation ppp
  ip tcp header-compression
  peer default ip address pool default
  dialer-group 1
  dialer idle-timeout 300                        
  no cdp enable
  ppp authentication chap pap
!
dialer-list 1 protocol ip permit
!
line con 0
  login authentication NOAUTH
line 1 48

!--- Modems used for normal async calls.

  no exec
  modem inout
!                                                
line vty 0 45

!--- V.120 call will be terminated on vty 0 45.
!--- If your router does not support more than five vtys refer 
!--- to the Components Used section.

  login authentication NOAUTH    

!--- Use the AAA list NOAUTH (which specified no authentication) 
!--- configured previously with this method. There will be no 
!--- Username/password exec prompt. Use the no login command
!--- if this NAS does not do AAA.

  autocommand ppp default

!--- This command is ONLY required for V.120 with PPP.

  session-timeout 5 output                       

!--- Timeout of 5 minutes.

  transport input v120                           

!--- Allow only V.120 connections into these VTYs.

line vty 46 50

!--- These vtys will be used for normal telnets into the router.

  login authentication default

!--- Use AAA list "default" for vty 46-50. 
!--- This method uses local authentication (configured previously).

  exec-timeout 30
  transport input telnet

!--- Permit only incoming telnet connections to use vty 46-50.


验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show ip route —显示IP路由条目。

  • show users —显示关于网络服务器的有效线路的信息,包括线路号、连接名和终端的位置。

验证V.120连接

要验证V.120连接,请完成这些步骤:

  1. 请使用debug v120,并且生成一流入V.120呼叫。您应该看到在NAS的此debug输出:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4

    如果此消息没出现,呼入呼叫很可能不是V.120,并且路由器同样地没有检测它。

  2. 验证vty-async接口是否出来。如果您的配置以虚拟模板使用V.120,请证实虚拟访问接口是否创建。在以下console log输出中, vty-async 32接口是UP :

    19:25:17: %LINK-3-UPDOWN: Interface VTY-Async32, 
    changed state to up
  3. 请使用debug ppp协商debug ppp authentication。保证PPP参数适当地协商。关于Ppp调试的更多信息,请参阅拨号技术:故障排除技术

  4. 执行show ip routeshow users检查V.120呼叫适当地建立。

以下示例是从我们没有V.120虚拟模板的设置的输出:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.68.0.0/32 is subnetted, 1 subnets
S       172.68.186.41 [1/0] via 172.18.120.1
     172.18.0.0/24 is subnetted, 1 subnets
S       172.18.120.0 [1/0] via 10.92.1.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.92.1.0 is directly connected, FastEthernet0
C    192.168.1.0/24 is directly connected, Loopback0
     172.0.0.0/32 is subnetted, 1 subnets
C       172.22.53.1 is directly connected, VTY-Async32

注意: 呼叫在接口vty-async 32连接,并且有路由给客户端。

注意: 当曾经非虚拟模板配置选项时,链路的NAS侧的IP地址将是那以太网或快速以太网接口在NAS。因此请验证以太网或快速以太网接口是否启用,并且可以ping。

DSL4-5300A#show users
  Line          User       Host(s)              Idle     Location
*0 con 0                   idle                 00:00:00
 32 vty 0     wan-2520-5  VTY-Async32           00:01:37 Serial0:18
Interface        User      Mode                 Idle     Peer Address
  VT32         wan-2520-5 Async PPP             00:01:14 172.22.53.1

注意: 呼叫在接口vty-async 32连接,并且对端IP地址指定。

如果以V.120使用虚拟模板选项show ip routeshow users输出象这样出现:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.199.0/32 is subnetted, 1 subnets
C       192.168.199.5 is directly connected, Virtual-Access1
     172.22.0.0/32 is subnetted, 1 subnets
S       172.22.186.41 [1/0] via 172.18.120.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.20.20.0 is directly connected, Virtual-Access1
.........

注意: 呼叫在接口虚拟访问1连接,并且有路由给客户端。

DSL4-5300A#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
  32 vty 0     wan-2520-5 Virtual-Access1      00:00:05 Serial0:18

注意: 呼叫在接口虚拟访问1.连接。

验证在非PPP模式的V.120

许多V.120终端适配器类似于调制解调器,并且支持一些AT命令集。因此,您能使用非PPP模式验证在客户端的V.120设置和路由器是否正确。您能然后配置在该链路的PPP。测试V.120单独允许我们排除故障V.120相关问题,无需添加PPP复杂性。

要测试在非PPP模式的V.120连接,请完成这些步骤:

  1. 启用用户名和密码提示符在VTY line configuration下。请使用login命令启用登录。请使用password password命令设置线路密码。如果使用AAA,请取消登录认证list命令在VTY下。

  2. 删除autocommand ppp default命令在VTY线路配置模式。例如:

    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login
    maui-soho-01(config-line)#password letmein
    maui-soho-01(config-line)#no autocommand ppp default
    
  3. 打开debug v120,并且发起从客户端的一呼叫。路由器应该显示此:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4       
  4. 继续V.120配置的其余。完成在配置部分描述的步骤。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令(可选)

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在您发出调试指令前,参考关于调试指令的重要信息欲知更多信息。

  • debug v120 —指示,当V.120处理开始或终止时和的接口它运行。

  • debug ppp协商—显示关于PPP流量和交换的信息,当协商PPP组件包括链路控制协议(LCP),验证和NCP时。成功的PPP协商将首先打开LCP状态,然后进行认证,最终协商NCP (通常为IPCP)。

  • debug ppp authentication —显示PPP认证协议消息,包括CHAP信息包交换和密码认证协议交换。


相关信息


Document ID: 6306