拨号和接入 : 按需拨号路由 (DDR)

在相同的 T1/E1 PRI 电路上配置拨入与拨出

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

本文描述如何配置进入和出去的呼叫的一接入服务器在同样T1PRI。进入和出去的呼叫是全部基于通信量的和使用按需拨号路由(DDR),但是为其他路由器不提供备份。如果希望配置仅拨入呼叫的一接入服务器,参考配置有PRI的本文一接入服务器流入的异步呼叫和ISDN呼叫的。要适用此配置包括备份,参考配置和故障排除DDR备份文件

先决条件

要求

Step1 -配置并且验证拨入和拨出客户端正确地设置。因为此配置集中于中心站点NAS配置,我们不包括客户端的一配置示例。一些客户端配置示例如下包括:

拨号到NAS的拨入客户端设备:

此NAS拨出的拨出客户端设备:

第 2 步 - 确认电话公司电路正常工作。您能使用show isdn status命令验证BRI或PRI电路正确地是功能。请参阅文档使用 show isdn status 命令进行 BRI 故障排除以获得详细信息。您必须同时启用用于出站呼叫的 T1/E1 PRI电路。请与电话公司联系以验证此信息。

使用的组件

此配置使用下面软件和硬件版本开发并且被测试。

  • NAS :Cisco AS5300用一个T1PRI电路。此AS5300运行Cisco IOS软件版本12.2(5)。

  • 客户端:Cisco AS5300用一个T1PRI电路。此配置没有包括。

  • 客户端:Cisco1600用一个BRI电路。此配置没有包括。

  • 客户端:Cisco 804用一个BRI电路。此配置没有包括。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

在许多情况下,使用同一个T1/E1 PRI电路拨入和拨出连接可能是必要的。网络接入服务器(NAS)在同样PRI将支持从多个ISDN用户的呼入呼叫和它可能也做呼出到另一个设备。出局拨号可能也用于备份方案, NAS将拨号并且连接给对等体丢失其主广域网链路。

相关产品

此配置可用于任何具有 T1 或 PRI 卡的路由器。因此,任何具有 T1 或 PRI 卡的 AS5xxx 系列路由器都能使用此配置。Cisco 2600及3600系列路由器可能也配置接受ISDN呼叫用T1/PRI广域网接口卡或网络模块。

也可以修改该配置,与E1或PRI端口结合使用。为E1控制器配置Telco提供的线性编码、成帧及其他物理特性。D信道配置(E1的接口串行x:15)和这里显示的类似。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档中使用的命令的其他相关信息,请使用 IOS 命令查找工具

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/6435/pri_dialin_6435.gif

配置

有配置的接入服务器两主要方法能做呼出呼叫和接受呼入呼叫在同样T1/E1 PRI。这些是拨号配置文件和拨号循环组。其中每一有其好处和缺点,例如:

  • 拨号循环组更加简单配置与管理。

  • 拨号配置文件需要每次进入和出去的呼叫的一个独立拨号程序接口。如果让许多流入和流出的对等体然后配置请复杂化创建和维护。

  • 拨号配置文件允许客户端特定配置。例如,您能指定某一客户端将分配从地址池A的一个IP地址,当另一个客户端将分配从池B.时的一个地址。

  • 拨号循环组允许将应用的仅同样参数对所有用户。每个用户定制不是可能的。

  • 拨号循环组只允许单个触发数据流定义进入和出去的呼叫。因此,您不能配置路由器使用一触发数据流定义呼入呼叫和另一个呼出呼叫的。

  • 拨号配置文件允许每对等体的独立的触发数据流定义。

本文提供示例使用拨号配置文件和拨号循环组在NAS。选择方法适当为您的情况。

有拨号配置文件的(AS5300)中央接入服务器
maui-nas-03#show running-config 
Building configuration...

Current configuration : 3351 bytes
!
! Last configuration change at 07:25:39 CDT Wed Oct 24 2001
! NVRAM config last updated at 16:37:00 CDT Tue Oct 23 2001
!
version 12.2
service timestamps debug datetime msec show-timezone
service timestamps log datetime msec show-timezone
service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
aaa authorization network default local 
enable secret 5 <deleted>
!
username admin password 7 <deleted>
username 800-isdn-client password 7 <deleted>
username 1600-isdn-client password 7 <deleted>
username 5300-client password 7 <deleted>
username lanai-nas-01 password 7 <deleted>

! -- Usernames for local authentication of the call.
! -- The client presents the username/password 
! -- and the NAS authenticates the peer.

spe 2/0 2/7
 firmware location mica-modem-pw.2.7.3.0.bin
!
resource-pool disable
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
isdn switch-type primary-ni

! -- Switch-type for this NAS. Obtain this information from the Telco.

isdn voice-call-failure 0
!
controller T1 0

! -- T1 PRI physical controller configuration.

 framing esf

! -- Framing for this T1 is Extended Super Frame (ESF). 
! -- Obtain this information from the telco.

 clock source line primary

! -- T1 0 is the primary clock source for this NAS. 
! -- Clock source must be specified for the timing 
! -- and synchronization of the T1 carrier.

 linecode b8zs

! -- Linecoding for this T1. Obtain this information from the telco.

 pri-group timeslots 1-24

! -- For T1 PRI scenarios, all 24 T1 timeslots are assigned 
! -- as ISDN PRI channels. The router will now automatically create the 
! -- corresponding D-channel: interface Serial 0:23
!
! -- The configurations for unused T1 controllers are omitted to save space.
! -- Unused T1s can be shutdown.


!
interface Ethernet0
 ip address 172.22.53.150 255.255.255.0
!
interface Serial0:23

! -- D-channel configuration for T1 0.

 no ip address
 encapsulation ppp
 dialer pool-member 10

! -- Assign this D-channel as member of dialer pool 10.
! -- Dialer pool 10 is used by interface Dialer 1 and Dialer 2. 
! -- All Dialer Interfaces for incoming calls should be configured 
! -- to use this pool.

 dialer pool-member 50 max-link 10

! -- The D-channel is also a member of dialer pool 50.
! -- Dialer pool 50 is used by interface Dialer 100.
! -- The pool can use a maximum of 10 links and will be used for outgoing calls.
 
 isdn switch-type primary-ni
 isdn bchan-number-order ascending

! -- B Channel Outgoing Call Order is ascending.
! -- Contact the Telco to determine whether the ISDN outbound trunk 
! -- call selection is configured for ascending or descending on the switch.

 no cdp enable
 ppp authentication chap
 ppp multilink

! -- Allow multlink ppp on this interface.

!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dialer1
 description For Dialin ISDN Client - austin-soho-01
 ip unnumbered Ethernet0

! -- The interface is unnumbered to conserve IP addresses.

 encapsulation ppp
 dialer pool 10

! -- Defines the pool of physical resources from which the Dialer 
! -- interface may draw B channels as needed. Interface Dialer 2 also 
! -- uses this pool. Serial 0:23 is a member of this pool.

 dialer remote-name 1600-isdn-client

! -- Specifies remote router authenticated name and must match that used by 
! -- the remote router to authenticate itself (which can be different from
! -- the router hostname). The router uses this remote-name to bind the 
! -- incoming call to this dialer. without this command calls from 
! -- 1600-isdn-client will fail after authentication.

 dialer idle-timeout 0

! -- Set an idle-timeout of infinity. 
! -- The "zero" option for dialer idle-timeout was introduced in 12.1(3)T.

 dialer-group 1

! -- Apply interesting traffic definition from dialer-list 1.


 peer default ip address pool DIALIN

! -- Clients are assigned addresses from the ip address pool named "DIALIN".

 no fair-queue
 ppp authentication chap callin
 ppp multilink
!
interface Dialer2
 description For Dialin ISDN Client - travis-soho-01
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer pool 10

! -- Defines the pool of physical resources from which the Dialer 
! -- interface may draw B channels as needed. Interface Dialer 1 
! -- also uses this pool. Serial 0:23 is a member of this pool.

 dialer remote-name 800-isdn-client

! -- Binds incoming calls from  user "800-isdn-client" to this dialer.

 dialer-group 1

! -- Apply interesting traffic definition from dialer-list 1. 

 peer default ip address pool DIALIN
 pulse-time 0
 ppp authentication chap callin
 ppp multilink
!
interface Dialer100
 description For Dialout Client - lanai-nas-01
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer pool 50

! -- This dialer will draw resources from dialer pool 50 
! -- in which int serial 0:23 is the sole member.
! -- Since this dialer is used for dialout, 
! -- the outgoing call will be sent to interface se 0:23.

 dialer remote-name lanai-nas-01

! -- Specifies remote router authenticated name and must match that used by 
! -- the remote router to authenticate itself 
! -- (which can be different from the router hostname).

 dialer idle-timeout 900

! -- Idle timeout for incoming calls is 900 seconds (15 mins).
! -- Users that are idle for more than 900 seconds will be dropped.

 dialer string 81690 class 56k

!--- Dial 81690 and use the map-class named "56k" (defined below).

 dialer load-threshold 1 outbound

! -- This sets the outbound load level for traffic at which
! -- additional connections will be added to the MP bundle load level.
! -- Values range from 1 (unloaded) to 255 (fully loaded). 
! -- With a threshold of 1, additional links will be immediately 
! -- brought up and added to the bundle.

 dialer-group 3

! -- Apply interesting traffic definition from dialer-list 3.
! -- Note: the interesting traffic definition for outbound 
! -- calls is different than for incoming calls.

 ppp authentication chap
 ppp multilink

! -- Allow multlink ppp.

!         
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip local pool DIALIN 172.22.53.151 172.22.53.159

! -- IP address pools for dialin clients.

ip classless
ip route 172.16.0.0 255.255.0.0 Dialer100

! -- Static route for the 172.16.0.0/16 network. 
! -- Interesting Traffic for that network
! -- will be sent to interface Dialer100 and the router 
! -- will initiate the outbound call.

no ip http server
ip pim bidir-enable
!
!
map-class dialer 56k

!-- map-class named "56k" that was used with the dialer string in int Dialer100.

 dialer isdn speed 56

! -- Set the speed of the call to be 56k (default is 64k).
! -- This may not be neccessary for your connection. Consult your telco
! --  to find out if you need to configure the dial speed to 56k.

access-list 101 remark Interesting traffic definition for dialin clients
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq ntp
access-list 101 permit ip any any

! -- EIGRP and  NTP traffic are tagged uninteresting for dialin clients.

access-list 103 remark Interesting traffic for link lanai-nas-01
access-list 103 deny   eigrp any any
access-list 103 deny   udp any any eq ntp
access-list 103 permit ip any any

! -- EIGRP and  NTP traffic are tagged uninteresting for the outbound dial.
! -- Eventhough the two interesting traffic definitions here are identical, 
! -- they can be changed depending on your traffic patterns.

dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to interface Dialer 1 & 2 using the command dialer-group 1.
!--- Note: The specified dialer-list number must be the same 
!--- as the dialer-group number; in this example, defined to be "1".

dialer-list 3 protocol ip list 103
!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
line 1 48
line aux 0
line vty 0 4
!
ntp clock-period 17180029
ntp server 172.22.53.1
end

上述Dialer Profile配置有每次进入和出去的呼叫的一个独立拨号程序接口。而呼出呼叫的拨号接口是Dialer100,呼入呼叫的拨号接口是拨号1和Dialer2。在呼入呼叫验证后,路由器绑定呼叫对根据拨号程序远程名的适当的拨号接口。呼出呼叫的(Dialer100)仅拨号接口有一dialer string用将拨号的编号。仅Dialer100包括dialer load-threshold命令,因为能根据Inbound或Outbound负载拨号另外的链路(默认出站)。

以下配置使用拨号循环组此方案:

中央接入服务器w/Rotary组
maui-nas-03#show running-config 
Building configuration...

Current configuration : 2436 bytes
!
! Last configuration change at 08:20:11 CDT Thu Oct 25 2001
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
aaa authorization network default local 
enable secret 5 <deleted>
!
username admin password 7 <deleted>
username lanai-nas-01 password 7 <deleted>
username 800-isdn-client password 7 <deleted>
username 1600-isdn-client password 7 <deleted>
spe 2/0 2/7
 firmware location mica-modem-pw.2.7.3.0.bin
!
resource-pool disable
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
isdn switch-type primary-ni
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

! -- The configuration for unused T1 controllers are omitted to save space.
! -- Unused T1s can be shutdown.

!
interface Ethernet0
 ip address 172.22.53.150 255.255.255.0
!
interface Serial0:23

! -- D-channel configuration for T1 0.

 no ip address
 encapsulation ppp
 dialer rotary-group 1

! -- T1 0 is a member of rotary group 1.
! -- The rotary group configuration is in interface Dialer 1.
! -- Note: this command was not included in the dialer profile configuration.

 isdn switch-type primary-ni
 isdn bchan-number-order ascending
 no peer default ip address
 no cdp enable
 ppp authentication chap
 ppp multilink
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dialer1

!--- Configuration for rotary group 1.
!--- The Dialer interface number (1) must exactly match rotary group number
!--- configured on the physical interfaces(interface Serial 0:23).

 ip unnumbered Ethernet0

! -- This dialer is unnumbered to ethernet 0.

 encapsulation ppp
 dialer in-band

! -- Enable this dialer interface to be a DDR interface.

 dialer idle-timeout 900

! -- Idle timeout for incoming calls is 900 seconds (15 mins).
! -- Users that are idle for more than 900 seconds will be dropped.
! -- If dialer in-band is used and a dialer idle-timeout is not defined, then 
! -- the default idle-timeout of 120 seconds (2min) will be applied.

 dialer map ip 172.16.1.1 name lanai-nas-01 speed 56 broadcast 81690

! -- Dialer map for the outbound dial. Add a dialer map for every router 
! -- that needs to be dialed. Inbound calls do not need dialer maps. 
! -- They will be dynmamically created.

 dialer load-threshold 1 outbound

! -- This sets the outbound load level for Multlink PPP at 1/255.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
! -- Note: The specified dialer-group number must be the same as 
! -- the dialer-list number; in this example, defined to be "1". 

 peer default ip address pool DIALIN

! -- clients are assigned addresses from the ip address pool named "DIALIN".

 no cdp enable
 ppp authentication chap
 ppp multilink
 multilink max-links 5
!
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip local pool DIALIN 172.22.53.151 172.22.53.159
ip classless
ip route 172.16.0.0 255.255.0.0 172.16.1.1
ip route 172.16.1.1 255.255.255.255 Dialer1
no ip http server
ip pim bidir-enable
!
!
access-list 101 remark Interesting traffic definition
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq ntp
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

! -- Interesting traffic is defined by dialer-list 1.
! -- This is applied to interface Dialer 1 using dialer-group 1.
! -- The interesting traffic definition for inbound and outbound calls 
! -- is the same. If you want different interesting traffic definition 
! -- for inbound and outbound calls use dialer profiles.

!
line con 0
 login authentication NO_AUTHEN
line 1 48
line aux 0
line vty 0 4
!
ntp clock-period 17179882
ntp server 172.22.53.1
end

在上述拨号程序循环组配置中,拨号接口有单个dialer map使用对拨出。配置需要拨号的每对等体的一dialer map。

注意: 当他们动态地创建,呼入呼叫不需要拨号图。使用show dialer map命令,这可以验证。示例如下所示:

maui-nas-03#show dialer map
Dynamic dialer map ip 172.22.53.152 name 1600-isdn-client () on Di1

! -- Dynamic dialer map for 1600-isdn-cliet created from Dialer1
! -- (the rotary group interface).

Dynamic dialer map ip 172.22.53.151 name 800-isdn-client () on Di1

! -- Dynamic dialer map for 800-isdn-cliet created from Dialer1
! -- (the rotary group interface).

Static dialer map ip 172.16.1.1 name lanai-nas-01 (81690) on Di1

! -- Static map configured on Dialer 1 was applied to this link 
! -- connected to lanai-nas-01.


验证

本部分所提供的信息可用于确认您的配置是否正常工作。

输出解释器工具支持某些 show 命令(只限于注册用户),通过它可以查看 show 命令输出的分析。

  • show isdn status - 确保路由器与 ISDN 交换机正常通信。在输出中,验证第1层状态是否为活跃状态,是否第2层状态=MULTIPLE_FRAME_ESTABLISHED出现。此指令也显示活动的呼叫的数量。

  • show ppp multilink - 显示关于处于活动状态的多链路捆绑的信息。应使用本命令来检查多链路连接。

  • show dialer [interface type number] - 显示为 DDR 配置的接口的常规诊断信息。如果拨号程序正常启动,则应出现 Dialer state is data link layer up 消息。如果physical layer up出现,则线路通信协议表现出来,但是网络控制协议(NCP)没有。启动拨号的数据包的源地址和目标地址显示在 dial reason line 中。此show指令也显示计时器的配置和连接超时前的时间。

  • show caller user username detail -显示特定用户参数,如分配的IP地址、PPP和PPP捆绑参数等。如果您的Cisco IOS版本软件不支持此指令,请使用show users命令。

  • show dialer map - 显示已配置的动态和静态 Dialer Maps。此指令可以被用于发现动态拨号映射是否被创建了。没有dialer map,您不能路由数据包。

以下是确保成功呼叫的一些显示命令输出。注意在输出和备注中的粗体部分。比较您得到与如下所示的结果的输出。

maui-nas-03#show isdn status
Global ISDN Switchtype = primary-ni
ISDN Serial0:23 interface
        dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    ! -- Layer 1 is ACTIVE and Layer 2 is MULTIPLE FRAME ESTABLISHED.

    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x807FFFFF
    Number of L2 Discards = 0, L2 Session ID = 0
    Total Allocated ISDN CCBs = 0

maui-nas-03#show isdn service
PRI Channel Statistics:
ISDN Se0:23, Channel [1-24]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 
   Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 

! -- All channels are Inservice.


maui-nas-03#show user
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00   

  Interface      User        Mode                     Idle     Peer Address
  Di100        lanai-nas- PPP   Bundle        00:00:35 172.16.1.1

  ! -- Connection to lanai-nas-01 uses int Dialer 100.

  Di2          800-isdn-c PPP   Bundle        00:00:22 172.22.53.154
  
! -- Connection to 800-isdn-client uses int Dialer 2.

  Di1          1600-isdn- PPP   Bundle        00:01:29 172.22.53.153
 
 ! --  Connection to 1600-isdn-client uses int Dialer 1.

  Se0:0        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:1        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:2        1600-isdn- Sync PPP                    -   Bundle: Di1
  Se0:3        1600-isdn- Sync PPP                    -   Bundle: Di1
  Se0:4        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:5        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:6        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:7        800-isdn-c Sync PPP                    -   Bundle: Di2
  Se0:8        800-isdn-c Sync PPP                    -   Bundle: Di2

  ! -- Two B-channels are connected to 800-isdn-client (Se0:7-Se0:8) and 
  ! -- 1600-isdn-client (Se0:2-Se0:3). Five other B-channels 
  ! -- (Se0:0-Se0:1 and Se0:4-Se0:6) are connected to lanai-nas-01.


maui-nas-03#show ppp multilink 

Dialer2, bundle name is 800-isdn-client

  ! -- int Dialer 2 controls multilink bundle to 800-isdn-client.

  Bundle up for never
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x8 received sequence, 0xC sent sequence
  Member links: 2 (max not set, min not set)
    Serial0:7, since 00:00:16, last rcvd seq 000006
    Serial0:8, since 00:00:15, last rcvd seq 000007

  ! -- B-channels Se0:7 and Se0:8 are connected.


Dialer100, bundle name is lanai-nas-01

! -- int Dialer 100 controls multilink bundle to lanai-nas-01.

  Bundle up for never
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x33 received sequence, 0x33 sent sequence
  Member links: 5 (max not set, min not set)
    Serial0:0, since 00:02:08, last rcvd seq 000032
    Serial0:1, since 00:02:05, last rcvd seq 00002E
    Serial0:4, since 00:01:35, last rcvd seq 00002F
    Serial0:5, since 00:01:05, last rcvd seq 000030
    Serial0:6, since 00:00:35, last rcvd seq 000031

  ! -- B-channels Se0:0-Se0:1 and Se0:4-Se0:6 are connected.


Dialer1, bundle name is 1600-isdn-client

! -- int Dialer 100 controls multilink bundle to 1600-isdn-client.

  Bundle up for never
  0 lost fragments, 1 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x28 received sequence, 0x7B sent sequence
  Member links: 2 (max not set, min not set)
    Serial0:2, since 00:06:24, last rcvd seq 000026
    Serial0:3, since 00:06:22, last rcvd seq 000027

 ! -- B-channels Se0:2 and Se0:3 are connected.


故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除资源

按照需要使用下列故障排除资源:

故障排除命令

输出解释器工具支持某些 show 命令(只限于注册用户),通过它可以查看 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug dialer -关于在拨号接口收到数据包的显示DDR调试信息。此信息有助于保证具有可以使用拨号程序接口的触发数据流。

  • debug isdn q931 -显示呼叫建立和拆卸ISDN网络连接(第3层)。

  • debug ppp negotiation -显示协商链路控制协议(LCP)、认证和网络控制协议(NCP)时的 PPP数据流量和交换的信息。成功的PPP协商将首先开放LCP状态,然后进行验证,最后进行NCP协商。在 LCP 协商期间建立多链路参数,如最大接收重建单元 (MRRU)。

  • debug ppp authentication - 显示 PPP 认证协议消息,包括 CHAP 数据包交换和口令身份验证协议 (PAP) 交换。

  • debug ppp error -显示与PPP连接协商和运行有关的协议错误和错误统计数据。

以下是成功传出呼叫的调试输出。注意在输出和备注中的粗体部分。比较您得到与如下所示的结果的输出。

maui-nas-03#debug dialer
Dial on demand events debugging is on
maui-nas-03#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-nas-03#debug ppp authentication
PPP authentication debugging is on
maui-nas-03#debug isdn q931
ISDN Q931 packets debugging is on

maui-nas-03#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

Oct 24 12:56:16.205 UTC: Se0:23 DDR: rotor dialout [priority]
Oct 24 12:56:16.205 UTC: Se0:23 DDR: Dialing cause ip 
(s=172.22.53.150, d=172.16.1.1)

! -- The dialing cause is a ping for 172.16.1.1. 
! -- ICMP is tagged as interesting.

Oct 24 12:56:16.205 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:16.205 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0063

! -- Outgoing ISDN Q.931 SETUP message.

Oct 24 12:56:16.205 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:16.205 UTC:         Channel ID i = 0xA98381
Oct 24 12:56:16.209 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
Oct 24 12:56:16.241 UTC: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x8063
Oct 24 12:56:16.241 UTC:         Channel ID i = 0xA98381
Oct 24 12:56:16.285 UTC: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x8063

! -- Received Q.931 CONNECT message.

Oct 24 12:56:16.297 UTC: %LINK-3-UPDOWN: Interface Serial0:0, changed state to up
Oct 24 12:56:16.297 UTC: Se0:0: interface must be fifo queue, force fifo
Oct 24 12:56:16.297 UTC: %DIALER-6-BIND: Interface Se0:0 bound to profile Di100
Oct 24 12:56:16.297 UTC: Se0:0 PPP: Treating connection as a callout
Oct 24 12:56:16.297 UTC: Se0:0 PPP: Phase is ESTABLISHING, 
Active Open [0 sess, 1 load]
Oct 24 12:56:16.301 UTC: Se0:0 LCP: O CONFREQ [Closed] id 12 len 33
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    MagicNumber 0xE384A4CD (0x0506E384A4CD)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:16.301 UTC: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  callref = 0x0063
Oct 24 12:56:16.317 UTC: Se0:0 LCP: I CONFREQ [REQsent] id 10 len 34
Oct 24 12:56:16.317 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.317 UTC: Se0:0 LCP:    MagicNumber 0x54F49B93 (0x050654F49B93)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:16.321 UTC: Se0:0 LCP: O CONFACK [REQsent] id 10 len 34
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MagicNumber 0x54F49B93 (0x050654F49B93)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:16.325 UTC: Se0:0 LCP: I CONFACK [ACKsent] id 12 len 33
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    MagicNumber 0xE384A4CD (0x0506E384A4CD)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:16.325 UTC: Se0:0 LCP: State is Open

! -- LCP negotation is complete.

Oct 24 12:56:16.325 UTC: Se0:0 PPP: Phase is AUTHENTICATING, 
by both [0 sess, 1 load]
Oct 24 12:56:16.325 UTC: Se0:0 CHAP: O CHALLENGE id 8 len 32 from "maui-nas-03"
Oct 24 12:56:16.337 UTC: Se0:0 CHAP: I CHALLENGE id 10 len 33 from "lanai-nas-01"
Oct 24 12:56:16.341 UTC: Se0:0 CHAP: O RESPONSE id 10 len 32 from "maui-nas-03"
Oct 24 12:56:16.353 UTC: Se0:0 CHAP: I SUCCESS id 10 len 4
Oct 24 12:56:16.357 UTC: Se0:0 CHAP: I RESPONSE id 8 len 33 from "lanai-nas-01"
Oct 24 12:56:16.361 UTC: Se0:0 CHAP: O SUCCESS id 8 len 4

! -- Two-way CHAP authentication is successful.

Oct 24 12:56:16.361 UTC: Se0:0 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:16.361 UTC: Di100 DDR: Authenticated host lanai-nas-01 
with no matching dialer map
Oct 24 12:56:16.361 UTC: Di100 PPP: Phase is UP [0 sess, 1 load]
Oct 24 12:56:16.361 UTC: Di100 IPCP: O CONFREQ [Closed] id 6 len 10
Oct 24 12:56:16.361 UTC: Di100 IPCP:    Address 172.22.53.150 (0x0306AC163596)
Oct 24 12:56:16.361 UTC: Di100 CDPCP: O CONFREQ [Closed] id 6 len 4
Oct 24 12:56:16.365 UTC: Di100 MLP: Added first link Se0:0 to bundle lanai-nas-01
Oct 24 12:56:16.365 UTC: Di100 PPP: Treating connection as a callout
Oct 24 12:56:16.377 UTC: Di100 IPCP: I CONFREQ [REQsent] id 1 len 10
Oct 24 12:56:16.377 UTC: Di100 IPCP:    Address 172.16.1.1 (0x0306AC100101)
Oct 24 12:56:16.377 UTC: Di100 IPCP: O CONFACK [REQsent] id 1 len 10
Oct 24 12:56:16.377 UTC: Di100 IPCP:    Address 172.16.1.1 (0x0306AC100101)
Oct 24 12:56:16.381 UTC: Di100 IPCP: I CONFACK [ACKsent] id 6 len 10
Oct 24 12:56:16.381 UTC: Di100 IPCP:    Address 172.22.53.150 (0x0306AC163596)
Oct 24 12:56:16.381 UTC: Di100 IPCP: State is Open
Oct 24 12:56:16.381 UTC: Di100 DDR: dialer protocol up
Oct 24 12:56:16.381 UTC: Di100 IPCP: Install route to 172.16.1.1

! -- A route to the peer is installed.

Oct 24 12:56:17.361 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, 
changed state to up
Oct 24 12:56:19.113 UTC: Se0:23 DDR: rotor dialout [priority]

! -- Second call is being dialed.

Oct 24 12:56:19.113 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:19.113 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0064
Oct 24 12:56:19.113 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:19.113 UTC:         Channel ID i = 0xA98382
Oct 24 12:56:19.113 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
Oct 24 12:56:19.141 UTC: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x8064
Oct 24 12:56:19.141 UTC:         Channel ID i = 0xA98382
Oct 24 12:56:19.205 UTC: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x8064
Oct 24 12:56:19.217 UTC: %LINK-3-UPDOWN: Interface Serial0:1, 
changed state to up
Oct 24 12:56:19.217 UTC: Se0:1: interface must be fifo queue, force fifo
Oct 24 12:56:19.217 UTC: %DIALER-6-BIND: Interface Se0:1 bound to profile Di100
Oct 24 12:56:19.217 UTC: %ISDN-6-CONNECT: 
Interface Serial0:0 is now connected to 81690 lanai-nas-01
Oct 24 12:56:19.221 UTC: Se0:1 PPP: Treating connection as a callout
Oct 24 12:56:19.221 UTC: Se0:1 PPP: Phase is ESTABLISHING, Active Open 
[0 sess, 1 load]
Oct 24 12:56:19.221 UTC: Se0:1 LCP: O CONFREQ [Closed] id 14 len 33
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    MagicNumber 0xE384B037 
(0x0506E384B037)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:19.221 UTC: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  
callref = 0x0064
Oct 24 12:56:19.241 UTC: Se0:1 LCP: I CONFREQ [REQsent] id 11 len 34
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MagicNumber 0x54F4A700 
(0x050654F4A700)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:19.241 UTC: Se0:1 LCP: O CONFACK [REQsent] id 11 len 34
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MagicNumber 0x54F4A700 
(0x050654F4A700)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:19.245 UTC: Se0:1 LCP: I CONFACK [ACKsent] id 14 len 33
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    MagicNumber 0xE384B037 (0x0506E384B037)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:19.245 UTC: Se0:1 LCP: State is Open
Oct 24 12:56:19.245 UTC: Se0:1 PPP: Phase is AUTHENTICATING, by both 
[0 sess, 1 load]
Oct 24 12:56:19.245 UTC: Se0:1 CHAP: O CHALLENGE id 8 len 32 from "maui-nas-03"
Oct 24 12:56:19.257 UTC: Se0:1 CHAP: I CHALLENGE id 11 len 33 from "lanai-nas-01"
Oct 24 12:56:19.261 UTC: Se0:1 CHAP: O RESPONSE id 11 len 32 from "maui-nas-03"
Oct 24 12:56:19.273 UTC: Se0:1 CHAP: I SUCCESS id 11 len 4
Oct 24 12:56:19.281 UTC: Se0:1 CHAP: I RESPONSE id 8 len 33 from "lanai-nas-01"
Oct 24 12:56:19.281 UTC: Se0:1 CHAP: O SUCCESS id 8 len 4
! -- Authentication is successful.
Oct 24 12:56:19.281 UTC: Se0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:19.281 UTC: Di100 MLP: Added link Se0:1 to bundle lanai-nas-01

! -- The link is added to the Multilink bundle.

Oct 24 12:56:20.281 UTC: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Serial0:1, changed state to up
Oct 24 12:56:25.221 UTC: %ISDN-6-CONNECT: Interface Serial0:1 
is now connected to 81690 lanai-nas-01
Oct 24 12:56:49.117 UTC: Se0:23 DDR: rotor dialout [priority]

! -- Third call is being dialed.

Oct 24 12:56:49.117 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:49.117 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0065
Oct 24 12:56:49.117 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:49.117 UTC:         Channel ID i = 0xA98385
Oct 24 12:56:49.117 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
...
...

! -- Output Omitted.

...
Oct 24 12:56:49.261 UTC: Se0:4 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:49.261 UTC: Di100 MLP: Added link Se0:4 to bundle lanai-nas-01

! -- The 3rd link is added to the bundle.

Oct 24 12:56:50.261 UTC: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Serial0:4, changed state to up
Oct 24 12:56:55.198 UTC: %ISDN-6-CONNECT: Interface Serial0:4 
is now connected to 81690 lanai-nas-01  
...
...
...

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 6435