拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

使用 BRI 与 Dialer Watch 配置 DDR 备份

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文展示使用ISDN基本速率接口(BRI)线路备份一条租用的线路、广域网或者串行连接使用拨号监视功能。关于Dialer Watch的更多信息功能,参考评估备份接口、浮动静态路由和Dialer Watch DDR备份的

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • 有运行Cisco IOSï ¿  ½软件版本12.1(5)T的1个BRI U接口的Cisco 1604。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

此示例使用传统按需拨号路由(DDR),使用dialer map命令BRI连接。您能也使用拨号配置文件而不是传统DDR (拨号图)。关于参考的拨号配置文件的更多信息配置与拨号配置文件的ISDN DDR

配置DDR备份介入二不同步骤:

  1. 配置DDR以传统DDR或拨号配置文件。在实施备份配置前验证您的DDR连接正常工作。这样,您就可以在配置备份之前,验证所使用的拨号方法、点对点协议 (PPP) 协商以及认证是否成功。

  2. 当主链路发生故障时,请配置路由器首次备份DDR连接。此配置使用拨号监视功能触发拨出。

关于必要步骤的更多信息配置备份参考配置和故障排除DDR备份文件

拨号监视(Dialer Watch)操作

通过 Dialer Watch,路由器监视是否存在指定路由,如果该路由不存在,则启动备份链路的拨号。与其他备份方法(如备份接口或浮动静态路由)不同的是,Dialer Watch 不需要相关流量即可触发拨号。下面介绍 Dialer Watch 的执行过程:

  • 在删除受监视路由时,Dialer Watch 会为受监视的任何 IP 地址或网络寻找至少一个有效路由。

    • 如果不存在有效路由,则将主线路视为已关闭且不可使用。

      • Dialer Watch然后发起呼叫,并且路由器连接并且交换路由信息。此时,远程网络的所有流量将使用备份链路。

    • 如果至少一个受监视的已定义 IP 网络存在有效路由,并且该路由指向针对 Dialer Watch 配置的备份接口之外的某个接口,则主链路被视为正常运行,Dialer Watch 不会启动备份链路。

  • 在备份链路运行之后,将在每个空闲超时过期之后再次检查主链路。如果主链路保持关闭,则重置空闲计时器。因为路由器应该周期地证实主链路是否被重建了,请配置拨号空闲超时的一个小值。当主链路被重建,路由协议将更新路由表,并且所有流量应该再次传递主链路。因为流量在备份链路间不再将通过,空闲超时将到期,并且路由器将撤销备份链路。

    注意: 当定义关注数据流时,请否决路由协议流量防止定期hello重置空闲超时。

  • 如果主链路恢复活动,辅助备用链路将被断开。然而禁用计时器可以实现,以便有延迟,在备份链路一次丢弃主链路恢复前。当空闲计时器过期时,此延迟计时器启动,并且主路由处于运行状态。此延迟计时器可确保稳定性,尤其在接口发生抖动或经历频繁的路由改变的情况下。

关于Dialer Watch的更多信息功能,参考评估备份接口、浮动静态路由和Dialer Watch DDR备份的

配置

本部分提供有关如何配置本文档所述功能的信息。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/5600/bri-backup-map-watch.gif

配置

此配置使用一个BRI电路备份串行链路。此配置也使用在两路由器之间的开放最短路径优先(OSPF)路由协议。一旦备用连接激活,您必须保证路由表更新使用新的备份路由。

关于命令规则的更多信息,请参阅Cisco技术提示规则

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1546 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for ppp calls.

enable secret 5 <deleted>!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret.
!--- Shared secret (used for CHAP) must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary link

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 ppp authentication chap
!
interface BRI0
 ip address 172.20.10.2 255.255.255.0

!--- IP address for the BRI interface (backup link)

 encapsulation ppp
 dialer idle-timeout 30

!--- Idle timeout (in seconds) for this backup link.
!--- Dialer watch checks the status of the primary link every time the
!--- idle-timeout expires.

 dialer watch-disable 15

!--- Delays disconnecting the backup interface for 15 seconds after the
!--- primary interface is found to be up, that is 15 seconds after the idle 
!--- timeout expired after the primary link came UP.

 dialer load-threshold 1 outbound

!--- This sets the load level for traffic at which additional connections
!--- will be added to the Multilink PPP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111

!--- Dialer map for the BRI interface of the remote router.

 dialer map ip 172.22.53.0 name maui-nas-05 broadcast 5551111

!--- Map statement for the route/network being watched by the
!--- dialer watch-list command
!--- This address must exactly match the network configured with the
!--- dialer watch-list command.
!--- When the watched route disappears, this dials the specified
!--- phone number.  

 dialer watch-group 8

!--- Enable dialer watch on this backup interface.
!--- Watch the route specified with dialer watch-list 8.

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required. 
!--- In such cases, omit the above two commands.

 ppp authentication chap

!--- Use CHAP authentication.

 ppp multilink

!--- Enable Multilink.

!
router ospf 5
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer watch-list 8 ip 172.22.53.0 255.255.255.0

!--- This defines the route(s) to be watched.
!--- This exact route (including subnet mask) must exist in the 
!--- routing table. Use the dialer watch-group 8 command to apply this
!--- list to the backup interface.

access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any

!--- Mark OSPF as uninteresting.
!--- This will prevent OSPF hellos from keeping the link up.

access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to BRI0 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!         
end

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted> !
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret.
!--- Shared secret(used for CHAP authentication) must be the same on
!--- both sides.

!
ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0

!--- Interface for backup link.

 ip address 172.20.10.1 255.255.255.0
 encapsulation ppp
 dialer map ip 172.20.10.2 name maui-soho-01 broadcast

!--- This is the dialer map with IP address and authenticated username
!--- for the remote destination. The name should match the authentication
!--- username provided by the remote side. The dialer map statement is
!--- used even though this router is not dialing out
!--- (that is, the phone number is not specified).

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required.
!--- In such cases, omit the above two commands.

 ppp authentication chap
 ppp multilink
!

!--- Output removed.

!
interface Serial2/0

!--- Primary link.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 clockrate 64000
 ppp authentication chap
!

!--- Output removed.

!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- This defines all IP traffic as interesting. OSPF does not need 
!--- to be marked uninteresting since this link does not dial out.
!--- Adjust the interesting traffic definition depending on your needs.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

注意: maui-nas-05的配置不包括涉及的任何备份 命令。从maui-nas-05角度看,备份链路是 另一个拨入客户端。这能简单化中心站点的配置 在许多设备建立一条备份链路对同一中央的情况下 站点。在备份方案中,有一端启动拨号只是理想的, 当另一侧只接受呼叫时。

拨号监视(Dialer Watch)命令

下列是可以使用的命令的列表Dialer Watch的。 其中一些命令在以上配置包括,而 其他提供供参考。

  • dialer watch-list组号ip IP地址地址掩码 ::定义了IP 将观看的地址或网络。地址或网络(以正确 掩码)在路由表里配置必须存在。您能也观看 多个路由用dialer watch-list命令。示例显示:

    dialer watch-list 1 ip 10.1.1.0 255.255.255.0
    dialer watch-list 1 ip 10.1.2.0 255.255.255.0
    dialer watch-list 1 ip 10.1.3.0 255.255.255.0       
    
    
  • dialer watch-group 组号 ::在的Enable (event) Dialer Watch 备份接口。 组 号码 使用这里匹配 组编号 拨号程序 定义路由的监控列表命令将观看。拨号程序 与特定组组编号的watch-group命令可以只是 配置在一个接口。这意味着路由器不能使用多个 提供备份的接口为特定路由。然而,一个接口能 有多个拨号watch-group命令,与 不同的组号。所以,一个接口可以用于提供备份 多个路由。

  • dialer watch-disable 秒钟 ::运用禁用延迟时间 接口。在主要接口恢复后,此延迟防止 断开指定的时间段的备份接口。此延迟 计时器开始,当空闲计时器超时时和状态主要的 路由被检查并且被发现。此延迟能保证稳定性, 特别是体验常见的路由的振荡的接口或接口 更改。

  • dialer watch-list组号 delay route-check initial秒钟:这 命令使路由器证实主路由是否是UP在以后 路由器的初始启动完成,并且计时器(以秒钟)超时。 没有此命令,当主路由是时, Dialer Watch只被触发 删除从路由表。如果主链路不能出来在期间 路由器的初始启动,路由从未被添加到路由表 并且不能观看。所以,用此命令, Dialer Watch 在初始期间,拨号备份链路在主链路故障情形下 开始路由器。

验证

有关详细信息,请参阅 使用 show isdn status命令BRI的 排除故障

此部分提供您能使用确认您的信息 配置是工作正常。

确定请显示命令支持 Output Interpreter采取了,允许您查看分析 show命令输出

  • show dialer [interface类型 编号] -显示一般诊断信息为 为DDR配置的接口和显示计时器配置和 在连接时间前的时间。您应验证以下消息:

    • “Dialer state is data link layer up”- 拨号程序正常启动。

      • “Physical layer up” -线路通信协议出来,但是网络 控制协议(NCP)没有。

    • “Dial reason”这显示源地址和目的地址 起动正在拨号的数据包。

  • show isdn status -保证那路由器 用ISDN交换机适当地通信。此命令也显示 激活的呼叫编号您应该验证下列信息:

    • “Layer 1 Status is ACTIVE”,

    • “Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED”

show 输出示例

客户端的路由表, maui-soho-01 (1600),与主要的 链路作用如下所示:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.10.0 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 02:48:10, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 02:48:10, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 02:48:10, Serial0

显示的show ip route输出如上, 显示从使用主链路(序列的对等体的OSPF获知的路由 0)。注意观看的路由(与掩码255.255.255.0)的172.22.53.0 在路由表里存在。必须验证这为了Dialer Watch能作用 正确地。

现在我们减少主链路并且激活备份链路。在 备份链路被激活, OSPF表交换和新的路由 使用备份链路安装。流量在备份链路间当前通过。

此命令示例如下:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, BRI0
C       172.20.10.1/32 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:01:26, BRI0
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:01:27, BRI0
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:01:27, BRI0

以上输出显示路由表更新和所有 流量将使用备份链路(BRI0)

show dialer命令可以用于 验证DDR接口适当地出来。注意BRI接口 拨号,因为路由器检测监视路由丢失。

maui-soho-01#  show dialer

BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
5551111                 10          0    00:01:49       successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect 11 secs
Connected to 5551111 (maui-nas-05)

BRI0:2 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

故障排除

排除拨号程序监视故障

配置并且验证DDR连接以前是工作正常 您配置Dialer Watch。这将帮助您隔离和排除故障DDR 问题,在您解决备份相关问题前。当配置Dialer Watch时 重新开始您使用Cisco IOSï ¿  ½软件版本12.1(7)或以上。 我们当前讨论几个问题和可能的解决方案:

问题:路由器不拨号备份链路,当 主链路断开。

可能的解决方案#1 :请使用显示ip route命令验证您注意的路由存在 路由表。为Dialer Watch配置的路由必须完全地匹配 一在路由表里。这包括验证那网络以及 掩码是相同的。例如,如果路由表显示10.0.0.0/8和 您使用dialer watch-list 1 ip 10.0.0.0 (是10.0.0.0/24)的255.255.255.0,拨号监视功能 请勿能检测10.0.0.0/8不再在路由表里。

可能的解决方案#2 :验证那里是两dialer map 在备份接口的语句。

  • 应该有路由/network的一个映射语句指定由 dialer watch-list命令

  • 应该有远程的IP地址的一个映射语句 路由器接口。

可能的解决方案#3 :配置 dialer watch-list组号延迟 路由检查初期秒钟 .。请参阅 部分Dialer Watch命令为 更多信息。

问题:备份链路建立,但是没有路由 信息在备份链路间传送。

可能的解决方案:验证备份接口IP 网络在路由协议配置里包括

问题:没有撤销备份链路,当 主链路恢复。

注意: 使用Dialer Watch,关注数据流只用于控制 反过来控制间隔的idle-timeout曾经轮询状态 主路由。

可能的解决方案#1 :降低拨号程序 idle-timeout。默认是120秒,但是您可以希望 根据您的需要降低此值。

可能的解决方案#2 :请使用显示 dialer命令验证空闲超时没有重置。

更改您的触发数据流定义(配置与 dialer-list命令)更加限制式。路由 协议流量应该被标记的非触发的。

作为最后一招,您能配置所有IP数据流如非触发的 使用dialer-list 1 protocol ip deny命令。 使用此触发数据流定义,空闲超时不会重置, 并且路由器将检查主链路的状况在指定的 间隔。

可能的解决方案#3 :检查确保, 备份链路比主链路较不理想从的角度 路由协议在使用中。这是,以便,当主链路恢复时, 动态路由协议将更喜欢主要的在备份链路而不是 在两条链路间的负载平衡。疏忽执行此能导致备份链路 不变坚持。请使用show ip route 确定路由器是否使用主要的和备份链路路由 路由器之间的流量。在这种情况下路由器将保持相同 重复的路由;一主要的和一个您能使用的备份链路的 保证其中任一的以下方法备份链路是较少 理想从路由协议的角度: 带宽延迟或者 距离。参考Cisco IOS软件命令 参考欲了解更详细的信息。

对于一般ISDN层1,2和3排除故障参考本文 使用show isdn status BRI故障排除的命令

故障排除命令

确定请显示命令支持 Output Interpreter Tool,允许您查看分析 show命令输出

注意: 在发出调试指令前,请参阅 重要信息 调试指令

  • debug dialer -这用于显示DDR 关于在拨号接口接收的数据包的信息。

  • debug isdn q931 -这表示呼叫建立 并且请切断ISDN网络连接(在路由器之间的层3)和 ISDN交换机。

  • debug ppp协商-这显示 关于PPP流量和交换的信息,当协商PPP组件时 包括链路控制协议(LCP)、验证和NCP。一成功 PPP协商首先将打开LCP状态,然后验证和终于 协商NCP。

  • debug ppp authentication -这显示 PPP认证协议消息,包括挑战握手 认证协议(CHAP)信息包交换和密码验证 协议(PAP)交换。如果观察一失败验证chap 用户名和密码正确地配置。

  • debug ppp error -这显示协议 错误和错误统计信息关联与PPP连接协商和 操作。

调试输出示例

下面debug dialer的输出显示 认可路由丢失的主链路失败和Dialer Watch。路由器中 然后启动备份链路。以后,每次idle-timeout到期, 路由器检查主链路是否发生故障。如果主链路被找到 是UP, Dialer Watch在禁用计时器以后断开备份链路 超时。在调试,请注意在每个消息的时间戳作为他们 在是的多种计时器和空闲超时能提供信息 激活。

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#
03:47:07: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary Link is brought down

03:47:07: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from FULL to DOWN,
 Neighbor Down: Interface down or detached
03:47:07: DDR: Dialer Watch: watch-group = 8

!--- Use dialer watch-group 8. 

03:47:07: DDR:    network 172.22.53.0/255.255.255.0 DOWN,
03:47:07: DDR:    primary DOWN

!--- The primary network is down.

03:47:07: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

!--- Dialing Reason is that the primary route is down.

03:47:07: DDR: Dialer Watch: watch-group = 8, 
03:47:07: DDR:    dialing secondary by dialer map 172.22.53.0 on BR0

!--- Indicates which dialer map statement is used for the dialout.

03:47:07: BR0 DDR: Attempting to dial 5551111
03:47:08: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
03:47:08: BR0:1 DDR: Dialer Watch: resetting call in progress
03:47:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to down
03:47:08: BR0:1 DDR: dialer protocol up
03:47:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state
 to up
03:47:14: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5551111 maui-nas-05

!--- BRI link is connected.

03:47:17: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on BRI0 from LOADING to FULL,
 Loading Done
03:47:38: BR0:1 DDR: idle timeout

!--- Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:47:38: DDR: Dialer Watch: watch-group = 8
03:47:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:47:38: DDR:    primary DOWN

!--- The primary network is still down.

03:48:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:48:08: DDR: Dialer Watch: watch-group = 8
03:48:08: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:48:08: DDR:    primary DOWN

!--- The primary network is still down.

...
...
...
03:50:38: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:50:38: DDR: Dialer Watch: watch-group = 8
03:50:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:50:38: DDR:    primary DOWN

!--- The primary network is still down.

03:50:44: %LINK-3-UPDOWN: Interface Serial0, changed state to up

!--- Primary link is re-established.

03:50:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to up
03:50:54: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from LOADING
 to FULL, Loading Done
03:51:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.


!--- The router will check to see if the primary link has come up.

03:51:08: DDR: Dialer Watch: watch-group = 8
03:51:08: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists. 

03:51:08: DDR:    primary UP

!--- The primary network is UP. Dialer watch will initiate a disconnect of


!--- the backup link.

03:51:08: BR0:1 DDR: starting watch disable timer

!--- Delays disconnecting the backup interface after the primary interface recovers.
!--- This timer is 15 seconds as configured with the dialer watch-disable 15 command

03:51:23: BR0:1 DDR: watch disable timeout

!--- 15 second disconnect delay expires. The link will be brought down.

03:51:23: BR0:1 DDR: disconnecting call

!--- Backup link is disconnected.

03:51:23: BR0:1 DDR: Dialer Watch: resetting call in progress
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP

!--- The primary network is UP.

03:51:23: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 5551111
 maui-nas-05, call lasted 255 seconds
03:51:23: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
03:51:23: BR0:1 DDR: disconnecting call
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP
03:51:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
maui-soho-01#


相关信息


Document ID: 5600