思科接口和模块 : 思科内容交换模块

在内容交换模块上配置安全(路由器)模式

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

基于第4到第7层信息,内容交换模块(CSM)在网络用户和服务器群之间提供了高性能连接。您能够用单个服务器实例(虚拟服务器)表示真实服务器组(服务器群),通过选择服务器负载均衡法来平衡通往服务器群的数据流,同时限制进入单个服务器(粘性连接)和服务器群(策略)的数据流。此配置示例描述了如何在 Catalyst 6000 系列 CSM 上配置服务器负载均衡 (SLB)。

您不能运行Cisco IOS�在交换机的SLB软件和CSM一样。在进行任何设置之前,您必须通过发出 ip slb mode [csm|rp] 命令来配置 CSM 模式。在 ip slb mode 命令 中,默认使用 rp 参数。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • 适用于 Supervisor Engine 1 with MSFC1 的 Catalyst 6000 系列 Supervisor IOS 12.1(8)EX 版本 (c6sup11-jsv-mz.121-8.EX)

  • Catalyst 6000 系列 CSM 软件 2.1(0) 版本 (c6slb-apc.2-1-1.bin)

CSM 在 Cisco IOS 12.1(6)E 或更高版本上运行。如果您使用的是 Supervisor Engine 2,则必须使用 Cisco IOS 12.1(8a)E 或更高版本。

操作模式

通过 CSM 进行的客户端与服务器连接可使用第 2 层或第 3 层交换。客户端连接至客户端 VLAN,服务器连接至服务器端 VLAN。服务器与客户端可存在于不同的子网上。服务器还可以距离一跳以上的位置,并能通过路由器连接到服务器端VLAN上。在这种情况下,服务器的默认网关和服务器到CSM服务器端VLAN网络的路由必须将来自服务器的所有负载平衡数据流导向整个CSM,或者必须在CSM中配置服务器群客户端NAT,供导向服务器群中的服务器数据流使用。客户端发送请求对VIP地址, ï ¿  ½,并且CSM寄请求给能满足请求的服务器。服务器将回应转发给CSM,CSM再转发给客户端。

当客户端和服务器端VLAN处于不同子网时,您可以在安全(路由器)模式配置CSM。此配置示例着重于安全(路由器)模式配置。当客户端和服务器端VLAN处于相同子网时,您可以在单个子网(网桥)模式中配置CSM进行操作。有关更多信息,请参阅下方的配置示例

网络图

客户端和服务器端 VLAN 在安全(路由器)模式下位于不同的子网上。图表显示了如何设置安全(路由器)模式配置。

csm_router.gif

配置

要为安全(多子网)模式配置 CSM,请完成以下步骤:

  1. 选择 CSM 模式。

    cat(config)# ip slb mode csm
    
  2. 在数据库中创建客户端和服务器 VLAN。退出 VLAN 数据库模式时,将应用配置更改。

    cat# vlan database 
    cat(vlan)# vlan 100 
    VLAN 100 added: Name: VLAN0100 
    cat(vlan)# vlan 200 
    VLAN 200 added: Name: VLAN0200 
    cat(vlan)# exit 
    APPLY completed. 
    Exiting....
  3. 配置将客户端(上行链路)连接至对应 VLAN 的物理接口。

    cat(config)# inter fastEthernet 2/1 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 100 
    cat(config-if)# no shut
    
  4. 配置将服务器连接至对应 VLAN 的物理接口。

    cat(config)# inter fastEthernet 2/3 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown 
    cat(config)# inter fastEthernet 2/4 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown
    
  5. 创建客户端 VLAN 和网关。

    cat(config)# ip slb vlan 100 client 
    cat(config-slb-vlan-client)# ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)# gateway 172.17.63.210
    
  6. 创建服务器端 VLAN。

    cat(config)# ip slb vlan 200 server 
    cat(config-slb-vlan-server)# ip address 10.1.1.251 255.255.255.0 
    cat(config-slb-vlan-server)# alias 10.1.1.250 255.255.255.0
    
  7. 创建服务器群。

    cat(config)# ip slb serverfarm WWWFARM 
    cat(config-slb-sfarm)# real 10.1.1.3 
    cat(config-slb-real)# inservice 
    cat(config-slb-real)# real 10.1.1.5 
    cat(config-slb-real)# inservice
    
  8. 创建虚拟服务器并关联服务器群。

    cat(config)# ip slb vserver SERVER 
    cat(config-slb-vserver)# virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)# serverfarm WWWFARM 
    cat(config-slb-vserver)# inservice
    

下列是使用Cisco Catalyst 6500和CSM的服务器负载均衡的示例配置。

CSM (WS-X6066-SLB-APC) 运行配置
Current configuration : 3791 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8.EX.bin 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 


!--- SLB mode. 

ip slb mode csm 
! 


!--- Client side VLAN configuration.� 
!--- Important: Gateway address pointing to interface VLAN 100.
 
ip slb vlan 100 client 
�ip address 172.17.63.217 255.255.255.192 
�gateway 172.17.63.210 
! 


!--- Server side VLAN configuration.�
 
ip slb vlan 200 server 
�ip address 10.1.1.251 255.255.255.0 
�alias 10.1.1.250 255.255.255.0 
! 


!--- Serverfarm configuration.
 
ip slb serverfarm WWWFARM 
�nat server� 
�no nat client 
real 10.1.1.3 
� inservice 
�real 10.1.1.5 
� inservice 
! 


!--- Vserver configuration.�
 
ip slb vserver SERVER 
�virtual 172.17.63.241 tcp www 
�serverfarm WWWFARM 
�inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 


!--- Client (uplink) connected to FastEthernet 2/1. 

interface FastEthernet2/1 
�no ip address 
�switchport 
�switchport access vlan 100 
�switchport mode access 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 


!--- Servers connected to FastEthernet 2/3 and 2/4.
� 
interface FastEthernet2/3 
�no ip address 
�switchport 
�switchport access vlan 200 
�switchport mode access 
! 
interface FastEthernet2/4 
�no ip address 
�switchport 
�switchport access vlan 200 
�switchport mode access ... 
interface FastEthernet2/48 
�no ip address 
�shutdown 
! 
interface Vlan1 
�no ip address 
�shutdown 
! 
interface Vlan100 
�ip address 172.17.63.210 255.255.255.192 
! 
ip default-gateway 172.17.63.193 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
�login 
! 
end

显示命令

注意: 命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

show ip slb status 命令

show ip slb status 命令显示 SLB 模块的状态。模块必须处于在线状态。

cat6#show ip slb status�
SLB Module is online in slot 3.�
Configuration Download state: COMPLETE, SUCCESS

show ip slb vserver 命令

show ip slb vserver 命令显示虚拟服务器信息。您还可以看到虚拟服务器的状态和连接数量:

cat6#show ip slb vserver
slb vserver�� prot��� virtual������������� vlan�� state�������� conns����������
---------------------------------------------------------------------------
SERVER������� TCP���� 172.17.63.241/32:80� ALL��� OPERATIONAL�� 0

show ip slb reals 命令

show ip slb reals命令显示来自每个真实服务器的信息,例如每个服务器中驻留的小型服务器站,服务器状态、阈值和连接。

cat6#show ip slb reals
real����������������� server farm����� weight� state��������� conns
-------------------------------------------------------------------
10.1.1.5������������� WWWFARM��������� 8������ OPERATIONAL��� 0��������
10.1.1.3������������� WWWFARM��������� 8������ OPERATIONAL��� 0

show ip slb serverfarms 命令

show ip slb serverfarms 命令显示服务器群信息。此指令显示为负载均衡使用的预报器。此示例使用默认设置,即“循环法”。

cat6#show ip slb serverfarm
server farm��� predictor��� nat�� reals�� redirect� bind id
-------------------------------------------------------------
WWWFARM������� RoundRobin�� S���� 2������ 0�������� 0

show ip slb vlan 命令

show ip slb vlan 命令显示客户端和服务器的 VLAN 信息。

cat6# show ip slb vlan
vlan�� IP address������ IP mask����������� type��
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192��� CLIENT
200��� 10.1.1.251������ 255.255.255.0����� SERVER

故障排除

通过使用ping slb命令您只能在Catalyst 6500上Ping真实服务器 ,如下所示。

cat6#ping slb 10.1.1.3�
IP address������ Reachable�
--------------------------�
10.1.1.3�������� Yes

相关信息


Document ID: 5448