IP : 串行隧道 (STUN)

BSC 和 BSTUN 指南

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文设计帮助您配置和使用二进制同步通信(BSC)数据链接协议和块串行隧道(BSTUN)在Cisco路由器。它也帮助您排除故障也许发生的问题。

先决条件

要求

本文档的读者应掌握以下这些主题的相关知识:

  • 二进制同步通信(BSC)概念。

  • 基本数据处理原理一般了解。

使用的组件

本文档中的信息根据与IBM特性组的Cisco IOS软件。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

系统概述

图1和2显示如何可以重新配置两个设备之间的一条现有BSC链路使用Cisco路由器。这提供同一个逻辑链接,不用对现有BSC设备的任何更改。

图1 -存在BSC设置

bsc_guide_1.gif

图2 - BSC设置Cisco路由器

bsc_guide_2.gif

Cisco路由器传输所有BSC块在两个设备之间,通过使用块串行隧道(BSTUN)封装。对于从线路、地址和控制字节接收的每BSC块被添加创建BSTUN帧,然后BSTUN使用传送到正确目的地路由器。

BSC/BSTUN配置

在一个干净的路由器上,请发出这些命令,按他们是列出的顺序。

全局命令

[no] bstun peer-name ip-address

IP地址定义了此BSTUN对等体为其他BSTUN对等体所知使用TCP传输的地址。

注意: 在Cisco IOS软件版本早于版本11.3必须配置此命令,或者必须配置,如果TCP/IP地址用于路由语句。

[no] bstun protocol-group group-number {bsc|bsc-local-ack|adplex|adt-poll|adt-poll-select|adt-vari-poll|diebold|异步通用|mdi}

这是global命令连结组编号与协议名称。组号是在1和255之间的一个十进制整数。bsc|bsc-local-ack|adplex是预定义的BSTUN协议关键字。欲知更多信息,参考定义配置的串行隧道和块串行隧道协议组

组类型的选择是否是重要确定使用passthru或本地确认(local-ack)。

注意: 必须总是配置此命令。

接口命令

encapsulation bstun

这interface命令配置在一特定的serial interfaces的BSTUN功能。在任何另外BSTUN或BSC命令为此接口前,配置在接口必须配置此命令。

[no] bstun group group-number

这interface命令定义了此接口属于的BSTUN组。在一个以前定义BSTUN组中必须安置在路由器的每个支持BSTUN的接口。数据包只移动在同一组中的支持BSTUN的接口之间。组号是在1和255之间的一个十进制整数。

组编号已经确定此接口是否运行local-ack或passthru。

[no] bsc mode

这是某些的列表主要选项。对于全面列表,参考在配置串行隧道和块串行隧道的在串行接口上配置Bisync选项

帧没有接收或发送,直到模式为这些设置之一配置:

  • 争用—这设置连接对serial interfaces是为点对点BSC站点的BSC链路。仅仅3780,和在passthru模式。

  • 争用虚拟地址—在Cisco IOS软件版本11.3的第一联机。用于与拨号争用使多个远程设备使用同一个接口在主机端路由器。

  • 拨号争用超时—在Cisco IOS软件版本11.3的第一联机。使用在主机端路由器争用。使多个远程设备在同一个物理接口多元化。

  • 主要的—定义了路由器作为BSC链路的主要的末端,并且连接的设备或设备是BSC分支站。

  • 第二—定义了路由器作为BSC链路的附属端,并且附加的远程设备是BSC控制站(例如前端处理器[FEP]或其他主机设备)。

如果此命令然后没有配置在接口的线路通信协议将发生故障,并且接口不会运行。

TCP路由配置

在此配置中,传输系统是TCP/IP。这能运行TCP/IP能运行的其中任一物理媒介。

[no] bstun route all tcp ip-address

[no] bstun route address address-number tcp ip-address

IP地址是相同的象在伙伴路由器的对等名称指定的IP地址。

串行路由配置

在此配置中,通道使用思科所有权传输。它比TCP/IP快速,但是在仅serial interfaces去。

[no] bstun route all interface serial interface-number

[no] bstun route address address-number interface serial interface-number

直接帧中继直通配置

在此配置中,通道使用串行封装专有形式在帧中继的,工作一样快速象串行路由。

[no] bstun route address address-number interface serial interface-number dlci dlci-number

发出此on命令帧中继接口:

[no] frame-relay map dlci-number bstun

直接帧中继local-ack配置

此配置使用得逻辑链路控制,类型2 (LLC2)在帧中继封装,给本地确认和端到端会话控制。必须包括lsap关键字;否则,封装将去作为passthru。

[no] bstun route address address-number interface serial interface-number dlci dlci-number lsap lsap

发出此on命令帧中继接口:

[no] frame-relay map dlci-number llc2

注意: 欲知更多信息,参考指定帧如何配置转发串行隧道和块串行隧道

Passthru配置

为什么Passthru ?

Passthru是基本隧道模式。传送在设备之间的每帧被通过,不可更改,通过BSTUN通道。序号和设备地址被添加,保证延迟通过网络不影响协议的运行。延迟投票或传输结束(EOT)信号到达可能极大打乱现有的会话。

什么时候使用Passthru

应该在这些情形中使用Passthru :

  • 转接的数据没有发送的一明确确认帧验证数据完整性。

  • 协议不是纯3270。

  • 用户想要端到端设备连通性,并且网络延迟小。

local-ack配置

为什么local-ack ?

local-ack取消发送在通道间的所有控制帧的开销。当主机发送第一投票到控制单元时,特殊控制帧在通道间发送开始该设备地址远程轮询。一旦远程设备表明是UP,控制帧发送到主机路由器告诉它响应到投票。当远程设备断开时,征兆在通道间发送通知主机路由器不再响应到投票。

什么时候使用local-ack

local-ack能在这些情形中使用:

  • 3270双同步是在使用中的。

  • 网络延迟导致双同步会话超时。

  • 在广域网间的超额流量是问题。

local-ack选项

[no] bsc pause time

此命令指定在一个轮询循环开始和下之间的时间。默认值是30 (即30十日或3秒)。

当只有在双同步接口时的一两个控制器它是一个好想法配置此命令。它有效减速?并且定量更多CPU周期到连接的设备。

[no] bsc poll-timeout time

此命令设置投票的超时或选择顺序,在一秒钟的十分之一单元;默认值是30 (即30十日或者3秒)。

最小规模的值取决于连接的设备的速度,并且是更多利益在主机末端。如果驱动路由器的主机使其超时降低到可能最小的值,将有性能改进,当一些设备失败。

[no] bsc retries retry-number

在设备假定有死者前,此命令设置重试次数数量尝试。范围是1到100;默认是5重试次数。

[no] bsc servlim value

此命令指定servlim (激活与非激活终端站轮询比率)值。范围是1到50;默认是3。

[no] bsc spec-poll

此命令告诉主机处理特定轮询作为一般轮询。当您用TANDEM主机时,工作请使用此命令。

一个更多信息,参考在配置串行隧道和块串行隧道的在串行接口上配置Bisync选项

争用配置

为什么争用?

争用是双同步3780变量。没有控制单元地址。设备是连接的点对点。通常,远程设备拨号到中央位置并且假设,其它设备不存在。

什么时候使用争用

请使用争用,只有当您使用远程工件项(RJE)时, 3780和2780份协议。一旦识别争用,请保证两端配置使用争用。

如果是不确定的,则请实行这些步骤:

  1. 配置主要的bsc

  2. 打开debug bsc packet

  3. 做连接的设备开始轮询。

1字节第2的消息指示争用。在第2前的任何字节不是3780。

优先级

与在广域网骨干网去的其他流量比较,双同步流量是非常小和容易地陷入沼泽由其他流量。在双同步的帧丢失要求一个长恢复间隔,是容易明显的对终端设备。要最小化此问题,推荐双同步流量的优先级。您能指定优先级流量以BSTUN优先级或与自定义排列。

  • 优先级队列是在接口输出队列的帧根据多种特性优先安排,例如数据包大小或接口类型的路由功能。

    优先级输出队列允许网络管理员定义流量四优先级? ? ?高、正常、介质和低? ? ?在指定接口。当流量进入路由器,分配到四个输出队列之一。在高优先级队列的数据包首先传送。当该队列倒空时,在下高优先级队列的流量传送,等等。此机制保证,在拥塞时,最高优先级的数据不由更低优先级数据流延迟。然而,如果流量发送对指定接口超出带宽该接口,更低优先级数据流能体验明显的延迟。

    例如,如果在广域网串行链路比IPX做IP一高优先级,在TCP/IP的BSC流量将利用事实IP转接在更加高优先级。

  • 自定义排列允许客户保留百分比指定的协议的带宽。客户能定义正常数据的十个输出队列和系统消息的一个另外的队列,例如LAN保活信息(路由信息包没有分配到系统队列)。Cisco路由器顺序地服务每个队列:在他们继续前进向下一个前,他们传送在每个队列的一个可配置数据流的百分比。当您使用自定义排列时,您能保证关键任务数据总是分配带宽的某一百分比,虽然其他流量的可预测吞吐量保证。

    要提供此功能, Cisco路由器确定应该从每个队列传送多少个字节,根据接口速度和配置的百分比。当从一个给的队列的计算的字节数传送时,路由器完成当前数据包的发射并且继续前进向下个队列。最终,每个队列在循环方式被服务。

参考配置串行隧道和块串行隧道,并且参考决定使用的哪个排队策略拥塞管理概述

[no] priority-list list-number protocol bstun queue [gt|Lt packetsize] [address bstun-group bsc-addr]

发出priority-list protocol bstun global configuration命令设定根据BSTUN报头的BSTUN排队优先级。发出命令复原的no表示对正常优先权。

custom-queue-list [no] [list]

列表是代表自定义队列列表的编号的整数(1 - 16)。

Keepalive配置

[no] bstun remote-peer-keepalive interval

此命令启用BSTUN对等体Keepalive。这发送请求给对等体,每当对等体为长比间隔时间时间期是静音模式。所有帧重置时钟,不仅Keepalive。默认是30秒。

[no] bstun keepalive-count number

当Keepalive此编号连续时未命中, BSTUN连接减少。默认是3。

什么时候使用Keepalive

当您运作local-ack和TCP/IP时, Keepalive是有用的防止受到通道中断。只有当信号从远程时,接收通道建立下来接口。如果通道发生故障,信号没有接收。

在passthru中,因为端到端连通性要求,这不是需要的。

debug 命令

[no] debug bstun event group

此命令允许您调试BSTUN连接和状态。当启用,它引起显示连接建立和总体状态消息的显示。

[no] debug bstun packet group group buffer-size displayed-bytes-size

此命令允许您调试游遍BSTUN链路的数据包。

[no] debug bsc packet group group buffer-size displayed-byte-size

此命令允许您调试游遍BSC功能的帧。

[no] debug bsc packet

此命令允许您调试游遍BSC功能的帧。它跟踪配置与BSTUN组组编号的所有接口。

[no] debug bsc event group

此命令允许您调试在BSC功能发生的事件。如果组编号省略,则跟踪配置与BSTUN组组编号的所有接口。

显示命令

show bstun

此命令显示BSTUN当前状态。

This peer: 10.10.20.108
 *Serial5 -- interface for ATM: R1710V421 (group 3 [bsc])
route  transport  address      state       rx_pkts   tx_pkts     drops
C2    TCP         10.10.10.107 open        655630    651332      0
 Serial6 -- interface for SEC: MST012  (group 2 [bsc])
route  transport  address      state       rx_pkts   tx_pkts   drops
C2     TCP        10.10.10.107 open        649385    644001      0

检查这些问题:

  • 状态关闭

  • 丢包。

  • 低数据包计数。

    注意: 低数据包计数总是不指示问题。当您运作local-ack时,计数仅包括数据帧,小于帧实际数量显着从主机发送。

show bsc

此命令显示BSC当前状态。

在Passthru中

BSC pass-through on Serial5:
Output queue depth: 0.
HDX enforcement state: IDLE.
Frame sequencing state: SEC.
Tx-Active: Idle. Rx-Active: False.
Tx Counts: 670239 frames(total). 670239 frames(data). 9288816 bytes.
Rx Counts: 651332 frames(total). 651332 frames(data). 651332 bytes.

检查这些问题:

  • IDLE之外,如果HDX实施状态陷在状态,则可能有一问题用连接的设备或用此路由器。这通常表明设备不响应。打开bsc event debug。如果看到从远程消息的很多无响应,首先请检查设备被激活,则检查双工。如果没有消息和没有最后的恢复,则传输完成事件丢失,并且的bug可能潜在是灾难的找到了。

  • 成帧顺序状态告诉您检查的哪个有限状态机(FSM)。

  • 如果rx-active是卡住在,这表明坏的事用硬件发生。发出no shut然后重置接口的关闭。如果这不工作,请重新加载路由器。

在local-ack

BSC local-ack on Serial0:
Secondary state is CU_Idle.
Control units on this interface:

      Poll address: 40. Select address: 60 *CURRENT-CU*
      Current active device address is: 40.
      State is Active.
      Tx Counts: 87228 frames(total). 11 frames(data). 87353 bytes.
      Rx Counts: 87271 frames(total). 5 frames(data). 436312 bytes.

Total Tx Counts: 87228 frames(total). 11 frames(data). 87353 bytes.
Total Rx Counts: 174516 frames(total). 5 frames(data). 523557 bytes.

如果状态陷在TCU_Down,这表明某事强制该接口坚持下来。检查时钟频率和BSC模式并且保证什么都不下降管理性。偶然地, no shut命令跟随的关闭命令再启动接口。

一般

  • 极大输出队列深度比1指示在接口的积压。检查半双工适当地配置。

  • 在同步符寻找外面模式含义二者之一接口发生故障或接收方禁用。适用于rx-active也的那应用此处。

show interface序列号

此命令是有用的发现关联与该serial interfaces的计数器。

Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

注意: 任何错误平均问题。

检查这些问题:

  • 中止指示一坏发射。

  • 忽略的帧是违犯双同步协议的帧。

  • 巨人指示二者之一MTU太小或双同步顺序是坏的。

  • 超出指示CPU资源短缺。

  • CRC指示在线路的损坏(喧闹或其他)。

如果使用DTE电缆,并且线路似乎频繁地断开或者传送失败,但是接收工作,则您也许需要发出ignore-dcd命令。这可以用协议分析程序验证。当DCE传送时,被传送的数据检测(DCD)被上升。当它完成时, DCD如此降低不能的路由器应答。

  • 硬件是CD2430指示Cirrus芯片组。

  • 硬件是HD64570指示日立芯片组。

日立使用字符中断和软件构件的帧。它不很好处理DCD。Cirrus使用帧中断。帧在ucode被建立。它有与DCD的选项播放。是重要,当您调试时,您认识接口类型,因为有他们之间的一些差异。

线路通信协议必须是UP。如果线路通信协议不上升,则请检查BSC模式配置。

Serial5 is up, line protocol is up
  Hardware is CD2430 in sync mode
 MTU 265 bytes, BW 4 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation BSTUN, loopback not set
    Half-duplex enabled.
      cts-delay 0 millisec
      dcd-txstart-delay 100 millisec
      dcd-drop-delay 100 millisec
      transmit-delay 0 millisec
      Errors - 0 half duplex violation
   Last input 10:27:12, output 1:07:12, output hang never
   Last clearing of "show interface" counters 4d11
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
      3223346 packets input, 3223356 bytes, 0 no buffer
      Received 0 broadcasts, 0 runts, 0 giants
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      3242346 packets output, 45259079 bytes, 0 underruns
      0 output errors, 0 collisions, 8 interface resets, 0 restarts
      0 output buffer failures, 0 output buffers swapped out
      4 carrier transitions
      DCD=up DSR=up DTR=up RTS=down CTS=down

如何排除 IBM Bisync 的故障

如何使用直通 FSM

保证您运行passthru。您需要查找正确有限状态机(FSM)跟随。

查看事件调试消息。有两经历的FSMs。HDX-FSM是半双工实施FSM。它被驱动不管线路是否是配置的全双工或半双工。它设法保证路由器的传输队列被旧有数据不变得落后。FS-FSM保证延迟帧通过网络不毁坏建立的会话。

如果争用配置,要确定查找,在哪里请去直通争用FSM。否则,请查看它在空闲状态以后进的状态。如果看到SEC,请查看附属成帧顺序FSM。如果看到PRI,请查看主要的成帧顺序FSM。

BSC: Serial6: HDX-FSM event: RXV old_state: PND_RCV. new_state: IDLE.
BSC: Serial6: FS-FSM event: SDI EOT old_state: SEC. new_state: IDLE.
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpOTH old_state: PND_COMP. new_state: PND_RCV.
BSC: Serial6: SDI: Data (1 bytes): 37
BSC: Serial6: HDX-FSM event: RXV old_state: PND_RCV. new_state: IDLE.

当您查看表时,您看到在左侧和您的输入发现在上面的状态。在列的每个条目是表{下状态操作}操作是执行的第一,然后转换发生。

如何使用local-ack FSM

保证您运作local-ack。show bsc命令分辨您接口是否是轮询者或pollee。从此,请使用适当的LACK FSM。

常见问题

将 3780 数据传送到 3270 配置或反之

警告 警告: 请勿执行此。这不可靠运作。

配置到坏对等体的路由

您配置一切,并且什么都不发生。您什么都不打开在远程路由器的debug bsc packet并且看见。您什么都然后不打开debug bstun packet和仍然看见。在此阶段,请打开debug bstun event;您什么都很可能仍然不看见。去上一步主机末端路由器并且打开debug bstun event。您应该当前看到指示连接不好的几个消息。

配置坏组号

当通道的任一个末端配置与一个不同的组编号时,这被观察。数据溢出在错误接口外面或被丢弃在BSTUN级别。

local-ack和passthru组编号不混合。保证协议组定义在间整个网络是一致。也运行争用的设备(3780)需要在从3270的不同的组编号。

TANDEM主机

21:55:18: BSC: Serial4: SDI-rx: Data (5 bytes): C7C740402D
21:55:19: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:19: BSC: Serial5: SDI-tx: Data (5 bytes): C2C240402D
21:55:21: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:21: BSC: Serial4: SDI-rx: Data (5 bytes): C7C740402D
21:55:22: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:22: BSC: Serial5: SDI-tx: Data (5 bytes): 404040402D
21:55:24: BSC: Serial4: SDI-rx: Data (1 bytes): 37

纵排不服从严格3270个规则。他们进行所有他们的与特定轮询的?,引起默认LACK FSM的一问题。要上纵排适当地工作,请配置在BSC辅助接口的bsc spec-poll

全双工和半双工的区别

混淆全双工和半双工是容易的。

  • 全双工能同时传送数据在发送站和接收站之间。

  • 半双工只能每次传送在一个方向的数据,在发送站和接收站之间。

欲了解更详细的信息请参阅关于show bsc命令的部分。

如果有协议分析程序或一中断盒联机,请连接您的在系统的分析器,不用路由器。

  • 如果RTS或CTS更改发信号,则您有半双工;它全双工。

  • 如果DCD似乎更改很多,并且线路上升和下降或坚持下来,您也许有交换DCD。

注意: 主路由器可能全双工,当远程路由器半双工时,反之亦然。这些是分离实际行,并且从接口的控制信号没有在通道间传输。

BSC与BSTUN示例

无设备响应示例

这是两个接口示例在一个附属路由器的:一local-ack和另一个passthru。都不接收从远程的一答复。当您看到投票进入附属路由器,您需要确定什么发生在远程终端。

21:55:18: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:19: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:19: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:21: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:21: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:22: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:22: BSC: Serial5: SDI-tx: Data (5 bytes): 40407F7F2D
21:55:24: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:24: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:25: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:25: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:27: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:27: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:28: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:28: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:30: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:30: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D

当您查看在passthru盒时的远程终端,您能看到帧来通过通道,但是连接的设备是平静的。

BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037

其次,请确定连接的设备是否是停止的或路由器是否有一个坏发射器:打开事件调试。

BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpOTH old_state: PND_COMP. new_state: PND_RCV.
BSC: Serial6: Response not received from remote
BSC: Serial6: HDX-FSM event: T/O old_state: PND_RCV. new_state: IDLE.
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: FS-FSM event: NDI EOT old_state: SEC. new_state: IDLE.
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpEOT old_state: PND_COMP. new_state: IDLE.
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)

从trace,请跟随HDX-FSM。如果它在PND_COMP状态被滞留,发射器失败。它很可能是实际情形没有供应时钟。正如你在上一个示例输出看到, PND_RCV状态到达,并且您看到从远程没接收的答复,指向二者之一一坏接收或一个非激活设备。

网络延时示例

这是网络延迟示例在虚拟多点网络环境的:

BSC: Serial0: NDI: Data (5 bytes): C703001061
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): 404040402D
BSC: Serial0: NDI: Data (4 bytes): 40C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37

!--- Output suppressed.

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C4C4C4C42D

因为C4未应答及时,有问题在这里:

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C5C5C5C52D
BSC: Serial0: NDI: Data (4 bytes): C5C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C7C7C7C72D

再次,这丢失。查找进一步,并且您看到问题变为一少许更坏:

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): 404040402D
BSC: Serial0: NDI: Data (4 bytes): 40C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C1C1C1C12D

C7的EOT再突然出现。丢弃该EOT从此恢复;下一帧是C1的EOT。

在本例中,从网络的帧到达后和失序。这导致很大数量的未应答投票在主机。解决方案,在这种情况下,将配置local-ack。

BSC 与 BSTUN 配置示例

网络图

此图表是运行3270个和3780个双同步终端站点的配置示例。

/image/gif/paws/5316/bsc_guide_3.gif

配置

该图表使用这些配置:

中央印制厂
hostname central
!
bstun peer-name 10.10.10.107
bstun protocol-group 1 bsc
bstun protocol-group 2 bsc
bstun protocol-group 44 bsc-local-ack
!
interface Serial0
 description EFTPOS host
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 clockrate 19200
 bstun group 1
 bsc contention 1
 bstun route all tcp 10.10.10.108
!
interface Serial2
 description WAN-ppp backbone
 ip address 10.10.10.107 255.255.255.0
 encapsulation ppp
 clockrate 2000000
!
interface Serial3
 description WAN-hdlc
 ip address 10.10.20.107 255.255.255.0
 bandwidth 2000
 no keepalive
 clockrate 2000000
!
interface Serial4
 description ATM Host
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 bstun group 44
 bsc secondary
 bstun route all tcp 10.10.20.108
!
interface Serial5
 description ATM host
 no ip address
 encapsulation bstun
 no keepalive
 bstun group 2
 bsc secondary
 bstun route address C2 tcp 10.10.20.108
!
end

Remote1
hostname remote1
!
bstun peer-name 10.10.10.108
bstun protocol-group 1 bsc
bstun protocol-group 44 bsc-local-ack
!
interface Serial0
 description EFTPOS 1
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 clockrate 19200
 bstun group 1
 bsc char-set ebcdic
 bsc contention
 bstun route all tcp 10.10.10.107
!
interface Serial1
 description ATM 3
 no ip address
 encapsulation bstun
 no keepalive
 bstun group 44
 bsc char-set ebcdic
 bsc primary
 bstun route address 40 tcp 10.10.10.107
!
interface Serial3
 description WAN -ppp
 ip address 10.10.10.108 255.255.255.0
 encapsulation ppp
!
end

Remote2
hostname remote2
!
!
bstun peer-name 10.10.20.108
bstun protocol-group 2 bsc
bstun protocol-group 44 bsc-local-ack
bstun protocol-group 10 bsc-local-ack
!
interface Serial0
 description WAN-hdlc
 ip address 10.10.20.108 255.255.255.0
 bandwidth 2000
 no keepalive
!
interface Serial5
 description ATM 1
 mtu 265
 encapsulation bstun
 clockrate 19200
 bstun group 44
 bsc char-set ebcdic
 bsc primary
 bstun route address C2 tcp 10.10.10.107
!
interface Serial6
 description interface for ATM 2
 mtu 265
 encapsulation bstun
 clockrate 19200
 bstun group 2
 bsc char-set ebcdic
 bsc primary
 bstun route address C2 tcp 10.10.10.107
!
ip route 10.10.10.0 255.255.255.0 10.10.20.107
!
end

参考

一般信息-二进制同步通信, IBM系统参考库, GA27-3004-2。

IBM 3274 :章节4 :遥控操作BSC。

IBM 3275 :章节9。

BSTUN On命令Cisco Documentation CD-ROM (线上可以得到在串行隧道和块串行隧道命令)。


相关信息


Document ID: 5316