????????? : 思科内容交换模块

在 CSM 上配置单子网(网桥)模式

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

在根据Layer4和服务器站之间的内容交换模块(CSM)提供高性能服务器负载均衡(SLB)的网络设备通过7个信息包。代表的服务器站,当虚拟服务器能改进服务的可扩展性和可用性您的网络的。您能添加新建的服务器和在任何时间删除失败或现有的服务器,无需影响虚拟服务器的可用性。

客户端连接对CSM通过提供虚拟服务器的Virtual IP (VIP)地址。当客户端首次对虚拟服务器时的连接, CSM选择分配到服务器站)的一个真实服务器(View (物理设备根据已配置的负载均衡算法和策略的连接的(访问规则)。策略在哪里管理流量通过定义发送客户端申请信息。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

此配置可以与支持CSM的所有软件和硬件版本一起使用。

背景理论

客户端和服务器通过CSM在一个特定VLAN配置里通信使用Layer2或分层堆积3�技术。客户端连接到客户端VLAN和服务器连接对服务器端VLAN。服务器与客户端可存在于不同的子网上。服务器能也查找超过离开一的跳和连接到服务器端的VLAN通过路由器。客户端发送请求到其中一个模块的VIP地址。CSM寄此请求给能回答请求的服务器。服务器然后准发对CSM的答复,并且CSM准发对客户端的答复。

当客户端和服务器端的VLAN是在相同子网时,您能配置在单个子网(网桥)模式的CSM。本文描述单个子网(网桥)模式。

当客户端和服务器端的VLAN是在不同的子网时,您在一个安全(路由器)模式能配置CSM经营。欲知更多信息,参考配置在CSM的安全(路由器)模式

配置

网络图

以下图表说明不同的VLAN和不同的子网。

CSMbridge.gif

配置

完成这些步骤:

  1. 创建MSFC的客户端和服务器VLAN。

    cat#conf t 
    cat(config)#vlan 100 
    cat(config-vlan)#exit 
    cat(config)#vlan 200 
    cat(config-vlan)#
  2. 配置联络客户端的物理接口(上行链路)对相应的VLAN。

    cat(config)#inter fastEthernet 2/1 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 100 
    cat(config-if)#no shut
    
  3. 配置连接服务器对相应的VLAN的物理接口。

    cat(config)#inter fastEthernet 2/3 
    cat(config-if)#switchport
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown 
    cat(config)#inter fastEthernet 2/4 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown
    
  4. 配置CSM。

    cat(config)#module csm 3 
    cat(config-module-csm)#
  5. 创建客户端VLAN和网关。

    cat(config-module-csm)#vlan 100 client 
    cat(config-slb-vlan-client)#ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)#gateway 172.17.63.214  
    cat(config-slb-vlan-client)#
  6. 创建服务器端的VLAN。

    cat(config-module-csm)#vlan 200 server 
    cat(config-slb-vlan-server)#ip address 172.17.63.217 255.255.255.192
    
  7. 创建服务器站。

    cat(config-module-csm)#serverfarm wwwfarm
    cat(config-slb-sfarm)#real 172.17.63.215 
    cat(config-slb-real)#inservice 
    cat(config-slb-real)#real 172.17.63.216 
    cat(config-slb-real)#inservice
    
  8. 创建Vserver并且关联服务器站。

    cat(config-module-csm)#vserver server 
    cat(config-slb-vserver)#virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)#serverfarm wwwfarm 
    cat(config-slb-vserver)#inservice
    

使用思科Catalyst 6500和CSM,这是SLB配置示例。

CSM (WS-X6066-SLB-APC)运行配置
Building configuration... 

Current configuration : 3863 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot system flash sup-bootflash:c6sup11-jsv-mz.121-11b.E 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 
mls qos statistics-export interval 300 
mls qos statistics-export delimiter | 
! 

!--- CSM located in slot 3. Module running as Active.�
 
! 
module ContentSwitchingModule 3� 
! 


!--- Client side CSM VLAN 100 
!--- Gateway pointing to the MSFC.

! 
�vlan 100 client 
� ip address 172.17.63.217 255.255.255.192 
� gateway 172.17.63.214 
! 

!--- Server side CSM VLAN 200.

! 
�vlan 200 server 
� ip address 172.17.63.217 255.255.255.192 
! 

!--- Server farm configuration.
 
! 
�serverfarm WWWFARM 
� nat server� 
� no nat client 
� real 172.17.63.215 
�� inservice 
� real 172.17.63.216 
�� inservice 
! 

!--- VServer configuration. 

! 
�vserver SERVER 
� virtual 172.17.63.241 tcp www 
� serverfarm WWWFARM 
� persistent rebalance 
� inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 

!--- Connection to upstream device.

! 
interface FastEthernet2/1 
�switchport 
�switchport access vlan 100 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 

!--- Connection to Web servers.

! 
interface FastEthernet2/3 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/4 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/5 
�no ip address 
�shutdown 
! 

!--- MSFC VLAN 100.

! 
interface Vlan100 
�ip address 172.17.63.214 255.255.255.192 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
! 
line con 0 
line vty 0 4 
�login 
! 
end

验证(show 命令)

show module csm # status 命令

show module csm - status命令显示SLB模块的状况。模块必须联机。

cat#show module csm 3 status
SLB Module is online in slot 3.
Configuration Download state: COMPLETE, SUCCESS

show module csm # vserver name word detail 命令

show module csm - vservers name word detail命令显示详细的虚拟服务器信息。您也看到虚拟服务器的状态,并且那里多少连接是。这是最好的命令使用获得虚拟服务器信息。

cat#show module csm 3 vservers name server detail�
SERVER, state = OPERATIONAL, v_index = 10
� virtual = 172.17.63.241/32:80, TCP, service = NONE, advertise = FALSE
� idle = 3600, replicate csrp = none, vlan = ALL, pending = 30
� max parse len = 600, persist rebalance = TRUE
� conns = 0, total conns = 4
� Default policy:
��� server farm = WWWFARM
��� sticky: timer = 0, subnet = 0.0.0.0, group id = 0
� Policy���������� Tot Conn���� Client pkts� Server pkts
� ------------------------------------------------------
� (default)������� 4����������� 56���������� 56

show module csm # real detail 命令

show module csm - real detail命令显示每个真实服务器的信息,例如每个服务器驻留的服务器站,服务器状态、阈值和连接。

cat#show module csm 3 real detail
172.17.63.215, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
172.17.63.216, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
cat#show module csm 3 real detail

show module csm # serverfarm name word detail 命令

show module csm - serverfarms name word detail命令显示服务器区域信息。此指令显示为负载均衡使用的预报器。在本例中,是默认,使用循环法。

cat#show module csm 3 serverfarms name wwwfarm detail�
WWWFARM, predictor = RoundRobin, nat = SERVER
� virtuals inservice: 1, reals = 2, bind id = 0, fail action = none
� inband health config: <none>
� retcode map = <none>
� Real servers:
��� 172.17.63.215, weight = 8, OPERATIONAL, conns = 0
��� 172.17.63.216, weight = 8, OPERATIONAL, conns = 0
� Total connections = 0

show module csm # vlan detail 命令

show module csm - vlan detail命令显示客户端和服务器的VLAN信息。

cat#show module csm 3 vlan detail�
vlan�� IP address������ IP mask��������� type������
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192� CLIENT
� GATEWAYS
� 172.17.63.214����
200��� 172.17.63.217��� 255.255.255.192� SERVER
cat#

故障排除

您应该能通过发出pingping模块ping真实服务器和CSM网关从Catalyst 6500 csm # reals命令。

cat#ping module csm 3 reals
IP address������ Reachable
--------------------------
172.17.63.215��� Yes
172.17.63.216��� Yes
cat#ping module csm 3 gateway�������������������������
IP address������ Reachable
--------------------------
172.17.63.214��� Yes

另一好故障排除命令是show module csm # arp。CSM将了解地址。确保网关,并且reals显示。

cat#show module csm 3 arp�
Internet Address� Physical Interface� VLAN����� Type������ Status
--------------------------------------------------------------------
�172.17.63.210��� 00-E0-B6-01-FA-49�� 100������ LEARNED��� up(0 misses)
�172.17.63.214��� 00-04-C0-C0-68-00�� 100������ GATEWAY��� up(0 misses)
�172.17.63.215��� 00-60-B0-87-DC-1A�� 200������ REAL������ up(0 misses)
�172.17.63.216��� 00-50-DA-BF-A1-7F�� 200������ REAL������ up(0 misses)
�172.17.63.217��� 00-30-F2-71-5D-2E�� 100/200�� --SLB--��� local
�172.17.63.222��� 00-02-B9-45-A2-91�� 100������ LEARNED��� up(0 misses)
�172.17.63.241��� 00-30-F2-71-5D-2D�� 0�������� VSERVER��� local

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 5217