网络应用服务 : 思科 500 系列内容引擎

使用 ACNS 软件 4.x 配置透明与代理媒体重定向

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文描述如何配置透明的Cisco Cache/Content Engine,并且缓存使用WEB缓存通信协议(WCCP)版本2. Cisco ACNS版本4.x的代理媒体,包括,作为一个选项, RealProxy从RealNetworks, Inc.leavingcisco.com 支持拆分缓存(根据要求内容)在实时流协议(RTSP) -基于流和其他实时PNM (RealNetworks图元文件)格式的数据流(分配的实际源)和流媒体。

内容引擎可以配置透明地接受从WCCP路由器重定向的RTSP请求,以及从RealPlayer客户端软件的传统代理类型RTSP请求。缓存提供的流媒体满意根据要求对的延伸,如果用户已经查看了一个被缓存的流媒体文件,可以被服务对随后的用户,不用需求连接到源服务器。注意不可能缓存现场广播。

要配置内容引擎接收RTSP流量,请完成这些步骤:

  1. 发出rtsp proxy命令在输入的IP地址、端口和用于内容引擎的RealProxy的许可证全局配置模式。

  2. 发出wccp media-cache global configuration命令注册内容引擎用所有支持WCCP的路由器。

流媒体对象在媒体文件系统(mediafs)磁盘分区被贮藏,当RealProxy软件复制到软件文件系统(swfs)时作为安装程序一部分,分区。发出disk命令创建mediafs分区;发出mediafs命令维护这些分区(参考维护硬盘磁盘存储欲知关于磁盘分区的详情)。RealProxy软件可以管理与RealAdministrator GUIï ¿  ½ (访问此页,默认用户名/密码是admin/菱形)。

要配置支持WCCP的路由器,您需要发出wccp service-group 80命令。命令输出在配置部分显示。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

要求

本文档的读者应掌握以下这些主题的相关知识:

  • 运行ACNS软件版本4.x或以上的内容引擎

  • 用mediafs分区安装的RealProxy软件装载

注意: 您在缓存软件里必须采购许可证密钥为了激活RealProxy功能。对于预定在Cisco.com,参考排序

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 在实验室环境的Cisco内容引擎590运行的Cisco ACNS软件版本4.x或以上清除配置

  • 思科7513路由器运行Cisco IOS软件版本12.0.18(S)

配置

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

/image/gif/paws/4717/media_redir.jpg

配置

Cisco Cache Engine 560 (Ciscoï ¿  ½ ACNS软件版本4.x)
hostname disaster

!

ip domain-name cisco.com

!

interface FastEthernet 0/0

ip address 172.17.241.108 255.255.255.0

exit

interface FastEthernet 0/1

shutdown

exit

!

ip default-gateway 172.17.241.45

!

ip name-server 144.254.6.77

!

!

wccp router-list 1 172.17.241.29 172.17.241.31 172.17.241.45

wccp web-cache router-list-num 1

wccp media-cache router-list-num 1

wccp version 2

!

!

rtsp proxy media-real license-key <removed>

rtsp proxy media-real ip-address 172.17.241.108

rtsp proxy media-real enable�

rtsp proxy incoming 554�

rtsp proxy l4-switch enable

!

!

username admin password 1 Gn1nQzm/arxcI

username admin privilege 15

username cisco password 1 714DWnzYTRHC.

username cisco privilege 15

!

!
Building configuration...

Current configuration : 3071 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service single-slot-reload-enable

!

hostname lsd

!

ip subnet-zero

ip wccp web-cache

ip wccp 80

ip cef

no ip domain-lookup

ip domain-name cisco.com.

ip name-server 144.254.6.77

!

interface Ethernet5/0

�ip address 172.17.241.45 255.255.255.0

�no ip directed-broadcast

�ip wccp 80 redirect out

!

interface Ethernet5/1

�ip address 10.10.10.1 255.255.255.0

�no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.241.1

!

line con 0

�exec-timeout 0 0

line aux 0

line vty 0 4

�password <removed>

�login

!

end

debug 和 show 命令

在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

disaster#show mediafs volumes

disk00/03 :    mounted  size: 10669934

disk01/00 :    mounted  size: 14226579

disk01/02 :   formatted  size: 7113289
disaster#show statistics mediacache real requests

                  Media Cache Statistics - Requests

                                                Total             % of Requests

                            ---------------------------------------------------

     Total Received Requests:                       5                         -

            Demand Cache Hit:                       3                      60.0

           Demand Cache Miss:                       2                      40.0

         Demand Pass-Through:                       0                       0.0

                  Live Split:                       0                       0.0

           Live Pass-Through:                       0                       0.0

disaster#show statistics mediacache real savings

             Media Cache Statistics - Savings

                        Requests                          Bytes

         -----------------------------------------------------------

  Total:                       5                       14617438

   Hits:                       3                        6458830

   Miss:                       2                        8158608

Savings:                    60.0 %                         44.2 %

disaster#show rtsp all

Media Types:

  Servicing Real Media

Real Proxy License Key:

  Installed

Media Specific Info:

  Real Proxy IP address: 172.17.241.108

Incoming Proxy-Mode:

  Servicing Proxy mode RTSP connections on port: 554

RTSP Transparent Proxy (WCCP):

  Configured for port: 554

RTSP Transparent Proxy (L4 Switch):

  Configured for port: 554
disaster#show wccp 80 detail



Service Details for Media Cache Service

        Service Enabled                    : Yes

        Service Priority                   : 200

        Service Protocol                   : 6

        Application                        : Streaming

        Service Flags (in Hex)             : 512

        Service Ports                      :    554     0     0     0

                                           :      0     0     0     0

        Security Enabled for Service       : No

        Multicast Enabled for Service      : No

        Weight for this Web-CE: 0
lsd#show ip wccp 80 detail

WCCP Cache-Engine information:

        IP Address:            172.17.241.108

        Protocol Version:      2.0

        State:                 Usable

        Redirection:           GRE

        Initial Hash Info:     00000000000000000000000000000000

                               00000000000000000000000000000000

        Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

                               FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

        Hash Allotment:        256 (100.00%)

        Packets Redirected:    35

        Connect Time:          23:41:34
lsd#show ip wccp

Global WCCP information:

    Router information:

        Router Identifier:                   172.17.241.45

        Protocol Version:                    2.0



    Service Identifier: web-cache

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            0

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        0

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none



    Service Identifier: 80

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            35

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        35

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none

缓存引擎显示命令

show 命令 说明
show wccp content-engines 显示WCCP内容引擎信息。
show wccp flows media-cache 显示媒体高速缓存服务数据包流。
show wccp routers 显示WCCP路由器列表。
show wccp services 显示WCCP配置的服务。
show wccp slowstart 显示WCCP缓慢的开始。
show wccp status 显示WCCP运行状态。
show statistics mediacache real savings 显示节省统计数据。
show statistics mediacache real requests 显示请求统计信息。
show rtsp all 显示所有RTSP配置。
show rtsp proxy 显示代理模式配置。
show mediafs volumes 显示mediafs音量。

Cache Engine调试指令

debug 命令 说明
debug wccp all 打开所有调试的Enable (event) WCCP。
debug wccp events Enable (event) WCCP事件。
debug wccp packets Enable (event) WCCP包相关信息。

路由器show命令

show 命令 说明
show ip wccp 80 detail 显示Cache Engine和WCCP路由器统计数据特定服务组的。
show ip wccp 80 view 显示服务组查阅信息

路由器调试命令

debug 命令 说明
debug ip wccp events 显示WCCP事件。
debug ip wccp packets 显示WCCP包相关信息。

命令汇总

这些Cache Engine命令用于此配置:

  • WCCP版本{1|2}

  • wccp router-list number ip-address

  • wccp介质缓存router-list-num编号

  • rtsp代理media-real license-key密钥

  • rtsp proxy media-real ip-address ip-address

  • rtsp代理media-real enable (event)

  • rtsp代理传入端口

这些是在此配置方面使用的路由器命令:

  • ip WCCP {web-cache|服务编号}

  • ip WCCP {web-cache|服务编号}重定向


相关信息


Document ID: 4717