语音和统一通信 : Cisco AS5300 系列通用网关

对 Cisco 访问服务器使用 Dialout/EZ

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

利用 Tactical Software 的 Dialout/EZ 产品,桌面 LAN 用户可将网络访问服务器 (NAS) 端口作为出站异步通信的调制解调器池共享。Dialout/EZ的用户不再需要专用调制解调器和电话线路在他们的桌面,反而使用通信(COM :)端口转向器软件允许接入服务器的拨号端口出现作为本地调制解调器到桌面通信应用。Windows用户能通过一个中央NAS/access服务器拨访问远程联机服务和均等发送从他们的PC。的传真在NAS的Cisco IOSï ¿  ½软件版本运行必须支持COM端口控制协议(RFC 2217)。您能发现关于策略软件的Dialout/EZ的更多信息从公司的网站在:http://www.tacticalsoftware.comleavingcisco.com

注意: Dialout/EZ是Cisco Dialout Utility的一更换。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 策略软件要求Cisco IOS软件版本12.0(9)或以后在NAS安装与Dialout/EZ兼容。

  • 由于Cisco Bug ID CSCds28071, Cisco建议您运行Cisco IOS软件版本12.1(8)或以后。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

安装和配置

为 Dialout/EZ 虚拟 COM 端口安装适当的调制解调器驱动程序

  1. 安装Dialout/EZ。

    关于客户端工作站的完整Dialout/EZ安装信息,参考在策略软件的网站的用户指南:Dialout/EZ

  2. 下载调制解调器驱动程序。

    Dialout/EZ虚拟COM端口没有任何调制解调器设备附加对他们。Dialout/EZ用户应该使用一个适当的.inf文件调制解调器(请安装在虚拟COM端口的一个调制解调器驱动程序)。MICA、NextPort和Microcom.inf文件可以从Cisco网站的下载。对于其他平台请使用指定的.inf文件。

    调制解调器类型 平台 .inf文件
    MICA 3600, AS5200,AS5300,AS5800 mdcsmica.inf
    NextPort AS5350,AS5400 AS5800, AS5850
    Microcom AS5200 mnpv90.inf
    NM xAM 2600, 3600 Microcom DeskPorte V.34 FAST
    WIC-xAM 2600, 3600 mdmrock5.inf (或标准28800位/秒调制解调器文件)

    注意: 对于Windows XP,思科提供了.inf文件可能不工作。尝试使用Windows内置的.inf文件。

  3. 安装调制解调器驱动程序。

    要安装在Windows PC的一个调制解调器驱动程序,请使用以下步骤:

    1. Start > Settings > Control Panel > Phone及Modem Options

    2. 选择调制解调器并且添加添加一个新的调制解调器。

    3. select不检测我的调制解调器;我从列表将选择它,然后其次单击。

    4. 选择制造商和型号您的调制解调器。选择在左窗口的思科显示在右侧的窗口的Mica。

    5. select有磁盘并且浏览到.inf文件保存的位置。

    6. 所选的端口选项,请使用在EZ Dialout安装时选择的COM端口(例如, COM 5)。

配置访问服务器

为仅字符模式调制解调器拨出应用程序需要的IOS软件配置(例如与Dialout/EZ)去在line configuration下:

line starting_line_number ending_line_number
     modem dtr-active  
     
! -- If the router is for dialin and dialout use "modem inout" instead

     transport input telnet
     
! -- Or transport input all could be used

     escape-character NONE 
     
! -- Due to Bug CSCdv12194 for the AS5350/AS5400.

     rotary 1 
     
! -- Specifies the use of TCP port 7001 in the Dialout/EZ manager 
     ! -- window to dial out rotary 1

如果使用外置调制解调器,则请如期望的一样添加RS232物理层和成帧参数在line configuration下:

speed 115200 
    
 ! --  Set to the highest speed supported by the modems

     flowcontrol hardware
     parity even 
     databits 7 
     
! -- Or databits 8

     stopbits 1 
     
! -- Recommended for best throughput

如果要控制对拨出线路的访问,请添加以下在线路配置模式:

password password

或者,请配置验证、授权和统计(AAA)并且适用于列表线路与:

login authentication listname

如果希望控制哪些中继使用拨出呼叫,请使用在Cisco IOS软件版本12.1(T)介绍的modem dialout controller命令(到现在,支持在仅AS5300)。欲知更多信息,参考配置流出的模拟呼叫的一个T1或E1接口使用modem dialout controller命令

提示: 有时Dialout/EZ能由从IOS软件的密码OK消息弄糊涂。要避免此问题,请配置AAA (本地或基于服务器的)在路由器。参考本文的AAA部分的As5xxx配置示例的。

可选:您能也配置modemcap重置调制解调器到默认配置在每呼叫以后。请使用modem autoconfigure type mica命令在line configuration下。设置出厂默认设置&F)可以应用到所有路由器不管调制解调器类型的此modemcap ((MICA、NextPort、Microcom等等)。关于modemcap的更多信息,参考内部数字和模拟调制解调器的推荐Modemcap在Cisco接入服务器

同一接入服务器可以用于拨入以及拨出(应用程序)。参考DialOut/EZ实用程序的部分示例NAS配置的全面的配置示例。

排除 DialOut/EZ 故障

按照下面略述的方法排除故障Dialout/EZ相关问题:

  1. 倒转Telnet到从NAS EXEC提示的NAS调制解调器。保证您能连接到调制解调器通过发出应该返回一好的答复的AT命令。如果能连接到调制解调器,使用atdt ########命令,请设法拨号远程设备的号码。如果连接是成功的,则路由器配置正确,并且硬件正确地工作。

    注意: 请使用二进制Telnet TCP端口范围:6000+line使用特定的或者7000+ rotary_number轮循的拨出。

    下面的示例显示成功的呼叫:

    maui-nas-03#telnet 172.22.53.150 7001
    
    ! -- Reverse Telnet to an up/up interface on the router 
    ! -- and use port 7000+rotary
    
    Trying 172.22.53.150, 7001 ... Open
    User Access Verification
    !
    Username: admin
    Password:
    at
    OK
    
    ! -- Modem is responding
    
    atdt 81560
    
    ! -- Dial number 81560 to connect to remote device. 
    ! -- This may take up to 30 seconds.
    
    CONNECT 33600 /V.42/V.42bis
    
    ! -- Call is connected to the remote device.
    
      User Access Verification
    
    ! -- Username prompt by remote device
    
      Username: cisco
      Password: maui-nas-01>

    如果反向Telnet不到达modem at命令模式,则NAS是不正确的配置的。应检查以下内容:

    1. IP地址您远程登录到应该是up/up和可ping通的从在LAN的PC主机的接口。如果不能ping路由器接口请排除故障您的路由选择相关问题的LAN。

    2. 调制解调器线路应该有modem inout (dialin/dialout)或modem dtr-active (仅拨出)。

    3. 应该配置线路有transport input telnet传输输入的全部

    如果反向Telnet在到达modem at命令模式成功,但是手动呼叫发生故障,则问题可能是Telco或远程路由器问题。排除故障远程路由器,线路并且在将来发生前再测试连接。参考故障排除拨号技术连接-非DDR呼出欲知更多信息。

  2. 尝试从一台PC主机的一反向Telnet在LAN。打开窗口超级终端(或对例如您使用Dialout/EZ的路由器IP地址和端口的Windows Telnet)和Telnet (7001)。如果能到达调制解调器和拨出,则LAN (我们没有错以前验证从NAS的拨出工作)。

  3. 如果反向Telnet不到达modem at命令模式,则NAS是不正确的配置的或IP网络不工作。应检查以下内容:

    1. IP地址您远程登录到应该是up/up和可ping通的从在LAN的PC主机的接口。如果不能ping路由器接口请排除故障您的路由选择相关问题的LAN。

    2. 不应该有阻塞Telnet连接的access-class。

    以下屏幕截图显示一次成功的超级终端会话:

    hyperterm1.gif

    hyperterm2.gif

    注意: 如果使用Microsoft Windows Telnet客户端,并且AAA在NAS配置, windows Telnet登录可能发生故障。此失败是由应用设置造成的和描绘的是为无法输入密码,因而登录发生故障。要更正此会话的Telnet应用程序设置,请遵从下面步骤在主机PC:

    1. Start > Run >类型telnet,点击OK键。

    2. 键入unset crlf命令。(这保证您发送回车作为Telnet <CR><NUL>而不是<CR><LF>。)

    3. 请使用开放<ip_address> <port>远程登录到调制解调器。

    4. 您应该当前连接到调制解调器,并且可以当前启动手动拨号使用atdt,正如超级终端示例显示上述。以下屏幕截图是示例:

      wintelnet1.gif

  4. 直接地连接对NAS调制解调器的使用超级终端通过DialOut/EZ's模拟COM端口。参考在安装的Dialout/EZ用户指南章节http://www.tacticalsoftware.com的leavingcisco.com 欲知更多信息。这验证DialOut/EZ's模拟的COM端口作用。

    如果在DialOut/EZ's模拟的COM端口的超级终端不工作,则问题将似乎是奇怪的对与IOS的DialOut/EZ's通信。收集以下信息:

    • 这些调试确定NAS是否接收Telnet连接。

      debug telnet 
      debug modem
      
    • Dialout/EZ Trace日志:选择Trace窗口菜单选项打开Dialout/EZ端口监控程序3.0窗口,当Trace窗口选项启用。要开始跟踪,请在此窗口的底部检查Enable Trace复选框。确保您保存进一步分析的日志。参考用户指南的故障排除部分在策略软件的网站的欲知更多信息。

  5. 因为我们验证Dialout/EZ能连接到调制解调器,其次请有终端应用程序启动连接。使用Dialout/EZ连接,如果终端应用程序不能彼此谈,则问题可能是奇怪的对终端应用程序。Dialout/EZ Trace日志可能是有用的在排除故障此问题。并且请打开Windows TAPI调制解调器日志并且所有记录日志可得到从应用程序。参考以下leavingcisco.com Microsoft条款的Microsoft的网站如何创建和使用Modemlog.txt文件(Q142730)欲知更多信息。

    如果操作不如期望的一样仍然运作,请采集IOS调试、Dialout/EZ Trace日志和(如果适用) Windows调制解调器日志,并且分析结果确定应用程序哪里失败。

    参考的策略软件:leavingcisco.com 其他信息的常见问题

为使用 DialOut/EZ 实用程序的 NAS 配置示例

AS25xx, NM xAM, WIC-xAM

以下路由器的一个示例配置文件用外部模拟调制解调器,例如Cisco AS2509、Cisco AS2510、Cisco AS2511或者Cisco AS2512接入服务器以及路由器用内部模拟调制解调器(NM xAM和WIC-xAM)例如26xx和36xx系列路由器。

下面的示例显示路由器有能力在进入和出去的呼叫上。如果路由器是为仅出站使用,则是需要的line configuration是所有。

interface Group-Async1
   
! -- Group-Async interface used for dialin calls
   ! -- This is not used for dialout

    ip unnumbered Ethernet0
    no ip mroute-cache
    encapsulation ppp
    no ip route-cache
    async default routing
    async dynamic address
    async mode interactive
    peer default ip address pool local
    dialer in-band
    no cdp enable
    ppp authentication chap
    group-range 1 8
    
! -- Range of lines include 1 through 8
    ! -- Modems 1 through 8 can now be used for incoming or outgoing calls

   !
   line 1 8
    
! -- Line configuration used for Dialout/EZ

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only use "modem dtr-active"

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead

    rxspeed 115200
    txspeed 115200
    
! -- Speed for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM)
 
    flowcontrol hardware
    
! -- Flowcontrol for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM

没有 AAA 的 AS5xxx

没有AAA,以下Cisco AS5xxx系列接入服务器的一个示例配置文件。

此示例显示接受呼入呼叫和进行的呼出的路由器:

controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 6661210
    dialer-group 1
    isdn incoming-voice modem
    
! -- Incoming analog calls will be switched to the modems

    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap
    ppp multilink
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap
    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   line 1 48
   
! -- Line configuration for Dialout/EZ

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout if the line is used for
    ! -- dialout only use, modem dtr-active transport preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport input all
    transport input telnet
    
! -- Configure one or both of the above commands

带有 AAA 的 AS5xxx

以下Cisco AS5xxx系列接入服务器的一个示例配置文件有配置的基于服务器的AAA的。

以下示例,显示为拨入和拨出呼叫配置的接入服务器:

aaa new-model
   aaa authentication login default radius
   
! -- Use the radius server for login on the default list
   ! -- for local AAA replace "radius" with "local" 
   ! -- (make sure to configure the username/password locally as well

   aaa authentication ppp ppptac radius
   
! -- Use the radius server for ppp on the list named ppptac
   ! -- This is used for incoming ppp calls and is not used for outgoing 
   ! -- Dialout/EZ calls
   !

   controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 name test 5551210
    dialer-group 1
    isdn incoming-voice modem
    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap ppptac
    ppp multilink
   !
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap ppptac
    
! -- Use list named ppptac for authentication

    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   !
   radius-server host 10.4.1.10
   radius-server timeout 20
   radius-server key nas1
   
! -- Radius server configuration

   !
   line 1 48
    
! -- Line configuration for Dialout/EZ as well as dialin calls

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only, use modem dtr-active transport 
    ! -- preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead


相关信息


Document ID: 23241