语音和统一通信 : Cisco Unity Express

Cisco CME基本自动呼叫分发和Cisco Unity Express Auto Attendant互操作配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档提供了使用 Cisco CallManager Express (CME) 基本自动呼叫分配 (ACD) 和 Cisco Unity Express 自动总机 (AA) 功能的配置示例。

先决条件

要求

需要大致熟悉 Cisco CME 和 Cisco Unity Express 配置。本文档着重介绍 Cisco CME Basic ACD 和 Cisco Unity Express AA 互操作配置。

以下是此配置示例中所述功能的最低版本:

  • Cisco CME 3.3

  • Cisco IOS�软件版本12.4.3

  • Cisco Unity Express 2.1.3

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 运行 Cisco CME 和 Cisco Unity Express 的 Cisco 2821 路由器

  • Cisco IOS 软件版本 12.4.3

  • Cisco CME 3.3

  • Basic ACD 脚本版本 2.1.0.0

  • Cisco Unity Express 2.1.3

  • IP Voice Cisco IOS 功能集

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

相关产品

此配置还可用于安装有 Cisco IOS 软件版本 12.4.1 或更高版本的 Cisco 2600XM、Cisco 3700、Cisco 2800 或 Cisco 3800 系列路由器。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

本文档讨论以下三种方案:

  • 方案 1 - 结合 Cisco Unity Express 使用 Cisco CME AA 和 ACD 组,仅作为语音邮件目标

  • 方案 2 - 将 Cisco Unity Express 用作 AA 主入口点,将 Cisco CME AA 用作该 AA 内的“子菜单”

  • 方案 3 - 将 Cisco CME AA 用作 AA 主入口点,使用 Cisco Unity Express AA 来提供灵活“通告”以作为 AA 的一部分

当 Cisco CME AA 被限制为提供用于将呼叫定向到 ACD 组的菜单时,方案 1 最适用。在此方案中,当 ACD 座席不可用或者在一定时间内未应答呼叫时,Cisco CME 将用作传入呼叫的 AA 目标,Cisco Unity Express 专门用作语音邮件服务器。此方案中不使用 Cisco Unity Express AA。

方案 2 是用于将 Cisco CME Basic ACD 与 Cisco Unity Express AA 集成的最灵活的总体配置。方案 2 中的设计使用 Cisco Unity Express AA,用于常规呼叫处理自动化并将呼叫移交给 ACD 座席。在此方案中,Cisco Unity Express 用作传入呼叫的 AA 目标;Cisco Unity Express 还向呼叫方提供了各种菜单选项(例如,按名称拨号、按分机拨号以及记录的信息片段等)。其中的一个选项是将某些呼叫转到 Cisco CME ACD 组。Cisco Unity Express 语音邮件的使用方式与方案 1 类似。

方案 3 是方案 1 的一种变化形式,其中 Cisco CME AA 用作传入呼叫的 AA 目标,ACD 是 AA 所需的主功能。但是,Cisco Unity Express AA 与 Cisco CME AA 一起用作“通告服务器”。这样就能够添加仅使用 Cisco CME AA 无法提供的某些通告(如办公时间或位置)。

注意: 本文档中提供的基于 GUI 的配置过程用于说明与此配置示例关联的实施过程,并总结了实施本文档中描述的功能所需要的步骤。但是,未提供完整的分步过程。本文档假设您已熟悉 Cisco CME 和 Cisco Unity Express GUI 的使用,并具备 Cisco IOS CLI 的使用知识。有关操作过程与命令用法的明确详细信息,请参阅相应的 Cisco CME 和 Cisco Unity Express 管理员指南、配置指南和命令参考。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

图 1 Cisco CME Basic ACD 和 Cisco Unity Express AA 的网络图

/image/gif/paws/67907/135345.jpg

配置

所有三种配置方案都有以下一般特性:

  • 单站点 Cisco CME 系统

  • PSTN 中继集成在 Cisco CME 路由器上

  • 该配置定义了 4 位数拨号方案,IP 电话分机在 2000 到 2010 范围内,非电话分机(如寻线组)在 2020 到 2099 范围内,Cisco Unity Express 入口点在 21 xx 范围内。

  • 定义了 9 个 IP 电话,分机是 2000 到 2009。

  • ACD 设置使用 3 个寻线组,每个寻线组有 3 个 IP 电话。

  • 定义了两个接待员,它们也是 ACD 组中 9 个 IP 电话的一部分。

该网络配置使用具有以下特性的 Cisco 2821 路由器:

  • 通过 IP 地址 b .168.1.1 访问 IP 网络

  • Cisco CME 配置带 9 个 IP 电话--每个电话是 4 位数分机(2001 到 2010)

  • NM-CUE

  • Cisco Unity Express IP 地址 a .1.11.2

本文档使用以下配置:

常规实施配置说明

本配置中使用的 PSTN 连接是通过外部交换局 (FXO) 中继进行的。如果您有 PRI 中继,则配置看上去与本文档中提供的配置示例完全相同,只是增加了以下配置条目:

controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Serial2/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 2/1:23
!
dial-peer voice 777 pots
 incoming called-number .
 direct-inward-dial
 port 2/1:23

本文档中提供的示例中所使用的 Cisco Unity Express AA 脚本非常简单,并且为简明起见,只包含最少数量的功能来实现本文档所说明的功能。与实验室测试网络相比,部署在真实网络中的 Cisco Unity Express AA 脚本应具有明显更高的传入呼叫处理能力。其他呼叫处理“步骤”可能包括以下内容:

  • 改进的错误处理(例如,当呼叫方按下菜单中没有的数字时)

  • 超时处理(例如,将菜单重复固定次数)

  • 能够阻止将呼叫转接到外部 PSTN 目标(逃避话费)。

方案 1 - 结合 Cisco Unity Express 语音邮件使用 Cisco CME Basic ACD

在方案 1 中,传入呼叫将定向到 Cisco CME AA(分机 2040),CME AA 向呼叫方提供问候语以及含 3 个选项的菜单。根据呼叫方的选择,呼叫将定向至 3 个 ACD 寻线组中的一个。如果呼叫在该 ACD 组中未得到应答,则这些呼叫将被转发到一般留言传递信箱 (GDM) 以留下留言。

注意: 您不能将 GDM 设置为复制到每个用户的邮箱(类似于分配列表)。

在本部分中所述的此方案中,将使用一个 GDM,以便 ACD 组中的所有 9 个 ACD 座席都可登录到此 GDM 并检索留言。在方案 2 所描述的其他变化形式中,将探讨每个 ACD 组具有一个 GDM 的能力。

呼叫流

本部分中所述配置的呼叫流如图 2 所示。

图 2 带有 Cisco CME Basic ACD 的 Cisco Unity Express AA 方案 1 呼叫流

/image/gif/paws/67907/135346.jpg

方案 1 配置说明

来自 FXO 端口 (0/3/0) 的 PSTN 呼叫将自动终止(通过 connection plar-opx 2040 命令)于 Cisco CME AA 引导号码 (2040)。Cisco CME AA 提供问候语以及带 3 个选项的欢迎菜单--图 2 的呼叫流图示中提供了语音提示内容。录制的问候语位于闪存文件 en_bacd_welcome.au 中,而录制的菜单短语位于 en_bacd_options_menu.au 文件中。

分机 2070 的 GDM 问候语如下:“Thank you for calling customer service;no one is available right now.Please leave a message and we will return your call as soon as we can.”

GDM 中留言的消息等待指示 (MWI) 是通过将 Cisco CME AA(param voice-mail 2070 命令)转接到中间分机 (2070) 来实现的,分机 2070 是接到语音邮件引导号码 (2105) 的 CFA(前转所有呼叫)。这里执行的是转接,而不是将 Cisco CME AA 直接指向语音邮箱引导号码--后者是使用 param voice-mail 2105 命令完成的。分机 2070 是座席电话上的按钮 2,此按钮表示 GDM 的 MWI,而该 GDM 与分机 2070 关联,而不是与 ACD 寻线组号(2020、2021 或 2022)关联。寻线组上未配置“最终”号码,因为 ACD 逻辑会绕过最终号码以支持 AA 转接号码(param voice-mail 命令)。

注意: 每次对脚本执行任何更改时,您都需要加载应用程序。

Cisco CME AA 脚本与环回 IP 地址 (a .1.1.1) 关联,以确保工具命令语言 (TCL) 脚本始终启用--而不考虑 LAN 接口的状态(dial-peer voice 2040 voip 命令)。背对背拨号对等体用于将呼叫定向到 Cisco CME AA 入口点 (2040),以确保 PSTN 呼叫方(以及本地 IP 电话)可呼叫 AA(dial-peer voice 2041 voip 命令)。

为方案 1 配置 Cisco CME

下面的步骤总结了方案 1 的 Cisco CME 配置:

  1. 选择 Configure > System Parameters 以配置 3 个 ACD 寻线组 2020、2021 和 2022,这 3 个组分别与 Cisco CME AA 的 3 个菜单选项关联。参见图3。

    图 3 指定 Cisco Unity Express ACD 寻线组

    /image/gif/paws/67907/135352.jpg

  2. 选择 Configure > System Parameters 以配置含座席 2001、2002 和 2003 的寻线组 2020 的详细内容。参见图4。

    图 4 配置寻线组 2020 的详细内容

    /image/gif/paws/67907/135353.jpg

  3. 选择 Configure > Phones,然后单击要更改的电话的 MAC 地址。随即出现“Change Phone”窗口(请参见图 5)。

  4. 在 ACD 座席的电话上输入分机 2070 以获取 GDM 中留言的 MWI。

    图 5 将分机与特定按钮关联

    /image/gif/paws/67907/135354.jpg

下面是方案 1 的完整(带注释)Cisco CME 路由器 CLI 配置,这是在对基本配置进行特定更改后得到的。

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Define the parameters for the Cisco CME ACD TCL script. 
!--- The hunt groups for the
!--- ACD are 2020, 2021, and 2022.

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !

!--- Define the parameters for the Cisco CME AA TCL script. 
!--- The pilot number is 2040.
!--- The voice-mail destination is extension 2070, which is call forward all
!--- (CFA) routed to voice mail (2105).

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the loopback address to which the TCL script is attached.

!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CME AA pilot number 2040.

!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!

!--- Calls to Cisco CME AA pilot number 2040 are associated with a loopback address
!--- a.1.11.1 to ensure that the TCL script is always up.

!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- The back-to-back dial-peer for Cisco CME AA 
!--- pilot number 2040 points to the
!--- AA TCL script and ensures that all PSTN and 
!--- internal callers can reach the AA.

!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- All calls in the 21xx range are directed to Cisco Unity Express.

!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!

!--- The following section shows nine ACD agents' extensions.

!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2070 is associated with the GDM. 
!--- This extension is used to get MWI
!--- on the ACD agents' phone.

!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- The following section shows phone definitions for the nine ACD agents.
!--- Ephone-dn 11 (2070) is defined as button 2 on each phone, so that all
!--- agents can get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!

!--- Three hunt-groups are used by the ACD scripts. 
!--- There are three agents in each group.

!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

为方案 1 配置 Cisco Unity Express

下面的步骤总结了方案 1 的 Cisco Unity Express 配置:

  1. 选择 Configure > Groups。然后单击要编辑的组 (custservice)。随即出现“Group Profile”窗口(请参见图 7)。

  2. 默认情况下,将显示“Profile”选项卡。配置与分机 2070 关联的 custservice 组。

    图 6 配置组配置文件

    142424.jpg

  3. 单击“Owners/Members”选项卡(请参见图 7)。

  4. 配置 custservice 组的成员(所有 9 个 ACD 座席用户)。

    图 7 配置组成员

    135356.jpg

下面是方案 1 的完整(带注释)Cisco Unity Express CLI 配置,这是在对基本配置进行特定更改后得到的:

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
!

!--- The custservice group is defined as all the 
!---users that have access to the GDM.

!
groupname custservice create
!

!--- Nine ACD agents are defined as users.

!
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The custservice group (and therefore GDM) 
!--- is associated with extension 2070.

!
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
groupname Administrators member admin
!

!--- Nine ACD agents users are members of the 
!--- custservice group, so they can have
!--- access to the GDM to retrieve messages.

!
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
!

!--- The Cisco Unity Express system AA is defined 
!--- in the system by default, but
!--- is not used in this scenario.

!
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Define the GDM associated with 2070, 
!--- associated with the custservice group.

!
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
!

!--- Define personal mailboxes for nine ACD agents.

!
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

方案 2 - 将 Cisco Unity Express AA 用作一级菜单,将 Basic ACD 用作二级菜单

在方案 2 中,传入呼叫将定向到 Cisco Unity Express 自定义 AA(引导号码 2100),该 AA 向呼叫方提供问候语以及含有 4 个选项的菜单。根据呼叫方的选择,呼叫将定向到 Cisco CME ACD(选项 1)、两个通告之一(选项 2 和 3)或与接待员关联的一般业务邮箱(分机 2080 的 GDM)(选项 4)。

如果呼叫方选择选项 1,则呼叫将移交给 Cisco CME ACD,Cisco CME AA 在这里提供了一个两级菜单,此菜单与方案 1 类似。

方案 2 呼叫流

本部分中所述配置的呼叫流如图 8 所示。

图 8 方案 2 的呼叫流

135360.jpg

方案 2 配置说明

来自 FXO 端口 (0/3/0) 的 PSTN 呼叫将自动终止于 Cisco Unity Express AA (2100)。

一级菜单(“Thank you for calling Widget Systems;press 1 for customer service;press 2 for office location;press 3 for office hours;press 4 to leave a voice message.”)由 Cisco Unity Express 自定义 AA 提供(文件 S10_Main_Menu.wav)。

二级菜单(“To help redirect your call:Press 1 for hardware-related questions;press 2 for software-related questions;press 3 for general questions.”)由 Cisco CME AA 提示文件提供。第一句话(“To help redirect your call”)包含在闪存文件 en_bacd_welcome.au 中,其余指令原封不动地沿用方案 1 配置,且包含在闪存文件 en_bacd_options_menu.au 中。

您可以录制一个小的空文件,或者从路由器闪存中删除此文件(这将使 Cisco CME 软件绕过问候),从而完全绕过 Cisco CME 问候语。在本部分中所描述的方案 2 示例中,与 Cisco Unity Express 和 Cisco CME 提示文件关联的菜单短语已构造成作为单个 AA 流向呼叫方。您还可以在绕过 Cisco CME AA 的同时,使用 param drop-through-option number 命令将呼叫直接转到 Cisco CME ACD,从而完全绕过 Cisco CME AA(问候语和选项选择)。

分机 2080 和关联的 GDM 将添加到配置中,用于为接待员提供一般邮箱。通过从一级菜单选择选项 4 可进入此邮箱;此邮箱将完全在 Cisco Unity Express 中得到处理。分机 2080 已添加到 IP 电话 2001 和 2004 - 这两个电话与作为接待员(以及 ACD 座席)的两名员工相关联。

如果呼叫方从一级菜单选择 1 并定向到 ACD 组,但是呼叫一直未得到应答,那么该呼叫将转接到分机 2070,也就是 ACD 座席的 GDM。

为方案 2 配置 Cisco CME

下面的步骤总结了方案 2 的 Cisco CME 配置:

  1. 选择 Configure > Phones。然后单击要更改的电话的 MAC 地址。随即出现“Change Phone”窗口(请参见图 9)。

  2. 将分机 2080 输入到接待员电话的按钮 3,而 ACD GDM 仍保留在按钮 2。通过此设置,员工可获取接待员和 ACD GDM 邮箱的 MWI。

    图 9 将分机按钮添加到接待员电话

    /image/gif/paws/67907/135361.jpg

下面是方案 2 的完整(带注释)Cisco CME 路由器的 CLI 配置,这是在对基本配置进行特定更改后得到的。

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CUE AA pilot number 2100.

!
voice-port 0/3/0
 connection plar opx 2100
!
voice-port 0/3/1
 connection plar opx 2100
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2080 is associated with the receptionists' GDM. 
!--- This extension is used to get MWI on the receptionists' phones.

!
ephone-dn  10
 number 2080
 description Reception GDM
 name Reception GDM
 call-forward all 2105
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- Ephone-dn 10 (2080) is defined as button 3 on 
!--- phones 2001 and 2004 so that all
!--- receptionists (ephones 1 and 4) get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

为方案 2 配置 Cisco Unity Express

下面的步骤总结了方案 2 的 Cisco Unity Express 配置:

  1. 打开 Cisco Unity Express 脚本编辑器实用程序,并创建自定义 Cisco Unity Express 脚本。请参阅图 10。

    图 10 配置顶级菜单的 Cisco Unity Express AA 脚本

    /image/gif/paws/67907/135362.jpg

  2. 选择 Voice Mail > Auto Attendant,并将脚本 (S10_CUE-AA-BACD-script.aef) 与引导号码 2100 关联。请参阅图 11。

    图 11 将脚本与引导号码关联

    /image/gif/paws/67907/135363.jpg

  3. 录制 AA 脚本的所有提示语。您可以用正确的文件名来脱机录制这些 .wav 文件,并将它们上载到 Cisco Unity Express,或者可通过电话委托管理 (AVT) 进行录制。

  4. (可选)如果您使用 AVT,则 Cisco Unity Express 会分配一个通用文件名,您以后可以将其更改为需要的文件名。选择 Voice Mail > Prompts,然后单击系统文件名。

  5. (可选)在对话框中根据需要编辑文件名,然后单击 Ok。“Voice Mail > Prompts”窗口此时在列表中显示更改后的文件名(请参见图 12)。

    图 12 AA 脚本提示列表

    /image/gif/paws/67907/135364.jpg

  6. 选择 Voice Mail > Auto Attendant,然后打开步骤 1 中构建的 AA。选择 Script Parameters,然后将提示文件名与脚本中正确的参数关联。

  7. 选择 Configure > Groups,然后单击要编辑的组 (reception)。随即出现“Group Profile”窗口(请参见图 13 顶部的局部窗口)。默认情况下,将显示“Profile”选项卡。

  8. 单击“Owners/Members”选项卡以配置成员。

    图 13 定义 Reception 组

    142217.jpg

下面是方案 2 的完整(带注释)Cisco Unity Express CLI 配置,这是在对基本配置进行特定更改后得到的。

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1

!--- Add the reception group.

!
groupname Administrators create
groupname Broadcasters create
groupname custservice create
groupname reception create
username admin create

username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The reception group (and therefore GDM) is associated with extension 2080.

!
groupname custservice phonenumber "2070"
groupname reception phonenumber "2080"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
!

!--- Add membership to group "reception".

!
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname reception member user21
groupname reception member user24
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast

!--- Define a 09:00-17:00 Monday-Friday business schedule for the AA.

!
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Add the custom AA script for the first-tier menu.

!
ccn application s10-cue-aa-bacd
 description "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10-cue-aa-bacd-script.aef"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_CustomerService" "2040"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the custom AA script with the pilot number 2100.

!
ccn trigger sip phonenumber 2100
 application "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Add the GDM for "reception"

!
voicemail mailbox owner "reception" size 3000
 description "Receptionists mailbox"
 end mailbox
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

方案 2 配置变化形式 1 - 每个寻线组具有单独的 GDM

前面几部分中所述的主方案的配置针对呼叫方留给 3 个 ACD 组(硬件支持、软件支持和常规问题)的所有留言定义了一个 GDM。这种细分可能不足以应付某些情况,因为一个组(例如软件支持)的座席在找到与软件支持有关的留言之前可能不想费力地浏览留给硬件支持组和一般支持组的留言。如果留言量很高,则您可以为每个 ACD 组设置一个单独的邮箱。

对于常规 Cisco CME 寻线组(不使用 ACD 时),您可以为每个寻线组定义一个单独的邮箱,方法是将各个 GDM 与寻线组号码(2020、2021 和 2022)关联,并将寻线组的“最终”目标指向语音邮件--如下面的配置示例所示。

为方案 2 变化形式 1 配置 Cisco CME

下面是针对多个单独 GDM 的 Cisco CME 配置变化形式:

ephone-hunt 1 sequential
 pilot 2020
 list 2001, 2002, 2003
 final 2105
 timeout 10
!
!
ephone-hunt 2 sequential
 pilot 2021
 list 2004, 2005, 2006
 final 2105
 timeout 10
!
!
ephone-hunt 3 sequential
 pilot 2022
 list 2007, 2008, 2009
 final 2105
 timeout 10

为方案 2 变化形式 1 配置 Cisco Unity Express

下面的步骤总结了在 Cisco Unity Express 中为方案 2 变化形式 1 配置组和 GDM 的过程:

  1. 将在 Cisco Unity Express 中为 3 个寻线组中的每个寻线组定义各个组。选择 Configure > Groups 以定义组。请参阅图 14。

    图 14 定义各个组

    135357.jpg

  2. Configure > Groups 中,单击要编辑的组 (hardware)。随即出现默认的“Profile”选项卡窗口(请参见图 15 顶部)。

    图 15 配置特定组

    /image/gif/paws/67907/135358.jpg

  3. 选择“Owners/Members”选项卡(请参见图 15 底部),然后单击左侧的复选框选择所有者和成员。

    下面是针对各个 GDM 的 Cisco Unity Express 配置变化形式:

    groupname hardware create
    groupname software create
    groupname general create
    groupname hardware phonenumber "2020"
    groupname software phonenumber "2021"
    groupname general phonenumber "2022"
    groupname hardware member user21
    groupname hardware member user22
    groupname hardware member user23
    groupname software member user24
    groupname software member user25
    groupname software member user26
    groupname general member user27
    groupname general member user28
    groupname general member user29
    voicemail mailbox owner "general" size 5520
     description "general mailbox"
     end mailbox
    voicemail mailbox owner "hardware" size 5520
     description "Hardware mailbox"
     end mailbox
    voicemail mailbox owner "software" size 5520
     description "software mailbox"
     end mailbox

方案 2 配置变化形式 2 - 每个 ACD 组具有单独的 GDM

“方案 2 配置变化形式 1 - 每个寻线组具有单独的 GDM”部分中总结的配置有两个缺点。

  • 只有在直接呼叫寻线组的情况下(分机 2020、2021 和 2022)它才起作用;如果寻线组用作 ACD,那么在呼叫 ACD 引导号码 (2040) 时,此配置不起作用。

  • 它没有任何方法来为座席提供 MWI,因为寻线组号码不能作为按钮置于电话上。

为了提供克服这两个缺点的配置,您可以使用 Cisco Unity Express 中的 xfermailbox 系统脚本。在 Cisco Unity Express 中定义三个组(hardware、software 和 general 分别对应一个组),然后将每个组与一个临时分机(如 2030、2031 和 2032)关联,临时分机可作为出现在座席电话上的按钮来放置(因此可提供 MWI)。表 2 总结了组、分机和电话的这种配置。

代理程序 分机 寻线组号码 ACD 组 组邮箱
user21 2001年 2020 硬件 2030
user22 2002年 2020 硬件 2030
user23 2003年 2020 硬件 2030
user24 2004年 2021 软件 2031
user25 2005年 2021 软件 2031
user26 2006年 2021 软件 2031
user27 2007年 2022 一般问题 2032
user28 2008年 2022 一般问题 2032
user29 2009年 2022 一般问题 2032

图 16 说明了此修改后的配置经过调整的呼叫流。

图 16 xfermailbox 脚本变化形式经调整的呼叫流

/image/gif/paws/67907/135359.jpg

将呼叫定向到 Cisco Unity Express 中的各个 GDM 需要一个调用 xfermailbox 系统脚本的自定义脚本。对 Cisco CME ACD 的呼叫只能通过使用单个 param voice-mail number 命令转发到 Cisco Unity Express(寻线组上的各个最终目标不能用于 ACD 呼叫流)。此命令将一个分机传送给 Cisco Unity Express 以进入邮箱(在前面的配置中,是分机 2070)。Cisco Unity Express 无法区分哪个寻线组是预定接收方,也无法确定要进入三个 GDM 中的哪个 GDM。

应改为将 Cisco CME ACD 语音邮件目标定向到一个进入自定义脚本 (s12-xfer-to-mbox.aef) 的 Cisco Unity Express 引导号码 (2110)。此引导号码向用户提供一个菜单,可让用户选择要为哪个组(hardware、software 或 general)留言。此菜单的内容显示在图 16 中呼叫流的底部。基于呼叫方的响应,mbox 变量设置为相应的分机(2030、2031 或 2032),呼叫将移交给三个 GDM 之一(通过 xfermailbox 系统脚本)。

下面的步骤说明了与修改方案 2 配置以处理表 2 和图 16 中概括的配置更改相关联的步骤:

  1. 打开 Cisco Unity Express 脚本编辑器实用程序,并编写名为 s12-xfer-to-mbox.aef 的自定义 Cisco Unity Express 脚本。请参阅图 17。

    图 17 自定义 Cisco Unity Express 脚本创建窗口

    /image/gif/paws/67907/135347.jpg

  2. 选择 Voice Mail > Auto Attendant。请参阅图 18。添加一个新自动总机,并将其与步骤 1 中生成的脚本相关联。

  3. 将自定义 s12-xfer-to-mbox.aef Cisco Unity Express 脚本与引导号码 2110 关联。请参阅图 18。

    图 18 将自定义 Cisco Unity Express 脚本与引导号码关联

    /image/gif/paws/67907/135348.jpg

  4. 为新的 AA 脚本录制语音提示(在本例中名为 S12_Main_Menu.wav)。您可以用正确的文件名脱机录制此 .wav 文件,并将其上载到 Cisco Unity Express,或者可以通过电话委托管理 (AVT) 进行录制。

  5. (可选)如果您使用 AVT,则 Cisco Unity Express 会分配一个通用文件名,您以后可以将其更改为需要的文件名。选择 Voice Mail > Prompts,然后单击系统文件名。

  6. (可选)在对话框中根据需要编辑文件名,然后单击 OK。“Voice Mail > Prompts”窗口此时在列表中显示更改后的文件名(请参见图 19)。

  7. 选择 Voice Mail > Auto Attendant,然后打开步骤 2 中构建的 AA。选择 Script Parameters,并将提示文件名与脚本中正确的参数关联。

    图 19 录制的提示的列表

    135349.jpg

  8. 选择 Configure > Extension 来定义分机 2030、2031 和 2032,以将 GDM 与每个分机关联。请参阅图 20。

    图 20 定义分机以将 GDM 与 ACD 寻线组关联

    /image/gif/paws/67907/135350.jpg

  9. 选择 Configure > Phones,然后单击要更改的电话的 MAC 地址。随即出现“Change Phone”窗口(请参见图 21)。

  10. 在 ACD 座席电话上添加代表 2030、2031 或 2032 的按钮以提供 MWI。

    图 21 说明如何添加按钮的窗口

    /image/gif/paws/67907/135351.jpg

下面是带注释的 Cisco CME 路由器 CLI 配置,用于说明对与“为方案 2 配置 Cisco CME”部分相关联的基本方案配置的 Cisco CME 配置进行的更改和添加。


!--- Set the Cisco CME AA voice mail destination 
!--- to 2110, the Cisco Unity Express
!--- script entrypoint for the transfer-to-mailbox functionality.

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2110
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the group extensions (2030, 2031 and 2032) to 
!--- be used as button appearances
!--- on the agent phones so they can get MWI for the GDMs. 
!--- Put these extension in CFA
!--- so they never ring and do not disturb the agents.

!
ephone-dn  12
 number 2030
 description HW Cust Svc Mbox
 name HW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  13
 number 2031
 description SW Cust Svc Mbox
 name SW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  14
 number 2032
 description Gen Cust Svc Mbox
 name Gen Cust Svc Mbox
 call-forward all 2110
!

!--- Add a button appearance of the appropriate 
!--- group extension to each of the
!--- ACD Agent phones.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:12 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:12
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:12
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:13 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:13
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:13
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:14
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:14
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:14

下面是带注释的 Cisco Unity Express CLI 配置,用于说明对与“为方案 2 配置 Cisco Unity Express”部分相关联的基本方案配置的配置进行的更改和添加以及之前的 GUI 更改:


!--- Define the three new groups, Hardware, Software and General.

!
groupname hardware create
groupname software create
groupname general create
!

!--- Define the new groups (and therefore GDMs) are associated with 
!--- extensions 2030, 2031 and 2032.

!
groupname hardware phonenumber "2030"
groupname software phonenumber "2031"
groupname general phonenumber "2032"
!

!--- Define the membership of  the Hardware, Software and General groups.

!
groupname hardware member user21
groupname hardware member user22
groupname hardware member user23
groupname software member user24
groupname software member user25
groupname software member user26
groupname general member user27
groupname general member user28
groupname general member user29
!

!--- Define the custom AA script that will branch 
!--- to the xfermailbox.aef system script
!--- when the caller selects the correct GDM from the menu.

!
ccn application s12-xfer-to-mbox
 description "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 script "s12_cue-aa-bacd-script.aef"
 end application
!

!--- Define the pilot number 2110 to the custom script.

!
ccn trigger sip phonenumber 2110
 application "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 end trigger
!

!--- Define the GDMs for each of the groups.

!
voicemail mailbox owner "hardware" size 3000
 description "hardware mailbox"
 end mailbox
voicemail mailbox owner "software" size 3000
 description "software mailbox"
 end mailbox
voicemail mailbox owner "general" size 3000
 description "general mailbox"
 end mailbox

方案 2 配置变化形式 3 - 使用直通 CD 功能

Cisco CME ACD 的直通功能可用于绕过 Cisco CME AA 菜单,并将呼叫直接转到 ACD 中。通过此功能,整个 AA 菜单可合并到 Cisco Unity Express AA 脚本中。虽然使用此功能需要在 Cisco CME 路由器上进行其他配置,但这与在 Cisco Unity Express AA(一级菜单)和 Cisco CME AA(二级菜单)之间拆分菜单和通告录音相比,简化了 AA 脚本(菜单)的维护。

在方案 2 变化形式 3 配置中,两级 AA 菜单将包含在 Cisco Unity Express AA 脚本中,如下所示:

  • Thank you for calling Widget Systems

    • Press 1 for Customer Service

      • Press 1 for Hardware related questions

      • Press 2 for Software related questions

      • Press 3 for General questions

    • Press 2 for Office location

    • Press 3 for Office hours

    • Press 4 to Leave a Voice Message

二级菜单选项可使呼叫从 Cisco Unity Express 移交给以下每个组的相应 Cisco CME ACD 引导号码:

  • Hardware — Cisco CME ACD 引导号码 2040

  • Software — Cisco CME ACD 引导号码 2041

  • General — Cisco CME ACD 引导号码 2042

本文档前面介绍的配置定义了一个 ACD 引导号码 (2040)。在下面的配置变化形式中,将定义三个不同的 Cisco CME ACD 引导号码(2040、2041 和 2042)。此变化形式将说明如何启用直通功能。使用直通功能可绕过 Cisco CME AA 菜单,并指定要遵循的特定选项(在相应 CLI 命令中指定)。系统的行为就像是呼叫方按下了 CLI 中静态指定的选项。在此方案中,Cisco CME AA 配置包含以下修改:

  • ACD 引导号码 2040 的配置包含 param drop-through-option 1 命令

  • ACD 引导号码 2041 的配置包含 param drop-through-option 2 命令

  • ACD 引导号码 2042 的配置包含 param drop-through-option 3 命令

为方案 2 变化形式 3 配置 Cisco CME

下面的步骤总结了方案 2 变化形式 3 的 Cisco CME 配置:

  1. 使用“直通”CLI 为引导号码 2040、2041 和 2042 添加其他 Cisco CME AA 和 ACD TCL 配置。

  2. 添加拨号对等体以允许拨打新引导号码 2040、2041 和 2042。

    下面是带注释的 Cisco CME 路由器 CLI 配置,用于说明对与“为方案 2 配置 Cisco CME”部分相关联的基本方案的 Cisco CME 配置进行的更改和添加。

    application
     service acd flash:app-b-acd-2.1.0.0.tcl
      param queue-cme-debugs 1
      param aa-hunt1 2020
      param aa-hunt2 2021
      param number-of-hunt-grps 3
      param aa-hunt3 2022
      param queue-len 30
    !
    
    !--- Define the TCL configuration for the Hardware group, using pilot number 2040 
    !--- and "drop-through-option 1". Extension 2030 is associated with the GDM for
    !--- the Hardware group, so this is the voice mail destination.
    
    !
     service hardware-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param max-time-vm-retry 1
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2030
      param aa-pilot 2040
      param number-of-hunt-grps 1
      paramspace english language en
      param handoff-string hardware-aa
      param call-retry-timer 20
      paramspace english location flash:
      param service-name acd
      param drop-through-option 1
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the TCL configuration for the Software group, 
    !--- using pilot number 2041 
    !--- and "drop-through-option 2". Extension 2031 is associated with the GDM for
    !--- the Software group, so this is the voice mail destination.
    
    !
     service software-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param number-of-hunt-grps 1
      paramspace english index 0
      param handoff-string software-aa
      paramspace english language en
      param call-retry-timer 20
      param service-name acd
      paramspace english location flash:
      param drop-through-option 2
      param second-greeting-time 30
      param max-time-vm-retry 1
      param voice-mail 2031
      paramspace english prefix en
      param max-time-call-retry 60
      param aa-pilot 2041
    !
    
    !--- Define the TCL configuration for the General group, using pilot number 2042 
    !--- and "drop-through-option 3". Extension 2032 is associated with the GDM for
    !--- the General group, so this is the voice mail destination.
    
    !
     service general-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param call-retry-timer 20
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2032
      param service-name acd
      param number-of-hunt-grps 1
      param drop-through-option 3
      paramspace english language en
      param handoff-string general-aa
      param max-time-vm-retry 1
      paramspace english location flash:
      param aa-pilot 2042
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the dial-peers for pilot number 2040 and attach the Hardware
    !--- TCL script to this number.
    
    !
    dial-peer voice 2040 voip
     destination-pattern 2040
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20400 voip
     service hardware-aa
     incoming called-number 2040
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    
    !--- Define the dial-peers for pilot number 2041 and attach the Software
    !--- TCL script to this number.
    
    !
    dial-peer voice 2041 voip
     destination-pattern 2041
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20410 voip
     service software-aa
     incoming called-number 2041
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    �
    
    !--- Define the dial-peers for pilot number 2042 and attach the General
    !--- TCL script to this number.
    
    !
    dial-peer voice 2042 voip
     destination-pattern 2042
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20420 voip
     service general-aa
     incoming called-number 2042
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad

为方案 2 变化形式 3 配置 Cisco Unity Express

下面的步骤总结了方案 2 变化形式 3 的 Cisco Unity Express 配置:

  1. 打开 Cisco Unity Express 脚本编辑器实用程序,并将脚本 s10-cue-aa-bacd.aef 调整为包含两级 AA 菜单。请参阅图 22。

    图 22 配置用于两级菜单的 Cisco Unity Express AA 脚本

    /image/gif/paws/67907/142220.jpg

  2. 选择 Voice Mail > Auto Attendant,并将新脚本 (S10A_CUE-AA-BACD-script.aef) 与引导号码 2100 关联。请参阅图 23。

    图 23 将脚本与引导号码关联

    /image/gif/paws/67907/142221.jpg

  3. 录制 AA 脚本所需的所有提示语。您可以用正确的文件名脱机录制这些 .wav 文件,并将其上载到 Cisco Unity Express,或者可以通过电话委托管理 (AVT) 进行录制。

  4. (可选)如果您使用 AVT,则 Cisco Unity Express 会分配一个通用文件名,您以后可以将其更改为需要的文件名。选择 Voice Mail > Prompts,然后单击系统文件名。

  5. (可选)在对话框中根据需要编辑文件名,然后单击 OK。“Voice Mail > Prompts”窗口此时在列表中显示更改后的文件名。

下面是带注释的 Cisco Unity Express CLI 配置,用于说明对与“为方案 2 配置 Cisco Unity Express”部分相关联的基本方案配置的 Cisco Unity Express 配置进行的更改和添加。


!--- Define a new AA with script s10a-cue-aa-bacd.aef.

!
ccn application s10a-cue-aa-bacd
 description "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10a_cue-aa-bacd-script.aef"
 parameter "S10_Hardware" "2040"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_Software" "2041"
 parameter "S10_General" "2042"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
!

!--- Associate AA pilot number 2100 with the new script.

!
ccn trigger sip phonenumber 2100
 application "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger

方案 3 - 将 Basic ACD 用作一级菜单,将 Cisco Unity Express AA 用作二级菜单

在本文档中介绍的第三个方案中,与方案 1 完全一样,传入呼叫定向到 Cisco CME AA(引导号码 2040)。唯一区别是,方案 3 只有两个 ACD 组(hardware 和 software),而主菜单中的第三个选项用于访问说明商店地点和营业时间的通告。

注意: 无法在 Cisco CME AA 中包含自由格式的通告。而是需要 Cisco Unity Express 自定义脚本。

使用方案 2 的变化形式可以得到同样的结果(从呼叫方的角度看)。提供方案 3 示例是为了说明另一种构造应用程序的方法,也就是将呼叫从 Cisco CME ACD 处理移交给 Cisco Unity Express AA。使用方案 2 的变化形式可能是生成此类应用程序的更典型方法。

方案 3 呼叫流

本部分中所述配置的呼叫流如图 24 所示。

图 24 方案 3 呼叫流

135510.jpg

方案 3 配置说明

来自 FXO 端口 (0/3/0) 的 PSTN 呼叫自动终止于 Cisco CME AA (2040)。

Cisco CME ACD 只有两个座席组(2020 和 2021)。菜单的选项 3 用于将呼叫移交给 Cisco Unity Express AA 以获得通告。当呼叫方选择选项 3 时,系统将呼叫方定向到 Cisco Unity Express AA 引导号码 (2100)(使用 param aa-hunt3 2100 命令的结果),而不是列出寻线组号码。

为方案 3 配置 Cisco CME

下面的示例显示了 Cisco CME 路由器的 CLI 配置:

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Point option 3 of the menu (aa-hunt3) to the 
!--- Cisco Unity Express AA (2100).

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2100
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

为方案 3 配置 Cisco Unity Express

下面的步骤总结了方案 3 的 Cisco Unity Express 配置:

  1. 打开 Cisco Unity Express 脚本编辑器实用程序,并编写自定义 Cisco Unity Express 脚本。请参阅图 25。

    图 25 商店营业时间和地点脚本

    /image/gif/paws/67907/135367.jpg

  2. 为 AA 脚本 (S11_CUE-AA-BACD-script.aef) 录制语音提示(在本例中名为 S11_Announcement.wav)。您可以用正确的文件名脱机录制此 .wav 文件,并将其上载到 Cisco Unity Express,或者可以通过电话委托管理 (AVT) 进行录制。

  3. (可选)如果您使用 AVT,则 Cisco Unity Express 会分配一个通用文件名,您以后可以将其更改为需要的文件名。选择 Voice Mail > Prompts,然后单击系统文件名。

  4. (可选)在对话框中编辑文件名,然后单击 OK。“Voice Mail > Prompts”窗口此时在列表中显示更改后的文件名(请参见图 26)。

  5. 选择 Voice Mail > Auto Attendant,然后打开步骤 2 中构建的 AA。选择 Script Parameters,并将提示文件名与脚本中正确的参数关联。

    图 26 显示提示选项的窗口

    135368.jpg

  6. 选择 Voice Mail > Auto Attendant,并将脚本与 AA 引导号码 2100 关联。请参阅图 27。

    图 27 显示脚本与 AA 引导号码关联的窗口

    /image/gif/paws/67907/135369.jpg

下面的示例显示了 Cisco Unity Express 系统的 CLI 配置:

cue# 
show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
groupname custservice create
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Define the AA script that will provide the announcement.

!
ccn application s11-cue-aa-bacd
 description "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s11_cue-aa-bacd-script.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the script with the 2100 AA pilot number.

!
ccn trigger sip phonenumber 2100
 application "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000

description "user26 mailbox"
end mailbox
end

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

单自动总机的 BACD 提示未播放

如果 BACD 文件位于 flash: //bacdprompt/ 文件夹中,则在 AA 服务中发出 paramspace english location flash: //bacdprompt/ 命令。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 67907