无线/移动 : "无线, LAN (WLAN)"

无线局域网控制器和轻量级AP上的QoS配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 12 月 20 日) | 反馈


目录


简介

本文档提供了配置示例,显示如何使用 Cisco 无线 LAN 控制器 (WLC) 和轻量接入点 (LAP) 在 Cisco 统一无线网络中配置服务质量 (QoS)。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 有关 LAP 和 Cisco WLC 配置的基本知识

  • 关于如何在有线网络中配置基本路由和 QoS 的知识

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 运行固件 4.0 版本的 Cisco 2006 WLC

  • Cisco 1000 系列 LAP

  • 运行固件版本 2.6 的 Cisco 802.11a/b/g 无线客户端适配器

  • 运行Cisco IOSï ¿  ½软件版本12.3(4)T1的Cisco3725路由器

  • 运行 Cisco IOS 软件版本 12.2(26) 的 Cisco 3640 路由器

  • 两台运行 Cisco IOS 软件版本 12.0(5)WC3b 的 Cisco 3500 XL 系列交换机

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

QoS 是指网络向一系列用户或应用提供对其他用户或应用有损害的更好或特别服务的能力。

使用 QoS,您可以在整个 LAN(包括 WLAN 和 WAN)上更高效地管理带宽。QoS 提供增强和可靠的网络服务的方式如下:

  • 支持重要用户和应用指定的专用带宽

  • 控制抖动和延迟(实时流量所需)

  • 管理并将网络拥塞减至最低

  • 整形网络流量以使数据流顺畅

  • 设置网络流量优先级

在过去,WLAN 主要用于传输低带宽、数据应用流量。目前,随着 WLAN 扩展到垂直(例如零售、金融和教育)和企业环境中,WLAN 用于传输高带宽数据应用(结合对时间敏感的多媒体应用)。此要求导致了无线 QoS 的必要性。

IEEE 802.11 标准委员会内的 IEEE 802.11e 工作组已完成标准定义。然而,对 802.11e 标准的采用正处于其早期阶段,如同许多标准一样具有许多可选组件。正如在 802.11i 中随着 802.11 安全性所出现的情况,行业组织(如 Wi-Fi 联盟)和行业领先者(如 Cisco)正在 WLAN QoS 中通过他们的 Wi-Fi 多媒体 (WMM) 和 Cisco Compatible Extensions (CCX) 程序定义关键需求。这通过他们的认证计划确保了主要功能的传递和互操作性。

Cisco 统一无线产品支持 WMM,这是一种基于由 Wi-Fi 联盟发布的 IEEE 802.11e 草案的 QoS 系统。

控制器支持四个 QoS 级别:

  • 白金服务/语音 — 确保高质量的无线语音服务。

  • 金牌服务/视频 — 支持高质量的视频应用。

  • 银牌服务/最大努力 — 支持客户机指定普通带宽。这是默认设置。

  • 铜牌服务/背景 — 为访客服务提供最低带宽。

当低带宽客户端可以设置为铜牌服务时,IP 语音 (VoIP) 客户端应设置为白金服务、金牌服务或银牌服务。

您可以使用 QoS 配置文件配置每个 QoS 级别的带宽,然后将配置文件应用于 WLAN。将配置文件设置推送到与该 WLAN 关联的客户端。此外,您可以创建 QoS 角色,以此为普通用户和访客用户指定不同的带宽级别。

有关如何使用 GUI 配置 QoS 配置文件的信息,请参阅使用 GUI 配置 QoS 配置文件

有关如何使用 CLI 配置 QoS 配置文件的信息,请参阅使用 CLI 配置 QoS 配置文件

有关 QoS 如何在 Cisco 统一无线网络中运行的详细信息,请参阅企业移动设计指南中的Cisco 统一无线 QoS 部分

本文档提供了配置示例,说明如何在控制器上配置 QoS 并与配置有 QoS 的有线网络进行通信。

第 3 层 QoS 数据包标记增强

Cisco 统一无线网络支持数据包的第 3 层 IP 差分服务代码点 (DSCP) 标记,数据包由 WLC 和 LAP 发送。此功能增强了接入点 (AP) 使用此第 3 层信息的方式,以确保数据包接收从 AP 到无线客户端的正确空中优先顺序。

在集中式 WLAN 体系结构中,通过轻量接入点协议 (LWAPP) 在 AP 和 WLC 之间通过隧道传输 WLAN 数据。为在整个隧道维护原始 QoS 分类,必须将封装数据包的 QoS 设置正确映射到外部隧道数据包的第 2 层 (802.1p) 和第 3 层 (IP DSCP) 字段。

如果原始数据包本身没有 DSCP 或 802.1P 值,则不可能在控制器和 LAP 之间对数据包进行 DSCP 标记。

控制器未应用其本身的 QoS。WLC 上的 QoS 支持给 WLC 提供能力,以应用在电线(或应用)上设置的相同优先级。

因此,WLC 或 AP 将采取的唯一操作是将原始数据包的值复制到 LWAPP 数据包的外部报头。WLC 上金牌服务、银牌服务和铜牌服务 QoS 选项的全部目的就是在 802.11e/802.1p UP 值和 IP DSCP 值之间进行适当的 QoS 转换,这取决于所使用的应用或标准。同样,WLC 上的 QoS 确保数据包可接收端到端的正确 QoS 处理。控制器不执行其自身的 QoS 行为。如果 QoS 已存在,并且需要将优先级应用到无线数据包,则控制器可按照支持进行操作。您无法使 QoS 仅存在于控制器上。

控制器不支持基于第 2 层 LWAPP 模式中的 WLAN 配置的 Class of Service (CoS) 标记值。推荐使用第 3 层 LWAPP,以便实施 Cos QoS。

这是 QoS 如何对 WLC 发挥作用的示例。应用(例如 CallManager)可能设置一个 QoS 值。因此,来自应用的原始数据包将由 IP 报头进行封装,该报头的 DCSP 值被设置为。现在,数据包到达控制器。接下来,数据包通过 SSID 测试。然而,如果您在为 QoS 配置文件铜牌服务配置的控制器上具有 SSID 测试,则从控制器到 AP 封装 LWAPP 数据包的数据包 IP 报头将具有铜牌服务值(尽管在来自应用的原始数据包附近的 IP 报头将有高优先级)。本文档假设由应用设置的 DCSP 和控制器上该 SSID 的 QoS 配置文件是相同的。但实际情况并非始终如此。

/image/gif/paws/81831/qos-wlc-lap1.gif

例如,当通过 WLAN 客户端发送 802.11e 流量时,它在其帧内具有用户优先级 (UP) 分类。AP 需要将此 802.11e 分类映射到传送帧的 LWAPP 数据包的一个 DSCP 值。这确保在数据包到 WLC 的途中给予了适当的优先级。在 LWAPP 数据包发送到 AP 时,WLC 上需要出现一个类似的进程。并且,需要一项机制在 non-802.11e 客户端的 AP 和 WLC 上对流量进行分类,因此也可以给予他们的 LWAPP 数据包适当的优先级。此表说明了如何在每个设备上处理数据包:

#~# UP (802.1p/802.11e) IP DSCP
1 控制器 接入点 它未将传入数据包的 DSCP 值转换为 AVVID 802.1p UP 值。如果 DSCP 值存在于数据包中,则透明地进入数据包。 从传入数据包复制 DSCP 值。
2 接入点 无线客户端 WMM 客户端:将传入 LWAPP 数据包的 DSCP 值转换为 802.11e UP 值。管制该值以确保其不超出已分配到该客户端的 WLAN QoS 策略所允许的最大值。将数据包放置在适用于 UP 值的 802.11 Tx 队列中。普通客户端:将数据包放置在已分配到该客户端的 WLAN QoS 策略的默认 802.11 Tx 队列中。 N/A(保留原始 DSCP 值)
3 接入点 控制器 N/A(接入点不支持 802.1Q/802.1p 标记) WMM 客户端:管制 802.11e UP 值以确保其不超出已分配到该客户端的 QoS 策略所允许的最大值;将该值转换为 DSCP 值。普通客户端:请使用已分配到该客户端的 QoS 策略的 802.11e UP 值;将该值转换为 DSCP 值。
4 控制器 以太网交换机 将传入 LWAPP 数据包的 DSCP 值转换为 802.1p UP 值。 N/A(保留原始 DSCP 值)

下表提供了 802.11e/802.1p UP 值和 IP DSCP 值之间发生的转换。由于 Cisco 的语音、视频和集成数据 (AVVID) 体系结构定义了从 802.1 UP 到 IP DSCP 的转换,并且 IEEE 定义了从 IP DSCP 到 802.11e UP 的转换,因此必须使用两套不同的转换。

基于 Cisco AVVID 802.1p UP 的流量类型 Cisco AVVID IP DSCP Cisco AVVID 802.1p UP IEEE 802.11e UP 备注
网络控制 -- 7 -- 仅为网络控制保留
互联网络控制 48 6 7 (AC_VO) LWAPP 控制
语音 46 (EF) 5 6 (AC_VO) 控制器:白金服务QoS配置文件
视频 34 (AF41) 4 5 (AC_VI) 控制器:金牌服务 QoS 配置文件
语音控制 26 (AF31) 3 4 (AC_VI) --
尽力 0 (BE) 0 3 (AC_BE) 0 (AC_BE) 控制器:银牌服务 QoS 配置文件 -
背景(Cisco AVVID 金牌服务背景) 18 (AF21) 2 2 (AC_BK) --
背景(Cisco AVVID 银牌服务背景) 10 (AF11) 1 1 (AC_BK) 控制器:铜牌服务 QoS 配置文件

注意: 在表里没有被提及的DSCP值的IEEE 802.11e上值通过考虑3个MSB位计算DSCP。例如, DSCP 32的(100 000 IEEE 802.11e上值在二进制)是MSB (100)的十进制已转换值,是4。802.11e上值DSCP 32是4。

网络设置

本文档使用以下网络设置:

  • 有线网络包括 Router1 和 Router2 这两个路由器,在它们之间运行 OSPF。有线主机包括一个 FTP 服务器 (F1)、一个语音客户端 (V1) 和一个视频客户端 (Vi1)。有线主机通过一个第 2 层交换机连接到网络,该交换机连接到路由器 R1 的快速以太网。

  • 无线网络通过 Router2 连接到网络,如所示。无线主机包括一个 FTP 客户端(已启用非 WMM)、一个语音客户端 V1(7920 个电话) 和一个视频客户端 Vi1(已启用 WMM)。

  • 应该给予语音数据包最高优先级,其次是视频数据包。必须给予 FTP 数据包最低优先级。

  • 在有线网络上,Weighted Random Early Detection (WRED) 用于实施 QoS。根据 DSCP 值对不同的流量类型进行分类和优先排序。在优先安排的数据包上实施 WRED。

  • 在无线网络上,必须为每种流量类型创建三个 WLAN,并启用适当的 QoS 配置文件。

    • WLAN 1 — FTP 客户端:铜牌服务 QoS 配置文件

    • WLAN 2 — 视频客户端:金牌服务 QoS 配置文件

    • WLAN 3 — 语音客户端:白金服务 QoS 配置文件

基本 IP 连接的设备和启用 QoS 都需要在有线网络和无线网络上进行配置。

/image/gif/paws/81831/qos-wlc-lap4.gif

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

为了配置此设置的设备,需要执行以下操作:

配置 QoS 的无线网络

在 WLC 上配置 QoS 之前,您必须配置 WLC 进行基本操作,并且在 WLC 中注册 LAP。本文档假设已配置 WLC 进行基本操作,并且已在 WLC 中注册 LAP。如果您是尝试设置 WLC 以对 LAP 执行基本操作的新用户,请参阅在无线 LAN 控制器 (WLC) 中注册轻量 AP (LAP)

在 WLC 中注册 LAP 之后,请完成以下任务,以便配置此设置的 LAP 和 WLC:

  1. 配置不同流量类别的 WLAN

  2. 启用 WLAN 的 QoS 配置文件

请完成这些步骤,以便在 WLC 上为语音客户端创建 WLAN:

  1. 要创建 WLAN,请从控制器 GUI 中单击 WLANs

  2. 要配置新的 WLAN,请单击 New

    在本示例中,WLAN 被命名为 VoiceClients,且 WLAN ID 为 1。

  3. 单击 Apply

    qos-wlc-lap5.gif

  4. “WLAN”>“Edit”窗口 中,定义特定于 WLAN VoiceClients 的参数。

    1. 对于 WLAN,请从“Interface Name”字段中选择相应的接口。

      此示例将语音接口映射到 WLAN VoiceClients

    2. 从服务质量 (QoS) 下拉菜单中选择 WLAN 相应的 QoS 配置文件。

      在本示例中,已选择白金服务 QoS 配置文件。这给语音 WLAN 提供最高优先级。

    3. 对于 7920 电话支持参数,请选择呼叫准入控制 (CAC) 的类型。

      此示例使用 AP CAC 限制

    4. 根据设计需求选择其他参数。

      在本示例中使用默认值。

    5. 单击 Apply

      qos-wlc-lap6.gif

      注意: 如果您的网络上使用 Cisco 7920 电话,请勿启用 WMM 模式。您无法在同一 WLAN 上同时启用 WMM 模式和客户端控制的 CAC 模式。当启用 AP 控制的 CAC 时,AP 发出一个 Cisco 专有的 CAC 信息元素 (IE),而且并未发出标准的 QBSS IE。

在 voice over WLAN 基础架构的部署不仅仅包括在 WLAN 上提供 QoS。一个语音 WLAN 需要考虑现场勘测覆盖范围需求、用户行为、漫游需求和准入控制。这在思科统一IP电话7900系列设计指南被覆盖。

同样,请创建视频客户端和 FTP 客户端的 WLAN。将视频客户端映射到动态接口视频,并将 FTP 客户端映射到动态接口 FTP。这些为屏幕截图:

注意: 本文档未讲解如何在 WLC 上创建 VLAN。有关如何在 WLC 上配置动态接口的信息,请参阅无线 LAN 控制器上的 VLAN 配置示例。

/image/gif/paws/81831/qos-wlc-lap7.gif

qos-wlc-lap8.gif

注意: WMM 的 WLAN 客户端支持并不意味着客户端流量自动受益于 WMM。寻求 WMM 益处的应用将相应的优先级分类分配到其流量,操作系统需要将该分类传递到 WLAN 接口。在专用设备(如 VoWLAN 话筒)中,这作为设计的一部分来完成。然而,如果您在通用平台(例如 PC)上实施,则必须在 WMM 功能使用获得好效果之前实施应用流量分类和 OS 支持。

对于视频客户端,已选择 QoS 配置文件金牌服务并启用了 WMM。对于 FTP 客户端,已选择铜牌服务作为 QoS 配置文件并禁用 WMM,因为在本示例中 FTP 客户端不支持 WMM。

qos-wlc-lap9.gif

qos-wlc-lap10.gif

注意: 当控制器处于第 2 层模式并且启用了 WMM 时,您必须将 AP 放置在中继端口上,以便允许它们加入控制器。

发出这些命令,以便使用 CLI 在 WLC 上配置 WLAN 和 QoS:

  • 发出 config wlan create <wlan-id> <wlan-name> 命令,以便创建一个新的 WLAN。对于 wlan-id,请输入一个 ID(从 1 到 16)。对于 wlan-name,请输入最多 31 个字母数字字符的 SSID。

  • 发出 config wlan enable <wlan-id> 命令,以便启用 WLAN。

  • 发出 config wlan qos wlan-id {bronze|银|金牌服务|platinum} 命令,以便将 QoS 级别分配到 WLAN。

  • 发出 config wlan wmm {disabled|允许|required} wlan-id 命令,以便启用 WMM 模式。

  • 对需要客户端控制 CA 的电话发出 config wlan 7920-support client-cac-limit {enabled|disabled} wlan-id 命令。

  • 对需要 AP 控制 CAC 的电话发出 config wlan 7920-support ap-cac-limit {enabled|disabled} wlan-id 命令。

配置 QoS 的有线网络

为了配置此设置的有线网络,您需要配置路由器的基本连接,并在有线网络中启用 QoS。OSPF 用作单播路由协议。

WRED 功能用于在有线网络中实施 QoS。DiffServ 兼容的 WRED 功能使 WRED 能够在计算数据包的丢弃概率时使用 DSCP 值。

这些是路由器 R1 和 R2 的配置:

Router1
Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP

!--- Classifies FTP Packets based on Access List 103.

  match access-group 103
class-map match-all Video

!--- Classifies Video Packets based on Access List 102.

  match access-group 102
class-map match-all Voice

!--- Classifies Voice Packets based on Access List 101.

  match access-group 101
!
!
policy-map Marking-For-FTP

!--- Sets DSCP value af11 for FTP packets.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice

!--- Sets DSCP value ef for Voice packets.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video

!--- Sets DSCP value af41 for Video packets.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based 

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice

!--- Applies the policy Marking-For-Voice to the interface.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video

!--- Applies the policy Marking-For-Video to the interface.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP

!--- Applies the policy Marking-For-FTP to the interface.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!--- Access list used to classify Voice packets.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any

!--- Access list used to classify Video packets.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any

!--- Access list used to classify FTP packets.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router2
Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

验证与故障排除

配置无线和有线网络的基本连接并且实施 QoS 之后,根据每种流量类型配置的策略对数据包进行分类、标记并发送。

QoS 功能的应用在负载较轻的网络中可能不容易检测到。随着网络上的负载增加,QoS 功能开始影响应用性能。QoS 在可接受范围内保持所选流量类型的延迟、抖动和损失。

对于启用 WMM 的视频客户端:

当位于有线端的视频客户端将数据发送到位于无线端的视频客户端时,发生以下一系列事件:

  1. 在 Router1 上的 FastEthernet 接口处,Marking-For-Video 策略应用于视频数据包,并且使用 DSCP 值 AF41 标记该数据包。

  2. 标记的视频数据包通过 Router1 上的串行接口 S3/0 和 Router2 上的 S0/0。这是根据 WRED 配置的阈值检查数据包的丢弃概率之处。当平均队列长度达到最低阀值(此例中视频数据包为 40 个数据包)时,WRED 随机丢弃具有 DSCP 值 AF41 的一些数据包。同样,当平均队列长度超出最大阀值(此例中视频数据包为 50 个数据包)时,WRED 丢弃具有 DSCP 值 AF41 的所有数据包。

  3. 视频数据包通过 Router2 上的 fastethernet 到达 WLC 之后,WLC 立即将传入数据包的 DSCP 值转换为 AVVID 802.1p UP 值,并将 DSCP 值从传入数据包复制到 LWAPP 数据包,如此处所示。在本示例中,DSCP 值 AF41 被转换为相应的 802.1p 值 4。

    qos-wlc-lap11.gif

  4. 当数据包到达 LAP 时,LAP 将传入 LWAPP 数据包的 DSCP 值转换为 802.11e UP 值,并管制该值,以确保其不超出已分配到该客户端的 WLAN QoS 策略所允许的最大值。然后 LAP 将数据包放置在适用于 UP 值的 802.11 Tx 队列中。在本示例中,DSCP 值 AF41 被转换为相应的 802.11e UP 值 5。

    /image/gif/paws/81831/qos-wlc-lap12.gif

当位于无线端的视频客户端将数据发送到有线端时,发生以下一系列事件:

  1. 当已启用 WMM 的客户端发送数据包到 LAP 时,LAP 管制 802.11e UP 值,以确保其不超出已分配到该客户端的 QoS 策略所允许的最大值。然后,它将该值转换为 DSCP 值。在本示例中,已通过 QoS 配置文件金牌服务配置视频 WLAN,其 802.11e UP 值为 4。该值被转换为相应的 DSCP 值 AF41 并发送到控制器。

    /image/gif/paws/81831/qos-wlc-lap13.gif

  2. 如图所示,控制器将传入 LWAPP 数据包的 DSCP 值转换为 802.1p UP 值,原始 DSCP 值也在未更改的情况下被发送。

    /image/gif/paws/81831/qos-wlc-lap14.gif

  3. 位于 Router2 上 fastethernet 处具有 DSCP 值 af41 的数据包通过 Router2 和 Router1 上的串行接口,并到达位于有线端的视频客户端。当数据包通过串行接口时,根据 WRED 配置的阈值检查该数据包的丢弃概率。

对于禁用 WMM 的 FTP 客户端:

当位于有线端的 FTP 服务器将数据发送到位于无线端的 FTP 客户端时,发生以下一系列事件:

  1. 在 Router1 上的 FastEthernet 接口处,Marking-For-FTP 策略被应用于 FTP 数据包,并且使用 DSCP 值 AF11 标记该数据包。

  2. 标记的 FTP 数据包通过 Router1 上的串行接口 s3/0 和 Router2 上的 S0/0。这是根据 WRED 配置的阈值检查数据包的丢弃概率之处。当平均队列长度达到最低阀值(此例中 FTP 数据包为 30 个数据包)时,WRED 随机丢弃具有 DSCP 值 AF11 的一些数据包。同样,当平均队列长度超出最大阀值(此例中 FTP 数据包为 40 个数据包)时,WRED 丢弃具有 DSCP 值 AF11 的所有数据包。

  3. FTP 数据包通过 Router2 上的 fastethernet 到达 WLC 之后,WLC 将传入数据包的 DSCP 值转换为 AVVID 802.1p UP 值,并将 DSCP 值从传入数据包复制到 LWAPP 数据包,如此处所显示。在本示例中,DSCP 值 AF11 被转换为相应的 802.1p 值 1。

  4. 当数据包到达 LAP 时,LAP 将数据包放置在已分配到该客户端的 WLAN QoS 策略的默认 802.11 Tx 队列中。在本示例中,数据包被放置在铜牌服务 QoS 配置文件的队列中。

当位于无线端的 FTP 客户端将数据发送到无线端时,发生以下一系列事件:

  1. 当位于无线网络的 FTP 客户端发送数据包到 LAP 时,LAP 使用已分配到该客户端的 QoS 策略的 802.11e UP 值。然后,LAP 将该值转换为 DSCP 值并将数据包发送到控制器。由于 FTP 客户端属于 QoS 配置文件铜牌服务,IEEE 802.11e UP 值 1 被转换为 DSCP 值 AF11。

  2. 如图所示,控制器将传入 LWAPP 数据包的 DSCP 值转换为 802.1p UP 值,原始 DSCP 值也在未更改的情况下被发送。然后通过第 2 层交换机将数据包转发到 Router2。

  3. 位于 Router2 上 fastethernet 处具有 DSCP 值 AF11 的数据包通过 Router2 和 Router1 上的串行接口,并到达位于有线端的视频客户端。当数据包通过串行接口时,根据 WRED 配置的阈值检查该数据包的丢弃概率。

当语音数据包从有线网络传输到无线网络时,发生类似过程,反之亦然。

故障排除命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

您可以在路由器上发出这些 Cisco IOS 命令,以便排除故障并验证您的 QoS 配置:

  • show queue {interface-name interface-number} — 列出了有关在接口处的队列中等待的数据包的信息。

  • show queueing random-detect interface {interface-name interface-number} — 列出了有关接口上队列工具的配置和统计信息。

  • show policy-map interface {interface-name interface-number} — 显示了连接到接口的输入和输出策略的统计信息和配置。确保在相应的 EXEC 模式中使用此命令。

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • debug qos set — 显示了有关 QoS 数据包标记的信息。

在 WLC 上发出此命令,以便查看 QoS 配置文件设置:

  • show qos {bronze/silver/gold/platinum} — 提供了有关 WLAN 配置的 QoS 配置文件的信息。

    以下是 show qos 命令的输出示例:

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • show wlan <WLAN-ID> — 显示有关 WLAN 的信息。以下为示例输出:

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

相关信息


Document ID: 81831