无线/移动 : "无线, LAN (WLAN)"

无线局域网控制器模块(WLCM)配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 19 日) | 反馈


目录


简介

通过 Cisco WLAN 控制器 (WLC) 模块 (WLCM),Cisco ISR 和 Cisco 3700 系列路由器能够管理多达六个无线 LAN (WLAN) 接入点 (AP),并且简化了部署和管理 WLAN。它等同于具有 NM 外形规格的 Cisco WLC 2006。唯一的区别是,NM-WLC(WLCM 模块)只有一个快速以太网端口从内部连接到主机路由器上,而 NM 面板上的外部快速以太网端口是禁用且不可用的。本文档介绍了如何在不同情况下配置 WLCM。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 有关轻量接入点协议 (LWAPP) 的基本知识

  • WLC 和轻量 AP (LAP) 的基本知识

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

基本配置

将 NM-WLC 设想为只具有一个快速以太网 (FE) 接口(称为端口 1)的外部 WLC (2006),该接口从内部连接到路由器的快速以太网接口(名为 WLAN 控制器接口)。此图表显示了一个示例。

注意: Cisco WLC 模块面板上的外部快速以太网端口不受支持。

/image/gif/paws/70530/nm-wlc-config-guide-1.gif

与模块连接的常用方式是使用 service-module session 命令在路由器内进行内部连接。

  1. 将 NM-WLC 模块插入到路由器上,并启动带有有效映像的路由器。

    任意映像(从 ipbase 到 adventerprisek9)均可支持 NM-WLC 模块。Cisco IOS 软件版本 12.4(2)XA1(路由器软件)引入了此功能。控制器固件版本最低应为 3.2.78.0(控制器软件)。

  2. 配置接口 WLAN 控制器 1/0 上的 IP 地址;假设将模块插入路由器的插槽 1。如果其处于关闭状态,请执行 no shut 命令。

    c2811#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    c2811(config)#
    c2811(config)#interface wlan-controller 1/0
    c2811(config-if)#ip address 192.168.99.254 255.255.255.0
    c2811(config-if)#no shut
    c2811(config-if)#end
    c2811#
  3. 在特权 EXEC 提示符处,使用 service-module session 命令在控制器上打开一个新会话。

    c2811#service-module wlan-controller 1/0 session 
    Trying 192.168.99.254, 2066 ... Open

    注意: WLCM 模块的 Cisco IOS 命令在运行 Cisco IOS 软件版本 12.4(15) T 或更高版本的路由器上会有所变化。有关更多信息,请参阅配置路由器中的 Cisco WLCM

如果在没有事先配置的情况下首次启动控制器,则其将自动进入 CLI 向导,向您询问一系列配置信息。无法绕过此向导,您必须输入其询问的所有信息。事先了解您希望得到怎样的配置外观有助于您回答这些问题。询问的某些信息是不相关的而且不会立即使用,但是您仍需提供这些信息,因为该向导不接受无效输入,而且也不能绕过。输出看起来与下表中的输出相似:

Cisco 控制器
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_ff:f6:a0]: NMWLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
 
Management Interface IP Address: 192.168.99.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1
Management Interface DHCP Server IP Address: 192.168.99.24
 
AP Manager Interface IP Address: 192.168.99.25
 
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.99.24): 192.168.99.24
 
Virtual Gateway IP Address: 1.1.1.1
 
Mobility/RF Group Name: mg1
 
Network Name (SSID): wl15
Allow Static IP Addresses [YES][no]: no
 
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
 
Enter Country Code (enter 'help' for a list of countries) [US]: US
 
Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: YES
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: no
Configuration saved!
Resetting system with new configuration...

完成配置后,其将自动重启新的配置并且在 User: 提示符处停止,此位置是提示您提供用户名和口令的地方。此时将出现 (Cisco Controller) > prompt。

User:admin
Password:*****
(Cisco Controller) >

当您处于控制器提示符时,您可以进一步配置或修改您通过 CLI 向导执行的操作。请使用,以获得帮助。

为切换回路由器,请按 ctrl+shift+6,松开,然后按 x。然后您将会看到路由器提示符。会话保持完整性,因此,如果按 Enter,它将把您带回到控制器。如果想要完全清除会话,请在路由器提示符中输入 disconnect

即使控制器只有一个物理端口(称为端口 1),您也可以在其上面创建任何数量的逻辑接口(静态或动态),并且这些接口可以带有 VLAN 标记或不带标记。默认情况下,控制器有两个静态且无标记接口:

  • 管理接口

  • AP-MANAGER 接口

管理接口用于管理目的。如果选择使用基于 Web 的 GUI 界面来管理 WLCM,您需要在管理接口上配置 IP 地址,并使其能够从计划对其进行管理的工作站中获得。

注意: 默认情况下,控制器上的 HTTP 服务器处于禁用状态,但是安全 HTTP 处于启用状态。因此,控制器管理 IP 地址的 URL 必须是 https://mgt-ip-address。

控制器使用 AP 管理器接口与 LAP 进行通信。因为管理和 AP 管理器接口均无标记,所以它们必须与路由器上的接口 WLC 位于相同的 IP 子网中。

(Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254
(Cisco Controller) config>interface address ap-manager 
                           192.168.99.25 255.255.255.0 192.168.99.254

您可以用两种方式配置 CLI。一种方式是使用正常提示(通过在 CLI 之前加上 config)。另一个方式是使用 config 命令转到 config 提示符,然后不带 config 一词发布 CLI。例如:

 (Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254

(Cisco Controller)>config interface address management 
                        192.168.99.24 255.255.255.0 192.168.99.254

此示例配置带有 IP 地址 192.168.99.24/24 的管理接口,并且将默认网关定义为 192.168.99.254。

注意: 基于管理和 AP 管理的默认网关应该指向 WLCM 以太网端口的 IP 地址。

注意: 通过向导配置好这些 IP 地址后,您就不需要这些命令了。这只是向您表明,两个 IP 地址属于相同子网,并且这也可通过命令行进行配置。

在两种情况下,最后的 IP 地址 (192.168.99.254) 是默认网关 IP 地址。因为控制器的唯一的出口是通过主机路由器,默认网关应该是路由器上的接口 WLAN 控制器 1/0 的 IP 地址。使用此配置,您可以从路由器 ping 到控制器的管理接口 IP 地址。

c2811#ping 192.168.99.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.24, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
c2811# 

示例 1 - 与路由器板载快速以太网/千兆以太网连接的 AP 的基本配置

当与路由器的板载千兆以太网接口 (g0/0) 连接的 LAP 启动后,它将发送 DHCP 请求以获取 IP 地址。在本示例中,路由器被配置为带有 192.168.100.0/24 网络 IP 地址池的 DHCP 服务器。因此,LAP 获得 IP 地址 192.168.100.101。DHCP offer 还告知 LAP(通过选项 43),控制器 IP 地址为 192.168.99.24(控制器的管理 IP 地址)。现在 LAP 发送控制器发现消息单播至 192.168.99.24。控制器提供注册,因此 LAP 向控制器登记。

请使用 show ap summary 命令,以便查看向 WLCM 登记的 LAP。

(Cisco Controller) >show ap summary

AP Name             Slots  AP Type    MAC Addr           Location          Port
------------------  -----  ---------  -----------------  ---------------- 	----
AP11                 2     Cisco      00:0b:85:01:03:30                   	1

在本示例中,控制器配置有两个 WLAN(wl15 和 wl16),如本文档稍后所述。

客户端 C1 向 SSID wl15 发送关联请求。它与路由器上配置的 DHCP 服务器关联并且获得 IP 地址 192.168.15.101 和默认网关 192.168.15.1。

客户端 C2 也向 SSID wl16 发送关联请求。它会进行关联并且获得 IP 地址 192.168.16.101 和默认网关 192.168.16.1。现在有两个不同子网中的两个客户端。它们之间的通信可以通过在其两个子接口(wlc1/0.15 和 wlc1/0.16)之间执行路由的路由器实现,如下列图表显示:

本文档的控制器配置部分讨论了在设备上进行此设置所要求的配置。

/image/gif/paws/70530/nm-wlc-config-guide-2.gif

控制器配置

此部分讨论控制器模块要求的配置。

  1. 创建在 VLAN 15 中名为 vl15 和在 VLAN 16 中名为 vl16 的动态接口。

    (Cisco Controller) >config interface create vl15 15
    (Cisco Controller) >config interface create vl16 16
    
  2. 为这些 VLAN 接口分配 IP 地址、网络掩码和默认网关。

    (Cisco Controller) >config interface address vl15 
                                  192.168.15.254 255.255.255.0 192.168.15.1
    
    (Cisco Controller) >config interface address vl16 
                                  192.168.16.254 255.255.255.0 192.168.16.1
    

    注意: 动态接口的默认网关必须是路由器上相应 VLAN 的子接口 IP 地址。

  3. 创建两个 WLAN 1516,分别对应 SSID wl15wl16

    (Cisco Controller) >wlan create 15 wl15
    (Cisco Controller) >wlan create 16 wl16
    
  4. 将这些 WLAN 与您(在有线侧)创建的相应 VLAN 接口绑定。

    (Cisco Controller) >wlan interface 15 vl15
    (Cisco Controller) >wlan interface 16 vl16
    
  5. 为您创建的动态接口配置 DHCP 服务器 IP 地址,以转发客户端 DHCP 请求。

    因为 DHCP 服务器配置在路由器上,所以应该指向路由器的相应子接口 IP 地址。如果您有一个外部 DHCP 服务器,则其应该指向该 IP 地址。

    (Cisco Controller) >interface dhcp vl15 192.168.15.1
    (Cisco Controller) >interface dhcp vl16 192.168.16.1
    
  6. 默认情况下,认证方法是 dot1X,并且已启用。为了与开放式身份验证一起使用,请使用此命令为两个 WLAN 禁用此方法:

    (Cisco Controller) >wlan security 802.1X disable 15
    (Cisco Controller) >wlan security 802.1X disable 16
    

此配置可以根据您的需求进行扩展,例如更多 VLAN/WLAN、身份验证(轻量级可扩展身份认证协议 [LEAP],EAP)、QoS 等等。

注意: 对于 WLCM,LAP 很难通过 IP 子网广播发现 WLCM。这是由于 WLCM 在底板上的集成方式,并且 LAP 和直接连接到 LAP 上的 2800 路由器的千兆接口需要是相同子网。如果您想成功执行 IP 子网广播发现,请使用 ip helper-address/ip forward-protocoludp 12223 命令。一般来说,这些命令的目的是潜在地转发/中继任意 IP 广播帧。只需将其中继并发送至 WLC 管理接口即可使 WLC 响应回到 LAP。

注意: 一旦管理接口配置了 IP 地址、网络掩码和网关信息,则此部分中的所有控制器配置可以通过使用 Web 浏览器进行 GUI 访问轻松完成。并且,在网络上使您的浏览器站点能够达到控制器所需的任意路由均已完成。打开 GUI 页的 URL 为 https://192.168.99.24。

路由器配置

完成这些步骤,以便对此部分描述的路由器进行配置。

  1. 配置连接在 LAP 上的路由器的接口 G0/0。

  2. 为接口 WLAN 控制器 1/0 配置 192.168.99.0/24 网络的 IP 地址,为 VLAN 15 中的子接口 w1/0.15 和 VLAN 16 中的子接口 w1/0.16 配置网络 192.168.15.0/24 和 192.168.16.0/24 的 IP 地址。

  3. 使用几个定义的池在路由器上配置 DHCP 服务器。

    • 池 lwapp-ap 将 IP 地址从 192.168.100.0/24 网络分配到 AP,192.168.100.0/24 网络还包括通知控制器 IP 地址的 AP 进行联系的 DHCP 选项 43。

    • 池客户端 15 将 IP 地址从 192.168.15.0/24 网络分配到 VLAN 15 中的客户端(有线/无线)。

    • 池客户端 16 将 IP 地址从 192.168.16.0/24 网络分配到 VLAN 16 中的客户端(有线/无线)。

此输出显示路由器上的配置:

路由器
!		
interface GigabitEthernet0/0								
Description: Connected to AP							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 duplex auto									
 speed auto
									
!										
ip dhcp excluded-address 192.168.100.1 192.168.100.100
!
ip dhcp pool lwapp-ap

!--- Creates a DHCP pool for the LAP.

network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15

!--- Creates a DHCP pool for users that connect to WLAN wl15.

network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16

!--- Creates a DHCP pool for users that connect to WLAN wl16.

network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!										
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15

!--- Creates a sub-interface for VLAN 15.
						
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16

!--- Creates a sub-interface for VLAN 16.
					
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0							
!

示例 2 - 与外部交换机连接的 AP 的 VLAN 配置

插入路由器的 WLCM 在逻辑上可视为等同于通过以太网接口连接到路由器上的外部 WLC,如下列图表所示。假设网络模块插入路由器的插槽 1,典型的连接包括:

  • 通过接口 WLAN 控制器 1/0 连接到路由器上的 WLCM。

  • 连接到路由器板载千兆以太网接口 G0/0 的第 2 层交换机。

  • 连接到交换机上的轻量 AP 协议 (LWAPP) AP。

  • 与 AP 关联的无线客户端 C1 和 C2,一个在 WLAN 15 中,另一个在 WLAN 16 中。

此示例显示如何在控制器上创建两个无线 VLAN 或 WLAN(wl15 和 wl16),如何将其映射到相应的有线侧 VLAN 15 和 VLAN 16,以及路由器如何通过 dot1Q 子接口完成 VLAN 15 和 VLAN 16 之间的路由。

在路由器上,在 WLC 接口(处于接口配置模式)下为每个 VLAN 创建一个子接口,将其分配到相应的 VLAN,并且从各自的子网配置 IP 地址。

有关在设备上进行此设置所要求的配置,请参见本文档的控制器配置部分。

/image/gif/paws/70530/nm-wlc-config-guide-3.gif

控制器配置

为此设置完成控制器模块中的以下步骤。

  1. 在控制器上,对于每个 VLAN,请在相应的 VLAN 中创建一个动态接口,并从各自的子网中分配一个 IP 地址、网络掩码和默认网关。

    (Cisco Controller)#configure interface create vl15 15
    (Cisco Controller)#configure interface create vl16 16
    
    (Cisco Controller)#configure interface address 
                      Vl15 192.168.15.254 255.255.255.0 192.168.15.1
    (Cisco Controller)#configure interface address 
                      Vl16 192.168.16.254 255.255.255.0 192.168.16.1
    
  2. 创建两个 WLAN 1516,分别对应 SSID wl15wl16

    (Cisco Controller)#configure wlan create 15 wl15
    (Cisco Controller)#configure wlan create 16 wl16
    
  3. 将这些 WLAN 与您(在有线侧)创建的相应 VLAN 接口绑定。

    (Cisco Controller)#configure wlan interface 15 Vl15
    (Cisco Controller)#configure wlan interface 16 Vl16
    
  4. 在路由器上指向各自子接口 IP 地址的控制器接口(针对无线客户端)上配置 DHCP 服务器信息。

    (Cisco Controller)#configure interface dhcp vl15 192.168.15.1
    (Cisco Controller)#configure interface dhcp Vl16 192.168.16.1
    

进行这些配置后,WLAN 中的两个无线客户端应该启动并正在运行,假设还完成了适当的安全配置。要从 WLAN 15 中的客户端发送到 WLAN 16 中的客户端的数据流在路由器上的子接口 w1/0.15 和 w1/0.16 之间进行路由。相同的配置可以扩展为任何数量的 VLAN,可达控制器的受支持 VLAN 的最大数量 (16)。

交换机配置

假设所有有线客户端均连接到通过用于 LAN 间路由的接口 Gig 1/0/1 中继到路由器的交换机(例如,cat3750),将 LWAPP AP 连接到交换机的接口 F1/0/1,并为其配置 VLAN 100。

Interface Fastethernet 1/0/1
Description: Connected to LWAPP AP
Switchport access vlan 100
Switchport mode access
!
Interface Gigabitethernet 1/0/1
Description: Connected to Router
Switchport trunk encapsulation dot1Q
Switchport mode trunk

路由器配置

在路由器上完成这些步骤。

  1. 配置连接到交换机上的接口 G0/0,此接口还是有线 LAN 的 VLAN 间路由所需的子接口。

  2. 为接口 WLAN 控制器 1/0 配置 192.168.99.0/24 网络的 IP 地址,为 VLAN 15 中的子接口 w1/0.15 和 VLAN 16 中的子接口 w1/0.16 配置网络 192.168.15.0/24 和 192.168.16.0/24 的 IP 地址。

  3. 使用几个定义的池在路由器上配置 DHCP 服务器。

    • 池 lwapp-ap 将 IP 地址从 192.168.100.0/24 网络分配到 AP,192.168.100.0/24 网络还包括通知控制器 IP 地址的 AP 进行联系的 DHCP 选项 43。

    • 池客户端 15 将 IP 地址从 192.168.15.0/24 网络分配到 VLAN 15 中的客户端(有线/无线)。

    • 池客户端 16 将 IP 地址从 192.168.16.0/24 网络分配到 VLAN 16 中的客户端(有线/无线)。

    注意: AP 和客户端需要独立的池。

路由器
ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
								
ip dhcp pool client-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 

ip dhcp pool client-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet0/0
Description: Connected to AP
No ip address							
 load-interval 30									
 duplex auto									
 speed auto
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0	
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0

注意: 您还可以在控制器上运行客户端的 DHCP 服务。但是建议在路由器上运行,因为控制器不是完善的 DHCP 服务器,而且不能传递 Cisco CallManager Express 等类似应用程序所需的 TFTP 服务器等选项。

使用此配置,AP 能获得 IP 地址、发现控制器和向控制器登记。两个无线客户端 C1 和 C2 应该能够与 AP 产生关联,并从各自的子网获得 IP 地址。

示例 3 - 与路由器上的 EtherSwitch 连接并与来自有线和无线局域网的相应 VLAN 合并的 AP 配置

在此方案中,有插入 ISR HWIC 插槽 0 的 EtherSwitch HWIC 以及插入 NM 插槽 1 的 NM-WLC。有线客户端 C3 连接至带有 IP 地址 192.168.15.102 的 VLAN 15 中的接口 F0/0/1,有线客户端 C4 被连接到带有 IP 地址 192.168.16.102 的 VLAN 16 中的 F0/0/2。

LWAPP AP 连接到带有 IP 地址 192.168.100.1 的 VLAN 100 中的接口 F0/0/0。路由器被配置为 DHCP 服务器,用于向 AP 提供 IP 地址。例如,AP 通过选项 43 收到 IP 地址 192.168.100.101、默认网关 192.168.100.1 和控制器 IP 地址 192.168.99.24。

注意: 控制器要求的配置类似于在前一个示例中介绍的配置,在此不进行讨论。剩余部分提供路由器要求的配置。

/image/gif/paws/70530/nm-wlc-config-guide-4.gif

无线客户端 C1 和 C2 分别与 wl15 和 wl16 中的 LAP 关联。无线客户端 C1 和 C2 还获得配置在路由器上的 DHCP 服务器或带有 IP 池的外部 DHCP 服务器为这些子网所分配的 IP 地址 192.168.15.101 和 192.168.16.101。如果 DHCP 服务器为外部服务器,则在相应的 VLAN 和子接口上必须配置 IP 帮助程序地址。从路由器的角度看,它具有由接口 VLAN 15 和接口 VLAN 16 所代表的两个有线 VLAN,以及由路由器的 WLC 接口下的 dot1Q 子接口 w1/0.15 和 w1/0.16 所代表的两个无线 VLAN。

为了将有线 VLAN 15 和无线 WLAN 15 折叠在一起,请配置普通网桥组(例如,网桥组 15)下的接口 VLAN 15 和接口 w1/0.15。同样地,为了将有线 VLAN 16 和无线 WLAN 16 折叠在一起,请配置普通网桥组(例如,网桥组 16)下的接口 VLAN 16 和接口 w1/0.16。进行此配置后,相应的有线和无线 VLAN 属于同一 IP 子网 192.168.15.0/24 和 192.168.16.0/24,并且能在网桥组内互相通信。但是为了使两个不同网桥组中的客户端能够互相通信,请启用路由器上的集成路由和桥接 (IRB),从而使它们通过各自网桥组中的 BVI 接口进行通信。

注意: 此配置基于这样一种假设,即您的路由器上具有用于有线 LAN 的 EtherSwitch HWIC 或 NM-ESW。如果您使用 EtherSwitch 服务模块 (NME-ESW) 而非 NM/HWIC,则 VLAN 接口由路由器的千兆以太网接口下相应的 dot1Q 子接口所取代,其余配置保持相同。

路由器配置
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 


interface FastEthernet0/0/0								
Description: Connected to AP
Switchport mode access
Switchport access vlan 100
!
interface FastEthernet0/0/1								
Description: Connected to C3
Switchport mode access
Switchport access vlan 15
!
interface FastEthernet0/0/2								
Description: Connected to C4
Switchport mode access
Switchport access vlan 16
!
Interface vlan 15
Bridge-group 15
!
Interface vlan 16
Bridge-group 16

Interface vlan 100							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

示例 4 - 与 NM-WLC 下的无线 VLAN 合并的 NME-ESW 下的有线 VLAN 的配置

考虑这样一种情景,即您将 EtherSwitch 服务模块 (NME-ESW) 插入到 ISR NM 插槽 2,将 NM-WLC 插入到 NM 插槽 1。NME-ESW 可被视为等同于通过千兆以太网链接连接到路由器上的外部交换机。有线客户端 C3 连接到带有 IP 地址 192.168.15.102 的 VLAN 15 中的接口 F0/0/1,有线客户端 C4 连接到带有 IP 地址 192.168.16.102 的 VLAN 16 中的接口 F0/0/2。

LWAPP AP 连接到 VLAN 100 中的接口 F0/0/3。EtherSwitch 内部接口 (G1/0/2) 从内部连接到带有接口千兆以太网 2/0 的主机路由器。因为在交换机中有不止一个 VLAN,所以交换机和路由器之间的内部链路应被配置为中继。路由器被配置为带有几个池的 DHCP 服务器,以便将 IP 地址提供给 AP 和客户端(有线和无线)。

AP 通过选项 43 获得 IP 地址 192.168.100.101、默认网关 192.168.100.1 和控制器 IP 地址 192.168.99.24,发现控制器并向控制器登记。无线客户端 C1 和 C2 与 WLAN 15 和 16 中的 LAP 关联,并且分别获得 IP 地址 192.168.15.101 和 192.168.16.101。VLAN 15 和 16 中的有线客户端 C3 和 C4 也从 DHCP 服务器中获得 IP 地址 192.168.15.102 和 192.168.16.102。

为了合并有线 WLAN 15 和无线 VLAN 15,请配置普通网桥组 15 下的接口 G2/0.15 和接口 w1/0.15。同样地,配置网桥组 16 下的接口 G2/0.16 和 W1/0.16。这两个网桥组通过它们的 BVI 接口 BVI15 和 BVI16 互相通信。

控制器配置与早期方案保持相同。

/image/gif/paws/70530/nm-wlc-config-guide-5.gif

路由器配置

路由器配置
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet2/0								
Description: Internally connected to Etherswitch
IP address 20.0.0.1 255.255.255.0
load-interval 30
!
Interface GigabitEthernet2/0.100
Encapsulation dot1Q 100							
 ip address 192.168.100.1 255.255.255.0						

Interface GigabitEthernet2/0.15
Encapsulation dot1Q 15							
 Bridge-group 15
!
Interface GigabitEthernet2/0.16
Encapsulation dot1Q 16							
Bridge-group 16									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

交换机配置

使用 service-module session 命令,打开一个从路由器到 EtherSwitch 服务模块的会话。一旦在交换机上,请配置交换机,如以下输出显示:

!
Interface GigabitEthernet 1/0/2
Description: Internally connected to router G2/0 interface.
Switchport trunk encapsulation dot1Q
Switchport mode trunk

!
Interface Fastethernet 0/0/1
Description: Connected to Client C3 in vlan 15
Switchport access vlan 15
Switchport mode access
!
Interface Fastethernet 0/0/2
Description: Connected to Client C4 in vlan 16
Switchport access vlan 16
Switchport mode access
!
Interface Fastethernet 0/0/3
Description: Connected to Client LWAPP AP in vlan 100
Switchport access vlan 100
Switchport mode access

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 70530