拨号和接入 : 按需拨号路由 (DDR)

了解空闲超时以及故障排除

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

影响拨号链路的常见问题之一是意外的呼叫中断。导致意外呼叫中断的原因既包括硬件故障,也包括 Telco 内出现的问题。但是,最常见的原因之一是空闲超时过期。

另一个常见的空闲超时问题是由于空闲超时从未过期,导致链路没有断开。这样会导致基于呼叫连接时间收取的长途连接话费较高。

本文档主要介绍如何配置空闲超时和解决相关问题。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

常见问题和症状

下列症状可能表示与空闲超时相关的问题:

  • 建立连接后呼叫每两分钟(120 秒)断开一次。

    此类断开通常是由于启用了默认的 120 秒空闲超时,但相关流量定义尚未定义或尚未应用于接口。虽然 dialer in-band 命令在接口中启用了默认的 120 秒空闲超时,但该值并不显示在 show running-configuration 输出中。由于不显示默认的空闲超时,因此通常会错误地判断为在 120 秒后断开连接。

  • 建立连接后呼叫每 x 分钟断开一次。

    此类断开通常是由于配置了空闲超时(使用 dialer idle-timeout 命令),但相关流量定义尚未定义或尚未应用于接口。

  • 呼叫过早断开。这可能是由于结合了较低的拨号程序空闲超时值或相关流量定义受限。

  • 呼叫不断开。这可能是由于拨号程序空闲超时值较高并且相关流量定义不精确所致。

空闲超时

主要空闲超时命令是 dialer idle-timeout,它是用于异步、异步组、ISDN 和拨号程序接口的接口配置命令。(另一个常用命令是 ppp timeout idle,它可用于虚拟访问接口,将不在本文档中介绍。有关 ppp timeout idle 的详细信息,请参阅文档 PPP 每用户超时。)

dialer idle-timeout {x} 命令可以在任何支持拨号程序的接口上配置。空闲计数器控制连接在终止前可以保持空闲的时间(秒)。计数器基于路由器确定为“相关流量”的对象重置或倒计时。如果路由器发现相关流量(在 dialer-list 中定义),它会重置空闲计时器,否则空闲计时器将继续倒计时。计时器达到零时,呼叫会中断。

下面列出您在使用该命令时应注意的一些要点:

  • 该命令只能应用于支持拨号程序的接口。默认情况下,所有的 ISDN 接口(基本速率接口 [BRI] 和主速率接口 [PRI]))都支持拨号程序,因此可以添加该命令,不会发生问题。

  • 异步接口(例如,异步接口 x 或异步组接口 x)默认情况下不支持拨号程序。您必须通过输入 dialer in-band 命令确保接口支持拨号程序。请注意,虚拟模板(及虚拟访问接口)不支持拨号程序,而是仅支持点对点呼叫。所以,他们不能使用此命令,除非运行Cisco IOSï ¿  ½软件版本12.2(4)T,当对空闲超时结构的增强包括。

  • 仅在异步接口上输入 dialer in-band 命令后才能配置 dialer idle-timeout

  • 在支持拨号程序的接口(即 ISDN 或与频带内拨号程序异步)上,默认空闲超时是 120 秒(两分钟)。除非您通过不同的空闲超时值显式配置命令 dialer idle-timeout,否则将使用默认值。

    注意: 由于是默认设置,默认空闲超时不显示在配置中。使用 show dialer 命令确定是否在接口中强制执行空闲超时。

  • 如果您希望用户在选择断开连接之前能够始终保持连接,请使用 dialer idle-timeout 0 命令。Cisco IOS 软件版本 12.1(3)T 中引入了 dialer idle-timeout 的“零”选项,该选项可将超时设置为无限。

触发 数据流

通过按需拨号路由 (DDR),所有的流量将分类为相关或非相关流量。如果是相关流量,则路由器连接到对等体。如果是非相关流量,则呼叫不连接。但是,对于已建立连接的连接,相关流量具有不同的用途。它用于将空闲超时重置回最大值(通过 dialer idle-timeout 命令配置)。建立连接时,空闲计时器开始减小。一旦路由器接收与相关流量定义匹配的数据包,空闲计时器即重置回最大值。

视为相关流量的流量由 dialer-list {n} 命令定义(在全局配置模式下),其中 {n} 与接口配置下的 dialer-group {n} 命令语句中的数字一致。

有两种定义相关流量的方法。简单方法(仅使用 dialer-list 命令)是将整个协议(例如 IP 或 IPX)指定为相关或不相关的流量定义。但是,如果您需要提供精细的相关流量定义(例如,如果 HTTP 流量是相关的,但 Telnet 流量是不相关的),则需要将 dialer-list 命令与 access-list 结合使用。

有关配置相关流量的详细信息,请参阅配置空闲超时和相关流量部分。

指定感兴趣的流量的方向

默认情况下,dialer idle-timeout 将根据出站方向的相关流量重置回最大值。如果仅入站流量应重置空闲超时,则使用另一关键字 inbound。对入站和出站流量使用 either 关键字以重置空闲超时。上述功能已引入 Cisco IOS 软件版本 12.1(1)T 中。

好处:通过指定仅入站流量将重置拨号程序空闲计时器,可以避免意外的 Internet 流量阻止空闲连接断开。

定义感兴趣的通信流和空闲超时

DDR 链路的两端必须都定义相关流量。即使接收呼叫的路由器仅处理来电并且不创建出站呼叫,我们仍需要定义相关流量。

相关流量定义对传入异步呼叫和 ISDN 呼叫具有不同的用途。

对于 ISDN 用户(对应于接口拨号程序 X)

无论您是否要强制执行空闲超时,拨号程序接口中都需要 dialer-groupdialer-list 命令。必须在拨号程序接口中使用 dialer-groupdialer-list 命令以避免封装故障。该要求仅针对 ISDN 用户,并不针对异步用户和异步组接口。

要强制执行空闲超时,请添加 dialer in-banddialer idle-timeout 命令。但是,如果已配置 dialer in-band 但未配置 dialer idle-timeout,则对于 ISDN 用户而言,空闲超时将默认为两分钟。

如果您希望 ISDN 用户在选择断开连接能够始终保持连接,请使用 dialer idle-timeout 0 命令。Cisco IOS 软件版本 12.1(3)T 中引入了 dialer idle-timeout 的“零”选项,该选项可将超时设置为无限。

对于 ISDN 用户(对应于接口 BRI x 和串行接口 x:23)

默认情况下,为所有的 ISDN 物理接口都启用了 DDR。这意味着该接口中已启用 dialer in-band。要强制执行空闲超时,请添加 dialer idle-timeout 命令。但是,如果已配置 dialer in-band 但未配置 dialer idle-timeout,则对于 ISDN 用户而言,空闲超时将默认为两分钟。

无论您是否要强制执行空闲超时,该接口中都需要 dialer-groupdialer-list 命令。必须在接口中使用 dialer-groupdialer-list 命令以避免封装故障。该要求仅针对 ISDN 用户,并不针对异步用户和异步组接口。

如果您希望 ISDN 用户在选择断开连接能够始终保持连接,请使用 dialer idle-timeout 0 命令。Cisco IOS 软件版本 12.1(3)T 中引入了 dialer idle-timeout 的“零”选项,该选项可将超时设置为无限。

对于异步用户(对应于异步组接口 X)

要为异步用户强制执行空闲超时,请在异步组接口中配置下列命令:

  • 频带内拨号

  • dialer idle-timeout

  • dialer-group

还需要对应的拨号程序列表。dialer-groupdialer-list 命令指定异步组接口中的相关流量。

对于异步用户,相关流量仅用于重置空闲超时。如果未定义相关流量,无论用户是否传递链路中的流量,他们都将在拨号程序空闲超时(默认为 120 秒)过期后断开连接。通过相关流量定义,网络接入服务器 (NAS) 将识别这些数据包并重置空闲超时,从而仅在有真正的空闲链路时断开用户连接。

您可以修改触发数据流,例如,只有HTTP (Web)数据流是触发数据流。在此类情况下,如果用户浏览 Web 的时间不是 300 秒(或指定的拨号程序空闲超时),他们的连接将断开。根据用户的流量模式配置相关流量。

如果您希望异步用户在选择断开连接之前能够始终保持连接,请从异步组接口中删除如配置中所示的下列命令:

  • 频带内拨号

  • dialer idle-timeout

  • dialer-group

您还可以使用 dialer idle-timeout 0 命令将空闲超时设置为无限。Cisco IOS 软件版本 12.1(3)T 中引入了 dialer idle-timeout 的“零”选项,该选项可将超时设置为无限。

设定空闲超时和感兴趣的数据流

本部分将讨论如何在路由器中配置空闲超时和相关流量。您可以将该配置应用于启用 DDR 的所有接口,例如:

interface BRI
interface async x
interface dialer x
interface group-async x
interface serial x:23

您还可以使用身份验证、授权和记账 (AAA) 服务器提供每用户超时。有关详细信息,请参阅文档 PPP 每用户超时

配置示例

下列配置示例包含简单的相关流量定义。这一特殊示例将所有的 IP 流量都指定为相关流量:

interface BRI0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 900
!--- Idle-timeout is set at 900 seconds (15 minutes)
dialer-group 1
!--- Apply interesting traffic definition from dialer-list 1
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
dialer-list 1 protocol ip permit
!--- Designate all IP traffic as interesting.  
This definition was applied to BRI0/0 using dialer-group 1.   
Note that the dialer-list and dialer-group numbers match

上面的配置使连接至少保持 900 秒(15 分钟)的有效状态,允许任一方向(默认值)的 IP 流量将空闲超时重置回 900 秒。因此,如果任一方向的 IP 流量传递时间不是 15 分钟,路由器会由于空闲超时已过期而断开线路连接。

注意: 如果您在该 DDR 链路上运行路由协议,则定期流量会使该链路始终处于接通状态。因此,建议 要对在其上运行路由协议(或其他定期流量)的链路使用如上所示的相关流量定义。

使用访问列表

以下示例显示路由器包含一个接收呼叫的基本速率接口 (BRI) 并通过 inbound 关键字启用了 dialer idle-timeout 命令。该命令仅允许符合拨号程序列表的入站流量重置拨号程序空闲计时器。在此,仅允许端口 80(HTTP 流量)上的 TCP 流量将空闲超时重置回 10 分钟(600 秒)。因此,如果最终用户浏览 Web 的时间不是 10 分钟,连接将断开。

使用 ISDN 接口

interface BRI0/0   
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 600 inbound

!--- Idle timeout is 600 seconds.  Only inbound interesting traffic will reset 
the idle timeout

dialer-group 1

!--- Apply the interesting traffic defintion from dialer-list 1

peer default ip address pool dialin
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http) from any host to any other host

access-list 101 deny ip any any

!--- All other IP traffic is uninteresting

dialer-list 1 protocol ip list 101

!--- Use list 101 for granular interesting traffic definition
ip local pool dialin 10.1.1.2 10.1.1.254

使用异步接口

默认情况下,不为异步接口启用 DDR,因此使用 dialer in-band 可为它们启用 DDR。

Interface group-async 1
ip unnumbered ethernet 0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
peer default ip address pool dialin
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80
access-list 101 deny ip any any

!--- Access-lists have an implicit deny.  However, we are explicitly denying IP 
here for clarity.


dialer-list 1 protocol ip list 101
ip local pool dialin 10.1.1.2 10.1.1.254

空闲超时的改进

在 Cisco IOS 软件版本 12.2(4)T 之前,仅为启用了拨号程序的接口上的相关流量重置拨号程序空闲计时器(例如通过 dialer in-band 命令启用 BRI、PRI 和异步组)。不能将空闲超时应用于连接到虚拟模板接口的用户。

自 Cisco IOS 软件版本 12.2(4)T 起,相关流量功能的用户配置文件空闲计时器增强功能提供新的命令和功能,可用于解决虚拟访问拨号网络 (VPDN) 会话的空闲计时器问题,这些会话使用虚拟访问(设计的)接口并依赖 PPP 空闲计时器机制。

验证空闲超时

执行下列步骤以验证空闲超时行为并排除其故障:

  1. 确保使用 show user 命令连接呼叫。

  2. 使用 show caller timeoutshow dialershow caller user 决定是否将空闲超时正确分配给已连接的接口。如果您运行 show 命令多次,应注意到连接断开时间会减少。

  3. 跨链路启动相关流量(根据拨号程序列表 x 的定义)。您应了解正在运行的配置以决定相关流量定义。

  4. 再次运行 show caller timeoutshow dialershow caller user 以确定空闲超时是否已重置。如果空闲超时没有重置,则表示相关流量未正确定义(使用 dialer-list)或未应用于接口(使用 dialer-group)。

下面列出了用于验证空闲超时行为的命令:

  • show caller timeout - 显示已安装的绝对超时和空闲超时以及用户在多长时间之后由于任何超时而断开连接。

  • show dialer [interface type number] - 显示为 DDR 配置的接口的常规诊断信息。如果拨号程序正常运行,则出现消息“dialer state is data link layer up”。如果显示“physical layer up”,这意味着线路协议启动,但网络控制协议 (NCP) 没有启动。启动拨号的数据包的源地址和目标地址显示在 dial reason line 中。该命令还显示计时器的配置以及连接超时前的时间。

  • show caller user username detail -显示特定用户参数,如分配的IP地址、PPP和PPP捆绑参数等。如果您的Cisco IOS版本软件不支持此指令,请使用show users命令。

对于 ISDN 呼叫

以下是接收端路由器的配置,其中包含通过 dialer rotary-group 1 命令链接到接口拨号程序 1 的 BRI 接口。请记住,使用命令 dialer in-band 为接口拨号程序 1 启用 DDR。

interface BRI0
   description 96665500
   no ip address
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer rotary-group 1
   dialer-group 1
   isdn switch-type basic-5ess
   no cdp enable
   ppp authentication pap
 !
 interface Dialer1
   ip address 10.1.1.1 255.255.255.0
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer in-band
   dialer idle-timeout 600
   dialer-group 1
   peer default ip address pool dialin
   no cdp enable
   ppp authentication chap callin
   ppp chap hostname cisco
   ppp chap password 7 <deleted>
 !
 ip local pool dialin 10.1.1.2 10.1.1.255
 dialer-list 1 protocol list 101
 access-list 101 permit icmp any any
 access-list 101 permit tcp any any eq 80
 access-list 101 deny ip any any

!--- Only http traffic and icmp traffic are interesting
 
 !

执行下列步骤以验证空闲超时:

  1. 确保呼叫已连接。您可以使用 show user 命令验证用户是否连接。例如:

    isdn2-4#show user
    
    Line   User  Host(s)       Idle     Location
    * 2 vty 0  idle         00:00:00 172.22.88.109
    
    Interface   User  Mode     Idle      Peer Address
    BR0:1       Preet Sync PPP 00:00:51  PPP: 10.1.1.2
    
  2. 验证空闲超时是否应用于连接。在下面的示例中,用户 Preet 在接口拨号程序 1 中拨入和终止,并从拨入池获得 IP 地址 10.1.1.2。现在,我们验证连接是否使用 600 秒(10 分钟)的空闲超时。

    isdn2-4#show dialer interface dialer1
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The idle timeout value configured on int dialer 1.   If the default 
    is in use, this value will be 120.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The user Preet obtained the idle timeout of 600 seconds.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 557 secs
    

    由于链路中未传输任何相关流量,因此断开时间将倒计时。最近的 43 秒内没有在任一方向传递相关流量。因此,用户将在 557 秒(600 - 43)后断开连接。该用户建立连接后,time until disconnect 字段将开始倒计时,并在收到相关流量时重置为最大值。

    Connected to 4086666700 (Preet)
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle

    另一个可用于验证空闲超时的命令是 show caller timeout

    isdn2-4#show caller timeout
    Line    User   Limit     Remaining   Timer  Type
    vty 2    -     00:10:00  00:09:59    Idle   Exec
    BR0:1   Preet  00:10:00  00:09:13    Dialer idle
    

    limit 字段显示已配置的最大空闲超时(分钟),而其余字段显示断开前的时间。

  3. 启动到对等体的相关流量。我们现在将启动到对等体的相关流量。确保您了解正在运行的配置以决定确切的相关流量定义。访问列表 101 将流向端口 80 的 Internet Control Message Protocol (ICMP) 和 TCP 流量定义为相关流量。因此,我们现在将从路由器 ping 通 10.1.1.2(用户 Preet 已协商的 IP 地址)。

    isdn2-4#ping 10.1.1.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 36/37/40 ms
    isdn2-4#
  4. 确认空闲超时已重置。使用 show caller timeoutshow dialershow caller user 命令确认空闲超时已重置:

    isdn2-4#show caller timeout 
     Line     User      Limit    Remaining  Timer Type 
     vty 2    -         00:10:00 00:09:59   Idle Exec 
     BR0:1    Preet     00:10:00 00:09:59   Dialer idle
    !--- Idle-timout is reset back to maximum
    
    
    isdn2-4#show dialer interface dialer1
    
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 599 secs
    
    !--- Idle timeout is reset back to maximum.
    
    
    Connected to 4086666700 (Preet)
    
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle
    isdn2-4# 
    

另一个可用来基于用户名查看超时信息的有用命令是 show caller user 命令

isdn2-4#show caller user Preet
 User: Preet, line BR0:1, service PPP 
 Connected for 00:05:36, Idle for 00:02:37
!--- Shows the inactivity for the last two minutes and 37 seconds. 
This counter increments to ten minutes and then the call is disconnected.


Timeouts: Limit    Remaining Timer  Type
          00:10:00 00:07:22  Dialer idle
!--- Time until idle disconnect.


PPP: LCP Open, PAP (<- none), IPCP
Dialer: Connected to 4086666700, inbound
        Type is ISDN, group Di1
IP: Local 10.1.1.1/24, remote 10.1.1.2
Counts: 215 packets input, 5392 bytes, 0 no buffer
        0 input errors, 0 CRC, 0 frame, 0 overrun
        230 packets output, 5603 bytes, 0 underruns
        0 output errors, 0 collisions, 7 interface resets

如果空闲超时未重置,请继续阅读排除空闲超时问题部分。

对于异步呼叫

以下是您可以在 ISP 环境中看到的典型异步呼叫配置。

 interface Group-Async0
   ip unnumbered Loopback0
   encapsulation ppp
   dialer in-band

!--- Make this interface dialer capable
 
   dialer idle-timeout 600

!---  Idle timeout of 600 seconds (10 minutes)

   dialer-group 1

!--- Interesting traffic definition from dialer-list 1

   async mode interactive
   peer default ip address pool dialin
   ppp authentication pap chap callin
   group-range 1/3/00 1/3/71
   !
   ip local pool dialin 10.1.1.3 10.1.1.255
 dialer-list 1 protocol list 101

!--- Interesting traffic definition is defined by access-list 101

access-list 101 permit icmp any any

!--- Permit icmp from any host to any other host

 access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http traffic)

access-list 101 deny ip any any

!--- Deny all other IP traffic.  This interesting traffic definition 
will allow icmp and http traffic to reset the idle timeout. All other IP traffic will not 
affect the timeout.

和 ISDN 一样,使用 show usersshow dialershow caller timeout 验证空闲超时。

使用 show users 命令查找对等体连接的接口和 IP 地址。

c5800#show users
      Line      User  Host(s)         Idle     Location
   * 0 con 0          idle            00:00:00 
     tty 1/3/01 Preet Async interface 00:00:09 PPP: 10.1.1.3
!--- User Preet is connected to async interface 1/3/01 and has IP address 10.1.1.3

Interface    User Mode             Idle     Peer          Address

使用 show dialer 命令(指定刚确定的接口)查看计时器的值:

c5800#show dialer interface async 1/3/01
As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (600 secs), Fast idle timer (20 secs)
!--- Idle timeout of 600 seconds is applied to the interface if this value 
is 120 seconds.


!--- Verify that dialer in-band is configured under the group-async interface.

Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Time until disconnect 574 secs (Preet)
!--- Call will be disconnected in 574 seconds unless it receives interesting traffic.
Dial String     Successes    Failures    Last DNIS     Last status

show caller timeout 命令还可以显示连接断开时间:

c5800#show caller timeout
                        Session    Idle      Disconnect
   Line        User     Timeout    Timeout     User in
   con 0        -        -          -           - 
   tty 1/3/01  Preet     -          -           - 
   As1/3/01    Preet     -         00:10:00    00:09:19 

现在我们将启动相关流量。访问列表 101 将流向端口 80(HTTP 流量)的 ICMP 和 TCP 流量定义为相关流量。从路由器 ping 通 10.1.1.3(用户 Preet 已协商的 IP 地址)以重置空闲超时。

c5800#ping 10.1.1.3
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 108/113/124 ms

确认超时已重置:

   c5800#show caller timeout
                      Session Idle    Disconnect
   Line       User    Timeout Timeout User in
   con 0      -        -       -      - 
   tty 1/3/01 Preet    -       -      - 
   As1/3/01   Preet    -     00:10:00 00:09:58
!--- Time to disconnect is close to 10 minutes

这证明相关流量已正确定义和应用。或者,您可以使用 show dialer 命令验证超时值:

c5800#show dialer interface async 1/3/01
   As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (600 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 594 secs (Preet)
   Dial String   Successes    Failures   Last DNIS    Last status

您还可以使用 show caller user {username} detailed 命令验证特定于该用户的参数:

c5800#show caller user preet detailed 
User:   Preet, line tty 1/3/01, service Async
        Active time 00:01:14, Idle time 00:00:18
Timeouts:          Absolute   Idle      Idle
                              Session   Exec
Limits:            -          -         00:10:00
Disconnect in:     -          -         -    
TTY: Line 1/3/01, running PPP on As1/3/01   
Location: PPP: 10.1.1.3   
DS0: (slot/unit/channel)=1/4/0   
Status: Ready, Active, No Exit Banner, Async Interface Active
        HW PPP Support Active   
Capabilities: No Flush-at-Activation, Hardware Flowcontrol In
              Hardware Flowcontrol Out, Modem Callout, Modem RI is CD                 
              Line usable as async interface, Telnet Faststream   
Modem State: Ready

User: Preet, line As1/3/01, service PPP
      Active time 00:01:11, Idle time 00:00:18   
Timeouts:        Absolute Idle
Limits:          -        00:10:00    
Disconnect in:   -        00:09:41 
!--- Idle timeout of 10 minutes. The call will be disconnected in 9 minutes 41 secs 
unless it receives interesting traffic during that time. If the absolute column has a 
value, then the call will be disconnected at that time regardless of the idle timeout.

PPP: LCP Open, CHAP (<- local), IPCP
LCP: -> peer, ACCM, AuthProto, MagicNumber, PCompression, ACCompression          
     <- peer, ACCM, MagicNumber, PCompression, ACCompression   
NCP: Open IPCP   
IPCP: <- peer, Address
      -> peer, Address   
Dialer: Connected, inbound
        Idle timer 600 secs, idle 20 secs
        Type is IN-BAND ASYNC, group As1/3/01   
IP: Local 10.1.1.251, remote 10.1.1.3   
Counts: 12 packets input, 651 bytes, 0 no buffer 
        0 input errors, 0 CRC, 0 frame, 0 overrun           
        13 packets output, 666 bytes, 0 underruns           
        0 output errors, 0 collisions, 0 interface resets

空闲超时问题故障排除

症状:呼叫过早断开或呼叫从不断开

如果呼叫意外断开或从不断开,请检查拨号程序空闲超时和相关流量定义。您能使用debug dialer packet命令发现特定信息包是否是有趣。例如:

Apr 26 01:57:24.483: Di1 DDR: ip (s=192.168.1.1, d=224.0.0.5), 
64 bytes, outgoing uninteresting (list 101)
Apr 26 01:57:26.225: Di1 DDR: ip (s=192.168.1.1, d=10.1.1.1), 
100 bytes, outgoing interesting (list 101)

在上面的示例中,OSPF hello 是每个访问列表 101 的非相关流量,而第二个数据包是每个访问列表 101 的相关流量。故障排除步骤如下所示:

  1. 在拨号程序接口配置中调整拨号程序空闲超时。默认是 120 秒,但您可能希望根据自己的需求增大或降低该值。

    router(config-if)#dialer idle-timeout 

    注意: 如果呼叫未断开,请确认拨号程序空闲超时的“零”选项(已在 Cisco IOS 软件版本 12.1(3)T 中引入)未设置。

  2. 更改相关流量定义(已通过 dialer-list 命令配置)。如果呼叫过早断开,您可能希望更宽松地定义相关流量(拒绝少量的流量而允许其他所有的流量)。如果呼叫从未断开,请将相关流量定义更改得更有限制性(允许少量的流量而拒绝其他所有的流量)。

    提示:如果链路未断开,请务必将路由协议流量(或任何其他的定期流量)定义为非相关流量。这样可以避免定期 hello 重置空闲超时。以下是相关流量定义的示例:

    access-list 101 remark Interesting traffic for dialer-list 1   
    access-list 101 deny ospf any any
    !--- Mark OSPF as uninteresting.  This will prevent OSPF hellos from 
    keeping the link up.
    
    
    access-list 101 deny udp any any eq ntp
    
    !--- Define ntp traffic as NOT interesting.  This will prevent periodic ntp 
    traffic from keeping the link up indefinitely.
    
    
    access-list 101 permit ip any any
    !--- All other IP traffic is interesting. Change this depending on your 
    traffic needs.
    
    dialer-list 1 protocol ip list 101
    !--- This interesting traffic is applied to the dialer interface using 
    dialer-group 1.
    
    

    有关详细信息,请参阅文档拨号技术:概述和解释

症状:呼叫每隔几秒断开一次

另一个问题是呼叫每隔“x”秒(通常是 120 秒)断开一次。在特定情况下,即使在链路中传递流量,DDR 也不重置空闲超时。这可能是因为下列原因:

  • 相关流量未定义

  • 相关流量定义未应用于接口

  • 接口不支持拨号程序

要解决该问题,请执行下列操作:

  1. 验证是否在接口下定义拨号程序列表和配置拨号程序组(指向拨号程序列表)。配置简单的相关流量定义:

    router(config)#interface dialer 1
    router(config-if)#dialer-group 1
    router(config-if)#exit
    router(config)#dialer-list 1 protocol ip permit
    

    经常发生的断开问题得以解决后,您可以调整相关流量定义以满足您的需求。

  2. 确保已在异步组和拨号程序接口中配置 dialer in-band。接口 BRI x、串行接口 x:23 等支持拨号程序的接口(用于 PRI)不需要使用该命令。

  3. 将拨号程序空闲超时调整为所需的值。

    router(config-if)#dialer idle-timeout 900
    

相关信息


Document ID: 23423