语音和统一通信 : Cisco Unified Communications Manager (CallManager)

配置 Cisco IOS MGCP 网关

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 26 日) | 反馈


目录


简介

本文档:

  • 指导您完成简单的 Media Gateway Control Protocol (MGCP) 配置。

  • 仅介绍建立一个用于带有两个外部交换局 (FXO) 和两个外部交换站 (FXS) 端口的路由器的配置所需的最基本命令。

注意: 运行Cisco IOS�软件版本12.1(5)T和以上在本文的说明为Cisco语音网关200 (VG200)和Cisco 2600及3600系列路由器工作。有关支持的其他 Cisco IOS MGCP 网关的软件版本,请参阅 Cisco IOS 软件文档。

症状:

当您通过带有模拟 FXO 和 FXS 端口的 Cisco IOS MGCP 网关配置 Cisco CallManager 时,可能会遇到以下情况:

  • MGCP网关没有在Cisco CallManager注册。参考MGCP与Cisco CallManager的网关注册故障

  • 呼叫方ID在FXO端口不运作。这是因为呼叫方ID不支持与FXO端口,当配置为MGCP。请改用 H.323 模式来配置网关。

  • 除非用户完全摘机,否则在执行瞬间挂机时,空中寻呼会锁定 FXO 端口。在 Shut 后使用 No shut 会重置端口。此问题与 Cisco Bug ID CSCef62275(仅限注册用户)有关,并在 Cisco IOS 软件版本 12.3(14)T 及更高版本中得到了修复。

本文档是包含六个文档的文档集中的第 2 部分:

先决条件

要求

Cisco 建议您了解以下主题:

  • 一个运行某个 Cisco IOS 软件版本的 Cisco IOS 网关,该软件版本通过 Cisco CallManager 来支持 MGCP

  • Cisco VG200

注意: 还有其他支持 Cisco 路由器上的 MGCP 的 Cisco IOS 软件版本系列。Cisco IOS 软件版本 12.1XM 就是其中一个例子。

警告 警告: 一些 MGCP 命令的语法与其他 Cisco IOS 软件版本中的语法不同。请参阅您的配置的文档以确定需要使用的语法。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 1 * Cisco VG200 / 2 X FXS / 2 X FXO / 1 快速以太网 10/100 端口;Cisco IOS 软件版本 12.1(5)T

  • 1 * 运行于 MCS7835 上的 Cisco CallManager 3.0(5a)

  • 2 *模拟电话听筒

  • 2 * Cisco 7960 IP 电话

有关 Cisco CallManager 与 Cisco IOS 网关之间的建议兼容软件版本,请参阅 Cisco Unified CME 和 Cisco IOS 软件版本兼容性列表

注意: 基于 ccm-manager 命令增强功能,建议使用 Cisco IOS 软件版本 12.2(11)T 或更高版本。ccm-manager 命令需要在所有路由器(2600 和 3600)和 VG200 上安装 Cisco IOS 软件版本 12.1(5)XM 或更高版本。

如果 Cisco 2600 和 3600 路由器运行 Cisco IOS 软件版本 12.1(3)T 或更高版本,则这些路由器支持 MGCP。您需要的软件版本基于您需要启用的功能。Cisco CallManager 服务器必须运行软件版本 3.0(5)a 或更高版本。所有类型路由器的配置是相同。Cisco CallManager配置对于所有类型的路由器都是相同的。

Cisco IOS 软件版本 12.1(5)XM1 及更高版本支持 VG200。您需要的软件版本基于您需要启用的功能。即使早期 Cisco CallManager 软件版本支持 VG200,也应使用软件版本 3.0(5)a 或更高版本。

注意: 还有其他支持 Cisco 路由器上的 MGCP 的 Cisco IOS 软件版本系列。Cisco IOS 软件版本 12.1XM 就是其中一个例子。

警告 警告: 一些 MGCP 命令的语法与其他 Cisco IOS 软件版本中的语法不同。请参阅您的配置的文档以确定需要使用的语法。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

要执行的任务

完成这些步骤:

  1. 配置 Cisco IOS 网关以太网接口的 IP 地址。

  2. 向 Cisco IOS 网关分配唯一名称。

  3. 配置 Cisco IOS 网关以将 MGCP 作为信令协议运行。

  4. 配置 Cisco CallManager 服务器的 IP 地址或域名系统 (DNS)。

  5. 选择 codec 类型和双音多频 (DTMF) 中继功能。

  6. 通知 Cisco IOS 网关它与 Cisco CallManager 服务器进行通信。

  7. 将 MGCP 应用程序绑定到语音端口。

  8. 启用语音端口。

  9. 启用 IP 连接。

分步操作

注意: 本文档其余部分将介绍 VG200。VG200 在交付时已进行默认配置。

完成这些步骤:

  1. 配置 VG200 以太网接口的 IP 地址,并启用该接口。

    router(config)#interface fastethernet 0/0
    router(config-if)#ip address 172.16.1.206 255.255.255.0
    router(config-if)#no shut
    
  2. 向 VG200 分配唯一名称。该名称可让 Cisco CallManager 服务器对其进行识别。

    router(config)#hostname VG200A 
    
    /* This is how CallManager keeps track of the MGCP network */
    /* devices it is communicating with. This name must be     */
    /* unique.                                                 */
  3. 配置 VG200 以将 MGCP 作为信令协议运行。

    VG200A(config)#mgcp
    
  4. 配置 Cisco CallManager 服务器的 IP 地址或 DNS 名称。

    VG200A(config)#mgcp call-agent 172.16.1.252
    
    VG200A(config)#ccm-manager config server 172.16.1.252
    
    VG200A(config)#ccm-manager config
    

    mgcp call-agent 命令用于配置媒体网关上 MGCP 端点的呼叫代理的地址和协议。此命令可用于指定所用协议的版本。有关详细信息,请参阅 mgcp call-agent

    ccm-manager config server 命令用于指定 Media Gateway Control Protocol (MGCP) 网关下载 Cisco CallManager XML 配置文件时使用的 TFTP 服务器。

    若要启用 Cisco CallManager XML 配置文件的下载,需要使用 ccm-manager config 命令。

    注意: 发出这些命令可对 Cisco CallManager 集群中的冗余 Cisco CallManager 进行配置:

    VG200(config)#ccm-manager redundant-host [ip-address |
      dns-name] [ip-address | dns-name] 
    VG200(config)#ccm-manager switchback {graceful | immediate
      |schedule-time hh:mm | uptime-delay minutes} 
  5. 选择 codec 类型和 DTMF 中继功能。

    VG200A(config)#mgcp dtmf-relay codec all mode out-of-band
    
  6. 发出此命令可在 MGCP 中启用对 Cisco CallManager 的支持:

    VG200A(config)#ccm-manager mgcp
    
  7. 将 MGCP 应用程序绑定到语音端口。

    注意: 发出 show voice port 命令可确定 VG200 所具有的端口的类型及其安装顺序。

    VG200A(config)#dial-peer voice 1 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/0
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 2 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/1
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 3 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/0
    
    /* FXS port */
    
    VG200A(config)#dial-peer voice 4 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/1
    
    /* FXS port */

    注意: 在某些 Cisco IOS 软件版本中,application MGCPAPP 命令是区分大小写的。除非您知道自己的软件版本不区分大小写,否则应始终以大写形式发出此命令。若要检查所用的软件版本是否区分大小写,可查看 show running-config 命令的输出。Cisco IOS 软件版本 12.1(5)T 不区分大小写。

  8. 确保已启用语音端口。

    注意: shutdownno shutdown 命令会影响语音接口卡 (VIC) 上的这两个端口。仅在其中一个端口上发出该命令。

    VG200A(config)#voice-port 1/0/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXO port */
    
    VG200A(config)#voice-port 1/1/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXS port */s
  9. 启用 IP 连接。

    如果与 VG200 进行通信的任何一个 VoIP 设备位于不同的子网络或 VLANS 中,请启用 IP 路由。还需要创建一个默认网络或最后选用网关。此步骤说明如何执行这两个任务:

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway
    
    

    注意: VG200 不是 IP 路由器。您无法在其上面运行 IP 路由协议,例如 Routing Information Protocol (RIP)、Interior Gateway Routing Protocol (IGRP) 或者 Open Shortest Path First (OSPF) 协议。就 IP 连接而言,其作用更像是一个终端站(客户端)。

    注意: 在其他 Cisco IOS 网关上(尤其是带有语音接口的路由器),您可以配置路由协议而不是静态路由。重要的是要确保 VoIP 设备之间的 IP 连接。

    注意: 由于启用 IP 路由时 ip routing 命令在默认情况下通常已开启,因此不会出现在配置中。默认命令通常不会出现在 Cisco 路由器配置中。VG200 Cisco IOS 映像通过将 no ip routing 命令硬编码到初始配置中来覆盖此默认行为。在该映像启动时,将在以下位置创建此配置:

    • write erase 命令已将配置清除的平台上

    • 在从未配置的 VG200 上

    ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway 命令会使 VG200 在路由表中安装一个最后选用网关。show ip route 命令对此进行确认。在本示例中,该网关的 IP 地址是 172.16.1.1:

    VG200A#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 172.16.1.1 to network 0.0.0.0
    
    C    172.16.0.0/16 is directly connected, FastEthernet0/0
    S*   0.0.0.0/0 [1/0] via 172.16.1.1
    VG200A#

    注意: 为使最后选用网关有效,还需要使用 ip classless 命令。默认情况下,ip classless 命令已启用。启用后,此命令成为出现在配置中的少数 Cisco IOS 软件默认命令之一,并在禁用后出现在 no 形式中。如果配置中包括命令行 no ip classless,则发出 ip classless 命令可启用 ip classless

警告 警告: Cisco CallManager 控制所有与 Dial Plan 有关的配置元素。请勿在 MGCP 管理端点(在拨号对等体语句中具有 application mgcpapp 命令的端点)的 MGCP 网关中配置这些元素。请勿配置以下任何功能:

  • 在拨号对等体下

    • destination-pattern

    • session target

  • 在语音端口下

    • connection { plar|tie-line|中继}

摘要

VG200 此时已做好与 Cisco CallManager 服务器通信的准备。VG200 定期发送消息以尝试建立连接。当 Cisco CallManager 服务器配置完成时,连接自动建立。您无需对 VG200 进行其他更改。

注意: 配置完成后,请重置网关端口,如此例所示:

router(config)#voice-port 1/0/0
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

配置

此表包含本文档中 VG200A 的完整配置:

VG200A 配置
VG200A#show running-config           
Building configuration...

Current configuration : 1244 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname VG200A
!
boot system flash
boot system rom
boot system tftp vg200 172.16.1.253
no logging buffered
logging rate-limit console 10 except errors
no logging console
enable secret #####
enable password #####
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
mgcp
mgcp call-agent 172.16.1.252
mgcp dtmf-relay codec all mode out-of-band
mgcp sdp simple
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
!
!
interface FastEthernet0/0
 ip address 172.16.1.206 255.255.0.0
 no ip mroute-cache
 speed auto
 full-duplex
!
ip default-gateway 172.16.1.1
ip classless
no ip http server
!
snmp-server engineID local 000000090200000196983000
snmp-server community public RO
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0/0
!
dial-peer voice 2 pots
 application mgcpapp
 port 1/0/1
!
dial-peer voice 3 pots
 application mgcpapp
 port 1/1/0
!
dial-peer voice 4 pots
 application mgcpapp
 port 1/1/1
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

VG200A#

VG200A 版本信息
VG200A>show version
Cisco Internetwork Operating System Software
IOS (tm) VG200 Software (VG200-I6S-M), Version 12.1(5)T,  
RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by Cisco Systems, Inc.
Compiled Sat 11-Nov-00 10:33 by ccai
Image text-base: 0x80008088, data-base: 0x807D4784

ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE 
SOFTWARE (fc1)

VG200A uptime is 19 hours, 37 minutes
System returned to ROM by reload
System image file is "flash:vg200"

cisco VG200 (MPC860) processor (revision 0x102) with 28672K/
4096K bytes of memory
y.
Processor board ID JAB0414058X (0)
M860 processor: part number 0, mask 49
1 FastEthernet/IEEE 802.3 interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

VG200A>

IOS MGCP 网关故障排除

在 IOS MGCP 网关中,可能会发生单向呼叫失败,包括出站呼叫失败或入站呼叫失败两种情况。为了解决此问题,请重新配置 MGCP 网关。通常,应重新配置 PRI 接口和/或 FXO 接口。然后,在网关上重新启动 mgcp 协议,方法是在全局配置模式下发出 no mgcp IOS 命令和 mgcp 命令。

无法从与 MGCP IOS 网关相连的模拟电话进行呼叫。将会收到忙音。

为了解决此问题,请执行以下步骤:

  1. 确保在相应端口上配置了 application mgcpapp 命令。

  2. 对普通旧式电话服务 (POTS) 拨号对等体重新排序,以在拨号对等体列表中首先列出 Cisco CallManager 生成的拨号对等体。确保由 MGCP 控制下的正确拨号对等体对呼入和呼出控制进行处理。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 42105