无线/移动 : "无线, LAN (WLAN)"

无线局域网控制器(WLC)和轻量级接入点(LAP)的组播配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 29 日) | 反馈


目录


简介

本文档介绍了有关如何配置组播的无线 LAN 控制器 (WLC) 和轻量接入点 (LAP) 并与启用组播的有线网络进行通信的示例。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 有关 LAP 和 Cisco WLC 配置的基本知识

  • 了解如何在有线网络中配置基本路由和组播

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 运行固件版本 4.0 的 Cisco 4400 WLC

  • Cisco 1000 系列 LAP

  • 运行固件版本 2.6 的 Cisco 802.11a/b/g 无线客户端适配器

  • 运行Cisco IOS 软件版本12.4(2)的Cisco 2500路由器

  • 两台运行 Cisco IOS 软件版本 12.0(5)WC3b 的 Cisco 3500 XL 系列交换机

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

无线 LAN 控制器 (WLC) 中的组播

在 Cisco 统一无线网络软件版本 3.2 之前,当 IP 多播启用时,控制器会将组播数据包传送至无线 LAN (WLAN) 客户端,方法是生成组播数据包副本,然后通过单播轻量接入点协议 (LWAPP) 隧道将这些数据包转发至各个与控制器相连的接入点 (AP)。控制器从第一跳路由器上的 VLAN 接收的各组播帧均会被复制,并通过 LWAPP 隧道发送至各个与之相连的 AP。

控制器可能需要针对每个组播数据包生成多达 300 个副本,具体取决于 AP 的数量。这种机制效率低下,并且给控制器添加了很重的处理负担。这会使网络泛洪大量的重复单播数据包。

在 Cisco 统一无线网络软件版本 3.2 和更高的版本中,Cisco 统一无线网络的组播性能得到了优化。这些版本引入更有效的方式将组播数据流从控制器传送至 AP。不再使用单播通过 LWAPP 隧道将各组播数据包传送至各 AP,而是使用 LWAPP 组播组将组播数据包传送至各 AP。这允许网络中的路由器使用标准组播技术来复制组播数据包,并将其传送至各 AP。对于 LWAPP 组播组,控制器成为组播源,AP 成为组播接收方。对于组播性能功能,AP 仅接受来自路由器和组播数据包(具有当前与其关联的控制器的源 IP 地址)的 Internet 组管理协议 (IGMP) 查询。

如果您的网络支持数据包组播,您可以配置控制器使用的组播方法。控制器以两种模式执行组播:

  • 单播模式 - 在此模式中,控制器将各组播数据包单播至与控制器关联的各个 AP。此模式效率低下,但是不支持组播的网络可能会用到。

  • 组播模式 - 在此模式中,控制器将组播数据包发送至 LWAPP 组播组。此方法可减少控制器处理器的开销,并将数据包的复制工作转移至您的网络,这比单播模式高效得多。

    您可以使用控制器 GUI 或 CLI 启用组播模式。

不同 WLC 软件版本中的组播行为

在 WLC 固件 4.0.206.0 版本之前,组播数据包转发在单播或组播模式下启用,同时会启用广播数据包转发。在 WLC 固件 4.0.206.0 版本中,必须分开启用广播和组播数据流。广播在默认情况下处于禁用状态。从 WLC CLI 发出此命令以启用广播:

config network broadcast enable

同样,广播使用在 WLC 上配置的组播模式,即使组播没有打开。如果想要在没有启用组播的情况下启用广播,可通过 CLI(而非 GUI)执行。这是因为您无法设置 IP 地址或模式,除非在 GUI 中启用组播。因此,如果组播模式是单播,而且广播已打开,这便是广播使用的模式(广播数据流被复制并单播至各个 AP)。如果组播模式设置为具有组播地址的组播,则广播会使用此模式(每个广播数据包通过组播组发送至 AP)。

config network multicast mode multicast 
                           Or
config network multicast unicast

无线局域网控制器版本 4.2 和更高的版本支持具有 AAA 覆盖的组播。您必须启用控制器上的 IGMP 监听,从而使组播与 AAA 覆盖协同工作。

在控制器软件版本 4.2 中,引入了 IGMP 监听以更好地引导组播数据包。当此功能启用时,控制器会从客户端采集 IGMP 报告、处理报告,在检查第 3 层组播地址和 VLAN 编号之后创建唯一组播组 ID (MGID),并将 IGMP 报告发送至基础架构交换机。控制器发送这些源地址作为接口地址的报告,控制器在该接口地址上从客户端接收报告。

然后控制器会利用客户端 MAC 地址更新 AP 上的接入点 MGID 表。当控制器接收特定组播组的组播数据流时,会将其转发至所有 AP。但是,仅具有活动客户端监听或预订该组播组的 AP 会发送位于该特定 WLAN 的组播数据流。IP 数据包会通过 MGID 转发,该 MGID 对于输入 VLAN 和目标组播组来说是唯一的。第 2 层组播数据包会通过 MGID 转发,该 MGID 对于输入接口来说是唯一的。

注意: 2000 系列控制器、2100 系列控制器或 Cisco 集成多业务路由器的 Cisco 无线局域网控制器网络模块不支持 IGMP 监听。

组播应用程序在 2100 系列控制器和 Cisco 集成多业务路由器的 Cisco 无线局域网控制器网络模块上存在已知的性能限制。Cisco 正在努力在以后的生产代码版本中解决这些限制问题。同时,Cisco 建议您将 4400 系列或 WiSM 控制器用于组播密集的应用程序。

注意: 与 2100 系列控制器的本地端口直接相连的 AP 不支持组播。

请参阅企业移动性设计指南中的 Cisco 统一无线组播设计章节,以了解关于具有 WLC 的组播的更多信息。

本文档介绍了说明如何在 WLC 上配置组播以连接到启用组播的有线网络的示例。

无线组播漫游

无线环境中的组播客户端面临的一大挑战是绕 WLAN 移动时维护其组播组成员。从 AP 移动到 AP 的、无线连接中的丢包会导致客户端组播应用程序中断。Internet 组管理协议 (IGMP) 在动态组成员信息的维护中起到重要作用。

要想在客户端在网络中漫游时了解其组播会话发生的情况,对 IGMP 有一个基本理解很重要。在第 2 层漫游案例中,会话被保留,这仅仅因为外来 AP(如果正确配置)已经属于组播组,并且数据流没有通过隧道被传输到网络中不同的锚点。第 3 层漫游环境在这种方式下稍加复杂,并且根据控制器上所配置的不同隧道模式,从无线客户端发送的 IGMP 消息可能会受影响。控制器上的默认移动隧道模式是不对称的。这意味着至客户端的回程数据流会被发送至锚 WLC,然后转发至外来 WLC,这是相关客户端连接驻留的位置。出站数据包从外来 WLC 接口发出。在对称移动隧道模式中,入站和出站数据流均会通过隧道被传输到锚控制器。

组播模式使用指南

当您在网络中启用组播模式时,请使用这些指南:

  • Cisco 统一无线网络解决方案针对具体目的使用某些 IP 地址范围。当您配置组播组时,请记住这些范围:

    虽然不推荐,但是所有组播地址均可分配至 LWAPP 组播组;这包括 OSPF、EIGRP、PIM、HSRP 和其他组播协议使用的保留链路本地组播地址。

    Cisco 建议从管理范围块 239/8 分配组播地址。IANA 已保留范围 239.0.0.0-239.255.255.255 作为管理范围地址,以用于私有组播域。请参阅附注以了解其他限制。这些地址本质上类似于保留的私有 IP 单播范围,例如 RFC 1918 中定义的 10.0.0.0/8。网络管理员可在其域内自由使用此范围内的组播地址,而无需担心与 Internet 中的其他地址产生冲突。管理性或专用地址空间必须在企业范围内使用,并且从自治域 (AS) 阻止其离开或进入。

    注意: 请勿使用 239.0.0.X 地址范围或 239.128.0.X 地址范围。这些范围内的地址与本地链路 MAC 地址重叠并且泛洪所有交换机端口,即使 IGMP 监听已开启。

    Cisco 建议企业网络管理员进一步将此地址范围细分为企业网络内更小的地域管理范围,以限制特定组播应用程序的“范围”。这样可防止高速率组播数据流离开园区(其中带宽充足)和拥塞广域网链路。它也允许高效地过滤到达控制器和无线网络的高带宽组播。有关组播地址指南的详细信息,请参阅企业 IP 多播地址分配指南

  • 当您启用控制器上的组播模式时,必须在控制器上配置一个 LWAPP 组播组地址。AP 使用 Internet 组管理协议 (IGMP) 预订 LWAPP 组播组。

  • Cisco 1100、1130、1200、1230 和 1240 AP 使用 IGMP 版本 1、2 和 3。然而,Cisco 1000 系列 AP 仅使用 IGMP v1 加入组播组。

  • 组播模式仅在第 3 层 LWAPP 模式下运行。

  • 在监控模式、嗅探器模式或者恶意探测器模式下的 AP 不加入 LWAPP 组播组地址。

  • 使用运行 4.1 或更低版本的控制器时,您可以在所有控制器上使用同一个组播地址。如果使用运行 4.2 或更高版本的控制器,控制器上配置的 LWAPP 组播组必须不同于网络上使用的各个控制器。

  • 如果使用 4.1 或更高版本的控制器,组播模式不会跨子网移动事件(例如访客隧道、特定站点 VLAN 或使用 RADIUS 的接口覆盖)运行。当您在有线 LAN 上禁用第 2 层 IGMP 监听/CGMP 功能时,组播模式不会在这些子网移动事件中运行。

    在更高的版本中,即 4.2 或更高版本,组播模式不会跨子网移动事件(例如访客隧道)运行。但是,它可以与使用 RADIUS 的接口覆盖(仅当 IGMP 监听启用时)和特定站点 VLAN(接入点组 VLAN)协同运行。

  • 控制器会丢弃发送至 UDP 端口号 12222、12223 和 12224 的所有组播数据包。请确保网络中的组播应用程序没有使用那些端口号。

  • 组播数据流在 802.11a 网络中以 6 Mbps 的速度传输。因此,如果多个 WLAN 尝试以 1.5 Mbps 的速度传输,会发生数据包丢失。这会中断组播会话。

网络设置

在此设置中,有线网络包括三个路由器(R1、R2 和 R3),并在它们之间运行 OSPF。

有线主机通过一个第 2 层交换机连接到网络,该交换机连接到路由器 R1。无线网络通过路由器 R3 连接到网络,如所示。

设备需要针对基本 IP 连接进行配置,并在网络中启用组播。因此,用户能够从有线端发送组播数据流并在无线端接收,反之亦然。

本文档中的 WLC、LAP 和无线客户端使用以下 IP 地址:

WLC Management Interface IP address: 172.16.1.30/16
WLC AP Manager Interface IP address: 172.16.1.31/16
LAP IP address: 172.16.1.50/16
Wireless Client C1 IP address: 172.16.1.75/16
Wireless Client C2 IP address: 172.16.1.76/16
Wired Client W1 IP address: 192.168.0.20/16
Wired Client W2 IP address: 192.168.0.30/16
Wired Client W3 IP address: 192.168.0.40/16

/image/gif/paws/81671/multicast-wlc-lap1.gif

配置

为了配置此设置的设备,需要执行以下操作:

配置组播的无线网络

在 WLC 上配置组播之前,必须针对基本操作配置 WLC,并将 LAP 注册到 WLC 中。本文档假设已配置 WLC 进行基本操作,并且已在 WLC 中注册 LAP。如果您是尝试设置 WLC 以对 LAP 执行基本操作的新用户,请参阅在无线 LAN 控制器 (WLC) 中注册轻量 AP (LAP)

注意: 请勿使用 239.0.0.X 或 239.128.0.X 地址范围。这些范围中的地址与本地链路 MAC 地址重叠并且泛洪所有交换机端口,即使 IGMP 监听已启用。有关重叠多播 MAC 地址的更多信息,请参阅 IP 多播技术概述第 2 层多播地址部分。

在 WLC 中注册 LAP 之后,请完成以下任务,以便配置此设置的 LAP 和 WLC:

  1. 配置客户端的 WLAN

  2. 通过 GUI 启用以太网组播模式

配置客户端的 WLAN

第一步是创建 WLAN,其中无线客户端能连接至该 WLAN,且能通过其访问网络。完成下列步骤以在 WLC 上创建 WLAN:

  1. 要创建 WLAN,请从控制器 GUI 中单击 WLANs

  2. 要配置新的 WLAN,请单击 New

    在本示例中,WLAN 被命名为 MulticastUsers,WLAN ID 为 1。

    /image/gif/paws/81671/multicast-wlc-lap2.gif

  3. 单击 Apply

  4. 在“WLAN”>“Edit”窗口中,定义特定于该 WLAN 的参数。

    1. 对于 WLAN,请从“Interface Name”字段中选择相应的接口。

      此示例将管理接口映射至 WLAN。

    2. 根据设计需求选择其他参数。

      在本示例中使用默认值。

    3. 单击 Apply

      multicast-wlc-lap3.gif

      注意: 在本示例中,不使用对无线用户进行身份验证的第 2 层安全方法。所以,在 Layer 2 Security 字段中选择 None。默认情况下,Layer 2 Security 选项为 802.1x。

      注意: 不同于映射 WLAN (SSID) 至管理接口,动态接口也可在 WLC 上配置以分段无线用户,并且 WLAN 可以映射到动态接口。有关如何在 WLC 上配置动态接口的信息,请参阅无线 LAN 控制器上的 VLAN 配置示例。

发出这些命令,以便使用 CLI 在 WLC 上配置 WLAN:

  1. 发出 config wlan create <wlan-id> <wlan-name> 命令,以便创建一个新的 WLAN。对于 wlan-id,请输入一个 ID(从 1 到 16)。对于 wlan-name,请输入最多 31 个字母数字字符的 SSID。

  2. 发出 config wlan enable <wlan-id> 命令,以便启用 WLAN。

    对于本文档中的示例,命令为:

    config wlan create 1 MulticastUsers
    config wlan enable 1
    

通过 GUI 启用以太网组播模式

下一步是配置组播的 WLC。完成这些步骤:

  1. 在控制器的通用网页中,确保 LWAPP 传输模式设置为第 3 层。

    组播性能功能仅在此模式下运行。

    /image/gif/paws/81671/multicast-wlc-lap4.gif

    注意: 当组播作为组播单播启用时,将复制各个 AP 的数据包;这会占用大量处理器,因此需谨慎使用。作为组播组播启用的组播将使用用户指定的组播地址,向 AP 进行更传统的组播。

  2. 从以太网组播模式的下拉菜单中,选择组播并输入组播组地址。

    在本示例中,地址是 239.255.1.60。

    /image/gif/paws/81671/multicast-wlc-lap7.gif

  3. 单击 Apply

    注意: WLC 4100 不支持组播模式。组播仅在单播模式下完成。这意味着控制器必须复制每个 AP 的组播数据包,并将组播数据包单播至各个 AP。

    发出以下命令以便通过 CLI 启用组播:

    1. 从命令行发出 config network multicast global enable 命令。

    2. 从命令行发出 config network multicast mode multicast <multicast-group-ip-address> 命令。

      对于本文档中的示例,命令为:

      config network multicast global enable
      config network multicast mode multicast 239.255.1.60
      

在管理员启用组播(默认情况下禁用组播模式)并配置 LWAPP 组播组后,新的组播算法通过以下方式之一运行:

当组播组源位于有线 LAN 时:

LWAPP AP 在正常加入进程(引导时)期间将控制器 LWAPP 组播组地址下载至控制器。在 AP 加入控制器并且下载其配置后,AP 会发出 IGMP 请求以加入控制器 LWAPP 组播组。这会触发启用组播的路由器(位于控制器和 AP 之间)中的组播状态的正常设置。组播组的源 IP 地址是控制器管理接口 IP 地址,而非用于第 3 层模式的 AP 管理器 IP 地址。

当控制器收到来自第一跳路由器上的任一客户端 VLAN 的组播数据包时,它会通过位于最低 QoS 级别的管理接口将该数据包传输至 LWAPP 组播组。LWAPP 组播数据包的 QoS 位经过最低级的硬编码,并且用户不可更改。

启用组播的网络将 LWAPP 组播数据包传送至已加入 LWAPP 组播组的各个 AP。启用组播的网络在路由器中使用正常的组播机制,来根据需要复制数据包,以便组播数据包能够到达所有 AP。这样便无需控制器复制组播数据包。

AP 能够接收其他组播数据包,但仅处理来自它们当前加入的控制器的组播数据包。其他所有副本均会被丢弃。如果与 VLAN(原始组播数据包发送源)关联的 WLAN SSID 不只一个,AP 会通过各 WLAN SSID 传输组播数据包(按照 LWAPP 报头中的 WLAN 位图)。此外,如果该 WLAN SSID 位于两个无线频段(802.11g 和 802.11a),若有客户端与其关联,那么两个无线频段均会传输 WLAN SSID 上的组播数据包,即使这些客户端没有请求组播数据流。

当组播组源为无线客户端时:

组播数据包会从 AP 单播(LWAPP 封装)至控制器,类似于标准无线客户端数据流。

控制器会生成两份组播数据包副本。一份发出与 WLAN SSID 关联的 VLAN,最终到达该 WLAN SSID。这会启用有线 LAN 上的接收器,以接收组播数据流和路由器以了解新的组播组信息。数据包另一份副本经过 LWAPP 封装并发送至 LWAPP 组播组,以便无线客户端能够接收该组播数据流。

配置组播的有线网络

为了配置此设置的有线网络,您需要配置路由器的基本连接,并在有线网络中启用组播。

如前所述,OSPF 用作单播路由协议。

所有组播协议均可用于有线网络。本文档使用 PIM-DM 作为组播协议。有关可用于在有线网络中进行组播的不同协议的详细信息,请参阅 Cisco IOS IP 多播配置指南

这些是路由器 R1、R2 和 R3 的配置:

路由器 R1
RouterR1#show run
Building configuration...

Current configuration : 836 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR1
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.3.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR3
 ip address 10.2.4.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
 !
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

路由器 R2
RouterR2#show run
Building configuration...

Current configuration : 616 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR2
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 description Connnected to RouterR3
 ip address 10.2.2.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.3.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

路由器 R3
RouterR3#show run
Building configuration...

Current configuration : 711 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterR3
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

 
!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.2.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.4.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

对于第 2 层交换机,无需针对组播进行配置。默认情况下所有基于 IOS 的第 2 层交换机均会启用 CGMP。因此,交换机会自动处理来自路由器的 CGMP 消息。

验证与故障排除

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

为了验证配置,您需要从源 W1 发送组播数据流,并检查该组播数据流是否会流经有线网络到达有线和无线组成员 W2、C1 和 C2。

执行此任务以测试您的网络中是否已正确配置 IP 多播。

如果所有支持组播的路由器均是组播组的成员,ping 该组会使所有路由器响应,这是一个有用的管理和调试工具。

安排路由器加入组播组的另一个原因是,当网络中的其他主机具有内部网关路由选择协议 (IGRP) 配置时,会阻止它们正确应答 IGMP 查询。如果您安排路由器加入组播组,这会使上游路由器维护该组的组播路由表信息,并保持该组的路径处于活动状态。为了将路由器配置为组播组的一部分,请从接口配置模式发出此命令:

ip igmp join-group <group-address> 
Example: Router(config-if)#ip igmp join-group 239.255.1.60

以下是路由器 R3 的 ping 命令的输出:

RouterR3#ping 239.255.1.60

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.255.1.60, timeout is 2 seconds:

Reply to request 0 from 10.2.2.2, 40 ms
Reply to request 0 from 10.2.3.1, 84 ms
Reply to request 0 from 10.2.4.1, 44 ms

定位故障跳

执行此任务以监控和诊断基本 IP 多播配置。当接收方和源没有正常运行时,您可以使用此步骤。

/image/gif/paws/81671/multicast-wlc-lap6.gif

以下为示例配置的 show ip igmp membershipshow ip mroute count 命令的输出。这些输出来自路由器 R3。

RouterR3#sh ip igmp membership
Flags: A  - aggregate, T - tracked
       L  - Local, S - static, V - virtual, R - Reported through v3
       I - v3lite, U - Urd, M - SSM (S,G) channel
       1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
       / - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
       <ip-address> - last reporter if group is not explicitly tracked
       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

 Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
 *,224.0.1.40                   10.2.2.1        1d21h    stop  2LA    Se0
 *,239.255.1.60                    172.16.1.1      1d06h    02:17 1LA    Et0
RouterR3#sh ip mroute count
IP Multicast Statistics
5 routes using 3094 bytes of memory
2 groups, 1.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.255.1.60, Source count: 3, Packets forwarded: 6860, 
Packets received: 7087
  Source: 172.16.1.30/32, Forwarding: 304/1/147/0, Other: 304/0/0
  Source: 172.16.1.75/32, Forwarding: 6329/8/57/3, Other: 6329/0/0
  Source: 192.168.0.20/32, Forwarding: 227/1/69/0, Other: 454/227/0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

从这些输出可以看出组播数据流从源 W1 流出并为组成员所接收。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 81671