拨号和接入 : 按需拨号路由 (DDR)

利用 Dialer Profiles 来配置 ISDN DDR

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

按需拨号路由 (DDR) 可以满足电路交换 WAN 上间歇网络连接的需要。主要有两种方法配置 DDR:传统 DDR 和 Dialer Profile。本文档主要讨论 Dialer Profile。关于配置传统 DDR 的信息,请参考以下资源:

先决条件

要求

在配置 Dialer Profile 之前,我们强烈建议您阅读 Dialer Profile 的配置与故障排除文档

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • 有Cisco IOSï ¿  ½软件版本的12.2(10b) Cisco 2503

  • 采用 Cisco IOS 软件版本 12.2(10b) 的 Cisco 2503

  • 采用 Cisco IOS 软件版本 12.2(10b) 的 Cisco 2520

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

Dialer Profile 将逻辑配置从用于接收或发出呼叫的物理接口分离出来。由于这种分离,多个 Dialer Profile 配置可以共享接口(如 ISDN、异步调制解调器或同步串行连接)。Dialer Profile 允许针对每个呼叫动态绑定逻辑和物理配置。这样,物理接口便可根据呼入或呼出呼叫要求而展现出不同的特性。Dialer Profile 可以定义封装、访问控制列表、最小或最大呼叫次数,并可启用/禁用功能。多个ISDN B信道用于同步连接到多个远程目的地时,拨号配置文件会特别有用。在这种情况下,可以将一个 Dialer Profile 绑定到一组 B 信道,将另一个 Dialer Profile 绑定到另一组 B 信道。这允许同一物理接口同时连接到多个远程目标。

Dialer Profile 包括以下部分:

  • 拨号程序接口 - 针对每个目标单独使用 Dialer Profile 的逻辑实体。在一个路由器中可以创建任意多个拨号程序接口。特定于目标的所有配置设置都位于拨号程序接口配置中。每个拨号程序接口使用一个拨号池,它是物理接口池(ISDN BRI和PRI、异步调制解调器和同步串行)。

  • 拨号程序池 - 每个接口参考拨号程序池,拨号程序池是与拨号配置文件相关的物理接口组。一个物理接口可以属于多个拨号程序池。通过配置可选的 priority 命令可以解决对于特定物理接口的争用。

  • 物理接口 - 为封装参数配置拨号程序池中的接口。也配置接口,识别接口所属的拨号程序池。Dialer Profile 支持 PPP 和高级数据链路控制 (HDLC) 封装。

  • 拨号映射级别(可选) - 提供拨号程序接口配置参数(例如ISDN速度、拨号计时器参数等)。可以从多个拨号程序接口引用一个映射类。

"欲知关于拨号原型的更多信息,并确定拨号原型是否适合您的情况,请参见文档""拨号程序配置文件的配置和故障排除""。"

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此图所示的网络设置。

/image/gif/paws/9568/ddr-profiles_a.gif

配置

本文档使用以下配置。

R3 :中央站点 (Cisco 2503)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R3
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin privilege 15 password 7 <deleted>
username R1 password 7 <deleted>
username R2 password 7 <deleted>

!--- For Challenge Handshake Authentication Protocol (CHAP), passwords must 
!--- be the same on both routers.

ip subnet-zero          
!
isdn switch-type basic-5ess
!
interface Ethernet0
  ip address 172.22.80.4 255.255.255.0 
!
interface BRI0
  no ip address
  encapsulation ppp
  dialer pool-member 1

!--- Places the interface into dialer pool # from which Dialer interfaces 
!--- may draw channels as needed. 
!--- Links the physical interface with the logical dialer interfaces.

  isdn switch-type basic-5ess
  ppp authentication chap
  ppp multilink

!--- Configure authentication and multilink on both physical and dialer interfaces.

!
interface Dialer0
  ip address 172.22.85.1 255.255.255.0 
  encapsulation ppp
  dialer pool 1

!--- Defines the pool of physical resources from which the Dialer interface 
!--- may draw B channels as needed.

dialer remote-name R1

!--- Should match the authenticated username of the peer


 dialer string 6661000 class mapclass1

!--- Dialer0 is linked to map-class mapclass1


dialer load-threshold 128 outbound
dialer-group 5

!--- DDR configuration command. 
!--- This command is linked to the dialer-list 5 command.

ppp authentication chap
ppp multilink
!
interface Dialer1
  ip address 172.22.86.1 255.255.255.0
  encapsulation ppp
  dialer pool 1
  dialer remote-name R2
  dialer string 6662000
  dialer-group 5
  ppp authentication chap
!
router eigrp 69
  redistribute static

!--- The redistribute static command advertises static routes 
!--- to a dynamic routing protocol.

passive-interface Dialer0
  passive-interface Dialer1

!--- The passive-interface command deactivates dynamic routing updates
!--- on the dialer interfaces. Prevents the Enhanced Interior Gateway 
!--- Routing Protocol (EIGRP) process from continuously bringing up the ISDN link.
 
  network 172.22.0.0
  auto-summary
  no eigrp log-neighbor-changes
!
ip classless
ip route 172.22.95.0 255.255.255.0 Dialer1
ip route 172.22.96.0 255.255.255.0 Dialer0

!--- Router uses dialer1 when reaching network 172.22.95.0.
!--- Router uses dialer0 when reaching network 172.22.96.0. 
         
!
map-class dialer mapclass1 
  dialer idle-timeout 180
  dialer fast-idle 5
dialer-list 5 protocol ip permit

!--- Defines DDR interesting traffic for dialer-group 5. Access-list may be used.

!
line con 0
line aux 0
line vty 0 4
!
end

R1 :远程站点 (Cisco 2503)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin privilege 15 password 7 <deleted>
username R3 password 7 <deleted>

!--- For CHAP, passwords must be the same on both routers.

ip subnet-zero
!
isdn switch-type basic-5ess
!
interface Ethernet0
ip address 172.22.96.1 255.255.255.0
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 10
isdn switch-type basic-5ess
ppp multilink
!
interface Dialer1
ip address 172.22.85.2 255.255.255.0
encapsulation ppp
dialer pool 10
dialer remote-name R3
dialer string 6663000
dialer load-threshold 128 outbound
dialer-group 5
ppp authentication chap
ppp multilink
!
ip classless
ip route 172.22.0.0 255.255.0.0 172.22.80.0 
ip route 172.22.80.0 255.255.255.0 Dialer1
!
dialer-list 5 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
end

R2 :远程工作者 (Cisco 2520)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin privilege 15 password 7 <deleted>
username R3 password 7 <deleted>

!--- For CHAP, passwords must be the same on both routers.

ip subnet-zero
!
isdn switch-type basic-5ess
!
interface Ethernet0
ip address 172.22.95.1 255.255.255.0
!
interface BRI0
ip address 172.22.86.2 255.255.255.0
encapsulation ppp
dialer map ip 172.22.86.1 name R3 6663000
dialer-group 1
isdn switch-type basic-5ess
ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.86.1
!
dialer-list 1 protocol ip permit
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

调整和可选命令

有关 DDR 命令的详细信息,请参考使用 Dialer Profile 命令的对等 DDR 文档。

下面是可选计时器命令列表:

  • dialer idle-timeout seconds - 指定要用于呼叫的空闲计时器值。如果在指定时间内没有传输相关流量,此计时器将断开呼叫。默认时间为 120 秒钟。

  • dialer fast-idle seconds - 如果有另一次等待相同接口的呼叫,并且接口空闲,则指定快速断开时间。等待中的呼叫不必等待空闲计时器过期。默认时间为 20 秒钟。

  • dialer wait-for-carrier-time seconds - 指定要用于呼叫的载波时间值时间。如果在指定时间内没有检测到载波,则放弃呼叫。

下面是可选映射类命令列表:

  • map-class dialer class-name - 指定映射类并进入映射类配置模式。在接口拨号模式上使用的dialer string-class class-name命令,连接map-class配置到拨号配置文件。以下命令是映射类配置模式下可用的命令:

  • dialer idle-timeout secdialer fast-idle secdialer wait-for-carrier-time sec (请参考“计时器”部分)。

  • dialer isdn [speed speed ] [spc] - 指定 ISDN 线路速度(默认值为 64kbps)。spc 选项用于指定 ISDN 半永久连接。

下面是可选多链路 PPP 命令列表:

  • PPP多链路 - 指定此拨号程序接口使用多链路PPP (对连接到同一目的地的捆绑接口的数据包进行分段)。这个命令放置在用于呼入呼叫的物理接口上和呼出呼叫的拨号程序接口里。

  • dialer load-threshold load[outbound|入站|either] - 指定在什么流量负载下将为多链路 PPP 启动其他链路。有效值是从 1 到 255(255 是 100% 链路利用率)。

下面是可以使用的其他命令的列表:

  • dialer hold-queue packets - 指定等待线路接通的信息包队列的长度。有效值是从 0 到 100。

  • dialer pool-member number [priority priority] [min-link minimum] [max link maximum] - 将一个物理接口分配给一个拨号程序池。

    • priority priority - 设置物理接口在拨号程序池中的优先级(从 1 到 255)。拨号时,会先选择具有最高优先级的接口。

    • min-link minimum -设置为此拨号程序池保留的接口上的ISDN B信道最小数量(从1到255)。用于拨号程序备份。

    • max-link maximum -设置为此拨号池保留的接口上的ISDN B信道最大数量(从1到255)。

  • dialer-list dialer-group protocol protocol-name {permit|拒绝|list access-list-number} - 全局配置命令,用于定义将启动 DDR 连接的相关流量。此命令与 dialer-group number 接口命令链接。

    • permit - 允许访问整个协议。

    • deny - 拒绝访问整个协议。

    • list - 指定访问控制表,以便定义一个间隔,使之比整个协议更准确。

验证

本部分提供的信息可帮助您确认您的配置是否可正常运行。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show dialer [interface type number] - 显示为 DDR 配置的接口的常规诊断信息。如果拨号程序正常启动,则应出现 Dialer state is data link layer up 消息。如果physical layer up出现,则线路通信协议表现出来,但是网络控制协议(NCP)没有。Dial reason line 显示启动拨号的数据包的源和目标地址。此show指令也显示计时器的配置和连接超时前的时间。

  • show isdn status - 确保路由器与 ISDN 交换机正常通信。在输出中,验证第1层状态是否为活跃状态,是否第2层状态=MULTIPLE_FRAME_ESTABLISHED出现。此指令也显示活动的呼叫的数量。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug isdn q931 -显示呼叫建立和拆卸ISDN网络连接(第3层)。

  • debug isdn q921 - 显示路由器和 ISDN 交换机之间的 D 信道上的数据链路层消息(第 2 层)。如果show isdn status命令不显示第1层和第2层,请使用此debug。

  • debug dialer [events|packets] - 显示与在拨号程序接口上收到的数据包有关的 DDR 调试信息。

  • debug ppp negotiation - 在协商 PPP 组件(包括链路控制协议 (LCP)、认证和 NCP)时显示有关 PPP 流量和交换的信息。一个成功的PPP协商协议首先开启LCP状态,然后是鉴权,最后协商NCP。

  • debug ppp authentication -显示PPP认证协议消息,包括质询验证协议(CHAP)信息包交换和密码认证协议(PAP)交换。

  • debug ppp error -显示与PPP连接协商和运行有关的协议错误和错误统计数据。

有关拨号程序配置文件故障排除的更多信息,请参见拨号程序配置文件配置和故障排除文档。

调试输出示例

R1 (172.22.85.2) 对 R3 (172.22.85.1) 进行 ping 操作,并触发一个 ISDN DDR 连接:

R1#debug dialer events 
     Dial on demand events debugging is on
R1#ping 172.22.85.1 

Type escape sequence to abort. 
     
Sending 5, 100-byte ICMP Echos to 172.22.85.1, timeout is 2 seconds:
*Mar 1 02:27:06.067: BR0 DDR: rotor dialout [priority]
*Mar 1 02:27:06.071: BR0 DDR: Dialing cause ip (s=172.22.85.2, d=172.22.85.1)
*Mar 1 02:27:06.075: BR0 DDR: Attempting to dial 6663000
*Mar 1 02:27:06.407: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

!--- R1 initiates the DDR process and uses its first BRI B channel.

*Mar 1 02:27:06.411: BR0:1: interface must be fifo queue, force fifo
*Mar 1 02:27:06.419: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar 1 02:27:06.619: Di1 DDR: Authenticated host R3 with no matching dialer map
*Mar 1 02:27:06.691: Di1 DDR: dialer protocol up.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms
R1#
*Mar 1 02:27:07.611: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
changed state to up
*Mar 1 02:27:12.427: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 
6663000 R3

!--- Call timeouts, R1 (172.22.85.2) pings R3 (172.22.85.1) 
!--- and triggers an ISDN DDR connection.


R3#debug ppp negotiation 
PPP protocol negotiation debugging is on
     
R3#debug ppp authentication
PPP authentication debugging is on
R3# 
*Mar 1 02:36:13.015: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

!--- R3 receives an ISDN call from R1

*Mar 1 02:36:13.019: BR0:1 PPP: Treating connection as a callin
*Mar 1 02:36:13.019: BR0:1 PPP: Phase is ESTABLISHING, 
Passive Open [0 sess, 1 load]
*Mar 1 02:36:13.019: BR0:1 LCP: State is Listen

!--- Incoming configuration request

*Mar 1 02:36:13.447: BR0:1 LCP: I CONFREQ [Listen] id 62 len 30
*Mar 1 02:36:13.447: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
*Mar      1 02:3:13.447: BR0:1      LCP: MagicNumber 0x60C29964 (0x050660C29964)
*Mar      1 02:3:13.447: BR0:1      LCP: MRRU 1524 (0x110405F4)
*Mar      1 02:3:13.447: BR0:1      LCP: EndpointDisc 1 R1 
(0x130B0156656E75732D484B

!--- Outgoing configuration request
 
*Mar      1 02:36 13.451:BR0:1 LCP: O CONFREQ [Listen] id 2 len 32
*Mar      1 02:3:13.451: BR0:1      LCP: AuthProto CHAP (0x0305C22305)
*Mar      1 02:3:13.451: BR0:1      LCP: MagicNumber 0x0070D085 (0x05060070D085)
*Mar      1 02:3:13.451: BR0:1      LCP: MRRU 1524 (0x110405F4)
*Mar      1 02:3:13.451: BR0:1      LCP: EndpointDisc 1 R3 
(0x130D014A7570697465722D484B)

!--- Outgoing configuration acknowledgment

*Mar 1 02:3:13.451:      BR0:1 LCP: O CONFACK [Listen] id 62 len 30
*Mar      1 02:3:13.451: BR0:1      LCP: AuthProto CHAP (0x0305C22305)
*Mar      1 02:3:13.451: BR0:1      LCP: MagicNumber 0x60C29964 (0x050660C29964)
*Mar      1 02:3:13.451: BR0:1      LCP: MRRU 1524 (0x110405F4)
*Mar      1 02:3:13.451: BR0:1      LCP: EndpointDisc 1 R1 
                                              (0x130B0156656E75732D484B)

!--- Incoming configuration acknowledgment

*Mar 1 02:36:13.511:      BR0:1 LCP: I CONFACK [ACKsent] id 2 len 32
*Mar      1 02:36:13.511: BR0:1      LCP: AuthProto CHAP (0x0305C22305)
*Mar      1 02:36:13.511: BR0:1      LCP: MagicNumber 0x0070D085 (0x05060070D085)
*Mar      1 02:36:13.511: BR0:1      LCP: MRRU 1524 (0x110405F4)
*Mar      1 02:36:13.511: BR0:1      LCP: EndpointDisc 1 R3 
                                          (0x130D014A7570697465722D484B)

!--- Link Control Protocol is open 

*Mar      1 02:3:13.511:      BR0:1 LCP: State is Open
01:49:36: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load]
*Mar      1 02:3:13.511: BR0:1      CHAP: O CHALLENGE id 2 len 31 from "R3"
*Mar      1 02:3:13.515: BR0:1      CHAP: I CHALLENGE id 22 len 29 from "R1"
*Mar      1 02:3:13.515: BR0:1      CHAP: Waiting for peer to authenticate first
*Mar      1 02:3:13.571: BR0:1      CHAP: I RESPONSE id 2 len 29 from "R1"
*Mar      1 02:3:13.575:      BR0:1 CHAP: O SUCCESS id 2 len 4
*Mar 1 02:36:13.575:BR0:1 CHAP: Processing saved Challenge, id 22
*Mar 1 02:36:13.575:%DIALER-6-BIND: Interface BR0:1 bound to profile Di0
*Mar 1 02:36:13.575:BR0:1 CHAP: O RESPONSE id 22 len 31 from "R3"
*Mar 1 02:36:13.575:      BR0:1 CHAP: I SUCCESS id 22 len 4

!--- PPP CHAP Authentication succeeded 

*Mar 1 02:36:13.607:BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 0 load]
*Mar 1 02:36:13.611:Di0 PPP: Phase is UP [0 sess, 0 load]

!--- PPP NCP begins

*Mar      1 02:36:13.611:Di0 IPCP: O CONFREQ [Closed] id 2 len      10
*Mar      1 02:36:13.611:Di0 IPCP: Address 172.22.85.1 (0x0306AC165501)
*Mar      1 02:36:13.611:Di0 CDPCP: O CONFREQ [Closed] id 2 len 4
*Mar      1 02:36:13.626:      Di0 MLP: Added first link BR0:1 to bundle R1
*Mar      1 02:36:13.626:      Di0 PPP: Treating connection as a callout
*Mar      1 02:36:13.626:      BR0:1 IPCP: MLP bundle interface is built, process 
packets now
*Mar      1 02:36:13.626:      BR0:1 IPCP: Redirect packet to Di0
*Mar      1 02:36:13.627:      Di0 IPCP: I CONFREQ [REQsent] id 2 len 10
*Mar      1 02:36:13.627:      Di0 IPCP: Address 172.22.85.2 (0x0306AC165502)
*Mar      1 02:36:13.631:      Di0 IPCP: O CONFACK [REQsent] id 2 len 10
*Mar      1 02:36:13.631:      Di0 IPCP: Address 172.22.85.2 (0x0306AC165502)
*Mar      1 02:36:13.634:      BR0:1 CDPCP: MLP bundle interface is built, process 
packets now
*Mar      1 02:36:13.634:      BR0:1 CDPCP: Redirect packet to Di0
*Mar      1 02:36:13.635:      Di0 CDPCP: I CONFREQ [REQsent] id 2 len 4
*Mar      1 02:36:13.635:      Di0 CDPCP: O CONFACK [REQsent] id 2 len 4
*Mar      1 02:36:13.639:      Di0 IPCP: I CONFACK [ACKsent] id 2 len 10
*Mar      1 02:36:13.639:      Di0 IPCP: Address 172.22.85.1 (0x0306AC165501)
*Mar      1 02:36:13.639:      Di0 IPCP: State is Open
*Mar      1 02:36:13.639:      Di0 CDPCP: I CONFACK [ACKsent] id 2 len 4
*Mar      1 02:36:13.639:      Di0 CDPCP: State is Open
*Mar      1 02:36:13.643:      Di0 IPCP: Install route to 172.22.85.2
*Mar      1 02:36:14.607:      %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
 changed state to up
*Mar      1 02:36:19.019:      %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 
 6661000 R1

当呼叫仍处于活动状态时:

R3#show dialer
BRI0 - dialer type = ISDN 
Dial String Successes      Failures Last DNIS Last status
     0 incoming call(s) have been screened.
     0 incoming call(s) rejected for callback.
BRI0:1 - dialer type = ISDN
     Idle timer (120 secs), Fast idle timer (20 secs)
     Wait for carrier (30 secs), Re-enable (15 secs)
     Dialer state is data link layer up
     Interface bound to profile Di0
     Current call connected 00:00:47
     Connected to 6661000 (R1)

!--- Call is connected to interface BRI 1/0: first B channel

BRI0:2 - dialer type      = ISDN
     Idle timer (120 secs), Fast idle timer (20 secs)
     Wait for carrier (30 secs), Re-enable (15 secs)
     Dialer state is idle
Di0 - dialer type      = DIALER PROFILE
     Load threshold for dialing additional calls is 128
     Idle timer (120 secs), Fast idle timer (20 secs)
     Wait for carrier (30 secs), Re-enable (15 secs)
     Dialer state is data link layer up
     Number of active calls = 1 (R1)

!--- Interface Dialer0 is active and connected to R1.


Dial String      Successes     Failures     Last DNIS     Last status
6661000                 0             0      never                 - Default
Di1 - dialer type      = DIALER PROFILE
     Idle timer (120 secs), Fast idle timer (20 secs)
     Wait for carrier (30 secs), Re-enable (15 secs)
     Dialer state is idle
     Number of active calls = 0

Dial String      Successes     Failures     Last DNIS     Last status
6662000                 0             0      never                 - Default

此配置演示如何针对每个呼叫将称为 Dialer Profile 的逻辑实体动态绑定到物理接口。使用拨号配置文件,网络能够更灵活连接到远程位置。此外,您还可以使用 Dialer Profile 更好地利用可用资源。因此,使用 Dialer Profile 能够克服传统 DDR 的很多缺点。


相关信息


Document ID: 9568