局域网交换 : EtherChannel

配置在2900XL/3500XL/2950运行Cisco IOS软件的系列交换机和Catalyst交换机之间的第二层以太网信道和中继

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 10 月 20 日) | 反馈


目录


简介

本文在IEEE 802.1Q/Inter交换机链路(ISL)中继提供配置示例和在Cisco Catalyst 2900XL/3500XL之间的Layer2 (L2) EtherChannel或Catalyst 2950系列交换机和运行Cisco IOSï ¿  ½软件的Catalyst 6500/6000交换机。您也可以使用运行 Cisco IOS 软件的 4500/4000 交换机来取代本示例中的 Catalyst 6500/6000。本文讨论了在交换机之间配置中继和信道时应考虑的最重要的要素。本文还提供了一些配置示例。

在本文中,每个交换机有四个快速以太网端口已中继和捆绑到 Fast EtherChannel (FEC)。中继协议用于 3500 XL ISL,802.1Q 用于 2950 示例。

注意: Catalyst 2950 不支持 ISL 中继。请改用 802.1Q 中继。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

为了创建本文中的示例,这些交换机在实验室环境中以原始配置使用:

  • 运行 Cisco IOS 软件版本 12.0(5)WC2 的 Catalyst 3548 XL 交换机

  • 运行 Cisco IOS 软件版本 12.1(6)EA2c 的 Catalyst 2950-24 交换机

  • 运行 Cisco IOS 软件版本 12.1(11b)E、带有 Supervisor 引擎 II 的 Catalyst 6509 交换机

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

DTP

设备之间的中继可以静态方式配置,或使用动态中继协议 (DTP) 配置。DTP 允许连接的两个设备在实际组成中继连接之前协商中继设置。可配置的 Cisco IOS 软件交换机端口(中继)模式包括:动态(端口协商接入或中继模式)、中继(无条件地将端口设置为中继)和接入(非中继接入端口)。中继-中继是静态(非 DTP 协商)中继两端最常使用的模式组合设置。对于动态(DTP 协商)中继,常用设置设置是动态-动态。其他组合也可能会生成有效结果,但不在本文的讨论范围内。支持 Port Aggregation Protocol (PAgP) 的交换机和非 PagP 设备之间的中继连接要求打开中继模式。

注意: 大多数 Cisco 路由器和一些 Catalyst 交换机都不支持 DTP,并且需要静态中继配置。例如,Catalyst XL 系列、Catalyst 2948G-L3、Catalyst 4908G-L3、Catalyst 8500 系列、2/3/4/7xxx 系列 Cisco 路由器等不支持 DTP,并且需要静态中继配置。

802.1q 本地 VLAN 考虑事项

802.1Q 中继在通过中继发送的帧中插入一个 4 字节 802.1Q 标记字段,这些帧包含 VLAN 信息。在通过中继传输的每个帧中插入 802.1Q 标记,但在本地 VLAN 上传输的帧除外,这些帧在不进行标记的情况下发送。在大多数情况下,中继两端的本地 VLAN 必须匹配,除非有特定的异常配置要求,这些配置要求不在本文讨论范围之内。如果本地 VLAN 不匹配,交换机会记录 Cisco 发现协议 (CDP) 消息,声明本地 VLAN 不匹配。虽然这不是灾难性的,但此设置实际会导致将两个不同的本地 VLAN 合并为一个更大的 L2 广播域 (VLAN)。这两个 VLAN 尝试计算此类桥接本地 VLAN 的通用生成树协议 (STP) 拓扑,并面临着最后超出支持的最大 STP 直径的风险。

注意: 存在邻居或第三方设备要求标记所有 VLAN 的特殊情况。如果发生此种情况,您可以采用创建虚拟 VLAN 并将其设置为本地 VLAN 的解决方案。这将标记所有其他所需 VLAN,并且它们将通过中继将数据流传递到邻居或第三方设备。在 Cisco IOS 软件版本 12.1.11bEX、12.1.13E 及更高版本中,运行 Cisco IOS 软件的 Catalyst 6500 支持将标记所有 VLAN 数据流(包括本地 VLAN) 的 802.1Q 中继选项。在全局配置模式下执行 vlan dot1q tag native 命令。在运行 Cisco IOS 软件的 Catalyst 4500/4000 上,Cisco IOS 软件版本 12.2(18)EW 中首先引入了 vlan dot1q tag native 命令。

Pagp

通过使用 PAgP,也可以静态或动态配置交换机之间的 Gigabit EtherChannel (GEC) 和 FEC。PAgP 允许连接的两个设备在实际组成信道之前协商设置。PAgP 信道模式包括:desirable (端口主动发起信道协商)、auto(默认值,端口不会发起协商,而会响应由其他端开始的协商尝试)和 on(无条件地设置信道端口,并且不会交换 PAgP 帧)。支持 PAgP 的交换机和非 PAgP 设备之间的连接需要 on 模式才能组成信道。

on-on 是静态(非 PAgP 协商)信道两端最常使用的模式组合。对于动态(PAgP 协商)信道,常用设置是 desirable-desirable 或 desirable-auto。为 desirable 模式配置的连接端口在开始建立信道之前执行信道协商和验证,并在信道运行期间持续验证信道。由于 PAgP 提供了额外的保护,因此,如果连接的两个交换机都支持 PAgP,则通常建议采用此设置。

注意: PAgP 具有某些专用的配置限制。协商信道的端口必须设置相同的速度、双工、中继封装和 VLAN。此外,还可以在特定平台上配置多个链路间的信道负载均衡算法。

注意: EtherChannel 在启用之后即视为唯一的 STP 端口。因此,为了避免在设置未经协商的信道时出现 STP 不一致,请按如下说明继续操作:

  1. 关闭信道的所有端口以便在两端配置。

  2. 在两端执行配置。

  3. 重新启用所有端口。

尝试在启用端口时配置此类信道可能会导致临时的 STP 不一致和/或循环。仅当未使用 PAgP 时,此步骤才适用。

Catalyst 2900XL/3500XL

Catalyst 2900 XL/ 3500 XL 系列交换机不支持 DTP 和 PAgP,因此需要静态中继和信道设置。有关详细信息,请参阅上面的注释。Catalyst 2900 XL/3500 XL 系列交换机当前支持 ISL 和 802.1Q 中继封装。有关详细信息,请参阅以下文档:

Cisco IOS 软件版本 11.2(8)SA4 及更高版本支持 ISL,Cisco IOS 软件版本 11.2(8)SA5 及更高版本支持 802.1Q。

通过运行 Cisco IOS 软件版本 11.2(8)SA1 或 11.2(8)SA2 的 Catalyst 2900 XL,您可以在每个交换机中使用四个 EtherChannel(端口组),并且每个组的端口数目不受限制。信道中链路间的负载均衡始终基于目标地址。Switched Port Analyzer (SPAN) 和端口安全功能不受支持。

在运行 Cisco IOS 软件版本 11.2(8)SA3 或更高版本的 Catalyst 2900 XL、运行 Cisco IOS 软件版本 11.2(8)SA6 或更高版本的 Catalyst 3500 XL 以及 Catalyst 2950 上,信道中链路间的负载平衡可配置为基于源或目标 MAC 地址。基于源是默认值。基于源的转发允许一个 FEC(端口组)最多有 8 个端口。基于目标的转发允许每个端口组的端口数目不受限制。每个交换机最多可以配置 12 个端口组,并且可以混合使用基于源/基于目标的组。SPAN 和端口安全不受支持。

Catalyst 2950

Catalyst 2950 交换机仅支持 802.1Q 中继,并且不支持 ISL 中继。运行 Cisco IOS 软件版本 12.1 的 Catalyst 2950 交换机支持 DTP 与 PAgP 动态中继和信道协商,运行 Cisco IOS 软件版本 12.0 的 Catalyst 2950 交换机仅支持静态模式。EtherChannel 负载均衡可以使用源 MAC 或目标 MAC 地址转发。通过执行 port-channel load-balance 全局配置命令,您可以配置负载均衡方法。这些交换机在每个信道中最多支持 8 个交换机端口。

运行 Cisco IOS 软件的 Catalyst 6500

运行 Cisco IOS 软件的 Catalyst 6500 交换机支持 L2(交换机端口)和第 3 层 (L3)(路由端口)EtherChannel 配置。Catalyst 6500/6000 系列交换机最多支持 64 个 EtherChannel(对于 Cisco IOS 软件版本 12.1(2)E 及早期版本,则为 256 个 EtherChannel)。您可以在 Catalyst 6000 系列交换机中的任何模块上组成一个最多具有八个兼容的已配置 LAN 端口的 EtherChannel,但安装了 Digital Feature Card (DFC) 的模块(例如,WS-X6816 等)除外,这些模块目前允许仅使用同一 DFC 模块上的端口的 L2 信道。但是,可以在安装了 DFC 的不同模块之间配置 L3 信道。此限制已在 Catalyst 6500/6000 Cisco IOS 软件版本 12.1(11b)EX 及更高版本中删除。本文配置 L2 EtherChannel。

通过运行 Cisco IOS 软件的 Catalyst 6500/6000,您可以通过执行 port-channel load-balance 全局配置命令来配置 EtherChannel 负载均衡,以便在任何源、目标和源-目标组合中使用 MAC 地址、IP 地址或第 4 层 (L4) 端口信息。默认值是在源和目标 IP 地址之间使用散列函数。

Catalyst 6500/6000 交换机支持 ISL 和 802.1Q 中继封装以及 DTP。通过执行 show interface interface_id capabilities 命令可以获取有关端口功能的详细信息。

运行 Cisco IOS 软件的 Catalyst 4000

运行 Cisco IOS 软件(以及 Supervisor 引擎 III 和 IV)的 Catalyst 4000 交换机支持 L2(交换机端口)和 L3(路由端口)EtherChannel 配置。Catalyst 4000 系列交换机最多支持 64 个 EtherChannel。您可以在 Catalyst 4000 系列交换机中的任一模块或多个模块上组成一个最多具有八个兼容的已配置以太网接口的 EtherChannel。每个 EtherChannel 中的所有接口的速度都必须相同,并且必须全部配置为 L2 或 L3 接口。

通过运行 Cisco IOS 软件的 Catalyst 4000,您可以通过执行 port-channel load-balance 全局配置命令来配置 EtherChannel 负载均衡,以便在任何源、目标和源-目标组合中使用 MAC 地址、IP 地址或 L4 端口信息。默认值是在源和目标 IP 地址之间使用散列函数。

运行 Cisco IOS 软件的 Catalyst 4000 支持 ISL 和 802.1Q 中继封装以及 DTP。在某些模块上,无法使用 ISL。有关此类模块的完整列表,请参阅配置第 2 层以太网接口了解 VLAN 中继部分。在将来的软件版本中,通过执行 show interface capabilities 命令可以获取有关端口功能的详细信息。目前,此命令不可用。

配置1 :Catalyst 3500 XL 和运行 Cisco IOS 软件的 Catalyst 6500 之间的 ISL 中继和 EtherChannel

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

此配置使用以下网络设置:

/image/gif/paws/22422/144-a.gif

Catalyst 3524XL

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel 
!--- and then enable them back when the configuration is complete on both switches.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!

!--- Output suppressed.


!
interface FastEthernet0/17
port group 1

!--- Assigned port to port channel 1.


switchport trunk encapsulation isl

!--- Configured the port to use the trunking encapsulation ISL.


switchport mode trunk

!--- Configured the port to be in trunking mode.


!
interface FastEthernet0/18

!--- Repeated the trunk and channel configuration.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!

!--- Output suppressed.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500(Cisco IOS 软件)

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel, 
!--- and then enable them back when the configuration is complete on both switches.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-cpu  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q

!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


no ip address 
channel-group 1 mode on

!--- Configured the port to participate in port channel 1 with channel mode on.


! 
Interface FastEthernet4/3

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/4

!--- Repeated the trunk and channel configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/5

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500# 

配置2 :在 Catalyst 2950 和运行 Cisco IOS 软件的 Catalyst 6500 之间使用 DTP 和 PAgP 的 802.1Q 中继和 EtherChannel

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

此配置使用以下网络设置:

/image/gif/paws/22422/144-b.gif

Catalyst 2950

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1 
switchport mode trunk
!
interface FastEthernet0/1
!         
interface FastEthernet0/2 
switchport mode trunk

!--- Configured port to be in trunking mode.


channel-group 1 mode desirable

!--- Configured port to participate in PAgP-negotiated port channel 1.


!
interface FastEthernet0/3

!--- Repeated trunk and channel configuration.
 

switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/4

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/5

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/6
!

!--- Output suppressed.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1 
ip address 10.10.10.1 255.255.255.0 
no ip route-cache
!
ip http server
!
line con 0 
transport input none
line vty 5 15
!
end 
Cat2950#

Catalyst 6500(Cisco IOS 软件)

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-CPU  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q


!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


No ip address 
channel-group 1 mode desirable

!--- Configured port to participate in port channel 1 with channel mode desirable.


! 
Interface FastEthernet4/3

!--- Repeated trunk and channel configuration. 


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/4

!--- Repeated trunk and channel configuration.
  

switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/5

!--- Repeated trunk and channel configuration. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500# 

验证:ISL 中继

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。 使用 OIT 可查看对 show 命令输出的分析。

Catalyst 3500XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

注意: 如果您具有包含 8 个端口的 EtherChannel,当运行 Cisco IOS 软件版本 12.0(5)WC5 之前的 Cisco IOS 软件版本时,执行 show etherchannel summary 命令会使交换机崩溃。

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500(Cisco IOS 软件)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)   

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

验证:802.1q 中继

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。 使用 OIT 可查看对 show 命令输出的分析。

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL  
0     00     Fa0/3    desirable-SL  
0     00     Fa0/4    desirable-SL  
0     00     Fa0/5    desirable-SL  

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance 
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Catalyst 6500 Cisco IOS 软件

Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL  
3     22     Fa4/3    desirable-SL  
0     44     Fa4/4    desirable-SL  
2     88     Fa4/5    desirable-SL  

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

故障排除

使用本部分可排除配置故障。

未在 802.1Q 中继中传输数据流

下列原因之一可导致此问题:

  • 在两台交换机之间连接的端口上的本地 VLAN 配置不匹配。

    验证两台交换机上的本地 VLAN 配置。在 CatOS 交换机上执行 show trunk 命令,以便查看本地 VLAN 设置。在 XL 交换机上执行 show interface interface_id switchport 命令,以便查看本地 VLAN 设置。如果两台交换机之间的本地 VLAN 不匹配,请将两台交换机配置为使用相同的本地 VLAN。执行 switchport trunk native vlan 接口配置命令,以便更改 XL 交换机上的本地 VLAN。执行 set vlan 命令,以便更改 CatOS 交换机上的本地 VLAN。

  • XL 交换机中不支持 DTP 帧。

    CatOS 交换机通过中继链路发送 DTP 帧,但是 XL 交换机不支持 DTP 帧。XL 交换机中不支持 DTP。为了避免此问题,请将 CatOS 交换机端口状态设置为不协商。执行 set trunk mod/port nonegotiate dot1q 命令,以便将中继模式设置为不针对 dot1q 中继模式进行协商。

  • XL 交换机上存在封装不匹配。

    在 XL 交换机上验证中继封装是否设置为 dot1q。执行 show interface interface_id switchport 命令,以便查看当前设置。执行 switchport trunk encapsulation dot1q 接口配置命令,以便将封装更改为 dot1q。

  • CatOS 的早期版本不支持 dot1q 中继。

    交换机中使用的 CatOS 早期版本不支持 dot1q 中继。将交换机的 CatOS 升级到支持 dot1q 中继和 ISL 中继的较高版本。


相关信息


Document ID: 22422