IP : 路由信息协议 (RIP)

RIP 触发扩展示例配置

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档显示了使用 ip rip triggered interface configuration 命令的配置示例。

Routing Information Protocol (RIP) 的触发扩展会增加点对点串行链路的效率。运行Cisco IOS�软件版本12.0(1)T和以上的所有平台支持此功能。触发扩展可避免使用 RIP 连接到广域网时遇到的两个常见问题:

  • RIP 进行的定期广播可以防止广域网回路关闭。

  • 即使在固定的点对点链路上,定期 RIP 传输的开销也可以严重中断正常的数据传输。

要启用此功能,请在链路的两端使用 ip rip triggered interface configuration 命令。请参阅下面的配置示例。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/13720/51a.gif

配置

本文档使用如下所示的配置。

S3-3640
interface Serial1/0 
  ip address 172.16.1.1 255.255.255.0
  ip rip triggered
 ! 
 router rip
  network 172.16.0.0 

S3-3620
interface Loopback8
 ip address 172.19.1.1 255.255.255.0
!
interface Ethernet0/3
 ip address 172.18.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.0
 ip rip triggered
!
router rip
 network 172.16.0.0
 network 172.18.0.0
 network 172.19.0.0

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

使用 ip rip triggered 配置的接口所获知的路由在 RIP 数据库和路由表中会显示为永久性条目。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show ip route - 显示路由表的当前状态。

  • show ip rip database - 如果根据汇总地址汇总相关路由,会显示在 RIP 路由数据库条目中的汇总地址条目。

S3-3640#show ip route
C       172.16.1.0/24 is directly connected, Serial1/0
R    172.19.0.0/16 [120/1] via 172.16.1.2, Serial1/0
R    172.18.0.0/16 [120/1] via 172.16.1.2, Serial1/0

S3-3640#show ip rip database
172.18.0.0/16    auto-summary
172.18.0.0/16
    [1] via 172.16.1.2, 00:02:44 (permanent), Serial1/0
	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0
172.19.0.0/16    auto-summary
172.19.0.0/16
    [1] via 172.16.1.2, 00:02:45 (permanent),Serial1/0
  	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug ip rip events - 显示有关 RIP 路由事务的信息。

S3-3640#debug ip rip events
RIP: received v1 triggered request from 172.16.1.2 on Serial1/0
RIP: start retransmit timer of 172.16.1.2
RIP: received v1 triggered ack from 172.16.1.2 on Serial1/0
RIP: Stopped retrans timer for 172.16.1.2
RIP: sending v1 ack to 172.16.1.2 via Serial1/0 (172.16.1.1),

结论

当您启用 RIP 的触发扩展时,只有发生下列事件之一,才会在广域网上传输路由更新:

  • 路由器收到路由更新的特定请求,然后就会发送完整的数据库。

  • 来自另一个接口的信息会修改路由数据库,因此只会发送最新的更改。

  • 接口会接通或断开,导致发送不完整的数据库。

  • 路由器第一次打开电源可确保至少发送一个更新,因此可发送完整的数据库。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 13720