拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

配置调制解调器和 Cisco 3640 BRI 的连通性

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

此配置支持通过使用V.90协议模拟拨号调制解调器的远程用户(例如,家庭用户或出差的员工)与网络连接。使用PC和模拟调制解调器,用户可以通过拨号PPP连接到Cisco 3640路由器的基本速率接口(BRI)上。BRI 可提供高速调制解调器连接,而费用要低于 Primary Rate 接口 (PRI)。

注意: 由于BRI的信道局限,只有二个异步用户可以同时拨入一个BRI。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

此配置使用下面软件和硬件版本开发并且被测试。

  • Cisco 3640

  • Cisco BRI 网络模块(使用以下模块之一):

    • NM-4B-S/T -四端口ISDN BRI网络模块,最低版本800-01236-03

    • NM-4B-U -四端口ISDN BRI用集成NT-1网络模块,最低版本800-01238-06

    • NM-8B-S/T -八端口ISDN BRI网络模块,最低版本800-01237-03

    • NM-8B-U -八端口ISDN BRI用集成NT-1网络模块,最低版本800-01239-06

  • 数字调制解调器网络模块(使用以下模块之一:NM-6DM、NM-12DM、NM-18DM、NM-24DM 或 NM-30DM)

  • LAN 接口卡

  • Cisco IOS�软件版本12.0(2)XC

如需了解硬件和软件最低要求(例如,零件号和修订版号)的更多信息,请参阅Cisco 3640路由器说明文档的ISDN BRI上的调制解调器。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

此配置使用一个本地用户列表来实现 Cisco 路由器上的访问安全性。

下面是show version命令输出的相关部分,带有用于实现此配置的Cisco IOS软件版本和调制解调器固件版本:

Cisco Internetwork Operating System Software IOS (tm) 3600 Software (C3640-I-M), Version 12.0(5)XK1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 
   System image file is "flash:c3640-i-mz.120-5.XK1"   
   MICA-6DM Firmware: CP ver 2310 - 6/3/1998, SP ver 2310 - 6/3/1998.

请使用 show diag EXEC 命令来确定安装在路由器中的硬件类型。show diag 命令可显示路由器中各硬件模块的版本号和部件号。下面是 show diag EXEC 命令的示例输出的相关部分:

maui-nas-04#show diag

Slot 1:
BRI (U) port adapter, 4 ports
Serial number 17156199 Part number 800-01238-06

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档中使用的命令的其他相关信息,请使用 IOS 命令查找工具

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/10307/bri_3640.gif

配置

本文档使用如下所示的配置。

Cisco 3640
maui-nas-04#show run
Building configuration...
Current configuration:
!
! Last configuration change at 10:11:43 CST Thu Apr 13 2000 
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname maui-nas-04
!
aaa new-model
AAA authentication login default group tacacs+ local
AAA authentication ppp default if-needed group tacacs+ local
!
enable secret <deleted>
!
username admin privilege 15 password 7 0213100D52050024
!
modem country mica 
<country>


!-- The country information is mandatory for the configuration to work

!
clock timezone CST -6
clock summer-time CST recurring
!
ip subnet-zero
ip domain-name maui-onions.com
ip name-server 172.22.53.210
!
isdn switch-type basic-ni

! --- Global ISDN switchtype

!
!
process-max-time 200
!
interface Loopback0
 ip address 172.22.87.4 255.255.255.0
 no ip directed-broadcast
!
interface Loopback1
 no ip address
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 172.22.80.4 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI1/0
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/1
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/2
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/3

! --- Active BRI

 no ip address
 no ip directed-broadcast
 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111 
 isdn spid2 51255522220101 5552222 
 isdn incoming-voice modem

! --- Direct incoming voice calls to the modems
! --- Add the above command to all BRIs that will accept analog calls

!
interface Group-Async1
 ip unnumbered Loopback0

! --- Loopback0 is assigned above
 
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 peer default ip address pool default

! --- Use local pool defined below

 ppp authentication pap

! --- Use PAP authentication

 group-range 65 66

! --- Line range is configured below

!
router eigrp 69
network 172.22.0.0
!
ip local pool default 172.22.84.2 172.22.84.253

! --- IP address pool assignment

ip default-gateway 172.22.80.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.80.1
ip http server
ip http authentication local
!
tacacs-server host 172.22.53.201
tacacs-server key <deleted>
!
line con 0
 transport input all
 line 65 66

! --- This must match the group-range in the Group-Async Interface
! --- Use the show line command to determine which lines are to be configured for dialin

 autoselect during-login
 autoselect ppp
 modem Dialin
line 67 70
line aux 0
line vty 0 4
password 
!
ntp clock-period 17179861
ntp server 172.22.255.1 prefer

end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

输出解释器工具支持某些 show 命令(只限于注册用户),通过它可以查看 show 命令输出的分析。

  • show isdn stat - 状态应为:

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    如果第 1 层未处于活动状态,则表明接线适配器或端口可能已损坏或未插入。如果第 2 层处于 TEI_Assign 状态,则表明路由器没有与交换机通信。

  • show line - 用于显示线路参数。请使用 show line 命令来确定需要针对拨入而配置的线路。

  • show users - 用于显示线路编号、连接名称、空闲时间和终端位置。

  • show diag - 用于确定安装在路由器中的硬件的类型。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug modem - 用于观察接入服务器上的调制解调器线路活动性。

  • debug modem csm - 用于调试用来连接调制解调器上的呼叫的呼叫状态机。

  • debug isdn q931- 当用户拨入来查看ISDN呼叫发生时,对ISDN的连接进行检查(例如连接是否丢失)。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 10307