拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

在澳大利亚配置 ISDN BRI 与 PRI

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文档介绍特定于澳大利亚用户的 ISDN 问题。其中包括示例配置以及关于可从 Telco 获得的各种 BRI 和 PRI 服务的信息。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件或硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

相关产品

此配置可在带有 BRI 或 PRI 接口的任何路由器上使用。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

BRI 交换机类型信息

澳大利亚的 BRI 不需要服务配置文件标识符 (SPID)。

有两个 ISDN 交换机类型可供使用:

  • basic-net3 - 当前最常用。

  • basic-ts013 - 用于旧的 ISDN 交换机,如 MicroLink。

PRI 交换机类型和服务信息

在澳大利亚,有两个交换机类型可供使用:

  • primary-net5 - 目前最常用(“Onramp”)。

  • primary-ts015 - 用于旧的 ISDN 交换机,如 MacroLink。

对于 PRI,还提供了多种类型的服务:

  • 10 B信道(10 � 64 Kbps) —一般叫作与主NET5的上线管道10。

    !
    controller E1 0
    pri-group timeslots 1-10,16
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !
  • 20 B信道(20 � 64 Kbps) —一般叫作与主NET5的上线管道20。

    !
    controller E1 0
    pri-group timeslots 1-21
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !
  • 30 B信道(30 � 64 Kbps) —一般叫作与主NET5的上线管道30。

    !
    controller E1 0
    pri-group timeslots 1-31
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !

网络图

本文档使用以下网络设置:

/image/gif/paws/10227/isdn_australia.gif

配置

本文档介绍澳大利亚的 ISDN 配置。第一种配置用于 BRI,而后面两种配置用于 PRI。

具有 basic-net3 交换机类型的 BRI

!--- Configuration uses BRI0 linked to a dialer profile 1
!--- via dialer pool to dial out.

!
!
ip routing
!
isdn switch-type basic-net3 
! 
interface loopback0
ip address 10.10.10.1 255.255.255.0
!
interface BRI0 
 ip unnumbered loopback0
 encapsulation ppp 
 dialer pool-member 1    
 isdn switch-type basic-net3 
 ppp authentication chap pap
! 
interface Dialer1 
 ip address 192.168.12.1 255.255.255.0 
 encapsulation ppp 
 dialer remote-name AROP
 dialer string 0291191111 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap pap callin    
!
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer1    
! 
dialer-list 1 protocol ip permit 
!

具有 primary-net5 交换机类型的 PRI

!--- Configuration uses PRI 30 x B-channels linked to a
!--- dialer profile 1 via dialer pool to dial out.

!
ip routing
! 
isdn switch-type primary-net5
! 
interface loopback0
 ip address 10.10.10.1 255.255.255.0
!
controller E1 0
 pri-group timeslots 1-31
!
interface Serial0:15
 ip unnumbered loopback0
 encapsulation ppp 
 dialer pool-member 1    
 isdn switch-type primary-net5
 ppp authentication chap pap 
! 
interface Dialer1 
 ip address 192.168.12.1 255.255.255.0 
 encapsulation ppp 
 dialer remote-name AROP
 dialer string 0291191111 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap pap callin    
!
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer1    
! 
dialer-list 1 protocol ip permit 
!

用于向 Cisco Mica 调制解调器进行模拟拨号的 PRI 20 B 信道

!--- Configuration uses PRI 20 x B-channels 
!--- to terminate up to 20 modem calls
!--- even though we have 30 modems. We are restricted 
!--- by the amount of B-channels.

!
!
ip routing
! 
isdn switch-type primary-net5 
! 
interface loopback0 
ip address 10.10.10.1 255.255.255.0 
! 
controller E1 0  
pri-group timeslots 1-21
!    
interface Serial0:15 
ip unnumbered loopback0 
encapsulation ppp 
isdn switch-type primary-net5 
isdn incoming voice-modem
ppp authentication chap pap 
! 
interface Group-Async 1
ip unnumbered loopback0
encapsulation ppp 
ppp authentication chap pap
async mode dedicated
peer default ip pool swim
group-range 1 30
!
ip local pool swim 192.168.1.1 192.168.1.20
!
line 1 30
modem inout
transport input all

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • show isdn status - 确保路由器与 ISDN 交换机正常通信。在输出中,验证第1层状态是否为活跃状态,是否第2层状态=MULTIPLE_FRAME_ESTABLISHED出现。此指令也显示活动的呼叫的数量。有关详细信息,请参阅使用 show isdn status 用于 BRI 故障排除

  • show dialer [interface type number] - 显示为按需拨号路由 (DDR) 配置的接口的一般诊断信息。如果拨号程序正常启动,则应出现 Dialer state is data link layer up 消息。如果physical layer up出现,则线路通信协议表现出来,但是网络控制协议(NCP)没有。启动拨号的数据包的源地址和目标地址显示在 dial reason line 中。此show指令也显示计时器的配置和连接超时前的时间。

  • show caller user username detail -显示特定用户参数,如分配的IP地址、PPP和PPP捆绑参数等。如果您的Cisco IOS�软件的版本不支持此命令,请使用show user命令

  • show dialer map - 显示已配置的动态和静态 Dialer Maps。此指令可以被用于发现动态拨号映射是否被创建了。如果没有 Dialer Map,则无法路由数据包。

故障排除

使用本部分可排除配置故障。

故障排除资源

按照需要使用下列故障排除资源:

故障排除命令

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug dialer -关于在拨号接口收到数据包的显示DDR调试信息。此信息有助于保证具有可以使用拨号程序接口的触发数据流。

  • debug isdn q931 -显示呼叫建立和拆卸ISDN网络连接(第3层)。

  • debug modem - 显示接入服务器上的调制解调器线路活动情况。该输出显示出调制解调器线路何时改变状态。

  • debug modem csm - EXEC 命令,用于诊断带有内部数字调制解调器的路由器上的呼叫交换模块 (CSM) 问题。使用该指令,您能跟踪呼入和呼出的呼叫交换排序的完成情况。

  • debug ppp negotiation - 在协商链路控制协议 (LCP) 和身份验证以及 NCP 时,显示有关 PPP 流量和交换的信息。成功的PPP协商将打开LCP状态,然后首先验证和终于协商NCP。多链路参数例如最大接收重建单元(MRRU)在LCP协商时设立。

  • debug ppp authentication - 显示 PPP 身份验证协议消息,包括质询握手身份验证协议 (CHAP) 数据包交换和口令身份验证协议 (PAP) 交换。

  • debug ppp error -显示与PPP连接协商和运行有关的协议错误和错误统计数据。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 10227